Guida utente Annulla

Unione dei dati mediante il pannello Variabili

  1. Guida utente di Illustrator
  2. Scoprire Illustrator
    1. Introduzione a Illustrator
      1. Novità di Illustrator
      2. Domande frequenti
      3. Requisiti di sistema per Illustrator
      4. Illustrator per Apple Silicon
    2. Area di lavoro
      1. Nozioni di base sull’area di lavoro
      2. Imparare più velocemente con il pannello Scopri di Illustrator
      3. Creare documenti
      4. Barra degli strumenti
      5. Scelte rapide da tastiera predefinite
      6. Personalizzare le scelte rapide da tastiera
      7. Introduzione alle tavole disegno
      8. Gestire le tavole disegno
      9. Personalizzazione dell’area di lavoro
      10. Pannello Proprietà
      11. Impostare le preferenze
      12. Area di lavoro Tocco
      13. Supporto di Microsoft Surface Dial in Illustrator
      14. Annullare le modifiche e gestire la cronologia di progettazione
      15. Ruota vista
      16. Righelli, griglie e guide
      17. Accesso facilitato in Illustrator
      18. Modalità protetta
      19. Visualizzare la grafica
      20. Usare la Touch Bar con Illustrator
      21. File e modelli
    3. Strumenti in Illustrator
      1. Panoramica sugli strumenti
      2. Selezionare gli strumenti
        1. Selezione
        2. Selezione diretta
        3. Selezione gruppo
        4. Bacchetta magica
        5. Lazo
        6. Tavola disegno
      3. Strumenti di navigazione
        1. Mano
        2. Ruota vista
        3. Zoom
      4. Strumenti Pittura
        1. Sfumatura
        2. Trama
        3. Crea forme
      5. Strumenti di testo
        1. Testo
        2. Testo su un tracciato
        3. Testo verticale
      6. Strumenti di disegno
        1. Penna
        2. Aggiungi punto di ancoraggio
        3. Elimina punto di ancoraggio
        4. Punto di ancoraggio
        5. Curvatura
        6. Segmento linea
        7. Rettangolo
        8. Rettangolo arrotondato
        9. Ellisse
        10. Poligono
        11. Stella
        12. Pennello
        13. Pennello tracciato chiuso
        14. Matita
        15. Shaper
        16. Sezione
      7. Strumenti di modifica
        1. Rotazione
        2. Riflettere
        3. Scala
        4. Distorsione curvilinea
        5. Larghezza
        6. Trasformazione libera
        7. Contagocce
        8. Fusione
        9. Gomma
        10. Forbici
        11. Dimension
    4. IA generativa (non disponibile nella Cina continentale)
      1. Generare una grafica vettoriale utilizzando un prompt di testo
      2. Ricolorare la grafica utilizzando un prompt di testo
    5. Azioni rapide
      1. Testo retrò
      2. Testo Luce al neon
      3. Testo vecchia scuola
      4. Ricolora
      5. Convertire schizzi in grafica vettoriale
  3. Illustrator sul Web (beta)
    1. Panoramica di Illustrator sul Web (beta)
    2. Domande frequenti di Illustrator sul Web (beta)
    3. Domande frequenti sulla risoluzione dei problemi
    4. Scelte rapide da tastiera per Illustrator sul Web (beta)
    5. Creare e combinare forme sul Web
    6. Aggiungere e modificare testo sul Web
    7. Applicare colori e sfumature sul Web
    8. Disegnare e modificare tracciati sul Web
    9. Utilizzo dei documenti cloud sul web
    10. Invitare i collaboratori per la modifica sul Web
  4. Illustrator per iPad
    1. Introduzione a Illustrator per iPad
      1. Panoramica di Illustrator per iPad
      2. Domande frequenti su Illustrator per iPad
      3. Requisiti di sistema | Illustrator per iPad
      4. Cosa è possibile fare con Illustrator per iPad
    2. Area di lavoro
      1. Area di lavoro di Illustrator per iPad
      2. Scelte rapide tocco e gesti
      3. Scelte rapide da tastiera per Illustrator per iPad
      4. Gestire le impostazioni dell'app
    3. Documenti
      1. Utilizzare i documenti in Illustrator per iPad
      2. Importazione di documenti Photoshop e Fresco
    4. Selezionare e disporre oggetti
      1. Creare oggetti ripetuti
      2. Fusione di oggetti
    5. Disegno
      1. Disegnare e modificare i tracciati
      2. Disegnare e modificare le forme
    6. Testo
      1. Utilizzo di testo e font
      2. Creare progetti di testo lungo un tracciato
      3. Aggiungere i propri font
    7. Utilizzo delle immagini
      1. Vettorizzazione di immagini raster
    8. Colore
      1. Applicare colori e sfumature
  5. Documenti cloud
    1. Nozioni di base
      1. Utilizzare i documenti cloud di Illustrator
      2. Condividere e collaborare sui documenti cloud di Illustrator
      3. Condividere i documenti per la revisione
      4. Aggiornare l'archiviazione cloud per Adobe Illustrator
      5. Documenti cloud di Illustrator | Domande frequenti
    2. Risoluzione dei problemi
      1. Risoluzione dei problemi di creazione o salvataggio dei documenti cloud di Illustrator
      2. Risoluzione dei problemi relativi ai documenti cloud di Illustrator
  6. Aggiungere e modificare contenuti
    1. Disegno e dimensionamento
      1. Nozioni di base sul disegno
      2. Modificare i tracciati
      3. Creare un disegno con perfezionamento pixel applicato
      4. Disegnare con lo strumento Penna, Curvatura o Matita
      5. Disegnare linee e forme semplici
      6. Disegnare griglie rettangolari e polari
      7. Disegnare e modificare riflessi
      8. Ricalco immagine
      9. Semplificare un tracciato
      10. Strumenti simboli e set di simboli
      11. Regolare i segmenti di tracciato
      12. Disegna un fiore in 5 semplici passaggi
      13. Creare e modificare una griglia prospettica
      14. Disegnare e modificare oggetti su una griglia prospettica
      15. Utilizzare gli oggetti come simboli per un uso ripetuto
      16. Disegnare tracciati allineati ai pixel per i flussi di lavoro Web
      17. Misurare e tracciare le dimensioni
    2. Oggetti e materiali 3D
      1. Informazioni sugli effetti 3D in Illustrator
      2. Creare grafica 3D
      3. Mappare l'immagine sugli oggetti 3D
      4. Creare testo 3D
      5. Creare oggetti 3D
    3. Colore
      1. Il colore
      2. Selezionare i colori
      3. Usare e creare i campioni
      4. Regolare i colori
      5. Utilizzare il pannello Temi Adobe Color
      6. Gruppi di colori (armonie)
      7. Pannello Temi colore
      8. Ricolorare il disegno
    4. Pittura
      1. Pittura
      2. Colorare con riempimenti e tracce
      3. Gruppi di pittura dinamica
      4. Sfumature
      5. Pennelli
      6. Metodi di trasparenza e fusione
      7. Applicare la traccia a un oggetto
      8. Creare e modificare i pattern
      9. Trame
      10. Pattern
    5. Selezionare e disporre oggetti
      1. Selezionare gli oggetti
      2. Livelli
      3. Raggruppare ed espandere gli oggetti
      4. Spostare, allineare e distribuire gli oggetti
      5. Sovrapporre gli oggetti    
      6. Bloccare, nascondere ed eliminare gli oggetti
      7. Copiare e duplicare gli oggetti
      8. Ruotare e riflettere gli oggetti
      9. Intrecciare gli oggetti
      10. Creare modelli artistici realistici
    6. Rimodellare oggetti
      1. Ritagliare le immagini
      2. Trasformare gli oggetti
      3. Combinare più oggetti
      4. Tagliare, dividere e rifilare gli oggetti
      5. Alterazione marionetta
      6. Ridimensionare, inclinare e distorcere gli oggetti
      7. Fusione di oggetti
      8. Rimodellare con gli involucri
      9. Rimodellare gli oggetti con gli effetti
      10. Creare nuove forme con gli strumenti Shaper e Crea forme
      11. Lavorare con gli angoli dinamici
      12. Flussi di lavoro migliorati per rimodellare gli oggetti con supporto touch
      13. Modificare le maschere di ritaglio
      14. Forme dinamiche
      15. Creare forme con lo strumento Crea forme
      16. Modifica globale
    7. Testo
      1. Aggiungere testo e utilizzare gli oggetti di testo
      2. Creare elenchi puntati e numerati
      3. Gestire l'area di testo
      4. Font e composizione tipografica
      5. Convertire il testo nelle immagini in testo modificabile
      6. Aggiungere formattazione di base al testo
      7. Aggiungere formattazione avanzata al testo
      8. Importare ed esportare il testo
      9. Formattare i paragrafi
      10. Caratteri speciali
      11. Creare testo su un tracciato
      12. Stili di carattere e di paragrafo
      13. Tabulazioni
      14. Trovare i font mancanti (flusso di lavoro Typekit)
      15. Testo in arabo e in ebraico
      16. Font | Domande frequenti e suggerimenti per la risoluzione dei problemi
      17. Creazione di un effetto di testo 3D
      18. Progettazioni di composizione tipografica creativa
      19. Ridimensionare e ruotare il testo
      20. Spaziatura tra righe e caratteri
      21. Sillabazione e interruzioni di riga
      22. Dizionari per il controllo ortografico e la sillabazione
      23. Formattare i caratteri asiatici
      24. Modulo di composizione per scritture asiatiche
      25. Creare progettazioni di testo con oggetti di fusione
      26. Creare un poster di testo utilizzando Ricalco immagine
    8. Creare effetti speciali
      1. Utilizzo degli effetti
      2. Stili di grafica
      3. Attributi di aspetto
      4. Creare schizzi e mosaici
      5. Ombre esterne, bagliori e bordi sfocati
      6. Riepilogo degli effetti
    9. Grafica per il Web
      1. Come ottenere risultati ottimali nella creazione di grafica per il Web
      2. Grafici
      3. SVG
      4. Sezioni e mappe immagini
  7. Importare, esportare e salvare
    1. Importazione
      1. Inserire più file
      2. Gestire file collegati e incorporati
      3. Informazioni sui collegamenti
      4. Scorporare le immagini
      5. Importare disegni di Photoshop
      6. Importare immagini bitmap
      7. Importare i file Adobe PDF
      8. Importare file EPS, DCS e AutoCAD
    2. Creative Cloud Libraries in Illustrator 
      1. Creative Cloud Libraries in Illustrator
    3. Salva
      1. Salvare un disegno
    4. Esporta
      1. Utilizzare la grafica di Illustrator in Photoshop
      2. Esportare un disegno
      3. Raccolta delle risorse ed esportazione in blocco
      4. Creare pacchetti di file
      5. Creare file Adobe PDF
      6. Estrarre il codice CSS | Illustrator CC
      7. Opzioni Adobe PDF
      8. Pannello Info documento
  8. Stampa
    1. Preparare la stampa
      1. Impostare i documenti per la stampa
      2. Modificare le dimensioni e l’orientamento della pagina
      3. Specificare gli indicatori di taglio per rifilare o allineare
      4. Introduzione al quadro di grandi dimensioni
    2. Stampa
      1. Sovrastampa
      2. Stampare con la gestione colore
      3. Stampa PostScript
      4. Predefiniti di stampa
      5. Segni di stampa e pagine al vivo
      6. Stampare e salvare un disegno con trasparenza
      7. Abbondanza
      8. Stampare le selezioni colore
      9. Stampare sfumature, trame e fusioni di colore
      10. Sovrastampa del bianco
  9. Automatizzare operazioni
    1. Unione dei dati mediante il pannello Variabili
    2. Automazione con script
    3. Automazione con le azioni
  10. Risoluzione dei problemi 
    1. Problemi noti
    2. Problemi di arresto anomalo
    3. Recuperare i file dopo l'arresto anomalo
    4. Problemi relativi ai file
    5. Formati di file supportati
    6. Problemi relativi ai driver del dispositivo GPU
    7. Problemi dei dispositivi Wacom
    8. Problemi relativi ai file DLL
    9. Problemi relativi alla memoria
    10. Problema del file delle preferenze
    11. Problemi di font
    12. Problemi con la stampante
    13. Condividere il rapporto sugli arresti anomali con Adobe
    14. Miglioramento delle prestazioni di Illustrator

Unite un documento Illustrator con un file di origine dati (file CSV o XML) con il pannello Variabili per creare più varianti della grafica. Potete modificare i nomi dei partecipanti sui badge per eventi oppure cambiare le immagini sui banner Web e sulle cartoline senza dover ripristinare il vostro disegno. Create un progetto e poi realizzate rapidamente le variazioni importando i nomi o le immagini da una sorgente dati.

Create variazioni personalizzate del modello di progettazione per progetti diversi, quali poster da stampare, banner Web e badge per eventi, utilizzando il pannello Variabili.

Prima di procedere

Tutto ciò di cui avete bisogno per unire i dati è una sorgente dati e un documento di destinazione. 

  • Il file sorgente dati contiene le informazioni che variano in ogni versione del documento di destinazione, quali i nomi, le fotografie e gli indirizzi dei destinatari di una lettera modulare. Una sorgente dati può avere il formato .csv (delimitato da virgole) o .xml (Extensible Markup Language).
  • Il documento di destinazione è un documento Illustrator che contiene il disegno di base da utilizzare come modello. Questo documento può contenere il segnaposto dei campi dati e gli elementi che rimangono uguali in ogni versione del documento unito.

Accedere alla funzione che consente di unire i dati

L’unione dei dati è accessibile dal pannello Variabili in Illustrator (Finestra > Variabili). Il tipo e il nome di ogni variabile nel documento sono elencati nel pannello. Se la variabile è associata a un oggetto, la colonna Oggetti visualizza il nome dell’oggetto associato così come appare nel pannello Livelli. Potete ordinare le righe facendo clic sulle voci nella barra dell’intestazione: in base al nome della variabile, al nome dell’oggetto o al tipo di variabile.

Pannello Variabili

A. Set di dati B. Menu del pannello C. Passare da un set di dati all’altro D. Nome dell’oggetto associato E. Nome della variabile F. Tipo di variabile G. Bloccare le variabili H. Creare un oggetto dinamico I. Creare una visibilità dinamica J. Togliere l’associazione alle variabili K. Creare le variabili L. Eliminare le variabili 

Procedura rapida per l’unione dei dati

  1. Create un documento Illustrator da utilizzare come modello.

  2. Impostate il file sorgente dati in formato CSV o XML. Per ulteriori informazioni, consultate Preparare un file sorgente dati.

  3. Importate una sorgente dati in Illustrator utilizzando il pannello Variabili. Per ulteriori informazioni, consultate Importare un file sorgente dati.

  4. Associate una variabile a un oggetto nel modello. Per ulteriori informazioni, consultate Associare le variabili agli oggetti.

  5. Visualizzate un’anteprima del documento con ciascun set di dati prima di esportare tutti i file. Per ulteriori informazioni, consultate Visualizzare l’anteprima del documento con ciascun set di dati.

  6. Esportate un batch di file dai dati utilizzando il pannello Azioni in Illustrator. Per ulteriori informazioni, consultate Esportare i file utilizzando il pannello Azioni.

Preparare un file sorgente dati

I file sorgente dati devono essere salvati in formato .csv (delimitato da virgole) o .xml (Extensible Markup Language).

Impostare i file sorgente CSV

In un file .csv (delimitato da virgole), i record sono separati da segni di paragrafo e i campi da virgole o tabulazioni. Il file sorgente dati può anche includere testo o percorsi che fanno riferimento a immagini presenti sul disco. Prima di importare un file CSV, effettuate le seguenti operazioni per consentire a Illustrator di identificare il tipo di variabile.

  1. Aprite il foglio di calcolo.

  2. Specificate il nome del campo dati nella prima riga del foglio di calcolo. In seguito, effettuate le seguenti operazioni:

    • Prima del nome del campo dati digitate un simbolo chiocciola (@) per inserire il testo o il percorso nei file immagine. Il simbolo @ è necessario solo nella prima riga; quelle successive devono contenere i percorsi delle immagini.
    • Analogamente, all’inizio del nome del campo dati digitate un simbolo “percentuale” (%) per i grafici e un simbolo “cancelletto” (#) per la visibilità.
    • Per definire la visibilità di un oggetto, specificate true o false per ciascun campo dati.
    Nota:
    • I nomi dei campi dati nel foglio di calcolo non devono contenere spazi vuoti. Ad esempio, potete specificare il campo dati con il nome Nome_azienda invece di Nome azienda.
    • Analogamente, i percorsi che fanno riferimento ai file del grafico non devono contenere spazi vuoti. Ad esempio, il percorso di un file di immagine deve essere C:\Foto\BillTucker e non C:\Foto\Bill Tucker.
    • Tutti i file del grafico collegati dal file sorgente dati devono essere salvati in formato .csv (delimitato da virgole).
    • Se viene visualizzato un messaggio di errore quando digitate il simbolo @ all’inizio del campo, digitate un apostrofo (’) prima del simbolo @ (ad esempio, ’@Foto) per convalidare la funzione. In alcune applicazioni, quale Microsoft Excel, il simbolo @ è riservato alle funzioni.

    (Windows) Esempio di riferimenti a immagini e grafici nel file sorgente dati

    Nome

    Età

    @Foto

    %Grafici

    #Visibilità

    Bill Tucker

    36

    C:\Foto\BillTucker.jpg

    C:\Foto\BillTucker.csv

    True

    Dat Nguyen

    53

    C:\MyDocuments\dat.jpg

    C:\MyDocuments\dat.csv

    True

    Maria Ruiz

    26

    C:\Foto\Ruiz.jpg

    C:\Foto\Ruiz.csv

    False

    (macOS) Esempio di riferimenti a immagini e grafici nel file sorgente dati

    Nome

    Età

    @Foto

    %Grafici

    #Visibilità

    Bill Tucker

    36

    /Users/photos/BillTucker.jpg

    /Users/photos/BillTucker.csv

    True

    Dat Nguyen

    53

    /Users/family/photos/dat.jpg

    /Users/family/photos/dat.csv

    True

    Maria Ruiz

    26

    /Users/alpha/photos/Ruiz.jpg

    /Users/alpha/photos/Ruiz.csv

    False

  3. Inserite i vostri dati nel foglio di calcolo.

  4. Effettuate una delle seguenti operazioni:

    • Salvate i fogli di calcolo creati utilizzando la versione più recente di Microsoft Excel (versione 2016) nei seguenti formati file:
      • CSV (delimitato da virgole) (*.csv)
      • CSV (MS-DOS) (*.csv)
    • Salvate i fogli di calcolo creati utilizzando Apple Numbers nel formato CSV con codifica Unicode (UTF-8).
    Nota:

    Attualmente, i file CSV esportati nei formati sopra menzionati sono supportati in Illustrator. Altri formati file CSV come .csv Macintosh non sono supportati per l’unione dei dati.

Preparare un file XML

  1. Definite una variabile nel documento. Per i dettagli, consultate Associare le variabili agli oggetti.

  2. Selezionate il pulsante Cattura set di dati  nel pannello Variabili.

  3. Dopo aver creato il numero desiderato di set di dati, selezionate Salva biblioteca variabili dal menu del pannello Variabili per salvare i set di dati come file XML. Specificate un nome file e una posizione e selezionate Salva.

    Esportare le variabili create in Illustrator come file XML

  4. A questo punto, modificate il file XML in un’applicazione per modificare il testo come Notepad++ (Windows) o TextWrangler (macOS) per includere i set di dati in questo file.

    Esempio: modifica di un file XML usando una qualsiasi applicazione per modificare il testo

    A. Sostituire il percorso dell’immagine B. Sostituire la stringa di testo  

  5. Selezionate Carica libreria variabili dal menu del pannello Variabili per importare il file XML in Illustrator. Selezionate il file XML e scegliete Apri.

    Importare le variabili in Illustrator

Importare un file sorgente dati

Per associare le variabili ai dati desiderati, importate una sorgente dati nel pannello Variabili. Potete selezionare una sola sorgente dati per documento.

  1. Scegliete Finestra > Variabili.

  2. Nel pannello Variabili, selezionate Importa.

  3. Nella finestra di dialogo Carica libreria variabili, selezionate un file sorgente dati in formato CSV o XML e fate clic su Apri.

  4. Potete modificare, rinominare o eliminare i set di dati successivamente, scegliendoli dal menu a comparsa Set di dati e modificando le opzioni.

    • Selezionate un set di dati dall'elenco Set di dati nel pannello Variabili per passare da un set di dati all'altro. È inoltre possibile selezionare i pulsanti Set di dati precedente  o Set di dati successivo.
    • Per applicare i dati sulla tavola da disegno al set di dati corrente, scegliete Aggiorna set di dati  dal menu del pannello Variabili.
    • Per rinominare un set di dati, modificate il testo direttamente nella casella di testo Set di dati. Oppure, fate doppio clic sulle parole Set di dati (a sinistra della casella di testo Set di dati), immettete un nuovo nome e selezionate OK.
    • Per eliminare un set di dati, selezionate l'icona Elimina. Potete anche selezionare Elimina set di dati dal menu del pannello Variabili.
    Nota:

    I file CSV (UTF-8 Comma Delimited) contenenti caratteri a doppio byte creati tramite Excel non possono essere importati nel pannello Variabili. Se aprite lo stesso file in formato di testo e poi lo salvate come CSV con codifica UTF-8, il file viene importato correttamente.

Associare le variabili agli oggetti

Usate le variabili per definire gli elementi in un modello da modificare. Potete definire quattro tipi di variabili: Visibilità, Stringa di testo, File collegato e Dati grafico. Il tipo di variabile indica quali attributi dell’oggetto sono modificabili (dinamici). Il tipo e il nome di ogni variabile nel documento sono elencati nel pannello. Se la variabile è associata a un oggetto, la colonna Oggetti visualizza il nome dell’oggetto associato così come appare nel pannello Livelli.

Tipo di variabile

Icona che indica il tipo di variabile

Definizione

Variabili Visibilità

Mostrare o nascondere un disegno.

Variabili Stringa di testo

Sostituire una stringa di testo.

Variabili File collegato

Sostituire l’oggetto nella tavola da disegno con un oggetto da un altro file.

Variabili Dati grafico

Sostituire i valori in un grafico.

Variabile di tipo nessuno (non associato)

Non associata ad alcun oggetto.

Seguite questi passaggi per definire le variabili in Illustrator:

  1. Selezionate un oggetto.

  2. Nel pannello Variabili (Finestra > Variabili), selezionate la variabile alla quale associarlo.

  3. Selezionate il pulsante Crea oggetto dinamico per associare l'oggetto alla variabile.

Seguite questi passaggi per creare una variabile senza associarla a un oggetto:

  1. Selezionate il pulsante Nuova variabile  nel pannello Variabili.

  2. Per associare un oggetto alla variabile in un secondo momento, selezionate l’oggetto e la variabile e fate clic sul pulsante Crea visibilità dinamica  o sul pulsante Crea oggetto dinamico .

Nota:

I nomi delle variabili non supportano i caratteri SurrogatePair e i caratteri a 4 byte. Se si utilizzano questi caratteri in un nome di variabile, viene visualizzato un messaggio di errore.

Utilizzare le variabili

Potete modificare il nome di una variabile o di un tipo, togliere l’associazione a una variabile e bloccare una variabile mediante il pannello Variabili.

Togliendo l’associazione a una variabile potete eliminare il collegamento tra la variabile e l’oggetto associato. Quando le variabili sono bloccate non potete creare o eliminare delle variabili, né modificarne le opzioni. Tuttavia, potete associare o meno gli oggetti alle variabili bloccate.

Modificare il nome e il tipo di una variabile

  1. Selezionate la variabile nel pannello Variabili e scegliete Opzioni variabile dal menu del pannello.

Rimuovere l'associazione a una variabile

  1. Selezionate il pulsante Rimuovi associazione variabile  nel pannello Variabili.

Bloccare e sbloccare tutte le variabili di un documento

  1. Selezionate il pulsante Blocca variabili  o Sblocca variabilinel pannello Variabili.

Eliminare le variabili

Eliminate una variabile per rimuoverla dal pannello Variabili. Se eliminate una variabile associata a un oggetto, l’oggetto diventa statico (se non è associato anche a una variabile di tipo diverso).

  1. Selezionate la variabile da eliminare.

  2. Scegliete una di queste opzioni:

    • Selezionate il pulsante Elimina variabile  nel pannello Variabili.

    • Per eliminare la variabile senza conferma, trascinatela sul pulsante Elimina variabile .

Modificare gli oggetti dinamici

Potete modificare i dati associati a una variabile modificando l’oggetto a cui è associata. Ad esempio, se state lavorando con una variabile Visibilità modificate lo stato di visibilità dell’oggetto nel pannello Livelli. La modifica di oggetti dinamici permette di creare più set di dati da usare nel modello.

  1. Selezionate un oggetto dinamico sulla tavola da disegno oppure effettuate una delle seguenti operazioni per selezionare automaticamente un oggetto dinamico.

    • Tenete premuto Alt (Windows) o Opzione (macOS) e fate clic su una variabile nel pannello Variabili.

    • Selezionate una variabile nel pannello Variabili e scegliete Seleziona oggetti associati dal menu del pannello Variabili.

    • Selezionate Tutti gli oggetti associati dal menu del pannello Variabili per selezionare tutti gli oggetti dinamici.

  2. Modificate i dati associati all’oggetto come segue:

    • Modificate la stringa di testo sulla tavola disegno.

    • Sostituite l'immagine con il pannello Collegamenti o il comando File > Inserisci per i file collegati.

    • Modificate i dati per i grafici nella finestra di dialogo Dati grafico.

    • Per tutti gli oggetti con visibilità dinamica, modificate lo stato di visibilità dell’oggetto nel pannello Livelli.

Identificazione degli oggetti dinamici tramite gli ID XML

Il pannello Variabili mostra i nomi degli oggetti dinamici così come appaiono nel pannello Livelli. Se salvate il modello in formato SVG per usarlo con altri prodotti Adobe, i nomi degli oggetti devono rispettare le convenzioni di attribuzione dei nomi XML. Ad esempio, i nomi XML devono iniziare con una lettera, un carattere di sottolineatura o i due punti e non possono contenere spazi.

Illustrator assegna automaticamente un ID XML valido a ogni oggetto dinamico che create. Per visualizzare, modificare ed esportare i nomi degli oggetti usando gli ID XML, scegliete Modifica > Preferenze > Unità (Windows) o Illustrator > Preferenze > Unità (Mac OS) e selezionate ID XML.

Visualizzare l’anteprima del documento per ciascun set di dati

Per verificare il risultato finale, potete visualizzare l’anteprima prima di esportare tutti i file. Utilizzate i tasti freccia accanto a Set di dati nel pannello Variabili per spostarvi e visualizzare l’anteprima del set di dati desiderato nel documento.

Esportare i file utilizzando il pannello Azioni

Dopo aver definito le variabili e uno o più set di dati, potete generare il disegno in modalità batch utilizzando i valori dei set di dati. Effettuate una delle seguenti operazioni:

  1. Utilizzando il pannello Azioni (Finestra > Azioni), registrate un’azione per salvare il documento nel formato desiderato. Per i dettagli, consultate Automazione con le azioni.

  2. Scegliete Batch dal menu del pannello Azioni e selezionate l’azione creata nel passaggio precedente.

  3. Per Origine, selezionate Set di dati per eseguire l’azione su ciascun set di dati nel file corrente.

  4. Per Destinazione, specificate l’operazione da eseguire con i file elaborati. Potete lasciare i file aperti senza salvare le modifiche (Nessuno), salvare e chiudere i file nella posizione corrente (Salva e chiudi) o salvare i file in un’altra posizione (Cartella).

    A seconda dell’opzione di Destinazione selezionata, potete impostare opzioni aggiuntive per il salvataggio dei file. Per ulteriori informazioni, visualizzate Eseguire un’azione su gruppi di file.

  5. Selezionate OK.

Salvare un modello per l’unione dei dati

Quando definite le variabili in un documento Illustrator, viene creato un modello per l’unione dei dati. Potete salvare il modello in formato SVG per usarlo con altri prodotti Adobe, come Adobe® Graphics Server. Uno sviluppatore che lavora con Adobe Graphics Server, ad esempio, può associare le variabili del file SVG direttamente a un database o a un’altra sorgente dati.

  1. Scegliete File > Salva con nome, inserite un nome file, selezionate il formato SVG e fate clic su Salva.

  2. Fate clic su Altre opzioni e selezionate Includi dati Adobe Graphics Server. Questa opzione contiene tutte le informazioni necessarie per la sostituzione delle variabili nel file SVG.

  3. Fate clic su OK.

Si verificano problemi quando importate il vostro file CSV?

Se ricevete l’errore La variabile della biblioteca non è valida durante il caricamento di un file sorgente dati CSV, verificate che:

  • Il file CSV non sia vuoto.
  • I fogli di calcolo creati utilizzando la versione più recente di Microsoft Excel vengano salvati in formato CSV (delimitati da virgola) (*.csv) o CSV (MS-DOS) (*.csv) e quelli creati utilizzando Apple Numbers in formato CSV con codifica Unicode (UTF-8). I file sorgente dati salvati in altri formati file come *.csv Macintosh non sono supportati per l’unione dei dati.
  • Tutte le colonne hanno un nome del campo dati. Ad esempio, Illustrator visualizza il messaggio di errore quando una colonna nel file sorgente dati contiene dati ma non ha un nome del campo dati.
  • Il file sorgente dati non ha una colonna vuota tra le colonne piene. Ad esempio, Illustrator visualizza il messaggio di errore quando la colonna B e D nel file sorgente dati contiene dati ma la colonna C è vuota.
Esempio: errori durante l’impostazione di un file sorgente dati CSV per l’unione dei dati

A. Manca il nome del campo dati per una colonna B. Non esiste una colonna vuota tra le colonne piene 

  • I nomi dei campi dati nel foglio di calcolo non contengono spazi vuoti.
  • I percorsi che fanno riferimento ai file del grafico nel file sorgente dati non contengono spazi vuoti.
  • Tutti i file del grafico collegati dal file sorgente dati vengono salvati in formato .csv (delimitato da virgole).

risorse correlate

Contattaci

Siamo sempre lieti di ricevere i vostri feedback. Condividete le vostre opinioni con la Community di Adobe Illustrator.

 Adobe

Ottieni supporto in modo più facile e veloce

Nuovo utente?