Optimisez votre système d’exploitation, matériel, et configuration de Photoshop pour optimiser les performances.

Présentation

Utilisez les informations suivantes pour améliorer les performances de Photoshop

D’une manière générale, vous devriez adopter une approche globale, afin d’optimiser les performances de Photoshop selon vos besoins. Lisez les présentes suggestions dans leur totalité, afin de connaître celles que vous devez mettre en œuvre dans le contexte de la configuration de votre ordinateur, des types de fichiers que vous utilisez et de vos flux de production. Chaque circonstance est unique et nécessite une combinaison particulière de techniques, en vue d’obtenir les meilleures performances de Photoshop.

Il existe quatre façons principales d’influer sur les performances de Photoshop :

  • Spécification des préférences de performance de Photoshop
  • Utiliser de bonnes habitudes de travail dans Photoshop
  • Optimiser votre configuration matérielle
  • Optimisez votre système d’exploitation pour Photoshop

Le moyen le plus facile d’améliorer les performances sans dépenser d’argent est de définir vos préférences Photoshop et d’affiner le réglage de ses fonctions pour tirer profit de votre façon de travailler et du type de fichiers que vous utilisez habituellement.

Le moyen le plus spectaculaire d’accroître les performances est d’investir dans un matériel plus rapide et plus puissant.

Définissez les préférences relatives aux performances de Photoshop

Ajustement de l’utilisation de la mémoire

Vous pouvez améliorer les performances en réglant l’allocation de mémoire. La zone d’utilisation de la mémoire de la boîte de dialogue Préférences de performances indique la quantité de mémoire RAM disponible pour Photoshop. Elle indique également la fourchette idéale pour votre système. Par défaut, Photoshop utilise 70 % de la mémoire RAM disponible.

Vous pouvez affecter davantage ou moins de RAM à Photoshop en modifiant la valeur de la case Laisser Photoshop utiliser. Vous pouvez également utiliser le curseur d’utilisation de la mémoire. Redémarrez Photoshop pour activer vos modifications.

Si vous rencontrez des erreurs de mémoire RAM saturée ou des erreurs de mémoire insuffisante dans Photoshop, augmentez votre allocation de RAM. Lorsqu’aucune autre application n’est en cours d’exécution, vous pouvez définir l’allocation de RAM à 100 % pour améliorer les performances de Photoshop.

Pour trouver l’allocation idéale à votre système, modifiez la valeur par incréments de 5 % et contrôlez les performances avec l’indicateur d’efficacité. Reportez-vous à la section Contrôler l’indicateur d’efficacité.

Préférences relatives aux performances de Photoshop

Gestion des disques de travail

Un Disque de travail est n’importe quel lecteur ou partition de lecteur avec de l’espace mémoire disponible. Par défaut, Photoshop utilise le disque dur sur lequel le système d’exploitation est installé comme disque de travail principal.

Pour améliorer les performances, définissez le disque de travail sur un disque dur défragmenté qui dispose d’un espace disponible et les vitesses de lecture/écriture rapides. Si vous avez plusieurs disques durs, spécifiez des disques de travail supplémentaires. Photoshop prend en charge jusqu’à 64 exaoctets d’espace sur le disque de travail, sur quatre volumes maximum. (Un exaoctet équivaut à 1 milliard de gigaoctets.)

Si votre disque de démarrage est un disque dur, par opposition à un disque SSD, l’utilisation d’un disque dur différent comme disque de travail principal peut améliorer les performances. Un disque SSD, en revanche, est très performant en tant que disque de démarrage principal et disque de travail. En fait, utiliser un disque SSD est probablement préférable qu’utiliser un disque dur distinct comme disque de travail principal.

Les conseils qui suivent peuvent vous aider dans l’assignation et la gestion de vos disques de travail :

  • Pour de meilleures performances, les disques de travail doivent être localisés sur un disque différent de celui sur lequel vous modifiez des fichiers volumineux.
  • Ils doivent être localisés sur un disque différent de celui utilisé par votre système d’exploitation pour la mémoire virtuelle.
  • Les disques RAID et les piles de disques conviennent parfaitement comme volumes de disques de travail dédiés.
  • Les disques sur lesquels vous stockez des disques de travail doivent être défragmentés régulièrement.
Pour gérer vos disques de travail :
  1. Choisissez Edition > Préférences > Disques de travail (Windows) ou Photoshop > Préférences > Disques de travail (Mac OS).
  2. Pour modifier l’ordre des disques de travail, cliquez sur les boutons fléchés.
  3. Pour activer ou désactiver un disque de travail, cochez ou décochez la case Actif.
  4. Cliquez sur OK. Relancez Photoshop pour appliquer les modifications.

Remarque :

Si Photoshop ne peut pas se lancer car le disque de travail est saturé, maintenez les touches Cmd + Opt (Mac) ou Ctrl + Alt (Windows) enfoncées lors du lancement pour définir un nouveau disque de travail.

Réglez les niveaux de cache

Photoshop utilise la mise en mémoire cache d’images pour accélérer le retraçage des images haute résolution. Vous pouvez définir jusqu’à huit niveaux des données d’images mises en cache. Les niveaux de cache croissants amélioreront la réactivité de Photoshop pendant que vous travaillez, bien que le chargement d’images prendra plus de temps.

Trois caches prédéfinis sont disponibles dans le panneau Préférences des performances. Ces options définissent le niveau de cache et la taille de mosaïque (quantité de données sur lesquels Photoshop fonctionne en même temps) en fonction du type de document que vous modifiez et de la quantité de RAM dont vous disposez. Les mosaïques volumineuses permettent d’accélérer des opérations plus complexes, telles que la netteté des filtres. Les modifications mineures, telles que l’application de contours, sont plus efficaces avec de plus petites mosaïques.

  • Haut et fin : meilleur pour retoucher les images de petites dimensions disposant de nombreux calques (plusieurs dizaines/centaines).
  • Grand et plat : meilleur pour modifier des images de plus grandes dimensions (plusieurs dizaines/centaines de mégaoctets) mais moins de calques.
  • Valeur par défaut : pour les images intermédiaires.

Pour un meilleur contrôle, vous pouvez définir les niveaux de cache manuellement (la valeur par défaut est 4) :

  • Si vous utilisez des fichiers relativement petits (environ 1 mégapixel ou 1 280 x 1 024 pixels) et de nombreux calques (plus de 50), définissez les niveaux de cache sur 1 ou 2. La définition des niveaux de cache à 1 désactive la mise en mémoire cache de l’image ; seule l’image à l’écran est placée dans le cache.
  • Si vous utilisez des fichiers avec des dimensions en pixels supérieures (50 mégapixels ou plus), définissez les niveaux de cache sur une valeur supérieure à 50. Les niveaux de cache plus élevés accélèrent le retraçage.

Remarque :

Vous risquez de ne pas obtenir des résultats de haute qualité avec certaines fonctionnalités de Photoshop si vous définissez les niveaux de cache sur 1.

Etats d’historique limites

Vous pouvez enregistrer l’espace du disque de travail et améliorer les performances en limitant ou en réduisant le nombre d’états d’historique que Photoshop enregistre dans le panneau Historique. La quantité d’espace que vous enregistrez varie selon le nombre de pixels qu’une opération change. Par exemple, un état d’historique basé sur un simple trait ou une opération non destructive, telle que la création ou la modification d’un calque de réglage, occupe peu d’espace sur le disque. L’application d’un filtre à une image entière, en revanche, consomme beaucoup plus d’espace.

Photoshop peut enregistrer jusqu’à 1.000 états d’historique ; le nombre par défaut est de 20. Pour réduire ce nombre, accédez à la boîte de dialogue Préférences des performances, choisissez Historique et Cache > États d’historique. Dans le menu déroulant États d’historique, faites glisser sur une valeur inférieure.

Définissez les paramètres du processeur graphique (GPU)

Le meilleur moyen d’optimiser l’accélération du GPU, qui permet d’accélérer les affichages d’écran, est de conserver le pilote d’adaptateur vidéo à jour. Pour plus d’informations sur l’accélération du GPU et des instructions de mise à jour des pilotes d’adaptateur vidéo, voir FAQ de Photoshop GPU et de carte vidéo.

Activer OpenCL, une technologie qui permet aux applications d’utiliser le processeur graphique, est susceptible d’accroître les performances si vous utilisez ces fonctionnalités Photoshop :

  • Panorama vidéo
  • Galerie d’effets de flou (Flou de diaphragme, Flou de profondeur de champ et Bascule-Décentrement)

Pour activer OpenCL, dans le panneau Préférences des performances, cliquez sur Paramètres avancés et sélectionnez Utiliser OpenCL.

Affinez les fonctionnalités de Photoshop

Suivez ces conseils pour personnaliser et accélérer les performances de Photoshop en fonction de votre style de travail.

Réglez les options d’enregistrement de récupération et d’arrière-plan

L’enregistrement en arrière-plan est activé par défaut. Lorsque cette option est activée, vous pouvez continuer à travailler pendant les tâches d’enregistrement (Enregistrer et Enregistrer sous) au lieu de devoir attendre que celles-ci soient achevées. La préférence Enregistrer automatiquement les données de récupération n’est activée que si l’option Enregistrer en arrière-plan est activée. Lorsque cette option est activée, les données de récupération de tout fichier ouvert sont enregistrées selon l’intervalle de temps spécifié. (Les données de récupération sont enregistrées sous forme de sauvegarde redondante ; votre fichier d’origine n’est pas modifié.)

De façon générale, l’enregistrement en arrière-plan n’affectera pas les performances ou la réactivité des opérations normales de Photoshop. Cependant, dans le cas d’un fichier plus volumineux que la mémoire vive disponible, l’opération d’enregistrement peut avoir une incidence sur les performances ou la réactivité de Photoshop.

Si Photoshop semble ralentir par intermittence, vous pouvez vérifier si l’enregistrement en tâche de fond affecte les performances. Sélectionnez Enregistrer la progression dans le menu contextuel d’état en bas à gauche de la fenêtre de l’image.

Si vous constatez des problèmes de performances au niveau de l’évolution de la barre de progression de l’enregistrement, accédez à Préférences > Gestion des fichiers et diminuez la fréquence de la préférence Enregistrer automatiquement les données de récupération. Ou désactivez la préférence.

Affinez Photoshop

La définition d’un intervalle d’enregistrement moindre offre une meilleure protection contre les blocages. De façon générale, l’enregistrement des données de récupération n’affecte pas les performances ou la réactivité de Photoshop. Cependant, un ralentissement des performances est plus probable si les fichiers que vous modifiez sont plus grands que la mémoire vive disponible.

Les informations de récupération sont enregistrées aux mêmes emplacements que les fichiers de travail Photoshop. Si vous travaillez régulièrement avec de nombreux fichiers volumineux ouverts, la quantité d’espace peut être importante. Si vous obtenez des erreurs d’espace disque insuffisant pendant l’exécution d’autres commandes que les commandes d’enregistrement, ajoutez de l’espace de disque de travail. Vous pouvez également désactiver la préférence Enregistrer automatiquement les données de récupération tous/toutes les.

Travailler en respectant les limites de taille des fichiers

Les fichiers très volumineux sont souvent la cause des problèmes de performances. Photoshop prend en charge une taille de fichier maximum de 300 000 x 300 000 pixels, sauf pour les fichiers PDF, qui sont limités à 30 000 x 30 000 pixels et à 200 x 200 pouces.

Types de fichiers pris en charge par Photoshop :

  • Fichiers PSD : 2 Go
  • Fichiers TIFF : 4 Go
  • Fichiers PSB : 4 exaoctets (4 096 pétaoctets ou 4 millions de téraoctets)
  • Fichiers PDF : 10 Go (la taille des pages est limitée à 200 pouces)

Contrôler l’indicateur d’efficacité

Regardez l’indicateur d’efficacité pour analyser les performances pendant que vous travaillez dans Photoshop. Cliquez sur le menu déroulant en bas de la fenêtre de l’image et choisissez Efficacité.

Si la valeur de l’indicateur est inférieure à 100%, Photoshop a utilisé toute la mémoire RAM disponible et utilise le disque de travail, ce qui ralentit les performances. Si l’efficacité est inférieur à 90%, attribuez davantage de RAM à Photoshop dans les préférences de performance. Ou, ajoutez de la mémoire RAM supplémentaire à votre système.

Indicateur d’efficacité

Fermer les fenêtres de document inutiles

Si vous recevez un message d’erreur « hors de RAM » ou si Photoshop est particulièrement lent, cela peut s’expliquer ayant un trop grand nombre d’images ouvertes. Si plusieurs fenêtres sont ouvertes, essayez de fermer certaines d’entre elles.

Réduire les motifs et les pointes dans les paramètres prédéfinis

Pour réduire la quantité d’espace de disque de travail utilisé par Photoshop, minimisez le nombre de motifs et de formes chargés. Enregistrez les paramètres prédéfinis dont vous n’avez actuellement pas besoin dans un fichier de paramètres prédéfinis. Ou supprimez-les s’ils ont été chargés à partir d’un fichier de préconfiguration.

Remarque :

Voir la section Utilisation du gestionnaire de paramètres prédéfinis pour obtenir des informations sur la gestion des motifs prédéfinis et des tailles de pinceau.

Réduire ou désactiver les vignettes d’aperçu du panneau

À chaque modification d’un document, Photoshop met à jour toutes les vignettes visibles dans les panneaux Calques et Couches. Cette mise à jour peut affecter la réactivité de Photoshop lors des opérations rapides de peinture, de déplacement ou de décalage des calques. Plus le nombre de vignettes est élevé, plus ce problème est important.

Pour réduire ou désactiver ces vignettes d’aperçu, cliquez sur le menu du panneau et choisissezOptions de panneau. Sélectionnez une plus petite taille de vignette ou choisissez Aucun, puis cliquez sur OK.

calques:Calques, panneau

Modification des options de compatibilité des fichiers

S’il est inutile d’utiliser vos fichiers PSD et PSB dans des versions antérieures de Photoshop ou dans des applications qui ne prennent pas en charge les calques, vous pouvez désactiver la fonction de compatibilité des fichiers afin d’accélérer l’enregistrement du document :

  1. Dans Préférences > Gestion des fichiers, pour les documents 16 et 32 bits des fichiers PSD et PSB, sélectionnez l’option Désactiver la compression des fichiers PSD et PSB.

  2. Dans le menu Maximiser la compatibilité des fichiers PSD et PSB, sélectionnez l’option Demander ou Jamais.

    Optimisez la compatibilité des fichiers PSD et PSB

    Reportez-vous à la section Maximiser la compatibilité lors de l’enregistrement de fichiers pour plus d’informations.

Travailler en mode d’image 8 bits

Photoshop peut effectuer de nombreuses opérations sur les images 16 et 32 bits. Toutefois, le traitement de ces images requiert davantage de mémoire, d’espace de travail et de temps que pour les images 8 bits.

Pour convertir l’image en 8 bits par couche, sélectionnez Image > Mode > 8 bits/couche. Reportez-vous à la section Codage dans l’aide de Photoshop pour plus d’informations.

Remarque :

La conversion en 8 bits par couche supprime des données de l’image. Enregistrez une copie de l’image d’origine 16 ou 32 bits avant de la convertir en 8 bits par couche.

Désactiver l’option d’aperçu des polices WYSIWYG

Pour accélérer le traitement de police dans Photoshop, désactivez la liste d’aperçu de la police WYSIWYG en sélectionnant Type > Taille d’aperçu de la police > Aucune.

Réduire la résolution des images

Plus la résolution de l’image est élevée, plus Photoshop a besoin de mémoire et d’espace disque pour l’affichage, le traitement et l’impression des images. Selon votre sortie finale, la résolution d’image supérieure n’offre pas nécessairement une meilleure qualité d’image, mais elle peut ralentir les performances, utiliser de l’espace de disque de travail supplémentaire, et ralentir l’impression. La résolution optimale de vos images dépend de la manière dont les images seront affichées ou imprimées. 

Pour les images affichées à l’écran, pensez en termes de dimensions en nombre total de pixels. Par exemple, la plupart des images Web ne sont pas plus larges que 725 pixels. Pour réduire les dimensions d’une image, sélectionnez Image > Taille de l’image. Dans la boîte de dialogue Taille de l’image, vérifiez que l’option Rééchantillonnage est sélectionnée. Saisissez une nouvelle valeur pour les dimensions largeur ou hauteur (entrer une valeur pour une dimension modifie les deux).

Réduire la résolution des images

Pour les images destinées à l’impression, les avantages apportés par une résolution supérieure à 360 ppp sont la plupart du temps négligeables, voire inexistants. Pour une image destinée à de nombreuses impressions, prenez le temps de trouver la résolution la plus adaptée. Pour réduire la résolution d’une image, sélectionnez Image > Taille de l’image. Dans la boîte de dialogue Taille de l’image, sélectionnez Rééchantillonnage. Modifiez les valeurs de largeur et de hauteur pour refléter la taille physique du document imprimé. Réduisez ensuite la valeur Résolution et cliquez sur OK.

Si vous souhaitez augmenter la résolution de l’image à l’impression plutôt que de la diminuer, effectuez cette opération lors des dernières étapes avant d’imprimer l’image. De cette manière, vous n’avez pas à traiter toutes ces informations supplémentaires dans les étapes précédentes.

Pour plus d’informations, reportez-vous à la sectionRecadrage, redimensionnement et rééchantillonnage.

Mémoire de purge

Vous pouvez améliorer les performances du système en dégageant de l’espace sur le disque de travail et la mémoire non utilisée à partir de Photoshop pour la rendre accessible à d’autres programmes. Pour ce faire, sélectionnez l’une des options suivantes :

  • Édition > Purger > Tout
  • Edition > Purger > Annuler
  • Maintenez la touche Option (Mac OS) ou Alt (Windows) enfoncée et sélectionnez À propos de Photoshop CC

Si d’autres programmes tentent activement d’affecter ou d’utiliser la mémoire, dégager de la mémoire dans Photoshop permettra d’améliorer les performances. Libérer de l’espace sur le disque de travail sera utile si vous ne disposez plus d’espace disponible sur un volume de disque. Si vous libérez suffidamment d’espace disque ou de mémoire, Photoshop fonctionnera plus lentement la prochaine fois que vous ouvrez des fichiers de grande taille, pendant que Photoshop alloue de l’espace.

Si vous voulez que Photoshop utilise toujours moins de mémoire, choisissez la commande Edition > Préférences > Performances (Windows) ou Photoshop > Préférences > Performances (Mac OS) et déplacez le curseur d’utilisation de la mémoire vers la gauche. Reportez-vous à la section Réglage de l’utilisation de la mémoire.

Remarque :

Les moniteurs d’activité, les gestionnaires de tâches, et les utilitaires de disque peuvent prendre plusieurs secondes pour enregistrer la modification. En fait, pour certains outils, il vous faudra peut-être demander explicitement la mise à jour.

Videz le presse-papiers

Le Presse-papiers contient souvent des données volumineuses si vous les avez copiées et collées dans des documents importants. En outre, ce contenu est de faible utilité lorsque vous effectuez du collage. Pour libérer de la mémoire vive utilisée par des données image dans le presse-papiers, sélectionnez Modifier > Purge > Presse-papiers.

Remarque :

La commande Purger ne peut pas être annulée.

Utiliser la Galerie de filtres

La galerie de filtres vous permet de tester un ou plusieurs filtres sur une image avant d’appliquer les effets, ce qui peut faire gagner un temps considérable et beaucoup de mémoire. Reportez-vous à la section Présentation de Galerie de filtres pour plus d’informations.

Faites glisser entre les fichiers plutôt que de copier-coller

Il est plus efficace d’effectuer un glisser-déposer de calques ou de fichiers qu’un copier-coller. En effet, le déplacement ne fait pas appel au Presse-papiers et transfère les données directement. Le copier-coller peut potentiellement impliquer un transfert de données plus important, ce qui réduit son efficacité.

Savoir utiliser les calques

Les calques sont fondamentaux dans l’utilisation de Photoshop, mais ils augmentent la taille du fichier et le temps de retraçage. Photoshop permet de recomposer chaque calque après chaque changement dans l’image. Une fois les modifications apportées aux calques terminées, aplatissez-les (fusionnez-les) pour réduire la taille du fichier. Sélectionnez les calques dans le panneau Calques, cliquez avec le bouton droit de la souris (Windows) ou, tout en maintenant la touche Ctrl enfoncée (Mac OS), choisissez l’option Fusionner les calques. Pour aplatir tous les calques d’un fichier, sélectionnez Calque > Aplatir l’image. Veillez également à supprimer tous les calques vides du fichier.

Remarque :

Photoshop ne vous permet pas de séparer les calques une fois qu’ils sont fusionnés. Vous pouvez choisir Édition > Annuler ou utiliser le panneau Historique pour revenir à un état non fusionné.

Si vous n’apportez pas de changements fréquents à certains de vos calques, vous pouvez transformer les calques ou les groupes de calques en objets dynamiques, ce qui libère de l’espace disque et améliore les performances. Sélectionnez les calques ou les groupes de calques dans le panneau Calques, cliquez avec le bouton droit de la souris (Windows) ou, tout en maintenant la touche Ctrl enfoncée (Mac OS), choisissez l’option Convertir en objet dynamique. Reportez-vous à la section Utilisation d’objets dynamiques.

Enregistrer les fichiers TIFF sans calques

Photoshop permet d’enregistrer des calques dans des fichiers TIFF. Toutefois, les fichiers TIFF à calques sont plus volumineux que les fichiers TIFF aplatis ; ils consomment davantage de ressources pour le traitement et l’impression. Si vous utilisez un fichier TIFF à calques, enregistrez le fichier à calques d’origine en tant que fichier Adobe Photoshop (.psd). Ensuite, lorsque vous êtes prêt à enregistrer le fichier au format TIFF, choisissez Fichier > Enregistrer sous. Dans la boîte de dialogue Enregistrer sous, choisissez Format > TIFF, sélectionnez l’option Enregistrer comme une copie, désélectionnez Calques, puis cliquez sur Enregistrer.

Si vous souhaitez accélérer l’exportation des fichiers TIFF, ne choisissez pas la compression ZIP. (La compression ZIP est cependant celle qui génère les plus petits fichiers TIFF.)

N’exportez pas le presse-papiers

Si vous sélectionnez l’option Exporter le presse-papiers, Photoshop rend le contenu du presse-papiers disponible à d’autres programmes. Si vous copiez d’importantes quantité de données dans Photoshop, mais ne les copiez pas dans d’autres applications, gagnez du temps en désactivant cette option :

  1. Choisissez la commande Photoshop > Préférences > Général (Mac OS) ou Édition > Préférences > Général (Windows).

  2. Désélectionnez Exporter le Presse-papiers.

  3. Cliquez sur OK.

Optimisez votre matériel configuré pour Photoshop

Si vous souhaitez modifier la configuration actuelle de votre matériel (ou peut-être si vous achetez un nouveau système), utilisez les informations suivantes pour l’optimiser pour Photoshop.

Utilisez un processeur rapide

La vitesse de l’unité centrale de l’ordinateur limite la vitesse de traitement de Photoshop. Photoshop nécessite un processeur multicœur Intel (Mac OS), ou bien un processeur 2 GHz ou supérieur (Windows).

Photoshop est généralement plus rapide avec les processeurs à plusieurs cœurs, même si certaines fonctionnalités tirent davantage profit que d’autres des cœurs supplémentaires. Néanmoins, les bénéfices diminuent avec le nombre de cœurs : plus le nombre de cœurs utilisés est élevé, moins vous tirez parti de chaque cœur supplémentaire. Par conséquent, Photoshop n’est pas quatre fois plus rapide sur un ordinateur disposant de 16 cœurs que sur un ordinateur qui en compte quatre. Pour la plupart des utilisateurs, l’augmentation des performances fournies par plus de six cœurs ne saurait justifier l’augmentation des coûts.

Remarque :

Si vous exécutez Photoshop dans un environnement virtuel, l’utilisation du GPU de Photoshop peut entraîner des problèmes de performances. Les ordinateurs virtuels ne peuvent pas accéder au GPU.

Ajoutez de la mémoire vive

Photoshop utilise de la mémoire vive (RAM) pour le traitement des images. Si Photoshop ne dispose pas de suffisamment de mémoire, il fait appel à l’espace disponible sur le disque dur (disque de travail) pour traiter les informations. L’accès aux informations en mémoire est plus rapide que l’accès aux informations sur un disque dur. Par conséquent, Photoshop est plus rapide lorsqu’il peut traiter la totalité ou la majeure partie des informations contenues dans la RAM.

Pour la version la plus récente de Photoshop, au moins 8 Go de mémoire vive sont recommandés.

Pour obtenir des instructions sur la façon d’allouer de la mémoire vive (RAM) à Photoshop, reportez-vous à la section Réglage de l’utilisation de la mémoire.

Utilisez un disque dur rapide et de grande capacité

Photoshop lit et écrit les informations des images sur le disque lorsque votre système ne dispose pas d’assez de mémoire vive pour toutes les contenir. L’Indicateur d’efficacité peut vous aider à déterminer si l’acquisition d’un disque dur plus rapide ou d’un disque SSD permettrait d’améliorer vos performances. Si l’indicateur d’efficacité est supérieur à 95 %, le gain de performances d’un disque de travail plus rapide ne compensera probablement pas son coût.

Pour améliorer les performances de Photoshop, utilisez un disque avec un taux de transfert de données rapide. Par exemple, utilisez un disque dur interne ou un disque dur externe connecté via une interface rapide, telle que Thunderbolt, FireWire 800, eSATA ou USB3. Le transfert de données est généralement plus lent sur les serveurs réseau (disques durs accessibles via un réseau).

La dernière version de Photoshop requiert au moins 2,5 Go (Windows) ou 3,2 Go (Mac OS). L’installation requiert de l’espace supplémentaire et Adobe recommande également de l’espace de disque dur supplémentaire pour la mémoire virtuelle et l’espace du disque de travail.

Les baies RAID 0 rapides constituent d’excellents disques de travail, en particulier si vous utilisez la baie exclusivement comme disque de travail. Assurez-vous également de défragmenter le volume régulièrement, et ne l’utilisez pas comme volume de démarrage.

Utilisez un disque SSD

Pour optimiser l’utilisation du disque SSD, utilisez-le en tant que disque de travail. Une utilisation en tant que disque de travail permet une nette amélioration des performances pour les images dont la taille est supérieure à celle de la RAM. Par exemple, la permutation de mosaïques entre la mémoire RAM et le SSD est beaucoup plus rapide qu’une permutation entre la mémoire RAM et le disque dur.

Si votre SSD ne dispose pas de beaucoup d’espace libre (dans le cas où le fichier de travail dépasse la taille que peut contenir le SSD), vous pouvez ajouter un disque dur secondaire ou tertiaire. (Ajoutez-le après le SSD.) Assurez-vous que ces disques sont sélectionnés en tant que disques de travail dans les performances de la fenêtre Préférences.

En outre, les SSD présentent des performances très variables, bien plus que les disques durs. L’utilisation d’un lecteur ancien plus lent implique un gain de performances limité par rapport à un disque dur.

Remarque :

L’ajout de RAM pour améliorer les performances est plus rentable que l’achat d’un SSD.

Si l’indicateur d’efficacité est déjà haut, un SSD n’améliore pas les performances. Plus l’indicateur d’efficacité est faible, plus le gain offert par un SSD sera important.

Pour plus d’informations sur les performances et sur Photoshop 64 bits, reportez-vous à la section Avantages et limites des SE 64 bits.

Optimisez votre système d’exploitation pour Photoshop

Utilisez les informations suivantes pour installer et utiliser votre système d’exploitation efficacement avec Photoshop.

Fermer les applications inutiles et les éléments de démarrage

D’autres applications ouvertes et éléments de démarrage réduisent la quantité de mémoire disponible pour Photoshop. Pour libérer de la mémoire supplémentaire, quittez les applications inutiles, les éléments de démarrage, et les extensions. Ensuite,Mettre une plus grande quantité de mémoire disponible pour Photoshop.

Désactivation de App Nap (Mac)

Exécutez l’application de nettoyage de disque (Windows)

De temps à autre, exécutez l’application de nettoyage de disque pour supprimer les fichiers temporaires et les autres fichiers qui ne sont pas en cours d’utilisation.

  1. Cliquez sur le bouton Démarrer, saisissez Nettoyage de disque dans la zone de texte Rechercher, puis sélectionnez Nettoyage de disque dans la liste Programmes.

  2. Sélectionnez un lecteur pour nettoyer.

  3. Sélectionnez les fichiers temporaires et tout autre fichier que vous souhaitez supprimer.

  4. Cliquez sur OK.

Défragmentez le disque dur

Photoshop met plus de temps à lire ou écrire un fichier fragmenté qu’un fichier enregistré dans un emplacement contigu.

Pour obtenir des instructions concernant la défragmentation des disques durs sous Windows, reportez-vous aux rubriques d’aide Microsoft suivantes :

  • (Windows 7 et Windows Vista) « Améliorer les performances en défragmentant le disque dur »
  • (Windows 8) “Optimisation de votre disque dur”

Remarque :

La fragmentation est très rarement un problème sous Mac OS, sauf si vous avez l’habitude de travailler avec un lecteur presque plein.

Les disques SSD ne doivent pas être défragmentés, leurs performances étant peu affectées par des niveaux normaux de fragmentation.

Remarque :

Les baies RAID ne se fragmentent pas. La fragmentation risque plutôt de poser problème si vous utilisez un seul disque pour toutes vos applications. Cela peut également être le cas si un même volume est partagé entre des fichiers permanents et le disque de travail de Photoshop, en particulier s’il ne dispose pas de beaucoup d’espace libre. Dans ce cas, la défragmentation du disque peut faire la différence.

Activez les mises à jour automatiques du système d’exploitation

Les mises à jour du système d’exploitation Windows ou Mac OS X peuvent améliorer leurs performances et leur compatibilité avec les applications.

Pour Windows, activez Windows Update.

Pour Mac OS X, utilisez Mise à jour de logiciels.

Spécifiez une mémoire virtuelle fixe (Windows)

La définition d’un paramètre de mémoire virtuelle fixe permet d’empêcher les fichiers du disque de travail de Photoshop de se faire concurrence sur l’espace de mémoire virtuelle (plus particulièrement si vous définissez le paramètre de mémoire virtuelle sur un disque différent du disque de travail principal). Veillez à utiliser un lecteur avec suffisamment d’espace libre, contigu pour de meilleures performances. Par ailleurs, gardez le fichier d’échange sur un disque dur à part, vide et défragmenté.

Comme toujours, l’utilisation conseillée de disques distincts pour la mémoire virtuelle et pour les disques de travail ne s’applique pas aux disques SSD. En cas d’utilisation d’un disque SSD, placer tous les fichiers les plus fréquemment utilisés sur un disque SSD est important, et ne présente pas ou peu de problèmes de performance.

Pour modifier la mémoire virtuelle, quittez toutes les applications, puis procédez comme suit :

  1. Sélectionnez Démarrer > Panneau de configuration, puis cliquez deux fois sur Système.

  2. Dans la liste des Tâches, sélectionnez Paramètres système avancés puis cliquez sur l’onglet Avancés.

  3. Dans la section Performances, cliquez surParamètres.

  4. Cliquez sur l’onglet Avancé, puis cliquez sur Modifier.

  5. Désélectionnez l’optionGérer automatiquement le fichier d’échange pour tous les lecteurs.

  6. Cliquez sur chaque lettre de disque dur pour afficher l’espace disponible. Sélectionnez un disque dur disposant de trois fois la quantité de RAM installée sur l’ordinateur et ne contenant pas un disque de travail.

  7. Sélectionnez Taille personnalisée et saisissez la quantité de votre RAM physique plus 300 Mo dans la zone Taille initiale. Entrez trois fois la quantité de RAM installée sur l’ordinateur dans la zone Taille maximale.

  8. Cliquez sur Définir, puis cliquez sur OK. Continuez à cliquez sur OK pour fermer toutes les boîtes de dialogue.

  9. Redémarrez l’ordinateur. Si des applications sont ouvertes, sélectionnez Redémarrer ultérieurement, fermez les applications, puis redémarrez Windows. Dans le cas contraire, cliquez sur Redémarrer maintenant.

Pour modifier la mémoire virtuelle sous Windows 8, quittez toutes les applications, puis procédez comme suit :

  1. Cliquez sur Démarrer > Panneaux de configuration. Si vous ne voyez pas le bouton Démarrer, sélectionnez l’icône des dossiers et recherchez le panneau de configuration.

  2. Sélectionnez Système et Sécurité > Système.

  3. Suivez les étapes ci-dessus, en commençant à l’étape 3.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne