패턴 작성기로 패턴 생성하기

마지막 업데이트 날짜 2026년 10월 29일

데스크톱용 Adobe Photoshop에서 패턴 작성기를 사용해 이미지 영역을 분할하고 재조합하여 끊김 없이 반복되는 타일로 만드는 방법을 알아보세요.

패턴 작성기는 이미지의 일부를 분석하고 재구성하여 끊김 없는 패턴을 만드는 Windows 및 macOS용 선택적 플러그인으로, 타일 크기, 평활도 및 디테일 보존을 제어할 수 있습니다.64비트 macOS를 사용 중이라면 Photoshop을 32비트 모드로 실행해야 합니다.

이 필터는 이미지를 분석하여 패턴을 생성하고 타일 크기, 평활도, 디테일에 대한 컨트롤을 제공합니다.레이어를 직접 채우거나 개별 타일을 프리셋으로 저장하여 이후 프로젝트에 사용할 수 있습니다.생성할 때마다 선택한 영역을 샘플링하고 알고리즘으로 재배열하여 고유한 베리에이션을 만들어냅니다.

패턴 작성기 다운로드 및 설정

선택적 플러그인 페이지에서 운영 체제에 맞는 패턴 작성기를 다운로드하세요.

제공된 안내에 따라 플러그인을 설치하세요.

Photoshop을 32비트 모드로 실행되도록 설정하세요(64비트 macOS에서만 해당).

소스 콘텐츠 준비

소스 영역이 포함된 레이어를 선택하세요.원본을 보존하려면 복제본을 만드세요.

새 위치에 패턴을 생성하려면 사각형 선택 영역을 만든 후 Edit > Copy를 선택하세요.

새 레이어를 추가하거나 원하는 크기로 새 파일을 만드세요.

패턴 생성 및 조정

필터 > 패턴 작성기를 선택하세요.

앞서 콘텐츠를 복사했다면 클립보드를 샘플로 사용을 선택하세요.그렇지 않다면 선택 윤곽 도구를 사용하여 미리보기에서 영역을 선택하세요.

폭 및 높이 필드에 픽셀 크기를 입력하거나 이미지 크기 사용을 선택하여 단일 타일 패턴을 만드세요.

평활도 슬라이더를 조정하여 패턴의 날카로운 가장자리를 줄이세요.

샘플 디테일을 설정하여 분할 크기를 조절하세요. 값이 높을수록 원본 디테일이 더 많이 보존되지만 생성 시간이 길어집니다.

초기 패턴을 만들려면 생성을 선택하세요.

샘플 디테일 값이 높을수록 더 정확한 패턴이 생성되지만 처리 시간이 길어집니다.생성을 취소하려면 Esc 키를 누르세요.미리보기에 패턴이 반복 타일로 표시됩니다.보기 메뉴를 사용하여 생성된 미리보기와 소스 이미지를 전환하세요.개별 타일 가장자리를 보려면 타일 경계를 선택하세요.이동 메뉴를 사용하여 타일 정렬을 조정하세요. 이렇게 하면 저장된 프리셋에 영향을 주지 않고 타일 위치가 재조정됩니다.

패턴 변형 탐색 및 저장

현재 설정을 사용하여 추가 변형을 만들려면 다시 생성을 선택하거나, 재생성하기 전에 옵션을 조정하세요.

타일 작업 내역 패널 하단의 탐색 버튼을 사용하여 생성된 모든 패턴을 검토하세요.

미리보기 영역에 전체 반복 패턴을 표시할지 여부를 제어하려면 패턴 미리보기 업데이트를 선택하거나 선택 해제하세요.

원하는 타일로 이동한 후 프리셋 패턴 저장 버튼을 선택하세요.

프리셋 이름을 입력하고 확인을 선택하세요.

저장된 패턴 프리셋에는 생성된 전체 패턴이 아니라 하나의 타일만 포함됩니다.패턴 도구를 사용하여 적용하면 타일이 매끄럽게 반복됩니다.

패턴으로 기본 레이어나 선택 영역을 채우려면 확인을 선택하세요.채우기 없이 프리셋 패턴을 저장하려면 취소를 선택하세요.