이미지에서 개체 개수 세기

마지막 업데이트 날짜 2026년 10월 29일

클릭 카운트 또는 선택 방법을 사용하여 이미지 요소의 수를 측정하고 합계를 [측정 로그]에 기록하세요.

이미지에서 개체 개수를 세면 과학적 분석, 재고 관리, 품질 관리 또는 데이터 수집 워크플로에 필요한 요소를 측정할 수 있습니다. Adobe Photoshop에는 추적 및 내보내기를 위해 결과를 측정 로그에 기록하는 두 가지 카운트 방법이 있습니다.

개체가 시각적으로 구분되지만 색상이나 모양이 다양한 경우, 카운트 도구를 사용하여 클릭으로 수동으로 개수를 세는 워크플로를 이용하세요.개체가 비슷한 색상을 가지며 배경과 대비가 뚜렷한 경우에는 선택 항목을 이용한 자동 카운트 기능을 사용하세요. 두 방법 모두 측정값을 기록하기 전에 카운트 데이터 포인트를 활성화해야 합니다.

카운트 도구는 이미지에서 클릭할 때마다 이를 추적하여 각 위치에 번호가 매겨진 마커를 표시합니다. 동일한 이미지 내에서 여러 카운트 그룹을 만들어 다양한 개체 유형을 정리할 수 있으며, 각 그룹마다 색상과 마커 크기를 원하는 대로 설정할 수 있습니다.카운트 마커는 계속 편집할 수 있으며 문서와 함께 저장됩니다.

자동 카운트 기능은 선택 도구를 사용하여 색상 유사성을 기준으로 개별 영역을 식별하고 개수를 셉니다. 이 방법은 현미경 이미지의 셀이나 컨베이어 벨트 위의 제품처럼 주변과 뚜렷하게 구분되는 균일한 개체에 가장 효과적입니다.

카운트 도구로 개체를 수동으로 세기

도구 모음에서 스포이드 도구와 함께 그룹화된 카운트 도구를 선택하십시오.

옵션 바에서 [카운트 그룹] 메뉴에서 기존 그룹을 선택하거나 폴더 아이콘을 사용하여 새 그룹을 만들어 카운트 그룹 설정을 구성하십시오.

카운트 마커의 [색상], [마커 크기](1~10), [레이블 크기](8~72)를 설정하십시오.

이미지에서 각 개체를 클릭하여 번호가 매겨진 카운트 마커를 추가하십시오.마커를 재배치할 때 Shift 키를 누른 채 드래그하면 이동을 수평 또는 수직으로 제한할 수 있습니다.

[분석] > [데이터 포인트 선택] > [사용자 지정]을 선택하고 카운트 도구 영역에서 카운트 데이터 포인트를 활성화하십시오.

[창] > [측정 로그]를 선택하여 로그 패널을 엽니다.

카운트 데이터를 저장하려면 [분석] > [측정값 기록]을 선택하거나 [측정 로그] 패널에서 [측정값 기록]을 선택하십시오.

팁

카운트 마커의 가시성을 전환하려면 [보기] > [표시] > [카운트]를 선택하십시오.마커를 제거하고 총 개수를 업데이트하려면 Windows에서는 Alt 키를 누른 채 클릭하고, macOS에서는 Option 키를 누른 채 클릭하십시오.

측정 로그는 문서 이름, 타임스탬프, 배율 정보와 함께 기록된 모든 개수를 저장합니다. 각 카운트 그룹은 자체 누적 합계를 유지하며, 기록 시 별도의 항목으로 표시됩니다. 측정 로그를 설정하고 측정 배율을 지정하는 방법에 대한 자세한 내용은 측정 수행을 위해 측정 로그 사용하기를 참조하십시오.

선택 영역을 사용하여 개체를 자동으로 개수 세기

[자동 선택 도구]를 선택하거나 [선택] > [색상 범위]를 선택하여 선택 방법을 지정하십시오.

개수를 세고자 하는 모든 개체를 포함하는 선택 영역을 만드십시오. 자동 선택 도구의 경우, [허용치]를 조정하여 개체 선택을 최적화하고 [앤티 앨리어스]와 [인접] 옵션의 선택을 해제하십시오. [색상 범위]의 경우, [허용량]과 [선택한 색상]을 조정하여 선택한 영역을 세밀하게 조정하십시오.

[분석] > [데이터 요소 선택] > [사용자 정의]를 선택하십시오.

[선택 영역]에서 [개수] 데이터 요소를 활성화하고 [확인]을 선택하십시오.

로그 패널이 보이지 않는 경우 [창] > [측정 로그]를 선택하여 패널을 여십시오.

[카운트 도구] 이외의 도구로 전환한 후 [분석] > [측정 기록]을 선택하거나 [측정 로그] 패널에서 [측정 기록]을 선택하십시오.

메모

선택 영역에서 개수를 기록할 때는 [카운트 도구]에서 다른 도구로 전환했는지 확인하십시오. 그렇지 않으면 [측정 기록] 옵션을 사용할 수 없습니다.

Adobe Photoshop은 각 개별 선택 영역의 개수를 계산하고 합계를 [개수] 열에 기록합니다.여러 선택 영역이 있는 경우, 누적 데이터를 보여주는 하나의 요약 행이 생성된 후 각 영역에 대한 개별 행이 이어집니다. 각 선택 영역은 [레이블] 열에 별도의 피처로 나열되며 고유한 번호가 할당됩니다.

[자동 선택 도구] 또는 [색상 범위] 명령을 사용하는 고급 선택 기법에 대한 자세한 내용은 자동 선택 도구로 색상별 영역 선택하기를 참조하십시오.