데이터 기반 그래픽

마지막 업데이트 날짜 2026년 10월 29일

변수와 데이터 세트를 사용해 텍스트와 이미지가 다른 여러 버전의 템플릿을 생성하세요.

데이터 기반 그래픽을 사용하면 변경할 요소를 정의하고 데이터 세트를 통해 대체 콘텐츠를 제공하여 하나의 템플릿에서 여러 이미지 변형을 만들 수 있습니다.

이 워크플로는 다양한 제품을 위한 웹 배너, 개인화된 인증서, 현지화된 마케팅 자료처럼 텍스트, 이미지 또는 레이어 가시성이 다른 여러 버전의 디자인을 생성해야 할 때 적용됩니다.템플릿에서 변경하려는 각 요소마다 별도의 레이어를 사용해야 합니다. 외부 텍스트 파일에서 데이터 세트를 가져오는 방법은 데이터 세트 가져오기 관련 문서를 참조하세요.

Photoshop은 템플릿의 다양한 측면을 제어하는 세 가지 변수 유형을 지원합니다. 가시성 변수는 레이어 콘텐츠의 표시 여부를 제어합니다. 텍스트 교체 변수는 문자 레이어의 문자열을 대체합니다. 픽셀 교체 변수는 레이어 픽셀을 이미지 파일의 콘텐츠로 교체합니다. 하나의 템플릿에 여러 변수 유형을 적용할 수 있으며, 여러 레이어를 동일한 변수에 연결하여 변경 사항을 동시에 조정할 수 있습니다.

템플릿 요소에 변수 정의하기

이미지 > 변수 > 정의를 선택합니다.

레이어 메뉴에서 변경하려는 콘텐츠가 포함된 레이어를 선택합니다.

가시성, 텍스트 교체, 픽셀 교체 중 하나 이상의 변수 유형을 선택합니다.

공백 없이 문자, 밑줄, 콜론, 마침표 또는 하이픈을 사용하여 이름 필드에 이름을 입력합니다.

픽셀 교체 변수의 경우 크기 조정 방법(맞춤, 채우기, 있는 그대로, 일치)을 선택합니다.

정렬 위치를 선택하고 테두리 상자로 클립을 선택합니다.

추가 레이어에 대해 반복한 후 확인을 선택합니다.

변수가 포함된 레이어는 대화상자에서 이름 옆에 별표(*)가 표시됩니다. 변수 이름을 변경하려면 이미지 > 변수 > 정의로 돌아가 레이어를 선택하고 이름 필드에 새 이름을 입력합니다. 여러 레이어를 동일한 변수에 연결하려면 추가 레이어의 변수를 정의할 때 이름 드롭다운 메뉴에서 기존 변수 이름을 선택합니다.

데이터 세트 만들기 및 관리

이미지 > 변수 > 데이터 세트를 선택합니다.

새 데이터 세트 아이콘을 선택하여 현재 값을 기준으로 데이터 세트를 만드세요.

이름 메뉴에서 변수를 선택하세요.

변수 데이터를 편집합니다.

  • 가시성 변수의 경우: 표시 또는 숨김을 선택하세요.
  • 픽셀 교체 변수의 경우: 파일을 선택하고 교체할 이미지를 선택하세요
  • 텍스트 교체 변수의 경우: 값 필드에 텍스트를 입력하세요.

데이터 세트의 각 변수에 대해 이 과정을 반복하세요.

필요한 각 디자인 베리에이션에 대해 추가 데이터 세트를 만드세요.

완료하면 확인을 선택합니다.

이미지 > 데이터 세트 적용으로 이동하여 목록에서 데이터 세트를 선택하고 적용을 선택하면 각 데이터 세트가 디자인에 어떤 영향을 미치는지 미리 볼 수 있습니다. 데이터 세트 대화상자를 닫지 않고 변경 사항을 확인하려면 미리 보기 체크박스를 선택할 수도 있습니다.

데이터 세트 대화상자의 화살표 아이콘을 사용하여 데이터 세트 간에 이동하세요. 기존 데이터 세트를 수정하려면 데이터 세트 메뉴에서 선택한 후 변수 값을 편집하세요. 데이터 세트를 삭제하려면 선택한 후 삭제 아이콘을 선택하세요.

데이터 세트에서 출력 파일 생성하기

파일 > 내보내기 > 데이터 세트 파일로를 선택하세요.

이름 지정 필드에 생성된 파일의 기본 이름을 입력하세요.

폴더를 선택하고 대상 디렉터리를 선택하세요.

목록에서 내보낼 데이터 세트를 선택하세요.

파일을 생성하려면 확인을 선택하세요.

Photoshop은 기본 이름과 데이터 세트 이름을 결합하여 각 데이터 세트에 대해 별도의 PSD 파일을 만듭니다. 각 파일에는 데이터 세트의 값이 적용된 템플릿이 포함되어 있습니다.

템플릿에 데이터 세트를 직접 적용하면(이미지 > 데이터 세트 적용) 원본 문서를 덮어씁니다.항상 복사본으로 작업하거나 데이터 세트를 파일로 내보내세요.