Adobe Photoshop을 실행할 때 Generator 오류 해결

마지막 업데이트 날짜 2026년 10월 29일

보안 설정을 확인하고, 충돌하는 플러그인을 제거하고, 로그를 검토하여 Adobe Photoshop의 Generator 오류를 해결하는 방법을 알아보세요.

Generator는 Photoshop과 Generator 플러그인 간의 통신을 처리하는 Node.js 애플리케이션입니다. 다른 이름으로 내보내기 및 이미지 에셋의 에셋 생성 로직을 제공합니다.

Photoshop을 실행하거나 [파일] > [내보내기] > [내보내기 형식]을 선택하면 "Generator에 문제가 있습니다.Photoshop을 종료하고 다시 시도하세요. 문제가 계속되면 제3자 플러그인을 제거하거나 Photoshop을 다시 설치해 보세요."

다음 해결 방법을 순서대로 시도해 보십시오.

보안 소프트웨어가 Generator를 차단함

보안 소프트웨어 또는 바이러스 백신 소프트웨어가 8010 포트의 Generator 통신을 차단하거나 node 프로세스 실행을 막을 수 있습니다.

보안 또는 바이러스 백신 설정을 여세요.

허용된 애플리케이션 목록에 Photoshop을 추가하세요.

Generator에 대해 8010 포트가 열려 있는지 확인하세요.

Windows의 C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe에 있는 node.exe를 허용된 애플리케이션 목록에 추가하세요.

macOS에서는 /Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node의 node 프로세스를 허용하세요.

Windows에서는 Photoshop이 제어된 폴더에 액세스하도록 허용하세요.

Photoshop을 다시 시작한 다음 [파일] > [내보내기] > [다른 이름으로 내보내기]를 선택해 Generator를 테스트하세요.

제3자 플러그인이 Generator와 충돌함

Photoshop Generator 폴더의 제3자 플러그인은 현재 버전과 호환되지 않거나 기본 이미지 에셋 플러그인과 충돌할 수 있습니다.

Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator

데스크톱에 Disabled Generator Plug-ins라는 이름의 임시 폴더를 만드세요.

제3자 플러그인 폴더를 임시 폴더로 이동하세요. 기본 이미지 에셋 플러그인은 Generator 폴더에 그대로 두세요.

Photoshop을 시작하고 파일 > 내보내기 > 내보내기 형식을 선택하세요.

오류가 사라지면 플러그인을 한 번에 하나씩 다시 추가하고, 오류가 다시 나타날 때까지 추가할 때마다 Photoshop을 다시 시작하세요.

기본 Image Assets 플러그인은 Generator 폴더에 그대로 두세요.별도로 설치한 플러그인만 이동하세요.

Generator가 시작되지 않으며 필요하지 않은 경우

다른 이름으로 내보내기 또는 Image Assets를 사용하지 않는 경우 해결 방법으로 Generator를 끄세요.

Photoshop을 시작합니다.

Windows에서는 편집 > 환경 설정 > 플러그인을 선택하세요.macOS에서는 Photoshop > 설정 > 플러그인을 선택하세요.

생성기 활성화를 선택 해제합니다.

확인을 선택한 다음 Photoshop을 다시 시작하세요.

파일 > 내보내기 > 다른 형식으로 내보내기를 선택하면 Generator가 다시 켜집니다.다른 형식으로 내보내기가 필요하다면 Generator를 끈 상태로 두지 말고 Generator 오류를 해결하세요.

Generator 로그에 시작 오류가 표시됩니다

Generator 로그에는 로드에 실패한 플러그인 또는 Generator 시작을 방해하는 시스템 문제에 대한 정보가 포함될 수 있습니다.

Windows에서는 C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator로 이동하세요.

macOS에서는 /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator로 이동하세요.

가장 최근의 Generator 로그를 열고 오류 메시지를 확인하세요.

Generator 폴더가 없다면 상위 폴더에 대한 쓰기 권한이 있는지 확인하세요.

추가 도움이 필요하다면 Adobe Log Collector Tool을 사용하여 진단 로그를 수집하세요.

Windows의 AppData 폴더와 macOS의 Library 폴더는 기본적으로 숨겨져 있습니다.Windows에서 숨긴 파일 및 폴더 표시 방법을 참조하면 Windows 로그 위치를 찾는 데 도움이 됩니다.

Apple Silicon에서 Generator 오류가 발생합니다

Apple Silicon이 탑재된 Mac에서 Generator가 계속 실패한다면 Rosetta로 Photoshop을 실행하여 기본 모드 호환성이 문제를 발생시키는지 확인할 수 있습니다.

Photoshop을 종료합니다.

Finder에서 Applications를 열고 Adobe Photoshop을 찾으세요.

Adobe Photoshop을 Control-클릭한 다음 정보 가져오기를 선택하세요.

Rosetta를 사용하여 열기를 선택한 다음 Photoshop을 시작하고 Generator를 테스트하세요.

오류가 지속된다면 Adobe 지원팀에 문의할 때 Generator 로그를 제공하세요.Generator와 관련 없는 다른 형식으로 내보내기 문제의 경우 내보내기 및 저장 작업 문제 해결 안내를 참고하세요.