레이어 복사 및 붙여넣기

마지막 업데이트 날짜 2026년 10월 29일

복사, 붙여넣기, 제 자리에 붙여넣기 기능을 사용하여 효과와 마스크를 그대로 유지한 채 레이어를 복제하세요.

레이어를 복사하고 붙여넣으면 비트맵 및 벡터 마스크, 레이어 효과, Smart Object 참조를 포함한 전체 레이어 데이터가 문서 간에 전송됩니다.이 방법을 사용하면 대상 문서에 독립적인 복제본을 만들면서도 모든 레이어 속성을 유지할 수 있습니다.

복사 및 붙여넣기를 사용하면 모든 레이어 속성을 유지하면서 문서 간에 레이어를 전송할 수 있습니다.동일한 문서 내에서 레이어를 복제하려면 레이어 > 레이어 복제를 사용하세요.복제본을 만들지 않고 기존 콘텐츠를 재배치하려면 이동 도구를 사용하여 문서 창 간에 레이어를 드래그하세요.

레이어 복사 및 붙여넣기

레이어 패널에서 복사할 레이어를 선택하세요.

편집 > 복사를 선택하거나 Ctrl + C(Windows) 또는 Command + C(macOS)를 누르세요.

대상 문서로 전환하거나 새 문서를 만드세요.

편집 > 붙여넣기를 선택하거나 Ctrl + V(Windows) 또는 Command + V(macOS)를 누르세요.

붙여넣은 레이어는 대상 문서 캔버스의 중앙에 나타납니다.붙여넣은 레이어는 캔버스에서 최소한 일부가 보이는 상태로 나타납니다.

레이어를 원래 위치에 붙여넣기

레이어 패널에서 복사할 레이어를 선택하세요.

편집 > 복사를 선택하거나 Ctrl + C(Windows) 또는 Command + C(macOS)를 누르세요.

대상 문서로 전환하세요.

편집 > 특수 붙여넣기 > 제 자리에 붙여넣기를 선택하거나 Ctrl + Shift + V(Windows) 또는 Command + Shift + V(macOS)를 누르세요.

제 자리에 붙여넣기 기능을 사용하면 복사한 콘텐츠가 캔버스 가장자리를 기준으로 동일한 위치에 유지됩니다.

복사한 레이어 크기에 맞춰 문서 만들기

하나 이상의 레이어를 선택하고 복사하세요.

[파일] > [새로 만들기]를 선택합니다.

새 문서 대화상자에서 사전 설정 옵션 중 클립보드를 선택하세요.

만들기를 선택하여 복사한 레이어의 크기와 일치하는 새 문서를 생성하세요.

편집 > 붙여넣기를 선택하거나 Ctrl + V(Windows) 또는 Command + V(macOS)를 누르세요.

클립보드 사전 설정은 복사된 모든 레이어의 테두리 상자 크기와 일치하는 문서를 만듭니다.

색상 및 해상도 관리.

문서 간에 붙여넣기를 하면 소스 문서와 대상 문서가 서로 다른 색상 프로필을 사용하는 경우 Photoshop에서 색상 프로필 불일치 대화상자가 표시될 수 있습니다. 색상을 대상 문서에 맞게 변환하거나 원본 색상을 유지할 수 있습니다. 편집 > 색상 설정의 색상 관리 설정에 따라 이러한 프롬프트가 표시되는 시점이 결정됩니다.

해상도가 다른 문서 간에 레이어를 붙여넣으면 붙여넣은 콘텐츠는 원래의 픽셀 크기를 유지합니다.이로 인해 붙여넣은 요소가 대상 문서에서 실제보다 더 크거나 작게 나타날 수 있습니다. 시각적 일관성을 유지하려면 복사 및 붙여넣기 전에 이미지 > 이미지 크기를 사용하여 해상도를 일치시키거나, 편집 > 자유 변형을 사용하여 붙여넣은 콘텐츠의 크기를 조정하세요.

스마트 오브젝트 복사 및 붙여넣기 동작 이해하기

경고

복사하여 붙여넣은 스마트 오브젝트 레이어를 편집해도 원본 스마트 오브젝트 레이어는 업데이트되지 않으며, 반대의 경우도 마찬가지입니다. 복사하여 붙여넣은 스마트 오브젝트는 독립적인 임베드된 인스턴스를 생성합니다.

문서 간에 스마트 오브젝트 인스턴스 간의 연결을 유지하려면 연결된 스마트 오브젝트를 사용하세요. 연결된 스마트 오브젝트는 외부 소스 파일을 참조하므로, 소스를 편집하면 모든 인스턴스가 업데이트됩니다.

병합된 콘텐츠 복사

병합하여 복사 명령은 선택한 영역 내의 모든 표시 레이어를 병합한 복사본을 생성합니다.

선택 도구를 사용하여 영역을 선택하거나, 아무것도 선택하지 않은 상태로 두면 표시되는 모든 콘텐츠가 복사됩니다.

편집 > 병합하여 복사를 선택하거나 Ctrl + Shift + C(Windows) 또는 Command + Shift + C(macOS)를 누르세요.

병합된 콘텐츠를 원하는 문서에 붙여넣으세요. 병합된 콘텐츠는 하나의 레이어에 표시됩니다.

병합하여 복사는 레이어 가시성을 따르므로, 표시되는 레이어만 병합 결과에 포함됩니다.숨김 레이어는 선택되어 있어도 제외됩니다.

경로별 동작 다루기

모양 레이어와 벡터 마스크를 포함한 벡터 경로가 있는 레이어를 복사할 때, 복사 및 붙여넣기 동작은 캔버스에서 경로가 선택되어 있는지 여부에 따라 달라집니다.

모양 레이어와 벡터 마스크 복사하기

캔버스에서 경로가 선택되어 있지 않은 경우:

  • 모양 레이어 또는 벡터 마스크가 있는 레이어를 복사하면 전체 레이어가 클립보드에 복사됩니다
  • 붙여넣기를 하면 모든 마스크, 효과 및 경로 데이터가 그대로 유지된 복제 레이어가 만들어집니다

캔버스에서 경로를 선택한 경우:

  • 경로가 선택된 모양 레이어를 복사하면 경로 데이터만 클립보드에 복사됩니다
  • 경로 데이터 붙여넣기 동작은 대상 레이어 유형에 따라 다릅니다(아래 참조)

경로 데이터 붙여넣기

경로 데이터의 붙여넣기 동작은 선택한 레이어 유형에 따라 달라집니다:

  • 비트맵 레이어(경로 없음)에 붙여넣는 경우: 붙여넣은 경로 데이터로 새 벡터 마스크를 만듭니다
  • 경로가 선택되지 않은 모양 레이어에 붙여넣는 경우: 기존 모양이 붙여넣은 경로로 대체됩니다
  • 경로가 선택된 모양 레이어에 붙여넣는 경우: 붙여넣은 경로가 모양 레이어의 기존 경로와 결합됩니다
  • 벡터 마스크가 있는 레이어(마스크가 선택되지 않음)에 붙여넣는 경우: 벡터 마스크 경로가 붙여넣은 데이터로 대체됩니다
  • 벡터 마스크가 있는 레이어(마스크가 선택됨)에 붙여넣는 경우: 붙여넣은 경로가 기존 벡터 마스크 경로와 결합됩니다
메모

레이어가 선택된 경우 잘라내기 명령(편집 > 잘라내기)을 사용할 수 없습니다. 레이어를 복사하면서 제거하려면 복사를 사용한 다음 레이어 패널에서 원본 레이어를 삭제하십시오.