레이어 구성 요소 만들기 및 관리

마지막 업데이트 날짜 2026년 10월 29일

레이어 가시성, 위치 및 모양의 스냅샷을 사용해 단일 파일에 여러 디자인 변형을 저장하세요.

레이어 구성 요소를 사용하면 버전마다 별도의 파일을 만들지 않고도 클라이언트에게 여러 디자인 변형을 제시할 수 있습니다.

레이어 구성 요소는 특정 시점의 [레이어] 패널 상태를 캡처한 스냅샷입니다. 단일 문서 안에서 다양한 레이아웃 옵션, 색상 구성표 또는 콘텐츠 배치를 보여줘야 할 때 레이어 구성 요소를 사용하세요.각 컴프는 레이어 가시성(레이어 표시 또는 숨기기), 레이어 위치, 레이어 모양(스타일 및 혼합 모드), 그리고 Smart Object 레이어 컴프 선택을 기록할 수 있습니다.레이어 구성 요소는 컴포지션을 최종 확정하기 전에 다양한 디자인 대안을 탐색할 때 가장 유용합니다.

새 레이어 컴프 만들기

[창] > [레이어 구성 요소]를 선택해 레이어 구성 요소 패널을 여세요.

캡처하려는 디자인 상태가 반영되도록 레이어를 정렬하세요.

레이어 구성 요소 패널 하단에서 [새 레이어 구성 요소 만들기] 버튼을 선택하세요.

[새 레이어 구성 요소] 대화 상자에서 설명적인 이름과 선택 사항인 댓글을 입력하세요.

기록할 레이어 속성을 선택하세요: 가시성, 위치, 모양(레이어 스타일) 또는 Smart Object용 레이어 구성 요소 선택.

확인을 선택합니다.

선택한 옵션은 이후 레이어 구성 요소의 기본 설정이 됩니다.

팁

기존 구성 요소를 복제하려면 레이어 구성 요소 패널에서 [새 레이어 구성 요소 만들기] 옵션으로 끌어다 놓으세요.

레이어 구성 요소 적용 및 보기

[창] > [레이어 구성 요소]를 선택해 레이어 구성 요소 패널을 여세요.

레이어 구성 요소 컨텍스트 메뉴에서 레이어 구성 요소 적용을 선택하세요.

패널 하단의 [이전] 및 [다음] 컨트롤을 사용해 모든 구성 요소 또는 특정 구성 요소를 순환하며 확인하세요.

[레이어 구성 요소 적용] 옵션을 선택해 문서를 복원하세요.

레이어 컴프 업데이트

레이어 구성 요소 패널에서 업데이트할 레이어 구성 요소를 선택하세요.

[레이어] 패널에서 레이어 가시성, 위치 또는 모양을 변경하세요.

구성 요소가 기록하는 속성을 변경해야 하면 레이어 구성 요소 패널 메뉴에서 [레이어 구성 요소 옵션]을 선택하세요.

레이어 구성 요소 패널 하단에 있는 레이어 구성 요소 업데이트 버튼을 선택합니다.

Smart Object에서 레이어 구성 요소 사용하기

레이어 구성 요소가 포함된 문서를 다른 문서에 Smart Object로 배치하면 소스 파일을 열지 않고도 해당 레이어 구성 요소에 액세스할 수 있습니다.이를 통해 Smart Object 레벨에서 디자인 변형 간에 전환할 수 있습니다.

문서의 Layers 패널에서 Smart Object 레이어를 선택합니다.

Window > Properties를 선택하여 속성 패널을 엽니다.

속성 패널의 레이어 컴프 메뉴에서 표시할 레이어 컴프를 선택합니다.

Adobe Photoshop의 속성 패널에 있는 레이어 구성 요소 메뉴로, 전용 옵션과 함께 레이어 구성 요소 목록이 표시됩니다.

Smart Object가 업데이트되어 적용한 변환이나 효과를 유지하면서 선택한 컴프를 표시합니다.

레이어 구성 요소 경고 지우기

레이어 컴프가 참조하는 레이어를 삭제, 병합 또는 변환하면 해당 레이어 컴프 옆에 경고 아이콘이 표시됩니다.이 경우 구성 요소를 원래 상태로 완전히 복원할 수 없습니다.

구성 요소 이름 옆의 경고 아이콘을 선택하면 구체적인 문제를 확인할 수 있습니다.

메시지에서 지우기를 선택하면 경고가 제거되고 나머지 레이어 속성이 유지됩니다.

경고 아이콘을 마우스 오른쪽 버튼으로 클릭한 후 단일 경고를 지우려면 Clear Layer Comp Warning을, 모든 경고를 한 번에 지우려면 Clear All Layer Comp Warnings를 선택합니다.

누락된 레이어 정보가 필요하지 않다면 구성 요소를 현재 상태로 업데이트하거나 경고를 무시할 수도 있습니다.

레이어 구성 요소 삭제

[레이어 구성 요소] 패널에서 레이어 구성 요소를 선택합니다.

패널 하단의 삭제 아이콘을 선택하거나 구성 요소를 삭제 아이콘으로 드래그합니다.

다른 방법으로는 패널 메뉴에서 Delete Layer Comp를 선택합니다.

레이어 구성 요소를 파일로 내보내기

File > Export > Layer Comps To Files를 선택합니다.

대화상자에서 대상 폴더를 선택합니다.

내보낼 구성 요소의 파일 형식을 선택합니다.

각 레이어 구성 요소에 대해 개별 파일을 만들려면 실행을 선택하세요.

각 레이어 컴프는 컴프 이름이 파일 이름에 추가된 별도의 파일로 내보내집니다.