참고:

Photoshop CC 이전 버전의 Photoshop에서는 Photoshop Extended가 있는 경우에만 이 문서에서 설명한 일부 기능이 사용 가능할 수 있습니다. Photoshop CC에는 별도의 Extended 제공 기능이 없습니다. Photoshop Extended의 모든 기능은 Photoshop CC의 일부입니다.

타임라인 애니메이션 작업 과정

타임라인 모드에서 레이어 내용을 애니메이션으로 저장하려면 현재 시간 표시기를 다른 시간/프레임으로 이동할 때 [타임라인] 패널에서 키프레임을 설정한 다음 레이어 내용의 위치, 불투명도 또는 스타일을 수정합니다. Photoshop에서는 기존의 두 프레임 사이에 프레임들이 자동으로 추가되거나 수정됩니다. 그리고 이때 새 프레임들 사이에서 레이어 속성(위치, 불투명도, 스타일)이 균일하게 변하면서 움직이거나 변하는 모양이 만들어집니다.

예를 들어, 레이어에 페이드 아웃 효과를 적용하려면 시작 프레임의 레이어 불투명도를 100%로 설정하고 레이어의 [불투명도 초시계]를 클릭합니다. 그런 다음 현재 시간 표시기를 끝 프레임의 시간/프레임으로 이동하고 같은 레이어의 불투명도를 0%로 설정합니다. Photoshop에서는 시작 프레임과 끝 프레임 사이의 프레임들이 자동으로 보간되며 레이어의 불투명도가 새 프레임에서 균일하게 감소됩니다.

Photoshop에서 자동으로 애니메이션의 프레임을 보간하는 것 외에도 빈 비디오 레이어를 페인트하여 손으로 그린 프레임별 애니메이션을 만들 수 있습니다.

참고:

SWF 형식 애니메이션을 만들려면 Adobe Flash, Adobe After Effects 또는 Adobe Illustrator를 사용합니다.

타임라인 기반 애니메이션을 만들려면 다음과 같은 일반 작업 과정을 사용하십시오.

1. 새 문서를 만듭니다.

크기 및 배경 내용을 지정합니다. 픽셀 종횡비 및 치수가 애니메이션의 출력에 적합한지 확인합니다. 색상 모드는 RGB여야 합니다. 특별히 변경해야 할 이유가 없다면 해상도를 72픽셀/인치, 비트 심도를 8bpc, 픽셀 종횡비를 정사각형으로 두는 것이 좋습니다.

[타임라인] 패널이 열려 있는지 확인하십시오. 필요한 경우, 패널의 중앙에 있는 아래쪽 화살표를 클릭하고 메뉴에서 [비디오 타임라인 만들기]를 선택한 다음 화살표의 왼쪽에 있는 단추를 클릭합니다. [타임라인] 패널이 프레임 애니메이션 모드일 경우 패널의 왼쪽 하단에 있는 [비디오 타임라인으로 변환]을 클릭합니다.

2. 패널 메뉴에서 [타임라인 프레임 속도 설정]을 지정합니다.

재생 시간 및 프레임 속도를 지정합니다. 자세한 내용은 타임라인 재생 시간 및 프레임 속도 지정을 참조하십시오.

3. 레이어를 추가합니다.

배경 레이어는 애니메이션으로 만들 수 없습니다. 내용을 애니메이션으로 만들려면 배경 레이어를 일반 레이어로 변환하거나 다음 중 하나를 추가하십시오.

  • 내용을 추가할 새 레이어

  • 비디오 내용을 추가할 새 비디오 레이어

  • 내용을 복제하거나 손으로 그린 애니메이션을 만들 새 빈 비디오 레이어

4. 레이어에 내용을 추가합니다.

5. (선택 사항) 레이어 마스크를 추가합니다.

레이어 마스크는 레이어 내용 중 일부를 표시할 때 사용할 수 있습니다. 레이어 마스크를 애니메이션으로 저장하여 시간에 따라 레이어 내용의 다른 부분을 표시할 수 있습니다. 자세한 내용은 레이어 마스크 추가를 참조하십시오.

6. 첫 번째 키프레임을 설정할 시간 또는 프레임으로 현재 시간 표시기를 이동합니다.

7. 레이어 속성의 키프레임 기능을 켭니다.

레이어 이름 옆의 삼각형을 클릭합니다. 아래쪽을 가리키는 삼각형이 레이어의 속성을 표시합니다. 그런 다음 초시계를 클릭하여 애니메이션으로 저장할 레이어 속성에 첫 번째 키 프레임을 설정합니다. 한 번에 하나 이상의 레이어 속성에 키 프레임을 설정할 수 있습니다.

8. 현재 시간 표시기를 이동하고 레이어 속성을 변경합니다.

레이어 속성이 변경되는 시간 또는 프레임으로 현재 시간 표시기를 이동합니다. 다음 중 하나 이상을 수행할 수 있습니다.

  • 레이어의 위치를 변경하여 레이어 내용이 이동하게 만듭니다.

  • 레이어 불투명도를 변경하여 내용에 페이드인 또는 페이드아웃 효과를 적용합니다.

  • 레이어 마스크의 위치를 변경하여 레이어의 다른 부분을 표시합니다.

  • 레이어 마스크를 켜거나 끕니다.

개체 색상 변경이나 프레임 내용 완전 변경과 같은 일부 애니메이션 유형의 경우 새로운 내용의 추가 레이어가 필요합니다.

참고:

모양을 애니메이션으로 저장하려면 [벡터 마스크 위치] 또는 [벡터 마스크 사용 가능]에 [시간 변경 가능 초시계]를 사용하여 모양 레이어보다는 벡터 마스크를 애니메이션으로 저장합니다.

9. 내용이 있는 추가 레이어를 추가하고 필요에 따라 레이어 속성을 편집합니다.

10. 레이어 재생 시간 막대를 이동하거나 재단하여 애니메이션에서 레이어가 나타나는 시점을 지정합니다.

11. 애니메이션을 미리 봅니다.

애니메이션을 만들면서 [타임라인] 패널에 있는 컨트롤을 사용하여 애니메이션을 재생해 볼 수 있습니다. 그런 다음 웹 브라우저에서 애니메이션을 미리 봅니다. [웹용으로 저장] 대화 상자에서도 애니메이션을 미리 볼 수 있습니다. 자세한 내용은 비디오 또는 타임라인 애니메이션 미리 보기를 참조하십시오.

12. 애니메이션을 저장합니다.

웹용으로 저장 명령을 사용하여 애니메이션을 애니메이션 GIF로 저장하거나, [비디오 렌더] 명령을 사용하여 이미지 시퀀스나 비디오로 저장할 수 있습니다. 또한 PSD 형식으로 저장한 후 Adobe After Effects로 불러올 수도 있습니다.

키프레임을 사용하여 레이어 속성을 애니메이션으로 저장

[위치], [불투명도], [스타일] 등의 여러 레이어 속성을 애니메이션으로 저장할 수 있습니다. 각각의 변경 작업을 다른 변경 작업과 동시에 또는 별도로 수행할 수 있습니다. 여러 개체를 애니메이션으로 개별 저장하려면 별개의 레이어에 각 개체를 만드는 것이 좋습니다.

다음은 레이어 속성을 애니메이션으로 저장하는 방법의 몇 가지 예입니다.

  • [위치] 속성에 키프레임을 추가한 후 현재 시간 표시기를 이동하고 문서 창에서 레이어를 드래그하여 위치를 애니메이션으로 저장할 수 있습니다.

  • [불투명도] 속성에 키프레임을 추가한 후 현재 시간 표시기를 이동하고 [레이어] 패널에서 레이어의 불투명도를 변경하여 레이어의 불투명도를 애니메이션으로 저장할 수 있습니다.

  • 개체 및 카메라 위치와 같은 3D 속성을 애니메이션으로 저장할 수 있습니다. 자세한 내용은 3D 애니메이션 만들기를 참조하십시오.

 

키 프레임을 사용하여 속성을 애니메이션으로 저장하려면 해당 속성에 대해 두 개 이상의 키 프레임을 설정해야 합니다. 그렇지 않으면 레이어가 재생되는 동안에만 레이어 속성의 변경 내용이 적용됩니다.

각 레이어 속성에는 애니메이션 만들기를 시작할 때 클릭하는 [시간 변경 가능 초시계] 아이콘 이 있습니다. 특정 속성에 대해 초시계를 활성화하면 현재 시간과 해당 속성 값을 변경할 때마다 새 키 프레임이 자동으로 설정됩니다. 속성에 대해 초시계를 비활성화하면 속성에 키 프레임이 없습니다. 초시계가 비활성화된 상태에서 레이어 속성 값을 입력하면 해당 레이어가 재생되는 동안에만 값이 적용됩니다. 초시계를 선택 해제하면 해당 속성의 모든 키 프레임이 영구적으로 삭제됩니다.

보간 방법 선택

보간(트윈이라고도 함)은 알려진 두 값 사이에 알 수 없는 값을 입력하는 프로세스입니다. 디지털 비디오와 필름에서 보간은 대개 두 키 프레임 사이에 새 값을 생성하는 것을 의미합니다. 예를 들어 15개 프레임의 그래픽 요소를 왼쪽으로 50픽셀 이동하려면 첫 번째 프레임과 15번째 프레임의 그래픽 위치를 설정하고 둘 다 키 프레임으로 표시합니다. 이렇게 하면 두 키 프레임 사이의 프레임이 보간됩니다. 키 프레임 간의 보간을 사용하여 움직임, 불투명도, 스타일 및 전체 조명을 애니메이션으로 저장할 수 있습니다.

[타임라인] 패널에서 키프레임의 모양은 키프레임 간의 간격에 대해 선택하는 보간 방법에 의해 결정됩니다.

선형 키프레임

애니메이션된 속성을 키 프레임 간에 균일하게 변경합니다. (단, 활성 상태와 비활성 상태 사이를 갑자기 변환하는 [레이어 마스크 위치] 속성은 예외입니다.)

키프레임 유지

현재 속성 설정을 유지합니다. 이 보간 방법은 레이어가 갑자기 나타나거나 사라지게 하려는 경우나 섬광 효과에 유용합니다.

키프레임의 보간 방법을 선택하려면 다음을 수행합니다.

  1. [타임라인] 패널에서 하나 이상의 키프레임을 선택합니다.

  2. 다음 중 하나를 수행합니다.
    • 선택한 키 프레임을 마우스 오른쪽 단추로 클릭한 다음 상황에 맞는 메뉴에서 [선형 보간] 또는 [보간 유지]를 선택합니다.

    • 패널 메뉴를 열고 [키프레임 보간] > [선형] 또는 [키프레임 보간] > [중단]을 선택합니다.

키프레임으로 현재 시간 표시기 이동

속성의 첫 키 프레임을 설정하면 키 프레임 간을 이동하거나 키 프레임을 설정 또는 제거하는 데 사용할 수 있는 키 프레임 내비게이터가 표시됩니다. 키 프레임 내비게이터 다이아몬드가 활성화되면(노랑) 해당 레이어 속성의 키 프레임에 현재 시간 표시기가 정확히 놓이고, 키 프레임 내비게이터 다이아몬드가 비활성화되면(회색) 키 프레임 사이에 현재 시간 표시기가 놓입니다. 키 프레임 내비게이터 상자의 각 면에 화살표가 표시되면 해당 속성의 다른 키 프레임이 현재 시간의 양면에 나타납니다.

  1. [타임라인] 패널에서 키프레임 내비게이터 화살표를 클릭하십시오. 왼쪽 화살표는 현재 시간 표시기를 이전 키 프레임으로 이동하고, 오른쪽 화살표는 현재 시간 표시기를 다음 키 프레임으로 이동합니다.

키프레임 선택

  1. [타임라인] 패널에서 다음 중 원하는 작업을 수행하십시오.

    • 키프레임을 선택하려면 키프레임 아이콘을 클릭합니다.

    • 여러 키프레임을 선택하려면 Shift 키를 누른 채 키프레임을 클릭하거나 키프레임 주위로 선택 윤곽을 드래그합니다.

    • 하나의 레이어 속성에 대해 모든 키프레임을 선택하려면 [초시계] 아이콘 옆의 레이어 속성 이름을 클릭합니다.

키프레임 이동

  1. [타임라인] 패널에서 하나 이상의 키프레임을 선택합니다.

  2. 선택한 키 프레임 아이콘을 원하는 시간으로 드래그합니다. (여러 키 프레임을 선택한 경우 선택한 키 프레임이 그룹으로 이동하며 동일한 시간 간격을 유지합니다.)

참고:

여러 키 프레임의 간격을 늘리거나 좁히려면 Alt 키(Windows) 또는 Option 키(Mac OS)를 누른 채 선택 영역의 첫 번째 또는 마지막 키 프레임을 드래그합니다. 선택 영역에서 반대쪽 끝의 키 프레임은 드래그할 때 제자리에 남아 있으므로 애니메이션 속도를 늦추거나 높입니다.

키프레임 복사 및 붙여넣기

[위치] 등의 속성에 대한 키 프레임을 다른 레이어의 같은 속성에 복사할 수 있습니다. 키 프레임을 붙여넣으면 붙인 키 프레임은 현재 시간 표시기에서 복사된 오프셋을 반영합니다.

한 번에 한 레이어에서만 키 프레임을 복사할 수 있습니다. 다른 레이어에 키 프레임을 붙이면 대상 레이어의 해당 속성에 키 프레임이 나타납니다. 맨 앞의 키 프레임이 현재 시간에 나타나며 나머지 프레임이 순서대로 나타납니다. 키 프레임은 붙인 후 선택된 상태로 나타나므로 타임프레임에서 즉시 해당 키 프레임을 이동할 수 있습니다.

참고:

한 번에 여러 속성 간에 키프레임을 복사하여 붙일 수 있습니다.

  1. [타임라인] 패널에서 복사할 키프레임이 있는 레이어 속성을 표시합니다.

  2. 하나 이상의 키 프레임을 선택합니다.
  3. 선택된 키 프레임을 마우스 오른쪽 단추로 클릭하고 [키 프레임 복사]를 선택합니다.
  4. 대상 레이어가 들어 있는 [타임라인] 패널에서 키프레임을 표시할 시점으로 현재 시간 표시기를 이동합니다.

  5. 대상 레이어를 선택합니다.
  6. 패널 메뉴를 열고 [키프레임 붙여넣기]를 선택합니다.

키프레임 삭제

  1. [타임라인] 패널에서 하나 이상의 키프레임 선택하고 다음 중 하나를 수행합니다.

    • 선택된 키프레임을 마우스 오른쪽 단추로 클릭(Windows)하거나 Control+클릭(Mac OS)하고 컨텍스트 메뉴에서 [키프레임 삭제]를 선택합니다.

    • 패널 메뉴에서 [키프레임 삭제]를 선택합니다.

손으로 그린 애니메이션 만들기

손으로 그린 프레임별 애니메이션을 만들려면 문서에 빈 비디오 레이어를 추가합니다. 비디오 레이어 위에 빈 비디오 레이어를 추가한 후 빈 비디오 레이어의 투명도를 조정하면 그 아래에 있는 비디오 레이어의 내용을 볼 수 있습니다. 그런 다음 빈 비디오 레이어에 내용을 그리거나 페인트하여 비디오 레이어 내용을 로토스코프할 수 있습니다. 비디오 레이어의 프레임 페인트도 참조하십시오.

참고:

여러 개의 개별 요소를 애니메이션으로 저장할 경우 서로 다른 빈 비디오 레이어에 별개의 내용을 만드십시오.

  1. 새 문서를 만듭니다.
  2. 빈 비디오 레이어를 추가합니다.
  3. 레이어에 내용을 추가하거나 페인트합니다.
  4. (선택 사항) [타임라인] 패널의 패널 메뉴에서 [어니언 스킨 활성화]를 선택하여 어니언 스킨 모드를 활성화합니다.

  5. 다음 프레임으로 현재 시간 표시기를 이동합니다.
  6. 이전 프레임의 내용과 조금 다른 위치에 있는 레이어에 내용을 추가하거나 페인트합니다.

    참고:

    [레이어] > [비디오 레이어]를 선택한 다음 적절한 명령을 선택하여 빈 비디오 프레임을 추가하거나 프레임을 복제하거나 빈 비디오 레이어에서 프레임을 삭제할 수 있습니다.

    손으로 그린 프레임을 추가로 만들 때 재생 컨트롤을 사용하거나 현재 시간 표시기를 드래그하여 애니메이션을 미리 볼 수 있습니다.

빈 비디오 프레임 삽입, 삭제 또는 복제

빈 비디오 프레임을 빈 비디오 레이어에 추가하거나 빈 비디오 레이어에서 제거할 수 있습니다. 빈 비디오 레이어에서 기존(페인트) 프레임을 복제할 수도 있습니다.

  1. [타임라인] 패널에서 빈 비디오 레이어를 선택하고 현재 시간 표시기를 원하는 프레임으로 이동합니다.

  2. [레이어] > [비디오 레이어]를 선택하고 다음 중 하나를 선택합니다.

    빈 프레임 삽입

    현재 시간의 선택된 빈 비디오 레이어에 빈 비디오 프레임을 삽입합니다.

    프레임 삭제

    현재 시간의 선택된 빈 비디오 레이어에서 비디오 프레임을 삭제합니다.

    프레임 복제

    선택된 빈 비디오 레이어에서 현재 시간에 비디오 프레임 사본을 추가합니다.

어니언 스킨 설정 지정

어니언 스킨 모드는 현재 프레임에 그려진 내용과 주변 프레임에 그려진 내용을 모두 표시합니다. 이러한 추가 프레임은 현재 프레임과 구분하기 위해 사용자가 지정한 불투명도로 나타납니다. 어니언 스킨 모드를 사용하면 획 위치 및 기타 편집의 참조점을 알 수 있으므로 프레임별 애니메이션을 그릴 때 유용합니다.

어니언 스킨 설정에서는 어니언 스킨이 활성화된 경우 이전 및 나중 프레임이 어떻게 나타나는가를 지정합니다. (타임라인 패널 개요를 참조하십시오.)

  1. [타임라인] 패널을 열고 [어니언 스킨 설정]을 선택합니다.

  2. 다음 옵션을 지정합니다.

    어니언 스킨 개수

    표시할 이전 프레임과 다음 프레임 개수를 지정합니다. 텍스트 상자에 [다음 이전 프레임](이전 프레임) 및 [다음 이후 프레임](다음 프레임) 값을 입력합니다.

    프레임 간격

    표시된 프레임 사이의 프레임 개수를 지정합니다. 예를 들어, 1이라는 값은 연속된 프레임을 표시하고 2라는 값은 두 프레임만큼 떨어진 획을 표시합니다.

    최대 불투명도

    현재 시간 바로 앞과 뒤에 프레임의 불투명도 비율을 설정합니다.

    최소 불투명도

    어니언 스킨 프레임 세트의 앞과 뒤의 마지막 프레임에 불투명도 비율을 설정합니다.

    혼합 모드

    프레임이 겹치는 영역의 모양을 설정합니다.

    Photoshop 어니언 스킨
    어니언 스킨

    A. 뒤에 한 개의 프레임이 있는 현재 프레임 B. 앞과 뒤에 프레임이 한 개씩 있는 현재 프레임 C. 앞에 한 개의 프레임이 있는 현재 프레임 

다중 레이어 애니메이션 열기

이전 버전의 Photoshop에서 저장한 애니메이션을 다중 레이어 Photoshop(PSD) 파일로 열 수 있습니다. 레이어들은 해당 스택 순서대로 [타임라인] 패널에 배치되어 맨 밑에 있는 레이어가 첫 번째 프레임이 됩니다.

  1. [파일] > [열기]를 선택하고 열려는 Photoshop 파일을 선택합니다.
  2. [레이어] 패널에서 애니메이션에 사용할 레이어를 선택하고 패널 메뉴에서 [레이어에서 프레임 만들기]를 선택합니다.

    애니메이션을 편집하거나, [웹용으로 저장] 명령을 사용하여 애니메이션 GIF를 저장하거나, [비디오 렌더] 명령을 사용하여 애니메이션을 QuickTime 동영상으로 저장할 수 있습니다.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책