Kodu biçimlendirme

Kodunuz yazılırken otomatik olarak biçimlendirilebilir ve girintilendirilebilir. Dinamik font eşlemesi kullanıyorsanız, çok dilli metin için uygun fontların kullanıldığından emin olun.

Otomatik Biçim seçeneklerini ayarlama

  1. Şunlardan birini yapın:
    • Panel menüsünden  (Eylemler panelinin sağ üst köşesinde) Tercihler'i seçin.

    • Komut Dosyası penceresinde, Düzen > Tercihler'i (Windows) veya Animate > Tercihler'i (Macintosh) seçin.

  2. Tercihler iletişim kutusunda, Otomatik Biçim’i seçin.
  3. Otomatik Biçim seçeneklerinden birini seçin.

    Otomatik Biçim seçeneklerini ayarladıktan sonra, ayarlarınız otomatik olarak sizin yazacağınız koda uygulanır, ancak varolan bir koda uygulanmaz; varolan bir koda ayarlarınızı el ile uygulamalısınız.

Otomatik Biçim ayarlarına göre kod biçimlendirme

  • Eylemler panelinde veya Komut Dosyası penceresi araç çubuğunda Otomatik Biçim’i  tıklatın.
  • Panel menüsünden (Eylemler panelinin sağ üst köşesinde) Otomatik Biçim’i seçin.
  • Control+Shift+F (Windows) veya Command+Shift+F (Macintosh) tuşlarına basın.
  • Komut Dosyası penceresinde Araçlar > Otomatik Biçim’i seçin.

Dinamik font eşlemeyi kullanma

  1. Dinamik font eşlemeyi açmak veya kapatmak için Tercihler iletişim kutusunda Dinamik Font Eşleme Kullan'ı seçin veya seçimini kaldırın.

    Dinamik font eşleme siz komut yazarken performansı artırdığından varsayılan olarak kapalıdır. Çok dilli metin ile çalışıyorsanız, dinamik font eşleme doğru fontların kullanılmasını sağlamaya yardım ettiğinden dinamik font eşlemeyi açın.

Otomatik girintiyi kullanma

  1. Otomatik girintiyi açmak veya kapatmak için Tercihler iletişim kutusunda Otomatik Girinti'yi seçin veya seçimini kaldırın.

    Otomatik girinti açık olduğunda, bir sol parantezden ''('' veya bir sol küme parantezinden ''{'' sonra yazdığınız metin, ActionScript tercihlerindeki Sekme Boyutu ayarına göre otomatik olarak girintilenir.

    Komut dosyalarınızda, bir satırı seçip Sekme tuşuna basarak satırı girintileyebilirsiniz. Girintiyi kaldırmak için satırı seçin ve Shift+Sekme tuşlarına basın.

Kodun yorum bölümleri

Kod yorumları ActionScript derleyicisinin yoksaydığı kod parçalarıdır. Bir yorum satırı, kodunuzun ne yaptığını anlatır veya silmek istemediğiniz kodu geçici olarak devre dışı bırakır. Bir kod satırını çift eğik çizgi işaretiyle (//) başlayarak yorumlayın. Derleyici satırda çift eğik çizgi işaretinin ardından gelen metni yoksayar. Ayrıca bloğun başına bir eğik çizgi işareti ve yıldız işareti (/*) ve bloğun sonuna bir yıldız işareti ve eğik çizgi işareti (*/) yerleştirerek daha büyük kod bloklarını yorumlayabilirsiniz.

Bu yorum işaretleyicilerini elle yazabilir veya Eylemler panelinin veya Komut Dosyası penceresinin üst tarafındaki düğmeleri onları eklemek için kullanabilirsiniz.

Kod satırını yorumlama

  1. Ekleme noktasını satırın başına veya yorumun başlamasını istediğiniz karakterin olduğu yere yerleştirin.
  2. Sağ tıklatın ve Yorum'u seçin. Ctrl + M (Windows) veya Command + M klavye kısayollarını da kullanabilir ya da Düzen > Yorum Seçimi alanına gidebilirsiniz.

Bir çift eğik çizgi işareti (//) ekleme noktasına yerleştirilir.

Birden çok kod satırını yorumlama

  1. Yorumlanacak satırları seçin. (Seçimin ilk ve son satırları kısmi satırlar olabilir.)
  2. Sağ tıklatın ve Yorum'u seçin. Ctrl + M (Windows) veya Command + M klavye kısayollarını da kullanabilir ya da Düzen > Yorum Seçimi alanına gidebilirsiniz.

Blok yorum karakterleri seçimin başına (/*) ve sonuna (*/) yerleştirilir.

Not:

Metnin seçili satırları arasında yorumlar varsa satır yorumu tüm seçili satırlara uygulanır.

Yorum kaldırma

  1. Ekleme noktasını yorumu içeren satıra yerleştirin veya yorumlanan kod bloğunu seçin.
  2. Sağ tıklatın ve Yorumu Kaldır'ı seçin. Ctrl + Shift + M (Windows) veya Command + Shift + M klavye kısayollarını da kullanabilir ya da Düzen > Seçimin Yorumunu Kaldır seçeneğine gidebilirsiniz.

Sözdizimi renklendirmeyi kullanma

ActionScript'te, her dilde olduğu gibi, sözdizimi anlam oluşturmak için öğelerin bir araya getirilme şeklidir. Yanlış ActionScript sözdizimi kullanırsanız, komut dosyalarınız çalışamaz.

Sözdizimi hatalarını vurgulamak üzere komut dosyalarınızın parçaları için bir renk kodu ayarlayın. Örneğin, sözdizimi renkleri tercihini anahtar kelimelerin mavi renkte görünmesini sağlamak için ayarladığınızı düşünün. var yazdığınızda, var sözcüğü mavi renkte görünür. Ancak, yanlışlıkla vae yazarsanız, vae sözcüğü bir yazım hatası yaptığınızı gösteren siyah renkte kalır.

Şunlardan birini yapın:

  • Düzen > Tercihler'i (Windows) veya Animate > Tercihler'i (Macintosh) seçin ve Kategori listesinde Kod Düzenleyicisi'ni tıklatıp Sözdizimi Renkleri ayarlarını belirtin.

  • Ekleme noktası Komut Dosyası bölmesindeyken, Control-U (Windows) veya Command-U (Macintosh) tuşlarına basın.

Not:

Eylemler panelinde komut dosyaları yazarken, hedeflediğiniz oynatıcı sürümü tarafından desteklenmeyen komutlar Eylemler araç kutusunda sarı renkte görünür. Örneğin, Flash Player SWF dosyası sürümü Flash 7'ye ayarlıysa, sadece Flash Player 8'in desteklediği ActionScript, Eylemler araç kutusunda sarı renkte görünür.

Çalışma zamanında kimlik ve klavye listesini kullanma

Animate başlatıldığında kimlik ve klavye listeleri kaynak dosyasından okunur ve önbelleğe alınır. Varsayılan listelerin kaynaktan okunmasının dışında, ek anahtar sözcükleri ve Tercihler klasöründeki kimlik listesini de tarar. Şu klasörlere ".txt files" ekleyerek ek anahtar sözcük ve kimlik ekleyebilirsiniz:

  • C:\Users\<KullanıcıAdı>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptKeywords]\

  • C:\Users\<KullanıcıAdı>[AppData]\Roaming\Adobe\Animate\13.0[ActionscriptIdentifiers]\

  • C:\Users\<KullanıcıAdı>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptKeywords]\

  • C:\Users\<KullanıcıAdı>[AppData]\Roaming\Adobe\Animate\13.0[JavascriptIdentifiers]\

Satır numaralarını ve kelime kaydırmayı kullanma

Kod düzenlediğinizde veya değiştirdiğinizde, satır numaraları kodun daha kolay kaydırılabilir ve ayrıştırılabilir olmasını sağlar. Kelime kaydırma, uzun kod satırlarını yatay olarak kaydırmaktan kaçınmanıza yardım eder (özellikle geliştirme ortamında veya düşük ekran çözünürlüklerinde çalışıyorsanız).

Satır numaralarını etkinleştirme veya devre dışı bırakma

  • Komut Dosyası penceresinde Görüntüle > Satır Numaraları seçeneklerini belirleyin.
  • Control+Shift+L (Windows) veya Command+Shift+L (Macintosh) tuşlarına basın.

Belirli bir satırı vurgulama

  • Komut Dosyası penceresinde Düzen > Satıra Git'i seçin.

Satır kelime kaydırmayı etkinleştirme veya devre dışı bırakma

  • Komut Dosyası penceresinde Görüntüle > Kelime Kaydır seçeneklerini belirleyin.
  • Control+Shift+W (Windows) veya Command+Shift+W (Macintosh) tuşlarına basın.

Gizli karakterleri görüntüleme

Boşluk, sekme ve satır kesmeleri gibi karakterler ActionScript kodunun içinde gizlenir. Bu karakterleri görüntülemeniz gerekebilir; örneğin, bir dize değerinin parçası olmayan çift bayt boşluklar, derleyici hatalarına sebep olduklarından, bunları bulmalı ve kaldırmalısınız.

  • Control+Shift+8 (Windows) veya Command+Shift+8 (Macintosh) tuşlarına basın.

Gizli karakterleri görüntülemek için şu semboller kullanılır.

Gizli karakter

Sembol

Tek bayt boşluk

.

Çift bayt boşluk

l

Sekme

>>

satır kesmesi


Komut dosyasında metin bulma

Bul aracı komut dosyalarınızda metin dizelerini bulmanızı ve değiştirmenizi sağlar.

Not:

Bir Animate belgesindeki her komut dosyasının içindeki metin boyunca arama yapmak için Film Gezgini'ni kullanın.

Metin bulma

  1. Eylemler panelinde veya Komut Dosyası penceresinde, Bul'u  tıklatın veya Control+F (Windows) ya da Command+F (Macintosh) tuşlarına basın.
  2. Arama dizesi girin.
  3. Sonrakini Bul'u tıklatın.

Komut dosyasında metin bulma ve değiştirme

  1. Eylemler panelinde veya Komut Dosyası penceresinde, Bul'u  tıklatın veya Control+F (Windows) ya da Command+F (Macintosh) tuşlarına basın.
  2. Arama dizesi girin.
  3. Değiştir kutusuna yeni dizeyi girin.
  4. Sonrakini Bul'u tıklatın.
  5. Dizeyi değiştirmek için Değiştir'i tıklatın; dizenin tüm tekrarlamalarını değiştirmek için Tümünü Değiştir'i tıklatın.

(Animate CC'de kaldırılmıştır) Eylemler panelinde arama tekrarı yapma

  1. Panel menüsünden  (Eylemler panelinin sağ üst köşesinde) Yeniden Bul'u seçin.

(Animate CC'de kaldırılmıştır) Komut Dosyası penceresinde arama tekrarı yapma

  1. Düzen > Yeniden Bul'u seçin.

(Animate CC'de kaldırılmıştır) Sözdizimini ve noktalama işaretlerini kontrol etme

FLA dosyasını yayınlamadan ActionScript kodunuzu hızlı bir şekilde denetleyebilirsiniz.

Siz sözdizimini denetlerken, geçerli komut dosyası denetlenir. Geçerli komut dosyası ActionScript sınıflarını çağırırsa, bu sınıflar da denetlenir. FLA dosyasında bulunabilecek diğer komut dosyaları denetlenmez.

ActionScript 2.0 dosyalarında Sözdizimi Denetimi, kodu derleyicide çalıştırır; sözdizimi ve derleyici hataları oluşturur.

ActionScript 3.0 dosyalarında Sözdizimi Denetimi, yalnızca sözdizimi hataları oluşturur. Tür uyuşmazlıkları, hatalı dönüş değerleri, değişken veya yöntem adı hatalı yazımları gibi derleyici hataları oluşturmak için Kontrol Et > Test Et komutunu kullanmalısınız.

Sözdizimi denetimi

Sözdizimini denetlemek için aşağıdakilerden birini yapın:

  • Eylemler paneli veya Komut Dosyası penceresinde Sözdizimi Denetimi'ni  tıklatın.
  • Komut Dosyası bölmesinin içini tıklatın ve ardından Control+T (Windows) veya Command+T (Macintosh) tuşlarına basın. Komut Dosyası bölmesinin iç kısmının tıklatılması veya buraya metin girilmesi odağı bölmeye getirir. Sahne alanı üzerindeki bir nesne odağa sahipse Dönüştür paneli açılır.

Sözdizimi hataları Derleyici Hataları panelinde listelenir.

Not:

Komut Dosyası penceresindeki harici bir ActionScript sınıf dosyasında, global sınıf yolu sözdizimi denetimini etkiler. Global sınıf yolu veya kaynak yolu doğru olarak ayarlanmış olsa bile, derleyici bu sınıfın derlenmekte olduğunun farkında olmadığından hataya yol açabilirsiniz.

Noktalama dengesini denetleme

  1. Komut dosyanızdaki kümeli parantezlerin{}, köşeli parantezlerin [] veya parantezlerin () arasını tıklatın.
  2. Windows'ta, Control+' (tek tırnak) tuşlarına basın; Macintosh'ta, Command+' (tek tırnak) tuşlarına basın. Küme parantezleri, parantezler ve köşeli parantezlerin arasında kalan metin vurgulanır ve sol noktalamanın kendisine karşılık gelen sağ noktalamasının olduğunu denetleyebilirsiniz.

(Animate CC'de kaldırılmıştır) Komut dosyalarını içe ve dışa aktarma

Bir komut dosyasını Eylemler paneline veya Komut Dosyası penceresine içe aktarabilirsiniz. Ayrıca komut dosyalarınızı Eylemler panelinden harici ActionScript dosyalarına dışa aktarabilirsiniz. (Komut Dosyası penceresini kullandığınızda, AS dosyasını kaydedebildiğinizden dışa aktarmaya gerek kalmaz.)

Bir dosyayı açarken veya içe aktarırken, komut dosyanızdaki metin beklediğiniz gibi görünmüyorsa, içe aktarma kodlama tercihini değiştirin.

Harici AS dosyası içe aktarma

  1. Komut Dosyası bölmesinde, harici komut dosyasının ilk satırını nerede konumlandırmak istiyorsanız ekleme noktasını oraya yerleştirin.
  2. Şunlardan birini yapın:
    • Eylemler panelinde, panel menüsünden Komut Dosyasını İçe Aktar'ı seçin veya Control+Shift+I (Windows) ya da Command+Shift+I (Macintosh) tuşlarına basın.

    • Komut Dosyası penceresinde, Dosya > Komut Dosyasını İçe Aktar seçeneklerini belirleyin veya Control+Shift+I (Windows) ya da Command+Shift+I (Macintosh) tuşlarına basın.

Eylemler panelinden komut dosyası dışa aktarma

  1. Dışa aktarılacak komut dosyasını seçin. Sonra Eylemler paneli menüsünden Komut Dosyasını Dışa Aktar'ı seçin veya Control+Shift+X (Windows) ya da Command+Shift+X (Macintosh) tuşlarına basın.
  2. ActionScript (AS) dosyasını kaydedin.

Metin kodlama seçeneklerini ayarlama

  1. Düzen > Tercihler'i (Windows) veya Animate > Tercihler'i (Macintosh) seçin ve Kategori listesindeki ActionScript'i seçin.

  2. Şu tercihlerden herhangi birini ayarlayın:

    Aç/İçe Aktar

    Unicode kodlamasını kullanarak açmak veya içe aktarmak için UTF-8 Kodlamasını seçin ya da sisteminiz tarafından kullanılan geçerli dilin kodlama şeklini kullanarak açmak veya içe aktarmak için Varsayılan Kodlama'yı seçin.

    Kaydet/Dışa Aktar

    Unicode kodlamayı kullanarak kaydetmek veya dışa aktarmak için UTF-8 Kodlamasını seçin veya sisteminiz tarafından kullanılan geçerli dil kodlama şeklini kullanarak kaydetmek veya dışa aktarmak için Varsayılan Kodlama'yı seçin.

Dışa aktarma kodlama uyarısını kapatma veya açma

  1. Düzen > Tercihler'i (Windows) veya Animate > Tercihler'i (Macintosh) seçin ve Kategori listesindeki Uyarılar'ı seçin.

  2. ActionScript Dosyalarını Dışa Aktarırken Kodlama Çatışmalarında Uyar'ı seçin veya seçimini kaldırın.

(Animate CC'de kaldırılmıştır) İçe ve dışa aktarılan komut dosyaları için kodlama

İçe veya dışa aktarılmış ActionScript dosyalarında kullanılacak kodlama türünü belirtmek için ActionScript tercihlerini ayarlayabilirsiniz. UTF-8 Kodlaması, dosyanıza birden çok dil içeren metin dahil etmenizi sağlayan 8 bit Unicode biçimidir; Varsayılan Kodlama sisteminizin geçerli olarak kullandığı dil tarafından desteklenen kodlamadır, geleneksel kod sayfası olarak da adlandırılır.

Not:

Bir İngilizce sistemde İngilizce olmayan bir uygulama kullandığınızda, SWF dosya yolunun herhangi bir parçası Multibyte Character Sets (MBCS) kodlama şeması kullanılarak temsil edilemeyecek karakterlere sahipse Filmi Test Et komutu başarısız olur. Örneğin, Japonca bir sistemde çalışan Japonca yollar İngilizce bir sistemde çalışmaz. İngilizce sistemlerde sadece İngilizce yol adları kullandığınızdan emin olun. Filmi Test Et oynatıcısını kullanan tüm uygulama alanları bu sınırlamaya tabidir.

Eylemler panelinde komut dosyalarını iğneleme

Komut Dosyası bölmesinde ayrı komut dosyası sekmelerini iğnelemek ve uygun şekilde hareket ettirmek için Komut Dosyasını İğnele özelliğini kullanın. Bu özellik, FLA dosyanızdaki kodu tek bir merkezi konumda düzenlemediyseniz veya birden fazla komut dosyası kullanıyorsanız kullanışlıdır.

Eylemler panelinde kodun açık konumunu korumak için bir komut dosyasını iğneleyebilir ve farklı açık komut dosyaları arasında geçiş yapabilirsiniz. Bu, özellikle hata ayıklarken faydalıdır. 

Ayrıca, Eylemler panelinden seçili bir komut dosyasını veya tüm komut dosyalarını ayırmak için Komut Dosyasını Ayır veya Tüm Komut Dosyalarını Ayır seçeneğini kullanabilirsiniz.

Aşağıdaki şekilde, Zaman Çizelgesi'ndeki geçerli konumla ilişkili komut dosyası Cleanup adlı katmanda Kare 1 üzerindedir. (Sol uçtaki sekme zaman çizgisi boyunca konumunuzu sürekli takip eder.) Komut dosyası aynı zamanda en sağdaki sekme olarak gösterilen şekilde iğnelenir. Aşağıdaki iki komut dosyası iğnelenmiştir:

  • Kare 1 üzerinde
  • Intro adlı katmanın Kare 15'i üzerinde

İğnelenmiş komut dosyaları arasında hareket etmek için sekmeleri tıklatın veya klavye kısayollarını kullanın. İğnelenmiş farklı komut dosyaları arasında hareket etmek, zaman çizelgesindeki geçerli konumunuzu değiştirmez. Action komut dosyası gezgininde yeni bir komut dosyası seçildiğinde ilk kareye, diğer bir deyişle Kare 1'e yönelik hareketlere odaklanın.

Not:

Komut Dosyası bölmesindeki içerik, zaman çizelgesinde seçtiğiniz konumu yansıtmak üzere değişmiyorsa Komut Dosyası bölmesi muhtemelen sabitlenmiş bir komut dosyası görüntülemektedir. Zaman çizelgesi boyunca konumunuzla ilişkili komut dosyasını görüntülemek için Komut Dosyası bölmesinin sol üst tarafındaki geçerli kare sekmesini tıklatın.

İğnelenmiş bir komut dosyası

Komut dosyası iğneleme

  1. Komut dosyasının Eylemler panelinde Komut Dosyası bölmesinin sol üst tarafındaki geçerli bir kare sekmesinde görünmesi için Zaman Çizelgesi'ni tıklatın.

  2. Şunlardan birini yapın:
    • Sekmenin sağ tarafındaki Raptiye simgesini tıklatın.
    • Komut dosyasını iğnelemek için Görünüm> Komut Dosyasını İğnele seçeneklerini belirleyin.

     

Tüm komut dosyalarını ayırma

  1. Eylemler panelinde iğnelenmiş komut dosyasını seçin.

  2. Eylemler panelinden seçili komut dosyasını ayırmak için Görüntüle> Komut Dosyasını Ayır seçeneğini belirleyin.

  3. Eylemler panelinden tüm komut dosyalarını ayırmak için Görüntüle> Tüm Komut Dosyalarını Ayır seçeneğini belirleyin.

Çözme Seçenekleri

İğnelenmiş komut dosyaları için klavye kısayolları

Ekleme noktası Komut Dosyası bölmesinin içindeyken, iğnelenmiş komut dosyalarıyla çalışmak için şu klavye kısayollarını kullanın.

Eylem

Windows 

Macintosh

Komut dosyasını iğnele

Control+Shift+= (eşittir işareti)

Command+Shift+=

Komut dosyasını ayır

Control+Shift+- (eksi işareti)

Command+Shift+-

Hedef yolları ekleme

Çoğu komut dosyası eylemi film kliplerini, düğmeleri ve diğer sembol örneklerini etkiler. Kodunuza bir hedef yolu, yani hedeflemek istediğiniz örneğin adresi, ekleyerek zaman çizelgesindeki sembol örneklerine başvurabilirsiniz. Mutlak ya da göreceli bir hedef yolu ayarlayabilirsiniz. Mutlak bir yol, örneğin adresini tam olarak içerir. Göreceli bir yol sadece adresin, FLA dosyasındaki komut dosyasının kendi adresinden farklı olan parçasını içerir ve komut dosyası başka bir konuma taşındıktan sonra çalışmaz.

  1. Eylemler panelinde komut dosyanızda bir eylem seçin.
  2. Hedef Yolu'nu  tıklatın.
  3. Hedef örneğinin yolunu girin veya hedefi listeden seçin.
  4. Mutlak ya da Göreceli yol seçeneğini seçin.

Kod ipuçlarını kullanma

Eylemler panelinde veya Komut Dosyası penceresinde çalışırken, yazılım girmekte olduğunuz eylemi algılayabilir ve bir kod ipucu görüntüleyebilir. görüntüleyebilir. İki tür kod ipucu vardır: o eylemin sözdiziminin tamamını içeren bir araç ipucu ve yöntem ve özellik adları gibi olası ActionScript öğelerini listeleyen bir açılır menü (bazen bir kod tamamlama biçimi olarak adlandırılır).

Kod ipuçları varsayılan olarak etkindir. Tercihleri ayarlayarak, kod ipuçlarını devre dışı bırakabilir veya ne kadar hızlı görüneceklerini belirleyebilirsiniz. Kod ipuçları tercihlerde devre dışı bırakıldığında, hala el ile belirli bir komut için bir kod ipucu görüntüleyebilirsiniz.

Not:

ActionScript 2.0'da oluşturduğunuz bir değişken veya nesne için kod ipuçlarını görüntüleyemiyorsanız, ancak kod ipuçları ActionScript tercihlerinde etkinse, değişkeni veya nesneyi uygun son ek ile adlandırdığınızdan veya değişken ya da nesne için katı tipleme kullandığınızdan emin olun.

Kod ipucu vermeyi etkinleştirme

Kod ipuçlarını çeşitli şekillerde tetikleyebilirsiniz.

Nesneler için katı yazma

ActionScript 2.0 kullandığınızda ve yerleşik sınıf tabanlı bir değişken için (Button, Array, vs. gibi) katı tipleme kullandığınızda, Komut Dosyası bölmesi değişken için kod ipuçları görüntüler. Örneğin, aşağıdaki iki satırdan oluşan kodu girdiğinizi varsayın:

var foo:Array = new Array(); 
foo.

Siz noktayı (.), Değişkeni bir dizi olarak yazdığınızdan, Animate açılır bir menüde Array nesneleri için geçerli bir yöntemler ve özellikler listesi görüntüler.

Son ekler ve kod ipuçları

ActionScript 1.0 kullanıyorsanız veya nesneler için siz onları tam olarak yazmadan kod ipuçları görüntülemek istiyorsanız, nesneyi oluştururken her birinin adına bir son ek ekleyin. Örneğin, Camera sınıfı için kod ipucunu tetikleyen son ek _cam ekidir. Şu kodu yazdığınızı varsayın: var my_array = new Array(); var my_cam = Camera.get();

Daha sonra my_cam ve sonrasında bir nokta girdiğinizde, Camera nesnesi için kod ipuçları görünür.

Sahne Alanı'nda görünen nesneler için son eki Özellik denetçisinde Örnek Adı kutusu içerisinde kullanın. Örneğin, MovieClip nesneleri için kod ipuçları görüntülemek üzere tüm MovieClip nesnelerine _mc son ekini içeren örnek adları atamak için Özellik denetçisini kullanın. Sonra, her ardından nokta gelen örnek adı yazdığınızda, kod ipuçları görünür.

var my_array = new Array(); 
var my_cam = Camera.get();

Not:

Bir nesne için katı yazma kullandığınızda kod ipuçlarını tetiklemek için son ekler gerekli olmasa da, devamlı olarak son ek kullanmanız kodunuzun anlaşılır olmasına yardımcı olur.

Şu tablo, ActionScript 2.0'da kod ipuçlarını tetikleyen son ekleri listeler:

Nesne türü

Değişken son ek

Array

_array

Button

_btn

Camera

_cam

Color

_color

ContextMenu

_cm

ContextMenuItem

_cmi

Date

_date

Error

_err

LoadVars

_lv

LocalConnection

_lc

Microphone

_mic

MovieClip

_mc

MovieClipLoader

_mcl

PrintJob

_pj

NetConnection

_nc

NetStream

_ns

SharedObject

_so

Sound

_sound

String

_str

TextField

_txt

TextFormat

_fmt

Video

_video

XML

_xml

XMLNode

_xmlnode

XMLSocket

_xmlsocket

Yorumlar ve kod ipuçları

Bir nesnenin kod ipuçları için sınıfını belirlemek üzere ActionScript yorumlarını kullanabilirsiniz. Şu örnekte, bir yorum ActionScript'e theObject örneğinin sınıfının Object olduğunu söyler, vs.

// Object theObject;// Array theArray;// MovieClip theMC;

Sonrasında bir nokta gelen theMC metnini girdiğinizde, MovieClip yöntemleri ve özellikleri listesini görüntüleyen kod ipuçları görünür. Sonrasında bir nokta gelen theArray metnini girerseniz, Array yöntemleri ve özellikleri listesini görüntüleyen kod ipuçları görünür, vs.

Ancak bu tekniğin yerine, Adobe size katı veri yazımını veya son ekleri kullanmanızı önerir, çünkü bu teknikler kod ipuçlarını otomatik olarak etkinleştirir ve kodunuzun daha anlaşılır olmasını sağlar.

Otomatik kod ipuçlarının tercih ayarlarını belirtme

  • Eylemler panelinde veya Komut Dosyası penceresinde, Düzen > Tercihler'i (Windows) veya Animate > Tercihler'i (Macintosh) seçin, Kategori listesinde Kod Düzenleyicisi'ni seçin ve ardından Kod İpuçları'nı etkinleştirin veya devre dışı bırakın.

(Animate CC'de kaldırılmıştır) Kod ipuçları için gecikme belirtme

  1. Eylemler paneli veya Komut Dosyası penceresinde, Düzen > Tercihler'i (Windows) veya Animate > Tercihler'i (Macintosh) seçin.

  2. Kategori listesinde ActionScript'i seçin.
  3. Saniye cinsinden bir gecikme miktarı seçmek için kaydırıcıyı kullanın.

Araç ipucu stili kod ipuçlarını kullanma

  1. Parantez gerektiren bir öğeden sonra bir sol parantez ''('' yazarak kod ipucunu görüntüleyin (örneğin, bir yöntem adından, if veya do..while gibi bir komuttan sonra).
    Sol parantezler kod ipuçlarını çağırır

  2. Parametre için bir değer girin.

    Birden çok parametre için değerleri virgüllerle ayırın. for döngüsü gibi işlevler ve deyimler için parametreleri noktalı virgüllerle ayırın.

    gotoAndPlay() veya for gibi aşırı yüklü olan komutlar (farklı parametre kümeleriyle çağırılabilen işlevler ve yöntemler) ayarlamak istediğiniz parametreleri seçmenizi sağlayan bir gösterge görüntüler. Parametreyi seçmek için küçük okları tıklatın veya Control+Sol Ok ve Control+Sağ Ok tuşlarına basın.

    Birden çok parametre kümesi olan bir kod ipucu

  3. Kod ipucuna son vermek için şunlardan birini yapın:
    • Bir sağ parantez yazın '')''.

    • Deyimin dışında fareyi tıklatın.

    • Escape tuşuna basın.

Menü stili kod ipuçları kullanın:

  1. Bir değişken veya nesne adından sonra bir nokta koyarak kod ipucunu görüntüleyin.
    Menü tipi kod ipuçları

  2. Kod ipuçları arasında gezinmek için Yukarı ve Aşağı Ok tuşlarını kullanın.
  3. Menüden bir öğe seçmek için Enter veya Sekme tuşuna basın veya öğeyi çift tıklatın.
  4. Kod ipucuna son vermek için şunlardan birini yapın:
    • Menü öğelerinden birini seçin.

    • Menü penceresinin yukarısını veya aşağısını tıklatın.

    • Daha önce bir sol parantez yazdıysanız ''('', bir sağ parantez yazın '')''.

    • Escape tuşuna basın.

Kod ipucunu elle görüntüleme

  1. Aşağıdaki konumlar gibi kod ipuçlarının görünebileceği bir kod konumunun içini tıklatın:
    • Bir özellik veya yöntemin girilmek zorunda olduğu bir deyim ya da komuttan sonraki noktanın (.) sonrası

    • Bir yöntem adında parantezlerin [()] arası

  2. Şunlardan birini yapın:
    • Kod İpuçları'nı el ile etkinleştirmek için Görünüm > Kod İpucunu Göster seçeneğini belirleyin.

    • Control+Boşluk Çubuğu (Windows) veya Command+Boşluk Çubuğu (Macintosh) tuşlarına basın.

Özel sınıflar için kod ipuçları

Özel ActionScript 3.0 sınıfları oluşturduğunuzda, Animate sınıfları ayrıştırıp içeriklerindeki nesneleri, özellikleri ve yöntemleri belirler. Daha sonra özel sınıflara başvuran kodu yazdığınızda Animate kod ipucu sağlayabilir. Özel sınıf kodu tamamlama özelliği, import komutu bulunan başka herhangi bir koda bağladığınız sınıflar için otomatiktir.

Kod ipucu, geliştiricilerin sınıf tarafından kullanılan tüm nesneleri, yöntemleri ve özellikleri hatırlamaları gerekmediğinden daha hızlı çalışabilmelerini sağlar. Tasarımcılar, sınıflarla çalışma konusunda ilk elden bilgiye sahip olmaları gerekmediğinden kendi yazmadıkları sınıflarla çalışabilirler.

Kod ipucu aşağıdakileri içerir:

  • Yuvalanan sınıf başvuruları için kod ipucu

    Yuvalanan başvuruları yazarken kod ipuçlarının devamlı desteği yardımcı olur.

  • “this” kodu için kod ipucu

    Bir sınıf dosyasının içine “this” yazdığınızda aynı sınıf için kod ipucu alırsınız.

  • “new+<space>” için kod ipucu

    “new+<boşluk>” yazdığınız zaman, Animate kullanılabilecek sınıf ve paket listesini görüntüler.

  • "import" kodu için kod ipucu

    “import+<boşluk>” yazdığınızda Animate kullanılabilecek tüm yerleşik ve özel paketlerin listesini görüntüler.

  • SWC kütüphaneleri için kod ipucu

    Dış kütüphane yolunun kütüphane yoluna SWC kütüphanesi eklediğinizde, Animate SWC dosyasının içinde bulunan tüm sınıflar için kod ipucu uygulamasını etkinleştirir.

Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi