Felhasználói útmutató Mégse

Adategyesítés a Változók panel használatával

  1. Illustrator felhasználói útmutató
  2. Az Illustrator megismerése
    1. Bevezetés az Illustrator programba
      1. Az Illustrator újdonságai
      2. Gyakori kérdések
      3. Az Illustrator rendszerkövetelményei
      4. Az Illustrator használata Apple Silicon processzorral ellátott számítógépeken
    2. Munkaterület
      1. A munkaterület alapjai
      2. Tanuljon gyorsabban az Illustrator Felfedezés panelje segítségével
      3. Dokumentumok létrehozása
      4. Eszköztár
      5. Alapértelmezett billentyűparancsok
      6. Billentyűparancsok testreszabása
      7. A rajztáblák bemutatása
      8. Rajztáblák kezelése
      9. Munkaterület testreszabása
      10. Tulajdonságok panel
      11. Beállítások megadása
      12. Érintés munkaterület
      13. Microsoft Surface Dial-támogatás az Illustrator alkalmazásban
      14. Szerkesztések visszavonása és a tervezési előzmények kezelése
      15. Nézet elforgatása
      16. Vonalzók, rácsok és segédvonalak
      17. Akadálymentesség az Illustrator alkalmazásban
      18. Biztonságos mód
      19. Grafika megtekintése
      20. Az Illustrator használata a Touch Barral
      21. Fájlok és sablonok
    3. Eszközök az Illustrator programban
      1. Az eszközök áttekintése
      2. Kijelölő eszközök
        1. Kijelölés
        2. Közvetlen kijelölés
        3. Csoport kijelölése
        4. Varázspálca
        5. Lasszó
        6. Rajztábla
      3. Navigációs eszközök
        1. Kéz
        2. Nézet elforgatása
        3. Kicsinyítés/nagyítás
      4. Festési eszközök
        1. Színátmenet
        2. Háló
        3. Alakzatformáló
      5. Szöveg eszközök
        1. Szöveg
        2. Görbére írt szöveg
        3. Függőleges szöveg
      6. Rajzeszközök
        1. Toll
        2. Szerkesztőpont hozzáadása
        3. Szerkesztőpont törlése
        4. Szerkesztőpont
        5. Görbület
        6. Vonalszegmens
        7. Téglalap
        8. Lekerekített téglalap
        9. Ellipszis
        10. Sokszög
        11. Csillag
        12. Ecset
        13. Pacaecset
        14. Ceruza
        15. Shaper
        16. Szelet
      7. Módosítás eszközök
        1. Forgatás
        2. Tükrözés
        3. Méretezés
        4. Nyírás
        5. Szélesség
        6. Szabad átalakítás
        7. Pipetta
        8. Keverés
        9. Radír
        10. Olló
    4. Gyorsműveletek
      1. Retro szöveg
      2. Neonfényű szöveg
      3. Régies szöveg
      4. Átszínezés
      5. Vázlat átalakítása vektorrá
  3. Az iPadhez készült Illustrator
    1. Az iPadhez készült Illustrator bemutatása
      1. Az iPadhez készült Illustrator áttekintése
      2. Az iPadhez készült Illustrator – GYIK
      3. Rendszerkövetelmények | Az iPadhez készült Illustrator
      4. Mit tehet vagy mit nem tehet az iPadhez készült Illustrator alkalmazásban
    2. Munkaterület
      1. iPadhez készült Illustrator munkaterülete
      2. Érintéses gyorsbillentyűk és ujjmozdulatok
      3. Billentyűparancsok az iPadhez készült Illustrator programban
      4. Az alkalmazásbeállítások kezelése
    3. Dokumentumok
      1. Dokumentumokkal végzett munka az iPadhez készült Illustratorban
      2. A Photoshop- és a Fresco-dokumentumok importálása
    4. Objektumok kiválasztása és elrendezése
      1. Ismétlődő objektumok létrehozása
      2. Objektumok keverése
    5. Rajzolás
      1. Görbék rajzolása és szerkesztése
      2. Alakzatok rajzolása és szerkesztése
    6. Szöveg
      1. Műveletek szöveggel és betűtípusokkal
      2. Szövegtervek létrehozása egy görbe mentén
      3. Saját betűtípusok hozzáadása
    7. Képekkel végzett munka
      1. Raszterképek vektorizálása
    8. Szín
      1. Színek és színátmenetek alkalmazása
  4. Felhőalapú dokumentumok
    1. Alapvető tudnivalók
      1. Az Illustrator felhőalapú dokumentumainak kezelése
      2. Illustrator felhőalapú dokumentumainak megosztása és együttműködés azokon
      3. Dokumentumok megosztása véleményezésre
      4. Felhőtárhely frissítése az Adobe Illustratorhoz
      5. Felhőalapú Illustrator-dokumentumok | Gyakori kérdések
    2. Hibaelhárítás
      1. Az Illustrator felhőalapú dokumentumainak létrehozásával vagy mentésével kapcsolatos hibák elhárítása
      2. Hibaelhárítás – Illustrator felhőalapú dokumentumokkal kapcsolatos hibái
  5. Tartalom hozzáadása és szerkesztése
    1. Rajzolás
      1. A rajzolás alapjai
      2. Görbék szerkesztése
      3. Képpont-tökéletes grafika rajzolása
      4. Rajzolás a Toll, a Görbület vagy a Ceruza eszközzel
      5. Egyszerű vonalak és formák rajzolása
      6. Képkontúrozás
      7. Görbe egyszerűsítése
      8. Perspektívarácsok meghatározása
      9. Szimbólumeszközök és szimbólumkészletek
      10. Görbeszegmensek módosítása
      11. Készítsen virágot 5 egyszerű lépéssel
      12. Perspektivikus rajzolás
      13. Szimbólumok
      14. Képpontra igazított görbék rajzolása internetes munkafolyamatokhoz
    2. 3D objektumok és anyagok
      1. Ismerje meg az Illustrator 3D-s hatásait
      2. 3D-s grafikák létrehozása
      3. Rajzelem leképezése 3D objektumokon
      4. 3D szöveg létrehozása
    3. Szín
      1. A színek ismertetése
      2. Színek kijelölése
      3. Színtárak használata és létrehozása
      4. Színek beállítása
      5. Az Adobe Color témák panel használata
      6. Színcsoportok (harmóniák)
      7. Színtémák panel
      8. Grafika átszínezése
    4. Festés
      1. Festés ismertetése
      2. Festés kitöltésekkel és ecsetvonásokkal
      3. Élő festési csoportok
      4. Színátmenetek
      5. Ecsetek
      6. Átlátszóság és keverési módok
      7. Ecsetvonás alkalmazása egy objektumon
      8. Mintázatok létrehozása és szerkesztése
      9. Hálók
      10. Mintázatok
    5. Objektumok kiválasztása és elrendezése
      1. Objektumok kijelölése
      2. Rétegek
      3. Objektumok csoportosítása és kibontása
      4. Objektumok mozgatása, igazítása és szétosztása
      5. Objektumok halmozása    
      6. Objektumok zárolása, elrejtése és törlése
      7. Objektumok másolása és megkettőzése
      8. Objektumok forgatása és tükrözése
      9. Tárgyak összefonása
    6. Objektumok átformálása
      1. Képek vágása
      2. Objektumok átalakítása
      3. Objektumok kombinálása
      4. Objektumok kivágása, felosztása és körülvágása
      5. Bábu hajlítása
      6. Objektumok méretezése, nyírása és torzítása
      7. Objektumok keverése
      8. Átformálás burkológörbék használatával
      9. Objektumok átformálása hatásokkal
      10. Új alakzatok készítése a Shaper és az Alakzatformáló eszközzel
      11. Élő sarkok használata
      12. Továbbfejlesztett újraformáló munkafolyamatok érintés támogatásával
      13. Vágómaszkok szerkesztése
      14. Élő alakzatok
      15. Alakzatok létrehozása az Alakzatformáló eszközzel
      16. Globális szerkesztés
    7. Szöveg
      1. Szöveg hozzáadása és a szövegobjektumokkal végzett munka
      2. Felsorolásjeles és számozott listák létrehozása
      3. A szövegterület kezelése
      4. Betűtípusok és tipográfia
      5. Szöveg formázása
      6. Szöveg importálása és exportálása
      7. Bekezdésformázás
      8. Speciális karakterek
      9. Görbére írt szöveg létrehozása
      10. Karakter- és bekezdésstílusok
      11. Tabulátorok
      12. Szöveg és típus
      13. Hiányzó betűtípusok keresése (Typekit munkafolyamat)
      14. Az Illustrator 10 verzióból származó szövegek frissítése
      15. Arab és héber szöveg
      16. Betűtípusok | GYIK és hibaelhárítási tippek
      17. 3D-s szöveghatás létrehozása
      18. Kreatív tipográfiai tervek
      19. Szöveg méretezése és elforgatása
      20. Sortávolság és karaktertérköz
      21. Elválasztás és sortörések
      22. Szöveg fejlesztések
      23. Helyesírás és nyelvi szótárak
      24. Ázsiai karakterek formázása
      25. Tördelők ázsiai típusú írásokhoz
      26. Szöveges tervek készítése objektumok keverésével
      27. Szöveges poszter létrehozása a Kép kontúrozása használatával
    8. Speciális effektusok létrehozása
      1. Hatásokkal való munka
      2. Grafikus stílusok
      3. Vetett árnyék létrehozása
      4. Megjelenési jellemzők
      5. Vázlatok és mozaikok létrehozása
      6. Vetett árnyékok, ragyogások és lágy perem
      7. Hatások összefoglalása
    9. Webgrafikák
      1. Gyakorlati tanácsok webgrafikák készítéséhez
      2. Diagramok
      3. SVG
      4. Animációk létrehozása
      5. Szeletek és képzónák
  6. Importálás, exportálás és mentés
    1. Importálás
      1. Több fájl elhelyezése
      2. Csatolt és beágyazott fájlok kezelése
      3. Hivatkozásinfó
      4. Képek beágyazásának megszüntetése
      5. Grafikák importálása a Photoshopból
      6. Bittérképek importálása
      7. Adobe PDF-fájlok importálása
      8. EPS-, DCS- és AutoCAD-fájlok importálása
    2. Creative Cloud Libraries az Illustrator alkalmazásban 
      1. Creative Cloud Libraries az Illustrator alkalmazásban
    3. Mentés
      1. Grafika mentése
    4. Exportálás
      1. Illustratorban készített tartalom használata a Photoshopban
      2. Grafika exportálása
      3. Kellékek összegyűjtése és exportálása kötegelve
      4. Csomagfájlok
      5. Adobe PDF fájlok létrehozása
      6. CSS kinyerése | Illustrator CC
      7. Adobe PDF-beállítások
      8. Fájlinformációk és -metaadatok
  7. Nyomtatás
    1. Előkészületek a nyomtatáshoz
      1. Dokumentumok beállítása nyomtatáshoz
      2. Az oldal méretének és tájolásának módosítása
      3. Vágójelek meghatározása körülvágáshoz és igazításhoz
      4. Első lépések nagyméretű rajzvászonnal
    2. Nyomtatás
      1. Felülnyomás
      2. Nyomtatás színkezeléssel
      3. PostScript-nyomtatás
      4. Nyomtatási készletek
      5. Nyomtatási jelek és kifutók
      6. Áttetsző grafikák nyomtatása és mentése
      7. Alátöltés
      8. Színkivonatok nyomtatása
      9. Színátmenetek, hálók és színkeverések nyomtatása
      10. Fehér felülnyomás
  8. Feladatok automatizálása
    1. Adategyesítés a Változók panel használatával
    2. Automatizálás parancsfájlokkal
    3. Automatizálás műveletekkel
  9. Hibaelhárítás 
    1. Összeomlási problémák
    2. Fájlok helyreállítása az összeomlás után
    3. Fájllal kapcsolatos problémák
    4. Támogatott fájlformátumok
    5. GPU-kártya eszközillesztővel kapcsolatos problémák
    6. Wacom eszközzel kapcsolatos problémák
    7. DLL-fájllal kapcsolatos problémák
    8. Memória-problémák
    9. Beállításfájl-problémák
    10. Betűtípus-problémák
    11. Nyomtatóproblémák
    12. Ossza meg az összeomlási jelentést az Adobe-bal
    13. Az Illustrator teljesítményjavítása

Egyesítsen Illustrator-dokumentumot adatforrásfájllal (CSV- vagy XML-fájllal) a Változók panel segítségével, hogy több variációt hozhasson létre grafikából. Megváltoztathatja a résztvevők nevét az eseményjelvényeken vagy módosíthatja a képet a webes szalagcímeken és a képeslapokon anélkül, hogy újra el kellene készíteni a grafikát. Hozzon létre egy dizájnt és a nevek vagy az adatforrásfájl képeinek importálásával hozzon létre gyorsan változatokat.

A Változók panel segítségével létrehozhat egyedi változatokat a különböző projektekhez, például nyomtatható poszterekhez, web szalagcímekhez és eseményjelvényekhez tartozó tervezői sablonjaiból.

Mielőtt továbblépne

Az adategyesítéshez mindössze az adatforrásfájlra és a céldokumentumra van szükség. 

  • Az adatforrásfájl tartalmazza a céldokumentum egyes verzióiban eltérő információkat, például a körlevelek címzettjeinek nevét és címét. Az adatforrásfájl lehet vesszővel tagolt (.csv) vagy Extensible Markup Language (.xml) formátumú fájl.
  • A céldokumentum egy Illustrator dokumentum, amely tartalmazza a sablonként használandó alapgrafikát. Ez a dokumentum tartalmazhatja az adatmező helyőrzőt és azokat az elemeket, amelyek az egyesített dokumentum minden verziójában változatlanok maradnak.

Hozzáférés az adategyesítés funkcióhoz

Az adategyesítés az llustrator Változók paneléről érhető el (Ablak> Változók). A dokumentumban lévő minden változó típusa és neve megjelenik a panelen lévő listában. Ha a változó egy objektumhoz kapcsolódik, akkor az Objektumok oszlopban megjelenik az objektum neve (ahogy az a Rétegek panelen is megjelenik). A sorokat a fejlécen lévő elemekre kattintva rendezheti: a változónév, az objektumnév vagy a változótípus szerint.

Változók panel

A. Adatkészlet B. Panelmenü C. Váltás adatkészletek között D. Kötött objektum neve E. Változó neve F. Változó típusa G. Változók zárolása H. Objektum dinamikussá tétele I. Láthatóság dinamikussá tétele J. Változók leválasztása K. Változók létrehozása L. Változók törlése 

Gyorsműveletek adategyesítéshez

  1. Hozzon létre egy Illustrator-dokumentumot a sablon használatához.

  2. Készítse el az adatforrásfájlt CSV- vagy XML-formátumban. További információt az Adatforrásfájl előkészítése című szakaszban olvashat.

  3. Importáljon egy adatforrásfájlt az Illustratorban a Változók panel használatával. További információt az Adatforrásfájl importálása című szakaszban olvashat.

  4. Kössön egy változót a sablonjában lévő objektumhoz. További információkat a Változók kötése objektumhoz című szakaszban olvashat.

  5. Tekintse meg a dokumentum előképét mindegyik adatkészlettel, mielőtt az összes fájlt exportálná. További információkat a Dokumentum előképének megtekintése mindegyik adatkészlettel című szakaszban olvashat.

  6. Exportáljon az adatokból kötegelt fájlokat a Műveletek panelt használva az Illustratorban. További információkat a Fájlok exportálása a Műveletek panel használatával című szakaszban olvashat.

Adatforrásfájl előkészítése

Az adatforrásfájlokat vesszővel tagolt (.csv) vagy Extensible Markup Language (.xml) formátumban kell elmenteni.

CSV forrásfájlok létrehozása

A vesszővel tagolt (.csv) fájlban a rekordokat bekezdésjelek választják el, a mezőket pedig vesszők vagy tabulátorok. Az adatforrásfájl tartalmazhat a lemezen található képekre utaló szöveget vagy elérési utakat is. CSV-fájl importálása előtt tegye a következőt, hogy az Illustrator azonosítani tudja a változó típusát.

  1. Nyissa meg a számolótáblát.

  2. Adja meg az adatmező nevét a számolótábla első sorában. Majd tegye a következőt:

    • A képfájlokra utaló szöveg vagy elérési utak beszúrásához az adatmező neve elejére írjon „kukac” (@) jelet. A @ csak az első sorban szükséges, a következő sorokban a képek elérési útjai lesznek.
    • Ehhez hasonlóan az adatmező neve elejére írjon százalék jelet (%) a diagramok és kettős kereszt jelet (#) a láthatóság érdekében.
    • Az objektumok láthatóságának meghatározásához adjon meg igaz vagy hamis értéket minden adatmezőhöz.
    Megjegyzés:
    • A számolótábla adatmező neve nem tartalmazhat szóközt. Az adatmezőt például megadhatja Vállalat_neve formátumban a Vállalat neve formátum helyett. 
    • A kép elérési útvonala ugyancsak nem tartalmazhat szóközt. Például a kép elérési útvonala C:\Photos\Bill Tucker helyett lehet C:\Photos\BillTucker.
    • Az adatforrásfájlból csatolt grafikus fájlokat vesszővel tagolt (.csv) fájlként kell elmenteni.
    • Ha hiba jelenik meg a @ jel beírása után, írjon aposztrófot (') a @ elé (például: '@Fénykép). Bizonyos alkalmazások, például a Microsoft Excel, a @ jelet függvények számára tartják fenn.

    (Windows) Példa adatforrásfájlba helyezett kép- és grafikahivatkozásokra

    Név

    Kor

    @Fénykép

    %Diagramok

    #Láthatóság

    Bill Tucker

    36

    C:\Photos\BillTucker.jpg

    C:\Photos\BillTucker.csv

    Igaz

    Dat Nguyen

    53

    C:\MyDocuments\dat.jpg

    C:\MyDocuments\dat.csv

    Igaz

    Maria Ruiz

    26

    C:\Photos\Ruiz.jpg

    C:\Photos\Ruiz.csv

    Hamis

    (macOS) Példa adatforrásfájlba helyezett kép- és grafikahivatkozásokra

    Név

    Kor

    @Fénykép

    %Diagramok

    #Láthatóság

    Bill Tucker

    36

    /Users/photos/BillTucker.jpg

    /Users/photos/BillTucker.csv

    Igaz

    Dat Nguyen

    53

    /Users/family/photos/dat.jpg

    /Users/family/photos/dat.csv

    Igaz

    Maria Ruiz

    26

    /Users/alpha/photos/Ruiz.jpg

    /Users/alpha/photos/Ruiz.csv

    Hamis

  3. Írja be az adatot a számolótáblába.

  4. Tegye az alábbiak egyikét:

    • A létrehozott munkafüzeteket a Microsoft Excel legújabb verzióját (2016-os kiadás) használva az alábbi fájlformátumok egyikébe mentse el:
      • CSV (vesszővel tagolt) (*.csv)
      • CSV (MS-DOS) (*.csv)
    • Mentse el a létrehozott számolótáblát Apple-számok használatával Unicode (UTF-8) kódolású CSV-formátumban.
    Megjegyzés:

    Jelenleg az Illustrator csak az említett formátumba kiexportált CSV-fájlokat támogatja. A rendszer az egyéb CSV-fájlformátumokat, így például a Macintosh Comma Separated (.csv) fájlokat nem támogatja az adategyesítésnél.

XML-fájl előkészítése

  1. Definiáljon egy változót a dokumentumban. A további tudnivalókat lásd a Változók kötése objektumhoz szakaszban.

  2. Válassza az Adatkészlet rögzítése  gombot a Változók panelen.

  3. A kívánt számú adatkészlet elkészítését követően az adatkészlet XML-fájlként történő mentése érdekében válassza ki a Változókönyvtár mentése lehetőséget a Változók panel menüjéből. Adja meg a fájl nevét és helyét, majd válassza a Mentés gombot.

    Illustratorban létrehozott változók exportálása XML-fájlként

  4. Most szerkessze az XML-fájlt egy szövegszerkesztő alkalmazással, például Notepad++ (Windows) vagy TextWrangler (macOS) használatával, hogy az adatkészletek bekerüljenek ebbe a fájlba.

    Példa: XML-fájl szerkesztése bármely szövegszerkesztő alkalmazással

    A. Cserélje ki a képfájl elérési útvonalát B. Cserélje ki a szöveget  

  5. Válassza a Változókönyvtár betöltése elemet a Változók panelmenüből az XML-fájl Illustratorba történő importálásához. Jelölje ki az XML-fájlt, majd válassza a Megnyitás gombot.

    Változók importálása az Illustratorba

Adatforrásfájl importálása

A változóknak a kívánt adathoz kötéséhez importálja az adatforrást a Változók panelen. Dokumentumonként csak egy adatforrásfájlt választhat.

  1. Válassza az Ablak > Változók lehetőséget.

  2. A Változók panelen válassza az Importálás lehetőséget.

  3. A Változókönyvtár betöltése párbeszédpanelen válassza ki az adatforrásfájlt CSV- vagy XML-formátumban, és válassza a Megnyitás gombot.

  4. Az adatkészlet későbbi módosításához, átnevezéséhez vagy törléséhez ki kell azt választani az Adatkészlet legördülő menüből, majd meg kell adni a beállításait.

    • Válasszon ki egy adatkészletet az Adatkészlet listából a Változók panelen az adatkészletek közötti váltáshoz. Kiválaszthatja az Előző adatkészlet  gombot vagy a Következő adatkészlet  gombot.
    • Ha a rajztáblán lévő adatokat az aktuális adatkészletre szeretné alkalmazni, válassza az Adatkészlet frissítése lehetőséget a Változók panelmenüből.
    • Adatkészlet átnevezéséhez közvetlenül szerkessze a szöveget az Adatkészlet szövegmezőben. Kattinthat duplán az Adatkészlet szóra (az Adatkészlet szövegmező bal oldalán) is, beírhat egy új nevet, és az OK gombra kattinthat.
    • Ha törölni szeretne egy adatkészletet, válassza a Törlés ikont. Az Adatkészlet törlése lehetőséget is kiválaszthatja a Változók panelmenüből.
    Megjegyzés:

    Az Excelben létrehozott, kétbájtos karaktereket tartalmazó CSV (UTF-8 vesszővel tagolt) fájlok nem importálhatók a Változók panelen. Ha ugyanazt a fájlt szöveges formátumban nyitja meg, majd CSV-ként menti UTF-8 kódolással, a fájl importálása megfelelően történik.

Változók kötése objektumhoz

Használjon változókat a módosítani kívánt sablon elemeinek meghatározására. Négyféle változót határozhat meg: láthatósági változó, szöveges karaktersorozat típusú változó, csatolt fájl típusú változó és diagramadat típusú változó. A változó típusa jelöli, hogy mely objektumjellemzők módosíthatók (azaz dinamikusak). A dokumentumban lévő minden változó típusa és neve megjelenik a panelen lévő listában. Ha a változó egy objektumhoz kapcsolódik, akkor az Objektumok oszlopban megjelenik az objektum neve (ahogy az a Rétegek panelen is megjelenik).

Változó típusa

A változó típusát jelölő ikon

Meghatározás

Láthatósági változók

Grafika megjelenítése vagy elrejtése.

Szöveges karaktersorozat típusú változók

Szöveg cseréje.

Csatolt fájl típusú változók

A rajztáblán lévő objektum cseréje egy másik fájlból származó objektummal.

Diagramadat típusú változók

Egy diagramban lévő értékek cseréje.

Típus nélküli (kötetlen) változó

Egy objektumhoz sincs kötve.

Kövesse az alábbi lépéseket a változók Illustratorban történő meghatározásához:

  1. Jelöljön ki egy objektumot.

  2. A Változók panelen (Window > Változók) válassza ki azt a változót, amelyikkel kötni szeretné.

  3.  Válassza az Objektum dinamikussá tétele  gombot az objektum változóval való összekapcsolásához.

Kövesse az alábbi lépéseket változó létrehozásához anélkül, hogy objektumhoz kötné:

  1. Válassza az Új változó  gombot a Változók panelen.

  2. Ha később egy objektumot szeretne a változóhoz kötni, jelölje ki az objektumot és a változót, majd válassza a Láthatóság dinamikussá tétele  gombot vagy az Objektum dinamikussá tétele  gombot.

Megjegyzés:

A változónevek nem támogatják a helyettesítő pár és a 4 bájtos karaktereket. Ha ezeket a karaktereket változónévben használja, hibaüzenet jelenik meg.

Változókkal való munka

A Változók panelen módosíthatja a változók nevét és típusát, valamint leválaszthat vagy lezárhat egy változót.

A változó leválasztása megszakítja a kapcsolatot a változó és a hozzá kötött objektum között. A lezárás megakadályozza a változók létrehozását, törlését és a változók beállításainak módosítását. Ugyanakkor hozzárendelhet és leválaszthat objektumokat a zárolt változókról.

Változó nevének és típusának módosítása

  1. Válassza ki a változót a Változók panelen, és válassza a Változó beállításai lehetőséget a panelmenüről.

Változó leválasztása

  1. Válassza a Változó leválasztása  gombot a Változók panelen.

A dokumentumban található összes változó lezárása és feloldása

  1. Válassza a Változók zárolása  gombot vagy a Változók feloldásagombot a Változók panelen.

Változók törlése

Töröljön egy változót, hogy eltávolítsa azt a Változók panelről. Ha egy objektumhoz rendelt változót töröl, akkor az objektum statikussá válik (hacsak nincs az objektum egy másik típusú változóhoz is kötve).

  1. Jelölje ki a törölni kívánt változót.

  2. Végezze el az alábbi opciók egyikét:

    • Válassza a Változó törlése  gombot a Változók panelen.

    • Ha megerősítés nélkül kívánja törölni a változót, húzza azt a Változó törlése  gombra.

Dinamikus objektumok szerkesztése

A változóhoz társított adatok a hozzájuk kötött objektumok szerkesztésével módosíthatók. Ha például egy Láthatósági változóval dolgozik, az objektum láthatósági állapotát a Rétegek panelen módosíthatja. A dinamikus objektumok szerkesztésével több adatkészletet is létrehozhat a sablonban.

  1. Jelöljön ki egy dinamikus objektumot a rajztáblán, vagy tegye a következők egyikét egy dinamikus objektum automatikus kijelöléséhez:

    • Az Alt billentyű (Windows) vagy Option billentyű (macOS) lenyomva tartása mellett kattintson egy változóra aVáltozók panelen.

    • Jelöljön ki egy változót a Változók panelen, és a Változók panel menüjéből válassza a Kötött objektumok kijelölése menüpontot a Változók panelmenüből.

    • Válassza az Összes kötött objektum lehetőséget a Változók panelmenüből az összes dinamikus objektum kiválasztásához.

  2. Az objektumhoz társított adatokat a következőképpen szerkesztheti:

    • Szerkessze a szöveges karaktersorozatot a rajztáblán.

    • Cserélje ki a képet a Linkek panelre vagy a Fájl > Hely parancsra a hivatkozott fájlokhoz.

    • Szerkessze a diagramok adatait a Diagramadatok párbeszédpanelen.

    • A dinamikus láthatóságú objektumok esetén módosítsa az objektum láthatósági állapotát a Rétegek panelen.

Dinamikus objektumok azonosítása XML-azonosítók használatával

A Változók panel a dinamikus objektumok nevét a Rétegek panelen való megjelenésüknek megfelelően jeleníti meg. Ha a sablont SVG formátumba menti, hogy más Adobe-termékekben is használni tudja, ezeknek az objektumneveknek meg kell felelniük az XML-elnevezési szabályoknak. Az XML-neveknek például betűvel, aláhúzással vagy kettősponttal kell kezdődniük, és nem tartalmazhatnak szóközöket.

Az Illustrator automatikusan egy érvényes XML azonosítót rendel minden létrehozott dinamikus objektumhoz. Ha az objektumokat XML azonosítókkal kívánja megtekinteni, szerkeszteni vagy exportálni, válassza a Szerkesztés > Beállítások > Mértékegységek (Windows) vagy az Illustrator > Beállítások > Mértékegységek (Mac OS) menüpontot, és válassza az XML azonosító lehetőséget.

Tekintse meg a dokumentum előképét mindegyik adatkészlettel

A végleges grafika kinézetét megtekintheti oly módon, hogy az összes fájl exportálása előtt megtekinti az előképet. Használja a Változók panelen lévő Adatkészlet melletti nyíl billentyűket, hogy a dokumentumában lévő kívánt adatkészletre navigáljon, és megtekintse annak előnézetét.

Fájlok exportálása a Műveletek panel használatával

Változók és egy vagy több adatkészlet meghatározása után kötegelt üzemmódban kimenetként létrehozható a grafika az adatkészletértékekkel. Tegye az alábbiakat:

  1. A Műveletek panelt (Ablak > Műveletek) használva rögzítsen egy műveletet, hogy a kívánt formátumban mentse el a dokumentumát. A részletekért lásd: Automatizálás műveletekkel.

  2. Válassza a Kötegelés lehetőséget a Műveletek panel menüből, és jelölje ki az előző lépésben létrehozott műveletet.

  3. A Forráshoz jelölje ki az Adatkészletek elemet, hogy az aktuális fájlban lévő minden adatkészleten végrehajtsa a műveletet.

  4. A Cél területen adja meg, hogy mit kíván tenni a feldolgozott fájlokkal. Nyitva hagyhatja a fájlt a változtatások mentése nélkül (Nincs), mentheti a jelenlegi helyre és bezárhatja a fájlt (Mentés és bezárás), vagy a fájlokat egy másik helyre mentheti (Mappa).

    A Cél beállítástól függően további fájlmentési beállításokat is megadhat. További információkért lásd: Műveletsor végrehajtása kötegelt fájlokon.

  5. Válassza az OK lehetőséget.

Mentse el a sablont adategyesítéshez

Amikor változókat definiál egy Illustrator-dokumentumban, sablont készít adategyesítéshez. A sablont SVG formátumban mentheti, hogy más Adobe-termékekkel, például az Adobe® Graphics Server alkalmazással is használhassa. Például az Adobe Graphics Server programmal dolgozó fejlesztők az SVG fájlban szereplő változókat közvetlenül adatbázishoz vagy más adatforráshoz köthetik.

  1. Válassza a Fájl > Mentés másként menüpontot, adjon meg fájlnevet, állítsa be fájltípusként az SVG formátumot, végül kattintson a Mentés gombra.

  2. Kattintson a Több beállítás gombra, és jelölje ki az Adobe Graphics Server adatok felvétele beállítást. Ez a beállítás tartalmaz minden információt, ami az SVG fájlban történő változóbehelyettesítéshez szükséges.

  3. Kattintson az OK gombra.

Problémák merültek fel a CSV-fájl importálásakor?

Ha a következő hibaüzenetet kapja: A bejövő változókönyvtár érvénytelen a CSV adatforrásfájl feltöltésekor, akkor ellenőrizze az alábbiakat:

  • A CSV-fájl nem üres.
  • A Microsoft Excel legújabb verziójával létrehozott munkafüzetek CSV (vesszővel tagolt) (*.csv) vagy CSV (MS-DOS) (*.csv) formátumban, az Apple Numbers alkalmazással létrehozott munkafüzetek pedig Unicode (UTF-8) kódolású CSV formátumban lettek elmentve. Az egyéb CSV fájlformátumokba, így például a Macintosh Comma Separated (.csv) formátumba mentett adatforrásfájlok az adategyesítésnél nem támogatottak.
  • Minden oszlop rendelkezik egy adatmezőnévvel. Az Illustrator például megjelenít egy hibaüzenetet, amikor az adatforrásfájl egyik oszlopában adatok vannak, de adatmezőnévvel nem rendelkezik.
  • A kitöltött oszlopok között nincs üres oszlop az adatforrásfájlban. Az Illustrator például megjelenít egy hibaüzenetet, amikor az adatforrásfájl B és D oszlopában vannak adatok, de a C oszlop üres.
Példa: hibák a CSV forrásfájl adategyesítéshez történő beállításánál

A. Hiányzik az egyik oszlop adatmezőneve B. A kitöltött oszlopok között van egy üres oszlop 

  • A munkafüzet adatmezőnevei nem tartalmaznak szóközt.
  • A forrásfájl kép- vagy grafikafájlokra mutató elérési útvonala nem tartalmaz szóközt.
  • Az adatforrásfájlból csatolt grafikus fájlokat vesszővel tagolt (.csv) fájlként kerülnek elmentésre.

kapcsolódó források

Beszéljen velünk

Szeretnénk Öntől hallani. Ossza meg gondolatait az Adobe Illustrator közösségben

Adobe logó

Bejelentkezés a fiókba