Photoshop e Catalina | macOS 10.15

Quais versões do Photoshop são compatíveis com o macOS Catalina?

Photoshop 21.0 e Photoshop 20.0.7 são compatíveis com o macOS 10.15 (Catalina), mas apresentam esses problemas de compatibilidade conhecidos. Você pode permanecer na versão atual do macOS até que estes problemas sejam resolvidos.

A Adobe recomenda com ênfase que os clientes façam seus próprios testes em uma partição que não seja de produção para assegurar que os novos sistemas operacionais funcionem com o hardware e drivers atuais (impressão, etc.).  

Se encontrar problemas que ainda não estão documentados aqui, sinta-se à vontade para informá-los no nosso site de feedback.

As versões legadas ou permanentes do Photoshop são compatíveis com o macOS Catalina?

Não, as versões legadas/permanentes do Photoshop não foram projetadas ou testadas para funcionar no macOS 10.15 (Catalina). Elas não são suportadas de forma alguma para uso no macOS Catalina.

A Adobe não recomenda que os clientes que usam versões antigas do Photoshop atualizem para o macOS Catalina.

As versões incompatíveis (versão 19.x e anterior) não serão exibidas na lista “Versões antigas” no aplicativo de desktop Creative Cloud.

As versões antigas usam componentes e instaladores de licenciamento de 32 bits. Portanto, elas não podem ser instaladas e ativadas após a atualização para o macOS Catalina. A atualização para o macOS Catalina com uma versão mais antiga já instalada no computador pode permitir que o aplicativo funcione de alguma forma, no entanto, você não poderá reinstalar nem ativar o aplicativo após a atualização do macOS.

Antes de atualizar para o macOS Catalina, você pode desinstalar as versões mais antigas, pois o desinstalador não funcionará após a atualização. Se já tiver atualizado para o macOS Catalina, você pode usar a ferramenta Creative Cloud Cleaner Tool para desinstalar as versões mais antigas.

Problemas de GPU no macOS Catalina

Problema

Soluções alternativas

Você pode encontrar problemas de GPU ao usar o Photoshop no macOS 10.15.7.

Atualize o macOS para a versão 11.3 (Big Sur).
Caso não seja possível atualizar para a versão 11.3 do macOS, siga a solução descrita em Photoshop e Catalina.

O conteúdo do documento falha ao atualizar quando as guias de alternância e/ou outros painéis estão em branco/vazios

Problema

Soluções alternativas

No macOS 10.15 Catalina, a janela do documento não é atualizada com o conteúdo correto da imagem ao alternar entre guias, ou a janela do documento e/ou outros painéis estão em branco/vazios.

Atualizar para o macOS 10.15.4

Erro em Salvar na Web do Adobe

Ao usar o Photoshop no macOS 10.15.x e selecionar Arquivo > Exportar > Salvar na Webocorre o erro “Erro em Salvar na Web do Adobe: Não foi possível concluir esta operação. Ocorreu um erro desconhecido."

Soluções alternativas

Verifique se o nome do arquivo que você abriu, o nome do arquivo que você está exportando a partir de Salvar na Web e a pasta na qual você está salvando são alfanuméricos (apenas números e letras) e não contêm caracteres especiais, como # e %.

Solução

Atualize para a versão mais recente do Photoshop e atualize para a versão atual do macOS.

Erro em Salvar para Web da Adobe: Não foi possível concluir esta operação. Ocorreu um erro desconhecido.
Erro em Salvar para Web da Adobe: Não foi possível concluir esta operação. Ocorreu um erro desconhecido.

A renderização do vídeo se inicia, mas nunca é concluída

Ao selecionar Arquivo> Exportar > Renderizar vídeo..., o processo nunca é concluído.

Solução

Atualizar para o Photoshop 21.x

Solução alternativa para a versão 20.0.7 ou anterior

No Finder, inicie as Preferências do sistema e vá até Segurança e privacidade > guia Privacidade> Acesso total ao disco. Clique no ícone de cadeado no canto inferior esquerdo, digite seu nome de usuário e senha de administrador. Clique no ícone + e adicione o Photoshop para conceder acesso ao seu disco rígido.

Segurança e privacidade

As opções de nomenclatura de arquivos não funcionam corretamente na caixa de diálogo Salvar como

No Photoshop 20.0.6, alterar o formato do arquivo não altera a extensão do arquivo no campo de nome.

Solução

Atualizar para o Photoshop 21.x ou Photoshop 20.0.7. A extensão do arquivo está oculta por padrão, mas corresponderá automaticamente ao formato selecionado no pop-up Formato.

Observação:

O Photoshop não poderá abrir um arquivo se a extensão não corresponder ao formato do arquivo, causando os seguintes erros:

Se um arquivo já tiver sido salvo com uma extensão incompatível, ele pode ser renomeado com a extensão correta e será aberto no Photoshop.

Se você não conseguir se lembrar de que tipo deveria ser o arquivo real, consulte Determinar o tipo de arquivo de um documento.

 

Os droplets não funcionam

Os droplets são iniciados, mas não são executados.

Solução

Atualize para o Photoshop 21.x ou Photoshop 20.0.7 e recrie os droplets.

O seletor de cores da Apple causa falha

Se você selecionar Preferências > Geral... e definir o Seletor de cores como “Apple”, na segunda vez em que abrir o seletor de cores, o Photoshop falhará.

Solução

Atualize para o Photoshop 21.x ou Photoshop 20.0.7.

 

Outros problemas corrigidos

Consulte Problemas corrigidos na versão de outubro de 2019 (versão 20.0.7) para obter detalhes adicionais.

Problemas de compatibilidade conhecidos

A Adobe descobriu os problemas de compatibilidade listados abaixo ao executar o Photoshop 20.0.7 ou posterior no macOS 10.15 (Catalina).

Ocorre um erro fatal com o Photoshop ao iniciar ou aleatoriamente durante o uso

Ocorre um erro fatal com o Photoshop no macOS 10.15.7 ao iniciar ou aleatoriamente durante o uso.

Solução

Atualize o macOS para a versão 11.3.

Soluções alternativas

Caso não seja possível atualizar o macOS para 11.3, faça o seguinte:

  1. Inicie o Photoshop.
  2. Vá para Preferências > Desempenho > Configurações avançadas e desmarque a caixa de seleção Usar OpenCL.
  3. Reinicie o Photoshop.

Caso não seja possível iniciar o Photoshop para concluir a etapa 2 acima, reinicie o computador e tente novamente.

Informações adicionais

Os dados do OpenCL no MacOS 10.15.7 podem ser corrompidos, causando erros nos aplicativos que dependem do OpenCL para aprimorar seus recursos. Este problema foi corrigido no macOS 11.3.

Marcar “Como cópia” não acrescenta o sufixo “cópia” no nome do arquivo

Marcar “Como cópia” na caixa de diálogo Salvar como não acrescenta o sufixo “cópia” no nome do arquivo.

Solução

Atualize para o Photoshop 22.4 ou posterior e use o novo comando Salvar uma cópia.

Para saber mais, consulte em Salvar seus arquivos no Photoshop.

Soluções alternativas

Edite manualmente o nome e adicione “cópia” ou altere o nome para um nome exclusivo.

Não é possível substituir um arquivo existente ao salvar com o mesmo nome de arquivo

O Photoshop salva uma cópia em vez de substituir um arquivo existente com o mesmo nome.

Solução

Atualize para o Photoshop 22.4 ou posterior e use o novo comando Salvar uma cópia.

Para saber mais, consulte em Salvar seus arquivos no Photoshop.

Soluções alternativas

Siga algum destes procedimentos:

  • Renomeie manualmente o arquivo salvo e remova “cópia” do nome do arquivo.
  • Salve o arquivo em outro local.

O salvamento não é concluído ao salvar em uma unidade formatada exFAT

Salvar arquivos em unidades externas formatadas exFAT pode congelar antes que o arquivo seja salvo.

Soluções alternativas

  • Salve o arquivo em uma unidade externa formatada com um sistema de arquivos diferente do exFAT
  • Salve o arquivo na unidade local e arraste e solte o arquivo na unidade formatada exFAT através do Finder.
Observação:

Estamos trabalhando com a Apple para resolver esse problema.

Plug-ins não encontrados ou não podem ser verificados

Uma novidade no mac 10.15 (Catalina) é que os plug-ins em quarentena retornarão um erro no Photoshop de que “o arquivo não foi encontrado” ou um erro do sistema operacional que diz que o plug-in “não pode ser aberto porque não foi possível verificar sua integridade”.

Caixas de diálogo de erro de plug-in

Isso acontece com os plug-ins que não são autenticados e são baixados da Web ou instalados por outros métodos, como arrastar e soltar.

Solução

Obtenha plug-ins atualizados de outros desenvolvedores autenticados para macOS 10.15. O Photoshop carregará os plug-ins autenticados pela Apple.

 

Informações adicionais

Os clientes que possuem plug-ins já instalados e atualizam para o macOS 10.15 não devem ver esse problema.

Os clientes que atualizam para o macOS 10.15 e tentam baixar e instalar um plug-in podem observar falhas.

Observação:

Os plug-ins aparecerão como carregados com êxito ao consultar Ajuda > Informações do sistema. Isso ocorre porque, no momento da inicialização, reunimos apenas informações básicas sobre o plug-in, como o nome. A verificação da quarentena não ocorre até que um cliente tenta usar o plug-in, geralmente na forma de um filtro de terceiros ou salvando um arquivo usando um plug-in de formato de arquivo opcional/de terceiros.

Solução alternativa para plug-ins antigos que não foram criados para o macOS 10.15

Para plug-ins mais antigos que não estão autenticados, os clientes com privilégios de usuário Admin podem remover o sinalizador de quarentena usando o seguinte comando se o plug-in estiver instalado na pasta de plug-ins do aplicativo Photoshop:

sudo xattr -r -d com.apple.quarantine /Applications/Adobe\ Photoshop\ 2019/Plug-ins/<plug-in-name>

Ou use o seguinte comando se o plug-in estiver instalado na pasta compartilhada de plug-ins da Creative Cloud:

sudo xattr -r -d com.apple.quarantine /Library/Application\ Support/Adobe/Plug-Ins/CC/<plug-in-name>

O Lens Profile Creator não é executado

O Lens Profile Creator é atualmente de 32 bits, mas estamos investigando a atualização para que seja um utilitário de 64 bits.

A ferramenta Borracha não funciona com o pincel de ajuste

Depois de ativar a opção Borracha no pincel de ajuste, ela é desativada assim que você pinta e faz adições ao ajuste em vez de apagá-lo.

Solução

A equipe de engenharia está investigando esse problema.

Ao selecionar Novo ao usar um pincel de ajuste, a adição ocorre no pincel selecionado anteriormente

Ao usar um pincel de ajuste e selecionar Novo, as pinceladas subsequentes continuarão ocorrendo no pincel de ajuste selecionado anteriormente, em vez de em um novo pincel.  

Soluções alternativas

É possível clicar em uma ferramenta diferente e depois voltar ao Pincel de ajuste para adicionar um novo pincel. 

Solução

A equipe de engenharia está investigando esse problema.

Não é possível usar o pincel em um ajuste de gradiente

Depois de criar um ajuste de gradiente,  não é possível selecionar o pincel para adicionar ao gradiente

Solução

A equipe de engenharia está investigando esse problema.

Não é possível selecionar Interno no Ajuste radial

Não é possível selecionar a opção Interno ao desenhar um Ajuste radial. Se você desenhar um Ajuste radial com a opção Externo selecionada. Não é possível alterar o ajuste para a opção Interno

Solução

A equipe de engenharia está investigando esse problema.

O ExtendScript Toolkit não é executado

O ExtendScript Toolkit, que é um aplicativo de 32 bits, não funcionará mais no macOS 10.15.

Solução

O ExtendScript Toolkit foi substituído pelo ExtendScript Debugger 1.1.0.

Falha somente com o comando de terminal para barra de menus e Dock escuros

Logotipo da Adobe

Fazer logon em sua conta