Guia do Usuário Cancelar

Gerar itens de imagem de camadas

  1. Guia do Usuário do Photoshop
  2. Introdução ao Photoshop
    1. Sonhe. Realize.
    2. Novidades no Photoshop
    3. Editar sua primeira foto
    4. Criar documentos
    5. Photoshop | Perguntas frequentes
    6. Requisitos de sistema do Photoshop
    7. Conheça melhor o Photoshop
  3. Photoshop e outros produtos e serviços da Adobe
    1. Trabalho com arte do Illustrator no Photoshop
    2. Trabalhar com arquivos do Photoshop no InDesign
    3. Materiais do Substance 3D para Photoshop
    4. Usar a extensão do aplicativo Capture no Photoshop
  4. Photoshop no iPad (não disponível na China continental)
    1. Photoshop para iPad | Perguntas comuns
    2. Conheça o espaço de trabalho
    3. Requisitos de sistema | Photoshop para iPad
    4. Criar, abrir e exportar documentos
    5. Adicionar fotos
    6. Trabalhar com camadas
    7. Desenhar e pintar com pincéis
    8. Fazer seleções e adicionar máscaras
    9. Retocar suas composições
    10. Trabalhar com camadas de ajuste
    11. Ajustar a tonalidade da composição com Curvas
    12. Aplicar operações de transformação
    13. Cortar e girar suas composições
    14. Girar, deslocar, aplicar zoom e redefinir tela
    15. Trabalhar com camadas de texto
    16. Trabalhar com o Photoshop e o Lightroom
    17. Obter fontes ausentes no Photoshop para iPad
    18. Texto em japonês no Photoshop para iPad
    19. Gerenciar configurações do aplicativo
    20. Atalhos e gestos de toque
    21. Atalhos do teclado
    22. Editar o tamanho da imagem
    23. Transmita ao vivo enquanto cria no Photoshop para iPad
    24. Corrigir imperfeições com o Pincel de recuperação
    25. Criar pincéis no Capture e usá-los no Photoshop para iPad
    26. Trabalhar com arquivos Camera Raw
    27. Criar e trabalhar com objetos inteligentes
    28. Ajustar a exposição em suas imagens com subexposição e superexposição
    29. Comandos de ajuste automático no Photoshop no iPad
    30. Borre áreas em suas imagens com o Photoshop no iPad
    31. Saturar ou dessaturar as imagens usando a ferramenta Esponja
    32. Preenchimento sensível a conteúdo para iPad
  5. Photoshop na Web (não disponível na China continental)
    1. Perguntas comuns
    2. Requisitos do sistema
    3. Atalhos do teclado
    4. Tipos de arquivo suportados
    5. Introdução ao espaço de trabalho
    6. Abrir e trabalhar com documentos na nuvem
    7. Recursos de IA generativa
    8. Conceitos básicos de edição
    9. Ações rápidas
    10. Trabalhar com camadas
    11. Retocar e remover imperfeições
    12. Criar seleções rápidas
    13. Melhorias na imagem com camadas de ajuste
    14. Mova, transforme e corte imagens
    15. Desenhar e pintar
    16. Trabalhar com camadas de texto
    17. Trabalhar com qualquer pessoa na Web
    18. Gerenciar configurações do aplicativo
    19. Gerar imagem
    20. Gerar fundo
    21. Imagem de referência
  6. Photoshop (beta) (não disponível na China continental)
    1. Introdução aos aplicativos Beta da Creative Cloud
    2. Photoshop (beta) para desktop
    3. Gerar imagem com solicitações de texto descritivo
    4. Gerar fundo com prompts de texto descritivo
  7. IA generativa (não disponível na China continental) 
    1. Perguntas frequentes sobre IA generativa no Photoshop
    2. Preenchimento generativo no Photoshop no desktop
    3. Expansão generativa no Photoshop no desktop
    4. Preenchimento generativo no Photoshop para iPad
    5. Expansão generativa no Photoshop para iPad
    6. Recursos de IA generativa no Photoshop na Web
  8. Autenticidade do conteúdo (não disponível na China continental)
    1. Credenciais de conteúdo no Photoshop
    2. Identidade e proveniência de NFTs
    3. Conectar contas para atribuição de criativos
  9. Documentos na nuvem (não disponível na China continental)
    1. Documentos na nuvem no Photoshop | Perguntas comuns
    2. Documentos na nuvem no Photoshop | Perguntas sobre fluxo de trabalho
    3. Gerenciar e trabalhar com documentos na nuvem no Photoshop
    4. Atualize o armazenamento na nuvem do Photoshop
    5. Não é possível criar ou salvar um documento na nuvem
    6. Solucionar erros de documentos na nuvem do Photoshop
    7. Coletar logs de sincronização de documentos na nuvem
    8. Convidar outras pessoas para editar seus documentos na nuvem
    9. Compartilhar arquivos e comentar no aplicativo
  10. Espaço de trabalho
    1. Noções básicas do espaço de trabalho
    2. Preferências
    3. Aprenda mais rapidamente com o painel Descobrir do Photoshop
    4. Criar documentos
    5. Insira arquivos
    6. Atalhos de teclado padrão
    7. Personalizar atalhos de teclado
    8. Galerias de ferramentas
    9. Preferências de desempenho
    10. Usar ferramentas
    11. Predefinições
    12. Grade e guias
    13. Gestos de toque
    14. Usar a Touch Bar com o Photoshop
    15. Recursos de toque e espaço de trabalho personalizáveis
    16. Visualizações de tecnologia
    17. Metadados e observações
    18. Recursos de toque e espaço de trabalho personalizáveis
    19. Inserir imagens do Photoshop em outros aplicativos
    20. Réguas
    21. Mostrar ou ocultar Extras que não podem ser impressos
    22. Especificação de colunas para uma imagem
    23. Desfazer e histórico
    24. Painéis e menus
    25. Posicionamento de elementos com encaixe
    26. Posicionamento com a ferramenta Régua
  11. Web design, design de tela e de aplicativos
    1. Photoshop para o design
    2. Pranchetas
    3. Visualização do dispositivo
    4. Copiar CSS de camadas
    5. Criar fatias nas páginas da Web
    6. Opções de HTML para fatias
    7. Modificar layout da fatia
    8. Trabalhar com gráficos da Web
    9. Criar galerias de fotos na Web
  12. Noções básicas sobre imagens e cores
    1. Como redimensionar imagens
    2. Trabalhar com imagens rasterizadas e vetoriais
    3. Tamanho e resolução da imagem
    4. Obter imagens a partir de câmeras e scanners
    5. Criar, abrir e importar imagens
    6. Exibir imagens
    7. Erro de marcador JPEG inválido | Abrir imagens
    8. Visualização de múltiplas imagens
    9. Personalizar seletores de cores e amostras
    10. Imagens HDR
    11. Corresponder cores na imagem
    12. Converter entre modos de cores
    13. Modos de cores
    14. Apagar partes de uma imagem
    15. Modos de mesclagem
    16. Escolher cores
    17. Personalização de tabelas de cores indexadas
    18. Informações sobre imagem
    19. Os filtros de distorção não estão disponíveis
    20. Sobre cores
    21. Ajustes de cores e monocromáticos usando canais
    22. Escolher cores nos painéis Cor e Amostras
    23. Amostra
    24. Modo de cores ou modo de imagem
    25. Disposição de cores
    26. Adição de uma alteração do modo condicional a uma ação
    27. Adicionar amostras de HTML CSS e SVG
    28. Profundidade de bits e preferências
  13. Camadas
    1. Conceitos básicos de camadas
    2. Edição não destrutiva
    3. Criação e gerenciamento de camadas e grupos
    4. Selecionar, agrupar e vincular camadas
    5. Coloque imagens em quadros
    6. Mesclagem e opacidade da camada
    7. Camadas de máscara
    8. Aplicar filtros inteligentes
    9. Composições de camada
    10. Mover, empilhar e bloquear camadas
    11. Camadas de máscara com máscaras de vetor
    12. Gerenciar camadas e grupos
    13. Efeitos e estilos de camadas
    14. Editar máscaras de camada
    15. Extrair ativos
    16. Revelar camadas com máscaras de corte
    17. Gerar itens de imagem de camadas
    18. Trabalhar com objetos inteligentes
    19. Modos de mesclagem
    20. Combinação de várias imagens em um retrato de grupo
    21. Combinação de imagens com de associação com a opção Mesclar camadas automaticamente
    22. Alinhar e distribuir camadas
    23. Copiar CSS de camadas
    24. Carregar seleções de uma máscara ou dos limites de uma máscara de camada
    25. Efeito vazado para revelar o conteúdo de outras camadas
  14. Seleções
    1. Introdução às seleções
    2. Faça seleções em sua composição
    3. Espaço de trabalho Selecionar e mascarar
    4. Selecionar com as ferramentas de letreiro
    5. Selecionar com as ferramentas de laço
    6. Ajustar seleções de pixels
    7. Mover, copiar e excluir pixels selecionados
    8. Criação de uma máscara rápida temporária
    9. Selecionar gama de cores em uma imagem
    10. Converter entre demarcadores e bordas de seleção
    11. Noções básicas de canal
    12. Salvar seleções e máscaras de canal alfa
    13. Selecionar áreas da imagem em foco
    14. Duplicação, divisão e mesclagem de canais
    15. Cálculos de canal
  15. Ajustes de imagem
    1. Substituir cores do objeto
    2. Distorção de perspectiva
    3. Reduzir desfoque devido a vibração da câmera
    4. Exemplos de pincel de recuperação
    5. Exportar tabelas de consulta de cor
    6. Ajustar nitidez e desfoque da imagem
    7. Entender os ajustes de cor
    8. Aplicação do ajuste Brilho/Contraste
    9. Aprimoramento dos detalhes de sombra e realce
    10. Ajuste de níveis
    11. Ajuste de matiz e saturação
    12. Ajustar a vibratilidade
    13. Ajuste de saturação de cor em áreas da imagem
    14. Fazer ajustes de tons rápidos
    15. Aplicar efeitos especiais de cor a imagens
    16. Aprimorar imagem com ajustes de equilíbrio de cores
    17. Imagens HDR
    18. Exibir histogramas e valores de pixel
    19. Corresponder cores na imagem
    20. Cortar e retificar fotos
    21. Conversão de uma imagem colorida em preto e branco
    22. Camadas de ajuste e de preenchimento
    23. Ajuste de curvas
    24. Modos de mesclagem
    25. Segmentar imagens para prensa tipográfica
    26. Ajustar a cor e o tom com conta-gotas de níveis e curvas
    27. Ajustar a exposição e tonalização HDR
    28. Subexposição ou superexposição de áreas de imagem
    29. Como fazer ajustes de cores seletivas
  16. Adobe Camera Raw
    1. Requisitos de sistema do Camera Raw
    2. Novidades no Camera Raw
    3. Introdução ao Camera Raw
    4. Criar panoramas
    5. Lentes compatíveis
    6. Vinheta, granulação e efeitos de desembaçamento no Camera Raw
    7. Atalhos de teclado padrão
    8. Correção automática da perspectiva no Camera Raw
    9. Filtro radial no Camera Raw
    10. Gerencie configurações do Camera Raw
    11. Abertura, processamento e salvamento de imagens no Camera Raw
    12. Corrija imagens com a ferramenta aprimorada Remoção de manchas no Camera Raw
    13. Rotação, recorte e ajuste imagens
    14. Ajustar a renderização de cores no Camera Raw
    15. Versões do processo no Camera Raw
    16. Ajustes locais no Camera Raw
  17. Reparo e restauração da imagem
    1. Remova objetos de suas fotos com o Preenchimento sensível ao conteúdo
    2. Corrigir e mover com reconhecimento de conteúdo
    3. Retocar e corrigir fotos
    4. Corrigir distorção de imagem e ruído
    5. Solução básica para a maioria dos problemas
  18. Aprimoramento e transformação de imagens
    1. Substitua o céu em suas imagens
    2. Transformar objetos
    3. Ajustar corte, giro e tamanho de tela de desenho
    4. Como cortar e corrigir fotos
    5. Criar e editar imagens panorâmicas
    6. Distorção de imagens, formas e caminhos
    7. Ponto de fuga
    8. Escala sensível a conteúdo
    9. Transformação de imagens, formas e caminhos
  19. Desenho e pintura
    1. Pinte padrões simétricos
    2. Desenhar retângulos e modificar as opções de traçado
    3. Sobre desenho
    4. Desenhar e editar formas
    5. Ferramentas de pintura
    6. Criar e modificar pincéis
    7. Modos de mesclagem
    8. Adicionar cores a caminhos
    9. Editar caminhos
    10. Pintar com o pincel de mistura
    11. Predefinições do pincel
    12. Gradientes
    13. Interpolação de gradiente
    14. Seleções, camadas e demarcadores de preenchimento e traçado
    15. Desenhar com as ferramentas Caneta
    16. Criar padrões
    17. Criação de padrão usando o Criador de padrões
    18. Gerenciamento de demarcadores
    19. Como gerenciar predefinições e bibliotecas de padrões
    20. Desenhar ou pintar com uma mesa digitalizadora
    21. Criar pincéis texturizados
    22. Adicionar elementos dinâmicos aos pincéis
    23. Gradiente
    24. Pintar traçados estilizados usando o Pincel História da Arte
    25. Pintar com um padrão
    26. Sincronizar predefinições em vários dispositivos
    27. Migrar predefinições, ações e configurações
  20. Texto
    1. Adicionar e editar o texto
    2. Mecanismo de texto unificado
    3. Trabalhar com fontes OpenType SVG
    4. Formatação de caracteres
    5. Formatar parágrafos
    6. Como criar efeitos de texto
    7. Edição de textos
    8. Espaçamento de linhas e caracteres
    9. Texto árabe e hebraico
    10. Fontes
    11. Solução de problemas de fontes
    12. Texto asiático
    13. Criar texto
  21. Filtros e efeitos
    1. Utilize a Galeria de desfoque
    2. Noções básicas sobre filtros
    3. Referência de efeitos de filtros
    4. Adição de efeitos de iluminação
    5. Usar o filtro Grande angular adaptável
    6. Usar o filtro Pintura a óleo
    7. Usar o filtro Dissolver
    8. Efeitos e estilos de camadas
    9. Aplicar filtros específicos
    10. Como borrar áreas da imagem
  22. Salvar e exportar
    1. Salvar seus arquivos no Photoshop
    2. Exportar seus arquivos no Photoshop
    3. Formatos de arquivo compatíveis
    4. Salvar arquivos em formatos de gráficos
    5. Mover designs entre o Photoshop e o Illustrator
    6. Salvar e exportar vídeo e animações
    7. Salvar arquivos PDF
    8. Proteção de direitos autorais da Digimarc
  23. Gerenciamento de cores
    1. Sobre gerenciamento de cores
    2. Uniformização de cores
    3. Configurações de cor
    4. Duotônicos
    5. Trabalhar com perfis de cores
    6. Gerencie as cores de documentos para exibição on-line
    7. Documentos com gerenciamento de cores durante a impressão
    8. Imagens importadas com gerenciamento de cores
    9. Revisão de cores
  24. Web design, design de tela e de aplicativos
    1. Photoshop para o design
    2. Pranchetas
    3. Visualização do dispositivo
    4. Copiar CSS de camadas
    5. Criar fatias nas páginas da Web
    6. Opções de HTML para fatias
    7. Modificar layout da fatia
    8. Trabalhar com gráficos da Web
    9. Criar galerias de fotos na Web
  25. Vídeo e animação
    1. Edição de vídeo no Photoshop
    2. Editar camadas de animação e de vídeo
    3. Visão geral de vídeo e animação
    4. Visualização de vídeo e animações
    5. Como pintar quadros em camadas de vídeo
    6. Importar arquivos de vídeo e sequências de imagem
    7. Criar quadros de animação
    8. Creative Cloud 3D Animation (visualização)
    9. Criar animações de linha do tempo
    10. Criar imagens para vídeo
  26. Impressão
    1. Imprimir objetos 3D
    2. Imprimir a partir do Photoshop
    3. Imprimir usando gerenciamento de cores
    4. Páginas de amostra e apresentações em PDF
    5. Imprimir fotos em um layout do pacote de figuras
    6. Imprimir cores spot
    7. Imprimir imagens em uma prensa tipográfica comercial
    8. Aprimorar as impressões em cores do Photoshop
    9. Solução de problemas de impressão | Photoshop
  27. Automação
    1. Criação de ações
    2. Criar gráficos orientados por dados
    3. Scripts
    4. Processamento de um lote de arquivos
    5. Executar e gerenciar ações
    6. Adicionar ações condicionais
    7. Sobre ações e o Painel Ações
    8. Gravar ferramentas em ações
    9. Adição de uma alteração do modo condicional a uma ação
    10. Conjunto de ferramentas de interface de usuário (UI) do Photoshop para plug-ins e scripts
  28. Solução de problemas
    1. Problemas corrigidos 
    2. Problemas conhecidos
    3. Otimizar o desempenho do Photoshop
    4. Solução de problemas básica
    5. Solução de problemas de travamento ou congelamento
    6. Solucionar erros de programa
    7. Solução de problemas de erros de disco de trabalho cheio
    8. Solucionar problemas de GPU e de driver gráfico
    9. Localizar ferramentas ausentes
    10. Photoshop 3D | Perguntas frequentes sobre recursos 3D descontinuados

É possível criar itens de imagens JPEG, PNG, GIF ou SVG a partir do conteúdo de uma camada ou um grupo de camadas em um arquivo PSD. Os itens são gerados automaticamente quando você adiciona uma extensão de formato de imagem suportado a um nome de camada ou nome de grupo de camadas. Opcionalmente, é possível também especificar parâmetros de qualidade e tamanho para os itens da imagem gerados.

Gerar itens de imagens a partir de um arquivo PSD é especialmente útil para o design para vários dispositivos da web.

Como criar e exportar gráficos da Web, consulte Como exportar arquivos em vários formatos no Photoshop.

Gerar itens de imagem de camadas ou grupos de camadas

Para compreender melhor o gerador de itens de imagem, considere um arquivo PSD simples (download neste link) com a seguinte hierarquia de camadas:

Geração de ativos de imagens do Photoshop
Exemplo de arquivo PSD e sua hierarquia de camadas

A hierarquia de camadas para este arquivo tem dois grupos de camadas —Rounded_rectangles e Ellipses. Cada um de esses grupos de camadas contém cinco camadas.

Siga estas etapas para criar itens de imagem deste arquivo PSD:

  1. Com o arquivo PSD aberto, selecione Arquivo > Gerar > Itens de imagem.
  2. Adicione as extensões apropriadas de formato de arquivo (.jpg, .png.gif, ou .svg) aos nomes das camadas ou dos grupos de camadas a partir das quais você deseja gerar recursos de imagem. Por exemplo, renomeie os grupos de camadas Rounded_rectangles e Ellipses como Rounded_rectangles.jpg e Ellipses.png; e a camada Ellipse_4 como Ellipse_4.gif.
Observação:

Os caracteres especiais : e * não são suportados nos nomes de camadas.

O Photoshop cria os itens de imagem e salva-os em uma subpasta ao lado do arquivo PSD de origem. Se o arquivo PSD de origem PSD ainda não foi salvo, o Photoshop salva os itens gerados em uma nova pasta na área de trabalho.

Nomes de ativos de imagem do Photoshop
Nomes de itens de imagem são gerados a partir dos nomes de camadas/grupos de camadas

Observação:

A geração de itens de imagem é ativada para o documento atual. Após habilitado, o recurso permanece disponível sempre que o documento é aberto a seguir. Para desativar a geração de itens de imagem para o documento atual, desmarque Arquivo > Gerar > Itens de imagem.

Gerar ativos para documentos na nuvem

Se você estiver trabalhando com um documento na nuvem, os ativos serão salvos no diretório “Associações de nuvem do Photoshop”:

  • Windows: C:\Users\yourname\Documents\Adobe\Photoshop Cloud Associates
  • macOS: /Users/yourname/Documents/Adobe/Photoshop Cloud Associates

Criar vários itens de uma camada ou de um grupo de camadas

Para gerar vários itens de uma camada/grupo de camadas, separe os nomes de itens com vírgulas. Por exemplo, o seguinte nome de camada cria três itens:

Ellipse_4.jpg, Ellipse_4b.png, Ellipse_4c.png

Salvar itens em uma subpasta

É possível optar por salvar os itens de imagem feitos gerados de grupos específicos de camadas em uma subpasta diretamente na pasta do documento. Inclua o nome da subpasta no nome do grupo de camadas; por exemplo:

[subpasta]/Ellipse_4.jpg 

Um caso de uso de webdesign

Gerar itens de imagens a partir de um arquivo PSD é especialmente útil para o design para vários dispositivos da web. Considere o seguinte design da web e a sua estrutura de camadas:

Um design da web e sua hierarquia de camadas

Vamos extrair o ícone na parte superior e a linha superior da grade de imagem de Pontos de acesso global como itens de imagem:

  • Adicionar extensões de formato de imagem para os nomes de camada apropriados.
Renomear as camadas/grupos de camadas apropriados do Photoshop

Renomear as camadas/grupos de camadas apropriados do Photoshop

Renomear as camadas/grupos de camadas apropriados

Observação:

Um único item de imagem é gerado a partir do conteúdo de uma camada/grupo de camadas. Por exemplo, o grupo de camadas do logotipo AdventureCo na captura de tela acima contém uma camada de forma e uma camada de texto dinâmico. Essas camadas são achatadas quando um item de imagem é gerado a partir do grupo de camadas.

O Photoshop cria os itens e salva-os no mesmo local do arquivo PSD de origem.

Ativos de imagens gerados do Photoshop
itens de imagens gerados

Especificar parâmetros de qualidade e tamanho

Por padrão, os itens JPEG são gerados com qualidade de 90%. Por padrão, os itens PNG são gerados como imagens de 32 bits. Os itens GIF são gerados com transparência alfa básica.

É possível personalizar a qualidade e o tamanho enquanto se renomeia camadas ou grupos de camadas na preparação para geração de itens.

Parâmetros dos itens JPEG

  • Adicione a qualidade de saída desejada como um sufixo para o nome do item: .jpg(1-10) ou .jpg(1-100%). Por exemplo:
    • Ellipse_4.jpg5
    • Ellipse_4.jpg50%
  • Adicione o tamanho desejado da imagem de saída (relativo ou em formatos suportados: px, in, cm e mm) como um prefixo para o nome do item. O Photoshop dimensiona a imagem proporcionalmente. Por exemplo:
    • 200% Ellipse_4.jpg
    • 300 x 200 Rounded_rectangle_3.jpg
    • 10in x 200mm Rounded_rectangle_3.jpg

Observação: lembre-se de adicionar um caractere de espaço entre o prefixo e o nome do item. Se você estiver especificando o tamanho em pixels, poderá omitir a unidade. Por exemplo, 300 x 200.

Observação:

Como ilustrado, você pode mesclar diferentes unidades e pixels para especificar o tamanho desejado de saída. Por exemplo, 4in x 100 Rounded_rectangle_3.jpg é um nome válido de camada para a geração de itens.

Parâmetros dos itens PNG

  • Adicione a qualidade de saída desejada como um sufixo para o nome do item: 8, 24 ou 32. Por exemplo:
    • Ellipse_4.png24
  • Adicione o tamanho desejado da imagem de saída (relativo ou em formatos suportados: px, in, cm e mm) como um prefixo para o nome do item. O Photoshop dimensiona a imagem proporcionalmente. Por exemplo:
    • 42% Ellipse_4.png
    • 300 mm x 20 cm Rounded_rectangle_3.png
    • 10 pol x 50 cm Rounded_rectangle_3.png

Observação: lembre-se de adicionar um caractere de espaço entre o prefixo e o nome do item. Se você estiver especificando o tamanho em pixels, poderá omitir a unidade. Por exemplo, 300 x 200.

Observação:

Como ilustrado, você pode mesclar diferentes unidades e pixels para especificar o tamanho desejado de saída. Por exemplo, 4in x 100 Rounded_rectangle_3.png é um nome válido de camada para a geração de itens.

Parâmetros de itens GIF

  • Adicione o tamanho desejado da imagem de saída (relativo ou em formatos suportados: px, in, cm e mm) como um prefixo para o nome do item. Por exemplo:
    • 42% Ellipse_4.gif
    • 300mm x 20cm Rounded_rectangle_3.gif
    • 20in x 50cm Rounded_rectangle_3.gif

Observação: lembre-se de adicionar um caractere de espaço entre o prefixo e o nome do item. Se você estiver especificando o tamanho em pixels, poderá omitir a unidade. Por exemplo, 300 x 200.

Observação:

Como ilustrado, você pode mesclar diferentes unidades e pixels para especificar o tamanho desejado de saída. Por exemplo, 4in x 100 Rounded_rectangle_3.gif é um nome de camada válido para a geração de itens.

Parâmetros de qualidade não estão disponíveis para itens GIF.

Construa nomes de camadas complexos

É possível especificar vários nomes de itens com parâmetros ao nomear uma camada para geração de itens. Por exemplo:

120% Delicious.jpg, 42% Delicious.png24, 100x100 Delicious_2.jpg90%, 250% Delicious.gif

O Photoshop cria os seguintes itens a partir dessa camada:

  • Delicious.jpg (uma imagem JPG de qualidade 8 dimensionada em 120%)
  • Delicious.png (uma imagem PNG de 24 bits dimensionada em 42%)
  • Delicious_2.jpg (uma imagem JPG de qualidade 90% com um tamanho absoluto de 100x100 px)
  • Delicious.gif (uma imagem GIF dimensionada em 250%)

Exemplos de escala absoluta

Bons exemplos de escala absoluta

  • 100x80 foo.png (escala absoluta simples)
  • 80 x 100px foo.png (espaços entre comprimentos)
  • 4in x100 foo.png (combinação de unidades e nenhuma unidade)
  • 90mm x120cm foo.png (mistura de unidades diferentes)
  • 100x? foo.png (curinga)
  • ?x60in foo.png (curinga no início)

Exemplos inválidos de escala absoluta

  • 100x100foo.png (sem espaço antes do nome do arquivo)
  • 80x100 60% foo.png (mistura de escala absoluta e relativa)
  • 50% 80x100 foo.png (mistura de escala absoluta e relativa)
  • 20in cm x50cm foo.png (unidades múltiplas)
  • 30nm x20 nano.png (unidade inválida)

Formatação e separação de vários arquivos

Bons exemplos

  • Camada 1.png (é permitido espaço no nome do arquivo — resulta em um único arquivo chamado “Camada”)
  • Camada 1.png, Camada 2.jpg (vírgula como separador)
  • Camada 1.png, Camada 2.jpg (vírgula seguida de espaços como separador
  • Camada 1.png+Camada 2.jpg (mais como separador)
  • Camada 1.png + Camada 2.jpg (mais seguido de espaços como separador)

Reúna todo o trabalho

100% Delicious, 42% Layer 1.png24 + 100x100 Camada.jpg-90% , 250% Quux/Foo Bar Baz.gif resulta em três arquivos (a string "100% Delicious" é ignorada porque não é um nome de arquivo):

  • Camada 1.png, em escala de 42%, como um png de 24 bits
  • Camada.jpg, como um tamanho absoluto de 100x100 pixels, como um jpg de 90% de qualidade
  • Foo Bar Baz.gif na subpasta Quux, na escala de 250%, como um gif.

Especificar configurações padrão para itens

É possível especificar configurações padrão de largura do documento para os itens gerados. Siga estas etapas:

  1. Crie uma nova camada vazia no documento.
  2. Comece o nome da camada com a palavra-chave padrão. Agora, insira as configurações a serem aplicadas a todos os itens da imagem gerados do documento. Por exemplo:

padrão alta-res/

Gerencie os itens da imagem em uma subpasta denominada alta-res. Por exemplo, [asset_folder]/alta-res/Delicious.jpg.

padrão alta-res/@2x

Gerencie os itens da imagem em uma subpasta denominada alta-res. Além de isso, adicione sufixos aos nomes dos itens com @2x. Por exemplo, [asset_folder] /alta-res/ Delicious@2x.jpg.

Padrão 50% baixa-res/

Salve os itens de imagem reduzidas em 50% na subpasta baixa- res na pasta de itens do documento 

padrão alta-res/@2x + 50% baixa- res/

Gerencie dois itens de uma camada:

  • Na subpasta alta-res, um item de imagem cujo nome tem o sufixo @2x
  • Na subpasta baixa-res, um item de imagem foi reduzido em 50%
Observação:

Os fatores de dimensionamento padrão são substituídos por fatores de dimensionamento especificados para camadas individuais.

Desabilitar a geração de itens de imagem para todos os documentos

É possível desativar a geração de itens de imagem globais para todos os documentos do Photoshop ao alterar as suas Preferências.

  1. Escolha Editar > Preferências > Plug-Ins.
  2. Desmarque Habilitar o Generator.
  3. Clique em OK.
Observação:

O comando de menu Arquivo > Criar não fica disponível ao desativar a geração de itens de imagem de Preferências. O recurso pode ser ativado novamente somente na caixa de diálogo Preferências .

Perguntas frequentes

Os nomes de itens devem ser exclusivos no nível do documento.

Por padrão, os itens JPG são gerados com qualidade de 90%. Por padrão, os itens PNG são gerados como imagens de 32 bits. Os itens GIF são gerados com transparência alfa básica.

Sim. A transparência e outros efeitos aplicados em uma camada são refletidos nos itens criados a partir dessa camada. No entanto, esses efeitos podem ser nivelados nos itens gerados.

Os ativos são cortados nos limites do documento. Se uma imagem não estiver dentro dos limites do documento, o Generator não cria os ativos de imagem associados.

Além da vírgula (,), é possível usar o símbolo de adição (+) como separador entre os nomes dos itens de imagem. Por exemplo:

42% Rounded_rectangle_1.png24 + 100x100 Rounded_rectangle_1.jpg90%

é igual a:

42% Rounded_rectangle_1.png24, 100x100 Rounded_rectangle_1.jpg90%

Mais itens semelhantes

 Adobe

Receba ajuda com mais rapidez e facilidade

Novo usuário?

Adobe MAX 2024

Adobe MAX:
a conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX

A conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX 2024

Adobe MAX:
a conferência da criatividade

14 a 16 de outubro, Miami Beach e online

Adobe MAX

A conferência da criatividade

14 a 16 de outubro, Miami Beach e online