Guia do Usuário Cancelar

Criar gráficos orientados por dados

  1. Guia do Usuário do Photoshop
  2. Introdução ao Photoshop
    1. Sonhe. Realize.
    2. Novidades no Photoshop
    3. Editar sua primeira foto
    4. Criar documentos
    5. Photoshop | Perguntas frequentes
    6. Requisitos de sistema do Photoshop
    7. Migrar predefinições, ações e configurações
    8. Conheça melhor o Photoshop
  3. Photoshop e serviços da Adobe
    1. Photoshop e Adobe Stock
    2. Bibliotecas da Creative Cloud
    3. Bibliotecas da Creative Cloud no Photoshop
    4. Usar a Touch Bar com o Photoshop
    5. Trabalho com arte do Illustrator no Photoshop
    6. Usar a extensão do aplicativo Capture no Photoshop
    7. Grade e guias
    8. Criação de ações
    9. Desfazer e histórico
    10. Atalhos de teclado padrão
    11. Recursos de toque e espaço de trabalho personalizáveis
  4. Photoshop para iPad
    1. Photoshop para iPad | Perguntas comuns
    2. Conheça o espaço de trabalho
    3. Requisitos de sistema | Photoshop para iPad
    4. Criar, abrir e exportar documentos
    5. Adicionar fotos
    6. Trabalhar com camadas
    7. Desenhar e pintar com pincéis
    8. Fazer seleções e adicionar máscaras
    9. Retocar suas composições
    10. Trabalhar com camadas de ajuste
    11. Ajustar a tonalidade da composição com Curvas
    12. Aplicar operações de transformação
    13. Cortar e girar suas composições
    14. Girar, deslocar, aplicar zoom e redefinir tela
    15. Trabalhar com camadas de texto
    16. Trabalhar com o Photoshop e o Lightroom
    17. Obter fontes ausentes no Photoshop para iPad
    18. Texto em japonês no Photoshop para iPad
    19. Gerenciar configurações do aplicativo
    20. Atalhos e gestos de toque
    21. Atalhos do teclado
    22. Editar o tamanho da imagem
    23. Transmita ao vivo enquanto cria no Photoshop para iPad
    24. Corrigir imperfeições com o Pincel de recuperação
    25. Criar pincéis no Capture e usá-los no Photoshop
    26. Trabalhar com arquivos Camera Raw
    27. Criar e trabalhar com objetos inteligentes
    28. Ajustar a exposição em suas imagens com subexposição e superexposição
  5. Versão beta do Photoshop na Web
    1. Perguntas comuns | Versão beta do Photoshop na Web 
    2. Introdução ao espaço de trabalho
    3. Requisitos de sistema | Photoshop na Web beta
    4. Atalhos de teclado | Versão beta do Photoshop na Web
    5. Tipos de arquivo compatíveis | Photoshop para Web Beta
    6. Abrir e trabalhar com documentos na nuvem
    7. Colaborar com as partes interessadas
    8. Aplicar edições limitadas a documentos na nuvem
  6. Documentos na nuvem
    1. Documentos na nuvem no Photoshop | Perguntas comuns
    2. Documentos na nuvem no Photoshop | Perguntas sobre fluxo de trabalho
    3. Gerenciar e trabalhar com documentos na nuvem no Photoshop
    4. Atualize o armazenamento na nuvem do Photoshop
    5. Não é possível criar ou salvar um documento na nuvem
    6. Solucionar erros de documentos na nuvem do Photoshop
    7. Coletar logs de sincronização de documentos na nuvem
    8. Compartilhar o acesso e editar seus documentos na nuvem
    9. Compartilhar arquivos e comentar no aplicativo
  7. Espaço de trabalho
    1. Noções básicas do espaço de trabalho
    2. Criar documentos
    3. Usar a Touch Bar com o Photoshop
    4. Suporte ao Microsoft Dial no Photoshop
    5. Galerias de ferramentas
    6. Preferências de desempenho
    7. Usar ferramentas
    8. Gestos de toque
    9. Recursos de toque e espaço de trabalho personalizáveis
    10. Visualizações de tecnologia
    11. Metadados e observações
    12. Compartilhe suas criações com rapidez
    13. Inserir imagens do Photoshop em outros aplicativos
    14. Preferências
    15. Atalhos de teclado padrão
    16. Réguas
    17. Mostrar ou ocultar Extras que não podem ser impressos
    18. Especificação de colunas para uma imagem
    19. Desfazer e histórico
    20. Painéis e menus
    21. Insira arquivos
    22. Posicionamento de elementos com encaixe
    23. Posicionamento com a ferramenta Régua
    24. Predefinições
    25. Personalizar atalhos de teclado
    26. Grade e guias
  8. Web design, design de tela e de aplicativos
    1. Photoshop para o design
    2. Pranchetas
    3. Visualização do dispositivo
    4. Copiar CSS de camadas
    5. Criar fatias nas páginas da Web
    6. Opções de HTML para fatias
    7. Modificar layout da fatia
    8. Trabalhar com gráficos da Web
    9. Criar galerias de fotos na Web
  9. Noções básicas sobre imagens e cores
    1. Como redimensionar imagens
    2. Trabalhar com imagens rasterizadas e vetoriais
    3. Tamanho e resolução da imagem
    4. Obter imagens a partir de câmeras e scanners
    5. Criar, abrir e importar imagens
    6. Exibir imagens
    7. Erro de marcador JPEG inválido | Abrir imagens
    8. Visualização de múltiplas imagens
    9. Personalizar seletores de cores e amostras
    10. Imagens HDR
    11. Corresponder cores na imagem
    12. Converter entre modos de cores
    13. Modos de cores
    14. Apagar partes de uma imagem
    15. Modos de mesclagem
    16. Escolher cores
    17. Personalização de tabelas de cores indexadas
    18. Informações sobre imagem
    19. Os filtros de distorção não estão disponíveis
    20. Sobre cores
    21. Ajustes de cores e monocromáticos usando canais
    22. Escolher cores nos painéis Cor e Amostras
    23. Amostra
    24. Modo de cores ou modo de imagem
    25. Disposição de cores
    26. Adição de uma alteração do modo condicional a uma ação
    27. Adicionar amostras de HTML CSS e SVG
    28. Profundidade de bits e preferências
  10. Camadas
    1. Conceitos básicos de camadas
    2. Edição não destrutiva
    3. Criação e gerenciamento de camadas e grupos
    4. Selecionar, agrupar e vincular camadas
    5. Coloque imagens em quadros
    6. Mesclagem e opacidade da camada
    7. Camadas de máscara
    8. Aplicar filtros inteligentes
    9. Composições de camada
    10. Mover, empilhar e bloquear camadas
    11. Camadas de máscara com máscaras de vetor
    12. Gerenciar camadas e grupos
    13. Efeitos e estilos de camadas
    14. Editar máscaras de camada
    15. Extrair ativos
    16. Revelar camadas com máscaras de corte
    17. Gerar itens de imagem de camadas
    18. Trabalhar com objetos inteligentes
    19. Modos de mesclagem
    20. Combinação de várias imagens em um retrato de grupo
    21. Combinação de imagens com de associação com a opção Mesclar camadas automaticamente
    22. Alinhar e distribuir camadas
    23. Copiar CSS de camadas
    24. Carregar seleções de uma máscara ou dos limites de uma máscara de camada
    25. Efeito vazado para revelar o conteúdo de outras camadas
    26. Camada
    27. Achatamento
    28. Composição
    29. Plano de fundo
  11. Seleções
    1. Espaço de trabalho Selecionar e mascarar
    2. Criar seleções rápidas
    3. Introdução às seleções
    4. Selecionar com as ferramentas de letreiro
    5. Selecionar com as ferramentas de laço
    6. Selecionar gama de cores em uma imagem
    7. Ajustar seleções de pixels
    8. Converter entre demarcadores e bordas de seleção
    9. Noções básicas de canal
    10. Mover, copiar e excluir pixels selecionados
    11. Criação de uma máscara rápida temporária
    12. Salvar seleções e máscaras de canal alfa
    13. Selecionar áreas da imagem em foco
    14. Duplicação, divisão e mesclagem de canais
    15. Cálculos de canal
    16. Seleção
    17. Caixa delimitadora
  12. Ajustes de imagem
    1. Distorção de perspectiva
    2. Reduzir desfoque devido a vibração da câmera
    3. Exemplos de pincel de recuperação
    4. Exportar tabelas de consulta de cor
    5. Ajustar nitidez e desfoque da imagem
    6. Entender os ajustes de cor
    7. Aplicação do ajuste Brilho/Contraste
    8. Aprimoramento dos detalhes de sombra e realce
    9. Ajuste de níveis
    10. Ajuste de matiz e saturação
    11. Ajustar a vibratilidade
    12. Ajuste de saturação de cor em áreas da imagem
    13. Fazer ajustes de tons rápidos
    14. Aplicar efeitos especiais de cor a imagens
    15. Aprimorar imagem com ajustes de equilíbrio de cores
    16. Imagens HDR
    17. Exibir histogramas e valores de pixel
    18. Corresponder cores na imagem
    19. Como cortar e corrigir fotos
    20. Conversão de uma imagem colorida em preto e branco
    21. Camadas de ajuste e de preenchimento
    22. Ajuste de curvas
    23. Modos de mesclagem
    24. Segmentar imagens para prensa tipográfica
    25. Ajustar a cor e o tom com conta-gotas de níveis e curvas
    26. Ajustar a exposição e tonalização HDR
    27. Filtro
    28. Desfoque
    29. Subexposição ou superexposição de áreas de imagem
    30. Como fazer ajustes de cores seletivas
    31. Substituir cores do objeto
  13. Adobe Camera Raw
    1. Requisitos de sistema do Camera Raw
    2. Novidades no Camera Raw
    3. Introdução ao Camera Raw
    4. Criar panoramas
    5. Lentes compatíveis
    6. Vinheta, granulação e efeitos de desembaçamento no Camera Raw
    7. Atalhos de teclado padrão
    8. Correção automática da perspectiva no Camera Raw
    9. Como fazer edições não destrutivas no Camera Raw
    10. Filtro radial no Camera Raw
    11. Gerencie configurações do Camera Raw
    12. Abertura, processamento e salvamento de imagens no Camera Raw
    13. Corrija imagens com a ferramenta aprimorada Remoção de manchas no Camera Raw
    14. Rotação, recorte e ajuste imagens
    15. Ajustar a renderização de cores no Camera Raw
    16. Resumo dos recursos | Adobe Camera Raw | Versões 2018
    17. Resumo dos novos recursos
    18. Versões do processo no Camera Raw
    19. Ajustes locais no Camera Raw
  14. Reparo e restauração da imagem
    1. Remova objetos de suas fotos com o Preenchimento sensível ao conteúdo
    2. Corrigir e mover com reconhecimento de conteúdo
    3. Retocar e corrigir fotos
    4. Corrigir distorção de imagem e ruído
    5. Solução básica para a maioria dos problemas
  15. Transformações de imagem
    1. Transformar objetos
    2. Ajustar corte, giro e tamanho de tela de desenho
    3. Como cortar e corrigir fotos
    4. Criar e editar imagens panorâmicas
    5. Distorção de imagens, formas e caminhos
    6. Ponto de Fuga
    7. Usar o filtro Dissolver
    8. Escala sensível a conteúdo
    9. Transformação de imagens, formas e caminhos
    10. Distorcer
    11. Transformar
    12. Panorama
  16. Desenho e pintura
    1. Pinte padrões simétricos
    2. Desenhar retângulos e modificar as opções de traçado
    3. Sobre desenho
    4. Desenhar e editar formas
    5. Ferramentas de pintura
    6. Criar e modificar pincéis
    7. Modos de mesclagem
    8. Adicionar cores a caminhos
    9. Editar caminhos
    10. Pintar com o pincel de mistura
    11. Predefinições do pincel
    12. Gradientes
    13. Interpolação de gradiente
    14. Seleções, camadas e demarcadores de preenchimento e traçado
    15. Desenhar com as ferramentas Caneta
    16. Criar padrões
    17. Criação de padrão usando o Criador de padrões
    18. Gerenciamento de demarcadores
    19. Como gerenciar predefinições e bibliotecas de padrões
    20. Desenhar ou pintar com uma mesa digitalizadora
    21. Criar pincéis texturizados
    22. Adicionar elementos dinâmicos aos pincéis
    23. Gradiente
    24. Pintar traçados estilizados usando o Pincel História da Arte
    25. Pintar com um padrão
    26. Sincronizar predefinições em vários dispositivos
  17. Texto
    1. Trabalhar com fontes OpenType SVG
    2. Formatação de caracteres
    3. Formatar parágrafos
    4. Como criar efeitos de texto
    5. Edição de textos
    6. Espaçamento de linhas e caracteres
    7. Texto árabe e hebraico
    8. Fontes
    9. Solução de problemas de fontes
    10. Texto asiático
    11. Criar texto
    12. Erro no mecanismo de texto usando a ferramenta Texto no Photoshop | Windows 8
    13. Compositor World-Ready para scripts asiáticos
    14. Como adicionar e editar o texto no Photoshop
  18. Vídeo e animação
    1. Edição de vídeo no Photoshop
    2. Editar camadas de animação e de vídeo
    3. Visão geral de vídeo e animação
    4. Visualização de vídeo e animações
    5. Como pintar quadros em camadas de vídeo
    6. Importar arquivos de vídeo e sequências de imagem
    7. Criar quadros de animação
    8. Creative Cloud 3D Animation (visualização)
    9. Criar animações de linha do tempo
    10. Criar imagens para vídeo
  19. Filtros e efeitos
    1. Usar o filtro Dissolver
    2. Utilize a Galeria de desfoque
    3. Noções básicas sobre filtros
    4. Referência de efeitos de filtros
    5. Adição de efeitos de iluminação
    6. Usar o filtro Grande angular adaptável
    7. Usar o filtro Pintura a óleo
    8. Efeitos e estilos de camadas
    9. Aplicar filtros específicos
    10. Como borrar áreas da imagem
  20. Salvar e exportar
    1. Salvar seus arquivos no Photoshop
    2. Exportar seus arquivos no Photoshop
    3. Formatos de arquivo compatíveis
    4. Salvar arquivos em formatos de gráficos
    5. Mover designs entre o Photoshop e o Illustrator
    6. Salvar e exportar vídeo e animações
    7. Salvar arquivos PDF
    8. Proteção de direitos autorais da Digimarc
  21. Impressão
    1. Imprimir objetos 3D
    2. Imprimir a partir do Photoshop
    3. Imprimir usando gerenciamento de cores
    4. Páginas de amostra e apresentações em PDF
    5. Imprimir fotos em um layout do pacote de figuras
    6. Imprimir cores spot
    7. Duotônicos
    8. Imprimir imagens em uma prensa tipográfica comercial
    9. Aprimorar as impressões em cores do Photoshop
    10. Solução de problemas de impressão | Photoshop
  22. Automação
    1. Criação de ações
    2. Criar gráficos orientados por dados
    3. Scripts
    4. Processamento de um lote de arquivos
    5. Executar e gerenciar ações
    6. Adicionar ações condicionais
    7. Sobre ações e o Painel Ações
    8. Gravar ferramentas em ações
    9. Adição de uma alteração do modo condicional a uma ação
    10. Conjunto de ferramentas de interface de usuário (UI) do Photoshop para plug-ins e scripts
  23. Gerenciamento de cores
    1. Sobre gerenciamento de cores
    2. Uniformização de cores
    3. Configurações de cor
    4. Trabalhar com perfis de cores
    5. Gerencie as cores de documentos para exibição on-line
    6. Documentos com gerenciamento de cores durante a impressão
    7. Imagens importadas com gerenciamento de cores
    8. Revisão de cores
  24. Autenticidade do conteúdo
    1. Saiba mais sobre credenciais de conteúdo
    2. Identidade e proveniência de NFTs
    3. Conectar contas para atribuição de criativos
  25. Visualização em 3D e imagens técnicas
    1. Photoshop 3D | Perguntas frequentes sobre recursos 3D descontinuados
    2. Creative Cloud 3D Animation (visualização)
    3. Imprimir objetos 3D
    4. Pintura 3D
    5. Aprimoramentos no painel 3D | Photoshop
    6. Conceitos e ferramentas essenciais sobre 3D
    7. Renderizar e salvar em 3D
    8. Criar animações e objetos 3D
    9. Pilhas de imagens
    10. Fluxo de trabalho 3D
    11. Medida
    12. Arquivos DICOM
    13. Photoshop e MATLAB
    14. Contagem de objetos em uma imagem
    15. Combinar e converter objetos 3D
    16. Edição de textura 3D
    17. Ajustar a exposição e tonalização HDR
    18. Configurações do painel 3D

Gráficos orientados por dados possibilitam a criação rápida e precisa de várias versões de uma imagem para projetos de impressão ou da Web. Por exemplo, com base em um único projeto de modelo, é possível criar 100 versões de um banner da Web com textos e imagens diferentes.

Siga estas etapas gerais para criar gráficos a partir de modelos e conjuntos de dados:

Crie o gráfico base que será usado como modelo.

Use camadas para separar os elementos a serem alterados no gráfico.

Defina variáveis no gráfico.

Variáveis especificam as partes da imagem que são alteradas. (Consulte Definição de variáveis.)

Crie ou importe os conjuntos de dados.

É possível criar os conjuntos de dados no modelo ou importá-los a partir de um arquivo de texto. (Consulte Definição de um conjunto de dados e Criação de conjuntos de dados em arquivos externos.)

Visualize o documento com cada conjunto de dados.

Para verificar a aparência final dos gráficos, é possível visualizá-los antes de exportar todos os arquivos. (Consulte Visualização ou aplicação de um conjunto de dados.)

Gere os gráficos exportando-os junto com os dados.

Esses gráficos podem ser exportados como arquivos PSD (Photoshop).. (Consulte Geração de dados com o uso de conjuntos de dados.)

Versões diferentes de uma imagem usando variáveis do Photoshop
Criação de diferentes versões de uma imagem usando variáveis

A. Modelo de arquivo de origem B. O usuário define camadas como variáveis. C. Diferentes versões da imagem podem ser criadas, cada qual com um conjunto distinto de dados de variáveis. 

Definição de variáveis

Variáveis são usadas para definir quais elementos são alterados em um modelo. É possível definir três tipos de variáveis. Variáveis de visibilidade mostram ou ocultam o conteúdo de uma camada. Variáveis de Substituição de Pixel substituem os pixels na camada pelos pixels de outro arquivo de imagem. Variáveis de Substituição de Texto substituem uma seqüência de texto em uma camada de texto.

Observação:

o GoLive reconhece todas as variáveis de texto e de visibilidade, mas não reconhece as variáveis de Substituição de Pixel.

Variáveis de definição do Photoshop
Duas versões de uma imagem com base no mesmo modelo

A. Variável de visibilidade B. Variável de Substituição de Pixel C. Variável de Substituição de Texto 

Não é possível definir variáveis para a camada de Plano de Fundo.

  1. Escolha Imagem > Variáveis > Definir.
  2. No menu pop-up Camada, selecione uma camada que inclua o conteúdo a ser definido como variável.

  3. Selecione um ou mais tipos de variáveis:

    Visibilidade

    Mostra ou oculta o conteúdo da camada ou do grupo de camadas.

    Substituição de Pixel

    Substitui os pixels na camada pelos pixels de outro arquivo de imagem.

    Substituição de Texto

    Substitui uma seqüência de texto em uma camada de texto.

  4. Siga um destes procedimentos:
    • Escolha Nome e digite um nome para a variável. Nomes de variáveis devem começar com uma letra, um caractere de sublinhado ou um caractere de dois pontos e não podem conter espaços ou caracteres especiais (exceto pontos, hífens, sublinhados e dois pontos).

    • No menu pop-up Nome, escolha uma variável existente à qual vincular a camada em questão. As camadas vinculadas à mesma variável aparecem ao lado do menu Nome, junto com o ícone de vínculo.

  5. Para variáveis de Substituição de Pixel, defina as seguintes opções.
    • Escolha um método para o dimensionamento da imagem de substituição: A opção Ajustar dimensiona a imagem de forma a ajustá-la à caixa delimitadora (podendo deixar partes da caixa delimitadora em branco). A opção Preencher dimensiona a imagem de forma que ela preencha a caixa delimitadora totalmente (podendo fazer com que a imagem ultrapasse os limites delimitados). A opção Como Está não dimensiona a imagem, enquanto a opção Encaixar dimensiona essa imagem desproporcionalmente de forma a ajustá-la à caixa delimitadora.

    • Clique em uma alça do ícone de alinhamento para escolher um alinhamento que colocará a imagem na caixa delimitadora. (Ela não está disponível para o método Encaixar.)

    • Selecione a opção Recorte para Caixa Delimitadora para recortar áreas da imagem que não se ajustam à caixa delimitadora. Essa opção apenas está disponível com a seleção do método de substituição Preencher ou Como Está. (Ela não está disponível para o método Encaixar.)

  6. Para definir variáveis em uma outra camada, escolha essa camada no menu.pop-up Camada.. Um asterisco é exibido ao lado do nome de uma camada que contenha variáveis. É possível usar as setas de navegação para percorrer camadas.
  7. Clique em OK.

Renomeação de uma variável

  1. Escolha Imagem > Variáveis > Definir.
  2. No menu pop-up Camada, escolha a camada que contém a variável.
  3. Para renomear a variável, digite um nome na caixa de texto Nome. Nomes de variáveis devem começar com uma letra, um caractere de sublinhado ou um caractere de dois pontos e não podem conter espaços ou caracteres especiais (exceto pontos, hifens, sublinhados e dois pontos).
  4. Para remover a variável, basta cancelar sua seleção.

Definição de um conjunto de dados

Um conjunto de dados é um agrupamento de variáveis e dados associados. Um conjunto de dados é definido para cada versão do gráfico que o usuário pretende gerar.

  1. Siga um destes procedimentos:
    • Escolha Imagem > Variáveis > Conjuntos de Dados.

    • Se a caixa de diálogo Variáveis estiver aberta, escolha Conjuntos de Dados, no menu pop-up localizado na parte superior da caixa de diálogo, ou clique em Próximo.

    Observação:

    Defina pelo menos uma variável antes de editar o conjunto de dados padrão.

  2. Clique no botão Novo conjunto de dados  .
  3. No menu pop-up Nome ou na lista localizada na parte inferior da caixa de diálogo, selecione uma variável.
  4. Edite os dados das variáveis:
    • Para variáveis de Visibilidade., selecione Visível para mostrar o conteúdo da camada ou Invisível para ocultar esse conteúdo.

    • Para variáveis de Substituição de Pixel., clique em Selecionar Arquivo, e selecione um arquivo de imagem de substituição. Clique em Não Substituir antes de aplicar o conjunto de dados para manter a camada em seu estado atual.

    Observação:

    A opção Não Substituir não redefinirá o arquivo para seu estado original se outra substituição já tiver sido aplicada.

    • Para variáveis de Substituição de Texto , digite uma seqüência de texto na caixa de texto Valor.
  5. Defina conjuntos de dados adicionais para cada versão do gráfico a ser gerado.

Posteriormente, será possível editar, renomear ou excluir o conjunto de dados escolhendo-o no menu pop-up Conjunto de Dados e, em seguida, editando suas opções. Use os ícones de seta para percorrer conjuntos de dados. Clique no ícone Excluir para excluir um conjunto de dados.

Visualização ou aplicação de um conjunto de dados

É possível aplicar o conteúdo de um conjunto de dados à imagem base e, ao mesmo tempo, deixar todas as variáveis e todos os conjuntos de dados inalterados. Essa ação altera a aparência do documento PSD de forma a incluir os valores do conjunto de dados. Também é possível visualizar a aparência de cada versão do gráfico com cada conjunto de dados.

Observação:

A aplicação de um conjunto de dados sobrescreve o documento original.

  1. Escolha Imagem > Aplicar Conjuntos de Dados. Selecione o conjunto de dados na lista e visualize a imagem na janela de documentos. Para aplicar um conjunto de dados, clique em Aplicar. Clique em Cancelar se você não estiver visualizando e não quiser alterar a imagem base.

    Também é possível aplicar e visualizar um conjunto de dados na página Conjunto de Dados, localizada na caixa de diálogo Variáveis.

Geração de gráficos como o uso de conjuntos de dados

Depois de definir variáveis e um ou mais conjuntos de dados, é possível gerar imagens, no modo em lote, usando os valores desse(s) conjunto(s) de dados e como arquivos PSD.

  1. Escolha Arquivo > Exportar > Conjuntos de Dados como Arquivos.
  2. Digite um nome base para todos os arquivos gerados. Se desejar, crie um esquema personalizado de nomenclatura de arquivo.
  3. Clique no botão Selecionar Pasta para selecionar um diretório de destino para os seus arquivos.
  4. Escolha conjuntos de dados a serem exportados.
  5. Clique em OK.

Criação de conjuntos de dados em arquivos externos

É possível criar rapidamente vários conjuntos de dados criando um arquivo de texto externo que inclua todas as informações sobre variáveis e carregando esse arquivo em um documento PSD que possua variáveis. Um dos métodos para fazer isso é digitar dados em um arquivo de texto ou em uma planilha do Microsoft Excel e, em seguida, exportar esses dados como um arquivo separado por vírgula ou tabulação.

A sintaxe do arquivo de texto externo é a seguinte (em que cada linha iniciada com "Variable" ou "Value" corresponde a uma linha inteira no arquivo):

VariableName1<sep>VariableName2<sep> <sep>VariableNameN <nl> 
Value1-1<sep>Value2-1<sep><sep>ValueN-1<nl> 
Value1-2<sep>Value2-2<sep><sep>ValueN-2<nl> 
Value1-M<sep>Value2-M<sep><sep>ValueN-M<nl>

Todos os nomes de variáveis são listados na primeira linha, seguindo a ordem na qual os valores são fornecidos nas linhas subseqüentes. Cada linha subseqüente representa um conjunto de dados, com os valores para cada variável especificada.

Observação:

Para criar várias linhas de texto em uma única linha de texto em um conjunto de dados, delimite o texto por aspas duplas e quebras de linha forçadas no arquivo separado por vírgula ou tabulação no qual deseja que as divisões ocorram.  

Elementos de sintaxe de arquivos de texto externos

<sep>

Arquivo separado por vírgula (CSV) ou por tabulação que separa cada nome ou valor de variável.

<nl>

Caractere de nova linha que termina cada conjunto de dados e que pode consistir em uma alimentação de linha e/ou em um retorno de carro.

“true” e “false”

Valores permitidos para uma variável de visibilidade.

Espaços

Espaços ao redor do delimitador são removidos durante a análise do arquivo. Espaços entre palavras em uma seqüência de valores (por exemplo, valores idênticos) são preservados, enquanto espaços à esquerda e à direita serão mantidos se estiverem delimitados por aspas duplas (por exemplo, “exclusivo”).

Aspas duplas

Podem ser parte de um valor caso estejam precedidas por outras aspas duplas (por exemplo, ““B”” pode corresponder a “B” no conjunto de dados).

Se <sep> ou <nl> fizer parte do valor da variável, o valor inteiro deverá ser delimitado por aspas duplas.

Todas as variáveis definidas no documento PSD devem estar especificadas no arquivo de texto. Será exibido um erro se o número de variáveis no arquivo de texto não corresponder ao número no documento.

Exemplo de conjunto de dados:

Com o uso de um modelo para “flores”, que possui variáveis para “tulipa” e “girassol”, é possível configurar um arquivo de texto com a seguinte aparência:

{contents of FlowerShow.txt} 
Variable 1, Variable 2, Variable 3 
true, TULIP, c:\My Documents\tulip.jpg 
false, SUNFLOWER, c:\My Documents\sunflower.jpg 
false, CALLA LILY, c:\My Documents\calla.jpg 
true, VIOLET, c:\My Documents\violet.jpg
Observação:

Um caminho relativo poderá ser usado para o local da imagem se o arquivo de texto estiver na mesma pasta que o arquivo original. Por exemplo, o último item do modelo apresentado pode ser: true, VIOLET, violet.jpg.

Importação de um conjunto de dados

  1. Siga um destes procedimentos:
    • Escolha Arquivo > Importar > Conjunto de Dados Variáveis.

    • Escolha Imagem > Variáveis > Conjuntos de Dados e clique no botão Importar.

  2. Navegue até o arquivo de texto a ser importado.
  3. Configure as opções de importação.

    Usar Primeira Coluna para Nomes de Conjuntos de Dados

    Nomeia cada conjunto de dados usando o conteúdo da primeira coluna do arquivo de texto (os valores referentes à primeira variável listada). Caso contrário, os conjuntos de dados serão nomeados como “Conjunto de Dados 1, Conjunto de Dados 2, etc.”

    Substituir Conjuntos de Dados Existentes

    Exclui todos os conjuntos de dados existentes antes da importação.

  4. Defina a codificação do arquivo de texto ou mantenha a configuração Automático.
  5. Clique em OK.
Logotipo da Adobe

Fazer logon em sua conta