Saiba como tornar mais rápida e eficaz a execução do Illustrator no Windows.

Vários fatores afetam a rapidez e eficiência da execução do Adobe Illustrator, como o seu sistema operacional, configuração de hardware, seu fluxo de trabalho e as opções selecionadas. Caso você perceba que o Illustrator está sendo executado mais lento do que o normal, tente as técnicas a seguir para otimizar não somente o desempenho do Illustrator, mas também o desempenho de seus outros aplicativos. (Um aprimoramento do desempenho é mais visível quando você trabalha com arquivos grandes).

Antes de começar

Antes de executar as etapas abaixo, assegure-se de instalar a versão mais recente do Illustrator ou quaisquer atualizações para a versão que você estiver utilizando. As atualizações de software geralmente incluem reparos ou melhorias relacionados à performance. 

Se estiver usando o Illustrator CC, é possível atualizar o Illustrator através do aplicativo de desktop Creative Cloud.

Observação:

Os procedimentos neste documento têm base na interface padrão do XP. Se a interface for personalizada, alguns procedimentos variarão. Por exemplo, o caminho para navegar até o Painel de controle pode variar. Escolha Iniciar > Configurações > Painel de controle ou Iniciar > Painel de controle, dependendo da sua versão do Windows. Para obter dicas de solução de problemas e informações gerais sobre o Windows, consulte Suporte da Adobe Suporte da Microsoft.

Otimizar o Windows

Ao configurar o sistema operacional para ter uma execução eficiente, você aumenta a quantidade de memória disponível para os aplicativos, o que ajuda que eles sejam executados com suavidade. Aqui estão diversas técnicas para otimizar o Windows e aprimorar o desempenho do Illustrator.

Aumentar a memória disponível

A memória virtual permite que utilizar espaço no disco rígido para armazenar as informações normalmente armazenadas na RAM. Leva mais tempo para acessar informações em um disco rígido do que acessar as informações na memória. Assim, isso pode reduzir o desempenho se o seu sistema tiver que confiar muito na memória virtual.

Para aprimorar o desempenho, escolha o tamanho correto para o seu arquivo de paginação (a área do disco rígido que armazena memória virtual). Os direitos de administrador são necessários para alterar o tamanho do arquivo de paginação. O Illustrator tem um melhor desempenho quando o tamanho máximo do arquivo de paginação for pelo menos três vezes a quantidade da RAM instalada.

  1. Saia de todos os aplicativos.

  2. Escolha Iniciar > Painel de Controle > Sistema > Configurações avançadas do sistema.

  3. Na caixa de diálogo Propriedades do sistema, escolha a guia Avançado.

  4. Clique em Configurações na seção Desempenho e, a seguir, escolha a guia Avançado.

  5. Na seção Memória virtual, clique em Alterar.

  6. Limpe a caixa de seleção Gerenciar automaticamente o tamanho de paging para todas as unidades .

  7. A partir da lista Unidade, selecione um disco rígido que possua pelo menos três vezes a quantidade da RAM instalada no computador. Por exemplo, se o computador tiver 64 MB de RAM, selecione um disco rígido que tenha pelo menos 192 MB de espaço livre. Para melhor desempenho, selecione um disco rígido não utilizado para o disco de trabalho do Illustrator.

Desativar os recursos do driver

Alguns drivers de adaptador de vídeo oferecem configurações avançadas para acelerar ou modificar a exibição de gráficos. Às vezes, essas configurações podem afetar contrariamente o desempenho do redesenho de tela no Illustrator. Tente desativar os recursos específicos do driver para determinar as melhores configurações a serem utilizadas com o Illustrator. Para obter mais informações, consulte a documentação do seu adaptador de vídeo.

Gerenciar fontes

Cada fonte que você tiver aumenta a quantidade de RAM utilizada pelo Windows. Instale apenas as fontes que precisar, para aprimorar o desempenho do sistema e dos aplicativos que acessam as fontes. Utilize um utilitário de gerenciamento de fonte para ajudar a gerenciar várias fontes.

Limitar a inicialização de aplicativos

Os aplicativos que são iniciados automaticamente com o Windows competem com o Illustrator pela RAM disponível. Para impedir que os aplicativos sejam iniciados automaticamente, faça o seguinte:

  1. Saia de todos os aplicativos.

  2. Inicie o Windows Explorer.
  3. Desative a inicialização de aplicativos ao mover todos os ícone e atalhos da pasta Iniciar (OSDisk\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp) para outra pasta.

  4. Reinicie o Windows.

Para fechar os aplicativos especificados para iniciar automaticamente no registro, faça o seguinte:

  1. Reinicie o Windows.
  2. Pressione Ctrl+Shift+Esc.

  3. Escolha a guia Processos.

  4. Selecione um nome de aplicativo e, a seguir, clique em Finalizar a tarefa.

  5. Reinicie o Illustrator. Se o desempenho do Illustrator melhorar, entre em contato com o fabricante do aplicativo para ajudá-lo na desativação permanente de seu início automático. Repita as etapas 2 a 5 para cada aplicativo de inicialização remanescente.

Reativar ícones e atalhos

Se o desempenho do Illustrator não melhorar após a reinicialização, então reative os ícones e os atalhos no Windows Explorer colocando-os de volta na pasta de inicialização.

Se o desempenho do Illustrator melhorar, então isole o problema de desempenho a um ou mais programas e reative seus ícones e atalhos ao colocá-los na pasta de inicialização usando o Windows Explorer.

Reinicie o computador depois da reativação de cada conjunto de ícones e atalhos e teste o desempenho do Illustrator.

Repita este processo até que o desempenho do Illustrator se degrade. Depois de isolar o ícone ou atalho que está causando o problema de desempenho, remova-o novamente e entre em contato com o fabricante do programa para verificar se há alguma atualização disponível.

Otimizar o hardware

O hardware utilizado afeta o desempenho do Illustrator: quanto mais rápido o processador ou o disco rígido, mais rápido o Illustrator poderá processar a informação. Outras melhorias do hardware, tais como instalar a memória RAM adicional, utilizar um sistema multiprocessador ou otimizar e desfragmentar unidades, também podem melhorar o desempenho. Tente estas técnicas otimizar o hardware.

Usar um processador mais rápido

A velocidade da Unidade de Processamento Central (CPU) do computador afeta a velocidade do Illustrator. Como o Illustrator manipula grandes quantidades de dados e executa muitos cálculos, sua velocidade depende da velocidade do processador. Considere a utilização de um computador com um processador mais rápido.

Instalar RAM adicional

Se o Illustrator possuir memória RAM insuficiente, ele usa o espaço no disco rígido (memória virtual, disco de trabalho ou ambos) para processar as informações. O Illustrator fica mais rápido quando pode processar as informações na memória, sem usar um disco rígido.

Otimizar espaço em disco

Aqui estão algumas maneiras de otimizar o espaço em disco:

  • Verifique seu disco rígido quanto a existência de erros, arquivos desfragmentados e faça melhor uso do espaço em disco rígido disponível usando os programas de CHKDSK.exe e Desfragmentador de disco. Para obter mais informações, consulte a documentação do Windows ou Aprimorar o desempenho para o Windows.
  • Salve seus arquivos nas unidades com velocidades de acesso mais rápidas. Por exemplo, use um disco rígido interno em vez de um servidor de rede (unidade de rede) ou uma unidade externa.
  • Se você desejar salvar um arquivo em uma rede ou em uma unidade externa, primeiro salve o arquivo em um disco rígido interno. A seguir, feche o arquivo e use o Windows Explorer para copiá-lo na rede ou para a unidade externa.

Usar uma impressora PostScript

Para obter melhores resultados ao imprimir a partir do Illustrator, utilize uma impressora PostScript. A maioria das impressoras não-PostScript conta com informações de exibição, recursos de servidor e drivers da própria impressora para retransmitir informações de impressão para a impressora. Por isso podem levar mais tempo para imprimir do que uma impressora PostScript.

Usar os recursos do Illustrator com eficácia

A maneira como você trabalha no Illustrator - especialmente a maneira na qual você visualiza a arte final - pode afetar o desempenho do Illustrator. Aqui estão algumas maneiras de usar eficientemente os recursos do Illustrator.

Trabalhar na visualização do contorno

A visualização de contorno oculta os atributos da pintura, exibindo a arte-final como um demarcador vazio. Trabalhar em visualização de contorno pode acelerar a exibição das artes-finais complexas, tais como objetos que contém gradientes ou padrões. A visualização de contorno também pode facilitar a edição de objetos ocultos por atrás de outros objetos preenchidos.

Para exibir um documento do Illustrator na Visualização do Contorno, escolha Visualizar > Contorno.

Criar exibições personalizadas

Você pode criar visualizações personalizadas do documento. As exibições personalizadas permitem alterar rapidamente o modo de exibição, a ampliação, a posição de rolagem e as opções de camada.

Para criar uma visualização personalizada de um documento do Illustrator, defina os atributos da visualização que desejar salvar. A seguir, escolha Visualizar > Nova visualização e insira um nome na caixa de diálogo Nova visualização. A exibição personalizada aparece no menu Exibir.

Alterar as configurações de efeitos de rasterização

É possível alterar a resolução de efeitos raster para otimizar o desempenho do Illustrator.

Para alterar a resolução de efeitos de rasterização, escolha Efeito > Configurações de efeitos de rasterização do documento. No menu suspenso Resolução , faça um dos seguintes:

  • Escolha Tela se você estiver editando arquivos. O Illustrator utiliza uma resolução de 72 ppi para efeitos de rastreio, aumentando a velocidade de exibição.
  • Escolha Alto se você estiver imprimindo arquivos. O Illustrator utiliza uma resolução de 300 ppi para efeitos raster, diminuindo a velocidade de impressão, mas aumentando a qualidade de impressão.

A seguir, clique em OK.

Ocultar camadas e remover as miniaturas

Use o painel Camadas para organizar e modificar a arte-final. Ao ocultar camadas que contêm uma arte-final complexa, ou imagens de bitmap de alta resolução, o Illustrator redesenha a tela mais rapidamente.

Para ocultar uma camada, clique no ícone de olho à esquerda do nome da camada. Para ocultar todas, menos a camada selecionada, pressione Alt+clique no ícone do olho.

O painel Camadas pode exibir miniaturas para camadas de alto nível, camadas aninhadas, grupos e objetos. Para reduzir o número de miniaturas para que o Illustrator redesenhe a tela mais rápido, escolha Opções de painel no menu do painel Camadas e reduza o número de miniaturas.

Painel Opções

Desativar a visualização de sobreimpressão

A visualização de superimposição fornece uma "visualização da tinta" que se aproxima da mesclagem, da transparência e da superimposição que aparecerá na saída com separação de cores. Para aprimorar o desempenho, evite utilizar a visualização de superimposição.

Para ativar e desativar a Visualização de sobreimpressão, escolha Visualizar > Visualização de sobreimpressão.

Excluir pranchetas não usadas

As pranchetas representam as regiões que podem conter artes-finais imprimíveis. Para otimizar o desempenho, recomenda-se excluir áreas de arte sem uso ou desnecessárias.

Para gerenciar suas pranchetas, escolha Janela > Pranchetas. Selecione uma prancheta que desejar remover e clique em Excluir.

Alterar a preferência do disco de trabalho

Ao trabalhar com uma imagem de bitmap incorporada e o seu sistema não tiver RAM suficiente, o Illustrator usa espaço do disco rígido ou de um disco de trabalho. Ele leva mais tempo para acessar informações em um disco rígido do que para acessar informações na memória. Por isso usar uma porção do disco rígido como memória virtual pode reduzir o desempenho. Se você precisar de mais memória para trabalhar no Illustrator, a Adobe recomenda a instalação de mais memória RAM.

Por padrão, o Illustrator utiliza a unidade do sistema como seu disco de trabalho principal. Altere a configuração do disco de trabalho primário do Illustrator para o seu disco rígido mais rápido.

Para alterar a preferência de disco de trabalho, faça o seguinte:

  1. Escolha Editar > Preferências > Plug-ins e disco de trabalho.

  2. Selecione um disco rígido a partir do menu suspenso Principal. Se você trabalha com imagens grandes e possui mais de um disco rígido, escolha outro disco a partir do menu suspenso Secundário.

  3. Clique em OK e reinicie o Illustrator.

Remover elementos não usados dos perfis de documento

Os perfis de documento do Illustrator contêm os padrões, os gradientes, os gráficos, as cores, as bibliotecas de cores e os pincéis que aparecem nos novos documentos do Illustrator. Esses arquivos também determinam o nível de zoom, tamanho da janela, preferências de exibição e posição de rolagem para novos documentos. Minimize o tamanho dos novos documentos removendo amostras e pincéis desnecessários dos novos perfis de documento do Illustrator.

Para obter instruções sobre como criar perfis de documentos personalizados no Illustrator, consulte Perfis de inicialização: Uma ótima ferramenta para personalizar seus novos documentos.

Remover elementos não usados dos modelos

Os modelos lhe permitem criar novos documentos que compartilham configurações e elementos de design em comum. Você pode minimizar o tamanho do arquivo de novos documentos, removendo amostras desnecessárias, símbolos, estilos gráficos e pincéis de modelos.

Para obter instruções sobre como criar arquivos de modelo, consulte Arquivos e modelos.

Ativar os vínculos para imagens

As imagens bitmap incorporadas (por exemplo, TIFF, BMP ou Photoshop EPS) podem aumentar dramaticamente o tamanho de um documento Illustrator, causando um desempenho mais lento. Para aprimorar o desempenho, ative a opção Vínculo quando você for colocar uma imagem de bitmap. A opção Vincular faz referência a imagem inserida no disco rígido.

  • Selecione Arquivo > Colocar. Na caixa de diálogo Inserir, selecione Vínculo.

Se uma agência de serviços requer imagens incorporadas, salve uma cópia dos arquivos. Escolha Incluir arquivos vinculados nas Opções de formato nativo do Illustrator ou a caixa de diálogo Opções de formato EPS .

Use visualizações EPS de baixa resolução

Se um documento tiver imagens EPS com visualizações de alta resolução, o Illustrator redesenha a tela lentamente enquanto você edita a arte-final. Para ativar o Illustrator para redesenhar a tela mais rapidamente, utilize visualizações de EPS de baixa resolução. Faça o seguinte:

  1. Escolha Editar > Preferências > Manuseio de arquivo e área de transferência.

  2. Selecione Usar baixa resolução de proxy para EPS vinculado e clique em OK.

Desativar Mostrar as interações de transparência DCS

A caixa de diálogo Opções de painel de vínculos inclui uma opção Exibir interações de transparência DCS. Se essa opção estiver selecionada, o painel Vínculos exibe um ícone amarelo para identificar os gráficos EPS DCS vinculados que são transparentes ou que sobrepõem objetos transparentes. Como esta opção força o Illustrator a determinar regularmente se os arquivos EPS vinculados interagem com a transparência, ela pode reduzir o desempenho.

Para desativar a opção Mostrar interações de transparências, faça o seguinte:

  1. Selecione Windows > Links. No menu do painel Vínculos, selecione Opções de painel.

  2. Limpe Mostrar interações de transparência DCS e clique em OK.

Ocultar o painel Navegador

O painel Navegador exibe uma visualização em miniatura da arte-final atual para facilitar a navegação. O tempo de processamento necessário para atualizar a miniatura cada vez você altera o documento depende da complexidade da arte-final. Para aprimorar a velocidade de redesenho da tela em um documento complexo, oculte o painel Navegador. No menu Janela, desmarque Navegador.

É possível configurar exibições personalizadas para obter um zoom mais eficiente em áreas específicas do seu documento.

Desativar o trabalho artístico com suavização de serrilhado

A opção de arte-final com suavização de serrilhado suaviza o texto e gráficos mesclando a cor dos pixels da borda do objeto com a cor dos pixels adjacentes. No entanto, esse processo pode causar o redesenho lento da tela. Para desativar essa opção, faça o seguinte:

  1. Escolha Editar > Preferências > Geral.

  2. Desmarque Arte final da suavização de borda e clique em OK.

Aplicar o comando Simplificar

O comando Simplificar reduz o número de pontos de ancoragem em caminhos e formas de caminho, reduzindo o tamanho do arquivo e aumentando o desempenho. Para aplicar o comando Simplificar, selecione o caminho ou objeto desejado e ,a seguir, escolha Objeto > Caminho > Simplificar.

Para obter mais informações sobre o comando Simplificar, consulte a Ajuda do Illustrator.

Desativar as guias inteligentes

As guias inteligentes lhe permitem criar, alinhar, editar e transformar objetos do Illustrator correspondentes a outros objetos. Se houver vários objetos na arte-final, o Illustrator exigirá mais tempo para exibir as guias inteligentes. Para desativar as Guias inteligentes, no menu Visualizar, desmarque Guias inteligentes.

Para obter mais informações sobre as Guias inteligentes, consulte Réguas, grades, guias e marcas de corte.

Rasterizar caminhos do Pincel de cerdas e desativar os recursos de PDF

Traçados de pincéis de cerda são feitos de vários caminhos sobrepostos, cheios e transparentes. Esses demarcadores, como qualquer outro demarcador preenchido do Illustrator, interagem com a tinta de outros objetos, inclusive com os demarcadores dos pincéis de cerda.

Teste e experimente com os pincéis de cerda e rendição de tinta antes de começar artes-finais de larga escala. Alterar os atributos dos pincéis e reaplicá-los acabará por reaproveitar todos os pincéis usados.

Ao utilizar Pincéis de cerdas, é possível reduzir a complexidade e o tamanho do arquivo do seu documento ao fazer o seguinte:

  • Rasterize alguns caminhos do Pincel de cerdas. Certifique-se de salvar uma cópia do trabalho artístico original antes da rasterização.

Se a arte-final contiver um grande número (superior a 30) de pincéis de cerdas, reduza a complexidade e número dos demarcadores de Pincel de cerdas. Selecione os caminhos Pincel de cerdas e escolha Objeto > Rasterizar.

  • Desative os recursos de PDF.

Por padrão, o Illustrator salva os dados PDF, permitindo que os arquivos do Illustrator (*.ai) sejam compatíveis com outros aplicativos da Adobe. Escolha Arquivo Salvar ou Arquivo > Salvar como e clique em Salvar. Na caixa de diálogo Opções do Illustrator, desmarque Criar arquivo compatível com PDF.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online