Guia do Usuário Cancelar

Mescla de dados usando o painel Variáveis

  1. Guia do Usuário do Illustrator
  2. Conheça o Illustrator
    1. Introdução ao Illustrator
      1. Novidades no Illustrator
      2. Perguntas frequentes
      3. Requisitos de sistema do Illustrator
      4. Illustrator para Apple Silicon
    2. Área de trabalho
      1. Princípios da área de trabalho
      2. Aprenda mais rápido com o painel Descobrir do Illustrator
      3. Criar documentos
      4. Barra de ferramentas
      5. Atalhos de teclado padrão
      6. Personalizar atalhos de teclado
      7. Introdução às pranchetas
      8. Gerenciar pranchetas
      9. Personalizar a área de trabalho
      10. Painel Propriedades
      11. Definir preferências
      12. Área de trabalho sensível ao toque
      13. Suporte ao Microsoft Surface Dial no Illustrator
      14. Desfazer edições e gerenciar histórico de design
      15. Girar visualização
      16. Guias, grades e réguas
      17. Acessibilidade no Illustrator
      18. Modo de segurança
      19. Exibir a ilustração
      20. Usar a Touch Bar com o Illustrator
      21. Arquivos e modelos
    3. Ferramentas no Illustrator
      1. Principais características das ferramentas
      2. Selecionar ferramentas
        1. Seleção
        2. Seleção direta
        3. Seleção de grupos
        4. Varinha mágica
        5. Laço
        6. Prancheta
      3. Ferramentas de navegação
        1. Mão
        2. Girar visualização
        3. Aplicar zoom
      4. Ferramentas de pintura
        1. Degradê
        2. Malha
        3. Construtor de formas
      5. Ferramentas de texto
        1. Texto
        2. Tipo no caminho
        3. Texto vertical
      6. Ferramentas de desenho
        1. Caneta
        2. Adicionar ponto de ancoragem
        3. Excluir ponto de ancoragem
        4. Ponto de ancoragem
        5. Curvatura
        6. Segmento de linha
        7. Retângulo
        8. Retângulo arredondado
        9. Elipse
        10. Polígono
        11. Estrela
        12. Pincel
        13. Pincel irregular
        14. Lápis
        15. Shaper
        16. Fatia
      7. Ferramentas de modificação
        1. Girar
        2. Refletir
        3. Dimensionar
        4. Inclinar
        5. Largura
        6. Transformação livre
        7. Conta-gotas
        8. Mesclar
        9. Borracha
        10. Tesoura
    4. Ações rápidas
      1. Texto retrô
      2. Texto com brilho néon
      3. Texto Old school
      4. Recolorir
      5. Converter esboço em vetor
  3. Illustrator no iPad
    1. Introdução ao Illustrator no iPad
      1. Visão geral do Illustrator no iPad
      2. Perguntas frequentes sobre o Illustrator no iPad
      3. Requisitos de sistema | Illustrator no iPad
      4. O que você pode ou não fazer no Illustrator no iPad
    2. Área de trabalho
      1. Área de trabalho do Illustrator no iPad
      2. Atalhos de toque e gestos
      3. Atalhos de teclado para o Illustrator no iPad
      4. Gerenciar as configurações do seu aplicativo
    3. Documentos
      1. Trabalhar com documentos no Illustrator no iPad
      2. Importar documentos do Photoshop e do Fresco
    4. Selecionar e organizar objetos
      1. Criar objetos repetidos
      2. Mesclar objetos
    5. Desenho
      1. Desenhar e editar caminhos
      2. Desenhar e editar formas
    6. Texto
      1. Trabalhar com texto e fontes
      2. Criar designs de texto em um caminho
      3. Adicionar suas próprias fontes
    7. Trabalhar com imagens
      1. Vetorizar imagens rasterizadas
    8. Cor
      1. Aplicar cores e degradês
  4. Documentos na nuvem
    1. Noções básicas
      1. Trabalhar com documentos na nuvem do Illustrator
      2. Compartilhar e colaborar em documentos na nuvem do Illustrator
      3. Compartilhar documentos para revisão
      4. Atualizar armazenamento na nuvem para o Adobe Illustrator
      5. Documentos na nuvem do Illustrator | Perguntas comuns
    2. Solução de problemas
      1. Solucionar problemas ao criar ou salvar documentos na nuvem no Illustrator
      2. Solucionar problemas de documentos na nuvem do Illustrator
  5. Adicionar e editar conteúdo
    1. Desenho
      1. Noções básicas sobre desenho
      2. Editar caminhos
      3. Desenhar artes com pixels perfeitos
      4. Desenhar com a ferramenta Caneta, Curvatura ou Lápis
      5. Desenhar linhas e formas simples
      6. Traçado de imagem
      7. Simplificar um caminho
      8. Definir grades de perspectiva
      9. Ferramentas de simbolismo e conjuntos de símbolos
      10. Ajustar segmentos de caminho
      11. Criar uma flor em cinco etapas fáceis
      12. Desenho em perspectiva
      13. Símbolos
      14. Desenhar caminhos alinhados a pixels para fluxos de trabalho da Web
    2. Objetos e materiais 3D
      1. Sobre efeitos 3D no Illustrator
      2. Criar gráficos 3D
      3. Mapear ilustração em objetos 3D
      4. Criar texto 3D
    3. Cor
      1. Sobre cores
      2. Selecionar cores
      3. Usar e criar amostras
      4. Ajustar cores
      5. Usar o painel Temas do Adobe Color
      6. Grupos de cores (harmonias)
      7. Painel Temas do Color
      8. Recolorir sua ilustração
    4. Pintura
      1. Sobre pintura
      2. Pintura com preenchimentos e traçados
      3. Grupos de Pintura em tempo real
      4. Gradientes
      5. Pincéis
      6. Modos de transparência e mistura
      7. Aplicar traçado a um objeto
      8. Criar e editar padrões
      9. Malhas
      10. Padrões
    5. Selecionar e organizar objetos
      1. Selecionar objetos
      2. Camadas
      3. Agrupar e expandir objetos
      4. Mover, alinhar e distribuir objetos
      5. Empilhar objetos    
      6. Bloquear, ocultar e excluir objetos
      7. Copiar e duplicar objetos
      8. Girar e refletir objetos
      9. Entrelaçar objetos
    6. Remodelar objetos
      1. Cortar imagens
      2. Transformar objetos
      3. Combinar objetos
      4. Cortar, dividir e aparar objetos
      5. Distorção de marionete
      6. Dimensionar, inclinar e distorcer objetos
      7. Mesclar objetos
      8. Remodelar usando envelopes
      9. Remodelar objetos com efeitos
      10. Criar formas com as ferramentas Shaper e Construtor de formas
      11. Trabalhar com Cantos ativos
      12. Fluxos de trabalho de remodelagem aprimorados com suporte para toque
      13. Editar máscaras de corte
      14. Formas em tempo real
      15. Criar formas usando a ferramenta Construtor de formas
      16. Edição global
    7. Texto
      1. Adicionar texto e trabalhar com objetos de texto
      2. Criar listas numeradas e com marcadores
      3. Gerenciar área de texto
      4. Fontes e tipografia
      5. Formatar texto
      6. Importar e exportar texto
      7. Formatar parágrafos
      8. Caracteres especiais
      9. Criar texto em um caminho
      10. Estilos de caracteres e parágrafos
      11. Guias
      12. Texto e tipo
      13. Localizar fontes ausentes (fluxo de trabalho do Typekit)
      14. Atualizar texto do Illustrator 10
      15. Texto árabe e hebraico
      16. Fontes | Perguntas frequentes e dicas de solução de problemas
      17. Criar efeito de texto em 3D
      18. Designs tipográficos criativos
      19. Dimensionar e girar texto
      20. Espaçamento entre linhas e caracteres
      21. Hifenização e quebras de linha
      22. Aprimoramentos de texto
      23. Dicionários de verificação ortográfica e idiomas
      24. Formatar caracteres asiáticos
      25. Compositores para scripts asiáticos
      26. Criar designs de texto com objetos de mistura
      27. Criar um pôster de texto usando o Traçado da imagem
    8. Criar efeitos especiais
      1. Trabalhar com efeitos
      2. Estilos de gráfico
      3. Criar uma sombra projetada
      4. Atributos de aparência
      5. Criar croquis e mosaicos
      6. Sombras projetadas, brilhos e difusão
      7. Resumo de efeitos
    9. Gráficos da Web
      1. Práticas recomendadas para a criação de gráficos da Web
      2. Gráficos
      3. SVG
      4. Criar animações
      5. Fatias e mapas de imagens
  6. Importar, exportar e salvar
    1. Importar
      1. Inserir vários arquivos
      2. Gerenciar arquivos vinculados e incorporados
      3. Informações sobre vínculos
      4. Desincorporar imagens
      5. Importar trabalho artístico do Photoshop
      6. Importar imagens de bitmap
      7. Importar arquivos Adobe PDF
      8. Importar arquivos EPS, DCS e AutoCAD
    2. Bibliotecas da Creative Cloud no Illustrator 
      1. Bibliotecas da Creative Cloud no Illustrator
    3. Salvar
      1. Salvar o trabalho artístico
    4. Exportar
      1. Usar arte do Illustrator no Photoshop
      2. Exportar o trabalho artístico
      3. Coletar ativos e exportar em lotes
      4. Compactar arquivos
      5. Criar arquivos Adobe PDF
      6. Extrair CSS | Illustrator CC
      7. Opções para Adobe PDF
      8. Informações de arquivos e metadados
  7. Impressão
    1. Preparar para imprimir
      1. Configurar documentos para impressão
      2. Alterar o tamanho e a orientação da página
      3. Especificar marcas de corte para aparar ou alinhar
      4. Introdução à tela grande
    2. Impressão
      1. Superimposição
      2. Imprimir com gerenciamento de cores
      3. Impressão PostScript
      4. Predefinições de impressão
      5. Marcas da impressora e sangrias
      6. Imprimir e salvar arte transparente
      7. Trapping
      8. Imprimir separações de cores
      9. Imprimir gradientes, malhas e misturas de cores
      10. Superimposição de branco
  8. Automatizar tarefas
    1. Mesclagem de dados usando o painel Variáveis
    2. Automação com scripts
    3. Automação com ações
  9. Solução de problemas 
    1. Problemas de falha
    2. Recuperar arquivos após falha
    3. Problemas em arquivos
    4. Formatos de arquivo com suporte
    5. Problemas no driver de dispositivo de GPU
    6. Problemas no dispositivo Wacom
    7. Problemas em arquivos DLL
    8. Problemas na memória
    9. Problemas no arquivo de preferências
    10. Problemas em fontes
    11. Problemas na impressora
    12. Compartilhar relatório de falha com a Adobe
    13. Melhorar o desempenho do Illustrator

Usando o painel Variáveis, você pode facilmente criar múltiplas variações do seu trabalho artístico, mesclando um arquivo de fonte de dados (CSV ou XML) com um documento do Illustrator. Por exemplo, ao invés de modificar manualmente os objetos em uma modelo, use a funcionalidade de mesclagem de dados para produzir centenas de variações de modelos para diferentes superfícies de forma rápida e precisa. Igualmente, você pode alterar os nomes dos participantes nos crachás de eventos ou variar imagens em banners da Web e cartões-postais, sem ter que refazer o trabalho artísticos. Crie de forma simples um design e, em seguida, produza rapidamente variações ao importar os nomes ou imagens a partir de um arquivo de fonte de dados.

Crie variações personalizadas do seu modelo de design para projetos diferentes, tais como pôsteres impressos, banners da Web, crachás para eventos, usando o painel Variáveis.

Pré-requisitos

Tudo o que você precisa para mesclar dados é um arquivo de fonte de dados e um documento de destino. 

  • arquivo de origem de dados contém as informações que variam em cada repetição do documento de destino, como os nomes, fotografias e os endereços dos destinatários de uma carta-formulário. Um arquivo de fonte de dados pode ser um arquivo delimitado por vírgula (.csv) ou um arquivo de linguagem de marcação extensível (.xml). 
  • O documento de destino é um documento do Illustrator que contém o trabalho artístico base para ser usado como modelo. Esse documento pode conter o substituto do campo de dados e os itens que permanecem os mesmos em cada iteração do documento mesclado.

Acessar a funcionalidade de mesclagem de dados

A mesclagem de dados é acessível a partir do painel Variáveis no Illustrator (Janela > Variáveis). O tipo e o nome de cada variável no documento estão listados no painel. Se a variável estiver vinculada a um objeto, a coluna Objetos exibirá o nome do objeto vinculada, como consta no painel Camadas. É possível classificar as linhas clicando em itens na barra do cabeçalho: por nome da variável, nome do objeto ou tipo de variável.

Painel Variáveis

A. Conjunto de dados B. Menu do painel C. Alternar entre conjuntos de dados D. Nome do objeto vinculado E. Nome da variável F. Tipo de variável G. Bloquear variáveis H. Tornar objeto dinâmico I. Tornar visibilidade dinâmica J. Desvincular variáveis K. Criar variáveis L. Excluir variáveis 

Etapas rápidas para mesclagem de dados

  1. Crie um documento do Illustrator para usar como modelo.

  2. Configure o arquivo de origem de dados no formato CSV ou XML. Para obter mais informações, consulte Preparar um arquivo de origem de dados.

  3. Importe um arquivo de origem de dados no Illustrator usando o painel Variáveis. Para obter mais informações, consulte Importar um arquivo de origem de dados.

  4. Vincule uma variável a um objeto em seu modelo. Para obter mais informações, consulte Vincular variáveis a objetos.

  5. Visualizar o documento com cada conjunto de dados antes de exportar todos os arquivos. Para obter mais informações, consulte Visualizar o documento com cada conjunto de dados.

  6. Exporte arquivos em lote de dados usando o painel Ações no Illustrator. Para obter mais informações, consulte Exportar arquivos usando o painel Ações.

Preparar um arquivo de origem de dados

Os arquivos de origem de dados devem ser salvos em arquivo delimitado por vírgulas (.csv) ou no formato Extensible Markup Language (.xml).

Configurar arquivos de origem CSV

Em um arquivo de texto delimitado por vírgula (.csv), os registros são separados por quebras de parágrafo; os campos são separados por vírgulas ou tabulações. O arquivo de origem dos dados também pode incluir texto ou demarcadores que veem imagens no disco. Antes de importar um arquivo CSV, faça o seguinte para que o Illustrator possa identificar o tipo de variável.

  1. Abra sua planilha.

  2. Especifique o nome do campo de dados na primeira linha da planilha. Em seguida, faça o seguinte:

    • No início do nome do campo de dados, digite um símbolo “arroba” (@) para inserir textos ou caminhos que se refiram a arquivos de imagem. O símbolo @ só é necessário na primeira linha; as linhas subsequentes deverão incluir os caminhos das imagens.
    • Da mesma forma, no início do nome do campo de dados, digite um símbolo de "porcentagem" (%) para gráficos e o símbolo de "hashtag" (#) para a visibilidade.
    Observação:
    • Os nomes do campo de dados na sua planilha não deve conter espaços em branco. Por exemplo, você pode especificar o campo de dados como Company_Name ao invés de Nome da empresa
    • Da mesma forma, os caminhos relacionados à imagem e arquivos gráficos não devem conter nenhum espaço em branco. Por exemplo, o caminho de um arquivo de imagem deve ser C:\Photos\BillTucker ao invés de C:\Photos\Bill Tucker.
    • Todos os arquivos gráficos vinculados a partir do arquivo de origem de dados devem ser salvos como arquivos delimitados por vírgulas (.csv).
    • Se for exibida uma mensagem de erro quando você digitar o símbolo @ no início do campo, digite um apóstrofo () antes do símbolo @ (por exemplo, @Fotos) para validar a função. Alguns aplicativos, como o Microsoft Excel, reservam o símbolo @ para executar funções.

    (Windows) Exemplo de referências a imagens e gráficos em um arquivo de origem de dados

    Nome

    Idade

    @Fotos

    %Gráficos

    Bill Tucker

    36

    C:\Fotos\BillTucker.jpg

    C:\Photos\BillTucker.csv

    Dat Nguyen

    53

    C:\MyDocuments\dat.jpg

    C:\MyDocuments\dat.csv

    Maria Ruiz

    26

    C:\Photos\Ruiz.jpg

    C:\Photos\Ruiz.csv

    (macOS) Exemplo de referências a imagens e gráficos em um arquivo de origem de dados

    Nome

    Idade

    @Fotos

    %Gráficos

    Bill Tucker

    36

    /Users/photos/BillTucker.jpg

    /Users/photos/BillTucker.csv

    Dat Nguyen

    53

    /Users/family/photos/dat.jpg

    /Users/family/photos/dat.csv

    Maria Ruiz

    26

    /Users/alpha/photos/Ruiz.jpg

    /Users/alpha/photos/Ruiz.csv

  3. Insira os dados na planilha.

  4. Siga um destes procedimentos:

    • Salve planilhas criadas usando a versão mais recente do Microsoft Excel (versão 2016) nos seguintes formatos de arquivo:
      • CSV (Comma delimited) (*.csv)
      • CSV (MS-DOS) (*.csv)
    • Salve as planilhas criadas usando os números Apple no formato CSV com codificação Unicode (UTF-8).
    Observação:

    No momento, os arquivos CSV exportados nos formatos mencionados acima contam com suporte no Illustrator. Outros formatos de arquivo CSV como Macintosh Comma Separated (.csv) não são suportados para a mesclagem de dados.

Preparar um arquivo XML

  1. Defina uma variável no seu documento. Para informações, consulte Vincular variáveis a objetos.

  2. Clique no botão Capturar conjunto de dados (), no painel Variáveis. Como alternativa, escolha Capturar conjunto de dados, no menu do painel Variáveis.

  3. Após criar o número desejado de conjuntos de dados, selecione Salvar biblioteca de variáveis a partir do menu do painel Variáveis para salvar os conjuntos de dados como um arquivo XML. Especifique o nome de arquivo, um local e clique em Salvar.

    Exporte as variáveis criadas no Illustrator como um arquivo XML

  4. Agora, edite o arquivo XML em um aplicativo de edição de texto como Notepad++ (Windows) ou TextWrangler (macOS) para incluir seus conjuntos de dados nesse arquivo.

    Exemplo: editar um arquivo XML usando qualquer aplicativo de edição de texto

    A. Substitua o caminho da imagem B. Substitua a string de texto 

  5. Para importar seu arquivo XML no Illustrator, selecione Carregar biblioteca de variáveis a partir do menu do painel Variáveis. Selecione o arquivo XML e clique em Abrir.

    Importar variáveis para o Illustrator

Importar um arquivo de origem de dados

Para vincular variáveis aos dados desejados, importe uma fonte de dados no painel Variáveis. Só é possível selecionar um arquivo de origem de dados por documento.

  1. Escolha Janela > Variáveis.

  2. No painel Variáveis, clique em Importar.

    Importar um arquivo de origem de dados usando o painel Variáveis

  3. Na caixa de diálogo Carregar biblioteca de variáveis, selecione um arquivo de fonte de dados em formato CSV ou XML e clique em Abrir.

    Selecionar um arquivo de fonte de dados CSV ou XML

  4. (Opcional) Você pode editar, renomear ou excluir o conjunto de dados depois ao selecioná-lo primeiramente a partir do  Conjunto de dados  menu suspenso e editar suas opções.

    • Para alternar entre conjuntos de dados, selecione um conjunto de dados na  lista Conjunto de dados  do painel Variáveis. Como alternativa, clique no botão Conjunto de dados anterior () ou Próximo conjunto de dados ().
    • Para aplicar os dados na prancheta ao conjunto de dados atual, escolha Atualizar  Conjunto de dados  no menu do painel Variáveis.
    • Para renomear um conjunto de dados, edite o texto diretamente na  Conjunto de dados  caixa de texto. Como alternativa, clique duas vezes nas palavras Conjunto de dados (à esquerda da  Conjunto de dados  caixa de texto), insira um novo  nome  e clique em OK.
    • Para excluir um conjunto de dados, clique no ícone Excluir. Como alternativa, escolha Excluir Conjunto de dados a partir do menu do painel Variáveis.

Vincular variáveis a objetos

Use as variáveis para definir elementos no modelo que deseja alterar. Você pode definir quatro tipos de variáveis: Variável de visibilidade, Variável de string de texto, Variável de arquivo vinculado e Variável de dados de gráficos. O tipo de uma variável indica que atributos de objetos são modificáveis (dinâmicos). O tipo e o nome de cada variável no documento estão listados no painel. Se a variável estiver vinculada a um objeto, a coluna Objetos exibirá o nome do objeto vinculada, como consta no painel Camadas.

Tipo de variável

Ícone para indicar o tipo da variável

Definição

Variáveis de visibilidade

Mostrar ou ocultar trabalho artístico.

Variáveis de string de texto

Substitua uma string de texto.

Variáveis de arquivos vinculados

Substitua o objeto na prancheta por um objeto de outro arquivo.

Variável de dados de gráficos

Substitua os valores em um gráfico.

Variável sem tipo (não vinculada)

Não vinculado a qualquer objeto.

Para definir as variáveis no Illustrator, faça o seguinte:

  1. Selecione um objeto.

  2. No painel Variáveis (Janela > Variáveis), selecione a variável que deseja vincular a ele.

  3.  Para vincular o objeto à variável, execute uma das seguintes ações:

    • Clique no botão Tornar objeto dinâmico ().
    • Escolha Tornar objeto dinâmico no menu do painel.

Para criar uma variável sem vinculá-la a um objeto, faça o seguinte:

  1. Clique no botão Nova variável (), no painel Variáveis, ou escolha Nova variável no menu desse painel.

  2. Para vincular subsequentemente um objeto à variável, selecione o objeto e a variável e clique no botão Tornar a visibilidade dinâmica () ou Tornar o objeto dinâmico (). Como alternativa, escolha uma dessas opções no menu do painel.

Trabalhar com variáveis

É possível editar o nome ou o tipo de uma variável, desvincular uma variável e bloquear uma variável usando o painel Variáveis.

A desvinculação de uma variável quebra o elo entre ela e seu objeto. O bloqueio de variáveis impede a criação e a exclusão de variáveis e a edição de suas opções. Entretanto, você pode vincular e desvincular objetos a variáveis bloqueadas.

Alterar o nome e o tipo de uma variável

  1. Clique duas vezes na variável, no painel Variáveis. Como alternativa, selecione a variável no painel Variáveis e escolha Opções de variável, no menu do painel Variáveis.

Desvincular uma variável

  1. Clique no botão Desvincular variável (), no painel Variáveis, ou escolha Desvincular variável no menu do painel Variáveis.

Bloquear ou desbloquear todas as variáveis em um documento

  1. Clique no botão Bloquear/Desbloquear variáveis ou , no painel Variáveis.

Excluir variáveis

A exclusão de uma variável a remove do painel Variáveis. Se você excluir uma variável vinculada a um objeto, esse objeto se tornará estático (a menos que ele também esteja vinculado a uma variável de tipo diferente).

  1. Selecione uma variável que você deseja excluir.

  2. Siga um destes procedimentos:

    • Clique no botão Excluir variável (), no painel Variáveis, ou escolha Excluir variável no menu do painel Variáveis.

    • Para excluir a variável sem confirmação, arraste-a até o botão Excluir variável ().

Editar objetos dinâmicos

Você pode alterar os dados associados a uma variável editando o objeto ao qual ela está vinculada. Por exemplo, se estiver trabalhando com uma variável de Visibilidade, altere o estado de visibilidade do objeto no painel Camadas. Editando objetos dinâmicos permite a você criar múltiplos conjunto de dados para serem usados no modelo.

  1. Selecione um objeto dinâmico na prancheta ou siga um destes procedimentos para selecionar automaticamente um objeto dinâmico:

    • Clique em uma variável com a tecla Alt (Windows), ou Option (Mac OS), pressionada no painel Variáveis.

    • Selecione uma variável no painel Variáveis e escolha Selecionar objeto vinculado no menu desse painel.

    • Para selecionar todos os objetos dinâmicos, escolha Selecionar todos os objetos vinculados, no menu do painel Variáveis.

  2. Edite os dados associados ao objeto da seguinte maneira:

    • Para o texto, edite a string de texto na prancheta.

    • Para arquivos vinculados, substitua a imagem usando o painel Vínculos ou o comando Arquivo > Inserir.

    • Para gráficos, edite os dados na caixa de diálogo Dados do gráfico.

    • Para todos os objetos com visibilidade dinâmica, altere o estado de visibilidade do objeto no painel Camadas.

Identificação de objetos dinâmicos usando IDs XML

O painel Variáveis exibe os nomes de objetos dinâmicos que constam no painel Camadas. Se você salvar o modelo no formato SVG para uso com outros produtos da Adobe, esses nomes de objetos deverão estar em conformidade com as convenções de nomeação XML. Por exemplo, nomes XML devem começar com uma letra, um sublinhado ou dois pontos e não podem conter espaços.

O Illustrator atribui automaticamente um ID XML válido a cada objeto dinâmico criado. Para ver, editar e exportar nomes de objetos usando IDs XML, selecione Editar > Preferências > Unidades (Windows) ou Illustrator > Preferências > Unidades (Mac OS) e selecione XML ID.

Visualizar o documento com cada conjunto de dados

Para ver como será o look do gráfico final, você pode visualizar antes de exportar todos os arquivos. Use as teclas de seta ao lado de Conjunto de Dados no painel Variáveis para navegar e visualizar o conjunto de dados desejado no documento.

Exportar arquivos usando o painel Ações

Após definir as variáveis e um ou mais conjuntos de dados, você pode produzir, em modo Em lote, um trabalho artístico usando os valores do conjunto de dados. Faça o seguinte:

  1. Usando o painel Ações (Janela > Ações), grave uma ação para salvar o documento no formato desejado. Para obter mais detalhes, consulte Automação com ações.

  2. Escolha Em lote no menu do painel Ações e selecione a ação criada na etapa anterior.

  3. Para Origem, selecione Conjuntos de dados para reproduzir a ação em cada conjunto de dados no arquivo atual.

  4. Em Destino, especifique o que deseja fazer com os arquivos processados. É possível deixar os arquivos abertos sem salvar as alterações (Nenhum), salvar e fechar o arquivo no local atual (Salvar e fechar) ou salvar os arquivos em um local diferente (Pasta).

    Dependendo da opção de Destino selecionada, é possível definir opções adicionais para salvar os arquivos. Para obter mais informações, consulte Reproduzir uma ação em arquivos em lote.

  5. Clique em OK.

Salvar modelo para mesclagem de dados

Ao definir variáveis em um documento do Illustrator, você cria um modelo para mesclagem de dados. É possível salvar esse modelo no formato SVG para uso com outros produtos da Adobe, como o Adobe® Graphics Server. Por exemplo, um desenvolvedor que trabalha com o Adobe Graphics Server pode vincular as variáveis no arquivo SVG diretamente a um banco de dados ou a outra fonte de dados.

  1. Selecione Arquivo > Salvar como, insira um nome de arquivo, selecione SVG como formato de arquivo e clique em Salvar.

  2. Clique em Mais opções e selecione Incluir dados do Adobe Graphics Server. Essa opção inclui todas as informações necessárias para a substituição de uma variável no arquivo SVG.

  3. Clique em OK.

Problemas ao importar o arquivo CSV?

Se você estiver recebendo o erro: A biblioteca de variáveis de entrada é inválida durante o upload de um arquivo de origem de dados CSV, verifique o seguinte:

  • O arquivo CSV não está em branco.
  • As planilhas que você criou usando a versão mais recente do Microsoft Excel são salvas como arquivo CSV (delimitado por vírgula) (*.csv) ou CSV (MS-DOS) (*.csv) e as criadas usando Apple Numbers são salvas no formato CSV com codificação Unicode (UTF-8). Origem de dados de arquivos salvos em outro formato de arquivo como Macintosh Comma Separated (*.csv) não são suportados para a mesclagem de dados.
  • Todas as colunas têm um nome de campo de dados. Por exemplo, o Illustrator exibe a mensagem de erro quando uma coluna no arquivo de origem de dados contém dados, mas não apresenta um nome de campo de dados.
  • O arquivo de origem de dados não tem uma coluna em branco entre qualquer coluna preenchida. Por exemplo, o Illustrator exibe a mensagem de erro quando a coluna B e D em seu arquivo de origem de dados contém dados, mas a coluna C está vazia.
Exemplo: erros durante a configuração de um arquivo de origem CSV para mesclagem de dados

A. Nome do campo de dados ausente para uma coluna B. Há uma coluna em branco entre as colunas preenchidas 

  • Os nomes do campo de dados na sua planilha não contêm espaços em branco.
  • Os caminhos referentes aos arquivos de imagem e gráfico no seu arquivo de origem não contêm espaços em branco.
  • Os arquivos gráficos vinculados a partir do arquivo de origem de dados são salvos como arquivos delimitados por vírgulas (.csv).
Logotipo da Adobe

Fazer logon em sua conta