Jelöljön ki egy szövegrészt

  1. A Szöveg eszköz használatával végezze el az alábbi műveletek egyikét:
    • A szövegkurzor húzásával jelölje ki a kívánt karaktert, szót vagy teljes szövegblokkot.
    • Egy szót duplán rákattintva jelölhet ki. A szó körüli szóközöket nem jelöli ki a program.
    • Egy sorra triplán kattintva jelölje ki az egész sort. Ha a Sorok kijelölése háromszoros kattintással beállítás nem aktív, a szövegre triplán kattintva az egész bekezdést kijelöli a program.

    • Ha a Sorok kijelölése háromszoros kattintással beállítás be van kapcsolva, az egész bekezdés kijelöléséhez négyszer kell kattintani a bekezdésre.

    • Kattintson ötszörösen, így jelölje ki az egész szövegegységet, vagy a szövegegység tetszőleges pontjára kattintva válassza a Szerkesztés menü Minden kijelölése. parancsát

Megjegyzés:

Ha jegyzetrögzítőt tartalmazó szöveget jelöl ki, a fenti eljárás bármelyikével egyúttal a jegyzetet és tartalmát is kijelöli.

Ha nem sikerül kijelölni a keretben lévő szöveget, lehetséges, hogy a szövegkeret zárolt rétegen vagy mesteroldalon található. Próbálja megszüntetni a réteg zárolását vagy lépjen a mesteroldalra. A szövegkeret elhelyezkedhet más szövegkeret vagy áttetsző objektum alatt is. Lásd: Fedett keretben lévő szöveg kijelölése.

A tripla kattintás hatásának módosítása

  1. Kattintson a Szerkesztés menü Beállítások almenüjének Szöveg parancsára (Windows) vagy az InDesign menü Beállítások almenüjének Szöveg parancsára (Macintosh).
  2. Jelölje be a Sorok kijelölése háromszoros kattintással jelölőnégyzetet, ha tripla kattintással egy egész sort ki szeretne jelölni (ez az alapértelmezett beállítás). Törölje a jelet a jelölőnégyzetből, ha tripla kattintással egy bekezdést szeretne kijelölni.

Fedett keretben lévő szöveg kijelölése

  1. Válassza a Kijelölés eszközt , nyomja le (és tartsa lenyomva) a Ctrl (Windows), illetve a Command (Mac OS) billentyűt, majd kattintással jelölje ki a kívánt szövegkeretet.
  2. Válassza a Szöveg eszközt, majd kattintson a szövegkeretbe vagy jelölje ki a megfelelő szöveget.

Rejtett (nem nyomtatandó) karakterek megjelenítése

  1. Válassza a Szöveg > Rejtett karakterek megjelenítése parancsot.
  2. Ha még midig nem jelennek meg az elrejtett karakterek, akkor kapcsolja ki az előnézet üzemmódot. Válassza, Nézet > Képernyőmód > Normál és válassza a Nézet > Felülnyomás előképét, ha törölni kívánja a kijelölést.

Megjelennek a nem nyomtatandó karakterek, például a szóközök, a tabulátorok, a bekezdés végét jelölő karakterek, a tárgymutató-jelölők és a szövegegység végét jelölő karakterek. Ezek a különleges karakterek csak a dokumentumablakban és a szövegegység-szerkesztő ablakban láthatók; nyomtatásban vagy PDF és XML formátumban nem jelennek meg. A rejtett karakterek a réteg színét veszik fel.

Nem nyomtatandó karakterek rejtve (felül) és megjelenítve (alul)
Nem nyomtatandó karakterek rejtve (felül) és megjelenítve (alul)

Anne-Marie Concepcion összefoglalója a különleges karakterekről (angol nyelven): Free Guide to InDesign Special Characters.

Rejtett karakterek listája

Rejtett karakter

Jelentése

Bekezdés vége

Bekezdésen belüli sortörés

Szóköz

Szövegegység vége

Lágy elválasztójel

Nemtörő elválasztójel

Fül

Jobb oldali behúzási tabulátor

Behúzás ide

Egymásba ágyazott stílus vége itt

Nem illeszkedő

Képírási térköz

Kvirt

Félkvirt

Nemtörő szóköz

Nemtörő szóköz (rögzített szélesség)

Hajszál szóköz

Hatod

Keskeny szóköz

Negyed szóköz

Harmad

Írásjel térköze

Helyi érték köze

Bő térköz

Hasábtörés

Kerettörés

Oldaltörés

Páratlan oldal törése

Páros oldal törése

Szándékos sortörés

InCopy jegyzet

InCopy jegyzet (a szövegegység-szerkesztőben)

Helyzetjelölő (csak az InCopy alkalmazásban)

Tárgymutató-jelölő

Tárgymutató-jelölő (a szövegegység-szerkesztőben)

Rejtett feltételes szöveg

Rejtett feltételes szöveg (a szövegegység-szerkesztőben)

Könyvjelző vagy hiperhivatkozás céljának jelölője (gyakran szerkesztőpont)

Könyvjelző vagy hiperhivatkozás céljának jelölője (a szövegegység-szerkesztőben)

Hiperhivatkozás célja (a szövegegység-szerkesztőben)

Kereszthivatkozással hivatkozott bekezdés

Kereszthivatkozás hiperhivatkozása (a szövegegység-szerkesztőben)

Rögzített objektum

Rögzített objektum (a szövegegység-szerkesztőben)

XML-címke

XML-címke (a szövegegység-szerkesztőben)

Lábjegyzet (a szövegegység-szerkesztőben)

Táblázat (a szövegegység-szerkesztőben)

Változó (a szövegegység-szerkesztőben)

Tárgymutató-jelölő (a szövegegység-szerkesztőben)

Hasáb-, keret- és oldaltörések felvétele

A hasáb-, keret- és oldaltöréseket különleges töréskarakterek beszúrásával szabályozhatja.

  1. A Szöveg eszközzel helyezze el a beszúrási pontot arra a helyre, ahol töréspontot szeretne beszúrni.
  2. A Szöveg menüben kattintson a Töréskarakter beszúrása parancsra, majd válasszon egy törési lehetőséget.

Megjegyzés:

Töréspontot a számbillentyűzeten található Enter billentyű lenyomásával is beszúrhat a szövegbe. Hasábtörés beszúrásához nyomja le az Enter billentyűt; kerettörés beszúrásához nyomja le a Shift+Enter billentyűkombinációt; oldaltörés beszúrásához nyomja le a Ctrl+Enter (Windows), illetve a Command+Return (Mac OS) billentyűkombinációt.

Töréskarakter eltávolításához előbb a Szöveg menü Rejtett karakterek megjelenítése parancsára kattintva jelenítse meg a nem nyomtatandó karaktereket, majd jelölje ki és törölje a megfelelő töréskaraktert.

Megjegyzés:

Ha egy töréspontot a bekezdésbeállítások módosításával hoz létre (például a Beállítások megtartása párbeszédpanelen), a törés a megadott beállítást tartalmazó bekezdés elé kerül. Ha egy töréspontot különleges karakter beszúrásával hoz létre, a törés közvetlenül a különleges karakter után jelenik meg.

Töréspontok beállításai

A Szöveg menü Töréskarakter beszúrása pontja az alábbi beállításokat tartalmazza:

Hasábtörés 

Az aktuális szövegkeret következő hasábjába folyatja a szöveget. Ha a keret csak egy hasábot tartalmaz, a szöveg a szöveglánc következő keretébe kerül.

Kerettörés 

A szöveget a szöveglánc következő keretébe folyatja az aktuális szövegkeret hasábbeállításaitól függetlenül.

Oldaltörés 

A szöveget a következő olyan oldalra folyatja, amely egy, az aktuális szövegkerethez fűzött keretet tartalmaz.

Páratlan oldal törése 

A szöveget a következő olyan páratlan számú oldalra folyatja, amely egy, az aktuális szövegkerethez fűzött keretet tartalmaz.

Páros oldal törése 

A szöveget a következő olyan páros számú oldalra folyatja, amely egy, az aktuális szövegkerethez fűzött keretet tartalmaz.

Új bekezdés 

E beállítás hatására a program új bekezdést nyit (mint az Enter vagy a Return billentyű lenyomására).

Szándékos sortörés 

Sortörést vált ki a karakter beszúrásának a helyén; új sort kezd új bekezdés nélkül (a Shift+Enter vagy a Shift+Return billentyűk megnyomásával azonos). A szándékos sortörést lágy sortörésnek is hívják.

Tetszés szerinti sortörés 

Azt jelzi, hogy sortörés esetén hol kell megtörnie a sornyi szövegnek. A tetszés szerinti sortörés olyan, mint egy lágy elválasztójel, azzal a különbséggel, hogy a program nem szúr be elválasztójelet a sortörés helyén.

Hasonló törési beállítások a Beállítások megtartása és a Bekezdésstílus beállításai párbeszédpanelen is találhatók.

A szövegszerkesztő használata

Az InDesign alkalmazásban szövegszerkesztésre az elrendezési oldalon és a szövegegység-szerkesztő ablakban van lehetőség. Amikor a szövegegység-szerkesztő ablakban ír és szerkeszt szöveget, az egész szövegegység a Beállítások panelen megadott betűtípussal, betűméretben és térközökkel jelenik meg, ugyanakkor az elrendezés vagy a formázás nem vonja el a figyelmét. A Szövegegység-szerkesztő egyben az a hely, ahol a változások követése megtekinthető.

Minden szövegegység más és más szövegegység-szerkesztő ablakban jelenik meg. Az ablakban a szövegegység egésze megjelenik a túlszedett szöveget is beleértve. Egyidejűleg több szövegegység-szerkesztő ablakot megnyithat – akár ugyanazon szövegegység több példányával. Függőleges mélységmérő vonalzó jelzi, hogy mennyi szöveg tölti ki a szövegkeretet, egy vonal pedig azt mutatja, hogy hol található túlszedett szöveg.

Szövegegység szerkesztésekor a módosítások az elrendezési ablakban is követhetők. A megnyitott szövegegységeket az Ablak menü listázza. A szövegegység-szerkesztő ablakban nem hozhat létre új szövegegységet.

Szövegegység-szerkesztő ablak
Szövegegység-szerkesztő ablak

A. Bekezdésstílusok B. Hasábszélesség módosítása az elválasztó vonal húzásával C. Függőleges mélységmérő vonalzó D. Túlszedett szöveget jelző vonal 

A szövegegység-szerkesztőben megtekintheti és szerkesztheti a táblázatokat. Itt egymást követő oszlopokban és sorokban jelennek meg a szövegek, hogy azokat könnyen lehessen szerkeszteni. Pillanatok alatt kibonthatja, illetve összecsukhatja a táblázatokat, valamint megadhatja, hogy sorok vagy oszlopok szerint szeretné-e azokat megjeleníteni.

A Szövegegység-szerkesztő a Változások követése beállítás mellett a hozzáadott, törölt és szerkesztett szövegeket is megjeleníti. Lásd Változtatások nyomon követése és ellenőrzése.

A szövegegység-szerkesztő megnyitása

  1. Jelölje ki a kívánt szövegkeretet, helyezze a beszúrási pontot a szövegbe, vagy jelöljön ki különböző szövegegységeket tartalmazó szövegkereteket.
  2. Kattintson a Szerkesztés menü Szerkesztés a szövegegység-szerkesztőben parancsára.

Megjegyzés:

Ha a szövegegység-szerkesztő ablakban meg szeretné nyitni ugyanazon szövegegység egy másik példányát, aktiválja a szövegegység-szerkesztőt, mutasson az Ablak menü Rendezés pontjára, és kattintson az Új ablak parancsra.

Visszatérés az elrendezési ablakba

  1. A szövegegység-szerkesztő ablakban tegye az alábbiak egyikét:
    • A Szerkesztés menüben kattintson a Szerkesztés az elrendezésben parancsra. Ezt a módszert alkalmazva az elrendezési ablakban ugyanaz a kijelölt szöveg, a beszúrási pont ugyanazon pozíciójával jelenik meg, mint legutóbb a szövegegység-szerkesztő ablakban; a szövegegység-szerkesztő ablak nyitva marad, de az elrendezési ablak mögé kerül.

    • Kattintson az elrendezési ablakba. A szövegegység-szerkesztő ablak nyitva marad, de az elrendezési ablak mögé kerül.

    • Zárja be a szövegegység-szerkesztő ablakot.

    • Az Ablak menü alján kattintson a dokumentum nevére.

A szövegegység-szerkesztő ablak elemeinek megjelenítése vagy elrejtése

Megjelenítheti, illetve elrejtheti a stílusok nevét tartalmazó oszlopot és a mélységmérőt. Kibonthatja, illetve összecsukhatja a lábjegyzeteket, valamint az új bekezdések kezdetének jelöléséhez megjelenítheti, illetve elrejtheti a bekezdéstörő jeleket. Ezek a beállítások az összes nyitva lévő és az ezután megnyitott szövegegység-szerkesztő ablakra hatással vannak.

  • A szövegegység-szerkesztő aktív állapotában a Nézet menüben mutasson a Szövegegység-szerkesztő pontra, majd kattintson a Stílusnévoszlop megjelenítése vagy a Stílusnévoszlop elrejtése parancsra. A függőleges sáv húzásával a stílusnévoszlop szélességét is módosíthatja. Az ezután megnyitott szövegegység-szerkesztő ablakok öröklik az így megadott oszlopszélességet.
  • A szövegegység-szerkesztő aktív állapotában a Nézet menüben mutasson a Szövegegység-szerkesztő pontra, majd kattintson a Mélységmérő megjelenítése vagy a Mélységmérő elrejtése parancsra.
  • A szövegegység-szerkesztő aktív állapotában a Nézet menüben mutasson a Szövegegység-szerkesztő pontra, majd kattintson a Minden lábjegyzet kibontása vagy a Minden lábjegyzet összecsukása parancsra.
  • A szövegegység-szerkesztő aktív állapotában a Nézet menüben mutasson a Szövegegység-szerkesztő pontra, majd kattintson a Bekezdéstörő jelek megjelenítése vagy a Bekezdéstörő jelek elrejtése parancsra.

A szövegegység-szerkesztő beállításai

A szövegegység-szerkesztő megjelenítése párbeszédpanelen módosíthatja a szerkesztő megjelenését. Jóllehet a szövegegység-szerkesztő a legalapvetőbbek kivételével figyelmen kívül hagyja a szövegformázási jellemzőket, néhány objektum és jellemző megjelenik. Ilyenek például az alábbiak:

Jellemző

Ikon

Táblázat

Szövegközi objektumok

XML-címkék

Változók

Hivatkozások forrása

Hivatkozásrögzítők

Kereszthivatkozás

Rejtett feltételes szöveg

Jegyzet

Lábjegyzetek

Tárgymutató-jelölők

Törölt szöveg

Hozzáadott szöveg

Áthelyezett szöveg

 

Szövegmegjelenítési beállítások

Megadhatja a megjelenítési betűtípust, a betűméretet, a sorközt, a szövegszínt és a hátteret. Választhat más témát is; például a Klasszikus rendszer téma kijelölésével fekete háttér előtt sárga szövegszínt definiálhat. Ezek a beállítások a szövegnek a szövegegység-szerkesztőben való megjelenését határozzák meg, az elrendezési nézetre nincsenek hatással.

Élsimítás engedélyezése

E beállítás megadásával elsimíthatja a betűk recés széleit, és választhat egyet a következő három élsimítási típus közül: LCD-re optimalizált, Sima vagy Alapértelmezett. Ez utóbbi szürkeárnyalatok révén simítja a szöveg széleit. Az LCD-re optimalizált típus szürkeárnyalatok helyett színeket használ a szövegélek simításához; leghatékonyabban világos színű háttérrel és fekete szöveggel működik. A Sima beállítás szintén szürkeárnyalatokon alapul, de eredménye világosabb, lágyabb körvonalú, mint az Alapértelmezett beállításé.

Kurzorbeállítások

Ezzel a beállítással módosíthatja a szövegkurzor megjelenését. Ha például azt szeretné, hogy a kurzor villogjon, jelölje be a Villogás jelölőnégyzetet.

A szövegközi keretekben lévő szöveg a szülő szövegegység-szerkesztő ablakban nem jelenik meg, de saját szövegegység-szerkesztő ablakában megjeleníthető.

Feltételes szöveg használata

A feltételes szövegnek köszönhetően többféle verziót készíthet ugyanabból a dokumentumból. Miután létrehozta a feltételeket, azokat különféle szövegtartományokra vonatkoztathatja. Ezt követően a feltételek megjelenítésével, illetve elrejtésével különféle verziókat készíthet a dokumentumokról. Számítógépes útmutató létrehozásakor például külön feltételeket készíthet a Macintosh és a Windows operációs rendszer felhasználói számára. A használati utasítás Macintosh operációs rendszernek megfelelő verziójának nyomtatása előtt az összes olyan szöveg megjelenítheti, amelyre a „Mac” feltétel vonatkozik, az összes olyat pedig elrejtheti, amelyre a „Windows” feltétel vonatkozik. A használati utasítás Windows operációs rendszernek megfelelő verziójának nyomtatásához felcserélheti a feltételek állapotát.

Feltételes szöveg
Látható feltételes szöveg

A. Minden feltétel látható B. Feltételes szöveg jelzői 
Rejtett feltételes szöveg
Rejtett feltételes szöveg

A. Rejtett „Mac” feltétel B. Rejtett feltétel szimbólumai 

A feltételeket csak szövegre lehet vonatkoztatni. Rögzített objektumok is feltételessé alakíthatók, de csak a rögzített objektum jelölőjének kijelölésével. Táblázatcellákban szereplő szövegre is vonatkoztathatja a feltételeket, a táblázat celláira, oszlopaira és soraira azonban nem. Zárolt InCopy szövegekre nem vonatkoztathatja a feltételeket.

A feltételes szöveget tartalmazó dokumentumok létrehozásakor követendő eljárás

Ha feltételes szöveget tartalmazó projektet készül létrehozni, vegye számba az anyag jellegét, és gondolja át, hogy a dokumentum beadását követően hány személy dolgozhat majd felváltva azon. Igyekezzen következetesen kezelni a feltételes szöveget, hogy egyszerűbben lehessen használni és könnyebben karban lehessen tartani a dokumentumot. A következő irányelveket tartsa szem előtt.

A verziók száma

Határozza meg, hogy hány verziója legyen a végleges projektnek. Ha például olyan útmutatót hoz létre, amely mind Windows, mind Macintosh platformon futó program működését ismerteti, akkor legalább két verziót: egy Windows, illetve egy Macintosh operációs rendszernek megfelelő verziót célszerű létrehozni. Ha azt szeretné, hogy az áttekintési folyamat során szerkesztői megjegyzésekkel is elláthassák a szöveget, akkor még több verziót érdemes létrehozni: egy megjegyzésekkel ellátott Macintosh verziót, egy megjegyzések nélküli Macintosh verziót, egy megjegyzésekkel ellátott Windows verziót és egy megjegyzések nélküli Windows verziót.

A sok feltételt tartalmazó dokumentumokhoz olyan feltétel-beállításokat is meghatározhat, amelyeknek a dokumentumra való alkalmazásával gyorsan készíthet különféle verziókat.

A szükséges feltételcímkék száma

Határozza meg, hogy hány feltételcímkére van szüksége a kívánt verziók előállításához. A dokumentum adott verziója a feltételcímkék egyedi készletével határozható meg. Egy végleges Windows útmutatót például egy megjelenített Windows feltételcímkével, valamint egy rejtett Macintosh feltételcímkével és egy rejtett Megjegyzések feltételcímkével határozhat meg. Ebben a példában azt kell majd eldöntenie, hogy külön feltételcímkét kíván-e használni a Windows, illetve a Macintosh operációs rendszerre vonatkozó megjegyzésekhez, vagy egyetlen feltételcímkét kíván-e használni mindkét operációs rendszerre vonatkozó megjegyzésekhez.

A tartalom felépítése

Mérje fel, hogy mennyi feltételt érdemes használni a dokumentumban, valamint gondolkodjon el azon, hogy hogyan lehet úgy összeállítani az anyagot, hogy azt utána ne legyen nehéz javítani és karban tartani. Elképzelhető például, hogy úgy is össze tud állítani egy könyvet, hogy annak csupán néhány dokumentumában kelljen feltételes szöveget használni. Úgy is dönthet, hogy külön fájlokat tart fenn egy adott fejezet verziói számára, és más-más könyvfájlt használ majd fel a könyv egyes verzióihoz.

Más esetekben, például többnyelvű dokumentumok esetén, a feltételek helyett érdemes lehet külön rétegeket létrehozni az egyes nyelvek számára, amelyeket azután tetszése szerint elrejthet, illetve megjeleníthet.

Címkézési stratégia

Határozhatja meg a feltételes szöveg legkisebb egységét. Más nyelvre fordítandó dokumentum esetén például célszerű egy kerek mondatnyi szöveget feltételes szöveggé alakítani. Mivel a szórendet gyakran módosítani kell a fordítás során, ezért egy mondatrész feltételes szöveggé alakítása nehezebbé teheti a fordítást.

A szóközök és az írásjelek feltételeinek következetlen alkalmazása felesleges szóközökhöz vagy helyesírási hibákhoz vezethet. Döntse el, hogy feltételes szöveggé kívánja-e alakítani a szóközöket és az írásjeleket. Ha a feltételes szöveg írásjellel kezdődik vagy végződik, az írásjelet is alakítsa feltételessé. Így könnyebb lesz majd olvasni a szöveget abban az esetben, ha egyszerre több verzió is meg van jelenítve.

A szótávolsággal kapcsolatos problémák (például nem feltételes szóközt követő feltételes szóköz) elkerülése érdekében egységesítse a feltételes szöveget követő szóközök kezelésének módját. (Pl. legyen az mindig feltételes vagy mindig nem feltételes).

A félreértések elkerülése érdekében határozza meg a feltételes szövegek megjelenítési sorrendjét, és következetesen ragaszkodjon ahhoz a teljes dokumentumban.

Tárgymutatók és kereszthivatkozások

Dokumentumok tárgymutatóinak készítésekor ügyeljen arra, hogy a feltételes szövegrészen belül vagy azon kívül helyezi-e el a tárgymutató-jelölőket. A rejtett feltételes szövegen belül található tárgymutató-jelölők nem szerepelnek a létrehozott tárgymutatóban.

A feltételes szövegre mutató kereszthivatkozások létrehozásakor ügyeljen arra, hogy a forrásszövegre a hivatkozottal azonos feltétel érvényesüljön. Ha például egy „Windows” bekezdéshez ad hozzá egy kereszthivatkozást, ám a szerkesztőpont egy „Mac” feltételben jelenik meg, akkor a „Mac” feltételnek megfelelő szövegek elrejtésekor a kereszthivatkozás nem lesz feloldva. A Hiperhivatkozás panelen az „Rsz” jelzés lesz látható a kereszthivatkozás mellett.

Ha feltételes szöveget is tartalmazó bekezdésre mutató kereszthivatkozást hoz létre, majd módosítja az adott feltételnek megfelelő szöveg láthatósági beállítását, akkor frissítse a kereszthivatkozást.

Feltételek készítése

A program az aktuális dokumentumba menti a létrehozott feltételeket. Ha a feltétel létrehozása közben nincs megnyitva dokumentum, akkor az adott feltétel valamennyi létrehozásra kerülő dokumentumban szerepel majd.

Feltételjelzők (ilyen lehet például egy pirosan szedett hullámos aláhúzás) megadásával könnyen azonosíthatóvá alakíthatja a feltételes szövegrészeket.

  1. A Feltételes szöveg panel megjelenítéséhez kattintson az Ablak menü Szöveg és táblázatok elemére.
  2. Kattintson a Feltételes szöveg panel menüjének Új feltétel parancsára, majd adja meg a feltétel nevét.
  3. A Jelző csoportban adja meg annak a jelzőnek a megjelenését, amelynél a feltételt alkalmazni kívánja.

    Alapértelmezés szerint a jelzők (például a hullámos piros vonalak) csak a dokumentum megjelenítésekor láthatóak, a nyomtatásban és a kimenetnek szánt végleges változatban azonban nem. A Feltételes szöveg panelen található Jelzők menü beállításaival elrejtheti a jelzőket, illetve megadhatja, hogy azok a nyomtatásban és a kimenetnek szánt változatban is megjelenjenek. Ez utóbbit pl. áttekintéshez élszerű választani.

  4. Kattintson az OK gombra.

Feltételek alkalmazása szövegre

Adott szövegrészre több feltételt is alkalmazhat. Alapértelmezés szerint feltételjelzők azonosítják a feltételes szövegrészeket. Ha azonban el vannak rejtve a feltételek, akkor a Feltételes szöveg panelen állapíthatja meg, hogy mely feltételek vonatkoznak egy adott szövegrészre. Tömör pipa jelzi, ha a feltétel érvényesül az adott szövegnél. Halvány pipa jelzi, ha a feltétel csak a kijelölés egy részében érvényesül.

  1. Jelölje ki azt a szövegrészt, amelynél érvényesíteni kívánja a feltételt.
  2. A Klónozás forrása panelen (Ablakok > Szöveg és táblázatok > Feltételes szöveg) tegye az alábbiak valamelyikét:
    • Feltétel alkalmazásához kattintson a kívánt feltételre vagy a feltétel neve mellett található négyzetre.

    • Feltétel alkalmazásához és a szövegnél alkalmazott többi feltétel eltávolításához az Alt (Windows), illetve az Option (Mac OS) billentyűt nyomva tartva kattintson a kívánt feltételre.

    • Feltétel eltávolításához a feltétel neve mellett található négyzetre való kattintással törölje a jelet a négyzetből. Ha az összes feltételt szeretné eltávolítani a kijelölt szövegből, akkor kattintson a [Nem feltételes] gombra.

Megjegyzés:

Billentyűparancsokkal nem alkalmazhat feltételeket. A Gyors alkalmazás gombbal viszont alkalmazhat feltételeket.

Feltételek megjelenítése és elrejtése

Egy feltétel elrejtésekor az összes olyan szövegrészt elrejti a program, amelyre az adott feltétel vonatkozik. A feltételek elrejtésének hatására gyakran módosul a dokumentum, illetve könyv oldalszámozása. Az Intelligens szövegáttördelés funkcióval automatikusan beszúrhat és eltávolíthat oldalakat, amikor elrejti, illetve megjeleníti a feltételeket.

A program figyelmen kívül hagyja a dokumentum rejtett feltételes szövegrészeit. Így például nem nyomtatja és nem exportálja a rejtett szövegrészeket, a rejtett feltételes szövegrészben található tárgymutató-jelölőket nem veszi fel a generált tárgymutatóba, valamint kereséskor és helyesírás-ellenőrzéskor kihagyja a rejtett feltételes szövegrészeket.

Amikor elrejti valamelyik feltételt, egy rejtett feltételre utaló szimbólum  tárolja a rejtett szövegrészt . Ha rejtett feltételre utaló szimbólumot tartalmazó szöveg kijelölésekor megpróbálja törölni az adott szövegrészt, az InDesign kérni fogja a rejtett feltételes szöveg törlésének jóváhagyását. Rejtett feltételes szövegrészeket nem láthat el a egyéb feltételekkel, stílusokkal és formázással.

Ha egy szövegrésznél több feltétel is érvényesül, melyek közül legalább egy meg van jelenítve, akkor az adott szövegrész nem lesz rejtve.

  • Adott feltételek megjelenítéséhez, illetve elrejtéséhez kattintson a kívánt feltétel neve mellett található láthatósági négyzetre. A szemet jelképező ikon mutatja, ha látható a feltétel.
  • Az összes feltétel megjelenítéséhez, illetve elrejtéséhez válassza a Feltételes szöveg panel menüjének Az összes megjelenítése, illetve Az összes elrejtése parancsát.

Feltételkészletek használata

A feltételkészletekkel az összes feltétel láthatósági beállítása megadható, így pillanatok alatt különféle változatokat készíthet a dokumentumból. Vegyünk példaként egy olyan komplex dokumentumot, amelynél a platformra vonatkozó feltételként a Macintosh, a Windows XP, a Vista és az UNIX feltétel, a nyelvre vonatkozó feltételként az angol, a francia, a német és a spanyol feltétel, szerkesztői feltételként pedig a Szerkesztői áttekintés és a Belső megjegyzések nevű feltétel van megadva. A Vista verzió francia nyelvű változatának áttekintéséhez létrehozhat egy olyan készletet, amely csak a Vista, a francia és a Szerkesztői áttekintés feltételt jeleníti meg, a többit pedig elrejti.

Bár ehhez nem feltétlenül szükséges készleteket használni, a készletekkel pillanatok alatt és megbízható módon módosíthatja a különféle feltételek láthatósági beállítását.

  1. A kívánt módon lássa el feltételekkel a szöveget.
  2. Ha a Feltételes szöveg panelen nem látható a Beállítás menü, válassza a Feltételes szöveg panel menüjének Beállítások megjelenítése parancsát.
  3. A Feltételes szöveg panelen a kívánalmaknak megfelelően tegye láthatóvá vagy rejtse el a feltételeket.
  4. A Beállítás menüben kattintson az Új készlet létrehozása parancsra, adja meg a készlet nevét, majd kattintson az OK gombra.

    Az új készlet lesz az aktív készlet.

  5. Végezze el a következő műveletek valamelyikét:
    • A feltételkészlet dokumentumra való alkalmazásához válassza ki annak nevét a Beállítás menüben.

    • Feltételkészlet felülírásához kijelöléssel tegye aktívvá a kívánt feltételkészletet, majd módosítsa az egyes feltételek láthatósági beállítását. Egy pluszjel (+) lesz látható a feltételkészlet mellett. A felülírások eltávolításához jelölje ki újra a feltételkészletet. A feltételkészlet új láthatósági beállításokkal való frissítéséhez válassza a „[feltételkészlet] újradefiniálása” lehetőséget.

    • Feltételkészlet törléséhez jelölje ki a feltételkészlet, majd válassza a „[feltételkészlet] törlése” lehetőséget. Egy feltételkészlet törlésével a készletben szereplő feltételek nem törlődnek, és az alkalmazott feltételek sem törlődnek alkalmazási helyükről.

Feltételek kezelése

  1. Végezze el a következő műveletek valamelyikét:

    Feltétel törlése

    Jelöljön ki egy feltételt, majd kattintson a Feltételes szöveg panel alján látható Feltétel törlése ikonra. A törölt feltétel helyett adjon meg egy másikat, majd kattintson az OK gombra. A megadott feltétel az összes olyan szövegrészre vonatkozni fog, amelyre a törölt feltétel is vonatkozott.

    Több feltétel törléséhez szomszédos feltételeknél a Shift billentyűt nyomva tartva, nem szomszédos feltételeknél a Ctrl (Windows), illetve a Command (Mac OS) billentyű nyomva tartva kattintással jelölje ki a törölni kívántakat, majd kattintson a Feltétel törlése ikonra.

    Szövegre vonatkozó feltétel eltávolítása

    Egy feltételcímke szövegből való eltávolítása nem ugyanúgy működik, mint amikor egy címkét távolít el a szövegből. Amikor eltávolít egy címkét a szövegből, az a dokumentumban marad, hogy később újra lehessen alkalmazni.

    Szövegre vonatkozó feltétel eltávolításához jelölje ki a szöveget, majd a feltétel neve mellett található négyzetre való kattintással törölje a jelet a négyzetből. Ha az összes feltételt szeretné eltávolítani a kijelölt szövegből, akkor kattintson a [Nem feltételes] gombra.

    Feltételek betöltése (importálása)

    Csak a feltételek betöltéséhez válassza a Feltételes szöveg panel menüjének Feltételek betöltése parancsát, a feltételek és készletek betöltéséhez pedig a Feltételek és készletek betöltése parancsát. Jelölje ki azt az InDesign-dokumentumot, amelyből importálni kívánja a feltételeket, majd kattintson a Megnyitás gombra. A betöltött feltételek és készletek lecserélik az azokkal azonos nevű feltételeket és készleteket.

    Az InCopy-fájlokból nem tölthet be feltételeket az InDesign programba, az InDesign-fájlokból viszont mind az InDesign, mind az InCopy programba betöltheti azokat.

    A betöltött készletek figyelmen kívül hagyják a jelenleg a Feltételes szöveg panelen található feltételek láthatósági beállításait.

    Könyvben szereplő feltételek szinkronizálása

    Ha szeretne gondoskodni arról, hogy egy könyv valamennyi dokumentumában ugyanazok a feltételek érvényesüljenek, akkor a stílusforrás-dokumentumban hozza létre a feltételeket, a Szinkronizálási beállítások párbeszédpanelen válassza ki a feltételes szöveg beállításait, végül szinkronizálja a könyvet.

    Feltételjelzők megjelenítése és elrejtése

    A feltételjelzők megjelenítéséhez, illetve elrejtéséhez a Feltételes szöveg panel Jelzők menüjében válassza a Megjelenítés, illetve az Elrejtés lehetőséget. Ha egy verzió van megjelenítve, és szeretné megtekinteni, hogy hol vannak feltételes részek, akkor jelenítse meg a feltételjelzőket. Ha az elrendezés megtekintése közben zavarónak találja a feltételjelzőket, rejtse el azokat. Ha a nyomtatásban és a kimenetben is szeretné szerepeltetnie a feltételjelzőket, válassza a Megjelenítés és nyomtatás lehetőséget.

    Feltétel nevének módosítása

    A Feltételes szöveg panelen kattintson valamelyik feltételre, várjon picit, majd a feltétel nevére való kattintással jelölje azt ki. Adjon meg egy másik nevet.

    Feltételjelzők szerkesztése

    Kattintson duplán valamelyik feltételre a Feltételes szöveg panelen, vagy jelölje ki valamelyik feltételt, majd válassza a panel menüjének Feltétel beállítása parancsát. Adja meg a jelző beállításait, majd kattintson az OK gombra.

Feltételes szöveg keresése és módosítása

A Keresés/csere párbeszédpanelen keresheti meg az adott feltétellel (feltételekkel) ellátott szövegrészeket, valamint láthatja le azokat más feltétellel (feltételekkel).

  1. Jelenítse meg az összes olyan feltételes szöveget, amelyet bele kíván foglalni a keresésbe.

    A program nem keres a rejtett szövegekben.

  2. Kattintson a Szerkesztés menü Keresés/csere parancsára.
  3. Ha a Formátum keresése és a Formátum módosítása mező nem látható a párbeszédpanel alján, kattintson a További beállítások elemre.
  4. Kattintson a Formátum keresése mezőre a Formázási beállítások keresése párbeszédpanel megnyitásához. A Feltételek részben a [Bármilyen feltétel] lehetőség kiválasztásával kereshet olyan szöveget, amelynél legalább egy érvényesül a feltételek közül, a [Nem feltételes] lehetőség kiválasztásával kereshet olyat, amelynél egy feltétel sem érvényesül, illetve külön is kiválaszthatja, hogy mely feltétel(ek)re kívánja korlátozni a keresést. Kattintson az OK gombra.

    Ezzel a funkcióval pontosan a kijelölt feltételeknek megfelelő szövegrészek kereshetők meg. Ha például az 1., és a 2. feltételt jelölte ki, akkor a program sem azokat a szövegrészeket nem jeleníti meg találatként, amelyekre ezek közül csak az egyik feltétel vonatkozik, sem azokat, amelyekre e két feltétel mellett még másik is vonatkozik.

  5. Kattintson a Formátum módosítása mezőre a Formázási beállítások megváltoztatása párbeszédpanel megnyitásához. Adja meg a különféle formázási beállításokat (pl. egy feltételes vagy egy karakterstílust), majd kattintson az OK gombra.

    Ha a Formázási beállítások megváltoztatása párbeszédpanelen kijelöli a Feltételek részben szereplő feltételeket, akkor a [Bármilyen feltétel] nem módosítja a talált feltételes szöveget. Ennek a lehetőségnek akkor veheti hasznát, ha más formázást (pl. karakterstílust) szeretne alkalmazni. Ha az összes feltételt szeretné eltávolítani a talált szövegből, akkor válassza a [Nem feltételes] lehetőséget. Adott feltétel kijelölésekor adja meg, hogy az felülírja-e a talált szövegre vonatkozó feltételek valamelyikét, vagy azzal együtt érvényesüljön-e.

  6. Kattintson a Keresés gombra, majd cserélje le a feltételt a Módosítás, a Módosítás/keresés vagy a Mindet módosítja gomb használatával.

Ez a munka a Creative Commons Nevezd meg!-Ne add el!-Így add tovább! 3.0 Unported licenc alatt lett közzétéve.  A Twitter™ és Facebook közzétételeket a Creative Commons jogi feltételei nem szabályozzák.

Jogi közlemények   |   Online adatvédelmi nyilatkozat