Gombok létrehozása

Létrehozhat olyan gombokat, amelyekkel műveletek hajthatók végre a rögzített elrendezésű EPUB, PDF vagy SWF formátumba exportált dokumentumban. Létrehozhat például egy gombot, amelyre kattintva a felhasználó más oldalra ugorhat vagy webhelyet nyithat meg.

Mozgókép lejátszására beállított gomb az exportált PDF fájlban

A gomb létrehozása során az alábbiakat teheti:

Megjegyzés:

A gombokkal és a dokumentumok dinamikus működésével kapcsolatos műveleteket az Interaktivitás munkaterületen végezze el.

Gomb létrehozása

  1. A Toll eszközzel vagy valamelyik rajzeszközzel (pl. a Téglalap vagy az Ellipszis eszközzel) rajzolja meg a gomb alakját. Szükség esetén a Szöveg eszközzel lássa el szöveggel a gombot (pl. „Tovább”, „Vásárlás” stb.)

    Megjegyzés:

    Ha több oldalon is megjelenő navigációs gombot hoz létre (például Következő oldal vagy Előző oldal), helyezze azokat mesteroldalra, így nem kell nem kell a gombokat minden oldalhoz külön elkészíteni. Ezek a gombok a dokumentum valamennyi olyan oldalán megjelennek, amelyekhez hozzá van rendelve a mesteroldal.

  2. A Kijelölés eszközzel  jelölje ki az átalakítandó képet, alakzatot vagy szövegkeretet.

    A mozgóképek, hangklipek és video-előnézeti képek nem alakíthatók gombokká.

  3. Kattintson az Objektum átalakítása gombbá ikonra a Gombok panelen (Ablak > Interaktív > Gombok). Emellett használható az Objektum > Interaktív > Átalakítás gombbá menüparancs is.
  4. Végezze el a következő műveletek valamelyikét a Gombok panelen:
    • A Név mezőben adjon meg egy olyan nevet a gomb számára, amely alapján meg tudja majd azt különböztetni a létrehozni kívánt többi gombtól.
    • Egy vagy több művelet megadásával határozza meg, hogy mi történjen, ha rákattintanak a gombra az exportált rögzített elrendezésű EPUB, PDF vagy SWF fájlban. Lásd: Interaktív gombok készítése.
  5. Használja az Előnézet panelt (Ablak > Interaktív > EPUB interaktivitás előnézet / SWF előnézet) elemét a gomb teszteléséhez, mielőtt exportálja a dokumentumot interaktív rögzített elrendezésű EPUB, PDF, vagy SWF formátumba.

Gomb hozzáadása a Minta gombjai panelről

A Minta gombjai panelen számos olyan előre létrehozott gomb található, amelyet át lehet húzni a dokumentumba. Ezeken a mintagombokon megjelenik például színátmenetes lágy perem és vetett árnyék hatás, és a Kurzorráhúzás megjelenés valamelyest eltérő. A mintagombokhoz műveletek is vannak társítva. A minta nyílgombokhoz a Ugrás a következő oldalra, illetve az Ugrás az előző oldalra művelet van hozzárendelve. Ezeket a gombokat tetszés szerint módosíthatja.

A Gombok panel egy objektumkönyvtár. A többi objektumkönyvtárhoz hasonlóan további gombokkal bővítheti a panelt, a feleslegeseket pedig eltávolíthatja arról. (Lásd: Objektumkönyvtárak használata.) A mintagombok a ButtonLibrary.indl fájlban vannak tárolva, ez a fájl az InDesign alkalmazás mappájának Készletek/Gomb könyvtár mappájában találhatók.

  1. A Gombok panel menüjének Minta gombjai elemének kiválasztásával nyissa meg a Minta gombjai panelt.
  2. Húzza át valamelyik gombot a Gombok panel panelről a dokumentumra. Ha a navigációs gombokat minden oldalon el kívánja helyezni, akkor helyezze a gombokat mesteroldalra.
  3. A Kijelölés eszközzel jelölje ki a gombot, majd tetszése szerint módosítsa azt a Gombok panelen.

A mintagombok módosítása során vegye figyelembe az alábbiakat:

  • Ha szöveget helyez a gombra, ne feledje másolás-beillesztés művelettel átmásolni azt a Normál gombállapotából a Kurzorráhúzás gombállapotba. Ellenkező esetben nem fog megjelenni a hozzáadott szöveg, amikor az adott gombra mutatnak az egérmutatóval a rögzített elrendezésű EPUB, PDF, illetve SWF fájlban.

  • A gombokat át lehet méretezni. Következő/előző oldal típusú nyílgombpár áthúzásakor méretezze át az első gombot, jelölje ki a másodikat, majd válassza az Objektum menü Megismételt alakítás elemének Megismételt alakítás parancsát.

Megjegyzés:

A gomb az Előnézet panelen próbálható ki.

Gomb átalakítása objektummá

Gomb objektummá alakításakor a gomb tartalma továbbra is az oldalon marad, a program csak a gomb tulajdonságait távolítja el. A program a gomb egyéb állapotaihoz társított tartalmat is eltávolítja.

  1. A Kijelölés eszközzel  jelölje ki a gombot.
  2. Válassza az Objektum menü Interaktív elemének Objektummá konvertálás parancsát.

Gombok interaktívvá tétele

Az InDesign programban létrehozhat, szerkeszthet és kezelhet interaktív hatásokat. A dokumentum rögzített elrendezésű EPUB, PDF vagy SWF fájlba exportálásakor ezek az interaktív műveletek aktívak lehetnek.

Tegyük fel például, hogy egy olyan gombot szeretne létrehozni, ami lejátszik egy hangot a PDF fájlban. A hangfájlt elhelyezheti az InDesign dokumentumban, majd létrehozhat egy gombot, ami lejátssza a hangot, amikor a gombra kattint a PDF dokumentumban.

Ebben a példában az egérgombbal való kattintás az esemény, a hang lejátszása pedig a művelet.

Az egérgomb felengedésekor hanglejátszásra beállított gomb

Megjegyzés:

Egyes műveletek mind PDF, mind SWF/EPUB fájlban, míg mások csak PDF, illetve csak SWF/EPUB fájlban támogatottak. Egy művelet választásakor kerülje a csak PDF-ben használható műveleteket, amikor SWF vagy rögzített elrendezésű EPUB formátumba exportál. Valamint PDF-ként exportáláskor kerülje a csak SWF/EPUB formátumban használható műveleteket.

Műveletek gombokhoz társítása

A különböző eseményekhez műveletek rendelhetők. Például megadhatja, hogy a program lejátsszon egy hangot az exportált PDF fájlban, amikor az egérmutató a gomb felülete fölé ér, vagy hogy lejátsszon egy mozgóképet, amikor a gombra kattintanak, aztán felengedik az egérmutatót. Ugyanahhoz az eseményhez több művelet is rendelhető. Létrehozhat például egy olyan műveletet, amellyel lejátszható egy mozgókép, aztán Tényleges méretre állítható a nézet.

  1. A Kijelölés eszközzel  jelölje ki a létrehozott gombot.
  2. A Gombok panelen jelölje ki a műveletek aktiválásának módját meghatározó események valamelyikét (pl. a Kattintáskor a gomb felengedésekor) eseményt.
  3. Kattintson a Műveletek elem mellett látható pluszjel gombra , majd válassza ki az eseményhez rendelni kívánt műveletet.
  4. Adja meg a művelet beállításait.

    Ha például az Ugrás az első oldalra műveletet választja, akkor adja meg a nagyítás mértékét. Ha az Ugrás URL-re műveletet, akkor a weboldal címét adja meg. Vannak olyan műveletek, amelyeknek nincsenek további beállításai. Ilyen például az Ugrás a következő nézetre művelet.

  5. Tetszés szerint rendeljen hozzá további műveleteket is az egyes eseményekhez.

Megjegyzés:

A gombok kipróbálásához exportálja a dokumentumot rögzített elrendezésű EPUB, PDF vagy SWF fájlba, majd nézze meg az exportált fájlt. PDF fájlba való exportálás esetén jelölje be az Interaktív elemek lehetőség mellett látható négyzetet. SWF fájlba való exportálás esetén jelölje be a Gombokkal együtt lehetőség mellett látható négyzetet.

Eseménytípusok

A dokumentum EPUB, PDF vagy SWF fájlba exportálása után az események határozzák meg a gombok által aktivált műveleteket. (Az Acrobat terminológiájában az eseményeket eseményindítóknak nevezik.)

Kattintáskor a gomb felengedésekor

Az egérgomb felengedése kattintás után. Ez a gombok esetén leggyakrabban használt esemény, mert lehetőséget ad a felhasználónak, hogy a művelet aktiválása nélkül elhúzhassa a mutatót a gombról.

Kattintáskor

Az egérgomb megnyomása (felengedés nélkül). Ha nincs kifejezett oka a Kattintáskor esemény használatára, akkor érdemesebb a Kattintáskor a gomb felengedésekor eseményt használni, mert a felhasználók így még megszakíthatják a műveletet.

Egérmutatóval való rámutatáskor

Amikor az egérmutató belép a gomb határolódoboza által definiált gombterületre.

Egérmutatóval való rámutatás megszűnésekor

Amikor az egérmutató elhagyja a gombterületet.

Belépés

Amikor a PDF fájl gombjába belépés történik, akár egérművelet, akár a Tab billentyű megnyomása következtében.

Elhagyás

Amikor a PDF fájl másik gombjába vagy űrlapmezőjébe történik belépés.

Művelettípusok

Művelet létrehozásakor azt kell megadnia, hogy mi történjen adott esemény (rendszerint a gombra való kattintás) bekövetkeztekor. Az alábbi műveletek végrehajtását rendelheti hozzá az adott eseménytípus aktiválásának esetére:

Ugrás a célra

A Könyvjelzők vagy Hiperhivatkozások panelen létrehozott, adott szerkesztőpontra ugrik. Lásd: Szöveghorgonyokra mutató ugrások létrehozása.

Ugrás az első/utolsó/előző/következő oldalra

A rögzített elrendezésű EPUB, PDF, illetve SWF fájl első, utolsó, előző vagy következő oldalára ugrás. A Nagyítás legördülő listában jelölje ki az oldal megjelenítési módját.

Ugrás URL-re

A megadott URL-címen lévő weblap megnyitása.

Gombok mutatása/rejtése

Megjeleníti, illetve elrejti a megadott gombokat az exportált rögzített elrendezésű EPUB, PDF vagy SWF fájlban. Ha például azt kívánja elérni, hogy az egyik gombra az egérrel rámutatva egy második gomb jelenjen meg, akkor a második gombot elrejtheti, majd egy kurzorráhúzáskor induló (On Rollover) műveletekkel megjeleníti azt. Lásd: Másik gomb megjelenítése kurzorráhúzáskor.

Videó

Lehetővé teszi a kijelölt mozgókép lejátszását, szüneteltetését, leállítását és lejátszásának folytatását. Csak a dokumentumban elhelyezett mozgóképek jelennek meg a Videó menüben.

Hang

Lehetővé teszi a kijelölt hangklip lejátszását, szüneteltetését, leállítását és lejátszásának folytatását. Csak a dokumentumhoz adott hangklipek jelennek meg a Mozgókép menüben.

Animáció (SWF/EPUB)

A kijelölt animáció lejátszása, szüneteltetése, leállítása és újraindítása. Csak a dokumentumban elhelyezett animációk jelennek meg az Animáció menüben.

Ugrás adott oldalra (SWF/EPUB)

Az SWF fájl megadott oldalára ugrik.

Ugrás adott állapotra (SWF/EPUB)

Többállapotú objektumban az adott állapotára ugrik. Ha például a többállapotú objektum több különféle képet tartalmaz állapotként, akkor ezzel a művelettel megjeleníthető az egyik kép.

Ugrás a következő vagy az előző állapotra (SWF/EPUB)

Többállapotú objektumban a következő vagy az előző állapotára ugrik. Ez a művelet különösen hasznos kattintással lapozható diavetítéshez. Lásd: Többállapotú objektumok létrehozása.

Ugrás a következő nézetre (PDF)

Az előző nézetre váltás után a következő oldalra ugrik. Ahogy a webböngészők Előre gombja csak azt követően érhető el, hogy a felhasználó a Vissza gombra kattint, ez a lehetőség is csak akkor érhető el, ha a felhasználó korábban egy előző nézetre ugrott.

Ugrás az előző nézetre (PDF)

A legutóbb megjelenített nézetre vált a PDF dokumentumban, vagy az utoljára használt nagyítási méretre vált.

Fájl megnyitása (PDF)

A megadott fájl megnyitása. Ha nem PDF fájlt ad meg, a felhasználónak rendelkeznie kell a fájltípus megnyitására alkalmas programmal a művelet sikerességéhez. Abszolút elérési utat adjon meg (például C:\dokumentumok\minta.pdf).

Nézet nagyítása (PDF)

Az oldal megjelenítése a megadott nagyítási beállítással. Módosíthatja az oldal nagyítási szintjét (például beállíthatja a Tényleges méret lehetőséget), az oldal elrendezését (például Folyamatos – Oldalpár) és az elforgatás tájolását.

Gombműveletek módosítása és törlése

  1. A Kijelölés eszközzel  jelölje ki a gombot.
  2. Végezze el a következő műveletek valamelyikét a Gombok panelen:
    • Művelet deaktiválásához törölje a jelet az adott művelet mellett található négyzetből. Az események és műveletek inaktiválása tesztelési célokra lehet hasznos.
    • A műveletek sorrendjének megváltoztatásához húzza át a műveleteket.
    • Művelet törléséhez jelölje ki a kívánt műveletet a legördülő listában, majd kattintson a Törli a kijelölt műveletet gombra .
    • Művelet módosításához jelölje ki azt az eseményt, amelyhez hozzá van rendelve a művelet, jelölje ki a műveletet a legördülő listában, majd módosítsa a beállításokat. Ha le szeretne cserélni valamelyik meglévő eseményhez tartozó műveletet, akkor törölje a műveletet, majd adjon hozzá egy újat az eseményhez.

Szerkesztőpontokra mutató ugrások létrehozása

InDesign dokumentumban létrehozott szerkesztőpont esetén akkor is beállíthatja a gombot úgy, hogy arra szerkesztőpontra ugorjon, ha az egy másik InDesign dokumentumban található. Szerkesztőpont megadására a Könyvjelzők és a Hiperhivatkozások panel használható. Gombbal nem lehet olyan könyvjelzőre ugrani, amely nem szerkesztőpont.

Megjegyzés:

Ha gombot ad meg egy hiperhivatkozás céljaként, akkor a hiperhivatkozás nem fog működni az exportált rögzített elrendezésű EPUB, PDF, illetve SWF dokumentumban.

  1. A Kijelölés eszközzel  jelölje ki a gombot.
  2. A Gombok panelen jelölje ki az ugrást indító események valamelyikét (pl. a Kattintáskor a gomb felengedésekor) eseményt.
  3. Kattintson a plusz jel gombra a Műveletek mellett, majd válassza az Ugrás a célra elemet.
  4. Jelölje ki a Dokumentumok listában szereplő megnyitott InDesign dokumentumok valamelyikét, vagy kattintson a listától jobbra található, mappát ábrázoló ikonra, és adja meg a kívánt fájlt.
  5. Adjon meg egy olyan rögzítőt, amit a Könyvjelzők vagy a Hiperhivatkozás panelen hozott létre.
  6. A Nagyítás legördülő listában jelölje ki az oldal megjelenítési módját.

Megjegyzés:

Ha másik dokumentumban lévő rögzítőt ad meg, a céldokumentumot ne feledje el PDF formátumba exportálni, és ehhez használja ugyanazt a fájlnevet, ami az InDesign dokumentum fájlneve, csak az INDD kiterjesztést cserélje a PDF kiterjesztésre. Emellett a PDF dokumentumokat ugyanabban a mappában kell tárolni, hogy a hivatkozások biztosan érvényesek legyenek az Acrobat és a Reader programokban.

Gombok Kurzorráhúzás és Rákattintás megjelenésének módosítása

A gombokat különálló objektumok alkotják, amely objektumok mindegyike a gombnak egy-egy megjelenését (vagy más néven állapotát) képviseli. Minden gombnak lehet akár három állapota is: Normál, Kurzorráhúzás és Rákattintás. Az exportált fájlban a gomb mindaddig a normál állapotban látszik, amíg az egérmutató az érzékeny területére nem ér (kurzorráhúzás), vagy amíg rá nem kattintanak a gombra. Az egyes megjelenések megkülönböztetésével látható visszajelzést tud adni.

Alaphelyzetben minden létrehozott gomb normál megjelenésű, és gomb szövegét vagy képét tartalmazza. Egy új megjelenés aktiválásakor, először ez a normál megjelenés másolódik oda. Az egyes állapotok eltérővé tételére módosíthatja a színeket, illetve szöveget vagy képet helyezhet el.

Gombállapotok

A. Az egér nem a gombra mutat (Normál) B. Az egér a gombra mutat (Kurzorráhúzás) C. Az egér rákattint a gombra (Rákattintás) 

Megjegyzés:

A gomb kattintásra érzékeny, azaz aktív felülete a gomb legnagyobb állapotát tükröző határolókereten belüli szögletes terület. Például egy kerek gombnak is szögletes az aktív felülete.

Gomb megjelenésének módosítása

Ha egy több megjelenést (Normál, Kurzorráhúzás és Rákattintás) tartalmazó gombot készít, érdemes az egyes megjelenések aktiválása előtt véglegesre szerkeszteni a gombot. A Kurzorráhúzás és Rákattintás megjelenés aktiválásakor majd ez a normál megjelenés másolódik.

Egyes módosítások csak a kijelölt megjelenésre, míg mások az összes aktivált megjelenésre hatnak. Ha egy megjelenés kijelölése után módosítja a háttérszínt, vagy szerkeszti a szöveget, akkor ezek a változtatások csak a kijelölt megjelenést érintik. Ha a Kijelölés eszközzel áthelyezi vagy átméretezi a gombot, ez a művelet az összes megjelenést érinti.

  1. Az Ablak menü Interaktív elemének Gombok parancsával jelenítse meg a Gombok panelt.
  2. A Kijelölés eszközzel  jelölje ki a szerkesztendő gombot a dokumentumban.
  3. A [Kurzorráhúzás] lehetőségre kattintva aktiválja a Kurzorráhúzás megjelenést.

    A Normál megjelenés bemásolódik a Kurzorráhúzás megjelenésbe.

  4. Miközben még mindig a Kurzorráhúzás állapot van kijelölve, módosítsa a gomb megjelenését.
    • A Vezérlőpult Körvonal vagy Kitöltés menüjéből válasszon egy színmintát a szín módosítására.
    • Úgy illeszthető kép az elrendezésbe, hogy közvetlen kijelölés eszközzel kijelölünk egy létező képet vagy duplán rákattintunk a létező gombképre, a Fájl > Elhelyezés menüelemet választjuk, majd duplán a fájlra kattintunk.
    • Kép szövegkeretbe illesztéséhez másolja azt a vágólapra, jelölje ki a megjelenést a Gombok panelen, majd válassza a Szerkesztés > Beillesztés alakzatba parancsot.
    • Szöveg beírásához jelölje ki a Szöveg eszközt, kattintson a gombra, majd adja meg a szöveget. A Szerkesztés menü Beillesztés alakzatba parancsával is beilleszthet egy beillesztett szövegkeretet.
  5. Rákattintási megjelenés megadásához előbb a [Rákattintás] elemre kattintva aktiválja azt, majd a fentiek szerint módosítsa a megjelenést.
  6. Az egyes gombmegjelenések az Előnézet panelen próbálhatók ki.

Megjegyzés:

A Gombok panelen megjelenő Állapot megjelenése típusú bélyegképek méretének módosításához válassza a Gombok panel menüjének Panel beállításai elemét, jelölje ki a kívánt lehetőséget, majd kattintson az OK gombra.

Megjelenések törlése és kikapcsolása

  1. Jelölje ki a megjelenést a Gombok panelen.
  2. Végezze el a következő műveletek valamelyikét:
    • A Kurzorráhúzás vagy Rákattintás megjelenést törléséhez kattintson a Törlés ikonra a panel alján. Egy megjelenés kitörlése különösen hasznos lehet, amikor lényegesen megváltoztatja a Normál megjelenést, és ebből kiindulva kívánja a Kurzorráhúzás és Rákattintás megjelenést újra elkészíteni.
    • Egy megjelenés kikapcsolható a mellette található Szem ikon kijelölésének megszüntetésével. A program a kikapcsolt állapotokat nem exportálja a rögzített elrendezésű EPUB, PDF vagy SWF fájlokba.

Megjegyzés:

A Normál állapot nem törölhető és nem kapcsolható ki.

Többállapotú objektumok létrehozása

Az Objektumállapotok panellel az objektumnak különféle verziói készíthetők el. Az állapot nem más, mint az oldalelem egy verziója. A több állapotot magába foglaló objektumok megnevezése többállapotú objektum.

Az Objektumállapotok panellel az objektumnak korlátlan számú állapota készíthető el. Minden újabb állapot létrehozásakor az objektumnak egy újabb verzióját készíti el. Egyszerre csak egy állapot jelenik meg az oldalon. Nyomtatáskor és PDF kimenetben végül csak az aktuális állapot jelenik meg.

Diavetítés készítése többállapotú objektummal

A többállapotú objektumokat leggyakrabban diavetítés készítésénél alkalmazzák, amelyben egy SWF fájl képeit a néző kattintással léptetheti. Készíthető például egy 20 képből álló diavetítés anélkül, hogy külön képeket kéne elhelyezni 20 külön oldalon.

  1. Helyezze el a diavetítésben megjelenítendő képeket.

    A lehetőleg gondoskodjon arról, hogy az egyes képek azonos méretű keretben legyenek.

    Az állapot nem feltétlenül csak egyetlen elemből áll; tartalmazhat több elemet is.

  2. A képek egymásra halmozásához jelölje ki valamennyit, majd kattintson a Vezérlőpult „Vízszintes középvonalak igazítása” és „Függőleges középvonalak igazítása” lehetőségére.

  3. A képek kijelölését megtartva, nyissa meg az Állapotok panelt (Ablak > Interaktív > Objektumállapotok), majd kattintson a „A kijelölés átalakítása többállapotú objektummá” gombra .

    A képek állapotok formájában megjelennek az Objektumállapotok panelben, és szaggatott vonal keretezi a kijelölt elemeket.

  4. Készítsen navigációs egy-egy gombot, amely kiváltja a „Ugrás a következő állapotra” és „Ugrás az előző állapotra” műveletek végrehajtását, amikor az egérgombot felette felengedi. Lásd: Gombkészítés.

  5. Használja az Előnézet panelt (Ablak > Interaktív > EPUB interaktivitás előnézet / SWF előnézet) elemét a navigációs gombok teszteléséhez.

  6. Exportálja a dokumentumot SWF formátumba. Lásd: Interaktív dokumentum.

Többállapotú objektum szerkesztése

  1. Többállapotú objektum kijelölése

  2. Végezze el bármelyek alábbi műveletet az Objektumállapotok panelen:

    • Az állapot szerkesztéséhez jelölje ki az állapotot az Objektumállapotok panelen, majd szerkessze az objektumot. Megadhat például körvonalat, kitöltést, illetve átméretezheti az objektumot.

    • Létező állapoton elhelyezhető újabb objektum, ha egyszerre kijelöli az objektumot és a többállapotú objektumot, majd az „Objektumok hozzáadása a látható állapothoz” gombra kattint.

    • Ha új objektumot kíván hozzáadni egy meglévő többállapotú objektumhoz, akkor jelölje ki mind a hozzáadandó objektumot, mind a többállapotú objektumot, majd kattintson a „Kijelölés átalakítása többállapotú objektummá” gombra .

    • Egy állapot megkettőzéséhez jelölje ki a lemásolandó objektumot, majd válassza az Új állapot elemet a panelmenüből. Az állapot tartalmát bővítheti, törölheti vagy szerkesztheti.

    • Objektumnak meglévő állapotba beillesztéséhez vágjon ki vagy másoljon egy vagy több objektumot, jelölje ki a többállapotú objektumot, jelölje ki a megfelelő állapotot az Objektumállapotok panelen, majd válassza a Beillesztés az állapotba elemet az Objektumállapotok panelmenüjéből.

    • Többállapotú objektum különálló objektumokra történő visszaalakításához jelölje ki az állapotot az Objektumállapotok panelen, majd válassza a panelmenü „Állapot feloldása objektumokká” elemét. Ha a többállapotú objektum összes állapotát külön objektummá kívánja alakítani, válassza a „Minden állapot feloldása objektumokká” menüelemet.

    • Egy állapot eltávolításához és tartalmának törléséhez jelölje ki az állapotot, majd válassza az Állapot törlése elemet a panelmenüből.

    • Ha el kívánja rejteni a többállapotú objektumot, amíg rá nem kattintanak egy gombra majd az exportált fájlban, akkor válassza a „Rejtett, amíg nincs indítva” beállítást a panelmenüből.

    • Egy dokumentum összes többállapotú objektumának alaphelyzetbe állítására a panelmenü „Minden többállapotú objektum első állapotba állítása” parancsa szolgál. Ha kijelöl egy állapotot, az objektum megőrzi azt akkor is, ha a dokumentumot közben bezárja, és újra megnyitja. Ezzel a művelettel viszont gyorsan visszaállítható az összes többállapotú objektum alapállapota.

Aktív felület kijelölése a gombon

Bizonyos esetekben szükség lehet a gomb területének (az úgynevezett „aktív felületnek” vagy „aktív hivatkozásnak”) rejtve tartására, hogy az csak akkor jelenjen meg, ha az egérmutató rámutat. Ha például az egeret egy térképen található gomb fölé húzza, megjeleníthet egy olyan képet, amely a területet ábrázolja, és amelyik eltűnik, amikor az egérmutatót a területen kívülre húzza.

Az exportált PDF fájlban meg fog jelenni egy kép, amikor az egérmutató az aktív felületen áll.

Rejtett kép megjelenítése kurzorráhúzáskor (On Rollover)

„Aktív felület” hatást például úgy tud elérni, hogy a Gombok panelen képet helyez el a Kurzorráhúzás állapotban. Ehhez olyan gombot kell készíteni, amelynek [Kurzorráhúzás] állapota egy képet ábrázol, viszont [Normál] állapota nem tartalmazza a képet.

  1. Jelölje ki az aktív felületen megjelenítendő képet. Győződjön meg róla, hogy a képnek nincs sem kerete, sem háttere.

  2. A Gombok panelen (Ablak > Interaktív > Gombok) a [Normál] megjelenésre kattintva alakítsa gombbá a kijelölt képet.

  3. A Gombok panelen a [Kurzorráhúzás] megjelenésre kattintva aktiválja a Kurzorráhúzás állapotot.

  4. Ismét kattintson a [Normál] megjelenésre. Ott jelölje ki a képet a Közvetlen kijelölés eszközzel , és törölje.

    Ügyeljen arra, hogy csak a képet törölje (a keret tartalmát), és nehogy a keretet és a tartalmat is. Ha törli a keretet, azzal törli az egész gombot.

  5. Az aktív felület hatás előnézetét az Előnézet panellel jelenítheti meg.

Másik gomb megjelenítése kurzorráhúzáskor (On Rollover)

Létrehozható olyan aktív felület, amely rákattintás vagy az egérrel rámutatás hatására megjelenít egy objektumot. Ehhez hozzon létre két gombot, az egyiket rejtse el, és a Gomb megjelenítése és Gomb elrejtése műveletekkel jelenítse meg és rejtse el a célgombot.

  1. Hozzon létre egy objektumot, amelyből a forrásgomb lesz. Kattintson a Gombok panel Objektum gombbá alakítása ikonjára.
  2. Helyezze el a célgombként szolgáló képet, majd alakítsa gombbá.
  3. Jelölje ki a célképet és válassza a Eseményindításig rejtett beállítást a Gombok panel alján.

    A képnek azért kell rejtettnek lennie az exportált dokumentumban, hogy az akkor jelenhessen meg, amikor forrásgombra rámutat vagy rákattint az egér.

  4. Jelölje ki a forrásgombot, és hozzon létre két külön műveletet: egyet, amely megjeleníti a célképet, és egy másikat, amely elrejti.

    Ha a kép megjelenítését az egérmutató forrásgombra húzásakor kívánja elvégeztetni, használja a Kurzorráhúzáskor (On Roll Over) és a Kurzorlehúzáskor (On Roll Off) eseményeket. Ha a kép megjelenítését a forrásgombra kattintáskor kívánja elvégeztetni, majd felengedéskor a képet eltüntetni, akkor használja a Rákattintáskor (On Click) és a Felengedéskor (On Release) eseményeket. Mindkét esetben a Gomb megjelenítése és Gomb elrejtése művelettel kell megjeleníteni és elrejteni a célgombot. Lásd: Interaktív gombok készítése.

  5. A gombok az Előnézet panelen próbálhatók ki.

A gombok PDF beállításainak módosítása

  1. A Kijelölés eszközzel  jelölje ki a gombot.
  2. A Gombok panelen válassza a PDF beállításokat.
  3. Gépeljen be egy képet helyettesítő leírást a látáskárosult felhasználók számára.
  4. Állítsa be hogy a gomb nyomtatható legyen-e a PDF fájlban, majd kattintson az OK gombra.

Gombok bejárási sorrendjének beállítása

A bejárási sorrend határozza meg, hogy melyik lesz a fókusszal rendelkező következő mező, ha a felhasználó lenyomja a Tab billentyűt vagy a Shift+Tab billentyűkombinációt a PDF, illetve SWF dokumentumban. A bejárási sorrend a rejtett rétegeken lévő gombokat is magába foglalja, a mesteroldalak gombjait viszont nem.

  1. Lépjen a gombokat tartalmazó oldalra.
  2. Kattintson az Objektum menü Interaktív pontjának Bejárási sorrend beállítása parancsára.
  3. Jelölje ki az áthelyezendő gombokat, és húzza őket a kívánt pozícióba. Húzás helyett a Feljebb és Lejjebb gombokat is használhatja. Ha kész, kattintson az OK gombra.

Ha az Acrobat programban módosítja a PDF fájlt és további gombokkal vagy űrlapmezőkkel bővíti az oldalt, akkor szükség lehet új bejárási sorrend megadására az Acrobat programban.

Ez a munka a Creative Commons Nevezd meg!-Ne add el!-Így add tovább! 3.0 Unported licenc alatt lett közzétéve.  A Twitter™ és Facebook közzétételeket a Creative Commons jogi feltételei nem szabályozzák.

Jogi közlemények   |   Online adatvédelmi nyilatkozat