A táblázatok cellákat tartalmazó sorokból és oszlopokból épülnek fel. A cella nem más, mint egy szövegkeret, amelyben szöveg, rögzített keretek és egyéb táblázatok helyezhetők el. A táblázatokat létrehozhatja az Adobe InDesign CS5 programban, vagy exportálhatja őket más alkalmazásokból.

Megjegyzés:

Az Adobe InCopy programban a táblázatok létrehozásához, szerkesztéséhez és formázásához az Elrendezés nézetet használja.

Táblázatok létrehozása

A táblázatok cellákat tartalmazó sorokból és oszlopokból épülnek fel. A cella nem más, mint egy szövegkeret, amelyben szöveg, szövegközi grafikák és egyéb táblázatok helyezhetők el. Táblázatok létrehozhatók teljesen újként, de akár már meglévő szövegből történő átalakítással is, sőt, egy másik táblázatba is beágyazhatók.

Táblázat létrehozásakor az új táblázat kitölti a befoglaló szövegkeret szélességét. Ha a kurzor a sor elején van, akkor a program a kurzorral megegyező sorba szúrja be a táblázatot, ha viszont a kurzor valamelyik sor közepén van, akkor a következő sorba.

A táblázatok a szövegközi grafikákhoz hasonlóan együtt mozognak az őket körülvevő szöveggel: egy adott táblázat például összefűzött kereteken is átnyúlik, ha a fölötte található szöveg betűmérete módosul, illetve ha szöveget ad hozzá vagy töröl a felhasználó. Görbén elhelyezkedő szöveg alkotta kereten azonban nem jeleníthető meg táblázat.

Michael Murphy cikke a táblázatok létrehozásáról és formázásáról (angol nyelven): Mind Your Table Manners.

Jeff Witchell az InfiniteSkills.com képviseletében egy videós bemutatót tart: A táblázatok beállításának alapjai.

Táblázat létrehozása teljesen újként

Amikor az InDesign programban egy táblázatot készít, lehetősége van, hogy a táblázatot egy szövegkeretben készítse (Táblázat beszúrása lehetőség használata). Másik lehetőség, hogy létrehoz egy táblázatot, és lehetővé teszi, hogy az InDesign hozza létre a befoglaló szövegkeretet (Táblázat létrehozása lehetőség használata).

Táblázat beszúrása lehetőség használata

  1. Táblázat rajzolásához egy létező szövegkeretben használja a Szöveg eszköztés helyezze a beszúrási pontot oda, ahol a táblázatot megjeleníteni szeretné.

  2. Kattintson a Táblázat menü Táblázat beszúrása parancsára.

    Megjegyzés:

    Ha a kurzor jelenleg nincs egy szövegkeretben, a Táblázat létrehozása lehetőség elérhető.

  3. Adja meg a sorok és az oszlopok számát.
  4. Ha a táblázat tartalma több oszlopot vagy keretet is felölel, adja meg, hogy hány fejléc- vagy láblécsorban ismétlődjenek az adatok.
  5. (Nem kötelező lépés:) Válasszon táblázatstílust.
  6. Kattintson az OK gombra.

    Az új táblázat kitölti a szövegkeretet.

Táblázat létrehozása lehetőség használata

Amikor a Táblázat létrehozása lehetőséget használja egy táblázat készítésekor, nem szükséges először egy szövegkeretet létrehoznia a dokumentumban. Ahogy rajzolja a táblázatot a dokumentumban, az InDesign a rajzolt táblázatnak megfelelő méretű szövegkeretet készít.

  1. Válassza a Táblázat > Táblázat létrehozása elemet.

    Megjegyzés:

    Ha a kurzor jelenleg egy szövegkeretben van, a Táblázat beszúrása lehetőség elérhető.

  2. Adja meg a sorok és az oszlopok számát.
  3. Ha a táblázat tartalma több oszlopot vagy keretet is felölel, adja meg, hogy hány fejléc- vagy láblécsorban ismétlődjenek az adatok.
  4. (Nem kötelező lépés:) Válasszon táblázatstílust.
  5. Kattintson az OK gombra.
  6. Használja a Táblázat kurzort az igényelt táblázat rajzolásához.

    InDesign készít egy szövegkeretet a rajzolt területnek megfelelően és a táblázatot a szövegkeretben helyezi el.

A táblázatok sormagasságát a választott táblázatstílus határozza meg: a különböző stílusok például cellastílusokkal formázhatják a táblázat egyes részeit. Ha e cellastílusok közül bármelyik is tartalmaz bekezdésstílusokat, akkor ez utóbbi stílusok sortávolsága szabja meg a szóban forgó terület sormagasságát. Ha nincs megadva bekezdésstílus, a dokumentum alapértelmezett infoterülete vezérli a sormagasságot. (Az infoterület a sortávolságon alapul. Ebben az értelemben az infóterület a kijelölt szövegbeli kiemelés hozzávetőleges magassága.)

Táblázat létrehozása már meglévő szövegből

Mielőtt táblázattá alakítaná a szöveget, győződjön meg arról, hogy a szöveg beállításai helyesek.

  1. Az átalakításra történő előkészítés részeként szúrja be az oszlopok elkülönítésére szolgáló tabulátorokat, vesszőket és bekezdésvégjeleket vagy egyéb karaktereket. Szúrja be a sorok elkülönítésére szolgáló tabulátorokat, vesszőket és bekezdésvégjeleket vagy egyéb karaktereket. (Sok esetben szerkesztés nélkül is táblázattá alakítható a szöveg.)
  2. Jelölje ki a Szöveg eszközzel  a táblázattá alakítandó szöveget.
  3. Kattintson a Táblázat menü Szöveg táblázattá alakítása parancsára.
  4. Az Oszlopelválasztó és a Sorelválasztó mezőben adja meg, hogy hol kezdődjenek az új sorok és oszlopok. Válasszon a Tabulátor, a Vessző vagy a Bekezdés lehetőség közül, vagy írja be a használandó karaktert (például a pontosvesszőt) az Oszlopelválasztó vagy a Sorelválasztó mezőbe. (A beírt karakter látható lesz a menüben, amikor legközelebb táblázatot hoz létre szövegből.)
  5. Ha mind az oszlopokhoz, mind a sorokhoz ugyanazt az elválasztó karaktert adja meg, írja be a táblázatban szerepeltetni kívánt oszlopok számát.
  6. (Nem kötelező lépés:) Táblázatstílus megadásával formázza a táblázatot.
  7. Kattintson az OK gombra.

Ha bármely sorban a táblázat oszlopainak számánál kevesebb elem található, a sort üres cellák töltik ki.

Táblázat beágyazása táblázatba

  1. Tegye a következők egyikét:
    • Jelölje ki a beágyazandó cellákat vagy táblázatot, és kattintson a Szerkesztés menü Kivágás vagy Másolat parancsára. Vigye a kurzort abba a cellába, amelyben meg szeretné jeleníteni a táblázatot, és kattintson a Szerkesztés menü Beillesztés parancsára.

    • Kattintson bele egy cellába, majd a Táblázat menü Táblázat beszúrása parancsára, adja meg a sorok és oszlopok számát, végül kattintson az OK gombra.

  2. Szükség szerint adja meg a belső margót. (Lásd: Szöveg formázása táblázaton belül.)

Cellában létrehozott táblázat esetén az egérrel nem jelölhető ki a cella szélén túllógó táblázat egyetlen része sem. Ehelyett növelni kell a sor vagy az oszlop méretét, vagy a kurzort a táblázat első részébe kell helyezni, és billentyűparancsokkal kell áthelyezni a kurzort és kijelölni a szöveget.

Táblázatok importálása egyéb alkalmazásokból

Ha az Elhelyez paranccsal importál táblázatokat tartalmazó Microsoft Word dokumentumot vagy Microsoft Excel-számolótáblát, az importált adatok szerkeszthető táblázat formájában jelennek meg. Az adatok formázása az importálási beállításokat összegző párbeszédpanelen végezhető el.

Lehetősége van arra is, hogy egy Excel-számolótáblából vagy egy Word dokumentumbeli táblázatból illesszen be adatokat InDesign vagy InCopy dokumentumba. A más alkalmazásokból beillesztett szöveg formázásának mikéntjét a Beállítások párbeszédpanel Vágólap kezelése kategóriájának beállításai határozzák meg. Ha be van jelölve a Csak szöveg választógomb, az adatok formázatlan, tabulátorral tagolt, ezáltal táblázattá alakítható szövegként jelennek meg. Ha a Minden információ (indexjelölők, minták, stílusok, stb.) választógomb az aktív, a beillesztett szöveg formázott táblázatként lesz látható.

Ha már meglévő táblázatba illeszti be a szöveget egy másik alkalmazásból, szúrjon be kellő számú sort és oszlopot, hogy legyen elegendő hely a szövegnek, jelölje be a Beállítások párbeszédpanel Vágólap kezelése kategóriájának Csak szöveg választógombját, és győződjön meg arról, hogy legalább egy cella ki van jelölve (hacsak nem cellába szeretné beágyazni a beillesztett táblázatot).

Ha az importált táblázatot részletesebben is szeretné beállítani, illetve ha meg akarja tartani a táblázat formázását, akkor használja az Elhelyez parancsot a táblázat importálásához. Ha meg kívánja őrizni a táblázat kapcsolatát az eredeti számolótáblával, akkor válassza a Hivatkozások létrehozása szöveg- és táblázatfájl elhelyezésekor beállítást a Fájlkezelés beállításokban.

Megjegyzés:

A másolási és beillesztési paranccsal is beilleszthet egy tabulátorokkal tagolt szöveget a kijelölt táblázatcellákba. Így a formázás módosítása nélkül cserélhet le tartalmat. Tegyük föl például, hogy egy havilapban kívánja frissíteni egy formázott táblázat tartalmát. Az egyik lehetőség egy Excel táblázat csatolása. Ha azonban más forrásból származik a tartalom, kimásolhatja az új tartalmat tartalmazó tabulátorokkal tagolt szöveget, kijelölheti a formázott InDesign táblázatban a cellák tartományát, majd beillesztheti a tartalmat.

Szöveg hozzáadása táblázathoz

A táblázatok celláiba szöveg, rögzített objektumok, XML címkék és egyéb táblázatok vehetők fel. A táblázatsorok magasságát automatikusan úgy állítja be a program, hogy a további sorok is elférjenek (kivéve, ha rögzített sormagasság van megadva). Lábjegyzetek nem vehetők fel táblázatokba.

  1. A Szöveg eszközzel  tegye a következők egyikét:
    • Vigye a kurzort az egyik cellába, és írjon be szöveget. Az ENTER (RETURN) billentyűt megnyomva hozzon létre egy új bekezdést ugyanabban a cellában. A cellákon a Tab billentyűvel lépkedhet előre (a Tab billentyűt az utolsó cellában lenyomva új sort szúrhat be). Visszafelé a Shift+Tab billentyűkombinációval lépkedhet.

    • Másolja a szöveget a vágólapra, helyezze a beszúrási pontot egy cellába, és kattintson a Szerkesztés menü Beillesztés parancsára.

    • Helyezze a beszúrási pontot abba a cellába, ahol a szöveget elhelyezni kívánja, kattintson a Fájl menü Elhelyez parancsára, végül kattintson duplán valamelyik szövegfájlra.

Grafikák hozzáadása táblázathoz

  1. Helyezze a beszúrási pontot abba a táblázatcellába, melyhez a képet adni szeretné.

  2. Végezze el a következő műveletek valamelyikét:
    • Válassza a Fájl > Elhelyezés elemet, és jelöljön ki egy vagy több grafikus fájlt.
    • Jelöljön ki egy vagy több grafikus fájlt és húzza át a Grafikák kategóriából a CC Libraries panelen.

    A kép vagy képek elérhetővé válnak a szórópisztolyban.

  3. A kép vagy képek elhelyezéséhez kattintson mindegyik táblázatcellába.

  4. Végezze el a következő műveletek valamelyikét:

Megjegyzés:

Nem lehet InDesign objektumdarabokat áthúzni a CC Libraries panel Grafikák kategóriájából .

Ha a felvenni kívánt grafika nagyobb a cellánál, a program automatikusan úgy állítja be a cella magasságát, hogy elférjen a grafika – a cella szélessége azonban nem változik, ezért nem kizárt, hogy a grafika túlnyúlik a cella jobb oldali szegélyén. Ha a grafika helyeként megadott sor magassága rögzített, akkor az annál magasabb grafikák hatására a cella túlszedett lesz.

Megjegyzés:

A túlszedett cellák elkerülése végett helyezze a szóban forgó képet a táblázaton kívülre, majd méretezze át és illessze be a táblázatcellába.

Táblázatcellákban elhelyezhet képeket a következő módszerekkel is:

  • Válassza az Objektum > Rögzített objektum > Beszúrás elemet, majd adja meg a beállításokat. A rögzített objektumhoz a későbbiekben is hozzáadhat grafikákat.
  • Másoljon a vágólapra egy grafikát vagy egy keretet, vigye a kurzort a kívánt helyre, és kattintson a Szerkesztés menü Beillesztés parancsára.

Fejlécek és láblécek hozzáadása táblázathoz

Hosszú táblázat létrehozásakor valószínűleg több oszlopra, keretre vagy oldalra is kiterjed a táblázat. Fejlécek és láblécek használatával a táblázat valamennyi felosztott részén megismételheti a megjelenítendő információt.

A táblázat létrehozásakor fejlécsorok és láblécsorok is felvehetők. Ez a művelet, valamint az ilyen sorok táblázatbeli megjelenésének módosítása a Táblázat beállításai párbeszédpanelen is végrehajtható. A törzssorok fejlécsorokká és láblécsorokká is átalakíthatók.

Fejlécek és láblécek hozzáadása táblázathoz
Keretenként egyszer ismétlődő fejlécsorok

Megjegyzés:

Ha a táblázatokat folytatólagosan szeretné számozni (pl. 1A táblázat, 1B táblázat stb.), adjon hozzá változót a táblázat fejlécéhez vagy láblécéhez. (Lásd Futó feliratok készítése ábrákhoz és táblázatokhoz.)

  1. Fejlécsorok létrehozásához jelölje ki a táblázat tetején lévő, láblécsorok létrehozásához pedig a táblázat alján található sorokat.
  2. Kattintson a Táblázat menü Sorok átalakítása almenüjének Fejléchez vagy Lábléchez parancsára.
  1. Helyezze a kurzort a táblázatba, és kattintson a Táblázat menü Táblázat beállításai almenüjének Fejlécek és láblécek parancsára.
  2. Adja meg a fejlécsorok és a láblécsorok számát. A táblázat tetejére vagy aljára további üres sorokat is felvehet.
  3. Az ismétlést beállító legördülő listákban válassza ki, hogy minden szöveges oszlopban (ha a szövegkeretekben több oszlop is van), keretenként egyszer vagy oldalanként egyszer jelenjen-e meg a fejlécben vagy a láblécben lévő információ.
  4. Ha nem szeretné, hogy a táblázat első sorában megjelenjen a fejlécben tárolt információ, jelölje be az Első kihagyása jelölőnégyzetet. Az Utolsó kihagyása négyzetet bejelölve a program nem tünteti fel a láblécben tárolt információt.

    Az Első kihagyása beállítás különösen hasznos, ha azt akarja jelezni, hogy a fejléc vagy lábléc folytatódik. Például több oldalra átnyúló táblázat esetén olyan fejlécet érdemes készíteni, hogy „2. táblázat (folytatás)”. Mivel a táblázat első oldalán nem szabad megjelennie „(folytatás)” feliratnak, az Első kihagyása beállítást kell választani, és a táblázat első sorába csak annyit beírni, hogy 2. táblázat.

  5. Kattintson az OK gombra.

Számos funkciót tud végrehajtani, hogy hasonló sorokat és oszlopokat hozzon létre, vagy megkettőzze őket. 

Elsősorban a táblázat sorain és oszlopain a következő funkciókat végezheti:

  • Táblázat sorainak és oszlopainak húzása egyik helyzetből egy másikba ugyanazon táblázaton belül.
  • Sorok és oszlopok megkettőzése.
  • Sorok és oszlopok beszúrása másik sor/oszlop elé vagy mögé
  • Sor tartalmának oszlopba vagy oszlop tartalmának sorba másolása.

Sorok/oszlopok húzása és megkettőzése

Táblázat sorainak és oszlopainak áthelyezése egyik helyzetből egy másikba ugyanazon táblázaton belül. Kövesse ezeket a lépéseket sorok/oszlopok húzásához és megkettőzéséhez.

  1. Válassza ki azt a sort vagy oszlopot, amit egy másik sorra vagy oszlopra húzni kíván. Győződjön meg arról, hogy a teljes oszlop vagy sor ki lett választva. Sorok vagy oszlopok részlegesen kiválasztva nem húzhatók.

  2. Az egérmutatót a kijelölt sorok fölött tartva egyéni kurzor jelzi, hogy a kijelölés áthelyezhető.

  3. A sor húzható. Az oszlopok és sorok felcserélhetők. A húzott sor csak sorként, míg a húzott oszlop csak oszlopként ejthető el.

    Sorok és oszlopok húzása
    Sorok és oszlopok húzása

    Egy sor egyik helyről másik helyre mozgatása az összes sor számát nem változtatja meg, csak három.

    Megjegyzés:

    Húzás csak ugyanabban a táblázatban lehetséges

  4. Sor vagy oszlop megkettőzéséhez nyomja le és tartsa lenyomva az Alt(Win) vagy Opt(Mac) billentyűt a sor vagy oszlop kijelölése után. Több, folyamatosan kiválasztott sor vagy oszlop húzható.

  5. A kijelölt sor vagy hasáb a tervezett helyre húzható. A sorok vagy oszlopok teljes mennyisége megnő úgy, ahogy a kijelölt megkettőződik.

    A fejléc és lábléc soraiból is másolhatók a tartalmak a táblázattörzs soraiba (lenyomva az Alt/Opt billentyűt). Hasonlóképpen a törzssorok is megkettőzhetők és fejléc és lábléc sorokká konvertálhatók.

Fejlécsorok csak fejléc részen belül húzhatók (csak akkor alkalmazható, ha több fejlécsor van) az alt/opt használható a sorok megkettőzéséhez. A törzsszöveg sorai nem húzhatók/ejthetők a fejléc szakaszba míg az alt/opt használható a sorok megkettőzéséhez.

Sorok/oszlopok másolása és beillesztése elé/mögé

Sorok másolhatók és beilleszthetők a kijelölt sor elé vagy mögé. A Beillesztés elé/mögé munkafolyamat használatával egy táblázat sorai/oszlopai másolhatók és beilleszthetők egy másik táblázatba is.

  1. Válasszon ki egy sort/oszlopot.

  2. Válassza ki a sort vagy oszlopot.

  3. Válassza a Táblázat > Beillesztés elé/Beillesztés mögé parancsot. 

  1. Végezze el a következő műveletek valamelyikét:
    • Helyezze a kurzort a fejlécsorba vagy a láblécsorba, és kattintson a Táblázat menü Sorok átalakítása almenüjének Törzshöz parancsára.

    • Kattintson a Táblázat menü Táblázat beállításai almenüjének Fejlécek és láblécek parancsára, és változtassa meg a fejlécsorok és a láblécsorok számát.

Ez a munka a Creative Commons Nevezd meg!-Ne add el!-Így add tovább! 3.0 Unported licenc alatt lett közzétéve.  A Twitter™ és Facebook közzétételeket a Creative Commons jogi feltételei nem szabályozzák.

Jogi közlemények   |   Online adatvédelmi nyilatkozat