选择“图像” > “变量” > “定义”。
- 新增功能
-
快速入门
- 技术要求和安装
-
了解基本信息
- 桌面版 Adobe Photoshop 常见问题解答
- 主屏幕概述
- 工作区概述
- 访问“发现”面板
- 保存自定义工作区
- 切换工作区
- 删除工作区
- 停靠或取消停靠面板
- 堆叠浮动的面板
- 使用“上下文任务栏”增强工作流程
- 重新排列文档窗口
- 添加和删除面板
- 移动面板
- 隐藏或显示所有面板
- 还原工作区
- 展开或折叠面板图标
- 更改面板和工具提示中的文本大小
- 在数字字段中执行简单的数学运算
- 高密度显示器支持和每个显示器的缩放比例
- 排列和分组面板
- 在 Photoshop 中缩放图像
- 校准显示器并创建显示器的配置文件
- Photoshop 中的 Creative Cloud Libraries
- 请求访问权限以测试实验性功能
- 导航图像并管理画布视图
- 设置工具栏和面板
- 设置和首选项
- 创建、打开和导入图像
-
创建和管理图层
- 开始使用图层
- 转换和处理图层
- Color adjustment and fill layers
- 应用图层效果
- 智能对象
- 创建图层合成
- 布局和设计工具
-
裁切、调整大小和变换
- 调整大小和分辨率
- 裁切和拉直
- 转换、操作和重塑
-
建立选区
- 选区快速入门
- 自动和基于颜色的选择
- 手绘选区
- 优化和修改选区
- 创建蒙版
-
修复和修饰
- 移除对象并填充空间
- 修复和克隆
- 调整光线和色调
- 清理和还原图像
-
调整颜色
- 颜色配置文件
- 选择颜色
- 颜色模式
- 颜色校正
- 选择性颜色调整
- 颜色效果和技巧
- HDR 和通道调整
-
应用绘画技巧
- 填充对象、选区和图层
- 创建并使用图案填充
- 画笔和预设
- 绘制形状和路径
-
文本和排版规则
- 开始使用文本
- 选择并管理字体
- 文字图层及创建
- 路径和形状上的文本
- 字符和字形
- 国际文本和语言
- 使用动态文本
-
效果和滤镜
- 开始使用滤镜
- 智能滤镜
- 模糊和锐化滤镜
- 艺术效果和风格化滤镜
- Neural Filters
- 快速操作
- 使用网格和测量参考线
-
添加视频和动画
- 创建动画帧
- 使用关键帧
- 组织和管理视频组
-
自动执行任务
- 创建和记录动作
- 处理一批文件
- 自动化设置和预设
- 通过模板和变量的
-
存储和导出
- 保存文件
- Export files to different formats
- 元数据、CSS 和 Content Credentials
- 打印
-
应用程序集成
- 在 Illustrator 中打开 Photoshop 文件
- 使用可选扩展
- 安装和管理 Marketplace 插件
- 安装 ScriptingListener 插件
- 为 Texturizer 过滤器安装纹理
- 适用于 Photoshop 的 MATLAB 文档属性
- 在 InDesign 中置入 Photoshop 文件
- 扩展描述和兼容性
- 设置 MATLAB 以便与 Photoshop 协同工作
- 从 Photoshop 将图像共享到 Slack
- 将 Photoshop 作品共享到 Trello
- 排查 InDesign 中 Photoshop 文件的问题
- 保存和管理云文档
- 邀请其他用户编辑云文档中的图像
- 使云文档可离线使用
- 使用插件市场安装和管理插件
- 创建联系表
- 创建 PDF 演示文稿
- 将 Illustrator 插图作为图层粘贴
- 从 Illustrator 粘贴到 Photoshop 的限制
- 将 Adobe Illustrator 图片粘贴到 Photoshop 中
- 在 Adobe Photoshop 中置入 Illustrator 文件或 PDF
- 在 Adobe Illustrator 中使用 Photoshop 图像
- 在 InDesign 中使用 Photoshop 图层复合
- InDesign 中的 Photoshop 文件行为
- Photoshop 云文档概述
- Photoshop 插件和扩展
-
疑难解答
- 工具和资源
- 性能和稳定性问题
- 文件和格式问题
-
工具和功能问题
- 使用项目符号和编号时 Photoshop 崩溃
- 键盘快捷键无法使用
- 使用 Illustrator 时的限制
- 解决视频渲染问题
- Adobe Photoshop 中的工具行为异常
- 工具从工具栏中消失
- 解决字体问题
- 解决 Photoshop 云文档错误
- Adobe Photoshop 中的插件崩溃和错误
- 为 Adobe Photoshop 输入问题捕获诊断日志
- 使用 Adobe Photoshop 脚本时出现的错误
- 使用滤镜和效果时的问题
- Adobe Photoshop 崩溃、卡顿或冻结
- 排查 Windows 上 Photoshop 快捷批处理的问题
- Stock 资源无法完全更新
- 文本随机更改或已损坏
- Photoshop 中的插件文件夹位置
- Photoshop 在 Apple Silicon 上的限制
- 我的预设、动作或增效工具缺失
- 油画过滤器显示为灰色
- “打印”对话框中的打印设置选项不可用
- 动作缺失
创建数据驱动的图形
使用变量和数据集,生成具有不同文本和图像的多个模板版本。
数据驱动图形可让您通过定义需要更改的元素并通过数据集提供替换内容,从单个模板生成多个图像变体。
当您需要生成文本、图像或图层可见性各不相同的多个设计版本时,可以使用此工作流程,例如各种产品的 Web 横幅、个性化证书或本地化营销素材。您的模板必须为每个要更改的元素使用单独的图层。有关从外部文本文件导入数据集的信息,请参阅有关数据集导入的相关文章。
Photoshop 支持三种变量类型,用于控制模板的各个方面。可见性变量用于控制图层内容是否可见。文本替换变量用于替换文字图层中的字符串。像素替换变量用于将图层像素替换为图像文件中的内容。您可以为单个模板应用多种变量类型,并将多个图层关联到同一变量,以实现协调更改。
为模板元素定义变量
从“图层”菜单中选择包含要更改内容的图层。
选择一种或多种变量类型:“可见性”、“文本替换”或“像素替换”。
在“名称”字段中输入名称,可使用字母、下划线、冒号、句点或连字符,但不能有空格。
为“像素替换”变量选择一种缩放方法(“适合”、“填充”、“照原样”或“一致”)。
选择对齐位置,然后选中“剪切到定界框”。
对其他图层重复此操作,然后选择“确定”。
对话框中,包含变量的图层会在其名称旁显示星号。要重命名变量,请返回“图像” > “变量” > “定义”,选择该图层,然后在“名称”字段中输入新名称。要将多个图层关联到同一变量,请在为其他图层定义变量时,从“名称”下拉菜单中选择现有的变量名称。
创建和管理数据集
选择“图像” > “变量” > “数据集”。
选择新建数据集图标,以根据当前值创建数据集。
从名称菜单中选择一个变量。
编辑变量数据:
- 对于可见性变量:选择可见或不可见
- 对于像素替换变量:选择文件,然后选取替换图像
- 对于文本替换变量:在值字段中输入文本。
对数据集中的每个变量重复此操作。
为您需要的每种设计变体创建其他数据集。
完成后,选择确定。
通过导航到图像 > 应用数据集、从列表中选择数据集并选择应用,预览每个数据集对设计的影响。 您还可以选中数据集对话框中的预览复选框,以便在不关闭对话框的情况下查看更改。
使用数据集对话框中的箭头图标在数据集之间移动。 要修改现有数据集,请从数据集菜单中选择该数据集,然后编辑变量值。 要删除数据集,请选择该数据集,然后选择删除图标。
从数据集生成输出文件
选择文件 > 导出 > 数据集 另存为文件。
在命名字段中输入生成文件的基本名称。
选择 文件夹,然后选择目标目录。
从列表中选择要导出的数据集。
选择确定以生成文件。
Photoshop 会为每个数据集创建单独的 PSD 文件,将您的基本名称与数据集名称相结合。 每个文件都包含应用了数据集值的模板。
将数据集直接应用于模板(图像 > 应用数据集)会覆盖原始文档。 请始终在副本上操作,或将数据集导出为文件。