打开您的安全软件或防病毒软件设置。
- 新增功能
-
快速入门
- 技术要求和安装
-
了解基本信息
- 桌面版 Adobe Photoshop 常见问题解答
- 主屏幕概述
- 工作区概述
- 访问“发现”面板
- 保存自定义工作区
- 切换工作区
- 删除工作区
- 停靠或取消停靠面板
- 堆叠浮动的面板
- 使用“上下文任务栏”增强工作流程
- 重新排列文档窗口
- 添加和删除面板
- 移动面板
- 隐藏或显示所有面板
- 还原工作区
- 展开或折叠面板图标
- 更改面板和工具提示中的文本大小
- 在数字字段中执行简单的数学运算
- 高密度显示器支持和每个显示器的缩放比例
- 排列和分组面板
- 在 Photoshop 中缩放图像
- 校准显示器并创建显示器的配置文件
- Photoshop 中的 Creative Cloud Libraries
- 请求访问权限以测试实验性功能
- 导航图像并管理画布视图
- 设置工具栏和面板
- 设置和首选项
- 创建、打开和导入图像
-
创建和管理图层
- 开始使用图层
- 转换和处理图层
- Color adjustment and fill layers
- 应用图层效果
- 智能对象
- 创建图层合成
- 布局和设计工具
-
裁切、调整大小和变换
- 调整大小和分辨率
- 裁切和拉直
- 转换、操作和重塑
-
建立选区
- 选区快速入门
- 自动和基于颜色的选择
- 手绘选区
- 优化和修改选区
- 创建蒙版
-
修复和修饰
- 移除对象并填充空间
- 修复和克隆
- 调整光线和色调
- 清理和还原图像
-
调整颜色
- 颜色配置文件
- 选择颜色
- 颜色模式
- 颜色校正
- 选择性颜色调整
- 颜色效果和技巧
- HDR 和通道调整
-
应用绘画技巧
- 填充对象、选区和图层
- 创建并使用图案填充
- 画笔和预设
- 绘制形状和路径
-
文本和排版规则
- 开始使用文本
- 选择并管理字体
- 文字图层及创建
- 路径和形状上的文本
- 字符和字形
- 国际文本和语言
- 使用动态文本
-
效果和滤镜
- 开始使用滤镜
- 智能滤镜
- 模糊和锐化滤镜
- 艺术效果和风格化滤镜
- Neural Filters
- 快速操作
- 使用网格和测量参考线
-
添加视频和动画
- 创建动画帧
- 使用关键帧
- 组织和管理视频组
-
自动执行任务
- 创建和记录动作
- 处理一批文件
- 自动化设置和预设
- 通过模板和变量的
-
存储和导出
- 保存文件
- Export files to different formats
- 元数据、CSS 和 Content Credentials
- 打印
-
应用程序集成
- 在 Illustrator 中打开 Photoshop 文件
- 使用可选扩展
- 安装和管理 Marketplace 插件
- 安装 ScriptingListener 插件
- 为 Texturizer 过滤器安装纹理
- 适用于 Photoshop 的 MATLAB 文档属性
- 在 InDesign 中置入 Photoshop 文件
- 扩展描述和兼容性
- 设置 MATLAB 以便与 Photoshop 协同工作
- 从 Photoshop 将图像共享到 Slack
- 将 Photoshop 作品共享到 Trello
- 排查 InDesign 中 Photoshop 文件的问题
- 保存和管理云文档
- 邀请其他用户编辑云文档中的图像
- 使云文档可离线使用
- 使用插件市场安装和管理插件
- 创建联系表
- 创建 PDF 演示文稿
- 将 Illustrator 插图作为图层粘贴
- 从 Illustrator 粘贴到 Photoshop 的限制
- 将 Adobe Illustrator 图片粘贴到 Photoshop 中
- 在 Adobe Photoshop 中置入 Illustrator 文件或 PDF
- 在 Adobe Illustrator 中使用 Photoshop 图像
- 在 InDesign 中使用 Photoshop 图层复合
- InDesign 中的 Photoshop 文件行为
- Photoshop 云文档概述
- Photoshop 插件和扩展
-
疑难解答
- 工具和资源
- 性能和稳定性问题
- 文件和格式问题
-
工具和功能问题
- 使用项目符号和编号时 Photoshop 崩溃
- 键盘快捷键无法使用
- 使用 Illustrator 时的限制
- 解决视频渲染问题
- Adobe Photoshop 中的工具行为异常
- 工具从工具栏中消失
- 解决字体问题
- 解决 Photoshop 云文档错误
- Adobe Photoshop 中的插件崩溃和错误
- 为 Adobe Photoshop 输入问题捕获诊断日志
- 使用 Adobe Photoshop 脚本时出现的错误
- 使用滤镜和效果时的问题
- Adobe Photoshop 崩溃、卡顿或冻结
- 排查 Windows 上 Photoshop 快捷批处理的问题
- Stock 资源无法完全更新
- 文本随机更改或已损坏
- Photoshop 中的插件文件夹位置
- Photoshop 在 Apple Silicon 上的限制
- 我的预设、动作或增效工具缺失
- 油画过滤器显示为灰色
- “打印”对话框中的打印设置选项不可用
- 动作缺失
修复启动 Adobe Photoshop 时出现的生成器错误
了解如何通过检查安全设置、删除冲突的插件和查看日志,修复 Adobe Photoshop 中的生成器错误。
生成器是一个 Node.js 应用程序,用于处理 Photoshop 和生成器插件之间的通信。它为导出为和图像资源提供资源创建逻辑。
当您启动 Photoshop 或选择文件 > 导出 > 导出为时,会出现一个对话框,提示“生成器出现故障。请退出 Photoshop 并重试。 如果故障持续存在,请删除所有第三方插件或尝试重新安装 Photoshop。”
请按顺序尝试以下解决方案。
安全软件阻止生成器
安全软件或防病毒软件可能会阻止生成器通过端口 8010 进行通信,或阻止节点进程运行。
将 Photoshop 添加到允许的应用程序列表中。
确保为生成器开放端口 8010。
在 Windows 上,将node.exe添加到允许的应用程序列表中,路径为C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe。
在 macOS 上,请允许位于/Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node的节点进程。
在 Windows 上,允许 Photoshop 访问受控文件夹。
重新启动 Photoshop,然后选择文件 > 导出 > 导出为以测试生成器。
第三方插件与生成器冲突
Photoshop 的 Generator 文件夹中的第三方插件可能与您当前的版本不兼容,或与默认的图像资源插件冲突。
Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator
macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator
在桌面上创建一个名为 Disabled Generator Plug-ins 的临时文件夹。
将第三方插件文件夹移动到该临时文件夹。将默认的图像资源插件保留在Generator文件夹中。
启动 Photoshop,然后选择文件 > 导出 > 导出为。
如果错误消失,请逐个重新添加插件,并在每次添加后重新启动 Photoshop,直到错误再次出现。
请将默认的 Image Assets 插件保留在 Generator 文件夹中。仅移动您单独安装的插件。
生成器无法启动,且您不需要它
如果您不使用 Export As 或 Image Assets,可关闭 Generator 作为临时解决方法。
启动 Photoshop。
在 Windows 上,选择 编辑 > 偏好设置 > 插件。在 macOS 上,选择 Photoshop > 设置 > 插件。
取消选择启用生成器。
选择 确定,然后重新启动 Photoshop。
选择 文件 > 导出 > 导出为 会重新开启 Generator。如果您需要使用 导出为,请解决 Generator 错误,而不要关闭 Generator。
Generator 日志显示启动错误
Generator 日志可能包含有关插件加载失败或阻止 Generator 启动的系统问题的信息。
在 Windows 上,导航到 C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator。
在 macOS 上,导航到 /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator。
打开最新的 Generator 日志,并查找错误消息。
如果 Generator 文件夹不存在,请确认您对父文件夹具有写入权限。
如果您需要更多帮助,请使用 Adobe Log Collector 工具来收集诊断日志。
Windows AppData 文件夹和 macOS Library 文件夹默认处于隐藏状态。在 Windows 中显示隐藏文件和文件夹的说明可以帮助您找到 Windows 日志。
Apple 芯片上出现 Generator 错误
如果在搭载 Apple 芯片的 Mac 上,Generator 仍然无法启动,可以尝试使用 Rosetta 运行 Photoshop,以确定问题是否由原生模式兼容性引起。
退出 Photoshop。
在 Finder 中,打开“应用程序”并找到 Adobe Photoshop。
按住 Control 键点击 Adobe Photoshop,然后选择 显示简介。
选中“使用 Rosetta 打开”复选框,然后启动 Photoshop 并测试 Generator。
如果错误仍然存在,请在联系 Adobe 支持团队寻求帮助时提供 Generator 日志。对于与 Generator 无关的“导出为”问题,请使用 导出和保存操作的故障排除指南。