校正广角镜头扭曲

上次更新時間 2026年10月29日

使用镜头配置文件和约束线,自动校正广角照片和全景图中的弯曲元素。

广角镜头和鱼眼镜头可捕捉广阔场景,但往往会将直线扭曲成曲线。当直线看起来弯曲时(例如建筑物向内倾斜或地平线向外弯曲),此滤镜会利用镜头元数据和您定义的约束线将其校正为直线。

此滤镜会根据嵌入的 EXIF 数据检测您的相机和镜头,并自动应用校正。对于没有元数据的图像,请手动指定焦距和裁切系数,以达到类似效果。

转化为智能对象(可选)

为实现非破坏性编辑,请在应用滤镜之前,将图层转化为智能对象。之后,您可以调整筛选条件设置,而不会降低质量。

在“图层”面板中选择图层

选择 图层 > 智能对象 > 转化为智能对象。

应用镜头扭曲校正

选择 滤镜 > 自适应广角。

在右侧选择校正类型:

  • 鱼眼:适用于鱼眼镜头产生的极端曲率
  • 透视:适用于相机倾斜导致的汇聚线
  • 全景:适用于 Photomerge 全景图
  • 完整球面:适用于纵横比为 2:1 的 360 度全景图
  • 自动:自动检测校正

调整 缩放 以调整图像大小并最小化空白区域。

如果图像缺少嵌入的镜头数据,请以毫米为单位指定 焦距。

调整 裁切因子 以控制校正后图像的裁切方式。

启用 按拍摄设置 以应用嵌入的镜头值。此选项仅在 Photoshop 检测到图像中的镜头信息时出现。

选择约束工具,然后在任意元素(例如建筑物边缘或水平线)上拖动一条线。按住 Shift 键拖动可将线条约束为垂直或水平方向。

选择多边形约束工具,沿应呈现为直线的弯曲建筑元素或复杂形状进行绘制。该筛选条件会检测曲率并自动跟随等高线。

在图像的不同区域添加约束线,以优化校正效果。右键单击任意约束线,可在垂直、水平或自动之间切换其方向。

选择确定以应用校正。

应用校正后,图像中弯曲内容被拉直的边缘处可能会出现空白或透明区域。裁切图像以移除这些区域,或使用内容识别填充来填充空区域。