移动、隐藏选区或使选区反相

可以将选框沿图像周围移动,隐藏选框,以及反相选区以选择图像中原先未选中的部分。

注意:

要移动选区本身,而不是移动选区边界,请使用移动工具。请参阅移动选区

移动选区边界

  1. 使用任何选区工具,从选项栏中选择“新选区”,然后将指针放在选区边界内。指针将发生变化 ,指明您可以移动选区。
  2. 拖动边框围住图像的不同区域。可以将选区边框局部移动到画布边界之外。当您将选区边框拖动回来时,原来的边框以原样再现。还可以将选区边框拖动到另一个图像窗口。
    Photoshop 移动选区边框
    原来的选区边框(左图),移动了的选区边框(右图)

    注意:

    您可以应用几何变换来更改选区边界的形状。(请参阅应用变换。)

控制选区的移动

  • 要将方向限制为 45 度的倍数,请开始拖动,然后在继续拖动时按住 Shift 键。
  • 要以 1 个像素的增量移动选区,请使用箭头键。
  • 要以 10 个像素的增量移动选区,请按住 Shift 键并使用箭头键。

隐藏或显示选区边缘

执行下列操作之一:

  • 选择“视图”>“显示额外内容”。此命令可以显示或隐藏选区边缘、网格、参考线、目标路径、切片、注释、图层边框、计数以及智能参考线。
  • 选取“视图”>“显示”>“选区边缘”。这将切换选区边缘的视图并且只影响当前选区。在建立另一个选区时,选区边框将重现。

选择图像中未选中的部分

  1. 选取“选择”>“反向”。

    注意:

    可以使用该选项选择放在纯色背景上的对象。使用魔棒工具选择背景,然后反相选区。

手动调整选区

可以使用选区工具在现有的像素选区中添加选区或减去选区。

在选区中手动添加或减去选区之前,可能需要先将选项栏中的羽化和消除锯齿值设置为原始选区中使用的相同设置。

添加到选区或选择附加选区

  1. 建立选区。
  2. 使用任何选区工具,执行下列任一选项:
    • 在选项栏中选择“添加到选区”选项 ,然后拖动以添加到选区。

    • 按住 Shift 键并拖动以添加到选区。

在添加到选区时,指针旁边将出现一个加号。

从选区中减去

  1. 建立选区。
  2. 使用任何选区工具,执行下列任一选项:
    • 在选项栏中选择“从选区中减去”选项 ,然后拖动以使其与其他选区交叉。

    • 按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 键并拖动以减去另一个选区。

在从选区中减去时,指针旁边将出现一个减号。

仅选择与其它选区交叉的区域

  1. 建立选区。
  2. 使用任何选择工具,执行下列操作之一:
    • 在选项栏中选择“与选区交叉”选项 ,然后拖动。

    • 按住 Alt+Shift 组合键 (Windows) 或 Option+Shift 组合键 (Mac OS),然后在要选择的原始选区的部分上拖动。

当您选择交叉区域时,指针的旁边将出现一个“x”。

Photoshop 交叉选区
交叉选区

按特定数量的像素扩展或收缩选区

  1. 使用选区工具建立选区。
  2. 选取“选择”>“修改”>“扩展”或“收缩”。
  3. 对于“扩展量”或“收缩量”,输入一个 1 到 100 之间的像素值,然后单击“确定”。

    边框按指定数量的像素扩大或缩小。(选区边界中沿画布边缘分布的任何部分不受扩展命令影响。)

在选区边界周围创建一个选区

“边界”命令可让您选择在现有选区边界的内部和外部的像素的宽度。当要选择图像区域周围的边界或像素带,而不是该区域本身时(例如清除粘贴的对象周围的光晕效果),此命令将很有用。

Photoshop 边框命令
原始选区(左图)和使用“边界”命令(值为 5 像素)之后的选区(右图)

  1. 使用选区工具建立选区。
  2. 选取“选择”>“修改”>“边界”。
  3. 为新选区边界宽度输入一个 1 到 200 之间的像素值,然后单击“确定”。

    新选区将为原始选定区域创建框架,此框架位于原始选区边界的中间。例如,若边框宽度设置为 20 像素,则会创建一个新的柔和边缘选区,该选区将在原始选区边界的内外分别扩展 10 像素。

扩展选区以包含具有相似颜色的区域

执行下列操作之一:

  • 选取“选择”>“扩大选取”以包含所有位于“魔棒”选项中指定的容差范围内的相邻像素。
  • 选取“选择”>“选取相似”以包含整个图像中位于容差范围内的像素,而不只是相邻的像素。

    若要以增量扩大选区,请多次选取上述任一命令。

注意:

无法在位图模式的图像或 32 位/通道的图像上使用“扩大选取”和“选取相似”命令。

清除基于颜色的选区中的杂散像素

  1. 选取“选择”>“修改”>“平滑”。
  2. 对于“取样半径”,输入 1 到 100 之间的像素值,然后单击“确定”。

    对于选区中的每个像素,Photoshop 将根据半径设置中指定的距离检查它周围的像素。如果已选定某个像素周围一半以上的像素,则将此像素保留在选区中,并将此像素周围的未选定像素添加到选区中。如果某个像素周围选定的像素不到一半,则从选区中移去此像素。整体效果是将减少选区中的斑迹以及平滑尖角和锯齿线。

调整选区边缘

视频教程:建立完美选区

视频教程:建立完美选区
无限技能

“调整边缘”选项可提高选区边缘的质量,从而方便抽出对象。还可以使用“调整边缘”选项来调整图层蒙版(请参阅调整蒙版不透明度或边缘)。

  • 单击选项栏中的“调整边缘”,或选取“选择”>“调整边缘”。然后设置以下选项:

视图模式

从弹出式菜单中,选择一个模式以更改选区的显示方式。有关每种模式的信息,请将指针悬停在该模式上,直至出现工具提示。“显示原稿”显示原始选区以进行比较。“显示半径”在发生边缘调整的位置显示选区边框。

边缘检测

调整半径工具 和抹除调整工具

使用这些工具可以精确调整发生边缘调整的边界区域。要从一种工具快速切换到另一种工具,可按 Shift+E 组合键。要更改画笔大小,可按括号键。

注意:

刷过柔化区域(例如头发或毛皮)以向选区中加入精妙的细节。

智能半径

自动调整边界区域中发现的硬边缘和柔化边缘的半径。如果边框一律是硬边缘或柔化边缘,或者您要控制半径设置并且更精确地调整画笔,则取消选择此选项。

半径

确定发生边缘调整的选区边界的大小。对锐边使用较小的半径,对较柔和的边缘使用较大的半径。

调整边缘

平滑

减少选区边界中的不规则区域(“山峰和低谷”)以创建较平滑的轮廓。

羽化

模糊选区与周围的像素之间的过渡效果。

对比度

增大时,沿选区边框的柔和边缘的过渡会变得不连贯。通常情况下,使用“智能半径”选项和调整工具效果会更好。

移动边缘

使用负值向内移动柔化边缘的边框,或使用正值向外移动这些边框。向内移动这些边框有助于从选区边缘移去不想要的背景颜色。

输出

净化颜色

将彩色边替换为附近完全选中的像素的颜色。颜色替换的强度与选区边缘的软化度是成比例的。

注意:

由于此选项更改了像素颜色,因此它需要输出到新图层或文档。保留原始图层,这样您就可以在需要时恢复到原始状态。(为了方便查看像素颜色中发生的变化,请选择“显示图层”视图模式。)

数量

更改净化和彩色边替换的程度。

输出到

决定调整后的选区是变为当前图层上的选区或蒙版,还是生成一个新图层或文档。

柔化选区边缘

可以通过消除锯齿和通过羽化来平滑硬边缘。

消除锯齿

通过软化边缘像素与背景像素之间的颜色过渡效果,使选区的锯齿状边缘平滑。由于只有边缘像素发生变化,因此不会丢失细节。消除锯齿在剪切、拷贝和粘贴选区以创建复合图像时非常有用。

消除锯齿适用于套索工具、多边形套索工具、磁性套索工具、椭圆选框工具和魔棒工具。(选择工具可显示该工具的选项栏。)

注意:

使用这些工具之前必须指定该选项。建立了选区后,您无法添加消除锯齿功能。

羽化

通过建立选区和选区周围像素之间的转换边界来模糊边缘。该模糊边缘将丢失选区边缘的一些细节。

可以在使用工具时为选框工具、套索工具、多边形套索工具或磁性套索工具定义羽化,也可以向现有的选区中添加羽化。

注意:

仅在移动、剪切、拷贝或填充选区后,羽化效果很明显。

使用消除锯齿功能选择像素

  1. 选择套索工具、多边形套索工具、磁性套索工具、椭圆选框工具或魔棒工具。
  2. 在选项栏中选择“消除锯齿”选项。

为选择工具定义羽化边缘

  1. 选择任一套索或选框工具。
  2. 在选项栏中输入“羽化”值。此值定义羽化边缘的宽度,范围可以是 0 到 250 像素。

为现有选区定义羽化边缘

  1. 选择“选择”>“修改”>“羽化”。
  2. 输入“羽化半径”的值,然后单击“确定”。

    注意:

    如果选区小而羽化半径大,则小选区可能变得非常模糊,以致于看不到并因此不可选。如果看到“选中的像素不超过 50%”信息,请减少羽化半径或增大选区的大小。或单击“确定”以接受采用当前设置的蒙版,并创建无法看到其边缘的选区。

    Photoshop 带羽化和不带羽化的选区
    不带羽化和带羽化的选区

    A. 不带羽化的选区,使用图案填充的同一个选区 B. 带有羽化的选区,使用图案填充的同一个选区 

从选区中移去边缘像素

当移动或粘贴消除锯齿选区时,选区边框周围的一些像素也包含在选区内。这会在粘贴选区的边缘周围产生边缘或晕圈。以下“图层”>“修边”命令使您可以编辑不想要的边缘像素:

  • 颜色净化将边像素中的背景色替换为附近完全选中的像素的颜色。

  • “去边”命令将边像素的颜色替换为距离不包含背景色的选区的边缘较远的像素的颜色。

  • 如果以黑色或白色背景为对照来消除选区的锯齿,并且您想要将该选区粘贴到不同的背景,“移去黑色杂边”和“移去白色杂边”将十分有用。例如,在白色背景上消除了锯齿的黑色文本的边缘会有灰色像素,在彩色背景上将可以看见这些像素。

注意:

您也可以通过使用“图层样式”对话框中的“高级混合”滑块移去边缘区域,从图层中移去区域或使区域变得透明。这将使黑色或白色区域透明。按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并单击滑块以将其分开;分开滑块使您可以移去边缘像素并使边缘保持平滑。

减少选区上的边缘

  1. 选取“图层”>“修边”>“去边”。
  2. 在“宽度”框中输入一个值,以指定要在其中搜索替换像素的区域。大多数情况下,1 或 2 像素就足够了。
  3. 单击“确定”。

从选区中移去杂边

  1. 选取“图层”>“修边”>“移去黑色杂边”或“图层”>“杂边”>“移去白色杂边”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略