匹配颜色

匹配不同图像中的颜色

“匹配颜色”命令可匹配多个图像之间、多个图层之间或者多个选区之间的颜色。它还允许您通过更改亮度和色彩范围以及中和色痕来调整图像中的颜色。“匹配颜色”命令仅适用于 RGB 模式。

注意:

当您使用“匹配颜色”命令时,指针将变成吸管工具。在调整图像时,使用吸管工具可以在“信息”面板中查看颜色的像素值。此面板会在您使用“匹配颜色”命令时向您提供有关颜色值变化的反馈。请参阅查看图像中的颜色值

“匹配颜色”命令将一个图像(源图像)中的颜色与另一个图像(目标图像)中的颜色相匹配。当您尝试使不同照片中的颜色保持一致,或者一个图像中的某些颜色(如肤色)必须与另一个图像中的颜色匹配时,“匹配颜色”命令非常有用。

除了匹配两个图像之间的颜色以外,“匹配颜色”命令还可以匹配同一个图像中不同图层之间的颜色。

匹配两个图像之间的颜色

  1. (可选)在源图像和目标图像中建立一个选区。

    如果您未建立选区,则“匹配颜色”命令将匹配图像之间的全部图像统计数据。

  2. 使要更改的图像处于现用状态,然后选取“图像”>“调整”>“匹配颜色”。

    如果要将“匹配颜色”命令应用于目标图像中的特定图层,请确保在选取“匹配颜色”命令时该图层处于活动状态。

  3. 在“匹配颜色”对话框中,从“图像统计”区域中的“源”菜单中,选取要将其颜色与目标图像中的颜色相匹配的源图像。当您不希望参考另一个图像来计算色彩调整时,请选取“无”。在选择了“无”时,目标图像和源图像相同。

    如有必要,请使用“图层”菜单从要匹配其颜色的源图像中选取图层。如果要匹配源图像中所有图层的颜色,则还可以从“图层”菜单中选取“合并的”。

  4. 如果您在图像中建立了选区,请执行下列一项或多项操作:
    • 如果要将调整应用于整个目标图像,请在“目标图像”区域中选择“应用调整时忽略选区”。此选项会忽略目标图像中的选区,并将调整应用于整个目标图像。

    • 如果您在源图像中建立了选区并且想要使用选区中的颜色来计算调整,请在“图像统计”区域中选择“使用源选区计算颜色”。取消选择该选项以忽略源图像中的选区,并使用整个源图像中的颜色来计算调整。

    • 如果在目标图像中建立了选区并且想要使用选区中的颜色来计算调整,请在“图像统计”区域中选择“使用目标选区计算调整”。取消选择该选项以忽略目标图像中的选区,并通过使用整个目标图像中的颜色来计算调整。

  5. 要自动移去目标图像中的色痕,请选择“中和”选项。确保选中“预览”选项,以便图像在您进行调整时得以更新。
  6. 要增加或减小目标图像的亮度,请移动“亮度”滑块。或者,在“亮度”框中输入一个值。最大值是 200,最小值是 1,默认值是 100。
  7. 要调整目标图像的色彩饱和度,请调整“颜色强度”滑块。或者,在“颜色强度”框中输入一个值。最大值为 200,最小值为 1(生成灰度图像),默认值为 100。
  8. 要控制应用于图像的调整量,请移动“渐隐”滑块。向右移动该滑块可减小调整量。
  9. 单击“确定”。

匹配同一图像中两个图层的颜色

  1. (可选)在图层中建立要匹配的选区。将一个图层中的颜色区域(例如,面部肤色)与另一个图层中的区域相匹配时,可以使用此方法。

    如果您未建立选区,则“匹配颜色”会对整个源图层的颜色进行匹配。

  2. 确保要成为目标的图层(要应用颜色调整的图层)处于现用状态,然后选取“图像”>“调整”>“匹配颜色”。
  3. 在“匹配颜色”对话框中的“图像统计”区域的“源”菜单中,确保“源”菜单中的图像与目标图像相同。
  4. 使用“图层”菜单选取要匹配其颜色的图层。如果要匹配所有图层的颜色,还可以从“图层”菜单中选取“合并的”。
  5. 如果您在图像中建立了选区,请执行下列一项或多项操作:
    • 如果要将调整应用于整个目标图层,请在“目标图像”区域中选择“应用调整时忽略选区”。此选项将忽略目标图层中的选区,并将调整应用于整个目标图层。

    • 如果您在源图像中建立了选区并且想要使用选区中的颜色来计算调整,请在“图像统计”区域中选择“使用源选区计算颜色”。取消选择该选项以忽略源图层中的选区,并使用整个源图层中的颜色来计算调整。

    • 如果您只想使用目标图层中选定区域的颜色来计算调整,请在“图像统计”区域中选择“使用目标选区计算调整”。如果要忽略选区并使用整个目标图层中的颜色来计算调整,请取消选择该选项。

  6. 要自动移去目标图层中的色痕,请选择“中和”选项。确保选中“预览”选项,以便图像在您进行调整时得以更新。

  7. 要增加或减小目标图层的亮度,请移动“亮度”滑块。或者,在“亮度”框中输入一个值。最大值是 200,最小值是 1,默认值是 100。
  8. 要调整目标图层中的颜色像素值范围,请调整“颜色强度”滑块。或者,在“颜色强度”框中输入一个值。最大值为 200,最小值为 1(生成灰度图像),默认值为 100。
  9. 要控制应用于图像的调整量,请调整“渐隐”滑块。向右移动该滑块可减小调整量。
  10. 单击“确定”。

存储和应用匹配颜色命令中的设置

  • 在“匹配颜色”对话框的“图像统计”区域中,单击“存储统计数据”按钮。命名并存储设置。
  • 在“匹配颜色”对话框的“图像统计”区域中,单击“载入统计数据”按钮。找到并载入已存储的设置文件。

替换颜色

替换图像中对象的颜色

Photoshop 提供了多种用于替换对象颜色的技术。要获得最大的灵活性和最佳的效果,可以对所选对象应用“色相/饱和度”调整。如果对灵活性要求不高,而只需提供一组方便的选项,则可以使用“替换颜色”对话框。如果注重速度而对精确度要求不高,则可以使用“颜色替换”工具。

视频教程:更改对象的颜色

视频教程:更改对象的颜色
Deke McClelland)

将色相/饱和度调整应用于所选对象

在大多数情况下,这一灵活技术最适合用来替换颜色。由于蒙版和调整图层都是非破坏性的,因此您之后可以完全任意地微调结果。独特的“着色”选项允许进行绝对(而不是相对)的颜色更改(避免从原始颜色进行着色)。

  1. 选择要更改的对象。使用“快速选择”工具  通常可以产生令人满意的效果。有关其它技术,请参阅选择颜色范围调整选区边缘

  2. 在“调整”面板中,单击“色相/饱和度”图标。

    此时,选区便成为调整图层上的蒙版。

  3. 在“属性”面板中,更改色相和饱和度设置以替换对象的颜色。如果用原始颜色对新颜色进行着色,请选择“着色”,然后重新调整设置。(请参阅调整色相和饱和度。)

    注意:

    将“明度”设置保留为 0,以保持对比度不变。要同时保持对比度和饱和度,请为调整图层选择色相混合模式。

  4. 如有必要,可以通过在蒙版上绘制白色或黑色来扩大或减少受影响的区域。(请参阅编辑图层蒙版。)

有关详细信息,请参阅调整面板概述

使用“替换颜色”对话框

“替换颜色”对话框同时包含用于选择颜色范围的工具以及用于替换该颜色的 HSL 滑块。也可以在拾色器中选取替换颜色。

“替换颜色”的“色相/饱和度”调整中缺少“着色”选项,在完全更改颜色时可能会需要使用该选项。您可能还会发现使用调整图层技术可以更加方便地更改特定对象。但是,“替换颜色”命令更适用于更改全局颜色,尤其是更改用于打印的溢色。

  1. 选取“图像”>“调整”>“替换颜色”。
  2. (可选)如果您正在图像中选择相似且连续的颜色,则选择“本地化颜色簇”可构建更加精确的蒙版。
  3. 选择一个预览选项:

    选区

    在预览框中显示蒙版。被蒙版区域是黑色,未蒙版区域是白色。部分被蒙版区域(覆盖有半透明蒙版)会根据不透明度显示不同的灰色色阶。

    图像

    在预览框中显示图像。在处理放大的图像或仅有有限屏幕空间时,该选项非常有用。

  4. 若要选择您希望替换的颜色,请使用吸管工具  单击图像或预览框,以选择蒙版曝光的区域。
  5. 若要调整选区,请执行以下任意操作:
    • 按住 Shift 键并单击或使用“添加到取样”吸管工具  来添加区域。

    • 按住 Alt 键并单击 (Windows)、按住 Option 键并单击 (Mac OS) 或使用“从取样中减去”吸管工具  来删除区域。

    • 单击“选区颜色”色板以打开“拾色器”。使用拾色器选择要替换的颜色。当您在拾色器中选择颜色时,预览框中的蒙版会更新。

  6. 拖动“颜色容差”滑块或输入“颜色容差”值可控制相关颜色在选区中的比重。
  7. 通过执行以下任一操作来指定替换的颜色:
    • 拖移“色相”、“饱和度”和“明度”滑块(或者在文本框中输入值)。

    • 双击“结果”色板并使用拾色器选择替换颜色。

    注意:

    纯灰色、黑色或白色不能替换为其它颜色。但是,可以更改它们的明度设置。(色相和饱和度设置是相对于现有颜色的,因此不会产生任何效果。)

  8. (可选)单击“存储”以存储设置,以便日后可为其它图像载入。

使用颜色替换工具

颜色替换工具可在目标颜色上绘制替换颜色。尽管该工具适用于快速编辑,但是其替换效果却并不令人满意,尤其是替换为深色和黑色时。如果使用工具选项后并没有获得令人满意的效果,请参阅调整色相和饱和度

颜色替换工具不能用于“位图”、“索引”或“多通道”颜色模式。

  1. 选择“颜色替换工具”。(如果“颜色替换工具”不可见,请按住“画笔工具”访问该工具。)
  2. 在选项栏中,选取画笔笔尖。通常,您应保持将混合模式设置为“颜色”。
  3. 对于“取样”选项,选取下列选项之一:

    连续 

    在拖动时连续对颜色取样。

    一次 

    只替换包含您第一次单击的颜色的区域中的目标颜色。

    背景色板 

    只替换包含当前背景色的区域。

  4. 从“限制”菜单中,选择以下选项之一:

    不连续

    替换出现在指针下任何位置的取样颜色。

    连续

    替换与紧挨在指针下的颜色邻近的颜色。

    查找边缘

    替换包含取样颜色的连接区域,同时更好地保留形状边缘的锐化程度。

  5. 对于“容差”,如果选择较低的百分比,则替换与所单击像素非常相似的颜色;如果选择较高的百分比,则替换范围更广的颜色。
  6. 要为所校正的区域生成平滑的边缘,请选择“消除锯齿”。
  7. 选取用于替换不需要的颜色的前景色。(请参阅在工具箱中选取颜色。)
  8. 在图像中单击要替换的颜色。
  9. 在图像中拖动可替换目标颜色。

注意:

如果替换颜色的范围太小,可在选项栏中增加“容差”设置。

有选择地混合颜色

调整可选颜色

可选颜色校正是高端扫描仪和分色程序使用的一种技术,用于在图像中的每个主要原色成分中更改印刷色的数量。您可以有选择地修改任何主要颜色中的印刷色数量 -- 而不会影响其他主要颜色。例如,可以使用可选颜色校正显著减少图像绿色图素中的青色,同时保留蓝色图素中的青色不变。

即使“可选颜色”使用 CMYK 颜色来校正图像,您也可以在 RGB 图像中使用它。

  1. 确保在“通道”面板中选择了复合通道。只有在查看复合通道时,“可选颜色”调整才可用。
  2. 执行下列操作之一:
    • 单击“调整”面板中的“可选颜色”图标

    • 选取“图层”>“新建调整图层”>“可选颜色”。在“新建图层”对话框中单击“确定”。

    注意:

    也可以选取“图像”>“调整”>“可选颜色”。但是,请记住,该方法对图像图层进行直接调整并扔掉图像信息。

  3. 执行下列操作之一:
    • 选择您想从“属性”面板的“颜色”菜单调整的颜色。您也可以选择您已经保存的预设。

    • 在“属性”面板中,从“预设”菜单中选择“可选颜色”预设。

  4. 在“属性”面板中选择一种方法:

    相对

    按照总量的百分比更改现有的青色、洋红、黄色或黑色的量。例如,如果您从 50% 洋红的像素开始添加 10%,则 5% 将添加到洋红。结果为 55% 的洋红(50% * 10% = 5%)。(该选项不能调整纯反白光,因为它不包含颜色成分。)

    绝对

    采用绝对值调整颜色。例如,如果从 50% 的洋红的像素开始,然后 10%,洋红油墨会设置为总共 60%。

    注意:

    调整是基于一种颜色与“颜色”菜单中的一个选项是如何接近的。例如,50% 的洋红介于白色和纯洋红之间,并将得到为这两种颜色定义的校正的按比例混合值。  

  5. 拖移滑块以增加或减少所选颜色中的图素。

    还可以存储对“可选颜色”调整所做的设置,供其他图像重新使用。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略