데이터 기반 그래픽

  1. Photoshop 사용 안내서
  2. Photoshop 소개
    1. 꿈을 꾸세요. 만들어 보세요.
    2. Photoshop의 새로운 기능
    3. 첫 사진 편집
    4. 문서 만들기
    5. Photoshop | 일반적인 질문
    6. Photoshop 시스템 요구 사항
    7. 사전 설정, 액션 및 설정 마이그레이션
    8. Photoshop에 대해 알아보기
  3. Photoshop 및 Adobe 서비스
    1. Photoshop 및 Adobe Stock
    2. Creative Cloud 라이브러리
    3. Photoshop의 Creative Cloud Libraries
    4. 격자 및 안내선
    5. 동작 만들기
    6. 실행 취소 및 작업 내역
    7. 기본 키보드 단축키
    8. 터치 기능 및 사용자 정의 가능 작업 영역
    9. Photoshop에서 Touch Bar 사용
    10. Photoshop의 Capture 앱 내 확장 프로그램 사용
  4. iPad용 Photoshop
    1. iPad용 Photoshop | 일반적인 질문
    2. 작업 영역 알아보기
    3. 시스템 요구 사항 | iPad용 Photoshop
    4. 클라우드 문서 작성, 열기 및 내보내기
    5. 사진 추가
    6. 레이어를 사용한 작업
    7. 브러시를 사용하여 그리기 및 페인팅
    8. 선택 및 마스크 추가
    9. 합성 이미지 재손질
    10. 조정 레이어를 사용하여 작업
    11. 커브를 사용하여 컴포지션의 톤수 조정
    12. 변환 작업 적용
    13. 합성 자르기 및 회전
    14. 캔버스 회전, 이동, 확대/축소 및 재설정
    15. 문자 레이어를 사용하여 작업
    16. Photoshop 및 Lightroom을 사용하여 작업
    17. iPad용 Photoshop에서 누락된 글꼴 받기
    18. iPad에서 Photoshop의 일본어 텍스트
    19. 앱 설정 관리
    20. 터치 바로 가기 키 및 제스처
    21. 키보드 단축키
    22. 시스템 요구 사항 1.x | iPad용 Photoshop
    23. 시스템 요구 사항 2.x | iPad용 Photoshop
    24. 이미지 크기 편집
    25. iPad에서 Photoshop으로 라이브 스트리밍
    26. 복구 브러시를 사용하여 결함 수정
    27. [캡처]에서 브러쉬를 만들어 Photoshop에서 사용
  5. 웹용 Photoshop
    1. 웹용 Photoshop | 일반적인 질문    
    2. 작업 영역 소개
    3. 시스템 요구 사항 | 웹용 Photoshop
    4. 키보드 단축키 | 웹용 Photoshop
    5. 지원되는 파일 유형 | 웹용 Photoshop
    6. 클라우드 문서를 열고 작업하기
    7. 이해 관계자와 공동 작업
    8. 클라우드 문서에 제한된 편집 적용
  6. 클라우드 문서
    1. Photoshop 클라우드 문서 | 일반적인 질문
    2. Photoshop 클라우드 문서 | 작업 과정 질문
    3. Photoshop에서 클라우드 문서 관리 및 작업
    4. Photoshop용 클라우드 스토리지 업그레이드
    5. 클라우드 문서를 만들거나 저장할 수 없음
    6. Photoshop 클라우드 문서 오류 해결
    7. 클라우드 문서 동기화 로그 수집
    8. 클라우드 문서 액세스 공유 및 편집
  7. 작업 영역
    1. 작업 영역 기본 사항
    2. 문서 만들기
    3. Photoshop에서 Touch Bar 사용
    4. Photoshop에서 Microsoft 다이얼 지원
    5. 도구 갤러리
    6. 성능 기본 설정
    7. 도구 사용
    8. 터치 제스처
    9. 터치 기능 및 사용자 정의 가능 작업 영역
    10. 기술 미리 보기
    11. 메타데이터 및 메모
    12. 생성한 내용 빠르게 공유
    13. 다른 응용 프로그램에 Photoshop 이미지 배치
    14. 환경 설정
    15. 기본 키보드 단축키
    16. 눈금자
    17. 인쇄되지 않는 표시자 표시 또는 숨기기
    18. 이미지의 열 지정
    19. 실행 취소 및 작업 내역
    20. 패널 및 메뉴
    21. 다른 응용 프로그램으로
    22. 스냅을 사용하여 요소 위치 지정
    23. 눈금자 도구를 사용하여 위치 지정
    24. 사전 설정
    25. 키보드 단축키 사용자 정의
    26. 격자 및 안내선
  8. 웹, 화면 및 앱 디자인
    1. 디자인용 Photoshop
    2. 대지
    3. Photoshop의 파일 내보내기
    4. 장치 미리 보기
    5. 레이어에서 CSS 복사
    6. 웹 페이지 분할
    7. 분할 영역에 대한 HTML 옵션
    8. 분할 영역 레이아웃 수정
    9. 웹 그래픽 작업
    10. 웹 포토 갤러리 만들기
  9. 이미지 및 색상 기본 사항
    1. 이미지 크기 조정 방법
    2. 래스터 및 벡터 이미지 작업
    3. 이미지 크기 및 해상도
    4. 카메라 및 스캐너에서 이미지 얻기
    5. 이미지 만들기, 열기 및 가져오기
    6. 이미지 보기
    7. 잘못된 JPEG 표시자 오류 | 이미지 열기
    8. 여러 이미지 보기
    9. 색상 피커 및 색상 견본 사용자 정의
    10. HDR(High Dynamic Range) 이미지
    11. 이미지의 색상 일치
    12. 색상 모드 간 변환
    13. 색상 모드
    14. 이미지의 일부 지우기
    15. 혼합 모드
    16. 색상 선택
    17. 인덱스 색상표 사용자 정의
    18. 이미지 정보
    19. 왜곡 필터를 사용할 수 없음
    20. 색상 정보
    21. 채널을 사용하여 색상 및 단색 조정
    22. 색상 및 색상 견본 패널에서 색상 선택
    23. 견본
    24. 색상 모드 또는 이미지 모드
    25. 색상 경향성
    26. 액션에 조건부 모드 변경 추가
    27. HTML CSS 및 SVG에서 색상 견본 추가
    28. 비트 심도 및 환경 설정
  10. 레이어
    1. 레이어 기본 정보
    2. 원본 이미지의 데이터 손실이 없는 비파괴 편집
    3. 레이어 및 그룹 생성 및 관리
    4. 레이어 선택, 그룹화 및 연결
    5. 프레임에 이미지 가져오기
    6. 레이어 불투명도 및 혼합
    7. 마스크 레이어
    8. 스마트 필터 적용
    9. 레이어 구성 요소
    10. 레이어 이동, 스택 및 잠금
    11. 벡터 마스크를 사용하여 레이어 마스크
    12. 레이어 및 그룹 관리
    13. 레이어 효과 및 스타일
    14. 레이어 마스크 편집
    15. 자산 추출
    16. 클리핑 마스크로 레이어 표시
    17. 레이어에서 이미지 자산 생성
    18. 고급 개체 사용
    19. 혼합 모드
    20. 여러 이미지를 결합하여 단체 사진 만들기
    21. 레이어 자동 혼합을 사용하여 이미지 결합
    22. 레이어 정렬 및 배분
    23. 레이어에서 CSS 복사
    24. 레이어 또는 레이어 마스크 경계에서 선택 영역 불러오기
    25. 녹아웃으로 다른 레이어의 내용 나타내기
    26. 레이어
    27. 병합
    28. 합성
    29. 배경
  11. 선택 영역
    1. 선택 및 마스크 작업 영역
    2. 빠른 선택 영역 만들기
    3. 선택 영역으로 시작
    4. 선택 윤곽 도구를 사용하여 선택
    5. 올가미 도구로 선택
    6. 이미지의 색상 범위 선택
    7. 픽셀 선택 조정
    8. 패스와 선택 영역 테두리 간 변환
    9. 채널 기본
    10. 선택한 픽셀 이동, 복사 및 삭제
    11. 임시 빠른 마스크 만들기
    12. 선택 영역 및 알파 채널 마스크 저장
    13. 초점이 되는 이미지 영역 선택
    14. 채널 복제, 분할 및 병합
    15. 채널 연산
    16. 선택 영역
    17. 테두리 상자
  12. 이미지 조정
    1. 원근 뒤틀기
    2. 카메라 흔들림 흐림 효과 감소
    3. 복구 브러시 예
    4. 색상 검색 테이블 내보내기
    5. 이미지 선명도 및 흐림 효과 조정
    6. 색상 조정 이해
    7. 명도/대비 조정 적용
    8. 어두운 영역과 밝은 영역의 세부 묘사 조정
    9. 수준 조정
    10. 색조 및 채도 조정
    11. 활기 조정
    12. 이미지 영역의 색상 채도 조정
    13. 빠른 톤 조정
    14. 이미지에 특수 색상 효과 적용
    15. 색상 균형 조정을 사용하여 이미지 향상
    16. HDR(High Dynamic Range) 이미지
    17. 막대 그래프와 픽셀 값 보기
    18. 이미지의 색상 일치
    19. 사진을 자른 후 똑바르게 하는 방법
    20. 컬러 이미지를 흑백으로 변환
    21. 조정 및 칠 레이어
    22. 곡선 조정
    23. 혼합 모드
    24. 인쇄업체로 보내기 위한 대상 이미지
    25. 수준 및 곡선 스포이드로 색상 및 색조 조정
    26. HDR 노출 및 토닝 조정
    27. 필터
    28. 흐림 효과
    29. 이미지 영역 닷지 또는 번
    30. 선택 색상 조정
    31. 개체 색상 대체
  13. Adobe Camera Raw
    1. Camera Raw 시스템 요구 사항
    2. Camera Raw의 새로운 기능
    3. Camera Raw 소개
    4. 파노라마 만들기
    5. 지원되는 렌즈
    6. Camera Raw의 비네팅, 그레인 및 안개 현상 제거 효과
    7. 기본 키보드 단축키
    8. Camera Raw의 자동 원근 교정
    9. Camera Raw에서 비파괴 편집을 수행하는 방법
    10. Camera Raw 방사형 필터
    11. Camera Raw 설정 관리
    12. Camera Raw에서 이미지 열기, 처리 및 저장
    13. Camera Raw의 향상된 별색 제거 도구를 사용하여 이미지 복구
    14. 회전, 자르기 및 이미지 조정
    15. Camera Raw에서 색상 렌더링 조정
    16. 기능 요약 | Adobe Camera Raw | 2018 릴리스
    17. 새로운 기능 요약
    18. Camera Raw의 프로세스 버전
    19. Camera Raw에서 로컬 조정 수행
  14. 이미지 복구 및 복원
    1. [내용 인식 채우기]로 사진에서 개체 제거하기
    2. 내용 인식 패치 및 이동
    3. 사진 손질 및 복구
    4. 이미지 왜곡 및 노이즈 교정
    5. 대부분의 문제를 수정할 수 있는 기본 문제 해결 단계
  15. 이미지 변형
    1. 개체 변형
    2. 자르기, 회전 및 캔버스 크기 조정
    3. 사진을 자른 후 똑바르게 하는 방법
    4. 파노라마 이미지 만들기 및 편집
    5. 이미지, 모양 및 패스의 뒤틀기
    6. 소실점
    7. 픽셀 유동화 필터 사용
    8. 내용 인식 비율
    9. 이미지, 모양 및 패스 변환
    10. 변형
    11. 변형
    12. 파노라마
  16. 그리기 및 페인팅
    1. 대칭 패턴 페인트
    2. 사각형 그리기 및 획 옵션 수정
    3. 그리기 정보
    4. 모양 그리기 및 편집
    5. 페인팅 도구
    6. 브러시 만들기 및 수정
    7. 혼합 모드
    8. 패스에 색상 추가
    9. 패스 편집
    10. 혼합 브러시를 사용하여 페인트
    11. 브러시 사전 설정
    12. 그레이디언트
    13. 선택 영역, 레이어 및 패스 채우기 및 획 그리기
    14. 펜 도구를 사용하여 그리기
    15. 패턴 만들기
    16. 패턴 작성기를 사용하여 패턴 생성
    17. 패스 관리
    18. 패턴 라이브러리 및 사전 설정 관리
    19. 그래픽 태블릿으로 그리기 또는 페인트
    20. 텍스처 브러시 만들기
    21. 브러시에 움직임 요소 추가
    22. 그레이디언트
    23. 미술 작업 내역 브러시로 스타일화된 획 페인팅
    24. 패턴을 사용하여 페인트
    25. 여러 장치에서 사전 설정 동기화
  17. 텍스트
    1. OpenType SVG 글꼴을 사용한 작업
    2. 문자 서식 지정
    3. 단락 서식 지정
    4. 문자 효과를 만드는 방법
    5. 텍스트 편집
    6. 행과 문자 간격
    7. 아랍어 및 히브리어 문자
    8. 글꼴
    9. 글꼴 문제 해결
    10. 아시아 언어 문자
    11. 문자 만들기
    12. Photoshop에서 입력 도구를 사용하는 경우 발생하는 텍스트 엔진 오류 | Windows 8
    13. 아시아 스크립트용 세계 통용 작성기
    14. Photoshop에서 텍스트를 추가하고 수정하는 방법
  18. 비디오 및 애니메이션
    1. Photoshop에서 비디오 편집
    2. 비디오 및 애니메이션 레이어 편집
    3. 비디오 및 애니메이션 개요
    4. 비디오 및 애니메이션 미리 보기
    5. 비디오 레이어의 프레임 페인트
    6. 비디오 파일 및 이미지 시퀀스 가져오기
    7. 프레임 애니메이션 만들기
    8. Creative Cloud 3D 애니메이션(미리 보기)
    9. 타임라인 애니메이션 만들기
    10. 비디오용 이미지 만들기
  19. 필터 및 효과
    1. 픽셀 유동화 필터 사용
    2. 흐림 효과 갤러리 사용
    3. 필터 기본 정보
    4. 필터 효과 참고 자료
    5. 조명 효과 추가
    6. 응용 광각 필터 사용
    7. 유화 필터 사용
    8. 레이어 효과 및 스타일
    9. 특정 필터 적용
    10. 이미지 영역에 문지르기 효과 만들기
  20. 저장 및 내보내기
    1. 그래픽 형식으로 파일 저장
    2. Photoshop에서 파일 저장
    3. 파일 형식
    4. 비디오 및 애니메이션 저장 및 내보내기
    5. PDF 파일 저장
    6. Digimarc 저작권 보호
  21. 인쇄
    1. 3D 개체 인쇄
    2. Photoshop에서 인쇄
    3. 색상 관리를 이용한 인쇄
    4. 밀착 인화 및 PDF 프레젠테이션
    5. 사진 패키지 레이아웃으로 사진 인쇄
    6. 별색 인쇄
    7. 이중톤
    8. 상업용 인쇄기로 이미지 인쇄
    9. Photoshop에서 색상 인쇄 개선
    10. 인쇄 문제 해결 | Photoshop
  22. 자동화
    1. 동작 만들기
    2. 데이터 기반 그래픽
    3. 스크립팅
    4. 파일 일괄 처리
    5. 액션 실행 및 관리
    6. 조건부 액션 추가
    7. 액션 및 액션 패널 정보
    8. 액션 중인 도구 기록
    9. 액션에 조건부 모드 변경 추가
    10. 플러그인 및 스크립트용 Photoshop UI 도구 키트
  23. 3D 및 전문 이미징
    1. Creative Cloud 3D 애니메이션(미리 보기)
    2. 3D 개체 인쇄
    3. 3D 페인팅
    4. 3D 패널 향상 | Photoshop
    5. 기본 3D 개념 및 도구
    6. 3D 렌더링 및 저장
    7. 3D 개체 및 애니메이션 만들기
    8. 이미지 스택
    9. 3D 작업 과정
    10. 측정
    11. DICOM 파일
    12. Photoshop 및 MATLAB
    13. 이미지에 있는 개체 카운트
    14. 3D 개체 결합 및 변환
    15. 3D 텍스처 편집
    16. HDR 노출 및 토닝 조정
    17. 3D 패널 설정
  24. 색상 관리
    1. 색상 관리의 이해
    2. 일관된 색상 유지
    3. 색상 설정
    4. 색상 프로파일 작업
    5. 온라인으로 보기 위한 문서 색상 관리
    6. 인쇄할 때 문서 색상 관리
    7. 가져온 이미지 색상 관리
    8. 색상 교정

데이터 연동 그래픽을 만들면 인쇄용이나 웹 프로젝트용으로 이미지의 여러 버전을 빠르고 정확하게 제작할 수 있습니다. 예를 들어, 기본 템플릿에 다양한 텍스트와 이미지를 적용하여 100가지 버전의 웹 배너를 제작할 수 있습니다.

다음의 일반적인 단계를 따라 템플릿과 데이터 세트에서 그래픽을 만듭니다.

템플릿으로 사용할 기본 그래픽을 만듭니다.

그래픽에서 변경할 요소를 레이어를 사용하여 분리합니다.

그래픽에 변수를 정의합니다.

변수는 이미지에서 변경되는 부분을 지정합니다. 자세한 내용은 변수 정의를 참조하십시오.

데이터 세트를 만들거나 불러옵니다.

템플릿에서 데이터 세트를 만들거나 텍스트 파일에서 불러올 수 있습니다. 자세한 내용은 데이터 세트 정의외부 파일에 데이터 세트 만들기를 참조하십시오.

문서를 각 데이터 세트를 적용하여 미리 봅니다.

모든 파일을 내보내기 전에 미리 보기를 통해 최종 그래픽 버전이 어떤 모양인지 확인할 수 있습니다. 자세한 내용은 데이터 세트 미리 보기 또는 적용을 참조하십시오.

그래픽을 데이터와 함께 내보내서 그래픽을 생성합니다.

그래픽을 Photoshop(PSD) 파일로 내보낼 수 있습니다. 자세한 내용은 데이터 세트를 사용하여 그래픽 생성을 참조하십시오.

Photoshop에서 변수를 사용하는 이미지의 여러 버전
변수를 사용하여 이미지의 여러 버전 만들기

A. 소스 파일 템플릿 B. 사용자가 레이어를 변수로 정의 C. 각각 다른 변수 데이터 세트를 사용하여 이미지의 여러 버전 생성 

변수 정의

변수를 사용하여 템플릿에서 변경될 요소를 정의합니다. 세 가지 유형의 변수를 정의할 수 있습니다. [가시성] 변수는 레이어의 내용을 표시하거나 숨깁니다. [픽셀 대체] 변수는 레이어의 픽셀을 다른 이미지 파일의 픽셀로 대체합니다. [텍스트 대체] 변수는 문자 레이어의 텍스트 문자열을 대체합니다.

참고:

GoLive는 모든 텍스트 및 가시성 변수를 인식하지만 픽셀 대체 변수는 인식하지 못합니다.

Photoshop 변수 정의
같은 템플릿을 사용한 이미지의 두 버전

A. 가시성 변수 B. 픽셀 대체 변수 C. 텍스트 대체 변수 

배경 레이어에는 변수를 정의할 수 없습니다.

  1. [이미지] > [변수] > [정의]를 선택합니다.
  2. [레이어] 팝업 메뉴에서 변수로 정의할 내용이 포함되어 있는 레이어를 선택합니다.

  3. 변수 유형을 하나 이상 선택합니다.

    가시성

    레이어 또는 레이어 그룹의 내용을 표시하거나 숨깁니다.

    픽셀 대체

    레이어의 픽셀을 다른 이미지 파일의 픽셀로 대체합니다.

    텍스트 대체

    문자 레이어의 텍스트 문자열을 대체합니다.

  4. 다음 중 하나를 수행합니다.
    • [이름]을 선택하고 변수의 이름을 입력합니다. 변수 이름은 문자, 밑줄 또는 콜론으로 시작해야 하며 공백이나 특수 문자(마침표, 하이픈, 밑줄 및 콜론 제외)가 포함될 수 없습니다.

    • [이름] 팝업 메뉴에서 기존 변수를 선택하여 이 레이어를 연결합니다. 같은 변수에 연결된 레이어가 [이름] 메뉴 옆에 연결 아이콘과 함께 표시됩니다.

  5. [픽셀 대체] 변수에서는 다음 옵션을 설정합니다.
    • 대체 이미지의 비율을 조정할 방법을 선택합니다. [맞춤] 옵션은 대체 이미지의 비율을 조정하여 테두리 상자 내에 맞춥니다. 따라서 테두리 상자 내부의 일부가 비어 있을 수 있습니다. [칠] 옵션은 대체 이미지의 비율을 조정하여 테두리 상자를 완전히 채웁니다. 따라서 이미지가 테두리 상자를 벗어나는 경우도 생깁니다. [그대로] 옵션은 대체 이미지의 비율을 조정하지 않습니다. [일치] 옵션은 너비와 높이의 비례를 무시하고 대체 이미지의 비율을 조정하여 테두리 상자에 꼭 맞춥니다.

    • 정렬 아이콘 의 핸들을 클릭하여 테두리 상자 안에 이미지를 배치할 정렬 옵션을 선택합니다. [일치] 옵션에는 사용할 수 없습니다.

    • [테두리 상자에 클립]을 선택하면 테두리 상자를 벗어나는 이미지 영역이 잘립니다. [칠] 또는 [그대로] 대체 방법을 선택한 경우에만 이 옵션을 사용할 수 있습니다. [일치] 옵션에는 사용할 수 없습니다.

  6. 다른 레이어의 변수를 정의하려면 [레이어] 팝업 메뉴에서 레이어를 선택합니다. 변수가 포함된 레이어의 이름 옆에는 별표가 나타납니다. 내비게이션 화살표를 사용하여 레이어 간에 이동할 수 있습니다.
  7. [확인]을 클릭합니다.

변수 이름 바꾸기

  1. [이미지] > [변수] > [정의]를 선택합니다.
  2. [레이어] 팝업 메뉴에서 변수가 포함된 레이어를 선택합니다.
  3. 변수의 이름을 바꾸려면 [이름] 텍스트 상자에 이름을 입력합니다. 변수 이름은 문자, 밑줄 또는 콜론으로 시작해야 하며 공백이나 특수 문자(마침표, 하이픈, 밑줄 및 콜론 제외)가 포함될 수 없습니다.
  4. 변수를 제거하려면 해당 변수의 선택을 해제합니다.

데이터 세트 정의

데이터 세트는 변수 및 연결된 데이터의 모음입니다. 생성할 각 그래픽 버전에 대해 데이터 세트를 정의합니다.

  1. 다음 중 하나를 수행합니다.
    • [이미지] > [변수] > [데이터 세트]를 선택합니다.

    • [변수] 대화 상자가 열리면 대화 상자 맨 위의 팝업 메뉴에서 [데이터 세트]를 선택하거나 [다음]을 클릭합니다.

    참고:

    기본 데이터 세트를 편집하려면 먼저 변수를 하나 이상 정의해야 합니다.

  2. [새 데이터 세트] 단추 를 클릭합니다.
  3. [이름] 팝업 메뉴나 대화 상자 아래쪽에 있는 목록에서 변수를 선택합니다.
  4. 변수 데이터를 편집합니다.
    • [가시성] 변수 의 경우 레이어의 내용을 표시하려면 [보임]을 선택하고 레이어의 내용을 숨기려면 [보이지 않음]을 선택합니다.

    • [픽셀 대체] 변수 의 경우 [파일 선택]을 클릭하고 대체 이미지 파일을 선택합니다. 레이어를 현재 상태로 두려면 데이터 세트가 적용되기 전에 [대체 안함]을 클릭합니다.

    참고:

    다른 대체가 이미 적용되었으면 [대체 안함]을 선택해도 파일이 원래 상태로 다시 설정되지 않습니다.

    • [텍스트 대체] 변수 의 경우 [값] 텍스트 상자에 텍스트 문자열을 입력합니다.
  5. 생성할 각 그래픽 버전에 대해 추가 데이터 세트를 정의합니다.

먼저 [데이터 세트] 팝업 메뉴에서 데이터 세트를 선택하고 옵션을 편집하여 나중에 데이터 세트를 편집하거나 이름을 바꾸거나 삭제할 수 있습니다. 화살표 아이콘을 사용하여 데이터 세트 간에 이동합니다. [삭제] 아이콘을 클릭하여 데이터 세트를 삭제합니다.

데이터 세트 미리 보기 또는 적용

모든 변수와 데이터 세트를 그대로 유지하면서 기본 이미지에 데이터 세트의 내용을 적용해 볼 수 있습니다. 이렇게 하면 PSD 문서에 해당 데이터 세트의 값이 포함되어 모양이 변경됩니다. 각 데이터 세트를 적용한 각 그래픽 버전이 어떤 모양일지 미리 볼 수도 있습니다.

참고:

데이터 세트를 적용하면 원본 문서를 덮어씁니다.

  1. [이미지] > [데이터 세트 적용]을 선택합니다. 목록에서 데이터 세트를 선택하여 해당 이미지를 문서 창에서 미리 봅니다. 데이터 세트를 적용하려면 [적용]을 클릭합니다. 미리 보는 동안 기본 이미지를 변경하지 않으려면 [취소]를 클릭합니다.

    [변수] 대화 상자의 [데이터 세트] 페이지에서 데이터 세트를 적용하고 미리 볼 수도 있습니다.

데이터 세트를 사용하여 그래픽 생성

변수와 하나 이상의 데이터 세트를 정의한 후 데이터 세트 값을 사용하여 일괄 처리 모드에서 이미지를 출력할 수 있습니다. 이미지를 PSD 파일로 출력할 수 있습니다.

  1. [파일] > [내보내기] > [데이터 세트를 파일로 저장]을 선택합니다.
  2. 생성된 모든 파일에 사용할 기본 이름을 입력합니다. 필요한 경우 고유한 파일 이름 지정 규칙을 만들 수도 있습니다.
  3. 폴더 선택 단추를 클릭하여 파일을 저장할 대상 디렉토리를 선택합니다.
  4. 내보낼 데이터 세트를 선택합니다.
  5. [확인]을 클릭합니다.

외부 파일에 데이터 세트 만들기

모든 변수 정보가 포함된 외부 텍스트 파일을 만든 후 변수가 포함된 PSD 문서로 이 파일을 불러오면 여러 개의 데이터 세트를 빠르게 만들 수 있습니다. 이 작업을 수행하는 방법 중 하나는 텍스트 파일이나 Microsoft Excel 스프레드시트에 데이터를 입력한 후 이 파일을 탭이나 쉼표로 구분된 파일에 보내는 것입니다.

외부 텍스트 파일의 구문은 다음과 같습니다. "Variable" 또는 "Value"로 시작하는 각 행은 파일에서 하나의 전체 행이 됩니다.

VariableName1<sep>VariableName2<sep> <sep>VariableNameN <nl> 
Value1-1<sep>Value2-1<sep><sep>ValueN-1<nl> 
Value1-2<sep>Value2-2<sep><sep>ValueN-2<nl> 
Value1-M<sep>Value2-M<sep><sep>ValueN-M<nl>

첫 번째 행에는 모든 변수 이름이 후속 행에서 값이 지정된 순서로 포함되어 있습니다. 이어지는 각 행은 하나의 데이터 세트를 나타내며 지정된 각 변수의 값을 포함하고 있습니다.

참고:

데이터 세트의 단일 행 텍스트에 여러 행 텍스트를 만들려면 텍스트를 큰따옴표로 묶고 줄바꿈할 탭이나 쉼표로 구분된 파일에 하드 리턴을 삽입합니다.  

외부 텍스트 파일 구문 요소

<sep>

쉼표로 구분된 파일(CSV)이나 탭(탭으로 구분된) 파일이며 각 변수 이름이나 값을 구분합니다.

<nl>

각 데이터 세트를 끝내는 줄 바꿈 문자이며 줄 바꿈, 캐리지 리턴 또는 두 가지 모두일 수 있습니다.

“true”와 “false”

가시성 변수에 대해 허용되는 값입니다.

공백

구분 기호 주위의 공백은 파일 구문을 분석할 때 제거됩니다. 그러나 값 문자열의 단어 사이에 있는 공백(예: two of a kind)은 유지되고, 큰따옴표로 묶인(예: “one kind ”) 선행 및 후행 공백은 유지됩니다.

큰따옴표

큰따옴표를 하나 더 사용하면 값으로 인식됩니다. 예를 들어, ““B””는 데이터 세트에서 “B”가 됩니다.

<sep> 또는 <nl>이 변수 값의 일부이면 전체 값을 큰따옴표로 묶어야 합니다.

PSD 문서에 정의한 모든 변수는 텍스트 파일에 정의되어야 합니다. 텍스트 파일에 있는 변수의 수가 PSD 문서에 있는 수와 일치하지 않으면 오류가 발생합니다.

데이터 세트 예:

튤립(tulip)과 해바라기(sunflower) 변수를 포함한 꽃(flowers) 템플릿을 사용하여 다음과 같이 나타나는 텍스트 파일을 설정할 수 있습니다.

{contents of FlowerShow.txt} 
Variable 1, Variable 2, Variable 3 
true, TULIP, c:\My Documents\tulip.jpg 
false, SUNFLOWER, c:\My Documents\sunflower.jpg 
false, CALLA LILY, c:\My Documents\calla.jpg 
true, VIOLET, c:\My Documents\violet.jpg
참고:

텍스트 파일과 이미지 파일이 같은 폴더에 있으면 이미지 위치를 상대 경로로 지정할 수 있습니다. 예를 들어, 예제의 마지막 항목은 true, VIOLET, violet.jpg로 나타낼 수 있습니다.

데이터 세트 가져오기

  1. 다음 중 하나를 수행합니다.
    • [파일] > [불러오기] > [변수 데이터 세트]를 선택합니다.

    • [이미지] > [변수] > [데이터 세트]를 선택하고 [불러오기] 단추를 클릭합니다.

  2. 불러올 텍스트 파일을 찾습니다.
  3. 불러오기 옵션을 설정합니다.

    첫 번째 열을 데이터 세트 이름으로 사용

    텍스트 파일에 있는 첫 번째 열의 내용(목록에서 첫 번째 변수의 값)을 사용하여 각 데이터 세트에 이름을 지정합니다. 그렇지 않은 경우 데이터 세트는 “데이터 세트 1, 데이터 세트 2” 등으로 이름이 지정됩니다.

    기존 데이터 세트 바꾸기

    데이터 세트를 불러오기 전에 기존 데이터 세트를 삭제합니다.

  4. 텍스트 파일의 인코딩을 설정하거나 [자동] 설정으로 둡니다.
  5. [확인]을 클릭합니다.
Adobe 로고

내 계정 로그인