Przygotowywanie obrazów z programu Photoshop do programu After Effects

Ostatnia aktualizacja 2 lis 2026

Zoptymalizuj strukturę warstw, nazewnictwo i ustawienia kolorów, aby przygotować obrazy z programu Photoshop do programu After Effects.

Dowiedz się, jak skonfigurować strukturę warstw, nazewnictwo i ustawienia kolorów w programie Photoshop, aby zapewnić bezproblemowy import do programu After Effects.

Program After Effects zachowuje poszczególne warstwy, style warstw, obszary przezroczyste, maski warstw i warstwy dopasowania z plików programu Photoshop. Program After Effects natywnie działa w trybie kolorów RGB. Może automatycznie konwertować pliki CMYK, ale dostosowanie kolorów w programie Photoshop przed importem skraca czas przetwarzania. Przed przygotowaniem obrazów do programu After Effects sprawdź, czy spełnione są następujące wymagania wstępne.

  • Posiadaj najnowszą wersję programu Adobe Photoshop
  • Najnowsza wersja programu After Effects
  • Znajomość warstw i formatów plików w programie Photoshop

Zorganizowanie warstw do animacji

Nadaj każdej warstwie unikalną nazwę na podstawie jej zawartości lub przeznaczenia, np. „Drzewo na pierwszym planie” lub „Niebo w tle”. Unikalne nazwy warstw zapobiegają błędnej identyfikacji warstw przez program After Effects podczas importu.

Pogrupuj powiązane warstwy w obiekty inteligentne, jeśli mają być animowane jako jedna jednostka, np. grupując wszystkie elementy pierwszego planu w jeden obiekt inteligentny, a elementy tła — w inny.

Uporządkuj warstwy w panelu Warstwy w kolejności, w jakiej powinny być wyświetlane w kompozycji programu After Effects.

Spostrzeżenie

Obiekty inteligentne umożliwiają animowanie złożonych grup warstw jako jednostek w programie After Effects, co pozwala uzyskać efekty głębi lub skoordynowany ruch.

Konfiguracja ustawień zgodności plików

Wybierz opcjeEdycja > Preferencje > Obsługa plików (Windows) lub InDesign > Preferencje > Obsługa plików (macOS).

W sekcji Zgodność plików wybierz opcję Zawsze z listy rozwijanej Maksymalizuj zgodność plików PSD i PSB.

Wybierz przycisk OK, aby zapisać zmianę ustawienia. Ustawienie Maksymalizuj zgodność plików PSD i PSB zapewnia, że program After Effects może prawidłowo odczytywać pliki z warstwami. Bez tego ustawienia program After Effects może nie rozpoznać wszystkich informacji o warstwach.

Podczas tworzenia nowego dokumentu do pracy z materiałem wideo wybierz Plik > Nowy, a następnie wybierz kategorię ustawień wstępnych dokumentu Film i wideo.

Wybierz ustawienie wstępne odpowiednie dla docelowego systemu wideo, np. HDTV 1080p lub Film(4K), aby zapewnić prawidłowe wymiary w pikselach.

Zastosuj edycje i profile kolorów

Sprawdź, czy dokument znajduje się w trybie RGB, przechodząc do menu Obraz > Tryb i wybierając w razie potrzeby opcję Kolor RGB.

Przed importem wykonaj w programie Photoshop wszystkie korekty kolorów, przeskalowanie i kadrowanie.

Wybierz Edycja > Przypisz profil, aby otworzyć okno dialogowe profilu kolorów.

Wybierz odpowiedni profil kolorów wideo do formatu wyjściowego:

  • Rec. ITU-R BT.601: Do standardowej rozdzielczości wideo NTSC lub PAL
  • Rec. ITU-R BT.709: Do wideo w wysokiej rozdzielczości

Wybierz przycisk OK, aby osadzić profil, co pozwoli programowi After Effects prawidłowo interpretować kolory.

Zapisz plik w formacie PSD.

Uwaga

Jeśli zmienisz nazwy warstw lub usuniesz warstwy w programie Photoshop po zaimportowaniu ich do programu After Effects, After Effects wyświetli te warstwy jako brakujące w panelu Projekt. Sfinalizuj strukturę warstw przed pierwszym importem, aby uniknąć zakłóceń w obiegu pracy.