Łączenie kilku obrazów w grupę zorientowaną pionowo

Ostatnia aktualizacja 2 lis 2026

Użyj funkcji Auto-Align Layers i maskowania warstw, aby połączyć dwa podobne zdjęcia w dopracowaną kompozycję.

Ten obieg pracy pozwala połączyć najlepsze elementy z dwóch niemal identycznych obrazów w jeden dopracowany portret. To idealne rozwiązanie, gdy jest dostępnych kilka ujęć tej samej sceny wykonanych w krótkich odstępach czasu, na których osoby i tło pozostają niemal w tych samych pozycjach, ale każde zdjęcie zawiera drobne niedoskonałości — ktoś mruga, odwraca wzrok lub ma zamknięte oczy. Funkcja Auto-Align Layers automatycznie dopasowuje wspólne obszary między obrazami, a maskowanie warstw pozwala selektywnie ujawniać najlepszą zawartość z każdego zdjęcia.W przypadku scenariuszy łączenia obejmujących różne ustawienia ekspozycji lub punkty ostrości zapoznaj się z omówieniem polecenia Auto-Blend Layers.

Przed rozpoczęciem upewnij się, że oba obrazy źródłowe mają identyczne wymiary i rozdzielczość. Jeśli się różnią, przytnij je lub zmień ich rozmiar tak, aby były zgodne.

Skonfiguruj dokument kompozycji

Otwórz oba obrazy źródłowe w programie Photoshop.

Wybierz kolejno Plik > Nowy i utwórz nowy dokument o takich samych wymiarach i rozdzielczości jak obrazy źródłowe.

W panelu Warstwy każdego obrazu źródłowego wybierz warstwę obrazu i przeciągnij ją do okna nowego dokumentu.

W panelu Warstwy nowego dokumentu umieść warstwę z niedoskonałością, którą chcesz skorygować (na przykład zamknięte oczy), nad warstwą z prawidłową zawartością.

Wyrównaj warstwy i dodaj maskę

Wskazówka

Opcja Tylko przemieszczenie zapobiega niepożądanym zniekształceniom, a jednocześnie zapewnia idealne nakładanie się identycznych obszarów.

Maluj na masce, aby połączyć obrazy

Upewnij się, że w panelu Warstwy jest zaznaczona miniatura maski warstwy — gdy jest aktywna, jest otoczona białą ramką.

Naciśnij klawisze D, aby zresetować kolory pierwszego planu i tła do czerni i bieli.

Wybierz narzędzie Pędzel (B) i dobierz odpowiedni Rozmiar pędzla do obszaru, który chcesz skorygować.

Powiększ obszar z niedoskonałością, naciskając klawisze Ctrl++ (Windows) lub Command++ (macOS).

Zamaluj obszar z niedoskonałością na czarno, aby odsłonić prawidłową zawartość z warstwy poniżej.

Jeśli zamaskujesz zbyt dużo, naciśnij klawisz X, aby zamienić kolory pierwszego planu i tła, a następnie maluj bielą, aby przywrócić górną warstwę.

Kontynuuj dopracowywanie maski, aż uzyskasz płynne połączenie obu obrazów.

Spostrzeżenie

Malowanie czernią na masce warstwy całkowicie ukrywa górną warstwę, a wartości szarości tworzą częściową przezroczystość. Biały przywraca pełną widoczność.

Po zakończeniu pracy z kompozycją zapisz wersję z warstwami (Plik > Zapisz jako > Format Photoshop), aby zachować możliwość edycji.Następnie utwórz spłaszczoną kopię (Warstwa > Spłaszcz obraz) i zapisz ją w wybranym formacie do udostępniania lub drukowania.

Więcej informacji o technikach maskowania warstw podano w temacie Edytowanie masek warstw.Aby poznać automatyczne mieszanie różnych wartości ekspozycji lub punktów ostrości, zobacz temat Tworzenie kompozycji z rozszerzoną głębią ostrości.