Tworzenie i zarządzanie kompozycjami warstw

Ostatnia aktualizacja 2 lis 2026

Rejestruj wiele wariantów projektu w jednym pliku za pomocą migawek Widoczność, położenia i wyglądu warstw.

Kompozycje warstw pozwalają prezentować klientom wiele wariantów projektu bez tworzenia osobnych plików dla każdej wersji.

Kompozycja warstw to migawka panelu Warstwy w określonym momencie. Używaj funkcji Kompozycje warstw, gdy trzeba pokazać różne opcje układu, schematy kolorów lub rozmieszczenie zawartości w jednym dokumencie. Każda kompozycja może zapisywać Widoczność warstw (pokazywanie lub ukrywanie warstw), położenie warstw, wygląd warstw (style i tryby mieszania) oraz wybory kompozycji warstw dla warstw Smart Object . Kompozycje warstw najlepiej sprawdzają się podczas analizowania alternatywnych wersji projektu przed sfinalizowaniem kompozycji.

Utwórz nową kompozycję warstw

Wybierz kolejno Okno > Kompozycje warstw, aby otworzyć panel Kompozycje warstw.

Ułóż warstwy tak, aby odzwierciedlały stan projektu, który chcesz zarejestrować.

Wybierz przycisk Utwórz nową kompozycję warstw u dołu panelu Kompozycje warstw .

W oknie dialogowym Nowa kompozycja warstw wpisz opisową nazwę i opcjonalne komentarze.

Wybierz właściwości warstw do zapisania: Widoczność, Położenie, Wygląd (Styl warstwy) lub Wybór kompozycji warstw dla obiektów inteligentnych.

Wybierz przycisk OK.

Wybrane opcje staną się ustawieniami domyślnymi dla przyszłych kompozycji warstw.

Wskazówka

Zduplikuj istniejącą kompozycję, przeciągając ją do opcji Utwórz nową kompozycję warstw w panelu Kompozycje warstw.

Stosowanie i przeglądanie kompozycji warstw

Otwórz panel Kompozycje warstw, wybierając kolejno Okno > Kompozycje warstw.

Wybierz opcję Zastosuj kompozycję warstw z menu kontekstowego Kompozycje warstw.

Użyj elementów sterowania Poprzednia i Następna u dołu panelu, aby przechodzić kolejno przez wszystkie kompozycje lub wybrane kompozycje.

Wybierz opcję Zastosuj kompozycję warstw, aby przywrócić dokument.

Aktualizacja kompozycji warstw

W panelu Kompozycje warstw wybierz kompozycję warstw do zaktualizowania.

Wprowadź zmiany dotyczące widoczności, położenia lub wyglądu warstw w panelu Warstwy.

Jeśli trzeba zmienić właściwości zapisywane przez kompozycję, wybierz opcję Opcje kompozycji warstw z menu panelu Kompozycje warstw .

Wybierz przycisk Aktualizacja kompozycji warstw u dołu panelu Kompozycje warstw.

Używanie kompozycji warstw w obiektach inteligentnych

Po umieszczeniu dokumentu zawierającego kompozycje warstw jako obiekt inteligentny w innym dokumencie można uzyskać dostęp do tych kompozycji warstw bez otwierania pliku źródłowego.Dzięki temu można przełączać się między wariantami projektu na poziomie obiektu smart.

Wybierz warstwę obiektu smart w panelu Warstwy dokumentu.

Otwórz panel Właściwości, wybierając Okno > Właściwości.

Wybierz kompozycję warstw, którą chcesz wyświetlić, z menu Kompozycja warstw w panelu Właściwości.

Menu kompozycji warstw w panelu właściwości w programie Adobe Photoshop, wyświetlające listę kompozycji warstw z dedykowanymi opcjami.

Obiekt smart jest aktualizowany, aby wyświetlić wybraną kompozycję, zachowując wszelkie przekształcenia lub efekty zastosowane do niego.

Wyczyść ostrzeżenia kompozycji warstw

Ikona ostrzeżenia pojawia się przy kompozycji warstw, gdy usuniesz, scalisz lub przekonwertujesz warstwy, do których odwołuje się ta kompozycja.Kompozycji nie można już w pełni przywrócić do jej pierwotnego stanu.

Wybierz ikonę ostrzeżenia znajdującą się przy nazwie kompozycji, aby zobaczyć szczegóły problemu.

Wybierz opcję Wyczyść w komunikacie, aby usunąć ostrzeżenie i zachować pozostałe właściwości warstwy.

Kliknij ikonę ostrzeżenia prawym przyciskiem myszy i wybierz opcję Wyczyść ostrzeżenie kompozycji warstw, aby usunąć jedno ostrzeżenie, lub opcję Wyczyść wszystkie ostrzeżenia kompozycji warstw, aby usunąć wszystkie ostrzeżenia jednocześnie.

Można również zaktualizować kompozycję do jej aktualnego stanu lub zignorować ostrzeżenie, jeśli brakujące informacje o warstwie nie są potrzebne.

Usuwanie kompozycji warstw

Zaznacz kompozycję na panelu Layer Comps (Kompozycje warstw).

Wybierz ikonę usuwania u dołu panelu lub przeciągnij kompozycję na ikonę usuwania.

Aby zastosować inną metodę, wybierz opcję Usuń kompozycję warstw z menu panelu.

Eksportowanie kompozycji warstw do plików

Wybierz Plik > Eksportuj > Kompozycje warstw do plików.

Wybierz folder docelowy w oknie dialogowym.

Wybierz format plików eksportowanych kompozycji.

Wybierz opcję Uruchom, aby utworzyć osobne pliki na każdą kompozycję warstw.

Każda kompozycja warstw jest eksportowana jako osobny plik, a jej nazwa jest dodawana do nazwy pliku.