Kopiowanie i wklejanie warstw

Ostatnia aktualizacja 2 lis 2026

Użyj opcji Kopiuj, Wklej i Wklej lokalnie, aby duplikować warstwy z zachowanymi efektami i maskami.

Kopiowanie i wklejanie warstw przesyła kompletne dane warstwy między dokumentami, w tym maski bitmapowe i wektorowe, efekty warstwy oraz odwołania do obiektów inteligentnych (Smart Object).Ta metoda zachowuje wszystkie właściwości warstwy, jednocześnie tworząc niezależne duplikaty w dokumencie docelowym.

Użyj kopiowania i wklejania, aby przenosić warstwy między dokumentami, zachowując wszystkie ich właściwości.Aby duplikować warstwy w tym samym dokumencie, użyj opcji Warstwa > Duplikuj warstwę.Aby zmienić położenie istniejącej zawartości bez tworzenia duplikatów, przeciągnij warstwy między oknami dokumentów za pomocą narzędzia Przesunięcie.

Kopiowanie i wklejanie warstw

W panelu Warstwy wybierz warstwy, które chcesz skopiować.

Wybierz Edycja > Kopiuj lub naciśnij klawisze Ctrl + C (Windows) lub Command + C (macOS).

Przejdź do dokumentu docelowego lub utwórz nowy dokument.

Wybierz Edycja > Wklej lub naciśnij klawisze Ctrl + V (Windows) lub Command + V (macOS).

Wklejona warstwa pojawia się na środku obszaru roboczego dokumentu docelowego.Wklejona warstwa pojawia się w taki sposób, że przynajmniej jej część jest widoczna na obszarze roboczym.

Wklejanie warstw w ich oryginalnym położeniu

W panelu Warstwy wybierz warstwy, które chcesz skopiować.

Wybierz Edycja > Kopiuj lub naciśnij klawisze Ctrl + C (Windows) lub Command + C (macOS).

Przejdź do dokumentu docelowego.

Wybierz Edycja > Wklej specjalnie > Wklej lokalnie lub naciśnij klawisze Ctrl + Shift + V (Windows) lub Command + Shift + V (macOS).

Wklej lokalnie zachowuje skopiowaną zawartość w tej samej pozycji względem krawędzi obszaru roboczego.

Tworzenie dokumentu o rozmiarze odpowiadającym skopiowanym warstwom

Wybierz i skopiuj jedną lub więcej warstw.

Wybierz polecenie Plik > Nowy.

W oknie dialogowym Nowy dokument wybierz opcję Schowek z listy ustawień wstępnych.

Wybierz Utwórz, aby wygenerować nowy dokument o wymiarach zgodnych ze skopiowanymi warstwami.

Wybierz Edycja > Wklej lub naciśnij klawisze Ctrl + V (Windows) lub Command + V (macOS).

Ustawienie wstępne Schowek tworzy dokument o wymiarach odpowiadających obwiedni wszystkich skopiowanych warstw.

Zarządzanie kolorem i rozdzielczością.

Podczas wklejania między dokumentami program Photoshop może wyświetlić okno dialogowe niezgodności profilów kolorów, jeśli dokument źródłowy i docelowy używają różnych profilów kolorów.Kolory można przekonwertować, aby dopasować je do dokumentu docelowego, lub zachować oryginalne kolory.Ustawienia zarządzania kolorami w Edycja > Ustawienia kolorów określają, kiedy wyświetlane są te monity.

Jeśli warstwy są wklejane między dokumentami o różnej rozdzielczości, wklejona zawartość zachowuje swoje wymiary w pikselach.Może to spowodować, że wklejone elementy będą wyglądać większe lub mniejsze niż w dokumencie docelowym.Aby zachować spójność wizualną, użyj polecenia Obraz > Rozmiar obrazu, aby dopasować rozdzielczości przed kopiowaniem i wklejaniem, lub użyj polecenia Edycja > Przekształcanie swobodnie, aby zmienić rozmiar wklejonej zawartości.

Informacje o działaniu kopiowania i wklejania obiektów Smart Object

Ostrzeżenie

Edycje skopiowanej i wklejonej warstwy obiektu Smart Object nie aktualizują oryginalnej warstwy obiektu Smart Object, i odwrotnie.Skopiowane i wklejone obiekty Smart Object tworzą niezależne, osadzone wystąpienia.

Aby zachować połączenia między wystąpieniami obiektów Smart Object w różnych dokumentach, użyj połączonych obiektów Smart Object.Połączone obiekty Smart Object odwołują się do zewnętrznych plików źródłowych, co zapewnia aktualizację wszystkich wystąpień podczas edytowania źródła.

Kopiuj scaloną zawartość

Polecenie Kopiuj scalone tworzy spłaszczoną kopię wszystkich widocznych warstw w obrębie wybranego obszaru.

Zaznacz obszar za pomocą dowolnego narzędzia zaznaczania lub nie zaznaczaj niczego, aby skopiować całą widoczną zawartość.

Wybierz Edycja > Kopiuj scalone lub naciśnij klawisze Ctrl + Shift + C (Windows) lub Command + Shift + C (macOS).

Wklej scaloną zawartość do dowolnego dokumentu.Scalona zawartość znajduje się na jednej warstwie.

Polecenie Kopiuj scalone uwzględnia widoczność warstw — tylko widoczne warstwy mają wpływ na wynik scalania.Ukryte warstwy są wykluczone, nawet jeśli są zaznaczone.

Praca z zachowaniami specyficznymi dla ścieżek

Podczas kopiowania warstw zawierających ścieżki wektorowe, w tym warstw kształtu i masek wektorowych, sposób działania kopiowania i wklejania zależy od tego, czy na obszarze roboczym są zaznaczone ścieżki.

Kopiowanie warstw kształtu i masek wektorowych

Gdy na obszarze roboczym nie są zaznaczone żadne ścieżki:

  • Skopiowanie warstwy kształtu lub warstwy z maską wektorową powoduje skopiowanie całej warstwy do schowka
  • Wklejenie powoduje utworzenie zduplikowanej warstwy z zachowaniem wszystkich masek, efektów i danych ścieżki

Gdy na obszarze roboczym wybrane są ścieżki:

  • Skopiowanie warstwy kształtu z wybranymi ścieżkami powoduje skopiowanie do schowka tylko danych ścieżki
  • Sposób wklejania danych ścieżki zależy od typu warstwy docelowej (patrz poniżej)

Wklejanie danych ścieżki

Sposób wklejania danych ścieżki różni się w zależności od wybranego typu warstwy:

  • Do warstwy bitmapowej (bez ścieżek): Tworzy nową maskę wektorową na podstawie wklejonych danych ścieżki
  • Do warstwy kształtu bez wybranych ścieżek: Zastępuje istniejący kształt wklejoną ścieżką
  • Do warstwy kształtu z wybranymi ścieżkami: Łączy wklejoną ścieżkę z istniejącymi ścieżkami w warstwie kształtu
  • Do warstwy z maską wektorową (maska niewybrana): Zastępuje ścieżkę maski wektorowej wklejonymi danymi
  • Do warstwy z maską wektorową (maska wybrana): Łączy wklejoną ścieżkę z istniejącą ścieżką maski wektorowej
Spostrzeżenie

Polecenie Wytnij (Edycja > Wytnij) jest niedostępne, gdy wybrane są warstwy.Aby usunąć warstwy podczas ich kopiowania, użyj polecenia Kopiuj, a następnie usuń oryginalne warstwy w panelu Warstwy.