Napraw błąd Generator podczas uruchamiania programu Adobe Photoshop

Ostatnia aktualizacja 2 lis 2026

Dowiedz się, jak naprawić błąd Generator w programie Adobe Photoshop, sprawdzając ustawienia zabezpieczeń, usuwając powodujące konflikty wtyczki i przeglądając dzienniki.

Generator to aplikacja Node.js, która obsługuje komunikację między programem Photoshop i wtyczkami Generator.Zapewnia logikę tworzenia zasobów na potrzeby opcji Eksportuj jako oraz Zasoby obrazu.

Po uruchomieniu programu Photoshop lub wybraniu opcji Plik > Eksportuj > Eksportuj jako zostanie wyświetlone okno dialogowe z komunikatem: „Wystąpił problem z Generatorem. Zamknij program Photoshop i spróbuj ponownie. Jeśli problem nie ustąpi, usuń wszelkie wtyczki innych firm lub spróbuj ponownie zainstalować program Photoshop.”

Wypróbuj poniższe rozwiązania w podanej kolejności.

Oprogramowanie zabezpieczające blokuje Generator

Oprogramowanie zabezpieczające lub antywirusowe może blokować komunikację Generatora na porcie 8010 lub uniemożliwiać działanie procesu node.

Otwórz ustawienia zabezpieczeń lub oprogramowania antywirusowego.

Dodaj program Photoshop do listy dozwolonych aplikacji.

Sprawdź, czy port 8010 jest otwarty na potrzeby Generator.

W systemie Windows dodaj node.exe do listy dozwolonych aplikacji w lokalizacji C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe.

W systemie macOS zezwól na działanie procesu node w lokalizacji /Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node.

W systemie Windows zezwól programowi Photoshop na dostęp do kontrolowanych folderów.

Uruchom ponownie program Photoshop, a następnie wybierz opcję Plik > Eksportuj > Eksportuj jako, aby przetestować Generator.

Wtyczka innej firmy powoduje konflikt z Generator

Wtyczki innych firm w folderze Generator programu Photoshop mogą być niezgodne z aktualnie używaną wersją lub powodować konflikt z domyślną wtyczką Zasoby graficzne.

Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator

Utwórz na pulpicie tymczasowy folder o nazwie Disabled Generator Plug-ins.

Przenieś foldery wtyczek innych firm do folderu tymczasowego.Pozostaw domyślną wtyczkę Image Assets w folderze Generator.

Uruchom program Photoshop i wybierz opcję Plik > Eksportuj > Eksportuj jako.

Jeśli błąd nie występuje, dodawaj wtyczki ponownie jedna po drugiej i uruchamiaj ponownie program Photoshop po każdym dodaniu, aż błąd ponownie się pojawi.

Pozostaw domyślną wtyczkę Image Assets w folderze Generator.Przenieś tylko wtyczki zainstalowane osobno.

Nie można uruchomić generatora, a nie jest on potrzebny

Jeśli nie jest używana funkcja Export As ani Image Assets, wyłącz funkcję Generator jako obejście problemu.

Uruchom program Photoshop.

W systemie Windows wybierz kolejno Edycja > Preferencje > Wtyczki. W systemie macOS wybierz kolejno Photoshop > Ustawienia > Wtyczki.

Usuń zaznaczenie opcji Włącz Generator.

Wybierz przycisk OK, a następnie uruchom ponownie Photoshop.

Wybranie opcji Plik > Eksportuj > Export As ponownie włącza funkcję Generator. Jeśli funkcja Export As jest potrzebna, rozwiąż błąd funkcji Generator zamiast pozostawiać ją wyłączoną.

Dzienniki generatora zawierają błędy uruchamiania

Dzienniki Generator mogą zawierać informacje o wtyczkach, których nie można załadować, lub o problemach systemowych uniemożliwiających uruchomienie funkcji Generator.

W systemie Windows przejdź do folderu C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator.

W systemie macOS przejdź do folderu /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator.

Otwórz najnowszy dziennik Generator i sprawdź, czy są w nim komunikaty o błędach.

Jeśli folder Generator nie istnieje, sprawdź, czy masz uprawnienia do zapisu w folderze nadrzędnym.

Jeśli potrzebna jest dodatkowa pomoc, użyj narzędzia Adobe Log Collector Tool, aby zebrać dzienniki diagnostyczne.

Foldery Windows AppData i macOS Library są domyślnie ukryte. Instrukcje wyświetlania ukrytych plików i folderów w systemie Windows mogą pomóc zlokalizować dzienniki systemu Windows.

Błędy Generator występują na komputerach Apple Silicon

Jeśli generator nadal nie działa na komputerze Mac z Apple silicon, uruchomienie programu Photoshop za pomocą Rosetta może pomóc ustalić, czy przyczyną problemu jest zgodność trybu natywnego.

Zamknij program Photoshop.

W programie Finder otwórz folder Applications i znajdź Adobe Photoshop.

Kliknij z naciśniętym klawiszem Control pozycję Adobe Photoshop, a następnie wybierz opcję Pobierz informacje.

Wybierz opcję Otwórz przy użyciu Rosetta, a następnie uruchom Photoshop i przetestuj funkcję Generator.

Jeśli błąd nadal występuje, podczas kontaktu z działem pomocy technicznej Adobe przekaż dzienniki Generator. W przypadku problemów z funkcją Export As niezwiązanych z funkcją Generator skorzystaj z wskazówek dotyczących rozwiązywania problemów z eksportowaniem i zapisywaniem.