Scalanie zdjęć w obraz HDR

Ostatnia aktualizacja 2 lis 2026

Dowiedz się, jak łączyć wiele ekspozycji za pomocą funkcji Scal do HDR Pro, aby uchwycić pełny zakres dynamiki sceny w programie Adobe Photoshop na komputerze.

Scalenie wielu ekspozycji w jeden obraz HDR pozwala zachować szczegóły w światłach i cieniach, które zostałyby utracone na standardowej fotografii.

Użyj funkcji Scal do HDR Pro, gdy masz wiele zdjęć tej samej scenerii zrobionych z różnymi ekspozycjami.Ten obieg pracy łączy te ekspozycje w jeden obraz HDR, który obejmuje pełny zakres dynamiki.Wynik można zapisać jako plik 32-bitowy, który przechowuje pełne dane HDR, lub jako plik 16-bitowy lub 8-bitowy z zastosowanym mapowaniem tonalnym.Aby dostosować istniejące 32-bitowe obrazy HDR, użyj zamiast tego funkcji Ekspozycja lub polecenia Tonowanie HDR.

  • Co najmniej trzy zdjęcia tej samej scenerii z różnymi ekspozycjami (minimum: jedno niedoświetlone, jedno prawidłowo naświetlone, jedno prześwietlone)
  • Zdjęcia powinny różnić się o 1–2 kroki wartości ekspozycji (EV)
  • Obrazy zrobione przy użyciu tych samych ustawień (jeśli to możliwe, ta sama ogniskowa, przysłona i ISO)
  • Zalecane jest robienie zdjęć ze statywu, aby uzyskać najlepsze wyniki wyrównania

Uruchamianie funkcji Scal do HDR Pro i wybór obrazów źródłowych

Wybierz Plik > Automatyzacja > Scal do HDR Pro. Można także wybrać obrazy źródłowe w programie Bridge, a następnie wybrać Narzędzia > Photoshop > Scal do HDR Pro.

Wybierz opcję Przeglądaj, aby znaleźć i wybrać konkretne obrazy, lub Dodaj otwarte pliki, aby użyć istniejących obrazów.

Wybierz opcję Próbuj automatycznie wyrównać obrazy źródłowe, jeśli obrazy nie są wyrównane.

Wybierz OK, aby przetworzyć obrazy źródłowe.

Jeśli obrazy źródłowe nie mają metadanych ekspozycji, program Photoshop wyświetla okno dialogowe Ręczne ustawianie EV. Wprowadź wartość ekspozycji dla każdego obrazu, a następnie wybierz OK.

Po przetworzeniu zostanie wyświetlone drugie okno dialogowe Scal do HDR Pro z miniaturami obrazów źródłowych i podglądem scalonego wyniku.

Konfigurowanie ustawień wyjściowych i stosowanie mapowania tonalnego

Wybierz głębię bitową z menu: 32 bity, 16 bitów lub 8 bitów.

W przypadku wyjścia 32-bitowego przesuń suwak punktu bieli znajdujący się pod histogramem, aby dostosować jasność podglądu.To dopasowanie wpływa tylko na wyświetlanie podglądu; wszystkie dane HDR pozostają w pliku.

W przypadku danych wyjściowych 16-bitowych lub 8-bitowych wybierz metodę mapowania tonalnego z menu Metoda i dostosuj jej ustawienia.

Wybierz opcję Usuń poświaty, jeśli obrazy źródłowe zawierają ruchome obiekty, takie jak ludzie, samochody lub listowie. Program Photoshop wyświetla zielony kontur wokół miniatury obrazu bazowego.

Wybierz przycisk OK, aby utworzyć scalony obraz HDR.

Aby zapisać Ustawienia mapowania tonalnego do wykorzystania w przyszłości, wybierz Ustawienie wstępne > Zapisz ustawienie wstępne. Aby ponownie zastosować zapisane Ustawienia, wybierz opcję Wczytaj ustawienie wstępne.

Usuwanie artefaktów poświaty z ruchomych obiektów

Jeśli obrazy źródłowe zawierają różną zawartość z powodu ruchomych obiektów, wybierz opcję Usuń poświaty w oknie dialogowym Scal do HDR Pro.

Jeśli ruch występuje w bardzo jasnych lub ciemnych obszarach, wybierz inną miniaturę, na której ruchome obiekty są lepiej naświetlone, aby poprawić wyniki.

Praca z krzywymi czułości aparatu

Krzywe czułości aparatu określają sposób, w jaki czujniki aparatu interpretują różne poziomy padającego światła. Domyślnie funkcja Scal do HDR Pro automatycznie oblicza krzywą czułości na podstawie obrazów źródłowych. Tę krzywą można zapisać i zastosować do innych scaleń HDR:

  • W prawym górnym rogu okna dialogowego Scal do HDR Pro wybierz menu krzywej czułości i wybierz opcję Zapisz krzywą czułości.
  • Aby zastosować zapisaną krzywą do nowego scalenia, wybierz opcję Wczytaj krzywą czułości z tego samego menu.

Dopasowanie podglądu 32-bitowego jest zapisywane w pliku HDR i stosowane każdorazowo podczas otwierania pliku w programie Photoshop. Aby ponownie dopasować podgląd punktu bieli dla istniejącego obrazu HDR, wybierz Widok > Opcje podglądu 32-bitowego.