Creare e gestire un indice in un PDF

Per i PDF di grandi dimensioni, è possibile ridurre il tempo richiesto per eseguire le ricerche incorporando nel documento un indice delle parole. Acrobat DC è in grado di effettuare ricerche all’interno dell’indice molto più rapidamente che non nel documento. L’indice incorporato viene incluso nelle copie distribuite o condivise del PDF. La procedura di ricerca all’interno di PDF con indici incorporati è identica a quella che è necessario implementare per eseguire ricerche negli stessi documenti senza indici incorporati; non sono richiesti passi supplementari.

Aggiungere un indice a un PDF

  1. Con il documento aperto in Acrobat DC, scegliere Strumenti > Indice.

    Il set di strumenti Indice viene visualizzato nella barra degli strumenti secondaria.

  2. Nella barra degli strumenti secondaria, fare clic su Gestisci indice incorporato.

  3. Nella finestra di dialogo Gestisci indice incorporato, fare clic su Incorpora indice.

  4. Leggere i messaggi visualizzati, quindi fare clic su OK.

    Nota:

    in Outlook e Lotus Notes, si ha la possibilità di incorporare un indice quando si convertono cartelle o messaggi e-mail in PDF. Tale operazione è consigliabile soprattutto nel caso di cartelle che contengono numerosi messaggi e-mail.

Aggiornare o rimuovere l’indice incorporato in un PDF

  1. Selezionare Strumenti > Indice.

    Il set di strumenti Indice viene visualizzato nella barra degli strumenti secondaria.

  2. Nella barra degli strumenti secondaria, fare clic su Gestisci indice incorporato.

  3. Fare clic su Aggiorna indice o Rimuovi indice.

Informazioni sulla funzione Catalogo (Acrobat Pro DC)

È possibile definire un gruppo specifico di PDF come catalogo e creare un indice unificato per l’intera raccolta di documenti. Quando gli utenti cercano determinate informazioni nei PDF catalogati, l’indice rende considerevolmente più rapido il processo di ricerca.

Quando si distribuisce la raccolta su un CD, insieme ai PDF è possibile includere anche l'indice.

È possibile catalogare documenti redatti utilizzando caratteri romani, cinesi, giapponesi o coreani. Le voci che è possibile catalogare includono il testo del documento, commenti, segnalibri, campi modulo, tag, metadati oggetto e documento, allegati, informazioni sui documenti, firme digitali, metadati XIF (extended image file format) di immagini e proprietà del documento personalizzate.

Preparazione dei PDF per l’indicizzazione (Acrobat Pro DC)

La prima operazione da eseguire consiste nel creare una cartella contenente i file PDF da indicizzare. Tutti i PDF dovrebbero essere completi, in termini sia di contenuto che di funzioni elettroniche, quali link, segnalibri e campi modulo. Se tra i file da indicizzare sono compresi documenti acquisiti mediante scansione, verificare che sia possibile eseguire ricerche all’interno del testo. Per migliorare le prestazioni di ricerca, è consigliabile suddividere i documenti lunghi in file più piccoli, delle dimensioni di un capitolo. Per semplificare la ricerca all’interno di un file, è inoltre possibile aggiungere informazioni alle relative proprietà del documento.

Prima di indicizzare una raccolta di documenti, è molto importante organizzare la struttura del documento sull’unità disco locale o in un volume del server di rete e verificare i nomi dei file tra le varie piattaforme. In una ricerca multipiattaforma, i nomi file potrebbero essere troncati e quindi difficili da recuperare. Per ovviare a questo problema, tenere in considerazione le seguenti linee guida:

  • Rinominare file, cartelle e indici utilizzando la convenzione di denominazione dei file MS-DOS (fino a un massimo di otto caratteri seguiti da un’estensione di tre caratteri), soprattutto se si intende distribuire la raccolta di documenti e l’indice su un disco CD-ROM con formattazione conforme a ISO 9660.

  • Eliminare dai nomi di file e cartelle i caratteri estesi, ad esempio i caratteri accentati e non inglesi (il font utilizzato dalla funzione Catalog non supporta i codici carattere compresi tra 133 e 159).

  • Non utilizzare cartelle con nidificazione profonda o nomi di percorso di lunghezza superiore a 256 caratteri per gli indici in cui verranno effettuate ricerche da utenti di Mac OS.

  • Se si utilizza Mac OS con server LAN OS/2, configurare IBM® LAN Server Macintosh (LSM) in modo da applicare le convenzioni di denominazione dei file MS-DOS o indicizzare solo i volumi FAT (File Allocation Table). I volumi HPFS (High Performance File System), infatti, possono contenere nomi file lunghi che non possono essere recuperati.

    Se la struttura del documento include sottocartelle che non si desidera indicizzare, è possibile escluderle durante il processo di indicizzazione.

Aggiunta di metadati alle proprietà del documento (Acrobat Pro DC)

Per semplificare la ricerca in un PDF, è possibile aggiungere informazioni sul file, definite metadati, alle proprietà del documento. Per visualizzare le proprietà relative al PDF correntemente aperto, fare clic su File > Proprietà, quindi selezionare la scheda Descrizione.

Quando si aggiungono dati da inserire nelle proprietà del documento, tenere presente i seguenti consigli:

  • Inserire un titolo descrittivo nel campo Titolo. Nella finestra di dialogo Risultati ricerca viene visualizzato il nome file del documento.

  • Utilizzare sempre la stessa opzione (campo) per le informazioni simili. Ad esempio, non aggiungere un termine importante all’opzione Oggetto per alcuni documenti e all’opzione Parole chiave per altri.

  • Utilizzare un unico termine coerente per fare riferimento alla stessa informazione. Ad esempio, non usare biologia per alcuni documenti e scienze naturali per altri.

  • Utilizzare l’opzione Autore per identificare il gruppo di persone responsabile del documento. L’autore di un documento sulle procedure di assunzione potrebbe essere, ad esempio, il repartoRisorse umane.

  • Se si utilizzano i numeri parte di un documento, aggiungerli come Parole chiave. Aggiungere, ad esempio, doc#=m234 in Parole chiave per indicare un documento specifico in una serie di diverse centinaia di documenti con un determinato soggetto.

  • Utilizzare l’opzione Oggetto o Parole chiave, singolarmente o insieme, per suddividere in categorie i documenti in base al tipo. Ad esempio, per lo stesso documento è possibile immettere relazione come voce relativa all’oggetto e mensile o settimanale come voci corrispondenti alle parole chiave.

    Se si ha già familiarità con Adobe PDF, è possibile definire campi di dati personalizzati, ad esempio Tipo documento, Numero documento e Identificatore documento, quando si crea l’indice. Questa operazione è consigliata solo agli utenti esperti e non è descritta nella guida completa di Acrobat.

Creare un indice per una raccolta (Acrobat Pro DC)

Quando si forma un nuovo indice, Acrobat DC crea un file con estensione .pdx e una nuova cartella di supporto che contiene uno o più file con estensione .idx. I file IDX contengono le voci di indice. Tutti questi file devono essere disponibili per gli utenti che desiderano effettuare ricerche nell’indice.

  1. Selezionare Strumenti > Indice.

    Il set di strumenti Indice viene visualizzato nella barra degli strumenti secondaria.

  2. Nella barra degli strumenti secondaria, fare clic su  Indice full-text con catalogo.

    Viene visualizzata la finestra di dialogo Catalogo.

  3. Nella finestra di dialogo Catalogo, fare clic su Nuovo indice.

    Viene visualizzata la finestra di dialogo Nuova definizione dell’indice.

    Nuove definizioni dell’indice in Acrobat
    Finestra di dialogo nuova definizione dell’indice.

  4. In Titolo indice digitare un nome per il file di indice.

  5. In Descrizione indice digitare una breve descrizione del tipo di indice o dell’uso previsto.

  6. Fare clic su Opzioni, selezionare le opzioni avanzate che si desidera applicare all’indice e fare clic su OK.

    Finestra di dialogo Opzioni in Acrobat
    Nella finestra di dialogo Opzioni è possibile impostare le opzioni avanzate per il nuovo indice.

  7. In Includi queste directory fare clic su Aggiungi, selezionare una cartella che contenga alcuni o tutti i file PDF da indicizzare e fare clic su OK. Per aggiungere ulteriori cartelle, ripetere la procedura descritta.

    Nota:

    qualsiasi cartella nidificata al di sotto di una cartella inclusa verrà inserita nel processo di indicizzazione. è possibile aggiungere cartelle da più server o unità disco, se non si intende spostare l’indice o le voci nella raccolta di documenti.

  8. In Escludi queste sottodirectory fare clic su Aggiungi e selezionare qualsiasi cartella nidificata che contenga i file PDF che si desidera escludere dall’indicizzazione. Fare clic su OK e ripetere la procedura, se necessario.

  9. Verificare le selezioni. Per cambiare l’elenco delle cartelle da includere o escludere, selezionare la cartella da modificare e fare clic su Rimuovi.

  10. Fare clic su Costruisci, quindi specificare il percorso del file di indice. Fare clic su Salva, quindi:

    • Fare clic su Chiudi al termine dell’indicizzazione.

    • Fare clic su Arresta per annullare il processo di indicizzazione.

    Nota:

    Se il processo di indicizzazione viene interrotto, non sarà più possibile riprendere la stessa sessione, ma sarà necessario avviarne una nuova. La selezione delle opzioni e delle cartelle rimane invariata. È possibile fare clic su Apri indice, selezionare l’indice parzialmente completato e verificarlo.

    Nota:

    Se i nomi di percorso lunghi vengono troncati nelle opzioni Includi queste directory ed Escludi queste sottocartelle, tenere fermo il puntatore sui punti di sospensione (...) di ciascun troncamento fino a quando non viene visualizzata una descrizione comandi che riporta il percorso completo della cartella inclusa o esclusa.

Finestra di dialogo delle opzioni di indicizzazione

Non includere i numeri

Selezionare questa opzione per escludere dall’indice tutti i numeri presenti nel testo del documento. L’esclusione dei numeri può ridurre sensibilmente la dimensione di un indice e rendere più veloci le ricerche.

Aggiungi ID a file Adobe PDF Versione 1.0

Selezionare questa opzione se la raccolta include i PDF creati con versioni precedenti ad Acrobat 2.0, che non aggiungevano automaticamente alcun numero di identificazione. I numeri di identificazione sono necessari nel caso in cui i nomi file Mac OS lunghi vengono abbreviati nella conversione in nomi file DOS. Acrobat 2.0 e le versioni successive aggiungono gli identificatori automaticamente.

Non visualizzare il messaggio sui documenti modificati durante la ricerca

Quando questa opzione non è selezionata, viene visualizzato un messaggio durante la ricerca in documenti modificati in seguito all’ultima creazione dell’indice.

Proprietà personalizzate

Utilizzare questa opzione per includere nell’indice le proprietà personalizzate del documento. Vengono indicizzate solo le proprietà personalizzate del documento presenti nei PDF sottoposti a indicizzazione. Digitare la proprietà, effettuare una selezione dal menu Tipo e fare clic su Aggiungi. Queste proprietà vengono visualizzate come opzione di ricerca nei menu a comparsa dei criteri aggiuntivi della finestra Ricerca PDF quando si esegue la ricerca nell’indice risultante. Ad esempio, se si aggiunge la proprietà personalizzata Nome documento e si seleziona la proprietà stringa dal menu Tipo, gli utenti che effettuano una ricerca nell’indice possono estendere tale ricerca alla proprietà personalizzata selezionando Nome documento dal menu Usa questi criteri aggiuntivi.

Nota:

quando si creano campi personalizzati in un’applicazione Microsoft Office in cui è selezionata l’opzione Converti informazioni documento nell’applicazione PDFMaker, i campi vengono trasferiti in tutti i file PDF creati.  

Campi XMP

Utilizzare questa opzione per includere i campi XMP personalizzati. Tali campi vengono indicizzati e visualizzati nei menu a comparsa dei criteri aggiuntivi in modo da poter essere cercati negli indici selezionati.

Parole

Utilizzare questa opzione per escludere parole specifiche (massimo 500) dai risultati della ricerca nell’indice. Digitare la parola desiderata, fare clic su Aggiungi e, se necessario, ripetere la procedura. L’esclusione di parole può ridurre le dimensioni dell’indice del 10-15%. Una parola non significativa può contenere fino a 128 caratteri e supporta la distinzione tra maiuscole e minuscole.

Nota:

Per impedire agli utenti di cercare frasi che contengono queste parole, elencare i termini non indicizzati nel file Leggimi di Catalogo.

Tag struttura

Utilizzare questa opzione per rendere possibile la ricerca nei nodi di tag con elementi foglia all’interno dei documenti dotati di struttura logica con tag.

Nota:

le impostazioni Proprietà personalizzate, Parole e Tag si applicano solo all’indice corrente. È possibile applicare queste impostazioni in maniera globale a tutti gli indici creati modificando le impostazioni predefinite relative a campi personalizzati, parole e tag nel pannello Catalog della finestra di dialogo Preferenze.  

File Leggimi di Catalogo (Acrobat Pro DC)

Spesso è opportuno creare un file Leggimi separato e memorizzarlo nella cartella insieme all’indice. Il file Leggimi può fornire informazioni utili sull’indice, quali:

  • Il tipo dei documenti indicizzati.

  • Le opzioni di ricerca supportate.

  • Il nome della persona da contattare o il numero di telefono da comporre per eventuali domande.

  • L’elenco dei numeri o dei termini esclusi dall’indice.

  • L’elenco delle cartelle che contengono i documenti inclusi in un indice disponibile sulla LAN oppure un elenco dei documenti inclusi in un indice situato in un disco rigido. È inoltre possibile aggiungere una breve descrizione del contenuto di ogni cartella o documento.

  • L’elenco dei valori relativi a ciascun documento, se si assegnano valori al campo Informazioni documento.

    Se un catalogo dispone di un numero di documenti particolarmente elevato, è consigliabile includere una tabella con i valori assegnati a ciascun documento. La tabella può far parte del file Leggimi oppure essere inclusa in un documento separato. L’uso della tabella durante la definizione dell’indice garantirà informazioni uniformi.

Revisione di un indice (Acrobat Pro DC)

È possibile aggiornare, ricreare o svuotare un indice esistente.

  1. Selezionare Strumenti > Indice.

    Il set di strumenti Indice viene visualizzato nella barra degli strumenti secondaria.

  2. Nella barra degli strumenti secondaria, fare clic su  Indice full-text con catalogo.

    Viene visualizzata la finestra di dialogo Catalogo.

  3. Nella finestra di dialogo Catalogo, fare clic su Apri indice.

  4. Individuare e selezionare il file di definizione PDX dell’indice desiderato e fare clic su Apri.

  5. Se l’indice è stato creato con Acrobat 5.0 o con una versione precedente, selezionare Crea copia per creare un nuovo indice senza eliminare quello esistente oppure selezionare Sovrascrivi indice prec. per sovrascrivere l’indice precedente.

  6. Nella finestra di dialogo Definizione indice, apportare le modifiche necessarie e fare clic sulla funzione che si desidera eseguire in Acrobat DC:

    Costruisci

    Crea un nuovo file IDX con le informazioni esistenti e lo aggiorna aggiungendo nuove voci e contrassegnando come non valide le voci modificate o obsolete. Se le modifiche apportate sono numerose o se si ricorre spesso a questa opzione, anziché creare un nuovo indice, i tempi di ricerca possono aumentare.

    Ricostruisci

    Crea un nuovo indice, sovrascrivendo la cartella di indice esistente e i relativi contenuti (i file IDX).

    Svuota

    Elimina i contenuti dell’indice (i file IDX) senza eliminare il file di indice stesso (PDX).

Preferenze di Catalogo (Acrobat Pro DC)

È possibile impostare le preferenze per l’indicizzazione da applicare globalmente a tutti gli indici creati successivamente. Alcune preferenze possono essere ignorate per un particolare indice selezionando nuove opzioni durante il processo di creazione dell’indice.

Nella finestra di dialogo Preferenze in Categorie, selezionare Catalogo. Molte delle opzioni sono identiche a quelle descritte per il processo di creazione dell’indice.

Nota:

L’opzione Applica compatibilità con ISO 9660 alle cartelle è utile nei casi in cui non si desidera modificare i nomi dei file PDF lunghi in nomi file MS‑DOS durante la preparazione dei documenti per l’indicizzazione. Tuttavia, è comunque necessario utilizzare le convenzioni di denominazione dei file MS‑DOS per i nomi delle cartelle (massimo 8 caratteri), ma non per i nomi dei file.

Aggiornamenti pianificati dell’indice (Acrobat Pro DC)

Utilizzare la funzione Catalog e un file batch di catalogo in formato PDX (.bpdx) per pianificare il momento e la frequenza con cui eseguire automaticamente le operazioni di creazione, ricostruzione, aggiornamento e svuotamento di un indice. Un file BPDX è un file di testo contenente un elenco di flag e percorsi di file indice di Catalog dipendenti dalla piattaforma. Per visualizzare il file BPDX in Acrobat DC è necessario utilizzare un’applicazione di pianificazione, ad esempio l’Utilità di pianificazione di Windows. In Acrobat DC viene quindi creato nuovamente l’indice in base ai flag presenti nel file BPDX.

Nota:

Per utilizzare file BPDX, nella sezione Catalogo della finestra Preferenze selezionare Consenti esecuzione file batch catalogo (.bpdx).

Spostamento di raccolte e relativi indici (Acrobat Pro DC)

È possibile creare e verificare una raccolta indicizzata di documenti su un disco rigido locale e spostarla successivamente su un server di rete o su un disco. Una definizione di indice include i percorsi relativi tra il file di definizione dell’indice (PDX) e le cartelle che contengono i documenti indicizzati. Se i percorsi relativi non vengono modificati, in seguito allo spostamento della raccolta indicizzata di documenti non sarà necessario creare di nuovo l’indice. Se il file PDX e le cartelle contenenti i documenti indicizzati si trovano nella stessa cartella, per mantenere il percorso relativo sarà sufficiente spostare tale cartella.

Se invece i percorsi relativi vengono modificati, lo spostamento della raccolta indicizzata di documenti rende necessaria la creazione di un nuovo indice. Tuttavia sarà ancora possibile utilizzare il file PDX originale. Per usare il file PDX originale, spostare prima i documenti indicizzati. Quindi, copiare il file PDX nella cartella in cui si desidera creare il nuovo indice e aggiornare opportunamente gli elenchi di inclusione e di esclusione di directory e sottodirectory.

Se l’indice risiede in un’unità o in un volume server differente da quello in cui si trova la raccolta di documenti ad esso correlata, lo spostamento della raccolta o dell’indice provocherà l’interruzione del collegamento con l’indice. Se si intende spostare una raccolta di documenti su un altro server di rete oppure su un CD, creare l’indice nella stessa posizione in cui si trova la raccolta.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online