Oktatóvideó: Kapcsolt intelligens objektumok

Oktatóvideó: Kapcsolt intelligens objektumok
Infinite Skills

Az intelligens objektumok ismertetése

Az intelligens objektumok olyan rétegek, amelyek raszterképek vagy vektorképek, például Photoshop- vagy Illustrator-fájlok képadatait tartalmazzák. Az intelligens objektumok megőrzik a kép eredeti tartalmát és valamennyi eredeti jellemzőjét, így visszafordítható módon szerkesztheti a réteget.

A Photoshop CC és CS6 szoftverben lehetősége van képek tartalmát Photoshop-dokumentumokba beágyazni. A Photoshop CC programban emellett kapcsolt intelligens objektumokat is létrehozhat, amelyek tartalmára a program külső képfájlokból hivatkozik. A kapcsolt intelligens objektumok tartalmát a program frissíti, ha a forrásként használt képfájl módosul.

A kapcsolt intelligens objektumok nem tévesztendők össze az intelligens objektumok Photoshop-dokumentumon belüli duplikált példányaival. A kapcsolt intelligens objektumok segítségével közös forrásfájlt használhat több Photoshop-dokumentumban, ami a webes tervezők számára ismerős és kedvelt koncepció.

Az intelligens objektumok előnyei

Az intelligens objektumok az alábbiakra nyújtanak lehetőséget:

  • Visszafordítható átalakítások végrehajtása. A réteg az eredeti képadatok és képminőség elvesztése nélkül méretezhető, elforgatható, dönthető, torzítható, perspektivikusan átalakítható és hajlítható, mivel az átalakítások nem érintik az eredeti képadatokat.

  • Vektoradatok, például az Illustrator alkalmazásból származó vektoralakzatok használata, melyek máskülönben raszterképpé lennének alakítva a Photoshop programban.

  • Szűrés visszafordítható módon. Az intelligens objektumokon alkalmazott szűrők bármikor szerkeszthetők.

  • Egy intelligens objektum szerkesztése és az összes hozzá kapcsolt példány automatikus frissítése.

  • Az intelligens objektum rétegéhez kapcsolt, illetve nem ahhoz kapcsolt rétegmaszk alkalmazása.

  • Különböző tervek kipróbálása kis felbontású helyőrző képekkel, amelyeket később a végleges verziókra cserélhet.

Közvetlenül az intellingensobjektum-rétegen csak akkor hajthatók végre a képpontadatokat megváltoztató módosítások – például festés, fakítás, színégetés és klónozás –, ha előbb normál réteggé konvertálja azt, és ezt a réteget a program raszterizálja. Ha olyan műveleteket szeretne végrehajtani, amelyek megváltoztatják a képpontadatokat, szerkesztheti az intelligens objektum tartalmát, új réteget klónozhat az intelligensobjektum-réteg felett, szerkesztheti az intelligens objektum másolatait vagy pedig új réteget hozhat létre.

Megjegyzés:

Ha olyan intelligens objektumot alakít át, amelyen intelligens szűrő van alkalmazva, a Photoshop kikapcsolja a szűrőeffektusokat az átalakítás végrehajtása közben. Az átalakítás végeztével azután újra alkalmazza a szűrőeffektusokat. Lásd: Intelligens szűrők alkalmazása.

Photoshop – Intelligens objektumok előnyei
Normál réteg és intelligens objektum a Rétegek panelen. A bélyegkép jobb alsó sarkában látható ikon az intelligens objektum jele.

Photoshop – Kapcsolt intelligens objektum a Rétegek panelen
(Photoshop CC) Kapcsolt intelligens objektum a Rétegek panelen

Beágyazott intelligens objektumok létrehozása

Többféle módon hozhat létre beágyazott intelligens objektumokat: a Megnyitás intelligens objektumként paranccsal, fájl elhelyezésével (CS6) vagy fájl beágyazottként történő elhelyezésével (CC, CS6), adatok beillesztésével az Illustrator alkalmazásból, illetve egy vagy több Photoshop-réteg intelligens objektummá konvertálásával.

  1. Tegye az alábbiak egyikét:
    • (CC) A Fájl menü Elhelyezés beágyazottként parancsával importáljon fájlokat intelligens objektumként a megnyitott Photoshop-dokumentumba.
    • Kattintson a Fájl menü Megnyitás intelligens objektumként parancsára, jelölje ki a fájlt, és kattintson a Megnyitás gombra.
    • (CS6) A Fájl menü Elhelyezés parancsával importáljon fájlokat intelligens objektumként a megnyitott Photoshop-dokumentumba.

    Megjegyzés:

    JPEG-fájlokat is elhelyezhet, de jobb PSD-, TIFF vagy PSB-fájlokat választani, mivel így hozzáadhat rétegeket, módosíthatja a képpontokat és veszteség nélkül mentheti újra a fájlt. (A módosított JPEG-fájlok mentéséhez össze kell olvasztani az új rétegeket és újra kell tömöríteni a képet, ezáltal romlik a kép minősége).

    • A kijelölt réteg intelligens objektummá konvertálásához mutasson a Réteg menü Intelligens objektum pontjára, és kattintson a Konvertálás intelligens objektummá parancsra.
    • A Bridge alkalmazásban mutasson a Fájl menü Elhelyezés pontjára, és kattintson a Photoshopban parancsra a fájl intelligens objektumként való importálásához a megnyitott Photoshop-dokumentumba.

    Megjegyzés:

    A Camera Raw fájlok könnyen kezelhetők, ha intelligens objektumként nyitja meg őket. A Camera Raw beállítások módosításához bármikor duplán kattinthat a nyers fájlt tartalmazó intelligensobjektum-rétegre.

    A Kép intelligens objektumként való megnyitása című videóból megtudhatja, hogyan.

    • Jelöljön ki egy vagy több réteget, majd a Réteg menüben mutasson az Intelligens objektumok pontra, és kattintson a Konvertálás intelligens objektummá parancsra. Ekkor a rétegek egyetlen intelligens objektumban egyesülnek.

    • Húzza át a PDF- vagy Adobe Illustrator-rétegeket vagy objektumokat a Photoshop-dokumentumba.

    • Illesszen be rajzelemet az Illustrator alkalmazásból a Photoshop-dokumentumba, és válassza az Intelligens objektum lehetőséget a Beillesztés párbeszédpanelen. A nagyobb rugalmasság érdekében engedélyezze a PDF és az AICB (nincs átlátszóság támogatás) lehetőséget az Adobe Illustrator Beállítások párbeszédpanelének Fájlkezelés és vágólap csoportjában.

Kapcsolt intelligens objektumok létrehozása | Photoshop CC

Megjegyzés:

A Kapcsolt intelligens objektum funkció a Photoshop 14.2-es és újabb verzióiban érhető el (Photoshop CC | 2014. január).

A Photoshop CC programban kapcsolt intelligens objektumokat hozhat létre. A kapcsolt intelligens objektumok tartalmát a program frissíti, ha a forrásként használt képfájl módosul. A kapcsolt intelligens objektumok különösen hasznosak a csoportos munka során, illetve abban az esetben, ha több tervben újrafelhasznált forrásokkal dolgozik.

Kapcsolt intelligens objektumot a következőképpen hozhat létre:

  1. Kattintson a Fájl > Elhelyezés kapcsoltként menüpontra.
  2. Jelölje ki a megfelelő fájlt, és kattintson az Elhelyez parancsra.

A program létrehozza a kapcsolt intelligens objektumot, amely kapcsolatot jelző ikonnal () jelenik meg a Rétegekpanelen.

Megjegyzés:

A megnyitott dokumentumokban úgy is létrehozhat kapcsolt intelligens dokumentumot, ha a dokumentumba húzza a megfelelő fájlt a következő billentyűk lenyomása mellett:

(Windows) Alt billentyű
(Mac OS rendszerben) Option billentyű

Az alapértelmezett működést a Beállítások > Általános > Elhelyezéskor mindig hozzon létre intelligens objektumokat beállítás kikapcsolásával tudja módosítani.

Kisebb fájlméret kapcsolt intelligens dokumentumokkal

Mivel a kapcsolt intelligens dokumentumok külső fájlhoz tartanak fenn függőséget, és nem a forrásfájl ágyazódik be az objektumot tartalmazó dokumentumba, használatuk gyakran jóval kisebb fájlméretet eredményez. A kapcsolt intelligens dokumentumok nem tárolják az eredeti fájlt az őket tartalmazó dokumentumban, azonban tárolják az eredeti fájl képadatainak egy összeolvasztott, méretezett verzióját. Bizonyos esetekben a ezeknek az adatoknak a mérete sokkal nagyobb is lehet az eredeti fájl méreténél, ekkor úgy tűnhet, hogy elhanyagolható a fájlméreten látható megtakarítás.

Kapcsolt intelligens objektumok frissítése

Ha módosul valamelyik külső forrásfájl, miközben az arra hivatkozó Photoshop-dokumentum meg van nyitva, a program automatikusan frissíti a megfelelő kapcsolt intelligens objektumot. Ugyanakkor ha szinkronizálatlan kapcsolt intelligens objektumokat tartalmazó Photoshop-dokumentumot nyit meg, frissítheti az intelligens objektumokat:

  • Kattintson jobb egérgombbal a kapcsolt intelligens objektum rétegére, és kattintson a Módosított tartalom frissítése parancsra.
  • A Réteg menü Intelligens objektumok pontjában kattintson a Módosított tartalom frissítése parancsra.

A program a Rétegekpanelen vizuálisan is jelöli azokat a kapcsolt intelligens objektumokat, amelyek forrásképe módosult:

Photoshop – Szinkronizálatlan kapcsolt intelligens objektumok kiemeléssel jelölve a Rétegek panelen
A szinkronizálatlan kapcsolt intelligens objektumokat a program kiemeléssel jelöli a Rétegek panelen.

Megjegyzés:

Az aktuális Photoshop-dokumentumban a Réteg > Intelligens objektumok > Az összes módosított tartalom frissítése
menüpontra kattintva frissítheti az összes kapcsolt intelligens objektumot.

Photoshop _ A hiányzó külső forrásfájllal rendelkező kapcsolt intelligens objektumokat a program kiemeléssel jelöli a Rétegek panelen
A hiányzó külső forrásfájllal rendelkező kapcsolt intelligens objektumokat a program a fenti módon jelöli a Rétegek panelen.

Megjegyzés:

A kapcsolt intelligens objektumok módosításainak keresésekor és a kapcsolt intelligens objektumok frissítésekor a Photoshop csak a közvetlenül kapcsolt fájlt vizsgálja. Az intelligens objektumokba ágyazott hivatkozásokat nem frissíti.

Megszakadt hivatkozás feloldása intelligens objektumban

A hiányzó külső forrásfájlú intelligens objektumok megszakadt hivatkozásainak feloldásához kövesse az alábbi lépéseket:

  1. Kattintson a jobb gombbal a kapcsolt intelligens hivatkozás rétegikonjára, és válassza a Megszakadt hivatkozás feloldása lehetőséget.
  2. Navigáljon a hiányzó objektum új helyére.
  3. Válassza az Elhelyez lehetőséget.

Kapcsolt intelligens objektum tulajdonságainak megtekintése

Jelölje ki a Rétegek panelen a kapcsolt intelligens objektum rétegét, majd válassza az Ablak menü Tulajdonságok elemét.

A program a következő tulajdonságokat jeleníti meg:

  • A kapcsolt intelligens objektum külső forrásfájljának elérési útvonala
  • A kapcsolt intelligens objektum mérete és elhelyezkedési koordinátái (X, Y)

A Tulajdonságok párbeszédpanelről a következő műveletek hajthatók végre:

  • A külső képfájl tartalmának szerkesztése. Szükség esetén a Photoshop megnyit egy külső alkalmazást, amely képes kezelni a forrásként használt képfájlt. Ha például a külső forrás-képfájl .ai fájl, a Photoshop megnyitja az Adobe Illustrator programot.
  • A kapcsolt intelligens objektum beágyazása az aktuális dokumentumba.

Kapcsolt intelligens objektumok beágyazása

Tegye az alábbiak egyikét:

  • Kattintson jobb egérgombbal valamelyik kapcsolt intelligens objektum rétegére a Rétegek panelen, és kattintson a Kapcsolt beágyazása parancsra.
  • A Réteg menü Intelligens objektumok pontjában kattintson a Kapcsolt beágyazása parancsra.
  • A Tulajdonságok panelen kattintson a Beágyazás parancsra.

Megjegyzés:

A Réteg > Intelligens objektumok > Az összes kapcsolt beágyazása menüpontra kattintva beágyazhatja a Photoshop-dokumentum összes kapcsolt intelligens objektumát.

Kapcsolt intelligens objektumok csomagolása

A kapcsolt intelligens objektumokat Photoshop-dokumentumba csomagolhatja úgy, hogy forrásfájljaik a számítógépen vannak mentve egy mappába. A program a Photoshop-dokumentum másolatát is menti a mappába, a forrásfájlok mellé.

  1. Kattintson a Fájl > Csomag parancsra.
  2. Válassza ki, hogy hol szeretné elhelyezni a forrásfájlokat és a Photoshop-dokumentum másolatát.

A dokumentum kapcsolt intelligens objektumaiba ágyazott esetleges hangfájlok vagy videók is a csomagba kerülnek.

Megjegyzés:

A fájlokat az őket tartalmazó kapcsolt intelligens objektumok csomagolása előtt menteni kell.

Így keresi meg a Photoshop a kapcsolt fájlokat

A Photoshop mindig a legfrissebb ismert relatív helyen keresi a kapcsolt fájlokat. Ha a kapcsolt fájl nem található ezen a helyen, a Photoshop a következőképp keresi:

  • Az utolsó ismert abszolút helyen
  • Mentett alias használata (csak Mac OS rendszerben)
  • Az objektumot tartalmazó dokumentum mappájában

E viselkedés révén minimális a kockázata annak, hogy a fájlok és projektmappák áthelyezése, másolása és megosztása megszakadt hivatkozásokat eredményezzen.

Megjegyzés:

A hiányzó eszközök feloldására szolgáló párbeszédpanel mindig a hiányzó forrásfájlok legutolsó ismert elérési útvonalát jeleníti meg.

Beágyazott intelligens objektumok konvertálása kapcsolt intelligens objektummá

A beágyazott intelligens objektumokat kapcsolt intelligens objektummá konvertálhatja. Az átalakításokat, szűrőket és a beágyazott intelligens objektumra alkalmazott többi effektust a program megőrzi a konvertálás során.

Tegye az alábbiakat:

  1. Jelölje ki egy beágyazott intelligens objektum rétegét a Photoshop-dokumentumban.
  2. A Réteg menü Intelligens objektumok pontjában kattintson a Kapcsolttá alakítás parancsra.
  3. Válassza ki, hogy hová szeretné menteni a forrásfájlt a számítógépén. Adja meg a fájl nevét, támogatott kiterjesztéssel együtt. Például: hivatkozott_fajl.jpg.

A Rétegek panel szűrése intelligens objektumok alapján | Photoshop CC

  1. A Rétegek panelen válassza az Intelligens objektumok lehetőséget a szűrésre szolgáló legördülő listában.
Photoshop – Rétegek szűrése intelligens objektumok alapján
Rétegek szűrése intelligens objektumok alapján

  1. Kattintson az alábbi ikonok egyikére:
  •  Filter for up-to-date Linked Smart Objects
    Naprakész kapcsolt intelligens objektumok szűrése
  •  Szinkronizálatlan kapcsolt intelligens objektumok szűrése
  •  Hiányzó kapcsolt intelligens objektumok szűrése
  •  Beágyazott intelligens objektumok szűrése

Megjegyzés:

A kapcsoló () segítségével kikapcsolhatja a rétegek szűrését.

Másolat készítése beágyazott intelligens objektumról

  1. A Rétegek panelen jelöljön ki egy intelligensobjektum-réteget, majd hajtsa végre az alábbiak valamelyikét:
    • Ha olyan másolatot szeretne készíteni az intelligens objektumról, amely össze van kapcsolva az eredetivel, mutasson a Réteg menü Új pontjára, és kattintson a Réteg létrehozása másolással parancsra, vagy húzza az intelligensobjektum-réteget a Rétegek panel alján található Új réteg létrehozása ikonra. Az eredetin végrehajtott módosítások a másolatra is vonatkoznak, és viszont.

    • Ha olyan másolatot szeretne készíteni az intelligens objektumról, amely nem kapcsolódik az eredetihez, mutasson a Réteg menü Intelligens objektum pontjára, és kattintson az Új intelligens objektum másolással parancsra. Az eredetin végrehajtott módosítások nem érintik a másolatot.

    Új intelligens objektum jelenik meg a Rétegek panelen, melynek neve azonos az eredetivel, a „másolata” utótaggal kiegészítve.

Intelligens objektum tartalmának szerkesztése

Intelligens objektum szerkesztésekor a forrástartalom vagy a Photoshop programban (ha a tartalom raszteradat vagy Camera Raw-fájl), vagy pedig az elhelyezett fájl formátumát alapértelmezés szerint kezelő alkalmazásban (például az Adobe Illustrator vagy az Adobe Acrobat programban) nyílik meg. A forrástartalom mentésekor a módosítások az intelligens objektum valamennyi kapcsolt példányában megjelennek a Photoshop-dokumentumban.

  1. A Rétegek panelen jelölje ki az intelligensobjektum-réteget, majd hajtsa végre az alábbiak valamelyikét:
    • Mutasson a Réteg menü Intelligens objektumok pontjára, és kattintson a Tartalom szerkesztése parancsra.
    • Kattintson duplán az intelligens objektum bélyegképére a Rétegek panelen.
    • A Tulajdonságok panelen kattintson a Tartalom szerkesztése parancsra.
  2. Kattintson az OK gombra ismét az párbeszédpanel bezárásához.
  3. Hajtsa végre a szerkesztési műveleteket a forrástartalom fájlján, majd kattintson a Fájl menü Mentés parancsára.

    A Photoshop frissíti az intelligens objektumot, így az tükrözi a végrehajtott módosításokat. (Ha a módosítások nem láthatók, aktiválja az intelligens objektumot tartalmazó Photoshop-dokumentumot.)

Intelligens objektum tartalmának cseréje

Kicserélheti egy intelligens objektum vagy több összekapcsolt példány képadatait. Ezzel a funkcióval gyorsan frissíthet egy vizuális tervet, vagy a kisfelbontású helyőrző képeket végleges verziókra cserélheti.

Megjegyzés:

Az intelligens objektum cseréjekor az első intelligens objektumon alkalmazott méretezés, hajlítás és effektusok megmaradnak.

  1. Jelölje ki az intelligens objektumot, majd a Réteg menüben mutasson az Intelligens objektumok pontra, és kattintson a Tartalom cseréje parancsra.
  2. Keresse meg a használni kívánt fájlt, és kattintson az Elhelyez gombra.
  3. Kattintson az OK gombra.

    A program elhelyezi az új tartalmat az intelligens objektumban.

Beágyazott vagy kapcsolt intelligens objektum réteggé alakítása

Az intelligens objektum normál réteggé alakítása esetén a tartalom az aktuális méretében lesz raszterizálva. Csak akkor alakítsa normál réteggé az intelligens objektumot, ha már nem szeretné szerkeszteni az intelligens objektum adatait. Az intelligens objektumon alkalmazott átalakítások, hajlítások és szűrők az intelligens objektum raszterizálása után már nem módosíthatók.

  • Jelölje ki az intelligens objektumot, majd kattintson a Réteg > Intelligens objektumok > Raszterizálás menüpontra.

Megjegyzés:

Ha újra létre szeretné hozni az intelligens objektumot, jelölje ki újra az eredeti rétegeit, és kezdje elölről. Az új intelligens objektum nem őrzi meg az eredeti intelligens objektumon alkalmazott átalakításokat.

Beágyazott intelligens objektum tartalmának exportálása

  1. Jelölje ki az intelligens objektumot a Rétegek panelen, majd a Réteg menüben mutasson az Intelligens objektumok pontra, és kattintson a Tartalom exportálása parancsra.
  2. Válassza ki az intelligens objektum tartalmának helyét, és kattintson a Mentés gombra.

    A Photoshop az eredeti elhelyezési formátumában (JPEG, AI, TIF, PDF vagy más formátum) exportálja az intelligens objektumot. Ha az intelligens objektum rétegekből jött létre, akkor PSB-formátumban lesz exportálva.

Ez a munka a Creative Commons Nevezd meg!-Ne add el!-Így add tovább! 3.0 Unported licenc alatt lett közzétéve.  A Twitter™ és Facebook közzétételeket a Creative Commons jogi feltételei nem szabályozzák.

Jogi közlemények   |   Online adatvédelmi nyilatkozat