Flash Player'da yürütülebilen slayt gösterisi türünde içerikler oluşturmak için SWF veya FLA'ya dışa aktarabilirsiniz. İki format arasındaki temel farklılık şudur: SWF dosyaları görüntülenmeye hazır ve düzenlenemeyen dosyalardır, FLA dosyaları ise, Adobe Flash Player'da görüntülenmesi için Adobe Flash Professional'da düzenlenmelidir.

SWF

Dışa aktarılan bir SWF dosyası Adobe Flash Player'da görüntülenmeye hazır olmasının yanı sıra sayfa geçişleri, köprüler, filmler, video klipler, animasyon ve gezinme düğmeleri gibi etkileşimli öğeler içerebilir.

FLA

Dışa aktarılan bir FLA dosyasında yalnızca etkileşimli öğeler bulunur. FLA dosyası, SWF'ye dışa aktarılmadan önce sizin veya bir Flash geliştiricisinin dosyaya gelişmiş efektler eklediği Flash Pro'da açılabilir.

Flash'a Dışa Aktarma
Flash'a Dışa Aktarma

A. Doğrudan SWF'ye dışa aktarma B. Flash Professional'da düzenleme için FLA'ya dışa aktarın 

Web için etkileşimli SWF (Flash) dosyaları oluşturma

SWF'ye dışa aktararak, Adobe Flash Player veya bir web tarayıcıda görüntülenmeye hazır etkileşimli bir dosya oluşturursunuz. SWF dosyasında InDesign'da eklenmiş düğmeler, sayfa geçişleri, film ve ses dosyaları, animasyon ve köprüler bulunabilir. SWF'ye dışa aktarma, InDesign belgesine bağlı etkileşimli bir slayt gösterisi veya kitap oluşturmak için iyi bir yöntemdir.

SWF dosyasını oluşturmadan önce belgeyi Flash Pro'da düzenlemek isterseniz SWF yerine FLA olarak dışa aktarın. Bkz. Web için FLA dosyaları oluşturma.

SWF dışa aktarma
SWF dışa aktarma

A. SWF dışa aktarmadan önce InDesign'daki belge B. Web tarayıcıda etkileşimli SWF dosyası 
  1. Flash dışa aktarmaya hazırlamak için InDesign belgesini oluşturun veya düzenleyin. Belgeyi dışa aktarmaya hazırlama hakkında daha ayrıntılı bilgi için bkz. Flash dışa aktarma sorunları.

    • Kullanıcıların dışa aktarılan SWF dosyasında sayfadan sayfaya taşıma yapabilmesine olanak sağlayan gezinme düğmeleri ekleyin. Düğmeleri bir nesne çizip, bu nesneyi Düğmeler panelini (Pencere> Etkileşimli > Düğmeler'i seçin) kullanarak bir düğmeye dönüştürerek oluşturabilirsiniz. Ayrıca, önceden tanımlanmış gezinme düğmelerini belgenize sürüklemek için Örnek Düğmeler panelini kullanabilirsiniz. Bkz. Düğmeler oluşturma.

    • Sıyırma ve erime gibi sayfa geçişleri eklemek için Sayfa Geçişleri panelini (Pencere > Etkileşimli > Sayfa Geçişleri'ni seçin) kullanın. SWF'ye dışa aktarırken, izleyicilerin sayfayı kapatmak için bir sayfa köşesini sürükleyebilmelerine olanak sağlayan Etkileşimli Sayfa Kıvrımı Ekle seçeneğini de seçebilirsiniz.

    • Hareket hazır ayarları eklemek için Animasyon panelini kullanın (Pencere > Etkileşimli > Animasyon'u seçin). Bkz. Animasyon.

  2. Belgeyi SWF formatına dışa aktarmak için Dosya > Dışa Aktar'ı seçin. Kayıt Türü (Windows) veya Format (Mac OS) menüsünden Flash Player'ı (SWF) seçin ve Kaydet'i tıklatın.

  3. SWF Dışa Aktar iletişim kutusunda seçenekleri belirleyin ve Tamam'ı tıklatın. Bkz. SWF dışa aktarma seçenekleri.

Bir SWF dosyasını dışa aktarırken ayrı HTML ve SWF dosyaları oluşturulur. SWF dosyası film veya ses klipleri içeriyorsa, bir Kaynaklar klasörü de oluşturulur. Dosyaları web teslim etmek veya yüklemek için tüm varlıkları gönderdiğinizden emin olun.

SWF dışa aktarma seçenekleri

Aşağıdaki seçenekler SWF Dışa Aktar iletişim kutusunun Genel ve Gelişmiş sekmelerinde görünür.

Dışa Aktar

Geçerli seçimin belgedeki tüm sayfalara mı yoksa bir sayfa aralığına mı dahil edileceğini belirtin. Dışa aktarılan bir PDF'de kullanılmak üzere dışa aktarılan SWF dosyasını kaydetmek istiyorsanız, Seçim seçeneğini belirlemek genellikle faydalı olur. Aralık seçeneğini belirlerseniz, 1'den 7'ye kadar olan sayfaları ve 9. sayfayı yazdırmak için 1-7, 9 sayfa aralığını belirtin. Bkz. Yazdırılacak sayfaları belirtme.

HTML Dosyası Oluştur

SWF dosyasını kayıttan yürüten HTML sayfasını oluşturmak için bu seçeneği belirleyin. Bu seçenek özellikle SWF dosyasının önizlemesini web tarayıcınızda hemen görüntülemek için yararlıdır.

Dışa Aktarmanın ardından SWF'yi Görüntüle

SWF dosyasını varsayılan web tarayıcısında yürütmek için bu seçeneği belirleyin. Bu seçenek yalnızca HTML dosyası oluşturduysanız kullanılabilir.

Boyut (piksel)

SWF dosyasının yüzde kullanılarak belirttiğiniz monitör boyutuna mı sığdırılacağını, yoksa belirttiğiniz genişlik ve yüksekliğe göre mi boyutlandırılacağını belirtin.

Arka Plan

SWF'nizin arka planının saydam mı olacağını yoksa Renk Örnekleri panelinden geçerli Kağıt rengini mi kullanacağını belirtin. Saydam seçeneğini belirlemek Sayfa Geçişleri ve Etkileşimli Sayfa Kıvrımı seçeneklerini devre dışı bırakır.

Etkileşim ve Ortam

Dışa aktarılan SWF dosyasında etkileşimli filmler, sesler, düğmeler ve animasyonlara izin vermek için Tümünü Dahil Et'i seçin. Düğmelerin normal durumunu ve video posterleri statik öğeler olarak dahil etmek için Yalnızca Görünüm'ü seçin. Yalnızca Görünüm seçiliyse, animasyonlar dışa aktarma sırasında mizanpajda göründükleri gibi dışa aktarılır. Gelişmiş panelinden Saydamlığı Düzleştir'i seçerseniz, Yalnızca Görünüm seçilir.

Sayfa Geçişleri

Dışa aktarma sırasında tüm sayfalara uygulanacak bir sayfa geçişi belirtin. Geçişleri belirtmek için Sayfa Geçişleri panelini kullanıyorsanız, bu ayarları kullanmak için Belgeden seçeneğini kullanın.

Etkileşimli Sayfa Kıvrımını Dahil Et

Bu seçenek seçiliyse, SWF dosyası oynatan kullanıcılar sayfayı çevirmek için sayfanın köşesini sürükleyebilir; böylece gerçek sayfa çevriliyormuş görüntüsü sağlanır.

Kare Hızı

Daha yüksek kare hızı daha düzgün animasyonlar oluşturur ancak dosyanın boyutu büyüyebilir. Kare hızını değiştirmek oynatma süresini etkilemez.

Metin

InDesign metni çıktısının nasıl alınacağını belirtin. En küçük dosya boyutunu elde edebileceğiniz bir aranabilir metin çıktısı almak için Flash Klasik Metin'i seçin. Metnin, metni anahatlara dönüştürürken olduğu gibi düz çizgiler dizisi olarak çıktısını almak için Anahatlara Dönüştür'ü seçin. Metnin bir bit eşlem görüntüsünde çıktısını almak için Piksele Dönüştür'ü seçin. Piksele dönüştürülen metin yakınlaştırıldığında pürüzlü görünebilir.

Sayfaları Rasterleştir

Bu seçenek tüm InDesign sayfası öğelerini bit eşlem olarak dönüştürür. Bu seçeneğin belirlenmesi daha büyük SWF dosyasın neden olur ve sayfa öğeleri yakınlaştırma açıkken pürüzlü görünür.

Saydamlığı Düzleştir

Bu seçenek, canlı saydamlığı SWF'den kaldırır ve saydamlık görünümünü korur. Ancak, bu seçenek seçildiyse, dışa aktarılan SWF dosyasındaki tüm etkileşim kaldırılır.

Sıkıştırma

InDesign'ın renkli ve gri tonlamalı görüntüler için en iyi kaliteyi belirlemesi için Otomatik'i seçin. Çoğu dosya için bu seçenek tatmin edici sonuçlar verir. JPEG (Kayıplı) seçilmesi gri tonlu ve renkli görüntüler için uygundur. JPEG sıkıştırması kayıplıdır, diğer bir deyişle görüntü verilerini siler ve görüntü kalitesini düşürebilir. Ancak, dosya boyutunu en az bilgi kaybıyla küçültmeyi dener. JPEG sıkıştırması verileri attığından, daha küçük dosya boyutları elde edebilir. PNG (Kayıpsız) seçilmesi dosyayı kayıplı sıkıştırma olmadan dışa aktarır.

Not:

SWF'ye dışa aktardığınızda saydam görüntülerin görüntü kalitesinde kayıp olduğunu fark ederseniz kaliteyi artırmak için PNG (Kayıpsız) seçeneğini belirleyin.

JPEG Kalitesi

Dışa aktarılan görüntüdeki ayrıntı miktarını belirler. Kalite ne kadar yüksek olursa, dosya boyutu da o kadar büyük olur. Sıkıştırma için PNG (Kayıpsız) seçeneğini seçerseniz, bu seçenek soluklaşır.

Çözünürlük

Dışa aktarılan SWF'deki bit eşlem görüntülerinin çözünürlüğünü belirtin. İzleyicilerin dışa aktarılan SWF'nize piksel tabanlı yakınlaştırma yapmasına olanak sağlamak için yüksek bir çözünürlük seçilmesi özellikle önemlidir. Yüksek bir çözünürlük seçilmesi dosya boyutunu önemli derecede büyütür.

Web için FLA belgeleri oluşturma

InDesign belgenizi FLA dosya formatına dışa aktardığınızda, içeriğini düzenlemek amacıyla dosyayı Adobe Flash® CS5 Professional'da açabilirsiniz. InDesign CS5 formatında FLA'ya dışa aktarma InDesign CS4'teki XFL dışa aktarma gibidir. Video, ses, animasyon ve karmaşık etkileşim düzenlemek ve eklemek için Flash geliştirme ortamını kullanın.

InDesign belgesini doğrudan bir web tarayıcısında açılabilen formata dışa aktarmak isterseniz FLA yerine SWF formatını kullanın. Bkz. Web için etkileşimli SWF (Flash) dosyaları oluşturma.

FLA dışa aktarma
FLA dışa aktarma

A. FLA dışa aktarmadan önce InDesign'daki belge B. Flash Pro'da açık FLA dosyası 
  1. Flash dışa aktarmaya hazırlamak için InDesign belgesini oluşturun veya düzenleyin. Belgeyi dışa aktarmaya hazırlama hakkında daha ayrıntılı bilgi için bkz. Flash dışa aktarma sorunları.

  2. Belgeyi FLA formatına dışa aktarmak için Dosya > Dışa Aktar'ı seçin. Kayıt türü (Windows) veya Format (Mac OS) menüsünden Flash CS5 Professional'ı (FLA) seçin ve Kaydet'i tıklatın.

  3. Flash CS5 Pro (FLA) Dışa Aktar iletişim kutusunda seçenekleri belirleyip Tamam'ı tıklatın. Dışa aktarma seçenekleri hakkında daha fazla bilgi için bkz. FLA dışa aktarma seçenekleri.

  4. Flash Professional uygulamasında, dışa aktarılmış FLA dosyasını açın.

FLA dışa aktarma seçenekleri

Flash CS5 Professional (FLA) Dışa Aktar iletişim kutusunda aşağıdaki seçenekler bulunur.

Dışa Aktar

Geçerli seçimin belgedeki tüm sayfalara mı yoksa bir sayfa aralığına mı dahil edileceğini belirtin. Aralık seçeneğini belirlerseniz, 1'den 7'ye kadar olan sayfaları ve 9. sayfayı yazdırmak için 1-7, 9 sayfa aralığını belirtin. Bkz. Yazdırılacak sayfaları belirtme.

Sayfaları Rasterleştir

Bu seçenek tüm InDesign sayfası öğelerini bit eşlem olarak dönüştürür. Bu seçeneğin belirlenmesi daha büyük bir FLA dosyasına neden olur ve yakınlaştırma açık olduğunda sayfa öğeleri pürüzlü görünür.

Saydamlığı Düzleştir

Bu seçeneğin belirlenmesi saydamlığı olan tüm nesneleri düzleştirir. Düzleştirilen nesnelerin Adobe Flash Pro'da hareketlendirilmesi zor olabilir.

Boyut (Piksel)

FLA dosyasının bir yüzdeye göre mi yoksa belirttiğiniz bir monitöre sığdırma boyutuna mı yoksa genişlik ve yüksekliğe göre mi ölçeklendirileceğini belirtin.

Etkileşim ve Ortam

Dışa aktarılan SWF dosyasında filmler, sesler, düğmeler ve animasyonlara izin vermek için Tümünü Dahil Et'i seçin. Belgede bir çoklu durum nesnesi varsa, her durum zaman çizelgesinde kendi çerçevesinde görünen bir film klibi sembolüne dönüştürülecektir.

Düğmelerin normal durumunu ve video posterleri statik öğeler olarak dahil etmek için Yalnızca Görünüm'ü seçin. Yalnızca Görünüm seçiliyse, animasyonlar dışa aktarma sırasında mizanpajda göründükleri gibi dışa aktarılır. Saydamlığı Düzleştir'i seçerseniz, Yalnızca Görünüm seçilir.

Metin

InDesign metni çıktısının nasıl alınacağını belirtin. Flash Professional uygulamasındaki zengin Metin Mizanpajı Çerçevesi niteliklerinden yararlanmak için Flash TLF Metni'ni seçin. Bu seçenek seçiliyse, tirelemeye izin vermek için Sözlük Tireleme Noktaları Ekle'yi seçin. Daha küçük bir dosya boyutu elde edebileceğiniz bir aranabilir metin çıktısı almak için Flash Klasik Metin'i seçin. Metnin, metni anahatlara dönüştürürken olduğu gibi düz çizgiler dizisi olarak çıktısını almak için Anahatlara Dönüştür'ü seçin. Metnin bir bit eşlem görüntüsünde çıktısını almak için Piksele Dönüştür'ü seçin. Piksele dönüştürülen metin yakınlaştırıldığında pürüzlü görünebilir.

Sıkıştırma

InDesign'ın renkli ve gri tonlamalı görüntüler için en iyi kaliteyi belirlemesi için Otomatik'i seçin. Çoğu dosya için bu seçenek tatmin edici sonuçlar verir. JPEG (Kayıplı) seçilmesi gri tonlu ve renkli görüntüler için uygundur. JPEG sıkıştırması kayıplıdır, diğer bir deyişle görüntü verilerini siler ve görüntü kalitesini düşürebilir. Ancak, dosya boyutunu en az bilgi kaybıyla küçültmeyi dener. JPEG sıkıştırması verileri attığından, daha küçük dosya boyutları elde edebilir. PNG (Kayıpsız) seçilmesi dosyayı kayıplı sıkıştırma olmadan dışa aktarır.

JPEG Kalitesi

Dışa aktarılan görüntüdeki ayrıntı miktarını belirler. Kalite ne kadar yüksek olursa, dosya boyutu da o kadar büyük olur. Sıkıştırma için PNG (Kayıpsız) seçeneğini seçerseniz, bu seçenek soluklaşır.

Çözünürlük

Dışa aktarılan FLA dosyasındaki bit eşlem görüntülerinin çözünürlüğünü belirtin. İzleyicilerin piksel tabanlı yakınlaştırma yapmasına olanak sağlamak için yüksek bir çözünürlük seçilmesi özellikle önemlidir. Yüksek bir çözünürlük seçilmesi dosya boyutunu önemli derecede büyütür.

Flash dışa aktarma sorunları

InDesign belgenizi SWF veya FLA çıktısı için tasarlarken aşağıdakileri göz önünde bulundurun.

Belge ayarı sorunları

InDesign sayfalarını dönüştürme

SWF ve FLA'ya dışa aktardığınızda InDesign formaları, slayt gösterisindeki slaytlar gibi, zaman çizelgesinde ayrı klipler haline gelir. Her forma yeni anahtar çerçeveyle eşleşir. Flash Player'da ok tuşlarına basarak veya etkileşimli düğmeleri tıklatarak dışa aktarılan belgenin formalarında ilerlersiniz.

Not:

Web için belge oluştururken, Yeni Belge iletişim kutusundaki Hedef menüsünden Web'i seçin.

Sayfa boyutu

Belge oluştururken Yeni Belge iletişim kutusundaki Sayfa Boyutu menüsünden 800 x 600 gibi belirli bir çözünürlük seçebilirsiniz. Dışa aktarma sırasında, dışa aktarılan SWF veya FLA dosyasının ölçeğini ya da çözünürlüğünü ayarlayabilirsiniz.

Etkileşim özellikleri

Düğmeler, sayfa geçişleri, köprüler, animasyon ve ortam dosyaları, dışa aktarılan SWF ve FLA dosyalarına dahil edilebilir.

Düğmeler

Dışa aktarılan SWF veya FLA dosyasındaki düğmeler, Sonraki Sayfa ve Önceki Sayfa eylemleri özellikle Flash Player'da oynatmak için yararlı kontrollerdir. Ancak, etkileşimli PDF dosyalarında çalışan bazı eylemlerin Flash Player'da hiç etkisi yoktur. Düğmeler panelinden bir eylem seçtiğinizde, Yalnızca PDF kısmındaki seçeneklerden herhangi birini seçmeyin.

Not:

Sonraki Sayfaya Git ve Önceki Sayfaya Git eylemleriyle önceden biçimlendirilmiş gezinme düğmeleri ekleyebilirsiniz. Düğmeler panel menüsünden Örnek Düğmeler'i seçin. Bkz. Örnek Düğmeler panelinden düğme ekleme.

Sayfa Geçişleri

Tüm sayfa geçişleri Flash Player'da düzgün çalışır. Sayfayı döndürdüğünüzde görüntülenen sayfa geçişlerine ek olarak, sayfaları döndürmek için köşelerini sürüklemenizi sağlayan etkileşimli sayfa kıvrımını da dışa aktarma sırasında ekleyebilirsiniz.

Köprüler

Web sitelerine ve belgedeki diğer sayfalara bağ oluşturur. Köprüler FLA dosyalarında bozuktur.

Filmler ve ses klipleri

Filmler ve ses klipleri, filmler için SWF, FLV, F4V ve MP4; ses klipleri için de MP3 gibi desteklenen formatlardaysa dışa aktarılan SWF dosyasına dahil edilirler.

FLA'ya dışa aktardığınızda, FLA dosyasına yalnızca poster görüntü dahil edilir. Desteklenen ortam dosyaları, dışa aktarılan FLA dosyasıyla aynı konuma kaydedilmiş bir kaynaklar klasöründe görünür.

Dönüştürme sorunları

Renk

SWF ve FLA dosyaları RGB rengi kullanır. Belge SWF veya FLA'ya dışa aktarıldığında, InDesign tüm renk uzaylarını (CMYK ve LAB gibi) sRGB'ye dönüştürür. InDesign spot renkleri eşdeğerdeki RGB proses renklerine dönüştürür.

Saydamlığı olan metnin bulunduğu resimde istenmeyen renk değişikliklerinden kaçınmak için Düzen > Saydam Karıştırma Alanı > Belge RGB'yi seçin. Saydamlık kullanılan görüntülerde istenmeyen renk değişimlerinin önüne geçmek için dışa aktarma sırasında kayıplı sıkıştırma kullanmaktan kaçının.

Metin

SWF veya FLA'ya dışa aktarırken, metinlerin Flash metni olarak kaydedilmesi yerine anahatlara veya piksellere dönüştürülmesini seçebilirsiniz. FLA dosyası Adobe Flash CS5 Professional uygulamasında açıldığında, Flash metni olarak dışa aktarılan metin tümüyle düzenlenebilecek şekilde kalır; SWF dosyası olarak kaydedildiğindeyse, web tarayıcılarda aranabilir.

Görüntüler

Görüntüleri SWF veya FLA'ya dışa aktarırken, görüntü sıkıştırmasını, JPEG kalitesini ve çözünürlük ayarlarını dışa aktarma sırasında değiştirebilirsiniz.

Görüntüleri FLA'ya dışa aktarırken, InDesign belgenizde birden çok defa yerleştirilmiş görüntüler, paylaşılan bir konumu olan tek bir görüntü olarak kaydedilir. InDesign belgesindeki çok sayıda vektör görüntüsünün dışa aktarılan dosyada performans sorunlarına neden olabileceğini unutmayın.

Dosya boyutunu küçültmek için yinelenen görüntüleri kalıp sayfalara yerleştirin görüntülerin kopyalanıp yapıştırılmasından kurtulun. Aynı görüntü belgeye birden çok kez yerleştirilir ve dönüştürülmez veya kırpılmazsa, dosyanın yalnızca bir kopyası FLA dosyasına dışa aktarılır. Kopyalanan ve yapıştırılan görüntüler ayrı nesneler gibi davranır.

Varsayılan olarak, yerleştirilmiş Illustrator dosyası FLA dosyasında tek bir görüntü gibi davranırken kopyalanıp yapıştırılan bir Illustrator dosyası birçok tek tek nesne oluşturabilir. En iyi sonucu elde etmek için Illustrator'dan kopyalayıp yapıştırmak yerine Illustrator görüntüsünü PDF dosyası olarak yerleştirin. Sonuçları birden çok düzenlenebilir yolda kopyalama ve yapıştırma.

Not:

Illustrator nesnelerinin bir dizi küçük vektör yerine tek nesne olarak yapıştırılmasını sağlamak için tercih seçeneklerini değiştirebilirsiniz. Illustrator Dosya İşleme ve Pano tercihlerinde PDF'yi seçip AICB (Saydamlık Desteği Yok) seçimini kaldırın. InDesign Pano İşleme tercihlerinde hem Yapıştırırken PDF'yi Tercih Et, hem de PDF'yi Panoya Kopyala'yı seçin.

Saydamlık

SWF'ye dışa aktarmadan önce, saydam nesnelerin düğme ya da köprü gibi etkileşimli öğelerle çakışmadığından emin olun. Saydamlığı olan nesne etkileşimli öğeyle çakışırsa dışa aktarma sırasında etkileşim kaybolabilir. FLA'ya dışa aktarmadan önce saydamlığı düzleştirmeniz gerekebilir.

Bazı durumlarda, kayıplı sıkıştırma seçmek saydamlık kullanılan görüntülerde kaliteyi düşürür. Dışa aktarırken, kaliteyi yükseltmek için PNG (Kayıpsız) formatını seçin.

3D nitelikler

Dışa aktarılan SWF ve FLA dosyalarında 3D nitelikler desteklenmez.

Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi