Tablo, satır ve sütun hücrelerinden oluşur. Hücre, metin, bağlantılı çerçeveler veya diğer tablolar ekleyebileceğiniz metin çerçevesine benzer. Adobe InDesign CS5 uygulamasında tablolar oluşturun veya diğer uygulamalardan dışa aktarın.

Not:

Adobe InCopy uygulamasında tablolar oluşturmak, düzenlemek ve formatlamak için Mizanpaj görünümünde olduğunuzdan emin olun.

Tablolar oluşturma

Tablo, satır ve sütun hücrelerinden oluşur. Hücre, metin, satır içi grafikler veya diğer tablolar ekleyebileceğiniz metin çerçevesine benzer. İlk baştan veya mevcut metinden dönüştürerek tablolar oluşturabilirsiniz. Tablo içine tablo da gömebilirsiniz.

Tablo oluşturduğunuzda yeni tablo, kapsayıcı metin çerçevesinin genişliğini doldurur. Ekleme noktası satırın başlangıcında olduğunda, tablo aynı satıra eklenir veya ekleme noktası satırın ortasında olduğunda sonraki satıra eklenir.

Tablolar, satır içi grafiklerin yaptığı gibi çevreleyen metinle akarlar. Örneğin, tablonun üzerindeki metinin punto boyutu değişirse veya metin eklenmiş veya çıkarılmışsa, tablo, akıtılan çerçeveler boyunca ilerler. Bununla birlikte, tablo yol üzerindeki metin çerçevesinde görüntülenmez.

Michael Murphy, tablo oluşturma ve biçimlendirme hakkında Mind Your Table Manners (Tablolardaki Davranışınıza Dikkat Edin) başlıklı bir makale sunuyor.

InfiniteSkills.com'dan Jeff Witchell Tablo oluşturma temelleri konulu bir video gösterimi sunuyor.

Sıfırdan tablo oluşturma

InDesign'da tablo oluştururken, tabloyu mevcut bir metin çerçevesi içinde oluşturma seçeneğinden yararlanabilirsiniz (Tablo Ekle seçeneğini kullanma). Dilerseniz bir tablo oluşturarak bu tabloyu çevreleyen metin çerçevesini InDesign'ın oluşturmasını sağlayabilirsiniz (Tablo Oluştur seçeneğini kullanma).

Tablo Ekle seçeneğini kullanma

  1. Mevcut bir metin çerçevesinin içine bir tablo çizmek için Yazım aracını kullanarak tablonun görünmesini istediğiniz yere ekleme noktasını yerleştirin.

  2. Tablo > Tablo Ekle'yi seçin.

    Not:

    İmleç o sırada bir metin çerçevesinin içinde değilse Tablo Oluştur seçeneği kullanılabilir durumdadır.

  3. Satır ve sütun sayılarını belirtin.
  4. Tablo içerikleriniz bir veya daha fazla sütun ya da çerçevede devam edecekse, yinelenmesini istediğiniz bilgilerin olacağı üstbilgi veya altbilgi satırlarının sayısını belirtir.
  5. (İsteğe bağlı) Tablo stilini belirtin.
  6. Tamam'ı tıklatın.

    Yeni tablo, metin çerçevesinin genişliğini doldurur.

Tablo Oluştur seçeneğini kullanma

Tablo Oluştur seçeneğini kullanarak tablo oluştururken öncelikle belgenizde bir metin çerçevesi oluşturmanıza gerek yoktur. Belgede tabloyu çizmeye başladığınız anda InDesign çizdiğiniz tablonun boyutunda bir metin çerçevesi oluşturur.

  1. Tablo > Tablo Oluştur'u seçin.

    Not:

    İmleç o sırada bir metin çerçevesinin içindeyse Tablo Ekle seçeneği kullanılabilir durumdadır.

  2. Satır ve sütun sayılarını belirtin.
  3. Tablo içerikleriniz bir veya daha fazla sütun ya da çerçevede devam edecekse, yinelenmesini istediğiniz bilgilerin olacağı üstbilgi veya altbilgi satırlarının sayısını belirtir.
  4. (İsteğe bağlı) Tablo stilini belirtin.
  5. Tamam'ı tıklatın.
  6. Tablo imlecini kullanarak istediğiniz tabloyu çizin.

    InDesign çizilen alanın boyutunda bir metin çerçevesi oluşturur ve tabloyu bu metin çerçevesinin içine yerleştirir.

Tablonun satır yüksekliği, belirtilen tablo stili tarafından belirlenir. Örneğin, tablo stili tablonun farklı bölümlerini biçimlendirmek için hücre stillerini kullanabilir. Bu hücre stillerinden herhangi biri paragraf stilleri içeriyorsa paragraf stillerinin başlangıç değeri, bu alanın satır yüksekliğini belirler. Paragraf stili kullanılmamışsa, belgenin varsayılan bilgisi satır yüksekliğini belirler. (Bilgi, başlangıç değerini temel alır. Bu bağlamda bilgi, seçili metinde vurgulamanın yaklaşık yüksekliğidir.)

Mevcut metinden tablo oluşturma

Metni tabloya dönüştürmeden önce metni doğru ayarladığınızdan emin olun.

  1. Metni dönüştürmek üzere hazırlamak için sekmeler, virgüller, satır başları veya sütunları ayırmak üzere farklı karakter ekleyin. Sekmeler, virgüller, satır başları veya satırları ayırmak üzere farklı karakter ekleyin. (Birçok örnekte, metin düzenlenmek zorunda kalmadan tabloya dönüştürülebilir.)
  2. Yazım aracını  kullanarak tabloya dönüştürmek istediğiniz metni seçin.
  3. Tablo > Metni Tabloya Dönüştür'ü seçin.
  4. Sütun Ayırıcı ve Satır Ayırıcı için yeni satır ve sütunların nerede başlaması gerektiğini belirtin. Sütun Ayırıcı ve Satır Ayırıcı alanında Sekme, Virgül veya Paragraf'ı seçin veya noktalı virgül (;) gibi bir karakter yazın. (Yazdığınız karakter, metinden tablo oluşturduğunuz bir sonraki sefer menüde görüntülenir.)
  5. Aynı ayırıcıyı sütun ve satırlar için belirlediyseniz, tablonun içermesini istediğiniz sütun sayısını belirtin.
  6. (İsteğe bağlı) Tabloyu biçimlendirmek için bir tablo stili belirtin.
  7. Tamam'ı tıklatın.

Satırın tablodaki sütun sayısından daha az öğe sayısına sahipse, boş hücreler satırları doldurur.

Tablo içine tablo gömme

  1. Aşağıdakilerden birini yapın:
    • Gömmek istediğiniz hücreleri veya tabloyu seçin ardından Düzen > Kopyala veya Yapıştır'ı belirleyin. Tablonun görüntülenmesini istediğiniz yere ekleme noktasını yerleştirin ardından Düzen > Yapıştır'ı seçin.

    • Bir hücrenin içini tıklatın, Tablo > Tablo Ekle'yi seçin, satır ve sütunların sayısını belirtin ve Tamam'ı tıklatın.

  2. Hücre iç metnini gerektiği gibi ayarlayın. (Bkz. Tablo içindeki metni formatlama.)

Hücre içinde tablo oluşturuyorsanız, hücre sınırlarından taşan tablonun herhangi bir bölümünü seçmek için fareyi kullanamazsınız. Bunun yerine, sütun veya satırı genişletin veya ekleme noktasını tablonun ilk bölümüne yerleştirin ve ekleme noktasını taşımak ve metni seçmek için klavye kısayollarını kullanın.

Diğer uygulamalardan tabloları içe aktarma

Tablolar içeren Microsoft Word belgesini veya Microsoft Excel çalışma sayfası içe aktarmak için Yerleştir komutunu kullandığınızda, içe aktarılan veriler düzenlenebilir tablodur. Biçimlendirmeyi denetlemek için İçe Alma Seçenekleri iletişim kutusunu kullanabilirsiniz.

Excel çalışma sayfasından veya Word tablosundan InDesign veya InCopy belgesine verileri de yapıştırabilirsiniz. Pano İşleme tercihi ayarları, farklı bir uygulamadan yapıştırılan metnin nasıl biçimlendirileceğini belirler. Salt Metin seçiliyse, bilgiler, daha sonra tabloya dönüştürebileceğiniz biçimlendirilmemiş sekmeli metin olarak görüntülenir. Tüm Bilgiler seçiliyse, yapıştırılan metin biçimlendirilmiş tablo olarak görüntülenir.

Metni başka bir uygulamadan mevcut tabloya yapıştırıyorsanız yapıştırılan metni karşılayacak kadar satır ve sütun ekleyin, Pano İşleme tercihlerinde Salt Metin seçeneğini belirleyin ve (yapıştırılan tabloyu bir hücreye gömmek istemiyorsanız) en az bir hücrenin seçili olduğundan emin olun.

İçe aktarılan tabloların biçimlendirilmesinde daha fazla kontrol sahibi olmak veya çalışma sayfası biçimlendirmesini korumak istersiniz, tabloyu içe aktarmak için Yerleştir komutunu kullanın. Bir çalışma sayfası bağlantısını korumak isterseniz, Dosya İşleme tercihleri ayarlarından Metin ve Çalışma Sayfası Dosyalarını Yerleştirirken Bağlantılar Oluştur'u seçin.

Not:

Tablo hücrelerinin seçimi boyunca sekmeli metni kopyalayabilir ve yapıştırabilirsiniz. Bu teknik, metni biçimini koruyarak değiştirmenin en iyi yoludur. Örneğin, aylık bir dergide bir biçimlendirme tablosunun içeriğini güncelleştirmek istediğinizi varsayın. Bunu yapmanın bir yolu Excel çalışma sayfasını bağlanmak olabilir. Ancak, içeriğiniz farklı bir kaynaktan geliyorsa, yeni içeriğin bulunduğu sekmeli metni kopyalayabilir, biçimlendirilmiş InDesign tablosunda hücre aralığını seçip yapıştırabilirsiniz.

Tabloya metin ekleme

Tablo hücrelerine metin, bağlantılı nesne, XML etiketleri ve diğer tabloları ekleyebilirsiniz. Tablo satırının yüksekliği, siz sabit satır yüksekliği ayarlamadığınız sürece ek metin satırlarına uymak üzere genişler. Tablolara dipnotlar ekleyemezsiniz.

  1. Yazım aracını  kullanarak aşağıdakilerden birini yapın:
    • Ekleme noktasını bir hücreye yerleştirin ve metni yazın. Aynı satırda yeni paragraf oluşturmak için Enter veya Return tuşuna basın. Hücreler arasında ilerlemek için Sekme tuşuna basın (en son satırda Sekme tuşuna basıldığında yeni satır eklenir). Hücreler arasında geriye doğru ilerlemek için Shift+Sekme tuşlarına basın.

    • Metni kopyalayın, bir hücreye ekleme noktasını yerleştirin ve ardından Düzen > Yapıştır'ı seçin.

    • Bir hücrenin içinde metni yerleştirmek istediğiniz yere ekleme noktasını yerleştirin, Dosya > Yerleştir'i seçin ve ardından bir metin dosyasını çift tıklatın.

Tabloya grafik ekleme

  1. Ekleme noktasını, görüntü eklemek istediğiniz tablo hücresinin içine yerleştirin.

  2. Aşağıdakilerden birini yapın:
    • Dosya > Yerleştir'i işaretleyin ve bir veya birkaç grafik dosyası seçin.
    • Grafikler kategorisinden bir veya birkaç grafik seçip sürükleyerek CC Libraries paneline bırakın.

    Görüntü veya görüntüler yerleştirme tabancasında görünür.

  3. Görüntüyü veya görüntüleri yerleştirmek için her tablo hücresinin içini tıklatın.

  4. Aşağıdakilerden birini yapın:

Not:

Grafikler kategorisindeki InDesign parçacıklarını sürükleyerek CC Libraries paneline bırakmak mümkün değildir.

Hücreden daha büyük bir grafik eklediğinizde, hücre yüksekliği grafiğe uymak için genişler ancak hücrenin genişliği değişmez; grafik, sağdaki hücreye genişleyebilir. Grafiğin yerleştirildiği satır için sabit yükseklik belirlenmişse, satır yüksekliğinden daha yüksek olan grafik hücrenin taşmasına neden olur.

Not:

Hücre taşmasını önlemek için resmi tablonun dışına yerleştirip resmi yeniden boyutlandırdıktan sonra tablo hücresine yapıştırın.

Görüntüleri tablo hücrelerine yerleştirmek için şu yöntemleri de kullanabilirsiniz:

  • Nesne > Bağlantılı Nesne > Ekle'yi seçin ve ayarları belirtin. Bağlantılı nesneye daha sonra da grafik ekleyebilirsiniz.
  • Grafiği veya çerçeveyi kopyalayın, ekleme noktasını yerleştirin ve ardından Düzen > Yapıştır'ı seçin.

Tablo üstbilgileri ve altbilgileri ekleme

Uzun bir tablo oluşturduğunuzda, tablo birden fazla sütuna, çerçeveye veya sayfaya yayılabilir. Tablonun bölünen her bölümünün üstünde veya altında bilgilerin yinelenmesi için üstbilgileri veya altbilgileri kullanabilirsiniz.

Tablo oluşturduğunuzda üstbilgi ve altbilgi satırları ekleyebilirsiniz. Üstbilgi ve altbilgi satırları eklemek ve bunların tablodaki görünümlerini değiştirmek için Tablo Seçenekleri iletişim kutusunu da kullanabilirsiniz. Gövde satırlarını üstbilgi veya altbilgi satırlarına dönüştürebilirsiniz.

Tablo üstbilgileri ve altbilgileri ekleme
Çerçeve başına bir kez yinelenen üstbilgi satırları

Not:

Tabloları sırasıyla Tablo 1A, Tablo 1B gibi numaralandırmak için tablo üstbilgisine veya altbilgisine değişken ekleyin. (Bkz. Şekiller ve tablolar için akan başlıklar oluşturma.)

  1. Üstbilgi satırları oluşturmak için tablonun en üstündeki satırları veya altbilgi satırları oluşturmak üzere tablonun en altındaki satırları seçin.
  2. Tablo > Satırları Dönüştür > Üstbilgi veya Altbilgi öğesini seçin.
  1. Ekleme noktasını tabloya yerleştirin ve ardından Tablo > Tablo Seçenekleri > Üstbilgiler Ve Altbilgiler'i seçin.
  2. Üstbilgi veya altbilgi satırlarının sayısını belirtin. Tablonun üstüne veya altına boş satırlar eklenebilir.
  3. Üstbilgi ve altbilgideki bilgilerin her metin sütununda (metin çerçevelerinin birden fazla sütunu varsa), çerçeve başına bir kez veya sayfa başına sadece bir kez mi görüntüleneceğini belirtin.
  4. Üstbilginin tablonun ilk satırında görüntülenmesini istemiyorsanız, İlkini Atla'yı seçin. Altbilginin tablonun son satırında görüntülenmesini istemiyorsanız, Sonuncuyu Atla'yı seçin.

    Üstbilgi veya altbilginin devam edeceğini belirtmek istiyorsanız, Öncekini Atla seçeneği yararlıdır. Örneğin, birden çok sayfaya yayılan bir tablo için üstbilgi metninin "Tablo 2 Devam Edecek" olmasını isteyebilirsiniz. “(Devam Edecek)” bilgisinin tablonun başında görünmesini istemediğinizde, Öncekini Atla'yı seçin ve tablonun ilk satırına yalnızca Tablo 2 yazın.

  5. Tamam'ı tıklatın.

Birbirine benzer satırlar ve sütunlar oluşturmak veya bunları çoğaltmak için yapabileceğiniz birkaç işlem vardır. 

Tablo satırları ve sütunları üzerinde esas olarak şu işlemleri yapabilirsiniz:

  • Aynı tablo içindeki tablo satır ve sütunlarını sürükleyerek bir konumdan diğerine bırakma.
  • Satır ve sütunları çoğaltma.
  • Satır ve sütunları bir satır veya sütunun önüne ya da arkasına yapıştırma
  • Satırdaki içerikleri bir sütuna ya da sütundaki içerikleri bir satıra kopyalama.

Çoğaltılan satır veya sütunları sürükleyip bırakma

Aynı tablo içindeki tablo satır ve sütunlarını bir konumdan diğerine taşıyabilirsiniz. Çoğaltılan satır veya sütunları sürükleyip bırakmak için aşağıdaki adımları uygulayın.

  1. Sürükleyerek başka bir satır veya sütuna bırakmak istediğiniz satır ya da sütunu seçin. Sütun veya satırın tamamının seçildiğinden emin olun. Tamamı seçilmeyen satır ve sütunlar sürüklenip bırakılamaz.

  2. Farenizi seçtiğiniz satırların üzerine getirdiğinizde, seçimin taşınabileceğini belirten benzersiz bir imleç görüntülenir.

  3. Öğe satırı sürüklenip bırakılabilir. Sütunları satırlarla değiştirebilirsiniz. Sürüklenen bir satır yalnızca satır olarak, sürüklenen bir sütun ise yalnızca sütun olarak bırakılabilir.

    Satır ve sütunları sürükleyip bırakma
    Satır ve sütunları sürükleyip bırakma

    Burada, bir satır diğer bir satıra taşındığında, tıpkı işlemden önce olduğu gibi toplam satır sayısı korunuyor (yalnızca üç satır).

    Not:

    Sürükleme ve Bırakma işlevi ancak aynı tablo içinde kullanılabilir.

  4. Bir satır veya sütunu çoğaltmak için satır ya da sütunu seçtikten sonra Alt(Win) veya Opt(Mac) tuşunu basılı tutun. Birbiri ardına seçilen birçok satır veya sütun sürüklenip bırakılabilir.

  5. Seçilen satır veya sütunu sürükleyerek hedeflenen konuma bırakın. Seçilen varlık çoğaltıldığı için toplam satır veya sütun sayısı artar.

    Ayrıca üstbilgi ve altbilgi satırlarındaki içerikleri Alt/Opt tuşuna basarak gövde satırlarına da kopyalayabilirsiniz. Aynı şekilde, gövde satırları da çoğaltılabilir ve üstbilgi/altbilgi satırlarına dönüştürülebilir.

Üstbilgi bölümündeki üstbilgi satırlarını ancak satırları çoğaltmak için alt/opt tuşu kullanılmadığı sürece sürükleyip bırakabilirsiniz (yalnızca birden fazla üstbilgi satırı olduğunda geçerlidir). Gövde satırları, satırları çoğaltmak için alt/opt tuşu kullanılmadığı sürece üstbilgi bölümüne sürüklenip bırakılamaz.

Satır veya sütunları kopyalayarak bir satır veya sütunun önüne veya arkasına yapıştırma

Satırları kopyalayarak seçilen bir satırın önüne veya arkasına yapıştırabilirsiniz. Şundan Önce/Sonra Yapıştır iş akışını kullanarak bir tablodaki satır veya sütunları kopyalayabilir ve başka bir tabloya yapıştırabilirsiniz.

  1. Bir satır veya sütun seçin.

  2. Sütun veya satır seçin.

  3. Tablo > Şundan Önce Yapıştır/Şundan Sonra Yapıştır'ı seçin. 

  1. Aşağıdakilerden birini yapın:
    • Ekleme noktasını üstbilgi veya altbilgi satırına yerleştirin ve ardından Tablo > Satırları Dönüştür> Gövdeye'yi seçin.

    • Tablo > Tablo Seçenekleri > Üstbilgiler ve Altbilgiler'i seçin ve ardından farklı üstbilgi satırı veya altbilgi satırı sayısı belirtin.

Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi