Створення файлу книги

Файл книги — це набір документів, до яких можна застосовувати однакові стилі, зразки, сторінки-шаблони та інші елементи. У документах книги можна послідовно нумерувати сторінки, друкувати виділені документи в книзі або експортувати їх у PDF. Один документ може належати більш ніж одному файлу книги.

Один із документів, доданих до файлу книги, є джерелом стилів. За замовчуванням джерелом стилів є перший документ у книзі, але в будь-який час можна вибрати нове джерело стилів. Під час синхронізації документів у книзі визначені стилі та зразки з джерела стилів замінюють відповідні елементи в інших документах книги.

Майкл Мерфі надав навчальний відеоматеріал про створення книг, який можна знайти на сторінці Основні поняття книги (Book Basics).

  1. Виберіть пункт меню «Файл» > «Створити» > «Книга».
  2. Введіть ім’я книги, вкажіть розташування, а потім натисніть кнопку «Зберегти».

    З’явиться панель «Книга». Файл книжки зберігається з розширенням імені файлу .indb.

  3. Додайте документи до файлу книги.

Додавання документів до файлу книги

Під час створення файлу книги відкривається панель «Книга». Панель «Книга» — це робоча область, у якій можна додавати, видаляти або змінювати розташування документів.

  1. У меню панелі «Книга» виберіть пункт «Додати документ» або натисніть кнопку зі знаком «плюс» внизу панелі «Книга».
  2. Виділіть документ або документи Adobe InDesign, які необхідно додати, а потім натисніть кнопку «Відкрити».

    Примітка.

    Файли можна перетягувати на панель «Книга» з вікна Провідника (Windows) або Finder (Mac OS). Можна також перетягувати документ з однієї книги до іншої. Щоб скопіювати документ, під час перетягування утримуйте клавішу Alt (Windows) або Option (Mac OS).

  3. Якщо включено документи, створені в попередніх версіях InDesign, під час додавання до книги вони перетворюються на формат Adobe InDesign CS5. У діалоговому вікні «Зберегти як» укажіть нове ім’я для перетвореного документа (або залиште поточне ім’я), а потім натисніть кнопку «Зберегти».

    Примітка.

    Перш ніж додавати документи Adobe PageMaker або QuarkXPress до файлу книги, необхідно їх перетворити.

  4. У разі потреби можна змінити порядок документів на панелі шляхом перетягування їх у відповідне розташування в списку.
  5. Щоб призначити документ джерелом стилів, натисніть квадрат поруч з іменем документа на панелі.

Щоб відкрити документ у файлі книги, двічі натисніть ім’я документа на панелі «Книга».

Керування файлами книг

Кожний відкритий файл книги з’являється на власній вкладці на панелі «Книга». Якщо одночасно відкрито декілька книг, натисніть вкладку, щоб перемістити на передній план необхідну книгу і отримати доступ до меню панелі.

Значки на панелі «Книга» визначають поточний стан документа, наприклад, відкритий , відсутній  (документ переміщено, перейменовано або видалено), змінений  (документ відредаговано або його нумерацію сторінок або розділів змінено в той час, коли книга була закрита) або використовується (якщо документ відкрито іншим користувачем у керованому робочому процесі). Поруч із закритими документами значок не з’являється.

Примітка.

Щоб переглянути шлях документа в книжці, затримайте курсор миші над іменем документа, доки не з’явиться підказка. Або в меню панелі «Книга» виберіть пункт «Відомості про документ».

Збереження файлу книги

Файли книг існують окремо від файлів документів. Наприклад, якщо вибрати команду «Зберегти книгу», InDesign зберігає зміни, застосовані до книги, але не до документів у книзі.

  1. Виконайте одну з описаних нижче дій.
    • Щоб зберегти книжку з новим ім'ям, у меню панелі «Книга» виберіть пункт «Зберегти книгу як», вкажіть розташування та ім’я файлу і натисніть кнопку «Зберегти».

    • Щоб зберегти існуючу книгу з тим самим іменем, у меню панелі «Книга» виберіть пункт «Зберегти книгу» або натисніть кнопку «Зберегти»  внизу панелі «Книга».

Примітка.

Якщо файли книг використовуються на сервері спільно, переконайтеся, що є система керування файлами, щоб випадково не втратити зміни, зроблені іншим користувачем.

Закриття файлу книжки

  • Щоб закрити одну книжку, в меню панелі виберіть команду «Закрити книгу».
  • Щоб закрити всі відкриті книги, зібрані на одній панелі, в рядку заголовка на панелі «Книга» натисніть кнопку «Закрити».

Видалення документів книги

  1. Виберіть документ на панелі «Книга».
  2. У меню на панелі «Книга» виберіть пункт «Видалити документ».

Видалення документа з файлу книжки не видаляє файл з диска, документ видаляється тільки з файлу книжки.

Заміна документів книжки

  1. Виберіть документ на панелі «Книга».
  2. У меню панелі «Книга» виберіть пункт «Замінити документ», вкажіть документ, на який його необхідно замінити, а потім натисніть кнопку «Відкрити».

Відкрийте файл книги у Провіднику або у Finder

  1. На панелі книг виберіть документ

  2. У меню панелі книг виберіть «Показати в Explorer» (Windows) або «Показати у Finder» (Mac OS).

Відкриється вікно переглядача, в якому відображається вибраний файл.

Синхронізація документів книги

Під час синхронізації документів у книзі вказані вами елементи (стилі, змінні, сторінки-шаблони, стилі трепінгу, формати перехресного посилання, параметри умовного тексту, нумеровані списки і зразки) копіюються з джерела стилів у визначені документи у книзі, замінюючи всі елементи, які мають однакові імена.

Якщо елементи джерела стилів у синхронізованих документах не знайдено, вони додаються. Елементи, не включені до джерела стилів, у синхронізованих документах залишаються без змін.

Вибір елементів для синхронізації

  1. У меню панелі «Книга» виберіть пункт «Параметри синхронізації».
  2. Виділіть елементи, які необхідно скопіювати з джерела стилів в інші документи книжки.

    Переконайтеся, що виділено всі стилі, включені до визначення інших стилів. Наприклад, стиль об’єкта може містити стилі абзаців і символів, які, в свою чергу, містять зразки.

  3. Виберіть параметр «Групи стилів розумного підбору», щоб уникнути дублювання унікальних імен стилів, які були переміщені до групи стилів або з неї.

    Припустимо, джерело стилів містить стиль символу в групі стилів, а документи, що синхронізуються, містять такий самий стиль символу за межами групи стилів. Якщо цей параметр вибрано, стиль символу переміщується до групи стилів у синхронізованих документах.

    Якщо цей параметр не вибрано, в групі стилів створюється другий примірник стилю символів, який відповідає стилю джерела. Стиль символу не змінюється за межами групи стилів.

    Примітка.

    Якщо документ містить декілька стилів з однією назвою (наприклад, «Стиль символів 1» в групі стилів та «Стиль символів 1» поза межами групи стилів), програма InDesign працюватиме так, ніби цей параметр не вибраний. Щоб отримати найкращий результат, створюйте стилі з унікальними іменами.

  4. Натисніть кнопку «OК».

Синхронізація документів у файлі книжки

Книжку можна синхронізувати, доки документи в книжці закриті. InDesign відкриває закриті документи, виконує зміни, а потім зберігає та закриває документи. Документи, відкриті під час синхронізації, змінюються, але не зберігаються.

  1. На панелі «Книга» натисніть порожній квадрат поруч з документом, який необхідно призначити джерелом стилів. Значок джерела стилів  зазначає, який документ є джерелом стилів.
    Вибране джерело стилів
    Вибране джерело стилів

  2. Переконайтеся, що елементи, які необхідно скопіювати з джерела стилів, вибрано в діалоговому вікні «Параметри синхронізації».
  3. На панелі «Книга» виділіть документи, які необхідно синхронізувати з документом, визначеним як джерело стилів. Якщо жодного документа не виділено, синхронізовано буде всю книжку.

    Примітка.

    Щоб переконатися, що жодного документа не виділено, натисніть порожню сіру область нижче документів книжки. Для цього, можливо, доведеться прокрутити або змінити розміри панелі «Книга». Можна також утримати клавішу Ctrl (Windows) або Command (Mac OS) і натиснути виділений документ, щоб зняти з нього виділення.

  4. У меню панелі «Книга» виберіть пункт «Синхронізувати виділені документи» чи «Синхронізувати книгу» або внизу панелі «Книга» натисніть кнопку «Синхронізувати» .

Примітка.

Вибір пункту меню «Правка» > «Скасувати» скасовує зміни тільки в документах, відкритих під час синхронізації.

Синхронізація сторінок-шаблонів

Сторінки-шаблони синхронізуються таким же чином, як і інші елементи — сторінки-шаблони з тим самим іменем (наприклад, шаблон А), як і у джерелі стилів, замінюються. Синхронізувати сторінки-шаблони зручно в документах, де використовуються однакові елементи оформлення, наприклад, поточні головка та кінцівка. Проте, якщо необхідно зберегти інші елементи на сторінці-шаблоні документів, які не є джерелом стилів, не синхронізуйте сторінки-шаблони або створюйте сторінки-шаблони з різними іменами.

Будь-які елементи сторінки-шаблону, змінені на сторінках документа після першої синхронізації, відокремлюються від шаблону. Однак, якщо планується синхронізувати сторінки-шаблони у книжці, краще синхронізувати всі сторінки книжки на початку процесу оформлення. Таким чином буде збережено зв’язок між зміненими елементами сторінки-шаблону та їх сторінкою-шаблоном і продовжено оновлення змінених елементів сторінки-шаблону у джерелі стилів.

Зручно також синхронізувати сторінки-шаблони, використовуючи тільки одне джерело стилів. Під час синхронізації з іншого джерела стилів змінені елементи сторінки-шаблону можуть відокремитися від сторінки-шаблону. Якщо необхідно виконати синхронізацію, використовуючи інше джерело стилів, спочатку вимкніть параметр «Сторінки-шаблони» в діалоговому вікні «Параметри синхронізації».

Перетворення файлів книг із попередніх версій InDesign

Файли книг, створені у попередній версій InDesign, можна перетворити шляхом відкриття і збереження їх в InDesign CS5. Під час синхронізації, оновлення, нумерації, друкування, пакування або експорту перетвореної книжки, документи, які містить ця книжка, також перетворюються на формат InDesign CS5. Рішення щодо необхідності перезаписати або залишити вихідні файли документів приймає користувач.

Перетворення файлу книжки для використання в InDesign CS5

  1. В InDesign CS5 виберіть пункт меню «Файл» > «Відкрити».
  2. Виберіть файл книжки, створений у попередній версії програми InDesign, і натисніть кнопку «OK».

    З’явиться попередження про те, що файл книги містить документи, збережені в попередньому форматі InDesign.

  3. У меню панелі «Книга» виберіть пункт «Зберегти книгу як». Задайте нове ім’я для перетвореного файлу книги і натисніть кнопку «Зберегти».

Перетворення документів у файлі книги

  1. Відкрийте файл книги у програмі InDesign CS5.
  2. У меню панелі «Книга»:
    • Якщо під час перетворення необхідно перезаписати оригінали, виберіть «Автоматичне перетворення документа».

    • Якщо необхідно залишити оригінали і зберегти перетворені документи з новими іменами, вимкніть параметр «Автоматичне перетворення документа». (Список книг буде оновлено і включено перетворені файли, а не оригінали.)

  3. Для перетворення документів виконайте одну з наступних дій:
    • У меню панелі «Книга» виберіть пункт «Синхронізувати книгу». (Див. розділ Синхронізація документів книги).

    • У меню панелі «Книга» виберіть «Оновити нумерацію» > «Оновити всі номери».

  4. Якщо пункт «Автоматичне перетворення документа» не вибрано, InDesign пропонує зберегти кожний перетворений документ із новим ім'ям.

Примітка.

Документи також перетворюються під час друку або експорту книжки у програму Adobe PDF.

Нумерація сторінок, розділів і абзаців у книзі

У книжці можна визначити спосіб нумерації сторінок, глав і абзаців. У файлі книги стилі нумерації та початкові номери для сторінок і розділів визначаються параметрами кожного документа в діалогових вікнах «Параметри нумерації і розділу» або «Параметри нумерації документа». Одне з цих діалогових вікон можна відкрити за допомогою меню «Формат» > «Параметри нумерації і розділу» в документі або за допомогою пункту «Параметри нумерації документа» в меню панелі «Книга».

Інформацію щодо створення нумерації сторінок у документі можна знайти в розділі Додавання базової нумерації сторінок.

Для нумерованих абзаців (наприклад, списків зображень) нумерація визначається параметрами стилю нумерації списку, які містяться у стилі абзаців.

Діапазон сторінок відображається поруч з ім'ям кожного документа на панелі «Книга». За замовчуванням InDesign оновлює нумерацію сторінок та розділів на панелі «Книга» під час додавання або видалення сторінок у документах книги або під час виконання змін у файлі книги, таких як зміна порядку, додавання або видалення документів. Можна вимкнути автоматичне оновлення номерів сторінок і розділів і змінювати нумерацію в книжці вручну.

Якщо книгу оновлено і нумерація здається неправильною, проблема може полягати в тому, що в основних параметрах замість номерів розділів відображається абсолютна нумерація. Див. розділ Відображення абсолютної нумерації або нумерації розділів на панелі «Сторінки».

Якщо документ відсутній або його неможливо відкрити, діапазон сторінок буде показано як «?» з місця, де повинен знаходитися відсутній документ, до кінця книжки. Це означає, що справжній діапазон сторінок невідомий. Перш ніж оновлювати нумерацію, видаліть або замініть відсутній документ. Якщо з’являється значок «Використовується» , це означає, що інший користувач відкрив документ у керованому робочому процесі на іншому комп’ютері і, перш ніж можна буде оновлювати нумерацію, він має закрити його.

Зміна параметрів нумерації сторінок та глав для кожного документа

  1. Виберіть документ на панелі «Книга».
  2. У меню панелі «Книга» виберіть пункт «Параметри нумерації сторінок документа» або двічі натисніть номери сторінок документа на панелі «Книга».
  3. Вкажіть параметри нумерації сторінок, розділів та глав. (Див. розділ Параметри нумерації документів.)
  4. Натисніть кнопку «OK».

Примітка.

Якщо замість вибору пункту «Автоматична нумерація сторінок» визначити номер першої сторінки в документі книжки, документ книжки розпочнеться на визначеній сторінці; всі подальші документи в книжці будуть відповідно перенумеровані.

Початок нумерації на парній або непарній сторінці

Нумерацію сторінок можна розпочати на парних або непарних сторінках документів книжки.

  1. У меню панелі «Книга» виберіть пункт «Параметри нумерації сторінок книжки».
  2. Оберіть «Продовження на наступній непарній сторінці» або «Продовження на наступній парній сторінці».
  3. Виберіть «Вставити порожню сторінку», щоб додати порожню сторінку в кінець документа, де наступний документ має розпочинатися на непарній або парній сторінці, а потім натисніть кнопку OK.

Вимкнення автоматичної нумерації сторінок у книжці

  1. У меню панелі «Книга» виберіть пункт «Параметри нумерації сторінок книжки».
  2. Вимкніть параметр «Автоматичне оновлення номерів сторінок та розділів» і натисніть кнопку OK.
  3. Щоб оновити нумерацію сторінок вручну, у меню панелі «Книга» виберіть «Оновити нумерацію» > «Оновити усі номери».

    Можна також оновити тільки номери сторінок і розділів або тільки номери глав і абзаців.

Використання у книжках послідовної нумерації абзаців

Щоб використовувати нумерацію абзаців для списків зображень, таблиць або інших елементів, спочатку необхідно визначити, який нумерований список використовується у стилі абзаців. Визначений нумерований список вказує, чи зберігається послідовна нумерація абзаців у межах документів книжки.

  1. Відкрийте документ, який використовується як джерело стилів для книжки.
  2. Виберіть «Текст» > «Марковані та нумеровані списки» > «Визначення списків».
  3. Натисніть «Створити», щоб визначити список, або виберіть існуючий список і клацніть «Редагувати».
  4. Виберіть параметри «Продовжити нумерацію в матеріалах» і «Продовжити нумерацію з попереднього документа в книжці».
  5. Натисніть кнопку «OK».
  6. Визначте стиль абзацу, в якому використовується нумерований список, і застосуйте його до тексту кожного документа, який містить список. (Див. розділ Створення стилю абзацу для поточних списків.)

Примітка.

Щоб переконатися, що в усіх документах книжки використовується однаковий параметр нумерованого списку, у діалоговому вікні «Параметри синхронізації» виберіть параметри «Стилі абзацу» й «Нумеровані списки», а потім синхронізуйте книжку.

Перевагою використання файлу книги є можливість застосовувати єдину команду для виводу (друку, перевірки перед друком, упакування або експорту в EPUB чи PDF) вибраних документів книги або всієї книги.

  1. На панелі «Книга» виконайте одну з таких дій:
    • Для виводу окремих документів виділіть необхідні документи.

    • Для виводу всієї книжки переконайтеся, що жодного документа не виділено.

  2. У меню панелі «Книга» виберіть команду виводу (наприклад, «Друкувати книгу» або «Друкувати виділені документи»).

Цей документ захищено ліцензією Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Публікації Twitter™ і Facebook не підпадають під умови ліцензії Creative Commons.

Юридична інформація   |   Політика мережевої конфіденційності