Експорт тексту

Ви можете записати весь матеріал InDesign або його частину у файлі такого формату, який ви згодом зможете відкрити в інших програмах. Кожен матеріал у документі експортується в окремий документ.

InDesign може експортувати текст у декілька форматів, наведених у списку діалогового вікна «Експорт». Формати зі списку використовуються в інших програмах, і вони можуть зберігати багато зі специфікацій тексту, відступи і табуляцію, що ви їх визначили в документі.

Ви можете записувати частини загально використовуваного тексту і елементи макета сторінки як фрагменти.

  1. Скористайтесь інструментом «Текст» і клацніть матеріал, який потрібно експортувати.
  2. Виберіть «Файл» > «Експорт».
  3. Задайте назву і місце розташування експортованого матеріалу, виберіть текстовий формат у «Тип файлу» (Windows) або «Формат» (Mac OS).

    Якщо немає списку для вашої програми обробки тексту, можна зберегти документ у форматі, який ця програма може імпортувати, наприклад, RTF. Якщо програма обробки тексту не підтримує жодний інший формат експорту InDesign, застосовуйте формат «Лише текст». Однак зважте на те, що експортування в суто текстовий формат усуне з тексту всі атрибути символів.

  4. Натисніть «Зберегти», щоб експортувати матеріал у вибраний формат.

Щоб зберегти все форматування, використовуйте фільтр експорту «Текст з тегами Adobe InDesign». Щоб отримати більше інформації, див. PDF-файл «Текст з тегами» на сторінці www.adobe.com/go/learn_id_taggedtext_cs5_ua (PDF).

Експортування вмісту для Інтернету

Щоб переорієнтувати вміст InDesign для Інтернету, ви маєте кілька можливостей:

Dreamweaver (XHTML)

Експортуйте виділене або цілий документ у базовий неформатований документ HTML. Ви можете робити посилання на зображення на якомусь сервері або створювати окрему теку для зображень. Можна також користуватися будь-яким HTML-редактором, наприклад, Adobe Dreamweaver®, щоб форматувати вміст для використання на веб-сторінках. Див. Експорт вмісту до Dreamweaver (CS5).

Копіювання і вставляння

Скопіюйте текст або зображення з документа InDesign і вставте в редактор HTML.

Adobe PDF

Експортуйте документ в Adobe PDF і розмістіть PDF на веб-сторінці. PDF може містити інтерактивні елементи, такі як фільми, звукові кліпи, кнопки та переходи між сторінками. Див. Динамічні документи PDF.

Flash (SWF)

Виконуйте експорт у файл SWF, готовий до негайного перегляду у Flash Player або в Інтернеті. Файл SWF може містити кнопки, гіперпосилання та переходи між сторінками, такі як витиснення, розчинення та завитки сторінки. Див. Створення інтерактивних SWF-файлів (Flash) для використання на веб-сторінках.

Flash (FLA)

Виконуйте експорт у файл FLA, придатний для редагування в Adobe Flash Professional. Див. Створення файлів FLA для веб-сторінок.

Електронні видання (EPUB)

Експортуйте документ або книгу як книгу eBook із можливістю перекомпонування на основі XHTML, сумісну з програмою-читцем Adobe Digital Editions. Див. Експорт вмісту для EPUB (CS5).

XML

Для більш складного переорієнтування робочого процесу експортуйте вміст із InDesign у формат XML, який потім можна імпортувати в HTML-редактор, такий як Dreamweaver. Див. Робота з XML.

Експорт вмісту у Dreamweaver (CS5)

Експортування в XHTML — це простий шлях одержати ваш вміст InDesign у формі, що готова для показу у web. Під час експорту вмісту в XHTML можна контролювати, як експортуються текст та зображення. InDesign зберігає назви стилів абзаців, символів, об’єктів, таблиць і клітинок, застосовані до експортованого вмісту, позначаючи вміст XHTML класами стилів CSS з тією самою назвою. За допомогою Adobe Dreamweaver або будь-якого придатного для CSS редактора HTML можна швидко застосувати форматування та макет до вмісту.

Що експортується

InDesign експортує всі матеріали, зв’язану та вбудовану графіку, файли фільмів SWF, виноски, текстові змінні (як текст), марковані та нумеровані списки, внутрішні перехресні посилання, гіперпосилання, що переводять на текст чи веб-сторінки. Таблиці також експортуються, але певне форматування, таке як обведення таблиці і клітинок, не експортується. Таблицям призначаються унікальні ідентифікатори, отже, у Dreamweaver на них буде можливо посилатися як на набори даних Spry.

Що не можна експортувати

InDesign не експортує об’єкти, які ви малюєте (такі як прямокутники, овали, багатокутники), файли з відео (за винятком SWF), гіперпосилання (за винятком зв'язків із веб-сторінками та застосованих до тексту зв'язків, що переходять до прив'язок тексту в тому самому документі), вставлені об’єкти (включно зі вставленими зображеннями Illustrator), текст, перетворений на контури, теги XML, книжки, закладки, гліфлети SING, переходи між сторінками, маркери індексів, об’єкти на монтажному столі, що не виділені і не торкаються сторінки, елементи шаблонів сторінок (якщо це правило стосовно них не скасовується або якщо вони не виділяються перед експортом).

  1. Якщо ви не експортуєте цілий документ, виділіть текстовий кадр, діапазон тексту, клітинки таблиці або графіку, яку бажаєте експортувати.
  2. Виберіть меню «Файл» > «Експортувати для» > «Dreamweaver».
  3. Укажіть ім’я та місце розташування HTML-документа, потім натисніть «Зберегти».
  4. У діалоговому вікні «Параметри експорту XHTML», вкажіть бажані параметри в розділах «Загальні», «Зображення» та «Додаткові», а потім натисніть «Експорт».

Створюється документ із вказаною назвою і розширенням .html (наприклад, «бюлетень.html»); якщо зазначено, у тому самому місці буде записана підтека зображень (наприклад, «бюлетень веб-зображення»).

Параметри експорту XHTML

У діалоговому вікні XHTML («Файл» > «Експортувати для > Dreamweaver») вкажіть такі параметри.

Загальні параметри

Поле «Загальні» включає наведені нижче параметри.

Експорт

Визначає, експортуватимуться лише виділені елементи чи цілий документ. Якщо вибрано текстовий кадр, експортується весь матеріал разом з витісненим текстом.

Якщо виділено «Документ», експортуються всі елементи сторінок з усіх розворотів, за винятком елементів шаблон-сторінок, правила щодо яких не були обійдені, і елементи сторінок на невидимих шарах. Теги XML і генеровані індекси і таблиці змісту також ігноруються.

Маркери

Виберіть «Перетворити на невпорядкований список», щоб перетворити абзаци з маркерами на елементи списку, сформатований в HTML, використовуючи тег <ul>. Виберіть «Перетворити на текст», щоб застосувати формат за допомогою тегу <p>, із символами маркерів у вигляді тексту.

Визначення порядку

Використовуйте порядок сторінок або структуру XML для визначення порядку читання об'єктів на сторінці.

Якщо вибрано «Створити на основі макета сторінки», InDesign визначає порядок читання об'єктів на сторінці, виконуючи сканування зліва направо та зверху вниз. У деяких випадках, особливо в складних документах з багатьма шпальтами, елементи оформлення можуть не показуватися в потрібному порядку читання. Використовуйте Dreamweaver для перевпорядкування та форматування вмісту.

Якщо вибрано «Створити на основі макета сторінки», InDesign визначає порядок читання об’єктів на сторінці відповідно до прив'язки документа (зліва направо або справа наліво). У деяких випадках, особливо в складних документах із багатьма шпальтами, експортовані елементи оформлення можуть не показуватися в потрібному порядку читання. Використовуйте Dreamweaver для перевпорядкування та форматування вмісту.

Якщо вибрано «Скопіювати структуру XML», з панелі структури XML виконується керування впорядкуванням експортованого вмісту та тим, який саме вміст експортується. Якщо вміст уже містить теги, можна просто перетягнути теги на панель структури XML, установивши порядок експорту XHTML. Якщо вміст не містить тегів, у меню панелі структури можна вибрати «Додати елементи без тегів», щоб генерувати теги, порядок яких можна змінити. Якщо включати елемент в експорт не потрібно, можна просто видалити тег за допомогою панелі структури XML. (Коли видаляється тег, вміст із файлу INDD не видаляється.) Див. розділ Додавання тегів до елементів сторінки.

Числа

Цей пункт визначає, як перетворюються числа в HTML-файлі.

Перетворити на впорядковані списки

Перетворює нумеровані списки на елементи списку, відформатовані в HTML із використанням тегу <ol>.

Перетворити на статичний впорядкований список

Перетворює нумеровані списки на елементи списку, але додає атрибут <value> на підставі поточного номера абзацу в InDesign.

Перетворити на текст

Перетворює нумеровані списки на абзаци, що починаються з поточного номера абзацу у вигляді тексту.

Параметри зображень

У меню «Копіювати зображення» визначте, як зображення експортуватимуться в HTML.

Оригінал

Експортує вихідне зображення в підтеку web-зображень. Коли цей параметр вибрано, всі інші параметри затемнені.

Оптимізоване

Дає вам змогу змінювати налаштування, щоб визначати, як експортуватиметься зображення.

Відформатоване

Зберігає форматування InDesign, таке як поворот і масштабування, якомога повніше для web-зображень.

Перетворення зображення

Дає вам змогу вибирати, чи мають оптимізовані зображення в документі перетворюватися на GIF або JPEG. Виберіть «Автоматично», щоб дозволити InDesign вирішувати, який формат використовувати в якому разі.

Параметри GIF (Палітра)

Дає вам змогу керувати тим, як InDesign оброблятиме кольори, оптимізуючи GIF-файли. Формат GIF використовує обмежену палітру кольорів, що не перевищує 256 кольорів.

Виберіть «Адаптивний (без згладжування)», щоб створити палітру з використанням типових зразків кольорів у графіці без жодного змішування (змішування малих ділянок кольорів для імітування додаткових кольорів). Виберіть «Web», щоб створити палітру безпечних кольорів для Інтернету, яка є підмножиною системних кольорів Windows і Mac OS. Виберіть «Система (Win)» або «Система (Mac)», щоб створити палітру, використовуючи вбудовану системну палітру. Цей вибір може мати неочікувані наслідки.

Параметри JPEG (якість зображення)

Встановлює компроміс між стисненням (для меншого розміру файлу) і якістю зображення для кожного створеного зображення JPEG. «Низька» дає найменший файл і найнижчу якість зображення.

Параметри JPEG (метод форматування)

Визначає, наскільки швидко має показуватися графіка JPEG, коли файл, що містить зображення, відкривається в Інтернеті. Виберіть «Прогресивний», щоб зображення JPEG показувалися поступово і дедалі детальніше по мірі завантаження. (Файли, створені з цим параметром, значно більші і потребують більше оперативної пам’яті для перегляду.) Виберіть «Базова лінія», щоб кожен JPEG-файл показувався лише після цілковитого завантаження, а на його місці до показу знаходився заповнювач.

Посилання на шлях на сервері

Замість експорту зображень до підтеки цей параметр дає вам змогу ввести локальний URL (такий як «images/»), що з’являтиметься перед назвою файлу зображення. У коді HTML атрибут «link» показує шлях і розширення, що їх ви встановили. Цей параметри є зокрема ефективним, коли ви самі перетворюєте зображення на web-сумісні зображення.

Примітка.

InDesign не перевіряє встановлений вами шлях для сценаріїв Java™, зовнішніх CSS-стилів або тек зображень, тому для перевірки шляхів використовуйте Dreamweaver.

Додаткові параметри

Використовуйте розділ «Додаткові», щоб налаштувати параметри CSS і JavaScript.

Параметри CSS

Каскадні таблиці стилів (CSS) — це набори правил форматування, що керують виглядом вмісту на веб-сторінці. Коли ви використовуєте CSS для форматування сторінки, ви відділяєте вміст від представлення. Вміст вашої сторінки, код HTML, знаходиться в самому HTML-файлі, тоді як правила CSS, що визначають представлення коду, містяться в іншому файлі (зовнішній таблиці стилів) або всередині HTML-документу (зазвичай у розділі «Head»). Наприклад, ви можете задати інші кеглі для виділеного тексту, і можете використовувати CSS для керування форматом і розміщенням блочних елементів на web-сторінці.

Вбудовані CSS

Експортуючи у XHTML, можна створити перелік CSS-стилів, що з’являється в розділі «Head» HTML-файлу з оголошеннями (атрибутами).

Якщо вибрано «Включити визначення стилів», InDesign здійснює спробу зіставити атрибути форматування тексту InDesign з еквівалентами CSS. Якщо вибір цього параметра скасовано, файл HTML міститиме пусті оголошення. Пізніше можна буде редагувати ці оголошення у Dreamweaver.

Якщо вибрано «Зберегти локальні заміни», буде додано локальне форматування, таке як курсив або жирний шрифт.

Без CSS

Якщо вибрати цей параметр, розділ CSS не буде включено у файл HTML.

Зовнішня CSS

Укажіть URL наявного аркуша стилю CSS, що зазвичай є відносним URL, наприклад /styles/style.css. InDesign не перевіряє, чи існує CSS, чи є вона дійсною, тому вам слід використовувати Dreamweaver, щоб підтверджувати ваше налаштування зовнішньої CSS.

Параметри JavaScript

Виберіть «Посилання на зовнішній JavaScript, щоб запускати якийсь JavaScript, коли відкривається сторінка HTML. Вкажіть URL сценарію JavaScript, що зазвичай є відносним URL. InDesign не перевіряє, чи існує цей сценарій і чи є він дійсним.

Експорт вмісту до EPUB (CS5)

Можна експортувати документ або книгу як книгу eBook із можливістю перекомпонування у формат EPUB, сумісну з програмою-читцем Adobe Digital Editions.

  1. Щоб експортувати документ, відкрийте документ і виберіть меню «Файл» > «Експортувати для» > «EPUB».
  2. Вкажіть ім'я та розташування файлу і натисніть кнопку «Зберегти».
  3. У діалоговому вікні «Параметри експорту Digital Editions» вкажіть потрібні параметри у розділах «Загальні», «Зображення» та «Зміст», а потім клацніть «Експорт».

InDesign створює єдиний файл .epub, що містить вміст, який базується на XHTML. Експортований файл включає зображення мініатюри JPEG першої сторінки у вказаному документі (або в документі-джерелі стилю, якщо була вибрана книга). Ця мініатюра використовується як малюнок книги у режимі показу «Бібліотека» Digital Editions Reader. Для перегляду файлу вам потрібна програма Digital Editions, яку можна безкоштовно завантажити з веб-сайту Adobe.

Примітка.

Файл .epub по суті є файлом .zip. Для перегляду та редагування вмісту файлу .epub, змініть його розширення з .epub на .zip і розпакуйте вміст. Це особливо зручно для редагування файлу CSS.

Ресурси EPUB

Перелік статей та ресурсів EPUB можна знайти на сторінках www.adobe.com/go/learn_id_epub_ua.

Додаткову інформацію про формат EPUB можна знайти на веб-сторінці www.idpf.org.

Завантажте безкоштовний екземпляр читача Digital Editions із сайту www.adobe.com/ua/products/digital-editions.html.

Інформацію про Digital Editions можна знайти у блозі Digital Editions.

Загальні параметри експорту в Digital Editions

До розділу «Загальні» діалогового вікна «Параметри експорту Digital Editions» входять наступні параметри:

Включення метаданих документа

Метадані документа (або документа-джерела стилю, якщо вибрано книгу) включаються в експортований файл.

Додавання запису видавця

Вкажіть інформацію про видавця, що відображається в метаданих eBook. Можливо, вам потрібно буде вказати URL-адресу видавця, щоб одержувач eBook мав можливість завітати на веб-сторінку та придбати eBook.

Унікальний ідентифікатор

Кожному документу EPUB потрібен унікальний ідентифікатор. Можна вказати атрибут унікального ідентифікатора Якщо це поле пусте, унікальний ідентифікатор створюється автоматично.

Порядок читання

Якщо вибрати «Створити на основі макета сторінки», порядок читання елементів сторінки в EPUB визначається за їхнім розташуванням на сторінці. В InDesign читання здійснюється зліва направо та зверху вниз. Якщо вам потрібно більше контролю над порядком читання, скористайтеся палітрою тегів XML, щоб додати теги до елементів сторінки. Якщо вибрати «Скопіювати структуру XML», порядок читання визначається за порядком тегів у вигляді структури. Див. розділ Додавання тегів до елементів сторінки.

Маркери

Виберіть «Перетворити на невпорядкований список», щоб перетворити абзаци з маркерами на елементи списку, сформатований в HTML, використовуючи тег <ul>. Виберіть «Перетворити на текст», щоб застосувати формат за допомогою тегу <p>, із символами маркерів у вигляді тексту.

Числа

Цей пункт визначає, як перетворюються числа в HTML-файлі.

Перетворити на впорядковані списки

Перетворює нумеровані списки на елементи списку, відформатовані в HTML із використанням тегу <ol>.

Перетворити на статичний впорядкований список

Перетворює нумеровані списки на елементи списку, але додає атрибут <value> на підставі поточного номера абзацу в InDesign.

Перетворити на текст

Перетворює нумеровані списки на абзаци, що починаються з поточного номера абзацу у вигляді тексту.

Переглянути eBook після експортування

Запускає Adobe Digital Editions Reader, якщо його встановлено. Якщо в системі немає читця, сконфігурованого для перегляду документів .epub, з’являється застереження.

Параметри зображень Digital Editions

До розділу «Зображення» діалогового вікна «Параметри експорту Digital Editions» входять наступні параметри: У меню «Перетворення зображення» визначте, як зображення експортуватимуться в HTML.

Відформатоване

Зберігає форматування InDesign, таке як поворот і масштабування, якомога повніше для web-зображень.

Перетворення зображення

Дає вам змогу вибирати, чи мають оптимізовані зображення в документі перетворюватися на GIF або JPEG. Виберіть «Автоматично», щоб дозволити InDesign вирішувати, який формат використовувати в якому разі.

Параметри GIF (Палітра)

Дає вам змогу керувати тим, як InDesign оброблятиме кольори, оптимізуючи GIF-файли. Формат GIF використовує обмежену палітру кольорів, що не перевищує 256 кольорів.

Виберіть «Адаптивне», щоб створити палітру з використанням типових зразків кольорів у графіці без жодного змішування (змішування малих ділянок кольорів для імітування додаткових кольорів). Виберіть «Web», щоб створити палітру безпечних кольорів для Інтернету, яка є підмножиною системних кольорів Windows і Mac OS. Виберіть «Системна (Win)» або «Системна (Mac)», щоб створити палітру, використовуючи вбудовану системну палітру. Цей вибір може мати неочікувані наслідки.

Виберіть «Черезрядково», щоб поступово відобразити зображення, що повільно завантажується, заповнюючи відсутні рядки. Якщо цей параметр не вибрано, зображення має вигляд розмитого і поступово набуває чіткості, досягаючи повної роздільної здатності.

Параметри JPEG (якість зображення)

Встановлює компроміс між стисненням (для меншого розміру файлу) і якістю зображення для кожного створеного зображення JPEG. «Низька» дає найменший файл і найнижчу якість зображення.

Параметри JPEG (метод форматування)

Визначає, наскільки швидко має показуватися графіка JPEG, коли файл, що містить зображення, відкривається в Інтернеті. Виберіть «Прогресивний», щоб зображення JPEG показувалися поступово і дедалі детальніше по мірі завантаження. (Файли, створені з цим параметром, значно більші і потребують більше оперативної пам’яті для перегляду.) Виберіть «Базова лінія», щоб кожен JPEG-файл показувався лише після цілковитого завантаження, а на його місці до показу знаходився заповнювач.

Параметри змісту Digital Editions

До розділу «Зміст» діалогового вікна «Параметри експорту Digital Editions» входять наступні параметри:

Формат для вмісту EPUB

Вкажіть, який формат потрібно використовувати, XHTML чи DTBook.

Включити записи InDesign TOC

Виберіть цей параметр, якщо потрібно створити зміст у лівій частині eBook. У меню «Стиль TOC» вкажіть стиль TOC, який потрібно використовувати в eBook. Можна вибрати «Макет» > «Стилі змісту», щоб створити спеціальний стиль TOC для eBook.

Не показувати автоматичні записи для документів

Виберіть цей параметр, якщо не потрібно, щоб імена документів відображалися у змісті eBook. Цей параметр особливо корисний під час створення eBook з книги.

Використовувати елементи першого рівня для розбиття на глави

Виберіть цей параметр, щоб розділити eBook на декілька файлів, кожен з яких починається з першого рівня запису TOC. Якщо файл вмісту перевищує 260 кб, на початку абзацу між записами першого рівня починається нова глава, щоб уникнути досягнення обмеження 300 кб.

Генерувати CSS

Каскадні таблиці стилів (CSS) — це набори правил форматування, що керують виглядом вмісту на веб-сторінці. Коли ви використовуєте CSS-код для форматування сторінки, ви відділяєте вміст від представлення.

Включити визначення стилів

Під час експорту до EPUB можна створити список стилів CSS, придатний для редагування.

Зберегти локальні заміни

Якщо вибрано цей параметр, буде додано локальне форматування, таке як курсив або жирний шрифт.

Включити вбудовувані шрифти

Включає в eBook усі шрифти, для яких дозволено вбудовування. Шрифти включають біти вбудовування, що визначають, чи дозволене вбудовування шрифту.

Лише імена стилів

Коли вибирається цей параметр, включаються лише невизначені імена стилів в аркуші стилів EPUB.

Використати існуючий файл CSS

Укажіть URL наявного аркуша стилю CSS, що зазвичай є відносним URL, наприклад /styles/style.css. InDesign не перевіряє, чи існує CSS, чи є вона дійсною, тому вам слід підтверджувати налаштування CSS.

Експорт вмісту у Buzzword

Buzzword — це текстовий веб-редактор, за допомогою якого користувачі можуть створювати та зберігати текстові файли на веб-сервері. Під час експорту матеріалу в Buzzword на сервері Buzzword створюється текстовий файл.

  1. Виділіть текст або встановіть точку вводу в текстовий кадр, що належить до матеріалу, який треба імпортувати.

  2. Виконайте одну з перелічених нижче дій.

    • В InDesign виберіть «Файл» > «Експортувати для» > «Buzzword».

    • В InCopy виберіть «Файл» > «Експортувати для» > «Buzzword».

  3. Якщо ви ще не ввійшли до служби CS Live, перейдіть за посиланням Увійти, укажіть свою адресу електронної пошти та пароль, а потім натисніть кнопку Увійти.

  4. У діалоговому вікні «Експорт матеріалу для Buzzword» вкажіть ім'я документа Buzzword, який необхідно створити, а потім клацніть «OK».

Документ Buzzword відкривається на Acrobat.com. Потім можна перемістити документ в інше робоче середовище і використовувати його спільно з іншими людьми.

Використання бібліотеки зразків веб-кольорів

InDesign містить бібліотеку зразків кольорів, що зветься Web, яка містить кольори, якими послуговується більшість веб-переглядачів для показу тексту і графіки на веб-сторінках. 216 кольорів у бібліотеці, що часто звуться безпечними кольорами web, є тими самими на різних платформах, бо вони є підмножиною кольорів, що їх використовують переглядачі як у Windows, так і в Mac OS. Безпечні кольори web в InDesign є тими самими, що й у палітрі безпечних кольорів web Adobe Photoshop та в палітрі безпечних для переглядачів кольорів Adobe Illustrator.

Кожен колір у цій бібліотеці називається за його RGB-значеннями. Шістнадцятковий код, що використовується в HTML для визначення кольору, зберігається в зразку кольору.

  1. Виберіть Новий колір у меню панелі «Зразки».
  2. В якості колірного режиму виберіть «Web».
  3. Виберіть безпечні кольори Web, потім натисніть «OK».

Цей документ захищено ліцензією Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Публікації Twitter™ і Facebook не підпадають під умови ліцензії Creative Commons.

Юридична інформація   |   Політика мережевої конфіденційності