Таблиця складається з рядків та стовпчиків комірок. Комірка схожа на текстовий кадр, куди ви можете додавати текст, прив'язані кадри або інші таблиці. Таблиці можна створювати в Adobe InDesign CS5 або експортувати з інших програм.

Примітка.

Щоб створити, відредагувати та форматувати таблиці в Adobe InCopy, переконайтеся, що для документа обрано режим перегляду макета.

Створення таблиць

Таблиця складається з рядків та стовпчиків комірок. Комірка схожа на текстовий кадр, куди ви можете додавати текст, вбудовану графіку або інші таблиці. Таблиці можна створювати «з нуля» або шляхом конвертації існуючого тексту. Крім того, ви маєте змогу вбудовувати одну таблицю в іншу.

Під час створення нова таблиця заповнює ширину текстового кадру-контейнера. Таблиця вставляється у той же рядок, якщо точка вставки знаходиться на початку рядка, або в наступний рядок, якщо точка вставки розміщена всередині рядка.

Оточуючий текст обтікає таблиці таким же чином, як і вбудовану графіку. Наприклад, таблиця переміщується по зв'язаних кадрах, коли змінюється розмір точки розміщеного над нею тексту, або коли текст додається чи видаляється. Однак таблиця не може відображатися на кадрі, де текст нанесено на контур.

Майкл Мерфі (Michael Murphy) розмістив статтю про створення та форматування таблиць на сторінці Замисліться про свої методи роботи з таблицями (Mind Your Table Manners).

Джеф Вітчел (Jeff Witchell) із InfiniteSkills.com пропонує відео, в якому він демонструє основи створення таблиць.

Створення таблиці із самого початку

В InDesign таблицю можна створити в наявному текстовому кадрі (Використання параметра «Вставити таблицю»). Крім того, можна створити таблицю та активувати функцію InDesign зі створення текстового кадру для неї (Використання параметра «Створити таблицю»).

Використання параметра «Вставити таблицю»

  1. Щоб намалювати таблицю всередині наявного текстового кадру, скористайтесь інструментом «Текст»і розмістіть точку вставлення в ділянці, де має бути розташовано таблицю.

  2. Виберіть «Таблиця» > «Вставити таблицю».

    Примітка.

    Якщо курсор знаходиться поза межами текстового кадру, функція «Створити таблицю» доступна.

  3. Вкажіть кількість рядків та стовпчиків.
  4. Якщо вміст таблиці буде проходити через кілька стовпчиків або кадрів, вкажіть кількість рядків верхнього та нижнього колонтитула, де буде повторюватись необхідна інформація.
  5. (Необов'язково) Вкажіть стиль таблиці.
  6. Натисніть кнопку «OК».

    Нова таблиця розтягується за шириною текстового кадру.

Використання параметра «Створити таблицю»

За використання параметра «Створити таблицю» необхідності спершу створювати текстовий кадр у документі немає. Одразу після малювання таблиці в документі InDesign створює текстовий кадр відповідно до розмірів намальованої таблиці.

  1. Виберіть «Таблиця» > «Створити таблицю».

    Примітка.

    Якщо курсор знаходиться всередині текстового кадру, параметр «Вставити таблицю» доступний.

  2. Вкажіть кількість рядків та стовпчиків.
  3. Якщо вміст таблиці буде проходити через кілька стовпчиків або кадрів, вкажіть кількість рядків верхнього та нижнього колонтитула, де буде повторюватись необхідна інформація.
  4. (Необов'язково) Вкажіть стиль таблиці.
  5. Натисніть кнопку «OК».
  6. Скористайтеся курсором інструмента «Таблиця», щоб намалювати відповідну таблицю.

    InDesign створює текстовий кадр розміром із виділену ділянку та поміщує до нього таблицю.

Висота рядків таблиці визначається вказаним стилем таблиці. Наприклад, для форматування різних частин таблиці у стилі таблиці можуть використовуватися стилі комірок. Якщо будь-який із цих стилів комірок містить стилі абзаців, то значення інтерліньяжу стилю абзацу визначатиме висоту рядків певної області таблиці. Якщо стилі абзацу не використовуються, висоту рядка визначає стандартне службове поле документа. (Службове поле базується на значенні інтерліньяжу. У цьому контексті службове поле — це приблизна висота виділення у виділеному тексті.)

Створення таблиці з існуючого тексту

Перед перетворенням тексту на таблицю переконайтеся, що текст відповідним чином підготовлений.

  1. Щоб підготувати текст до перетворення на таблицю, вставте табулятори, коми, символи початку нового абзацу або інші символи для розділення тексту на стовпчики. Вставте табулятори, коми, символи початку нового абзацу або інші символи для розділення тексту на рядки. (У більшості випадків перетворення тексту на таблицю можна виконувати без попереднього редагування.)
  2. За допомогою інструмента «Текст»  виділіть текст, який необхідно перетворити на таблицю.
  3. Виберіть «Таблиця» > «Перетворити текст на таблицю».
  4. Для параметрів «Розділювач стовпчиків» та «Розділювач рядків» вкажіть початок для нових рядків або стовпчиків. У полях «Розділювач стовпчиків» та «Розділювач рядків» виберіть значення «Табулятор», «Кома», «Абзац» або введіть символ (наприклад, крапку з комою (;)). (Будь-який введений вами символ з'явиться в меню наступного разу, коли ви створюватимете таблицю з тексту.)
  5. Якщо ви вказали однаковий розділювач для стовпчиків та рядків, визначте кількість стовпчиків, яку повинна містити таблиця.
  6. (Необов'язково) Вкажіть стиль таблиці для її форматування.
  7. Натисніть кнопку «OК».

Якщо кількість елементів у рядку є меншою, ніж кількість стовпчиків у таблиці, рядок буде заповнено пустими комірками.

Вбудовування однієї таблиці в іншу

  1. Виконайте одну з перелічених нижче дій.
    • Виділіть комірки або таблицю, які необхідно вбудувати, потім виберіть «Правка» > «Вирізати» або «Копіювати». Помістіть точку вставки у комірку, в яку необхідно вставити таблицю, потім виберіть «Правка» > «Вставити».

    • Клацніть всередині комірки, виберіть «Таблиця» > «Вставити таблицю», вкажіть кількість рядків і стовпчиків і натисніть «OК».

  2. За потреби відрегулюйте вкладку комірок. (Див. розділ Форматування тексту в таблиці.)

Якщо таблицю було створено всередині комірки, ви не зможете використати мишку для вибору тої частини таблиці, яка виходить за межі комірки. Натомість розширте рядок чи стовпчик, або помістіть точку вставки у першу частину таблиці та за допомогою комбінацій клавіш переміщуйте точку вставки і виділяйте текст.

Імпорт таблиць з інших програм

Якщо ви використовуєте команду «Помістити» для імпорту електронної таблиці Microsoft Excel або документа Microsoft Word, який містить таблиці, дані будуть імпортовані у вигляді таблиці, доступної для редагування. Для здійснення контролю за форматуванням можна використовувати діалогове вікно «Параметри імпорту».

Дані з електронної таблиці Excel або таблиці Word також можна вставляти в документ InDesign або InCopy. Параметри уподобань для роботи з буфером обміну визначають спосіб форматування тексту, вставленого з іншої програми. Якщо вибрано «Тільки текст», дані відобразяться як неформатований текст із табуляцією, який пізніше можна перетворити в таблицю. Якщо вибрано «Всі дані», вставлений текст відобразиться у вигляді форматованої таблиці.

За вставлення тексту з іншої програми в наявну таблицю додайте достатньо рядків і стовпчиків для розміщення вставленого тексту, потім у параметрах для роботи з буфером обміну виберіть параметр «Лише текст» і переконайтеся, що виділено хоча б одну комірку (крім випадків, коли вставлену таблицю необхідно вбудувати в комірку).

Якщо вам потрібно більше контролю над форматуванням імпортованої таблиці або якщо необхідно зберегти посилання на форматування електронної таблиці, виконуйте імпорт таблиці за допомогою команди «Помістити». Якщо потрібно підтримувати зв'язок з електронною таблицею, виберіть параметр «Створити зв'язки при додаванні тексту та файлів електронних таблиць» під час налаштування уподобань для «Оброблення файлів».

Примітка.

Можна також копіювати та вставляти текст із табуляцією поперек виділених комірок таблиці. Ця дія є гарним способом заміни вмісту із збереженням форматування. Наприклад, припустимо, що ви бажаєте оновити вміст у форматованій таблиці у щомісячному журналі. Один із способів — це з'єднання з електронною таблицею Excel. Однак, якщо вміст походить з іншого джерела, можна копіювати текст із табуляцією, що містить новий вміст, вибрати діапазон комірок у форматованій таблиці InDesign та вставити текст.

Додавання тексту до таблиці

У комірки таблиці можна додавати текст, прив'язані об'єкти, теги XML та інші таблиці. Висота рядка таблиці збільшуватиметься, щоб вмістити додаткові рядки тексту, якщо тільки ви не встановите фіксовану висоту рядка. До таблиць не можна додавати виноски.

  1. За допомогою інструмента «Текст»  виконайте одну з таких дій:
    • Розташуйте точку вставляння у комірці та введіть текст. Для створення нового абзацу в тій же комірці натисніть Enter або Return. Натисніть Tab для переміщення вперед по комірках (натискання Tab в останній комірці призведе до вставки нового рядка). Натисніть одночасно Shift і Tab для переміщення назад по комірках.

    • Скопіюйте текст, помістіть точку вставки в таблицю та виберіть «Правка» > «Вставити».

    • Помістіть точку вставки в ту комірку, в яку необхідно додати текст, виберіть «Файл» > «Помістити» та двічі клацніть на текстовому файлі.

Додавання графіки до таблиці

  1. Помістіть точку вставки до комірки таблиці, куди слід додати зображення.

  2. Виконайте одну з описаних нижче дій.
    • Виберіть команду меню «Файл» > «Помістити» та виберіть один або кілька графічних файлів.
    • Виберіть і перетягніть один або кілька графічних елементів із категорії «Графіка» на панелі «CC Libraries».

    В інструменті поміщення з'являться одне чи кілька зображень.

  3. Аби помістити одне або кілька зображень, клацайте всередині кожної комірки таблиці.

  4. Виконайте одну з описаних нижче дій.

Примітка.

Перетягнути фрагменти InDesign із категорії «Графіка» панелі «CC Libraries» неможливо.

Якщо розміри вставленої графіки перевищують розміри комірки, висота комірки збільшується для вміщення графіки, але ширина залишається сталою — графіка може виходити за межі правого боку комірки. Якщо рядок, в який було вставлено графіку, має фіксовану висоту, графіка з більшою висотою буде витіснена за межі комірки.

Примітка.

Щоб уникнути витіснення комірки, можна помістити зображення за межами таблиці, змінити розміри зображення, а потім вставити його в комірку таблиці.

Також помістити зображення в комірки таблиці можна за допомогою наведених далі методів.

  • Виберіть команди меню «Об’єкт» > «Прив'язаний об'єкт» > «Вставити», а потім задайте налаштування. Потім до прив'язаного об'єкта можна додати графіку.
  • Скопіюйте графіку або кадр, помістіть у необхідному місці точку вставки та виберіть «Правка» > «Вставити».

Додавання до таблиці верхніх і нижніх колонтитулів

За створення великої таблиці можливе витіснення більше одного стовпця, кадру або однієї сторінки. Для відтворення інформації вгорі та внизу кожної з частин таблиці можна скористатися верхніми та нижніми колонтитулами.

Рядки верхнього та нижнього колонтитула можна додати під час створення таблиці. Крім того, для додавання рядків верхнього та нижнього колонтитула або для зміни їхнього вигляду в таблиці можна скористатися діалоговим вікном «Параметри таблиці». Ви також маєте можливість перетворювати основні рядки в рядки верхнього та нижнього колонтитула.

Додавання до таблиці верхніх і нижніх колонтитулів
Рядки верхнього колонтитула, що повторюються один раз на кадр

Примітка.

Щоб призначати таблицям послідовні номери (наприклад, Таблиця 1A, Таблиця 1Б тощо) додайте змінну до верхнього або нижнього колонтитула таблиці. (Див. Створення супровідних підписів для малюнків і таблиць.)

  1. Виділіть рядки згори таблиці для створення рядків верхнього колонтитула або рядки знизу таблиці для створення рядків нижнього колонтитула.
  2. Виберіть «Таблиця» > «Перетворити рядки» > «На верхній колонтитул» або «На нижній колонтитул».
  1. Помістіть точку вставки у таблицю та виберіть «Таблиця» > «Параметри таблиці» > «Верхні та нижні колонтитули».
  2. Вкажіть кількість рядків верхнього та нижнього колонтитула. Згори або знизу таблиці можуть бути додані пусті рядки.
  3. Визначте періодичність появи інформації в рядках верхнього та нижнього колонтитула: в кожному текстовому стовпчику (якщо текстові кадри містять кілька стовпчиків), один раз на кадр або один раз на сторінку.
  4. Виберіть «Пропускати перший», якщо ви не бажаєте, щоб інформація верхнього колонтитула з'являлась у першому рядку таблиці. Виберіть «Пропускати останній», якщо ви не бажаєте, щоб інформація нижнього колонтитула з'являлася в останньому рядку таблиці.

    Параметр «Пропустити перший» особливо корисний, коли потрібно вказати, що верхній або нижній колонтитул є продовженням. Наприклад у таблиці, що складається з кількох сторінок, у верхньому колонтитулі може бути текст «Таблиця 2 (Продовження)». Оскільки вам не потрібно, щоб на початку таблиці було написано «(Продовження)», виберіть «Пропустити перший», і просто напишіть «Таблиця 2» у першому рядку таблиці.

  5. Натисніть кнопку «OК».

У програмі доступні численні функції для створення однакових рядків і стовпців, а також для їх дублювання. 

Спочатку можна скористатися наведеними функціями для роботи з рядками та стовпцями таблиці:

  • Перетягування рядків та стовпців таблиці з одного місця до іншого в межах однієї таблиці.
  • Дублювання рядків і стовпців.
  • Вставка рядків і стовпців до або після іншого рядка/стовпця
  • Копіювання вмісту рядка до стовпця або навпаки.

Перетягування та дублювання рядків/стовпців

Можна перетягувати рядки та стовпці таблиці з одного місця до іншого в межах однієї таблиці. Дотримуйтеся наведених інструкцій для перетягування та дублювання рядків/стовпців.

  1. Виділіть рядок чи стовпець для перетягування в інший рядок чи стовпець. Виділити треба весь рядок або стовпець. Частково виділені рядки або стовпці неможливо перетягнути.

  2. Наведіть вказівник миші на виділений стовпець – з'явиться унікальний курсор, який свідчить про те, що виділене можна перемістити.

  3. Елемент таблиці можна перетягнути. Стовпці можна міняти місцями з рядками. Рядок (стовпець), що перетягується, можна вставити лише як рядок (стовпець).

    Перетягування рядків і стовпців
    Перетягування рядків і стовпців

    На цьому малюнку переміщення рядка з одного місця до іншого не змінює їх кількості, яка дорівнює трьом.

    Примітка.

    Перетягування можна виконувати лише в межах однієї таблиці.

  4. Щоб дублювати рядок чи стовпець, виділивши його, натисніть і утримуйте клавішу Alt (у Win) або Opt (у Mac). Можна перетягувати кілька послідовно виділених рядків чи стовпців.

  5. Перетягніть виділений рядок чи стовпець до необхідної ділянки таблиці. Загальна кількість рядків чи стовпців збільшується мірою дублювання виділених елементів.

    Окрім того, можна скопіювати вміст із рядків верхнього та нижнього колонтитулів до основних рядків (натиснувши клавішу Alt/Opt). Основні рядки також можна дублювати та перетворювати на рядки верхнього й нижнього колонтитулів.

У ділянці заголовка також можна перетягувати рядки (доступно лише за наявності кількох рядків у заголовку), якщо для дублювання рядків не було використано клавіші alt/opt. Рядки з основної частини таблиці не можна перетягувати в розділ заголовка, за винятком випадку, коли для дублювання рядків було використано клавіші alt/opt.

Копіювання рядків/стовпців і вставка до/після виділеного

Скопійовані рядки можна вставити до або після виділеного рядка. За допомогою команд «До/після» можна копіювати рядки/стовпці таблиці та вставляти їх в іншу таблицю.

  1. Виділіть рядок/стовпець.

  2. Виділіть рядок або стовпець.

  3. Оберіть команду меню «Таблиця» > «Вставити до»/«Вставити після». 

  1. Виконайте одну з описаних нижче дій.
    • Помістіть точку вставки у рядок верхнього або нижнього колонтитула і виберіть «Таблиця» > «Перетворити рядки» > «В основні».

    • Виберіть команду меню «Таблиця» > «Параметри таблиці» > «Верхні та нижні колонтитули» і вкажіть іншу кількість рядків верхнього або нижнього колонтитула.

Цей документ захищено ліцензією Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Публікації Twitter™ і Facebook не підпадають під умови ліцензії Creative Commons.

Юридична інформація   |   Політика мережевої конфіденційності