Проблема

Возникает следующая ошибка при запуске или использовании After Effects CS3, CS4 или CS5:

«Ошибка After Effects: Не удалось выполнить преобразование символов Unicode. (23::46)»

Решения

Решение 1: Используйте однобайтовые символы для имен файлов, путей и жестких дисков.

Смените строки многобайтовых символов (такие как символы китайского, иврита или японского языка) на однобайтовые символы (например, английские буквы). 

Решение 2: Замените файл AMT.zdct для целевого языка.

Mac OS

  1. Откройте папку Applications/Adobe After Effects CS5 (или CS3 или CS4).
  2. Щелкните правой кнопкой мыши по значку приложения Adobe After Effects CS4 и выберите «Показать содержимое пакета».

  3. Откройте папку Content/Resources/AMT Languages.

  4. Запишите имя файла .txt в этой папке, которое является кодом языка, на котором было установлено приложение After Effects. Это целевой язык.Например, US English это en_US, турецкий - tr_TR, русский - ru_RU и т. д.Список типовых кодов языка доступен здесь.

  5. Вернитесь к папке Resources и откройте папку AMT.

  6. Откройте папку с именем в виде кода целевого языка, определенного на шаге 4.

  7. Вставьте символ тильды (~) в начале имени файла AMT.zdct.Это действие приведет к тому, что After Effects проигнорирует файл, но сохранит этот файл как резервную копию.

  8. Вернитесь к папке AMT и откройте папку для en_US. (Также можно выбрать другие языки, не связанные с этой проблемой, например fr_FR (французский) или es_ES (испанский)).

  9. Скопируйте файл AMT.zdct из этой папки в папку целевого языка из шага 6. Чтобы скопировать файл, удерживайте нажатой клавишу Option, одновременно перетаскивая его из одной папки в другую. Или выберите файл и выполните команду «Файл» > «Дублировать», а затем переместите файл в другую папку и удалите «Копия» в конце имени файла.

  10. Запустите After Effects.

Windows

  1. Откройте папку Program Files\Adobe\Adobe After Effects CS4 (или CS3)\Support Files\AMT Languages.
  2. Запишите имя файла .txt в этой папке, которое является кодом языка, на котором было установлено приложение After Effects. Это целевой язык.Например, US English это en_US, турецкий - tr_TR, русский - ru_RU и т. д.Список типовых кодов языка доступен здесь.

  3. Вернитесь к папке Support Files и откройте папку AMT.

  4. Откройте папку с именем в виде кода целевого языка, определенного на шаге 2.

  5. Вставьте символ тильды (~) в начале имени файла AMT.zdct.Это действие приведет к тому, что After Effects проигнорирует файл, но сохранит этот файл как резервную копию.

  6. Вернитесь к папке AMT и откройте папку для en_US. (Также можно выбрать другие языки, не связанные с этой проблемой, например fr_FR (французский) или es_ES (испанский)).

  7. Скопируйте файл AMT.zdct из этой папки в папку целевого языка из шага 4. Выберите файл, выберите «Правка» > «Копировать», вернитесь обратно в папку целевого языка, а затем выберите «Правка» > «Вставить».

  8. Запустите After Effects.

Дополнительная информация

Файлы AMT.zdct содержат фразы текста для пунктов меню, переведенные на другие языки. Проблема в After Effects препятствует правильному переводу специальных символов, используемых в некоторых языках, если язык операционной системы не поддерживает эти символы.

After Effects было установлено на языке, который использует не романский Unicode или кириллический набор символов в операционной системе, где язык не совпадает.Например, вы установили After Effects на турецком в операционной системе на английском языке.

Следующие языки затрагивает данная проблема:

  • Арабский
  • Китайский (упрощенный)
  • Китайский (традиционный)
  • Греческий
  • Иврит
  • Японский
  • Корейский
  • Румынский
  • Русский
  • Турецкий
  • Украинский

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет