Bilgisayarınızın Photoshop'u en uygun hızda stabil bir şekilde çalıştırmasına yardımcı olmak için işletim sisteminizi, donanımınızı ve uygulama ayarlarınızı ayarlayın. Photoshop bilgisayarınızda beklenenden daha yavaş çalışıyorsa veya Photoshop kullanırken sistem donmaları, gecikmeler ya da duraksamalar yaşıyorsanız bu belgede belirtilen ipuçlarını ve teknikleri deneyin.

Not:

Photoshop'un en uygun biçimde çalışması için bilgisayarınızın belirli minimum sistem gereksinimlerini karşılaması gerekmektedir. Photoshop'un düşük güçle çalışan veya desteklenmeyen donanımla (örneğin, uyumsuz bir grafik işlemciye (GPU) sahip bir bilgisayarda) çalıştırılması performans sorunlarına neden olabilir.

Performans arttıran adımlar

Genel olarak Photoshop'un performansını ihtiyaçlarınıza optimize etmek için bütüncül bir yaklaşım uygulamalısınız. Bu makalede belgelenen önerilere göre bilgisayar kurulumu, kullandığınız dosya türleri ve kendinize özgü iş akışınız bağlamında hangilerini uygulayacağınızı değerlendirin. Her kullanıcının kurulumu kendine hastır ve Photoshop'tan en verimli performansı elde etmek için farklı bir dizi teknik gerektirir.

Photoshop'ta performansı etkilemenin dört temel yolu bulunmaktadır:

Para harcamadan performansı iyileştirmenin en kolay yolu, çalışma tarzınızın avantajlarından ve genellikle çalıştığınız dosya türlerinden yararlanacak şekilde Photoshop tercihlerini ayarlamak ve özelliklerde ince ayarlama yapmaktır.

Performansı artırmanın en etkili yolu, daha hızlı ve daha güçlü donanıma yatırım yapmaktır.

Performansa ilişkin tercihleri ayarlama

Bellek, ön bellek, grafik işlemci, ekranlar gibi bilgisayarınızın kaynaklarının en uygun şekilde kullanımını sağlamaya yardımcı olmak için Photoshop tercihler seti (Tercihler > Performans) sağlar. Photoshop'u öncelikli kullanım amacınıza ve genellikle çalıştığınız belge türlerine bağlı olarak, bu ayarların farklı kombinasyonları size uygun olabilir. Tercihler iletişim penceresinin diğer sekmelerinde yer alan Çalışma Diskleri gibi diğer ayarlar da bilgisayarınızın çalışma hızını ve stabilitesini doğrudan etkileyebilir.

Photoshop performans tercihleri
Photoshop'ta performans tercihleri

Photoshop'a ayrılan belleği ayarlama

Photoshop'a ayrılan bellek/RAM miktarını artırarak performansı geliştirebilirsiniz. Performans tercihleri ekranının Bellek Kullanımı alanı (Tercihler > Performans) Photoshop için kullanılabilir olan RAM miktarını gösterir. Ayrıca, sisteminiz için ideal Photoshop bellek ayırma aralığı da burada gösterilir. Varsayılan ayar olarak, Photoshop boştaki RAM miktarının %70'ini kullanır.

  1. Photoshop Bunu Kullansın kutusundaki değeri değiştirerek Photoshop'a daha fazla RAM ayırabilirsiniz. Alternatif olarak Bellek Kullanımı kaydırma çubuğunu ayarlayın.
  2. Değişikliklerin geçerli olması için Photoshop'u yeniden başlatın.

Sisteminiz için ideal RAM ayırmayı bulmak amacıyla %5'lik artışlar halinde değiştirin ve Verimlilik göstergesinden performansı izleyin. Verimlilik göstergesini takip etme bölümüne bakınız.

Bilgisayarınızın belleğinin %85'inden fazlasını Photoshop'a ayırmanız önerilmez. Böyle yapılması, diğer zorunlu sistem uygulamaları için kullanılabilir bellek bırakmayarak performansı etkileyebilir.

Not:

Photoshop'ta RAM yetersiz veya bellek yetersiz hatalarıyla karşılaşırsanız, Photoshop için ayrılan RAM miktarını artırmayı deneyin. Ancak, Photoshop için ayrılan RAM miktarının çok yüksek (>%85) ayarlanması diğer çalışan uygulamaların performansını etkileyebilir ve sisteminizi istikrarsız yapar. 

Bu sorun için en iyi çözüm bilgisayarınıza daha fazla RAM eklemektir.

Önbellek düzeylerini ayarlayın

Önbellek temel bilgileri

Photoshop, yüksek çözünürlükteki belgelerin üzerinde çalışırken, bunların yeniden çizilmesini hızlandırmak amacıyla görüntü önbelleğini kullanır. Önbelleğe alınan görüntü verileri için en fazla sekiz düzey belirtebilirsiniz ve mevcut dört önbellek döşeme boyutundan birini seçebilirsiniz.

Önbellek düzeylerinin artırılması çalışma sırasında Photoshop'un yanıt hızını iyileştirmesine rağmen görüntülerin yüklenmesi daha uzun sürer. Önbellek döşeme boyutu, Photoshop'un tek seferde üzerinde çalıştığı veri miktarını belirler. Daha büyük döşeme boyutları, keskinleştirme filtreleri gibi karmaşık işlemleri hızlandırır. Fırça darbeleri gibi daha küçük değişiklikler, daha küçük döşeme boyutlarıyla daha hızlı yanıt verir.

Önbellek ayarları

Performans tercihleri bölümünde üç adet önbellek ayarı mevcuttur. Photoshop'u öncelikli kullanım durumunuza/amacınıza uygun geleni seçin:

  • Web/Kullanıcı Arayüzü Tasarımı: Photoshop'u öncelikli kullanım amacınız web, uygulama veya ekran tasarımıysa bu seçeneği seçin. Bu seçenek, düşük-orta piksel boyutundaki varlıkların çok sayıda katmanlarını içeren belgeler için uygundur.
  • Varsayılan/Fotoğraflar: Photoshop'u öncelikli kullanım amacınız orta boyutlu görüntü dosyalarını rötüşlamak veya düzenlemekse bu seçeneği seçin. Örneğin, Photoshop'ta genellikle cep telefonunuzdan veya dijital fotoğraf makinenizden gelen fotoğrafları düzenliyorsanız bu seçeneği kullanın.
  • Çok Büyük Piksel Boyutları: Photoshop'ta aşırı büyük dosyalarla yoğun bir şekilde çalışıyorsanız bu seçeneği seçin; örn. panoramalar, mat boyamalar vb.

Önbellek düzeyleri

Daha iyi kontrol için önbellek düzeylerini elle belirleyin; varsayılan değer 4'tür.

  • Nispeten küçük dosyalar —kabaca 1 megapiksel veya 1280'e 1024 piksel— ve çok sayıda katman (50 veya üzeri) kullanıyorsanız, Önbellek Düzeylerini 1 veya 2 olarak ayarlayın. Önbellek Düzeylerini 1 olarak ayarlamak, görüntü önbelleğini devre dışı bırakır; sadece mevcut ekran görüntüsü önbelleğe alınır.
  • Daha büyük piksel boyutuna —örneğin 50 megapiksel veya daha büyük— sahip dosyalar kullanıyorsanız, Önbellek Düzeylerini 4'ün üzerine ayarlayın. Daha yüksek önbellek düzeyleri yeniden çizimi hızlandırır.

Not:

Önbellek Düzeylerini 1 olarak ayarlarsanız, bazı Photoshop özellikleriyle yüksek kaliteli sonuçlar elde edemeyebilirsiniz.

Geçmiş durumları sınırlayın

Geçmiş bölmesinden Photoshop'un kaydettiği geçmiş durumu sayısını sınırlayarak veya azaltarak çalışma diski alanından tasarruf sağlayabilir ve performansı artırabilirsiniz. Tasarruf sağladığınız alan miktarı, bir işlemin kaç pikseli değiştirdiğine bağlı olarak değişir. Örneğin küçük bir boya darbesi veya bir ayarlama katmanı oluşturmak ya da değiştirmek gibi yıkıcı olmayan bir işleme dayanan geçmiş durumu çok az alan tüketir. Öte yandan bütün görüntüye bir filtre uygulanması çok daha fazla alan tüketir.

Photoshop en fazla 1.000 geçmiş durumu kaydedebilir; varsayılan sayı 20'dir. Bu sayıyı azaltmak için Performans tercihleri iletişim kutusuna girin, Geçmiş ve Önbellek > Geçmiş Durumları seçeneklerini seçin.Gerekirse Geçmiş Durumlar açılır menüsünde, ayarı daha düşük bir değere sürükleyin.

Grafik işlemcisi (GPU) ayarlarını belirleyin

Ekran yeniden çizimlerini hızlandıran GPU hızlandırmayı optimize etmenin en iyi yolu, video bağdaştırıcısı sürücüsünü güncel tutmaktır. GPU hızlandırmayı hakkında daha fazla bilgi ve video bağdaştırıcısı sürücülerini güncelleme talimatları için Photoshop GPU ve ekran kartı SSS bölümüne bakınız.

Uygulamaların GPU'yu kullanmasına imkan tanıyan bir teknoloji olan OpenCL'nin açılması aşağıdaki Photoshop özelliklerini kullanırsanız performansı artırabilir:

  • Video Panorama
  • Bulanıklaştırma Galerisi (İris, Alan, Eğme-Kaydırma Bulanıklaştırma)

OpenCL'yi açmak için Performans Tercihleri panelinde, Gelişmiş Ayarlar'a tıklayın ve OpenCL Öğesini Kullan seçeneğini seçin.

GPU tercihleri

Photoshop, Tercihler iletişim penceresinde yer alan Performans ve 3D bölümlerinde özel GPU ayarları sunar.

Tercihler > Performans bölümündeki ayarlar

Sisteminize uygun bir video kartı takılıysa, bu kart Performans bölümünün GPU Ayarları alanında görülür.

  • GPU hızlandırmayı etkinleştirmek için OpenGL Çizimini Etkinleştir seçeneğinin seçili olduğundan emin olun.
  • Kartın performansına ince ayar yapmak için Gelişmiş Ayarlar düğmesine tıklayın ve Temel, Normal veya Gelişmiş seçeneklerinden gereksiniminize uygun olanı seçin.
    • Temel—GPU diğer uygulamalarla paylaşılırken veya yavaş yanıt verirken en temel OpenGL özelliklerini çalıştırmak için en düşük miktarda GPU belleği kullanır. GPU'yu da kullanan başka programlar çalıştırıyorsanız veya GPU hızlandırmalı özellikler kullanırken bozuk ekran yeniden çizmeleri ya da yavaş performans farkederseniz bu seçeneği seçin.
    • Normal—varsayılan ayardır. Gelişmiş OpenGL özelliklerini desteklemek için büyük miktarda GPU belleği kullanır ve Photoshop'ta GPU hızlandırmalı özellikleri düzenli olarak kullanıyorsanız seçilmelidir.
    • Gelişmiş—Normal modla aynı miktarda bellek kullanır ancak çizim performansını artırmak için daha gelişmiş özellikler sağlar. Bu ayar, 3D'de çalışırken veya GPU hızlandırmalı özelliklerle yoğun bir şekilde çalışırken en iyi seçimdir.

Not: Mod değişimleri sadece Photoshop yeniden başlatıldıktan sonra etkinleşir.

Tercihler > 3D bölümündeki ayarlar

Performanslar iletişim kutusunun 3D bölümü, Performans bölümünde bulunan bellek kontrolüne benzer bir VRAM kaydırma çubuğu içerir. Photoshop 3D motoru için kullanılabilir video RAM'in (VRAM) üst sınırını belirlemek amacıyla kaydırma çubuğunu kullanın. Toplam değer, genel kullanılabilir VRAM değerinin bir yüzdesidir. %100'lük bir ayarda, işletim sistemiyle birlikte kullanım için genel VRAM değerinin bir bölümü hala ayrı olarak tutulur. Daha yüksek değerler genel 3D performansına yardımcı olur ancak diğer GPU etkin uygulamalarla RAM için rekabet edebilir.

memory-usage-3D
3D: Bellek kullanımı

Çalışma disklerini yönetin

Bir çalışma diski, boş bellek içeren herhangi bir harici veya dahili sürücü ya da sürücü bölümüdür. Varsayılan olarak, Photoshop birincil çalışma diski olarak işletim sisteminin yüklendiği sabit sürücüyü kullanır. Çalışma diski ayarlarını Tercihler > Çalışma Diskleri bölümünde ayarlayabilirsiniz.

  1. Düzenle > Tercihler > Çalışma Diskleri (Windows) veya Photoshop > Tercihler > Çalışma Diskleri (Mac OS).
  2. Bir çalışma diskini etkinleştirmek veya devre dışı bırakmak için Etkin onay kutusunu seçin veya seçimini kaldırın. Çalışma diski sırasını değiştirmek için ok düğmelerine tıklayın.
  3. Tamam'a tıklayın.
  4. Değişiklikleri uygulamak için Photoshop'ı yeniden başlatın.

Çalışma diski tercihlerini ayarlamak için öneriler

  • En iyi performans için çalışma disklerini, mevcut portlar içinde en yüksek bant genişliğine sahip olan uyumlu bir porta bağlayın. Çeşitli portların bant genişliği sınırları şu şekildedir:
    Thunderbolt = 10GB/sec
    eSATA = 600MB/sec
    PCIe = 500MB/sec
    USB3 = 400MB/sec
    USB2 = 35MB/sec
  • Performansı iyileştirmek amacıyla çalışma diskini, geniş kullanılmamış alan ve yüksek okuma/yazma hızlarına sahip birleştirilmiş bir sabit diske ayarlayın. Birden fazla sabit diskiniz varsa, ek çalışma diskleri belirleyebilirsiniz. Photoshop en fazla dört birimde 64 eksabayt'a kadar çalışma diski alanını destekler. (Bir eksabayt eşittir 1 milyar GB.)
  • Başlangıç diskiniz bir katı hal diski (SSD) yerine sabit diskse, ana çalışma diskiniz için farklı bir sabit disk kullanmayı deneyin. Öte yandan bir SSD hem ana başlangıç diski hem de çalışma diski olarak iyi performans gösterir. Aslında bir SSD kullanmak, ana çalışma diski olarak ayrı bir sabit disk kullanmaktan muhtemelen daha iyidir.
  • Çalışma diskleri düzenlediğiniz büyük dosyalardan farklı bir sürücüde bulunmalıdır.
  • Çalışma diskleri, işletim sisteminizin sanal bellek için kullandığı sürücüden farklı bir sürücüde olmalıdır.
  • RAID diskleri/disk dizileri, atanan çalışma diski birimleri için iyi seçimlerdir.
  • Sürücüleri düzenli aralıklarla çalışma diskleriyle birleştirin.

Not:

Çalışma diski dolu olduğu için Photoshop başlatılamazsa, yeni bir çalışma diski kurmak için Cmd + Opt (Mac) veya Ctrl + Alt (Windows) tuşlarını basılı tutun.

Kurtarma ve arkaplan kaydetme seçenekleri

Performans > Dosya İşleme > Kurtarma Bilgilerini Hern Dakikada Otomatik Olarak Kaydet seçeneğinin de performans üzerinde hızlandırıcı bir etkisi olabilir. Arka Planda Kaydet tercihi varsayılan ayar olarak etkindir. Açık olduğunda, Kaydet ve Farklı Kaydet komutları gerçekleştirildiğinde Photoshop bu komutların tamamlanmasını beklemenizi gerektirmek yerine çalışmaya devam etmenizi sağlar. Kurtarma Bilgilerini Otomatik Olarak Kaydet tercihi sadece Arka Planda Kaydet açıksa etkindir. Etkinleştirildiğinde, belirtilen aralıkta her bir açık dosya için kurtarma bilgileri kaydedilir. (Kurtarma bilgileri yedekleme amacıyla kaydedilir; orijinal dosyanızda değişiklik yapılmaz.)

Genellikle arka planda kaydetme işlemleri, normal Photoshop işlemlerinin performansını veya yanıt hızını önemli ölçüde etkilemez. Ancak boştaki RAM miktarından çok daha büyük bir dosya düzenliyorsanız, kaydetme işlemi tamamlanana kadar kaydetme işlemi yanıt hızını veya performansı etkileyebilir.

Photoshop aralıklı olarak yavaşlıyor görünüyorsa, arka planda kaydetmenin performansı etkileyip etkilemediğini kontrol edebilirsiniz. Görüntü pencerenizin sol alt kısmındaki durum açılır menüsüden İlerlemeyi Kaydet'i seçin.

İlerlemeyi Kaydet çubuğu hareket ederken performans sorunları fark ederseniz, Tercihler > Dosya İşleme menüsüne girin ve Kurtarma Bilgilerini Otomatik Olarak Kaydet tercihinin sıklığını azaltın. Veya tercihi kapatın.

Photoshop'ta ince ayarlama yapın

Kurtarma aralığı için daha düşük bir değer ayarlamak, çökmelere karşı daha fazla koruma sağlar. Çoğu durumda kurtarma bilgileri, Photoshop'un performansını veya yanıt hızını etkilemez. Ancak değişiklik yaptığınız dosyalar boştaki RAM boyutundan daha büyükse performansta bir yavaşlama görülmesi muhtemeldir.

Kurtarma bilgileri, Photoshop çalışma dosyaları ile aynı konumlara kaydedilir. Çalışma sırasında sürekli olarak çok sayıda büyük dosyayı açık tutarsanız, alan miktarı önemli derecede yüksek olabilir. Kaydet komutu dışındaki komutları gerçekleştirirken disk alanı yetersiz hataları alırsanız, çalışma diski alanı ekleyin. Veya Kurtarma Bilgilerini Otomatik Olarak Kaydet tercihini devre dışı bırakın.

Verimlilik göstergesi

Photoshop'ta çalışırken performansı izlemek amacıyla Verimlilik göstergesini takip edin. Görüntü penceresinin altındaki açılır menüye tıklayın ve açılır menüden Verimlilik seçeneğini seçin.

Göstergedeki değer %100'ün altındaysa, Photoshop boştaki RAM miktarının tamamını kullanmıştır ve performansı yavaşlatan çalışma diskini kullanmaktadır. Verimlilik %90'ın altındaysa, Performans tercihlerinde Photoshop'a daha fazla RAM ayırın. Veya sisteminize daha fazla RAM ekleyin.

Verimlilik göstergesi
Verimlilik göstergesi

Performans için Photoshop özelliklerinde ince ayarlama yapın

Dosya boyutu sınırlamalarında çalışın

Çok büyük dosyalar genellikle performans sorunlarına neden olur. Photoshop en fazla 300.000 x 300.000 piksel dosya boyutunu desteklerken PDF dosyaları 30.000 x 30.000 piksel ve 200 x 200 inç ile sınırlıdır.

Photoshop'un dosya boyutu kapasitesi:

  • PSD dosyaları: 2 GB
  • TIFF dosyaları: 4 GB
  • PSB dosyaları: 4 eksabayt (4096 petabayt veya 4 milyon terabayt)
  • PDF dosyaları: 10 GB (sayfalar 200 inç maksimum boyutla sınırlıdır)

Gereksiz belge pencerelerini kapatın

“RAM yetersiz” hata mesajı alıyorsanız veya Photoshop yavaş çalışıyorsa, çok fazla görüntü açılmış olmasından kaynaklanabilir. Birden fazla pencere açıksa, bir kısmını kapatmaya çalışın.

Hazır ayarlardaki desenler ve fırça uçlarını azaltın

Photoshop'un kullandığı çalışma diski alanını azaltmak amacıyla yüklü tuttuğunuz desen ve fırça ucu sayısını en aza indirin. Şu anda ihtiyacınız olmayan hazır ayarları bir hazır ayar dosyasına kaydedin. Veya bir hazır ayar dosyasından yüklendiyse bunları silin.

Not:

Hazır ayar desenlerini ve fırça uçlarını yönetme hakkında daha fazla bilgi için Hazır Ayar Yöneticisiyle çalışma bölümüne bakınız.

Panel önizleme minik resimlerini küçültün veya kapatın

Bir belgede değişiklik yaptığınız her seferde Photoshop, Katmanlar ve Kanallar panellerinde görünür olan bütün küçük resimleri günceller. Bu güncelleme katmanları hızlı bir şekilde boyarken, taşırken veya hafifçe iterken yanıt hızını etkileyebilir. Ne kadar fazla minik resim görünür olursa, bu etki o kadar fazla olur.

Bu minik resim önizlemelerini küçültmek veya devre dışı bırakmak için Panel menüsüne tıklayın ve Panel Seçenekleri'ni seçin. Daha küçük bir minik resim boyutu seçin veya Yok seçeneğini seçip Tamam düğmesine tıklayın.

Katmanlar paneli

Dosya uyumluluğu seçeneklerini değiştirin

Photoshop'un daha eski sürümlerinde veya katmanları desteklemeyen uygulamalarda PSD ve PSB dosyalarıyla çalışmanız gerekmiyorsa, belge kaydetmeyi hızlandırmak için bir dosya uyumluluğu özelliğini kapatabilirsiniz:

  1. Tercihler > Dosya İşleme bölümünden 16 bit ve 32 bit PSD ve PSB belgeleri için PSD ve PSB Dosyalarını Sıkıştırmayı Devre Dışı Bırak seçeneğini seçin.

  2. PSD ve PSB Dosyası Uyumluluğunu En Üst Düzeye Çıkart menüsünden Sor veya Hiçbir Zaman seçeneğini seçin.

    PSD ve PSB dosyası uyumluluğunu en üst düzeye çıkartın

    Daha fazla bilgi için Dosyaları kaydederken uyumluluğu en üst düzeye çıkarma bölümüne bakınız.

8 bit görüntü modunda çalışın

Photoshop, 16 bit ve 32 bit görüntülerde çok sayıda işlem gerçekleştirebilir. Ancak bu görüntüler 8 bit görüntülere kıyasla işlemek için daha fazla bellek, çalışma alanı ve zaman gerektirir.

Görüntünüzü 8 bit kanala dönüştürmek için Görüntü > Mod > 8 Bit/Kanal seçeneklerini seçin. Daha fazla bilgi için Photoshop Yardımı'nda Bit derinliği'ne bakınız.

Not:

8 bit kanala dönüştürmek, görüntünüzden verileri siler. 8 bit kanala dönüştürmeden önce orijinal 16 bit veya 32 bit görüntünüzün bir kopyasını kaydedin.

WYSIWYG font önizlemeyi kapatın

Photoshop'ta font işlemeyi hızlandırmak amacıyla Yazım > Font Önizleme Boyutu > Yok seçeneklerini seçerek WYSIWYG font önizleme listesini kapatın.

Görüntü çözünürlüğünü azaltın

Görüntü çözünürlüğü ne kadar yüksek olursa, bir görüntüyü görüntülemek, işlemek ve yazdırmak için Photoshop'un ihtiyaç duyduğu bellek ve disk alanı o kadar fazla olur. Nihai çıktıya bağlı olarak daha yüksek görüntü çözünürlüğü daha yüksek nihai görüntü kalitesi sağlamayabilir ama performansı yavaşlatabilir, ek çalışma diski alanı kullanabilir ve yazdırmayı yavaşlatabilir. Görüntüleriniz için optimum çözünürlük, görüntülerin nasıl görüntülendiğine veya yazdırıldığına bağlıdır.

Ekranda sunulan görüntüler için toplam piksel boyutları açısından düşünün. Örneğin çoğu web görüntüsü 725 piksel genişlikten fazlasına ihtiyaç duymaz. Görüntü boyutlarını küçültmek amacıyla Görüntü > Görüntü Boyutu seçeneklerini seçin. Görüntü Boyutu iletişim kutusunda, Yeniden Örnekle seçeneğinin seçili olduğundan emin olun. Boyut Genişliği veya Yüksekliği için yeni bir değer girin (birine değer girildiğinde her ikisi değişir).

Görüntü çözünürlüğünü azaltın

Basılan görüntüler için çözünürlüğü 360 DPI üzerine yükseltmek çoğu durumda çok az fayda sağlar veya hiç fayda sağlamaz. Çok fazla baskı alıyorsanız, istediğiniz sonuçları veren bir çözünürlük bulmak için deneyin. Görüntü çözünürlüğünü küçültmek amacıyla Görüntü > Görüntü Boyutu seçeneklerini seçin. Görüntü Boyutu iletişim kutusunda, Yeniden Örnekle'yi seçin. Basılı belgenizin fiziksel boyutunu yansıtacak şekilde Genişlik ve Yükseklik değerlerini değiştirin. Ardından Çözünürlük değerini düşürün ve TAMAM düğmesine tıklayın.

Yazdırma için görüntü çözünürlüğünü azaltmak yerine yükseltecekseniz, bu çözünürlük yükseltme işlemini görüntüyü yazdırmadan önce son adımlarınızdan biri olarak gerçekleştirin. Bu şekilde önceki adımlarda bütün bu ek bilgileri işlemek zorunda kalmazsınız.

Daha fazla bilgi için Gelişmiş kırpma, yeniden boyutlama ve yeniden örnekleme bölümüne bakınız.

Belleği temizleyin

Photoshop'tan kullanılmayan bellek ve çalışma diski alanını boşaltıp diğer programların kullanımına sunarak sistem performansını yükseltebilirsiniz. Bunu yapmak için aşağıdaki seçeneklerden birini seçin:

  • Düzen > Temizle > Tümü
  • Düzen > Temizle > Geri Al
  • Option (Mac OS) veya Alt (Windows) tuşunu basılı tutun ve About Photoshop CC Hakkında'yı seçin

Diğer programlar aktif olarak bellek ayırmaya veya kullanmaya çalışıyorsa, Photoshop'ta boş belleği arttırmak performansı yükseltir. Disk alanı yetersizse çalışma diski alanını boşaltmak da faydalı olacaktır. Önemli ölçüde bellek veya disk alanı boşaltırsanız, yer ayırma işlemi yapacağından dolayı büyük Photoshop dosyaları açtığınız bir sonraki seferde Photoshop daha yavaş olacaktır.

Photoshop'un her zaman daha az bellek kullanmasını istiyorsanız, Düzen > Tercihler > Performans (Windows) veya Photoshop > Tercihler > Performans (Mac OS) seçeneklerini seçin ve Bellek Kullanımı kaydırma çubuğunu sola sürükleyin. Bellek kullanımını ayarlayın bölümüne bakınız.

Not:

Etkinlik monitörleri, görev yöneticileri ve disk araçlarının değişimi kaydetmesi birkaç saniye sürebilir. Aslında bazı araçlar için güncellemeyi açıkça istemeniz gerekebilir.

Panoyu temizleyin

Büyük belgelerde veri kopyalıyor veya yapıştırıyorsanız pano içeriği genellikle büyüktür. Ve bu içerik yapıştırma yaparken çok az fayda sağlar. Panoda görüntü verileri tarafından kullanılan RAM'i boşaltmak için, Düzen > Temizle > Pano seçeneklerini seçin.

Not:

Temizle komutu geri alınamaz.

Filtre Galerisini kullanın

Filtre Galerisi efektleri uygulamadan önce bir görüntüde bir veya daha fazla filtreyi test etmenizi sağlar ve önemli ölçüde zaman ve bellek tasarrufu sağlar. Daha fazla bilgi için Filtre Galerisine genel bakış bölümüne bakınız.

Kopyalayıp yapıştırmak yerine dosyalar arasında sürükleyin

Katmanları veya dosyaları sürüklemek, kopyalayıp yapıştırmaktan daha etkindir. Sürükleme işlemi Panoyu kullanmaz ve verileri doğrudan aktarır. Kopyalayıp yapıştırmak daha fazla veri aktarımı gerektirir ve etkinliği çok daha düşüktür.

Katmanları akıllıca kullanın

Katmanlar Photoshop'ta temel öneme sahiptir ama dosya boyutunu ve yeniden çizim süresini uzatır. Görüntüdeki her bir değişikliğin ardından Photoshop her bir katmanı yeniden oluşturur. Katmanlardaki değişiklikleri tamamladıktan sonra, dosya boyutunu küçültmek için katmanları düzleştirin (birleştirin). Katmanlar panelinde katmanları seçip sağ tıklayın (Windows) veya Control tuşuyla tıklayın (Mac OS) ve Katmanları Birleştir seçeneğini seçin. Bir dosyadaki bütün katmanları düzleştirmek için, Katman > Görüntüyü Düzleştir seçeneğini seçin. Ayrıca dosyadaki bütün boş katmanları kaldırdığınızdan emin olun.

Not:

Photoshop ayrı katmanları birleştirdikten sonra ayırmanıza izin vermez. Birleştirilmemiş duruma geri dönmek için Düzen > Geri Al seçeneklerini seçebilir veya Geçmiş panelini kullanabilirsiniz.

Katmanlarınızdan bazılarını sıkça değiştirmiyorsanız, katmanları veya katman kümelerini Akıllı Nesnelere dönüştürmeyi düşünün; bu şekilde disk alanından tasarruf edebilir ve performansı yükseltebilirsiniz. Katmanlar panelinde katmanları veya katman kümelerini seçip sağ tıklayın (Windows) veya Control tuşuyla tıklayın (Mac OS) ve Akıllı Nesneye Dönüştür seçeneğini seçin. Akıllı Nesnelerle Çalışma bölümüne bakınız.

TIFF dosyalarını katmanlar olmadan kaydedin

Photoshop, TIFF dosyalarına katmanları kaydedebilir. Ancak katmanlı TIFF dosyaları düz TIFF dosyalarından daha büyüktür ve işleme ve yazdırma için daha fazla kaynak gerektirir. Katmanlı bir TIFF dosyasıyla çalışırsanız, orijinal katmanlı dosyayı bir Adobe Photoshop (.psd) dosyası olarak kaydedin. Ardından dosyayı TIFF formatında kaydetmeye hazır olduğunuzda, Dosya > Farklı Kaydet'i seçin. Farklı Kaydet iletişim kutusunda, Format > TIFF'i seçin, Kopya Olarak Kaydet'i seçin, Katmanların seçimini kaldırın ve Kaydet'e tıklayın.

TIFF dosyalarını dışa aktarırken daha fazla hız için ZIP sıkıştırmayı seçin. (Ancak ZIP sıkıştırma en küçük TIFF dosyalarını üretir.)

Panoyu dışa aktarmayın

Panoyu Dışa Aktar seçeneği, Photoshop'un pano içeriğini diğer programların kullanımına sunmasına neden olur. Photoshop'ta büyük miktarda veri kopyalar ancak diğer uygulamalara yapıştırmazsanız, bu seçeneği kapatarak zaman kazanın:

  1. Photoshop > Tercihler > Genel (Mac OS) veya Düzen > Tercihler > Genel'i (Windows) seçin.

  2. Panoyu Dışarı Aktar seçimini kaldırın.

  3. Tamam'a tıklayın.

Kitaplıklar panelini devre dışı bırakma

  1. Kitaplıklar menüsünden Kapat'ı seçin.

    Kitaplıklar menüsü
  2. Photoshop'u yeniden başlatın.

Cihaz Önizlemesini devre dışı bırakın

  1. Cihaz Önizlemesi menüsünden Kapat'ı seçin.

    Cihaz Önizlemesini devre dışı bırakma menüsü
  2. Photoshop'u yeniden başlatın.

Üreticiyi Devre Dışı Bırakın

  1. Düzenle > Tercihler > Eklentiler'i seçin.

  2. Üreticiyi Etkinleştir seçimini kaldırın.

  3. Tamam'a tıklayın.

Cetvelleri Devre Dışı Bırakın

Cetvelleri devre dışı bırakmak için Görünüm menüsünde Cetveller'in seçimini kaldırın.

Creative Cloud masaüstü uygulamasını yeniden başlatın.

Donanım kurulumunuzu Photoshop için optimize edin

Mevcut donanım kurulumunuzu değiştirmekle (veya yeni bir sistem satın almakla) ilgileniyorsanız, Photoshop için optimize etmek amacıyla aşağıdaki bilgileri kullanın.

Hızlı bir işlemci kullanın

Bilgisayarın merkezi işlemci ünitesinin veya CPU'sunun hızı, Photoshop'un işleme hızını sınırlar. Photoshop çok çekirdekli bir Intel işlemci (Mac OS) veya 2 GHz ya da daha hızlı bir işlemci (Windows) gerektirir.

Photoshop genellikle daha fazla işlemci çekirdeği ile daha hızlı çalışsa da bazı özellikler diğerlerine göre ek çekirdeklerden daha fazla yararlanır. Ancak çoklu işlemci çekirdekleri ile azalan dönüşler sağlarsınız: Ne kadar fazla çekirdek kullanırsanız, her bir ek çekirdekten daha az fayda sağlarsınız. Bu nedenle Photoshop, dört çekirdekli bir bilgisayarda 16 işlemci çekirdeğine sahip bir bilgisayardan dört kat daha hızlı çalışmaz. Çoğu kullanıcı için altı çekirdeğin üstünde performans artışı, artan maliyeti haklı çıkarmaz.

Not:

Photoshop'u sanal bir ortamda kullanıyorsanız, Photoshop'un GPU'su performans sorunlarına neden olabilir. Sanal makineler GPU'ya erişim sağlayamaz.

RAM ekleyin

Photoshop görüntüleri işlemek amacıyla rastgele erişilebilir belleği (RAM) kullanır. Photoshop'un belleği yetersizse, bilgileri işlemek amacıyla çalışma diski olarak bilinen sabit disk alanını kullanır. Bellekteki bilgilere erişim, sabit diskteki bilgilere erişimden daha hızlıdır. Bu nedenle Photoshop, RAM'daki bütün veya çoğu görüntü bilgisini işleyebildiği zaman en hızlıdır.

Photoshop'un en son sürümü için en az 8 GB RAM önerilir.

Photoshop'a ne kadar RAM ayıracağınızı nasıl belirteceğinizle ilgili talimatlar için Bellek kullanımını ayarlama bölümüne bakınız.

Hızlı, büyük bir sabit disk kullanın

Sisteminizde bilgilerin tamamını içerecek yeterli RAM bulunmadığında Photoshop görüntü bilgilerini okur ve diske yazar. Verimlilik göstergesi daha hızlı bir sabit disk veya katı hal diskine sahip olmanın performansını artırıp artırmayacağını belirlemenize yardımcı olabilir. Verimlilik sayısı genellikle %95'in üzerindeyse, daha hızlı bir çalışma diskine para harcamanın çok az faydası olur.

Photoshop performansını iyileştirmek amacıyla, yüksek veri aktarım hızına sahip bir disk kullanın. Thunderbolt, FireWire 800, eSATA veya USB3 gibi hızlı bir arayüzden bağlanan harici bir disk veya dahili bir sabit disk kullanın. Ağ sunucuları (ağ üzerinden ulaşılan sabit disk) daha düşük veri aktarım hızına sahiptir.

Photoshop'un son sürümü için en az 2,5 GB (Windows) veya 3,2 GB (Mac OS) gerekir. Kurulum ek alan gerektirir ve Adobe, sanal bellek ve çalışma diski alanı için daha fazla sabit disk alanı önerir.

Hızlı RAID 0 dizileri, diziyi özellikle çalışma diski için kullanırsanız mükemmel çalışma diskleri oluşturur. Ayrıca diziyi düzenli olarak birleştirdiğinizden emin olun ve bunu, açılış diski olarak kullanmayın.

Katıl hal diski kullanın

Bir SSD'den en büyük faydayı sağlamak amacıyla bu diski çalışma diski olarak kullanın. Çalışma diski olarak SSD'yi kullanmak, tamamı RAM'e sığmayan görüntüleriniz varsa önemli performans iyileştirmeleri sağlar. Örneğin RAM ile SSD arasında döşeme takası yapılması RAM ile sabit disk arasındaki takastan çok daha hızlıdır.

SSD'nizin çok fazla boş alanı yoksa (çalışma dosyası SSD'ye sığmayacak kadar büyürse), ikinci veya üçüncü bir sabit disk ekleyin. (SSD'den sonra ekleyin.) Bu disklerin Performans tercihleri bölümünde çalışma diskleri olarak seçildiğinden emin olun.

Ayrıca SSD'ler performans açısından çok farklılık gösterir ve bu farklılık sabit disklere göre çok daha yüksektir. Daha eski, daha yavaş bir disk kullanılması, sabit diske göre az iyileştirme sağlar.

Not:

Performansı arttırmak amacıyla RAM eklemek, bir SSD satın almaya göre daha düşük maliyetlidir.

Verimlilik göstergesi zaten yüksekse, SSD performansı yükseltmez. Verimlilik göstergesi ne kadar düşük olursa, SSD'nin sağladığı iyileştirme o kadar yüksek olur.

Performans ve 64 bit Photoshop ile ilgili daha fazla bilgi için 64 bit İşletim Sisteminin avantajları, sınırlamalar bölümüne bakınız.

İşletim sisteminizi Photoshop için optimize edin

İşletim sisteminizi Photoshop'la etkin bir şekilde kullanmak için aşağıdaki bilgilerden yararlanın.

Gereksiz uygulamaları ve başlangıç öğelerini kapatın

Diğer açık uygulamalar ve başlangıç öğeleri, Photoshop'un kullanabileceği boş bellek miktarını azaltır. Ek bellek açmak amacıyla gereksiz uygulamalardan, başlangıç öğelerinden ve uzantılardan çıkın. Ardından Photoshop'a daha fazla boş bellek sağlayın.

App Nap'i devre dışı bırakın (Mac)

Disk Temizlemeyi çalıştırın (Windows)

Geçici dosyaları ve kullanılmayan diğer dosyaları temizlemek amacıyla zaman zaman Disk Temizlemeyi çalıştırın.

  1. Başlat düğmesine tıklayın, Arama metni kutusuna Disk Temizleme yazın ve Programlar listesinden Disk Temizleme'yi seçin.

  2. Temizlenecek bir sürücü seçin.

  3. Geçici Dosyaları ve silmek istediğiniz diğer dosyaları seçin.

  4. Tamam'a tıklayın.

Sabit diski birleştirin

Photoshop'un sürekli bir konuma kaydedilen bir dosyaya kıyasla parçalanmış bir dosyayı okuması veya yazması daha uzun sürer.

Windows'ta sabit disklerin birleştirilmesiyle ilgili talimatlar için aşağıdaki Microsoft Yardım konularına bakınız:

  • (Windows 7 ve Vista) "Sabit diskinizi birleştirerek performansı artırma"
  • (Windows 8) “Sabit diskinizi optimize etme”

Not:

Sürücü neredeyse dolu olarak çalıştırmadığınız sürece bölünme Mac OS'ta nadiren sorun oluşturur.

Katı hal diskleri birleştirme gerektirmez çünkü disk performansı normal bölünme düzeyleriyle önemli ölçüde düşmez.

Not:

RAID dizilerinde bölünme olmaz. Bölünmenin sorun oluşturma ihtimali her şey için tek bir disk kullanıyorsanız daha yüksektir. Kalıcı dosyalar ve Photoshop çalışma diski aynı birimi kullanıyorsa, özellikle birimin yeterli boş alanı olmadığında da sorun olabilir. Bu durumda diski birleştirmek önemli bir fark yaratabilir.

Otomatik İşletim Sistemi güncellemelerini açın

Windows veya Mac OS X işletim sistemindeki güncellemeler, performansı ve uygulamalarla uyumluluğu arttırır.

Windows için Windows Update'i açın.

Mac OS X için Yazılım Güncelleme'yi kullanın.

Sabit bir sanal bellek belirtin (Windows)

Sabit bir sanal bellek ayarı belirtilmesi, Photoshop çalışma disklerinin sanal bellekle alan için yarışmasını önler (özellikle sanal bellek ayarını ana çalışma diskinden farklı bir sürücüye ayarlarsanız). En iyi performans için yeterli boş, kesintisiz alan bulunan bir sürücü kullanın. Ayrıca disk belleği dosyasını ayrı, boş, birleştirilmiş bir sabit diskte tutun.

Her zaman olduğu gibi sanal bellek ve çalışma diskleri için ayrı diskler kullanılması tavsiyesi katı hal diskleri için geçerli değildir. Bir SSD'de en yoğun olarak kullanılan bütün dosyaların bir SSD'ye yüklenmesi faydalıdır ve herhangi bir olumsuzluk taşımaz veya çok az olumsuzluk görülür.

Sanal belleği değiştirmek için bütün uygulamalardan çıkın ve aşağıdakileri uygulayın:

  1. Başlat > Denetim Masası'nı seçin ve Sistem'e çift tıklayın.

  2. Görevler listesinde Gelişmiş Sistem Ayarları'nı seçin ve Gelişmiş sekmesine tıklayın.

  3. Performans bölümünde, Ayarlar'a tıklayın.

  4. Gelişmiş sekmesine tıklayın ve Değiştir'e tıklayın.

  5. Tüm Sürücülerde Disk Belleği Dosyası Boyutunu Otomatik Yönet seçimini kaldırın.

  6. Sürücüdeki kullanılabilir alanı görmek için her bir sabit diski harfine tıklayın. Bilgisayarınızın yüklü RAM'inin üç katı büyüklükte ve çalışma diski içermeyen bir sabit disk seçin.

  7. Özel Boyut'u seçin ve İlk Boyut kutusuna fiziksel RAM miktarı artı 300 MB girin. Maksimum Boyut kutusuna bilgisayarınızın RAM miktarının üç katını girin.

  8. Ayarla düğmesini ve ardından Tamam'a tıklayın. Bütün iletişim kutularından çıkmak için Tamam'a tıklamaya devam edin.

  9. Bilgisayarı yeniden başlatın: Açık uygulamalarınız varsa, Daha sonra yeniden başlat'ı seçin, uygulamalarınızı kapatın ve ardından Windows'u yeniden başlatın. Yoksa, Şimdi yeniden başlat'ı seçin.

Windows 8'de Sanal Belleği değiştirmek için bütün uygulamalardan çıkın ve aşağıdakileri uygulayın:

  1. Başlat > Denetim Masası'na tıklayın. Başlat düğmesini görmüyorsanız, klasörler simgesini seçin ve bilgisayarınızda denetim masası'nı arayın.

  2. Sistem'i seçin ve Güvenlik > Sistem'i seçin.

  3. 3. adımdan başlayarak yukarıdaki adımları uygulayın.

Güç seçeneklerini belirleyin

  • (Mac OS) Sistem Tercihleri > Enerji Tasarrufu'nu seçin ve Otomatik Grafik Değiştirme seçimini kaldırın.
  • (Windows) Denetim MasasıGüç Seçenekleri'ni ve ardından Yüksek Performans'ı seçin.

Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi