Jeff Almasol, nel suo sito Web redefinery, mette a disposizione uno script che esegue il rendering ed esporta separatamente ciascuno dei livelli selezionati. Ad esempio, usate questo script se i livelli rappresentano versioni diverse di un effetto oppure parti diverse di un effetto che di cui desiderate eseguire il rendering con passaggi separati, per una maggiore flessibilità in relazione al modo in cui essi vengono composti.

Visualizzare e cambiare le informazioni sul livello

  • Per rinomare un livello o un gruppo di proprietà, effettuate una delle seguenti operazioni:
    • Selezionate l’elemento nel pannello Timeline, premete Invio (Windows) o Invio (Mac OS) e immettete il nuovo nome.

    • Fate clic con il pulsante destro del mouse (Windows) o tenendo premuto Control (Mac OS) sull’elemento nel pannello Timeline, scegliete Rinomina e immettete il nuovo nome.

  • Per alternare tra la visualizzazione dei nomi di elementi di metraggio sorgente e i nomi dei livelli nel pannello Timeline, fate clic sull’intestazione di colonna Nome livello/Nome sorgente nel pannello Timeline.

Nota:

se il nome del livello e quello del metraggio sorgente sono uguali, il nome del livello viene racchiuso da parentesi quadre: [nome livello].

  • Per visualizzare il nome del file del metraggio sorgente per un livello selezionato nel pannello Info, premete Ctrl+Alt+E (Windows) o Comando+Opzione+E (Mac OS).
  • Per vedere quale elemento di metraggio è la sorgente di un livello, fate clic con il pulsante destro del mouse (Windows) o tenendo premuto il tasto Control (Mac OS) sul livello nel pannello Timeline e scegliete Rivela sorgente livello nel progetto.

L’elemento di metraggio sorgente viene selezionato nel pannello Progetto.

Potete filtrare i livelli nel pannello Timeline per visualizzare solo i livelli con le proprietà corrispondenti a una stringa di ricerca o ad altre determinate caratteristiche. Consultate Cercare e filtrare nei pannelli Timeline, Progetto ed Effetti e predefiniti e Scelte rapide: visualizzare proprietà e gruppi nel pannello Timeline (scelte rapide da tastiera).

Nel sito Web redefinery di Jeff Almasol è disponibile uno script per scrivere automaticamente le informazioni specificate sugli elementi di metraggio o sui livelli nei campi Commento dei rispettivi elementi nel pannello Progetto o Timeline.

Nel sito Web di Christopher Green è disponibile uno script (Project_Items_Renamer.jsx) che consente di rinominare più livelli selezionati nel pannello Timeline. Potete effettuare ricerche e sostituzioni di testo nei nomi, aggiungere dei caratteri all’inizio o alla fine dei nomi, tagliare un dato numero di caratteri dall’inizio o dalla fine dei nomi o sostituire i nomi con numeri in serie.

Colonne e switch Livello nel pannello Timeline

Molte delle caratteristiche di un livello sono determinate dagli switch, che sono collocati nelle colonne del pannello Timeline. Per impostazione predefinita, la colonna Funzionalità A/V viene visualizzata a sinistra del nome del livello, mentre le colonne Switch e Modalità (Controlli trasferimento) vengono visualizzate a destra e possono essere disposte in un ordine diverso. (Consultate Colonne.)

Per visualizzare o nascondere le colonne nel pannello Timeline, fate clic su Switch livello , Controlli trasferimento , oppure sul pulsante Attacco/Stacco/Durata/Dilatazione nell’angolo inferiore sinistro del pannello Timeline. Premete Maiusc+F4 per visualizzare o nascondere la colonna Superiore. Premete F4 per alternare le colonne Switch e Modalità.

I risultati di alcune impostazioni degli switch dei livelli dipendono dalle impostazioni degli switch di composizione che si trovano nella parte superiore destra della struttura dei livelli nel pannello Timeline.

Nota:

Cambiate rapidamente lo stato di uno switch per più livelli facendo clic sullo switch di un livello e trascinando in alto o in basso la colonna per i livelli adiacenti.

Jeff Almasol, nel suo sito Web redefinery, mette a disposizione uno script che crea un pannello con il quale potete salvare e ripristinare le impostazioni dello switch del livello per tutti i livelli della composizione.

Switch nella colonna Funzionalità A/V

Video 

Alterna l’attivazione e la disattivazione dei riferimenti visivi dei livelli. (Consultate Attivare e disattivare la visibilità o l’influenza di un livello o gruppo di proprietà.)

Audio

Alterna l’attivazione e la disattivazione dei suoni dei livelli.

Solo

Include il livello corrente nelle anteprime e nei rendering, ignorando i livelli senza questo gruppo di livelli. (Consultate Isolare un livello.)

Blocca

Blocca il contenuto dei livelli, impedendo qualsiasi modifica. (Consultate Bloccare e sbloccare un livello.)

Switch nella colonna Switch

Inattivo

Nasconde il livello corrente quando è selezionato lo switch di composizione Nascondi livelli inattivi . (Consultate Mostrare e nascondere i livelli nel pannello Timeline.)

Comprimi trasformazioni/Rasterizza in modo continuo

Comprime le trasformazioni se il livello è una precomposizione; rasterizza in modo continuo se il livello è un livello forma, un livello testo o un livello con un file di grafica vettoriale (ad esempio un file di Adobe Illustrator) come metraggio sorgente. Se selezionate questo switch per un livello vettoriale, After Effects rasterizza nuovamente il livello per ciascun fotogramma; di conseguenza, la qualità dell’immagine viene migliorata, ma aumentano i tempi di visualizzazione in anteprima e di rendering. (Consultate Ordine di rendering e compressione delle trasformazioni e Rasterizzare in modo continuo un livello contenente grafica vettoriale.)

Qualità 

Alterna tra le opzioni Alta e Bozza per la qualità di un livello di rendering, compreso il rendering sullo schermo per le anteprime. (Consultate Qualità immagine del livello e posizionamento subpixel.)

Effetto 

Selezionate questa opzione per eseguire il rendering del livello con gli effetti. Lo switch non agisce sull’impostazione relativa agli effetti individuali sul livello. (Consultate Eliminare o disattivare gli effetti e i predefiniti di animazione.)

Fusione fotogrammi 

Imposta la fusione dei fotogrammi su uno dei tre stati seguenti: Mix fotogrammi , Movimento pixel o Disattivato. Se lo switch di composizione Attiva fusione fotogrammi non è selezionato, l’impostazione di fusione del fotogramma del livello è irrilevante. Consultate Fusione fotogrammi.

Effetto movimento 

Attiva o disattiva l’effetto movimento per il livello. Se lo switch di composizione Attiva fusione fotogrammi non è selezionato, l’impostazione di effetto movimento del livello è irrilevante. Consultate Effetto movimento.

Livello di regolazione

Identifica il livello come livello di regolazione. (Consultate Livelli di regolazione.)

Livello 3D

Identifica il livello come livello 3D. Se il livello è un livello 3D con sottolivelli 3D, come nel caso di un livello testo con proprietà 3D per carattere, lo switch utilizza questa icona: . (Consultate Panoramica sui livelli 3D e relative risorse.)

Attivare e disattivare la visibilità o l’influenza di un livello o gruppo di proprietà

Lo switch Video (bulbo oculare) per un livello controlla se le informazioni visive per un livello vengono sottoposte a rendering per le anteprime o l’output finale. Se il livello è un livello di regolazione, lo switch Video controlla se gli effetti sul livello vengono applicati o meno all’elemento composto dei livelli sottostanti. Se il livello è una videocamera o una luce, lo switch Video controlla se esso è attivato o disattivato.

Numerosi componenti dei livelli (come tratti pennello, operazioni di tracciato nei livelli forma e animatori di testo nei livelli testo) hanno ciascuno i propri switch Video. Potete utilizzare lo switch Video per alternare individualmente tra la visibilità e l’influenza di questi elementi.

  • Per disattivare la visibilità di un livello, deselezionate lo switch Video per il livello.
  • Per selezionare lo switch Video per tutti i livelli, scegliete Livello > Switch > Mostra tutto il video.
  • Per deselezionare lo switch Video per tutti i livelli ad eccezione dei livelli selezionati, scegliete Livello > Switch > Nascondi altro video.

Isolare un livello

Potete isolare uno o più livelli da animare, visualizzare in anteprima o per creare l’output finale mediante isolamento. L’isolamento evita che tutti gli altri livelli dello stesso tipo vengano sottoposti a rendering, sia per le anteprime nel pannello Composizione che per l’output finale. Ad esempio, se isolate un livello video, i livelli luce e audio rimangono invariati e appaiono quando eseguite l’anteprima o il rendering della composizione. Gli altri livelli video, invece, non appaiono.

  • Per isolare uno o più livelli, selezionateli nel pannello Timeline e fate clic sull’icona Singolo a sinistra dei nomi dei livelli.
  • Per isolare un livello e annullare l’isolamento di tutti gli altri livelli, premete Alt (Windows) o Opzione (Mac OS) e fate clic sull’icona Singolo  a sinistra del nome del livello.

Quando un livello è isolato, lo switch Video viene disattivato per gli altri livelli, a indicare che non sono visibili.

Nel sito Web After Effects Scripts di Lloyd Alvarez potete trovare uno script che consente di associare tag ai livelli e quindi di selezionare, nascondere o isolare i livelli in base ai rispettivi tag. I tag vengono aggiunti ai commenti nella colonna Commenti del pannello Timeline.

Bloccare e sbloccare un livello

Lo switch Blocca impedisce la modifica accidentale dei livelli. Quando un livello è bloccato, non è possibile selezionarlo nei pannelli Composizione o Timeline. Se tentate di selezionare o modificare un livello bloccato, il livello inizia a lampeggiare nel pannello Timeline.

Quando un livello è bloccato, nella colonna Funzionalità A/V appare l’icona Blocca , visualizzata per impostazione predefinita a sinistra del nome del livello nel pannello Timeline.

  • Per bloccare o sbloccare un livello, fate clic sullo switch Blocca per il livello nel pannello Timeline.
  • Per sbloccare tutti i livelli della composizione attiva, scegliete Livello > Switch > Sblocca tutti i livelli.

Etichette colori per livelli, composizioni ed elementi di metraggio

Potete usare le etichette (riquadri colorati nella colonna Etichetta) nel pannello Progetto e nel pannello Timeline per organizzare e gestire composizioni, elementi e livelli del metraggio. Per impostazione predefinita, i vari colori delle etichette indicano diversi tipi di elementi di metraggio, ma potete assegnare i colori delle etichette per indicare le categorie desiderate.

Nota:

Rinominate i gruppi di livelli per meglio organizzare e suddividere in categorie i livelli e gli elementi di metraggio. Per visualizzare i nomi delle etichette nella colonna Etichetta, allargate la colonna impostando un valore maggiore della larghezza predefinita.

  • Per selezionare tutti i livelli con lo stesso colore di etichetta, selezionate un livello con quel colore di etichetta e scegliete Modifica > Etichetta > Seleziona gruppo etichetta.
  • Per modificare il colore di un’etichetta per un livello, fate clic sull’etichetta nel pannello Timeline e scegliete un colore.
  • Per modificare il colore di un’etichetta per tutti i livelli con quel colore di etichetta, selezionate uno dei livelli appartenenti al gruppo di etichette, scegliete Modifica > Etichetta > Seleziona gruppo etichetta e scegliete Modifica > Etichetta > [nome colore].
  • Per modificare nomi e colori predefiniti per le etichette, scegliete Modifica > Preferenze > Etichette (Windows) o After Effects > Preferenze > Etichette (Mac OS).
  • Per modificare le associazioni predefinite dei colori delle etichette con i tipi di sorgente, scegliete Modifica > Preferenze > Etichette (Windows) o After Effects > Preferenze > Etichette (Mac OS).
  • Per disattivare l’uso del colore dell’etichetta di un livello per le maniglie e i tracciati animati dei livelli, scegliete Modifica > Preferenze > Aspetto (Windows) o After Effects > Preferenze > Aspetto (Mac OS) e deselezionate Usa colore etichetta per tracciati e maniglie livello.
  • Per disattivare l’uso di un livello, un elemento di metraggio o il colore dell’etichetta di una composizione nelle schede dei relativi pannelli, scegliete Modifica > Preferenze > Aspetto (Windows) o After Effects > Preferenze > Aspetto (Mac OS) e deselezionate Usa colore etichetta per schede correlate.

Nota:

per impostazione predefinita, i colori delle etichette dei pannelli non rispondono alla funzione Luminosità delle preferenze Aspetto. Affinché Luminosità possa agire anche sui colori delle etichette dei pannelli, selezionate l’opzione Riguarda i colori etichette, nelle preferenze Aspetto.

Mostrare e nascondere i livelli nel pannello Timeline

Potete contrassegnare un livello come inattivo e quindi usare lo switch di composizione Nascondi livelli inattivi nella parte superiore del pannello Timeline per nascondere tutti i livelli inattivi nella struttura dei livelli del pannello Timeline. I livelli inattivi si rivelano utili per aumentare lo spazio nel pannello Timeline in modo da mostrare i livelli e le proprietà dei livelli da regolare.

L’icona della colonna Switch indica se un livello è inattivo o attivo .

I livelli inattivi vengono comunque sottoposti a rendering, sia per le anteprime che per l’output finale. Per escludere i livelli dalle anteprime o dall’output finale, usate lo switch Video o trasformate il livello in un livello guida.

  • Per alternare tra lo stato inattivo e lo stato attivo di un livello, fate clic sullo switch Inattivo del livello, oppure selezionate il livello nel pannello Timeline e scegliete Livello > Switch > Inattivo.
  • Per alternare tra l’occultamento e la visualizzazione di tutti i livelli inattivi, fate clic per selezionare o deselezionare lo switch di composizione Nascondi livelli inattivi nella parte superiore del pannello Timeline, oppure scegliete Nascondi livelli inattivi nel menu del pannello Timeline.

Potete inoltre filtrare i livelli nel pannello Timeline per visualizzare solo i livelli con le proprietà corrispondenti a una stringa di ricerca o ad altre determinate caratteristiche. Consultate Cercare e filtrare nei pannelli Timeline, Progetto ed Effetti e predefiniti e Visualizzare proprietà e gruppi nel pannello Timeline (scelte rapide da tastiera).

Nel sito Web After Effects Scripts di Lloyd Alvarez potete trovare uno script che consente di associare tag ai livelli e quindi di selezionare, nascondere o isolare i livelli in base ai rispettivi tag. I tag vengono aggiunti ai commenti nel campo Commenti del pannello Timeline.

Qualità immagine del livello e posizionamento subpixel

L’impostazione di qualità di un livello determina la precisione con la quale esso viene sottoposto a rendering e influenza inoltre la precisione degli altri calcoli relativi al livello, come il tracciamento del movimento e l’uso del livello come livello di controllo per un effetto composto.

I livelli duplicati o divisi conservano l’impostazione Qualità del livello originale.

Potete scegliere tra tre opzioni di qualità: Alta, Bozza o Reticolo. Se selezionate Alta, potete scegliere tra campionamento bicubico o bilineare, descritto nella sezione successiva.

Per passare alla qualità Alta (campionamento bilineare), Bozza e Alta (campionamento bicubico) per i livelli selezionati, fate clic sullo switch Qualità nel pannello Timeline. Per scegliere tra tutte queste opzioni più l’opzione Reticolo, scegliete Livello > Qualità:

Alta

Visualizza ed esegue il rendering di un livello in base a posizionamento subpixel, anti-alias, ombreggiatura 3D e calcolo completo degli effetti applicati. Alta richiede il tempo più lungo per eseguire il rendering (sia per le anteprime che per l’output finale).

Bozza

Visualizza un livello con una qualità poco precisa. La qualità bozza visualizza ed esegue il rendering di un livello senza anti-alias e posizionamento subpixel; inoltre, alcuni effetti non vengono calcolati con precisione.

Reticolo

Visualizza un livello sotto forma di riquadro, senza il contenuto del livello stesso. I reticoli dei livelli vengono visualizzati e sottoposti a rendering più velocemente rispetto ai livelli ottenuti dal rendering impostato sulla qualità Alta o Bozza.

Campionamento bilineare e bicubico

Per i livelli con qualità impostata su Alta, potete scegliere il campionamento bicubico o bilineare. Questa impostazione per livello determina il modo in cui i pixel vengono campionati per le trasformazioni, ad esempio per il ridimensionamento.

Le scelte rapide da tastiera predefinite per l’impostazione del metodo di campionamento per i livelli selezionati sono Alt+B (Windows) e Opzione+B (Mac OS) per Alta/Bilineare; Alt+Maiusc+B (Windows) e Opzione+Maiusc+B (Mac OS) per Alta/Bicubico.

Il campionamento bicubico fa un uso maggiore del processore rispetto al campionamento bilineare, e non offre sempre la qualità migliore. Può infatti produrre artefatti in alcune circostanze, ad esempio anelli o striature in corrispondenza di transizioni nette da un colore a un altro. Il campionamento bicubico è spesso la scelta migliore nei casi in cui le transizioni da un colore a un altro sono più graduali, ad esempio nella maggior parte di immagini fotografiche, ma non necessariamente per grafica dai bordi netti. Il campionamento bicubico è più utile per l’ingrandimento che non per la riduzione.

Nota:

Le texture nel modulo di rendering 3D per ray tracing non utilizzano il campionamento bicubico, ma sempre quello bilineare. Anche le trasformazioni all’interno di effetti utilizzano il campionamento bilineare, a meno che l’effetto non implementi specificatamente un altro metodo (come nel caso di un effetto plug-in di ridimensionamento dedicato o un effetto di distorsione).

Posizionamento subpixel

I valori delle proprietà (come Posizione e Punto di ancoraggio) in After Effects non sono limitati ai valori interi, in quanto possono avere anche dei valori frazionari. Questo consente di eseguire un’animazione uniforme, in quanto un valore viene interpolato da un fotogramma chiave all’altro. Ad esempio, se un valore Posizione va da [0,0,0] in un fotogramma chiave nel tempo 0 a un valore di [0,0,80] nel tempo 1 secondo in una composizione di 25 fotogrammi al secondo, allora il valore del fotogramma 1 è [0,0,3.2].

After Effects calcola tutti i valori spaziali, come Posizione e punti di controllo dell’effetto, fino a una precisione di 1/65,536 di pixel. Questa caratteristica è definita precisione subpixel.

Se i pixel di un livello non sono posizionati direttamente sui bordi dei pixel della composizione, si verifica una piccola quantità di sfocatura—molto simile all’anti-alias. Questa sfocatura non è un problema per un oggetto in movimento, in quanto gli oggetti in movimento sono soggetti all’effetto movimento, ma possono attenuare i piccoli dettagli in un’immagine statica. Inoltre, se un’immagine si sta muovendo lentamente o semplicemente alla velocità sbagliata, potreste avere l’impressione che essa stia oscillando tra nitidezza e sfocatura.

Poiché il punto di ancoraggio predefinito di un livello è il centro di un oggetto, gli oggetti di forma insolita hanno punti di ancoraggio non interi e appaiono sfocati. Per ridurre al minimo la sfocatura e il risultato di messa a fuoco/non a fuoco, attenetevi alle seguenti indicazioni:

  • Create grafici con dimensioni dispari o pari, in base alle dimensioni della composizione. Ad esempio, se la composizione è di 640x480 pixel, create grafica con dimensioni pari (come 100x100 pixel); se la composizione è di 99x99 pixel, create grafica con dimensioni dispari (come 75x53 pixel).

  • Impostate le informazioni sulla posizione per la grafica (compresa la posizione di blocco e i fotogrammi chiave della posizione finale) su numeri interi e non numeri frazionari.

Rasterizzare in modo continuo un livello contenente grafica vettoriale

Quando importate grafica vettoriale, After Effects la rasterizza automaticamente. Tuttavia, se desiderate ridimensionare un livello contenente grafica vettoriale superiore al 100%, dovete rasterizzare in modo continuo il livello per mantenere la qualità dell’immagine. Potete rasterizzare in modo continuo la grafica vettoriale all’interno di livelli basati su file di Illustrator, SWF, EPS e PDF. La rasterizzazione continua fa sì che After Effects rasterizzi il file a seconda delle necessità in base alla trasformazione per ciascun fotogramma. Un livello rasterizzato in modo continuo, generalmente genera risultati di qualità superiore, ma il rendering potrebbe venire eseguito più lentamente.

I livelli testo e i livelli forma sono sempre rasterizzati in modo continuo.

Quando applicate un effetto a un livello rasterizzato in modo continuo, i risultati possono essere diversi da quelli ottenibili applicando l’effetto a un livello senza rasterizzazione continua. Questa differenza nei risultati avviene perché l’ordine di rendering predefinito per il livello cambia. L’ordine di rendering predefinito per un livello senza rasterizzazione continuo è maschere, seguito da effetti e quindi da trasformazioni, mentre l’ordine di rendering predefinito di un livello rasterizzato in modo continuo è maschere, seguito da trasformazioni e quindi effetti.

Sia che decidiate di rasterizzare in continuo sia che decidiate di non farlo, se visualizzate e renderizzate una composizione usando Qualità alta, After Effects eseguirà l’antialising dell’immagine.

Non potete aprire né interagire con un livello rasterizzato in modo continuo in un pannello Livello. Una conseguenza di questa limitazione è che non potete disegnare direttamente su un livello rasterizzato in modo continuo. Tuttavia, potete copiare e incollare i tratti di disegno da altri livelli.

Immagine proveniente da un file di Illustrator importato con livello rasterizzato
Immagine proveniente da un file di Illustrator importato

A. Originale B. Ingrandimento con Rasterizza in modo continuo disattivato C. Ingrandimento con Rasterizza in modo continuo attivato 
  1. Nel pannello Timeline, fate clic sullo switch Rasterizza in modo continuo del livello , che corrisponde allo switch Comprimi trasformazioni per i livelli di precomposizione.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online