Guida utente Annulla

Utilizzare l’animazione basata sui dati

  1. Guida utente di After Effects
  2. Versioni beta
    1. Panoramica del programma beta
    2. After Effects Beta Home
    3. Funzioni in versione beta
      1. Pannello Proprietà (Beta)
      2. Importazione di modelli 3D (beta)
      3. Gestione del colore OpenColorIO e ACES (Beta)
  3. Guida introduttiva
    1. Introduzione ad After Effects
    2. Novità di After Effects 
    3. Note sulla versione | After Effects
    4. Requisiti di sistema di After Effects
    5. Scelte rapide da tastiera di After Effects
    6. Formati di file supportati | After Effects
    7. Consigli sull’hardware
    8. After Effects per Apple Silicon
    9. Pianificazione e impostazione
  4. Spazi di lavoro
    1. Elementi generali dell’interfaccia utente
    2. Interfaccia di After Effects
    3. Flussi di lavoro
    4. Spazi di lavoro, pannelli e visualizzatori
  5. Progetti e composizioni
    1. Progetti
    2. Nozioni di base sulla composizione
    3. Effettuare la precomposizione, la nidificazione e il pre-rendering
    4. Visualizzare informazioni dettagliate sulle prestazioni con Profilo composizione
    5. Modulo di rendering per composizioni CINEMA 4D
  6. Importazione del metraggio
    1. Preparazione e importazione di immagini fisse
    2. Importazione da After Effects e Adobe Premiere Pro
    3. Importazione e interpretazione di video e audio
    4. Preparazione e importazione di file di immagine 3D
    5. Importazione e interpretazione degli elementi di metraggio
    6. Operazioni con gli elementi di metraggio
    7. Rilevare i punti di modifica utilizzando Rilevamento modifiche scena
    8. Metadati XMP
  7. Testo e grafica
    1. Testo
      1. Formattazione dei caratteri e pannello Carattere
      2. Effetti Testo
      3. Creazione e modificazione di livelli testo
      4. Formattazione paragrafi e pannello Paragrafo
      5. Estrusione di livelli di testo e forma
      6. Animazione del testo
      7. Esempi e risorse per l’animazione del testo
      8. Modelli di testo dinamico
    2. Grafica animata
      1. Utilizzare modelli di grafica animata in After Effects
      2. Utilizzare le espressioni per creare elenchi a discesa nei modelli di grafica animata
      3. Utilizzare Proprietà essenziali per creare modelli di grafica animata
      4. Sostituire immagini e video in modelli di grafica animata e in Proprietà essenziali
  8. Disegni, colori e tracciati
    1. Panoramica su livelli forma, tracciati e grafica vettoriale
    2. Strumenti di disegno: Pennello, Timbro clona e Gomma
    3. Assottigliare i tratti forma
    4. Attributi forma, operazioni di disegno e operazioni con i tracciati per i livelli forma
    5. Usare l’effetto forma Sposta tracciati per modificare le forme
    6. Creazione delle forme
    7. Creare maschere
    8. Rimuovere oggetti dai video con Riempimento in base al contenuto
    9. Pennello a rotoscopio e Migliora mascherino
  9. Livelli, marcatori e fotocamera
    1. Selezione e disposizione di livelli
    2. Modalità di fusione e stili di livello
    3. Livelli 3D
    4. Proprietà dei livelli
    5. Creazione livelli
    6. Gestione livelli
    7. Marcatori livello e marcatori composizione
    8. Videocamere, luci e punti di interesse
  10. Animazione, fotogrammi chiave, tracciamento del movimento e tipo di trasparenza
    1. Animazione
      1. Fondamenti di animazione
      2. Animazione con gli strumenti Marionetta
      3. Gestione e animazione di tracciati forma e maschere
      4. Animazione di forme create con Sketch e Capture con After Effects
      5. Strumenti di animazione assortiti
      6. Utilizzare l’animazione basata sui dati
    2. Fotogramma chiave
      1. Interpolazione fotogrammi chiave
      2. Impostare, selezionare ed eliminare i fotogrammi chiave
      3. Modifica, spostamento e copia di fotogrammi chiave
    3. Tracciamento del movimento
      1. Tracciamento e stabilizzazione del movimento
      2. Tracciamento dei volti
      3. Tracciamento maschera
      4. Riferimento maschera
      5. Velocità
      6. Dilatazione e modifica del tempo
      7. Codice di tempo e unità per la visualizzazione del tempo
    4. Trasparenza
      1. Tipo di trasparenza
      2. Effetti Trasparenza
  11. Trasparenza e composizione
    1. Composizione e trasparenza: panoramica e risorse
    2. Canali alfa e maschere
    3. Mascherini traccia e mascherini mobili
  12. Regolazione del colore
    1. Concetti di base sul colore
    2. Gestione colore
    3. Effetti di correzione del colore
  13. Effetti e predefiniti di animazione
    1. Panoramica sugli effetti e sui predefiniti di animazione
    2. Elenco di effetti
    3. Effetti di simulazione
    4. Effetti di stilizzazione
    5. Effetti audio
    6. Effetti di distorsione
    7. Effetti di prospettiva
    8. Effetti canale
    9. Effetti di generazione
    10. Effetti di transizione
    11. Effetto di riparazione scansione lineare
    12. Effetti sfocatura e nitidezza
    13. Effetti canale 3D
    14. Effetti di utilità
    15. Effetti mascherino
    16. Effetti di disturbo e granulosità
    17. Effetto mantieni dettagli (ingrandimento)
    18. Effetti obsoleto
  14. Espressioni e automazione
    1. Espressione
      1. Concetti di base sull’espressione
      2. Informazioni sul linguaggio dell’espressione
      3. Utilizzo dei controlli di espressione
      4. Differenze di sintassi tra i motori di espressione JavaScript e Legacy ExtendScript
      5. Modifica di espressioni
      6. Errori nelle espressioni
      7. Utilizzo dell’editor espressioni
      8. Utilizzo delle espressioni per modificare e accedere alle proprietà di testo
      9. Riferimenti del linguaggio delle espressioni
      10. Esempi di espressione
    2. Automazione
      1. Automazione
      2. Script
  15. Video immersivo, VR e 3D
    1. Creare ambienti VR in After Effects
    2. Applicare effetti video immersivi
    3. Strumenti di composizione per i video VR/360
    4. Tracciamento del movimento della videocamera 3D
    5. Lavorare in Design Space 3D
    6. Gizmo Trasformazione 3D
    7. Ulteriori informazioni sull’animazione 3D
    8. Anteprima delle modifiche apportate ai progetti 3D con il sistema Mercury 3D
    9. Aggiungere grafica reattiva agli elementi grafici 
  16. Visualizzazioni e anteprime
    1. Visualizzazione in anteprima
    2. Anteprima video con Mercury Transmit
    3. Modifica e utilizzo di visualizzazioni
  17. Rendering ed esportazione
    1. Nozioni di base su rendering ed esportazione
    2. Codifica H.264 in After Effects
    3. Esportare un progetto After Effects come progetto Adobe Premiere Pro
    4. Convertire filmati
    5. Rendering di più fotogrammi
    6. Rendering automatico e rendering di rete
    7. Rendering ed esportazione di immagini fisse e sequenze di immagini fisse
    8. Utilizzo del codec GoPro CineForm in After Effects
  18. Lavorare con altre applicazioni
    1. Dynamic Link e After Effects
    2. Utilizzo di After Effects con altre applicazioni
    3. Impostazioni sincronizzazione in After Effects
    4. Creative Cloud Libraries in After Effects
    5. Plug-in
    6. Cinema 4D e Cineware
  19. Collaborazione: Frame.io e Progetti team
    1. Collaborazione in Premiere Pro e After Effects
    2. Frame.io
      1. Installare e attivare Frame.io
      2. Utilizzare Frame.io con Premiere Pro e After Effects
      3. Domande frequenti
    3. Progetti team
      1. Introduzione ai Progetti team
      2. Creare un progetto team
      3. Collaborare con Progetti team
  20. Memoria, archiviazione, prestazioni
    1. Memoria e archiviazione
    2. Come After Effects gestisce i problemi di memoria insufficiente durante la visualizzazione dell’anteprima    
    3. Migliorare le prestazioni
    4. Preferenze
    5. Requisiti di GPU e driver GPU per After Effects

Scopri come usare l’animazione basata sui dati.

Per creare animazioni basate sui dati, vengono utilizzati dati in tempo reale, raccolti da varie sorgenti, che influiscono sulle animazioni nella composizione. I dati possono provenire da più sorgenti e possono essere statici o variabili. Importa i dati nel progetto After Effects e utilizzali come input con cui animare grafici e caratteri e controllare effetti visivi, titoli di filmati e altra grafica animata.

Esempio di animazione basata sui dati
Esempio di animazione basata sui dati

Sorgenti di dati

Puoi utilizzare i dati di quasi tutte le sorgenti possibili come:

  • File di dati generati da dispositivo: dati da dispositivi quali i fitness tracker, che rilevano l’attività tramite appositi sensori e li memorizzano in diversi formati di file. Si tratta di dati variabili nel tempo come, ad esempio, velocità, altitudine, distanza, frequenza cardiaca e diversi altri parametri relativi all’attività svolta dall’utente.
  • Dati statici generati dall’utente: dati statici globali quali risultati di sondaggi che possono essere modificati per integrare i grafici. Un file di dati creato dall’utente potrebbe offrire un flusso di lavoro per dati globali.
  • URL: dati in tempo reale da siti Web, quali il percorso di entrata e uscita di un utente che naviga in una pagina Web.
  • Metadati: dati incorporati nei metadati di un file video.

Formati di input

Puoi importare i file di dati nei seguenti formati:

  • JSON
  • MGJSON
  • CSV
  • TSV
  • BVH

Se i file di dati che hai a disposizione sono in altri formati, convertili in uno dei formati di file di importazione supportati e importali nel progetto di After Effects. Sono disponibili vari strumenti per convertire i file di dati in formati supportati da After Effects.

Animazione basata sui dati

Supporto per standard JSON (.json)

Puoi importare un file JSON standard in After Effects come elemento di metraggio. I file di dati funzionano in background. After Effects fa direttamente riferimento ai dati in questi file di dati per definire le animazioni nei progetti. L’elemento di metraggio JSON non è rappresentato come flusso di dati nel pannello Timeline. Puoi fare riferimento ai dati mediante le espressioni come oggetto JSON valutato.

Puoi modificare le espressioni per cambiare il modo in cui i dati vengono usati come riferimento. Puoi scrivere i dati in un editor di testo, cui After Effects fa riferimento per definire le animazioni. Il supporto JSON si basa sullo schema JSON, che specifica e definisce il modo in cui un’applicazione utilizza e modifica i dati JSON.

I tipi di dati di base JSON sono:

  • Numero: un numero decimale firmato.
  • Stringa: una sequenza di zero o più caratteri Unicode.
  • Booleano: valori true o false.
  • Matrice: (o array) un elenco ordinato di zero o più valori.
  • Oggetto: una raccolta non ordinata di coppie di valori o nomi in cui i nomi (chiavi) sono stringhe.
  • Null: un valore vuoto, rappresentato dalla parola "null".
Nota:

Se intendi usare Adobe Media Encoder o collegare le composizioni a Premiere Pro, aggiungi il file sorgente dati alla Timeline anziché usare le espressioni per fare riferimento alle voci di dati che si trovano nel pannello Progetto. L’aggiunta del file di dati come livello di composizione garantirà inoltre che verrà copiato quando si sceglie Raccogli file.

Utilizzare i file JSON in After Effects

Per utilizzare un file standard JSON, segui questi passaggi:

  1. Seleziona File > Importa > File.

  2. Seleziona un file .JSON e fai clic su Apri.

  3. Il file viene aggiunto alla finestra del progetto. Crea una composizione con l’elemento di metraggio.

  4. Aggiungi un solido alla composizione. Per aggiungere un solido, seleziona Livello > Nuovo > Solido.

  5. Nel pannello Timeline, apri le proprietà del livello solido e quindi il parametro Opacità usando Alt + clic per Windows e + clic per macOS.

  6. Modifica i dati nell’espressione per modificare l’animazione. Puoi controllare i dati JSON e il file di dati in cui sono memorizzate tutte le informazioni.

  7. Puoi anche sostituire il file JSON con un altro file JSON per modificare i dati cui si fa riferimento. Per sostituirlo, seleziona Sostituisci metraggio > File e apri il nuovo file dal computer.

Per utilizzare i dati, puoi applicare un’espressione alla proprietà che desideri basare sui dati, quindi:

  1. Utilizza l’attributo sourceData per leggere i dati in un file .JSON. Ad esempio:

    var sampleData = footage("sample.json").sourceData;
  2. Per restituire il valore corrispondente, fai riferimento alla proprietà specifica all’interno dei dati JSON. Ad esempio,

    myData.engineData.RPM oppure myData.latitude.value.

Supporto per grafica animata JSON (.mgJSON)

Puoi importare un file di dati MGJSON come elemento di metraggio nel progetto. Quando aggiungi un elemento di metraggio di dati a una composizione, i flussi di proprietà dei dati vengono raggruppati in un gruppo di livello superiore, “Dati”. Il gruppo Dati presenta i dati del metraggio come proprietà. Ogni proprietà nel gruppo Dati è un’espressione collegata al file di metraggio che accede al valore del file di dati utilizzando l’espressione footage("foo.mgjson").dataValue(N). Qui N è il percorso verso il flusso di dati nel file. MGJSON funziona in base a uno schema, studiato per semplificare il riferimento e l’importazione dei flussi di dati in After Effects.

A ogni singola proprietà dei dati è applicata un’espressione che la collega ai dati nel file MGJSON. Se il file MGJSON sorgente viene modificato, i valori delle proprietà dei dati vengono aggiornati automaticamente.

Nel pannello Timeline, puoi aprire la sezione dei livelli Dati e utilizzare il selettore per collegare i parametri ad altri parametri. Le modifiche vengono inserite automaticamente.

Utilizzare elementi di metraggio MGJSON in After Effects

Per utilizzare un file MGJSON, segui questi passaggi:

  1. Seleziona File > Importa > File.

  2. Per importare, seleziona un file MGJSON e quindi Apri.

  3. Il file viene aggiunto alla finestra del progetto. Crea una composizione con l’elemento di metraggio.

  4. Importa una risorsa nel progetto e aggiungila alla composizione.

  5. Nel pannello Timeline, apri la sezione delle proprietà dell’elemento di metraggio.

  6. Seleziona una delle proprietà della risorsa, ad esempio Rotazione, su uno dei flussi di dati nel livello di dati. La proprietà della risorsa fa ora riferimento ai dati provenienti dal livello di dati. Ogni flusso di dati riflesso ha un’espressione i cui valori vengono richiamati dal file di metraggio.

  7. Quando visualizzi in anteprima l’elemento di metraggio, la risorsa viene animata in base al flusso di dati del livello di dati.

Puoi inoltre convertire i campioni di dati dal file di dati in fotogrammi chiave. Per la conversione in fotogrammi chiave, effettua i seguenti passaggi:

  1. Importa il file MGJSON nel progetto e trascinalo nel pannello Timeline.

  2. Fai clic con il pulsante destro del mouse sul livello dati e seleziona Assistente fotogrammi chiave > Crea fotogrammi chiave da dati dal menu.

  3. Per visualizzare i fotogrammi chiave, apri la sezione del livello dei dati.

Nota:

Dopo la conversione in fotogramma chiave, i dati non sono più in tempo reale e non vi si fa riferimento dal file di dati.

Puoi inoltre visualizzare i dati in tempo reale come grafico in Editor grafico. Per visualizzarli, fai clic sull’icona Editor grafico nel pannello Timeline.

L’animazione basata sui dati utilizza la panoramica delle espressioni. Per ulteriori informazioni, consulta Animazione basata sui dati (riferimento espressioni).

Allineare la sequenza temporale del video ai dati mgJSON

Il comando Livello > Tempo > Allinea video ai dati esegue uno scostamento dei livelli video di diversi fotogrammi, come specificato nel file mgJSON. Puoi utilizzare questo comando per allineare il video nel tempo ai campioni di dati archiviati in un file mgJSON corrispondente. Ad esempio, se hai acquisito i dati di una corsa, ma l’ora di inizio del video non corrisponde all’ora di inizio dei dati acquisiti, puoi specificare lo scostamento così da allineare automaticamente i dati.

Per allineare la sequenza temporale del video ai dati mgJSON, segui questi passaggi:

  1. Aggiungi il file .mgJSON alla composizione che contiene i livelli di destinazione.
  2. Seleziona sia il livello .mgJSON che il livello di destinazione.
  3. Seleziona Livello > Tempo > Allinea video ai dati.

A questo scopo, il file mgJSON deve contenere un gruppo videoSyncTimeList che contiene:

  • il nome di uno o più livelli di destinazione (fileName)
  • il numero di fotogrammi per scostare (frameNumber) questi livelli dall’inizio del livello dei dati.

Ad esempio:

"videoSyncTimeList": [
  {
    "fileName": "sample1.mp4",
    "frameNumber": 1000
  },

  {
    "fileName": "sample2.mp4",
    "frameNumber": -1000
  }

Il valore di fileName deve corrispondere al nome del livello di un livello selezionato, non al nome del file sorgente del livello. Se nella composizione sostituisci il nome di un livello con il nome sorgente, ad esempio rinomini il livello "sample1.mp4" in "Race Camera 1", devi cambiare anche il valore di fileName nel file mgJSON. I livelli a cui fa riferimento fileName non devono essere elementi di metraggio con un file sorgente, possono essere anche tinte unite, composizioni nidificate o altri tipi di livello.

I valori positivi di frameNumber scostano il livello di destinazione a sinistra (prima del livello di dati). I valori negativi di frameNumber scostano il livello di destinazione a destra (dopo il livello di dati). Il valore 0 per frameNumber allinea l’inizio del livello di destinazione all’inizio del livello di dati.

Supporto per CSV (.csv) e TSV (.tsv o .txt)

Puoi importare file CSV (valori separati da virgole) e TSV (valori separati da tabulazioni) come elementi di metraggio in After Effects e utilizzarli come sorgenti dati. I file CSV e TSV memorizzano i dati tabulari sotto forma di testo normale, con valori separati da virgola o da tabulazioni. I file di dati CSV e TSV funzionano in modo simile ai file JSON.

Per utilizzare i file di dati CSV o TSV in After Effects, segui questi passaggi:

  1. Importa un file CSV o TSV nel progetto come elemento di metraggio, analogamente al modo in cui importi un file video, audio o di altro tipo. Utilizza uno dei seguenti modi per importare i file come elemento di metraggio:

    • Seleziona File> Importa > File.
    • Fai clic con il pulsante destro del mouse sul pannello Progetti e seleziona Importa > Tipo file.
    • Fai doppio clic sul pannello Progetto.
  2. Il file viene aggiunto alla finestra del progetto. Crea una composizione con il file.

  3. Nel pannello Timeline, apri la sezione delle proprietà dell’elemento di metraggio. Collega le proprietà dei dati del livello nella composizione a un altro livello con il selettore espressioni o il selettore di collegamento proprietà. Per aprire il campo di testo delle espressioni, tieni premuto Maiusc e fai clic sull’icona del timer sul nome del livello. Puoi anche collegare le proprietà dei dati con il comando Modifica > Copia con collegamenti proprietà.

    Per informazioni sulle proprietà dei dati del livello nella Timeline, consulta Nozioni di base sulle proprietà dei dati.

  4. Per fare riferimento al file di metraggio dei dati, utilizza un’espressione per la proprietà che desideri basare sui dati. Utilizza l’attributo di metraggio dataValue() per leggere i dati da una riga o da una colonna specifica. Le righe e le colonne presentano indice zero. Ad esempio, footage("sample.tsv").dataValue([15,1]) restituisce il valore sulla riga 16 della seconda colonna.

Nozioni di base sulle proprietà dei dati

Quando aggiungi un file JSON, CSV o TSV a una composizione e apri le proprietà, queste conterranno solo il gruppo di proprietà Dati, anziché il gruppo di proprietà Trasformazione. Il gruppo di proprietà Dati contiene la gerarchia dei dati come definita nel file.

Gruppo di proprietà Dati JSON nel pannello Timeline
Gruppo di proprietà Dati JSON nel pannello Timeline

Gruppo di proprietà Dati CSV e TSV nel pannello Timeline
Gruppo di proprietà Dati CSV e TSV nel pannello Timeline

Questo gruppo di dati funziona in modo simile al modo in cui After Effects tratta i file di grafica animata JSON (.mgJSON). La differenza è che i file JSON, CSV e TSV possono contenere solo valori di dati statici, mentre i file mgJSON possono contenere dati dinamici (che cambiano nel tempo).

A ogni singola proprietà dei dati è applicata un’espressione che la collega ai dati nel file JSON, CSV o TSV. Se cambi il file di dati sorgente, i valori della proprietà dei dati riflettono questa modifica.

Collegare le proprietà con il selettore di collegamento proprietà

Se non vuoi scrivere espressioni complesse, puoi utilizzare il selettore di collegamento proprietà, oppure il comando Modifica > Copia con collegamenti proprietà per collegare le proprietà dei dati a quelle di altri livelli. Man mano che si collegano i livelli, il selettore di collegamento proprietà scrive automaticamente le espressioni.

Librerie di funzioni per espressioni personalizzate - JSX

In After Effects 15.0 era possibile importare un file JSON che definiva le funzioni JavaScript personalizzate e che potevano essere utilizzate come libreria di funzioni per le espressioni personalizzate. In After Effects 15.1, gli oggetti JavaScript non rappresentano una sintassi valida per JSON. After Effects 15.1 utilizza un modulo di analisi JSON diverso molto rigido che non consente l’importazione di un file JSON con sintassi non valida.

Se provi a importare un file JSON con una funzione JavaScript definita in After Effects 15.1 o ad aprire un progetto che contiene tale file, After Effects presenta un errore.

Per evitare l’errore, puoi importare in After Effects 15.1 un file con estensione di sintassi JavaScript (.jsx). Il contenuto del file JSX può essere uguale a quello del file JSON importato in After Effects 15.0, devi solo cambiare l’estensione del nome del file in .jsx. Se apri un progetto esistente che contiene un file JSON non funzionante, utilizza File > Sostituisci metraggio per sostituire il file JSON con il file JSX. Le panoramiche delle espressioni per il file JSON vengono sostituite dalle panoramiche per i file JSX.

Problemi noti con l’animazione basata sui dati

Quando utilizzi l’animazione basata sui dati in After Effects, potresti riscontrare alcuni problemi noti. Per un elenco completo, consulta Problemi noti con l’animazione basata sui dati.

Logo Adobe

Accedi al tuo account