Dynamic Link e After Effects

Dynamic Link

In precedenza, la condivisione di risorse multimediali tra applicazioni di post-produzione richiedeva in genere l’esecuzione del rendering e l’esportazione del materiale da un’applicazione prima di consentirne l’importazione in un’altra. Tale flusso di lavoro era poco efficiente e particolarmente lungo. Per apportare modificare alla risorsa originale, era necessario eseguire nuovamente il rendering e l’esportazione della risorsa. Inoltre, più versioni di una risorsa sottoposta a rendering ed esportata occupano molto spazio su disco e possono essere di difficile gestione.

Dynamic Link offre un’alternativa a questo flusso di lavoro, Potete creare collegamenti dinamici tra After Effects e Premiere Pro. La semplicità della creazione di un collegamento dinamico è paragonabile all’importazione di qualsiasi tipo di risorsa. Le risorse collegate dinamicamente sono contrassegnate da icone e colori di etichetta specifici che ne facilitano l’identificazione. I collegamenti dinamici vengono salvati in progetti generati da tali applicazioni.

Creare e collegare composizioni After Effects con Dynamic Link

Potete creare nuove composizioni di After Effects e creare collegamenti dinamici alle stesse da Adobe Premiere Pro. Puoi anche creare collegamenti dinamici a composizioni di After Effects esistenti da Adobe Premiere Pro.

Creare una composizione da clip in Adobe Premiere Pro

Potete sostituire le clip selezionate in Adobe Premiere Pro con composizioni di After Effects collegate dinamicamente basate su tali clip. La nuova composizione eredita le impostazioni di sequenza da Adobe Premiere Pro.

  1. Aprite Premiere Pro e selezionate le clip da sostituire.

  2. Fate clic con il pulsante destro del mouse su una delle clip selezionate.
  3. Seleziona Sostituisci con composizione After Effects.

    Viene aperto After Effects (se non è già aperto) e viene creata una nuova composizione collegata.

Crea una composizione collegata dinamicamente da Adobe Premiere Pro

La creazione di una nuova composizione collegata dinamicamente da Adobe Premiere Pro avvia After Effects. In After Effects viene quindi creato un progetto e una composizione con le dimensioni, le proporzioni pixel, la frequenza fotogrammi e la frequenza di campionamento audio del progetto di origine (se After Effects è già in esecuzione, viene creata una composizione nel progetto corrente). Il nome della nuova composizione è basato sul nome del progetto di Adobe Premiere Pro seguito da Composizione collegata [x].

  1. In Adobe Premiere Pro, scegliete File > Adobe Dynamic Link > Nuova composizione After Effects. Nella versione 2014 di Premiere Pro, potete importare composizioni mediante Browser multimediale. Per ulteriori informazioni, consultate le sezioni seguenti di Premiere Pro:

  2. Se viene visualizzata la finestra di dialogo Salva con nome di After Effects, immettete un nome e un percorso per il progetto di After Effects e fate clic su Salva.

    Nota:

    Quando create una composizione di After Effects collegata dinamicamente, la durata della composizione è impostata su 30 secondi. Per modificare la durata, selezionate la composizione in After Effects e scegliete Composizione > Impostazioni composizione. Fare clic sulla scheda Base e specificare un nuovo valore per Durata.

Per ottenere risultati migliori, fare corrispondere le impostazioni di composizione (come le dimensioni, le proporzioni pixel, la frequenza fotogrammi) a quelle usate nel progetto Adobe Premiere Pro.

  1. Effettuate una delle seguenti operazioni:
    • In Adobe Premiere Pro, scegliete File > Adobe Dynamic Link > Importa composizione After Effects. Scegliere un file di progetto di After Effects (.aep), quindi scegliere una o più composizioni.

    • In Adobe Premiere Pro, scegliete un file di progetto After Effects e fate clic su Apri. Scegliete quindi una composizione nella finestra di dialogo visualizzata e fate clic su OK.

    • Trascinare una o più composizioni dal pannello Progetto di After Effects al pannello Progetto di Adobe Premiere Pro.

    • Trascinare un file di progetto di After Effects nel pannello Progetto di Premiere Pro. Se il file di progetto di After Effects contiene più composizioni, si apre la finestra di dialogo Importa composizione.

Nota:

Puoi collegarti più volte a una singola composizione di After Effects in uno specifico progetto di Adobe Premiere Pro.

Modificare una composizione collegata dinamicamente in After Effects

Usate il comando Modifica originale di Adobe Premiere Pro per modificare una composizione di After Effects collegata. Dopo l’apertura della composizione in After Effects, puoi apportare modifiche alla composizione senza dovere usare nuovamente il comando Modifica originale .

  1. Selezionare la composizione di After Effects in Adobe Premiere Pro oppure scegliere una clip collegata nella timeline e selezionare Modifica > Modifica originale.

  2. Modificare la composizione in After Effects, Quindi, passare ad Adobe Premiere Pro per visualizzare le modifiche.

Le modifiche apportate in After Effects appaiono in Adobe Premiere Pro. Adobe Premiere Pro smette di utilizzare eventuali file di anteprima di cui è stato eseguito il rendering per la clip prima delle modifiche.

Nota:

potete modificare il nome della composizione in After Effects dopo aver creato un collegamento dinamico alla stessa da Adobe Premiere Pro. Adobe Premiere Pro non aggiorna il nome della composizione collegata nel pannello Progetto ma conserva il collegamento dinamico.

Eliminare una composizione o una clip collegata dinamicamente

Puoi eliminare una composizione collegata da un progetto di Adobe Premiere Pro in qualsiasi momento, anche se la composizione è in uso nel progetto.

In qualsiasi momento puoi eliminare le clip collegate dalla timeline di una sequenza o timeline di Adobe Premiere Pro.

  1. In Adobe Premiere Pro, selezionare la composizione o la clip collegata e premere il tasto Canc.

Creare una sequenza collegata in Adobe Premiere Pro con Dynamic Link

La creazione di una sequenza di Adobe Premiere Pro da After Effects avvia Adobe Premiere Pro. In Adobe Premiere Pro vengono quindi creati un progetto e una sequenza con le dimensioni, le proporzioni pixel, la frequenza fotogrammi e la frequenza di campionamento audio del progetto di origine (se Adobe Premiere Pro è già in esecuzione, viene creata una sequenza nel progetto corrente).

  1. In After Effects, scegliere File > Adobe Dynamic Link > Nuova sequenza Premiere Pro.

Per ottenere risultati migliori, fate corrispondere le impostazioni di sequenza e le impostazioni di progetto in Adobe Premiere Pro (ad esempio, dimensioni, proporzioni pixel, frequenza fotogrammi) a quelle nel progetto After Effects.

Effettuate una delle seguenti operazioni:

  • In After Effects, scegliete File > Adobe Dynamic Link > Importa sequenza Premiere Pro. Scegliere un progetto di Adobe Premiere Pro, quindi selezionare una o più sequenze.

  • Trascinare una o più sequenze dal pannello Progetto di Adobe Premiere Pro al pannello Progetto di After Effects.

Prestazioni Dynamic Link

Una clip collegata può fare riferimento a una composizione sorgente complessa. Le azioni eseguite sulla composizione sorgente richiedono tempi di elaborazione maggiori a seconda della complessità. After Effects applica le azioni e rende i dati finali disponibili per Adobe Premiere Pro mediante le funzioni di cache per prestazioni globali e cache del disco persistente. Queste funzioni consentono di migliorare le prestazioni di After Effects utilizzando i fotogrammi memorizzati nella cache quando Premiere Pro richiede i fotogrammi.

Per ridurre i ritardi di riproduzione, effettuare una delle seguenti operazioni:

  • Portare offline la composizione collegata

  • Disattivare una clip collegata per interrompere temporaneamente il riferimento a una composizione

  • Sostituire la composizione collegata dinamicamente con il file sottoposto a rendering utilizzando la funzione Esegui rendering e sostituisci di Premiere Pro (Clip > Esegui rendering e sostituisci).  

Se solitamente lavori con composizioni sorgente complesse, prova ad aumentare la RAM o a dotare il sistema di un processore più potente.

Nota:

Una composizione di After Effects collegata non supporta l’elaborazione multipla Rendering simultaneo di più fotogrammi. Consultare Migliorare le prestazioni ottimizzando le impostazioni relative a memoria, cache ed elaborazione multipla.

Esportare in Adobe Media Encoder

Per codificare le composizioni After Effects, aggiungerle alla coda di codifica in Adobe Media Encoder, quindi selezionare i predefiniti di codifica o creare le impostazioni di codifica personalizzate. In After Effects, puoi aggiungere una composizione alla coda di Media Encoder utilizzando una delle seguenti opzioni:

  • File > Esporta > Aggiungi alla coda di Media Encoder
  • Composizione > Aggiungi alla coda di Media Encoder

Quando aggiungerai una composizione o un progetto alla coda di Adobe Media Encoder, After Effects avvia Adobe Media Encoder con le composizioni elencate nella coda.

Il processo di codifica è descritto nei seguenti articoli:

Logo Adobe

Accedi al tuo account