I tracciati maschera e i tracciati forma possono essere animati allo stesso modo delle altre proprietà: impostate i percorsi in ciascun fotogramma chiave e After Effects eseguirà l’interpolazione tra questi valori specifici.

Introduzione al rotoscoping e relative risorse

Il rotoscoping (o semplicemente roto nell’uso familiare) consiste nel disegnare o dipingere sui fotogrammi di un filmato, utilizzando come riferimento gli elementi visivi del filmato stesso. Un tipo comune di rotoscoping consiste nel tracciare un percorso attorno a un oggetto in un filmato e nell’utilizzare tale percorso come maschera per separare l’oggetto dal suo sfondo. Questo consente di lavorare con l’oggetto e lo sfondo separatamente, in modo da poter applicare effetti diversi all’oggetto rispetto al suo sfondo, oppure sostituire lo sfondo.

Nota:

Gli strumenti Pennello rotoscopio e Migliora bordi di After Effects consentono di completare molte delle operazioni del tradizionale rotoscoping, ma in tempi notevolmente ridotti. Per informazioni sull’utilizzo dello strumento Pennello a rotoscopio, consultate Pennello a rotoscopio, miglioramento dei bordi e miglioramento del mascherino.

Nota:

Se un oggetto sullo sfondo o in primo piano è omogeneo e di colore distinto, potete usare la trasparenza colore invece del rotoscoping per rimuovere lo sfondo o l’oggetto. Se il metraggio era stato effettuato tenendo conto della trasparenza colore, la trasparenza colore è molto più facile del rotoscoping. Vedete Introduzione alla trasparenza e relative risorse.

In After Effects, il rotoscoping consiste principalmente nel disegnare maschere, animare il relativo tracciato e utilizzare quindi le maschere per definire un mascherino. Molte attività e tecniche aggiuntive semplificano questo lavoro, come ad esempio l’uso del tracciamento del movimento sull’oggetto prima di iniziare a disegnare le maschere e l’utilizzo successivo dei dati del tracciamento del movimento per fare in modo che una maschera o un mascherino seguano automaticamente l’oggetto.

Suggerimenti sul rotoscoping

  • Immediatamente dopo aver iniziato a disegnare una maschera, premete Alt+Maiusc+M (Windows) o Opzione+Maiusc+M (Mac OS) per attivare i fotogrammi chiave per la maschera e impostate un fotogramma chiave. In questo modo, non dovrete dedicare del tempo alla modifica di una maschera, fotogramma per fotogramma, per poi rendervi conto che avete perso tutto il lavoro fatto sui fotogrammi precedenti perché vi siete dimenticati di fare clic sul cronometro per animare il tracciato della maschera.
  • Disegnate le vostre maschere su un livello pieno di colore bianco, con il relativo switch Video (bulbo oculare) disattivato, al di sopra del livello metraggio (bloccato). In questo modo, non correte alcun rischio di spostare accidentalmente il livello metraggio quando manipolate la maschera e potete inoltre applicare con maggiore facilità i dati del tracciamento alla maschera. (Applicate i dati del tracciamento al livello pieno invisibile che contiene la maschera.) Questo significa anche che non perderete i fotogrammi di anteprima della inserita nella cache ogni volta che manipolate la maschera. Vedete Attivare e disattivare la visibilità o l’influenza di un livello o gruppo di proprietà e Bloccare e sbloccare un livello.
  • Attivate la preferenza Mantieni conteggio vertice costante. Consultate Designare il primo vertice per un tracciato Bezier.
  • Quando possibile, trasformate (ruotate, proporzionate, spostate) l’intera maschera o un sottogruppo dei vertici della maschera invece di spostare i vertici singolarmente. Questo consente da un lato di mantenere l’efficienza e dall’altro di evitare le vibrazioni dovute ai movimenti non omogenei tra fotogrammi. Consultate Spostare i vertici nella modalità di trasformazione libera.
  • Il tracciamento del movimento manuale richiede un tempo inferiore rispetto al rotoscoping manuale. Quanto più precisi sono i dati di tracciamento per le varie parti della scena e dell’oggetto, tanto inferiore sarà il tempo necessario per disegnare e mettere a punto le maschere. Consultate Spostare il tracciamento e la stabilizzazione.
  • Utilizzate la funzionalità sfumatura maschera di larghezza variabile per un maggiore controllo durante la sfumatura degli oggetti.

Risorse online sul rotoscoping

Questo video tratto dalla serie After Effects CS5: Learn By Video mostra come combinare il tracciamento del movimento e il rotoscoping per isolare e correggere selettivamente il colore del volto di un attore.

Nel suo sito Web Effects Corner, Scout Squires mette a disposizione due filmati che mostrano come eseguire il rotoscoping, sia mediante i disegni che le maschere:

Mathias Möhl mette a disposizione lo script KeyTweak nel suo sito Web, con il quale potete modificare simultaneamente molti fotogrammi chiave in una proprietà. Con KeyTweak potete modificare manualmente alcuni fotogrammi chiave, mentre lo script modifica di conseguenza i restanti fotogrammi chiave. KeyTweak risulta particolarmente utile per i fotogrammi chiave Tracciato maschera in un flusso di lavoro di rotoscoping.

Rich Young offre diverse risorse sul rotoscoping nel suo sito Web After Effects Portal.

Visualizzare tracciati maschere e forme

  • Per visualizzare i tracciati maschere per i livelli selezionati nel pannello Timeline, premete M.
  • Per visualizzare le maschere o le forme selezionate nel pannello Timeline, premete SS (premete due volte il tasto S).
  • Per visualizzare i tracciati maschera e forma nel pannello Composizione, fate clic sul pulsante Attiva/disattiva visualizzazione tracciato maschera e forma nella parte inferiore del pannello Composizione.
  • Per visualizzare i tracciati maschere nel pannello Livello, scegliete Maschere dal menu Visualizza del pannello Livello.
  • Per nascondere un tracciato maschera e mostrarne altri, bloccate le maschere selezionando lo switch Blocca nel pannello Timeline, quindi scegliete Livello > Maschera > Nascondi maschere bloccate.
  • Per isolare le maschere selezionate e nascondere le altre, scegliete Livello > Maschera > Blocca altre maschere e quindi Livello > Maschera > Nascondi maschere bloccate.

Selezionare tracciati forma, forme e gruppi di forme

Potete selezionare i livelli forma e i relativi componenti scegliendo tra uno dei quattro livelli di selezione, definiti modalità di selezione:

Modalità di selezione livello

Viene selezionato l’intero livello forma. Le trasformazioni vengono applicate alle proprietà di trasformazione relative al livello, nel gruppo di proprietà Trasformazione che si trova allo stesso livello del gruppo di proprietà Contenuto.

Modalità di selezione gruppo

Viene selezionato un intero gruppo di forme. Le trasformazioni vengono applicate alle proprietà di trasformazione relative al gruppo, nel gruppo di proprietà di trasformazione all’interno dello stesso gruppo di forme nel pannello Timeline.

Modalità di trasformazione libera

Vengono selezionati più vertici su uno o più tracciati Bezier. Viene visualizzato un rettangolo di selezione di trasformazione libera attorno ai vertici nel pannello Composizione. Agendo su questo rettangolo, potete spostare più vertici con una singola trasformazione. Le trasformazioni vengono applicate ai vertici stessi, i quali sono contenuti all’interno della proprietà Tracciato nel pannello Timeline.

Modalità di modifica del tracciato

Vengono selezionati solo i vertici. In questa modalità, potete eseguire le operazioni di modifica di un tracciato, quali l’aggiunta di vertici a un tracciato e lo spostamento di singoli vertici.

Nota:

Quando è attivo uno strumento Penna, la modalità di modifica del tracciato è attiva. Per restare nella modalità di modifica del tracciato, selezionate lo strumento Penna; tenete premuto V o Ctrl (Windows) o Comando (Mac OS) per attivare temporaneamente lo strumento Selezione, a seconda dei casi.

Modalità di selezione per le forme sui livelli forma
Modalità di selezione per le forme sui livelli forma

A. Selezione livello B. Selezione gruppo C. Trasformazione libera D. Modifica tracciato 

Per informazioni sulla selezione di maschere, consultate Selezionare maschere, segmenti e vertici.

Nota:

Tenete premuto Ctrl+A (Windows) o Comando+A (Mac OS) con un vertice di forma selezionato per selezionare tutti i vertici presenti sul tracciato. Premete nuovamente per selezionare tutte le forme. Premete nuovamente per selezionare tutti i livelli.

Selezionate un livello forma

  • Fate clic sul nome del livello o sulla barra della durata del livello nel pannello Timeline.
  • Usando lo strumento Selezione, fate clic all’interno dei limiti del livello nel pannello Composizione.
  • Per deselezionare tute le forme su un livello lasciando selezionato il livello forma, fate clic all’interno dei limiti del livello, ma esternamente a tutti i tracciati forma.

Selezionare un gruppo di forme nella modalità di selezione gruppo

  • Usando lo strumento Selezione, fate doppio clic su un membro del gruppo nel pannello Composizione. Ogni volta che fate doppio clic, scendete di un altro livello nella gerarchia del gruppo.
  • Per attivare lo strumento Selezione diretta , tenete premuto Ctrl (Windows) o Comando (Mac OS) con lo strumento Selezione selezionato. Fate clic su una forma nel pannello Composizione con lo strumento Selezione diretta per selezionare direttamente il gruppo della forma, indipendentemente dalla profondità alla quale è nidificata nella gerarchia del gruppo.
  • Per selezionare un gruppo contenuto all’interno dello stesso gruppo del gruppo già selezionato, fate clic sul gruppo da selezionare.
  • Per aggiungere un gruppo a una selezione, tenete premuto Maiusc e fateci clic sopra. Potete tenere premuto Maiusc e fare doppio clic con lo strumento Selezione diretta per aggiungere alla selezione i gruppi nidificati più in profondità.

Selezionare i tracciati e i vertici nella modalità di modifica del tracciato

Nota:

Per specificare la dimensione delle maniglie di direzione Bezier e dei vertici per maschere e forme, scegliete Modifica > Preferenze > Generale (Windows) o After Effects > Preferenze > Generale (Mac OS), quindi modificate il valore Dimensione in punti tracciato.

  • Per selezionare un vertice, fateci clic sopra con lo strumento Selezione. Per aggiungere vertici alla selezione, tenete premuto Maiusc e fate clic su di essi.
  • Per selezionare un segmento di tracciato, fate clic sul segmento con lo strumento Selezione. Per aggiungere segmenti alla selezione, tenete premuto Maiusc e fate clic su di essi.
  • Per selezionare un intero tracciato, tenete premuto Alt (Windows) o Opzione (Mac OS) e fate clic su un segmento o vertice del tracciato con lo strumento Selezione oppure selezionate una parte del tracciato e premete Ctrl+A (Windows) o Comando+A (Mac OS).
  • Per selezionare vertici mediante trascinamento, selezionate un tracciato o una parte di tracciato per passare alla modalità di modifica del tracciato ed eseguite quindi un trascinamento con lo strumento di selezione scorrevole per tracciare un rettangolo di selezione attorno ai vertici da selezionare. Per aggiungere vertici alla selezione, tenete premuto Maiusc mentre tracciate ulteriori rettangoli di selezione.

Selezionare tutti i punti su un tracciato e attivare la modalità di trasformazione libera

  • Fare doppio clic su un segmento di tracciato nella modalità di modifica tracciato o nella modalità di selezione gruppo per una singola forma.
  • Selezionate la proprietà Tracciato nel pannello Timeline e premete Ctrl+T (Windows) o Comando+T (Mac OS).

Selezionare maschere, segmenti e vertici

A differenza dei livelli, le maschere offrono più possibilità di selezione. Potete selezionare una maschera come tracciato intero, in modo da spostarla o ridimensionarla. Tuttavia, per modificare il tracciato di una maschera, selezionate uno o più punti della stessa. I punti selezionati appaiono pieni, mentre i punti non selezionati appaiono vuoti.

Nota:

Per specificare la dimensione delle maniglie di direzione Bezier e dei vertici per maschere e forme, scegliete Modifica > Preferenze > Generale (Windows) o After Effects > Preferenze > Generale (Mac OS), quindi modificate il valore Dimensione in punti tracciato.

Selezionare o deselezionare le maschere nel pannello Composizione o Livello

  • Per selezionare un vertice di una maschera, fate clic sul vertice con lo strumento Selezione . Per aggiungere vertici alla selezione, tenete premuto Maiusc e fate clic su di essi.
  • Per selezionare un segmento di maschera, fate clic sul segmento con lo strumento Selezione. Per aggiungere segmenti alla selezione, tenete premuto Maiusc e fate clic su di essi.
  • Per selezionare un’intera maschera, tenete premuto Alt (Windows) o Opzione (Mac OS) e fate clic su un segmento, vertice o maniglia della maschera con lo strumento di selezione oppure selezionate una parte di maschera e scegliete Modifica > Seleziona tutto o premete Ctrl+A (Windows) o Comando+A (Mac OS). Per aggiungere maschere alla selezione, tenete premuto Alt+Maiusc (Windows) o Opzione+Maiusc (Mac OS) e fate clic su di esse.
  • Per selezionare maschere mediante trascinamento, selezionate la maschera o una parte di maschera per passare alla modalità di modifica e usate lo strumento Selezione per tracciare un rettangolo di selezione che racchiuda i vertici o le maschere da selezionare. Per aggiungere maschere o vertici alla selezione, tenete premuto Maiusc mentre tracciate ulteriori rettangoli di selezione.
  • Per selezionare tutte le maschere di un livello, selezionate una maschera sul livello e scegliete Modifica > Seleziona tutto oppure premete Ctrl+A (Windows) o Comando+A (Mac OS).
  • Per deselezionare tutte le maschere, premete Ctrl+Maiusc+A (Windows) o Comando+Maiusc+A (Mac OS).
  • Per selezionare una maschera adiacente su un livello, premete Alt+accento grave (`) (Windows) o Opzione+accento grave (`) (Mac OS) per selezionare la maschera successiva, oppure Maiusc+Alt+accento grave (`) (Windows) o Maiusc+Opzione+accento grave (`) (Mac OS) per selezionare la maschera precedente.
  • Per deselezionare una maschera, fate clic su un punto qualsiasi che non sia sopra la maschera.
  • Per rimuovere un vertice o un segmento da una selezione, tenete premuto Maiusc e fate clic sul vertice o sul segmento.

Nota:

Per usare lo strumento Selezione quando è selezionato lo strumento Penna, tenete premuto Ctrl (Windows) o Comando (Mac OS).

Selezionare le maschere nel pannello Timeline

  1. Fate clic sulla freccia destra accanto al nome di un livello per espandere il livello.
  2. Fate clic sulla freccia destra accanto al titolo Maschere per espanderlo, in modo da mostrare tutte le maschere presenti nel livello.
  3. Effettuate una delle seguenti operazioni:
    • Per selezionare una maschera, fate clic sul relativo nome.
    • Per selezionare una serie di maschere consecutive, tenete premuto Maiusc e fate clic sui nomi della prima e dell’ultima maschera della serie.
    • Per selezionare contemporaneamente diverse maschere non consecutive, tenete premuto Ctrl (Windows) o Comando (Mac OS) e fate clic sui nomi delle maschere da includere.

Nota:

Potete selezionare soltanto maschere intere nel pannello Timeline. Per selezionare singoli vertici di una maschera, usate il pannello Composizione o Livello.

Bloccare o sbloccare le maschere

Le maschere bloccate non possono essere selezionate nei pannelli Timeline, Composizione e Livello e non possono essere impostate come destinazione nel pannello Livello. Usate questa funzione per evitare modifiche indesiderate alle maschere.

  1. Nel pannello Timeline, espandete il gruppo di proprietà Maschere.
  2. Nella colonna Funzionalità A/V fate clic sulla casella situata sotto l’icona Blocca  di fianco alla maschera da bloccare o sbloccare. Una maschera è bloccata e non può essere selezionata quando il relativo switch Blocca è selezionato, vale a dire quando l’icona Blocca è visualizzata nel riquadro.

Nota:

Per sbloccare più maschere contemporaneamente, selezionate uno o più livelli e scegliete Livello > Maschera > Sblocca tutte le maschere.

Nota:

Per isolare le maschere selezionate e nascondere le altre, scegliete Livello > Maschera > Blocca altre maschere e quindi Livello > Maschera > Nascondi maschere bloccate.

Spostare i vertici nella modalità di trasformazione libera

Potete scalare e ruotare un’intera maschera, oppure il tracciato forma (o i vertici selezionati in uno o più tracciati) usando il comando Trasformazione libera punti. Quando usate questo comando, i vertici selezionati vengono racchiusi in un rettangolo di selezione di trasformazione libera dei punti, al centro del quale appare un punto di ancoraggio che indica il punto di ancoraggio della trasformazione corrente. Potete scalare e ruotare i vertici selezionati trascinando il rettangolo di selezione o le relative maniglie. Potete inoltre modificare il punto di riferimento dal quale i vertici vengono ruotati o ridimensionati spostando il punto di ancoraggio del rettangolo di selezione. Le maniglie e il punto di ancoraggio del rettangolo di selezione Trasformazione libera punti sono indipendenti rispetto alle maniglie e al punto di ancoraggio del livello.

Nota:

Quando eseguite la rotazione dell’animazione con Trasformazione libera punti, i vertici della maschera vengono interpolati in una linea retta da un fotogramma chiave all’altro. Per questo motivo, gli effetti ottenuti possono essere diversi da quelli previsti.

  1. Visualizzate il livello contenente i tracciati da trasformare nel pannello Composizione o Livello.
  2. Con lo strumento Selezione, effettuate una delle seguenti operazioni:
    • Per trasformare un qualsiasi numero di vertici, selezionate i vertici da trasformare e scegliete Livello > Tracciato forma e maschera > Trasformazione libera punti.
    • Per trasformare un intero tracciato maschera o forma, selezionatelo nel pannello Timeline e scegliete Livello > Tracciato forma e maschera > Trasformazione libera punti.
  3. Per spostare il punto di ancoraggio del rettangolo di selezione, posizionate lo strumento Selezione sopra il punto di ancoraggio del rettangolo di selezione  fino a trasformare lo strumento Selezione in icona di spostamento del punto di ancoraggio . Eseguite un trascinamento per posizionare il punto di ancoraggio.
  4. Effettuate una o più delle seguenti operazioni:
    • Per spostare il tracciato o i vertici selezionati, posizionate il puntatore all’interno del rettangolo di selezione e trascinate.
    • Per scalare il tracciato o i vertici selezionati, posizionate il puntatore sopra una maniglia del rettangolo di selezione; appena il puntatore assume la forma di una freccia dritta a due punte , trascinate in modo da modificare la dimensione. Tenete premuto Maiusc durante il trascinamento in modo da vincolare la scalatura. Tenete premuto Ctrl (Windows) o Comando (Mac OS) e trascinate per ridimensionare il punto di ancoraggio del rettangolo di selezione.
    • Per ruotare il tracciato o i vertici selezionati, posizionate il puntatore appena al di fuori del rettangolo di selezione di trasformazione libera dei punti; appena il puntatore assume la forma di una freccia curva a due punte , trascinate in modo da eseguire la rotazione.
  5. Per uscire dalla modalità di trasformazione libera, premete Esc, Invio (Windows) o A capo (Mac OS).

Convertire un tracciato tra Bezier e RotoBezier manuale

Potete convertire qualsiasi tracciato maschera Bezier o tracciato forma Bezier manuale in un tracciato RotoBezier. Se il tracciato Bezier manuale dispone di maniglie direzionali che sono state regolate, questa conversione cambia la forma del tracciato, in quanto After Effects calcola automaticamente la curvatura dei segmenti RotoBezier.

La conversione di un tracciato RotoBezier in tracciato Bezier manuale non cambia la forma del tracciato.

  1. Selezionate un maschera nel pannello Livello, Composizione o Timeline, oppure selezionate un tracciato forma nel pannello Composizione o Timeline.
  2. Scegliete Livello > Tracciato forma e maschera > RotoBezier.

Modificare un tracciato maschera o un tracciato forma Bezier

Potete modificare un tracciato maschera Bezier usando lo strumento Selezione e gli strumenti Penna nel pannello Livello o Composizione. Potete modificare un tracciato maschera Bezier usando lo strumento Selezione e gli strumenti Penna nel pannello Composizione.

Gli strumenti Penna (Aggiungi vertice, Elimina vertice e Converti vertice) sono raggruppati con lo strumento Penna nel pannello Strumenti. Per visualizzare questi strumenti nel pannello Strumenti, fate clic sullo strumento Penna nel pannello Strumenti tenendo premuto il pulsante del mouse.

Nota:

Nella maggior parte dei casi, lo strumento Penna appropriato diventa attivo quando posizionate il puntatore dello strumento Penna in un contesto particolare. Ad esempio, lo strumento Elimina vertice diventa attiva quando posizionate il puntatore dello strumento Penna sopra un vertice esistente, mentre lo strumento Aggiungi vertice diventa attivo quando posizionate il puntatore dello strumento Penna sopra un segmento di tracciato. Per attivare manualmente e passare da uno strumento all’altro, premete G.

Quando modificate un tracciato, accertatevi di fare clic soltanto sui vertici o sui segmenti esistenti; in caso contrario, potreste creare accidentalmente un nuovo tracciato.

Spostare, aggiungere o eliminare un vertice

  1. Effettuate una delle seguenti operazioni:
    • Per spostare un vertice, trascinatelo con lo strumento Selezione .

    Nota:

    Per passare temporaneamente dallo strumento Penna allo strumento Selezione, premete V o Ctrl (Windows) o Comando (Mac OS).

    • Per aggiungere un vertice a una maschera, fate clic sul segmento presente tra due vertici esistenti con lo strumento Aggiungi vertice .
    • Per eliminare un vertice da una maschera, fate clic sul vertice con lo strumento Elimina vertice .

Regolare un segmento di tracciato

  1. Effettuate una delle seguenti operazioni con lo strumento Selezione:
    • Trascinate un vertice.
    • Trascinate le maniglie direzionali che si estendono da un vertice arrotondato adiacente.
    • Trascinate un segmento curvo.

    Nota:

    Il trascinamento di un segmento curvo su una maschera RotoBézier determina anche lo spostamento dei vertici.

Visualizzare un vertice alternando tra la forma di un punto arrotondato e quella di un punto d’angolo

  1. Fate clic sul vertice con lo strumento Converti vertice .

    Nota:

    Per attivare lo strumento Converti vertice con lo strumento Penna selezionato, tenete premuto Alt (Windows) o Opzione (Mac OS).

Regolare la tensione di una maschera RotoBézier

  1. Per regolare la tensione di più vertici contemporaneamente, selezionarli tutti.
  2. Con lo strumento Converti vertici , trascinate un vertice.

    Nota:

    Per attivare lo strumento Converti vertice con lo strumento Penna selezionato, tenete premuto Alt (Windows) o Opzione (Mac OS).

    Durante il trascinamento di un vertice della maschera RotoBézier compare il puntatore Regola tensione .

    Se fate clic su un vertice invece di trascinarlo, potete impostare il vertice su un punto d’angolo (tensione al 100%); se fate nuovamente clic, potete impostare il vertice su un punto arrotondato (tensione al 33%). Se trascinate in alto o a destra, potete ridurre la tensione della selezione, aumentando la curva dei segmenti adiacenti del tracciato; se trascinate in basso o a sinistra, potete aumentare la tensione della selezione, riducendo la curva dei segmenti adiacenti del tracciato.

    Nota:

    Per visualizzare il valore di tensione di un vertice, osservate il pannello Info durante la regolazione della tensione.

Modificare un tracciato maschera numericamente

  1. Selezionate la maschera.
  2. Nel pannello Timeline espandete le proprietà Maschera.
  3. Accanto alla proprietà Tracciato maschera, fate clic sulla parola sottolineata e specificate le modifiche nella finestra di dialogo Forma maschera.

Designare il primo vertice per un tracciato Bezier

Per animare un tracciato, After Effects designa il vertice più alto nel fotogramma chiave iniziale come primo vertice e numera ciascun vertice successivo in ordine crescente a partire dal primo vertice. After Effects assegna quindi la stessa numerazione ai vertici corrispondenti in tutti i fotogrammi chiave successivi. After Effects effettua l’interpolazione dello spostamento di ciascun vertice dalla posizione iniziale in un fotogramma chiave alla posizione del vertice con numero corrispondente nel fotogramma chiave successivo. In qualsiasi momento durante un’animazione, potete designare un altro vertice come primo vertice; in tal modo After Effects rinumera i vertici del tracciato. La rinumerazione dei vertici determina il cambiamento dell’animazione del tracciato, in quanto After Effects mappa i nuovi numeri dei vertici in base ai vecchi numeri corrispondenti ancora salvati nei fotogrammi chiave successivi.

Quando copiate un tracciato chiuso in un tracciato animato, il vertice designato come primo vertice del tracciato chiuso viene utilizzato come inizio del tracciato animato. Tutti i tracciati animati sono tracciati aperti.

Alcune operazioni sul tracciato forma, come Taglia tracciati, utilizzano inoltre il primo vertice per determinare in che modo modificare il tracciato.

Nota:

Per impostazione predefinita, se aggiungete un vertice a un tracciato, il nuovo vertice appare sul tracciato per tutta la durata di quest’ultimo, ma ne modifica la forma soltanto nella posizione temporale in cui è stato aggiunto. Se eliminate un vertice da un tracciato in corrispondenza di un punto temporale specifico, il vertice viene eliminato dal tracciato per tutta la durata di quest’ultimo. Per evitare che After Effects aggiunga ed elimini i vertici per tutta la durata del tracciato, scegliete Modifica > Preferenze > Generale (Windows) o After Effects > Preferenze > Generale (Mac OS) e deselezionate Mantieni conteggio vertici costante durante la modifica delle maschere.

Nota: in After Effects CC e CS6, Mantieni conteggio vertici costante durante la modifica delle maschere è denominato “Mantieni conteggio vertici e bordi sfumati costante durante la modifica delle maschere”.

  1. Create un tracciato animato.
  2. Nel pannello Timeline spostate l’indicatore del tempo corrente nella posizione temporale in cui desiderate designare un nuovo primo vertice.
  3. Selezionate il vertice da designare come primo vertice.
  4. Scegliete Livello > Tracciato forma e maschera > Imposta primo vertice.

    Nota:

    Il vertice designato come primo vertice appare leggermente più grande degli altri vertici nel pannello Composizione.

Animare un tracciato maschera con Interpolazione maschera avanzata

Interpolazione maschera avanzata fornisce un elevato livello di controllo per la creazione di fotogrammi chiave di tracciato maschera e un’animazione graduale e realistica. Dopo aver selezionato i fotogrammi chiave di tracciato maschera da interpolare, Interpolazione maschera avanzata crea fotogrammi chiave intermedi in base alle impostazioni definite. Il pannello Info visualizza l’andamento dell’interpolazione e il numero di fotogrammi chiave creati.

  1. Scegliete Finestra > Interpolazione maschera.
  2. Selezionate almeno due fotogrammi chiave del tracciato maschera adiacenti.
  3. Impostate le opzioni nel pannello Interpolazione maschera e fate clic su Applica.

    Nota:

    Per interrompere la procedura di interpolazione, premete Esc. Nel pannello Info viene indicato che la procedura è stata interrotta e viene riportato il numero di fotogrammi chiave creato.

    Frequenza fotogrammi chiave

    Specifica il numero di fotogrammi chiave al secondo creati dalla funzione Interpolazione maschera avanzata tra i fotogrammi chiave selezionati. Ad esempio, una valore di 10 crea un nuovo fotogramma chiave ogni 1/10 di secondo. Scegliete Auto per impostare una frequenza di fotogrammi chiave pari alla frequenza dei fotogrammi della composizione indicata tra parentesi. Per ottenere un’animazione più fluida, create un numero maggiore di fotogrammi chiave; per ottenere tempi di rendering più rapidi, create un numero minore di fotogrammi chiave.

    Nota:

    A prescindere dalla frequenza di fotogrammi chiave scelta, la funzione Interpolazione maschera avanzata aggiunge sempre fotogrammi chiave in corrispondenza del fotogramma che segue immediatamente il primo fotogramma chiave di tracciato maschera e in corrispondenza del fotogramma che precede immediatamente il secondo fotogramma chiave di tracciato maschera. Ad esempio, se eseguite l’interpolazione tra i fotogrammi chiave a 0 secondi e 1 secondo in una composizione a 30 fps con una frequenza di fotogrammi chiave di 10 al secondo, i fotogrammi chiave del tracciato maschera vengono aggiunti in corrispondenza dei fotogrammi numero 1, 3, 6, 9, 12, 15, 18, 21, 24, 27 e 29.

    Campi fotogrammi chiave

    Raddoppia la frequenza di fotogrammi chiave. Se selezionate questa opzione e la frequenza di fotogrammi chiave è pari alla frequenza di fotogrammi della composizione, viene aggiunto un fotogramma chiave per ogni campo video. Selezionate questa opzione per l’animazione di maschere per video interlacciato. Se questa opzione non è selezionata, la maschera potrebbe determinare lo scivolamento dell’oggetto che tentate di rendere trasparente. Per ulteriori informazioni sui campi nel video interlacciato, vedete Video interlacciato e separazione dei campi.

    Usa tracciati vertici lineari

    Specifica lo spostamento dei vertici del primo fotogramma chiave lungo un tracciato in linea retta fino ai vertici corrispondenti del secondo fotogramma chiave. Lasciate questa opzione deselezionata se desiderate ottenere l’interpolazione di alcuni vertici lungo tracciati curvi; ad esempio, nel caso in cui l’interpolazione desiderata riguardi parti che ruotano. Se questa opzione non è selezionata, la funzione Interpolazione maschera avanzata crea un tracciato naturale per la maschera.

    Resistenza piegatura

    Specifica in che misura il tracciato maschera interpolata deve rispondere alla piegatura piuttosto che all’allungamento. Un valore di 0 specifica che durante l’animazione il tracciato maschera deve piegarsi più che allungarsi; un valore di 100 specifica che il tracciato maschera deve allungarsi più che piegarsi.

    Qualità

    Specifica il grado di esattezza con cui la funzione Interpolazione maschera avanzata deve associare i vertici tra un fotogramma chiave e un altro. Un valore di 0 specifica che un dato vertice del primo fotogramma chiave deve corrispondere soltanto al vertice avente lo stesso numero nel secondo fotogramma chiave. Ad esempio, il decimo vertice del primo fotogramma chiave deve corrispondere al decimo vertice del secondo fotogramma chiave. Un valore di 100 specifica che un vertice del primo fotogramma chiave può corrispondere a un vertice qualsiasi del secondo fotogramma chiave. I valori più elevati forniscono in genere interpolazioni migliori; tuttavia, determinano tempi di elaborazione più lunghi.

    Aggiungi vertici tracciato maschera

    Specifica che la funzione Interpolazione maschera avanzata deve aggiungere vertici al fine di ottenere interpolazioni di qualità migliore. In generale, Interpolazione maschera qualità fornisce risultati ottimali quando i tracciati maschere presentano densità elevate di vertici. Inoltre, un vertice del primo tracciato maschera non può corrispondere al punto centrale di un segmento curvo o in linea retta del secondo tracciato maschera; pertanto, talvolta è necessario aggiungere preliminarmente i vertici per ottenere l’effetto desiderato. La funzione Interpolazione maschera avanzata non modifica i fotogrammi chiave originali. Soltanto i nuovi fotogrammi chiave del tracciato maschera elaborati mediante Interpolazione maschera avanzata presentano vertici aggiuntivi.

    Il valore impostato specifica il grado di dettaglio della suddivisione dei tracciati maschere di input. Pixel tra vertici specifica la distanza in pixel tra i vertici del tracciato maschera con il perimetro maggiore dopo la suddivisione. Vertici totali specifica il numero di vertici dei tracciati maschere interpolati. Percentuale di contorno specifica l’aggiunta di un vertice alla percentuale indicata della lunghezza del contorno del tracciato maschera. Ad esempio, un valore di 5 indica l’aggiunta di un vertice in corrispondenza di ciascun segmento consecutivo del contorno che rappresenta il 5% del perimetro totale. Per usare soltanto i vertici che erano presenti sul tracciato nel primo fotogramma, non selezionate questa opzione.

    Nota:

    La funzione Interpolazione maschera avanzata può determinare l’aggiunta di vertici in corrispondenza di posizioni di vertici esistenti anche se l’opzione Aggiungi vertici tracciato maschera non è selezionata. Se due vertici di un tracciato maschera corrispondono a un unico vertice dell’altro, il vertice viene duplicato nella stessa posizione in modo che il segmento tra i due vertici si riduca fino a raggiungere tale posizione.

    Metodo corrispondenza

    Specifica l’algoritmo usato dalla funzione Interpolazione maschera avanzata per fare corrispondere i vertici di un tracciato maschera ai vertici dell’altro. L’opzione Auto applica l’algoritmo di corrispondenza delle curve se uno dei due fotogrammi chiave selezionato contiene un segmento curvo; in caso contrario, applica l’algoritmo delle polilinee. L’opzione Curva applica l’algoritmo per i tracciati maschere contenenti segmenti curvi. L’opzione Polilinea applica l’algoritmo per i tracciati maschere contenenti soltanto segmenti in linea retta.

    Nota:

    I fotogrammi chiave del tracciato maschera aggiunti mediante la funzione Interpolazione maschera avanzata diventano polilinee se è selezionato il metodo di corrispondenza Polilinea, a prescindere dal fatto che i tracciati maschere di input contengano o meno segmenti curvi.

    Usa corrispondenze vertici 1:1

    Specifica che la funzione Interpolazione maschera avanzata deve creare un vertice in un tracciato maschera corrispondente al vertice avente lo stesso numero nell’altro tracciato maschera. In ciascun tracciato maschera di input, Interpolazione maschera avanzata effettua la corrispondenza tra i primi vertici, tra i secondi vertici, tra i terzi vertici e così via. Se i numeri di vertici dei due tracciati non coincidono, questa operazione può determinare effetti indesiderati.

    Corrispondenza primi vertici

    Specifica che la funzione Interpolazione maschera avanzata deve fare corrispondere i primi vertici dei due fotogrammi chiave dei tracciati maschera. Se questa opzione non è selezionata, Interpolazione maschera avanzata ricerca la migliore corrispondenza tra i primi vertici dei due tracciati maschere di input.

    Nota:

    Per ottenere risultati soddisfacenti, assicuratevi che i primi vertici dei tracciati maschere di input corrispondano tra loro, quindi selezionate Corrispondenza primi vertici.

Spostare una maschera o eseguire il panning di un livello dietro la relativa maschera

Potete regolare l’area visibile attraverso una maschera spostando la maschera nel pannello Livello o Composizione o eseguendo il panning (spostamento) del livello dietro la maschera nel pannello Composizione. Quando spostate una maschera, i valori Posizione del livello maschera rimangono costanti, mentre la maschera si sposta in relazione agli altri oggetti del pannello Composizione.

Se usate lo strumento Sposta sotto (Punto di ancoraggio) per eseguire il panning di un livello dietro una maschera, la posizione della maschera rimane costante nel pannello Composizione mentre cambia nel pannello Livello. I valori Posizione del livello mascherato cambiano in relazione alla composizione. Se eseguite il panning oltre i bordi del fotogramma del livello, vengono modificati anche i valori del Tracciato maschera del livello. L’uso dello strumento Sposta sotto (Punto di ancoraggio) rende più rapida la procedura, poiché senza di esso sarebbe necessario modificare manualmente le proprietà Posizione e Tracciato maschera del livello con maschera. Potete animare un livello eseguendo il panning dietro un altro livello mediante l’impostazione dei fotogrammi chiave relativi alle proprietà Posizione e Tracciato maschera del livello con maschera.

Spostare una maschera o eseguire il panning di un livello dietro la relativa maschera
Se usate lo strumento Sposta sotto (Punto di ancoraggio) nel pannello Composizione, After Effects effettua due regolazioni automatiche. Nel pannello Livello la maschera viene spostata in relazione al proprio livello (in alto), mentre nel pannello Composizione il livello viene spostato in relazione alla composizione (in basso).

Spostare una maschera

  1. Selezionate la maschera o le maschere da spostare.
  2. Nel pannello Composizione trascinate la maschera o le maschere in una nuova posizione. Per vincolare lo spostamento della maschera o delle maschere in senso orizzontale o verticale, tenete premuto Maiusc dopo l’inizio del trascinamento.

Eseguire il panning di un livello dietro la relativa maschera

  1. Selezionate lo strumento Sposta sotto (Punto di ancoraggio) nel pannello Strumenti.

  2. Fate clic all’interno dell’area della maschera nel pannello Composizione e trascinate il livello in una nuova posizione.

Tracciamento di volti e maschere

Il tracciatore maschera trasforma una maschera in modo da seguire il movimento di uno o più oggetti in un filmato. Per ulteriori informazioni, consultate Tracciamento maschera.

Potete anche usare il tracciatore maschera per individuare e tracciare con precisione volti umani. Per ulteriori informazioni, consultate Tracciamento dei volti.

Le espressioni possono accedere a punti di tracciati su maschere, forme Bezier e tratti pennello

Potete utilizzare le espressioni per leggere e scrivere le coordinate x e y di punti di tracciati o vertici, per:

  • Maschere di livello
  • Forme Bezier   
  • Tratti pennello negli effetti Disegno e Pennello a rotoscopio e miglioramento dei bordi.

I metodi di espressione permettono di accedere ai vertici dei tracciati in modo analogo agli script. Il metodo di espressione è denominato points() invece di vertices() per familiarità.

Accesso ai metodi di espressione

Per accedere ai metodi di espressione, eseguite i passaggi descritti di seguito:

  1. Per creare un livello solido, selezionate Livello > Solido.

  2. Una volta creato un solido, create una maschera. Fate clic su uno strumento Forma, ad esempio un poligono, e create una maschera sul livello solido.

  3. Nel pannello Timeline, aprite la sezione delle proprietà Maschera, quindi tenete premuto Alt e fate clic su Tracciato maschera.

  4. Viene visualizzato il campo delle espressioni. Nel pannello Timeline, fate clic sul Menu lingua espressioni e scegliete Proprietà tracciato.

    Menu lingua espressioni
    Menu lingua espressioni
  5. Selezionate un metodo di espressione dall’elenco dei metodi di espressione per i punti di tracciato.

    Per ulteriori informazioni sui metodi di espressione, consultate Accesso ai punti tracciato su forme, maschere e tratti pennello per le espressioni (riferimento espressioni).

Di seguito sono forniti alcuni esempi di metodi di espressione per gli oggetti tracciato seguenti:

  • Tracciati di maschere di livello: layer("Dark Gray Solid 1").mask("Mask 1").path or .maskPath
  • Tracciati di forme Bezier: layer("Shape Layer 1").content("Shape 1").content("Path 1").path
  • Tracciati di tratti dell’effetto Disegno: layer("Dark Gray Solid 1").effect("Paint").stroke("Brush 1").path
  • Tracciati di tratti dell’effetto Pennello a rotoscopio e migliora bordo: layer("Dark Gray Solid 1").effect("Roto Brush & Refine Edge").stroke("Foreground 1").path

Suggerimenti per lavorare con questi metodi di espressione:

  • I valori di punti e tangenti sono restituiti come una matrice di matrici di coppie di numeri [x,y] per le coordinate dei vertici. I valori delle coordinate sono arrotondati a quattro cifre decimali.
  • Le matrici di punti e tangenti iniziano con il primo vertice del tracciato. Per modificare il primo vertice dei tracciati delle maschere di livello e dei tracciati delle forme Bezier, utilizzate il comando Livello > Tracciati maschera e forma > Imposta primo vertice.
  • Le coordinate dei punti del tracciato di una maschera di livello sono relative all’origine del livello nel suo angolo superiore sinistro.
  • Le coordinate dei punti di tracciato delle forme Bezier sono relative al punto di ancoraggio del gruppo di forme del tracciato (ad es., “Trasformazione: Forma 1 > Punto di ancoraggio”).
  • Le coordinate dei punti del tracciato dei tratti pennello sono relative all’inizio del tratto; il primo punto è [0,0].
  • Il metodo toComp() o altri metodi di trasformazione dello spazio livello possono essere utili per convertire le coordinate da diversi livelli in uno spazio comune o semplicemente per restituire le coordinate relative allo spazio composizione.
  • Poiché i tracciati delle forme Bezier sono relativi al punto di ancoraggio del gruppo di forme locale, e non al livello, i rispettivi valori potrebbero essere diversi da quanto potreste aspettarvi. Per ovviare a questo inconveniente, impostate tutte le proprietà Trasformazione del gruppo di forme su zero. Tenete presente che la conversione di una forma parametrica in forma Bezier può influire sulla posizione del gruppo della forma.
  • Al metodo createPath() è possibile passare metodi points, tangents e isClosed dello stesso tracciato o di altri tracciati. Potete passare questi metodi senza modificarli per duplicare un tracciato oppure trasformare i valori dei punti e delle tangenti prima di passarli per modificare o animare il tracciato.

Pannello Crea Null da tracciati

Il pannello scriptUI Crea Null da tracciati consentedi creare animazioni intuitive basate su espressioni, senza dover scrivere manualmente le espressioni stesse. È possibile collegare direttamente i diversi tracciati a forme, forme a solidi e così via. Il pannello Crea Null da tracciati utilizza la possibilità di accesso delle espressioni ai punti di tracciato per collegarli automaticamente aiNull,in modo da evitare di scrivere manualmente l’espressione.

Il pannello crea degli oggetti Null per ogni punto di tracciato su un tracciato maschera o forma Bezier. I seguenti pulsanti nel pannello consentono di gestire i Null:

  • I punti seguono i Null: questo pulsante crea degli oggetti Null che controllano la posizione dei punti di tracciato. I punti di tracciato sono collegati ai Null, che potete animare per guidare i punti di tracciato.
  • I Null seguono i punti: questo pulsante crea degli oggetti Null controllati dalla posizione dei punti di tracciato. I Null sono collegati ai punti di tracciato, che potete animare per spostare i Null.
  • Traccia il tracciato: questo pulsante crea un singolo Null che segue il tracciato. La posizione del Null è collegata alle coordinate del tracciato. La rotazione del Null si orienta automaticamente per seguire il tracciato. Il pulsante Traccia il tracciato controlla lo spostamento del Null lungo il tracciato e se effettua un ciclo continuo. Per impostazione predefinita, i fotogrammi chiave sono impostati per tracciare il tracciato in 1 secondo e ilciclo continuoè attivato.

Operazioni con il pannello

  1. Per aprire il pannello, selezionate Finestre > Crea Null da tracciati.jsx.

  2. Per aggiungere una maschera forma, selezionate Livello > Nuovo > Livello forma. Aggiungete una maschera forma al livello.

    Nota:

    Il pannello funziona con le forme Bezier, pertanto tutte le forme parametriche, ad esempio rettangoli, ellissi e stelle, devono essere convertite in forma Bezier. Per convertire una forma parametrica in una forma Bezier, aprite la sezione del livello forma e fate clic con il pulsante destro del mouse sultracciatoforma, ad esempio Rettangolo 1, e selezionate Converti in tracciato Bezier.

    Ripetete il passaggio 2 per aggiungere altre forme.

  3. Tutte le forme Bezier e le maschere dispongono di un tracciato. Nel pannello Timeline, aprite la sezione dei livelli per visualizzare i tracciati. Se desiderate tenere traccia dei punti di tracciato, selezionate un tracciato nel pannello Timeline e fate clic su I Null seguono i punti nel pannello Crea Null da tracciati.

    Lo script genera un oggetto Null per ogni punto sul tracciato. È possibile eliminare tutti i Null che non servono.

    Nota:

    Quando convertite una forma parametrica in forma Bezier, After Effects regola la proprietà Posizione della forma. Ciò provoca uno scostamento quando viene calcolata la posizione dei Null. Per evitare questo problema, impostate il valore della proprietà Trasforma di una forma come Trasforma: Ellisse da 1 a zero prima di creare i Null.

  4. Se desiderate che i punti di tracciato seguano i Null, selezionate un tracciato nel pannello Timeline. Quindi fate clic su I punti seguono i Null nel pannello Crea Null da tracciati.

  5. Una volta creati i Null per tutti i punti di tracciato, potete collegarlitraloro per creare animazioni. I Null creati con il pulsante I punti seguono i Null e quelli creati con I Null seguono i punti hanno colori diversi. Per collegare i Null, selezionate un oggetto Null e tenete premuto Maiusc mentre usate il selettore per selezionare un livello principale e fare sì che le coordinate del Null passino al livello principale.

    Dopo aver collegato tutti i Null tra loro, visualizzate in anteprima l’animazione per vedere come funziona.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online