使用各种 Photoshop 工具,您可以轻松地修复污点、美白牙齿、修正红眼以及修复图像中的许多其它缺陷。

注意:

Photoshop 不支持打开和编辑纸币或钞票图片。请参阅防伪系统 (CDS)

关于仿制源面板

“仿制源”面板(“窗口”>“仿制源”)具有用于仿制图章工具或修复画笔工具的选项。您可以设置五个不同的样本源并快速选择所需的样本源,而不用在每次更改为不同的样本源时重新取样。您可以查看样本源的叠加,以便在特定位置仿制源。您还可以缩放或旋转样本源以更好地匹配仿制目标的大小和方向。

对于基于时间轴的动画,“仿制源”面板还具有一些选项,可用于指定样本源视频/动画帧与目标视频/动画帧之间的帧关系。另请参阅仿制视频和动画帧中的内容

使用仿制图章工具进行修饰

仿制图章工具 将图像的一部分绘制到同一图像的另一部分或绘制到具有相同颜色模式的任何打开文档的另一部分。您也可以将一个图层的一部分绘制到另一个图层。仿制图章工具对于复制对象或移去图像中的缺陷很有用。

也可以使用仿制图章工具在视频帧或动画帧上绘制内容。另请参阅仿制视频和动画帧中的内容

使用仿制图章工具时,请在要从其中拷贝(仿制)像素的区域上设置一个取样点,并在另一个区域上绘制。要在每次停止并重新开始绘画时使用最新的取样点进行绘制,请选择“对齐”选项。取消选择“对齐”选项,从初始取样点开始绘制,这与停止并重新开始绘制的次数无关。

可以对仿制图章工具使用任意的画笔笔尖,这将使您能够准确控制仿制区域的大小。也可以使用不透明度和流量设置来控制仿制区域的绘制应用程序。

Photoshop 用仿制图章工具修改图像
用仿制图章工具修改图像

  1. 选择仿制图章工具
  2. 在选项栏中,选择画笔笔尖并为混合模式、不透明度和流量设置画笔选项。
  3. 要指定如何对齐样本像素以及如何对文档中的图层数据取样,请在选项栏中设置以下任一选项:

    对齐

    连续对像素进行取样,即使松开鼠标按钮,也不会丢失当前取样点。如果取消选择“对齐”,则会在每次停止并重新开始绘制时使用初始取样点中的样本像素。

    样本

    从指定的图层中进行数据取样。要从现用图层及其下方的可见图层中取样,请选择“当前和下方图层”。要仅从现用图层中取样,请选择“当前图层”。要从所有可见图层中取样,请选择“所有图层”。要从调整图层以外的所有可见图层中取样,请选择“所有图层”,然后单击“取样”弹出式菜单右侧的“忽略调整图层”图标。

  4. 可通过将指针放置在任意打开的图像中,然后按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并单击来设置取样点。

    注意:

    确保您没有在调整图层上执行操作。仿制图章工具不适用于调整图层。

  5. (可选)在“仿制源”面板中,单击“仿制源”按钮 并设置其它取样点。

    最多可以设置五个不同的取样源。“仿制源”面板可存储样本源,直到您关闭文档。

  6. (可选)在“仿制源”面板中执行下列任一操作:
    • 要缩放或旋转所仿制的源,请输入 W(宽度)或 H(高度)的值,或输入旋转角度
    • 要反转源的方向(适用于类似眼睛的镜像功能),请单击“水平翻转” 或“垂直翻转” 按钮。
    • 要显示仿制的源叠加,请选择“显示叠加”并指定叠加选项。

    注意:

    选择“已剪切”将叠加剪切到画笔大小。

  7. 在要校正的图像部分上拖移。

设置用于仿制和修复的样本源

使用仿制图章或修复画笔工具,可以对当前文档或 Photoshop 中任何打开文档中的源进行取样。

在仿制视频或动画时,可以在所绘制的当前帧中设置取样点,或者对不同帧中的源进行取样,即使该帧位于不同的视频图层或位于另一个打开的文档中,也可如此。

在“仿制源”面板中,一次可以设置最多五个不同的取样源。“仿制源”面板可存储样本源,直到您关闭文档。

  1. 要仿制视频帧或动画帧,请打开“动画”面板(如果不仿制视频帧或动画帧,请跳到第 2 步)。选择时间轴动画选项,并将当前时间指示器移动到包含要取样的源的帧。

  2. 要设置取样点,请选择仿制图章工具,然后在任一打开的文档窗口中按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 单击。
  3. (可选)要设置另一个取样点,请单击“仿制源”面板中的其它仿制源按钮

    通过设置不同的取样点,可以更改“仿制源”按钮的取样源。

缩放或旋转样本源

  1. 选择仿制图章工具或修复画笔工具并设置一个或多个源样本。
  2. 在“仿制源”面板中,选择一个仿制源,然后执行下列任一操作:
    • 要缩放样本源,请输入 W(宽度)或 H(高度)的百分比值或清除 W 或 H。默认情况下将约束比例。要单独调整尺寸或恢复约束选项,请单击“保持长宽比”按钮
    • 要旋转样本源,请输入一个角度值或清除“旋转仿制源”图标
    • 要将样本源复位到其初始大小和方向,请单击“复位变换”按钮 

调整样本源叠加选项

可以调整样本源叠加选项以便在使用仿制图章工具和修复画笔工具进行绘制时,更好地查看叠加和下层图像。

注意:

要在使用仿制图章工具进行绘制时临时显示叠加,请按住 Alt+Shift 组合键 (Windows) 或 Option+Shift 组合键 (Mac OS)。画笔将临时变为移动源叠加工具。拖动将叠加移动到另一个位置。

  1. 在“仿制源”面板中,选择“显示叠加”并执行下列任一操作:
    • 要在应用绘画描边时隐藏叠加,请选择“自动隐藏”。
    • 要将叠加剪贴到画笔大小,请启用“剪贴”选项。
    • 要设置叠加的不透明度,请在“不透明度”文本框中输入百分比值。
    • 要设置叠加的外观,请从“仿制源”面板底部的弹出式菜单中选择“正常”、“变暗”、“变亮”或“差值”混合模式。
    • 要反相叠加中的颜色,请选择“反相”。

    注意:

    要帮助对齐源叠加和下层图像中的相同区域,请将“不透明度”设置为 50%,然后选择“反相”,并取消选择“已剪切”。对齐时,匹配的图像区域将显示为纯灰。

指定仿制源位移

使用仿制图章工具或修复画笔工具时,可以用样本源在目标图像中的任何位置进行绘制。叠加选项可帮助您将要绘制的区域可视化。不过,如果您在相对于取样点的特定位置进行绘制,可以指定 x 和 y 像素位移。

  1. 在“仿制源”面板中,选择要使用的源并为“位移”选项输入 x 和 y 像素值。

使用修复画笔工具进行修饰

注意:从 Photoshop CC 2015.5 版开始,您可以将修复画笔工具恢复到旧版 Photoshop CC 2014 中的行为。选择“首选项”>“工具”>“使用恢复画笔的旧版恢复算法”。关于 Photoshop 版本历史记录的更多信息,请参阅新增功能摘要

“修复画笔工具”可用于校正瑕疵,使其避免出现在周围的图像中。与仿制工具一样,使用修复画笔工具可以利用图像或图案中的样本像素来绘画。但是,修复画笔工具还可将样本像素的纹理、光照、透明度和阴影与所修复的像素进行匹配。从而使修复后的像素不留痕迹地融入图像的其余部分。

可以对视频帧或动画帧应用修复画笔工具。请参阅 Photoshop 中的修复画笔示例,以了解有关修复画笔实际操作的建议和示例。

Photoshop 样本像素和修复后的图像
样本像素和修复后的图像

  1. 选择修复画笔工具
  2. 单击选项栏中的画笔样本,并在弹出面板中设置“画笔”选项:

    注意:

    如果使用压敏的数字化绘图板,请从“大小”菜单选取一个选项,以便在描边的过程中改变修复画笔的大小。选取“钢笔压力”根据钢笔压力而变化。选取“喷枪轮”根据钢笔拇指轮的位置而变化。如果不想改变大小,请选择“关闭”。

    模式

    指定混合模式。选择“替换”可以在使用柔边画笔时,保留画笔描边的边缘处杂色、胶片颗粒和纹理。

    指定用于修复像素的源。“取样”可以使用当前图像的像素,而“图案”可以使用某个图案的像素。如果选择了“图案”,请从“图案”弹出面板中选择一个图案。

    对齐

    连续对像素进行取样,即使松开鼠标按钮,也不会丢失当前取样点。如果取消选择“对齐”,则会在每次停止并重新开始绘制时使用初始取样点中的样本像素。

    样本

    从指定的图层中进行数据取样。要从现用图层及其下方的可见图层中取样,请选择“当前和下方图层”。要仅从现用图层中取样,请选择“当前图层”。要从所有可见图层中取样,请选择“所有图层”。要从调整图层以外的所有可见图层中取样,请选择“所有图层”,然后单击“取样”弹出式菜单右侧的“忽略调整图层”图标。

    扩散

    控制粘贴的区域以怎样的速度适应周围的图像。图像中如果有颗粒或精细的细节则选择较低的值,图像如果比较平滑则选择较高的值。

  3. 可通过将指针定位在图像区域的上方,然后按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并单击来设置取样点。

    注意:

    如果要从一幅图像中取样并应用到另一图像,则这两个图像的颜色模式必须相同,除非其中一幅图像处于灰度模式。

  4. (可选)在“仿制源”面板中,单击“仿制源”按钮 并设置其它取样点。

    最多可以设置五个不同的取样源。“仿制源”面板将记住样本源,直到您关闭所编辑的文档。

  5. (可选)在“仿制源”面板中,单击“仿制源”按钮以选择所需的样本源。
  6. (可选)在“仿制源”面板中执行下列任一操作:
    • 要缩放或旋转所仿制的源,请输入 W(宽度)或 H(高度)的值,或输入旋转角度
    • 要显示仿制的源叠加,请选择“显示叠加”并指定叠加选项。
  7. 在图像中拖移。

    每次松开鼠标按钮时,取样的像素都会与现有像素混合。

注意:

如果要修复的区域边缘有强烈的对比度,则在使用修复画笔工具之前,请先建立一个选区。选区应该比要修复的区域大,而且会精确地遵从对比像素的边界。当用修复画笔工具绘画时,该选区将防止颜色从外部渗入。

使用污点修复画笔工具进行修饰

污点修复画笔工具可以快速移去照片中的污点和其它不理想部分。污点修复画笔的工作方式与修复画笔类似:它使用图像或图案中的样本像素进行绘画,并将样本像素的纹理、光照、透明度和阴影与所修复的像素相匹配。与修复画笔不同,污点修复画笔不要求您指定样本点。污点修复画笔将自动从所修饰区域的周围取样。

Photoshop 污点修复画笔
使用污点修复画笔移去污点

注意:

修饰大片区域或需要更大程度地控制来源取样时,您可以使用修复画笔而不是污点修复画笔。

  1. 选择工具箱中的污点修复画笔工具 。如有必要,单击修复画笔工具、修补工具或红眼工具以显示隐藏的工具并进行选择。
  2. 在选项栏中选取一种画笔大小。比要修复的区域稍大一点的画笔最为适合,这样,您只需单击一次即可覆盖整个区域。
  3. (可选)从选项栏的“模式”菜单中选取混合模式。选择“替换”可以在使用柔边画笔时,保留画笔描边的边缘处杂色、胶片颗粒和纹理。
  4. 在选项栏中选取一种“类型”选项:

    近似匹配

    使用选区边缘周围的像素,找到要用作修补的区域。

    创建纹理

    使用选区中的像素创建纹理。如果纹理不起作用,请尝试再次拖过该区域。

    内容识别

    比较附近的图像内容,不留痕迹地填充选区,同时保留让图像栩栩如生的关键细节,如阴影和对象边缘。

    注意:

    要为“内容识别”选项创建更大或更精确的选区,请使用“编辑”>“填充”命令。(请参阅内容识别、图案或历史记录填充。)

  5. 在选项栏中选择“对所有图层取样”,以从所有可见图层中对数据进行取样。如果取消选择“对所有图层取样”,则只从现用图层中取样。
  6. 单击要修复的区域,或单击并拖动以修复较大区域中的不理想部分。

视频 | 在 Photoshop 中修饰汽车图像

视频 | 在 Photoshop 中修饰汽车图像
了解如何在 Photoshop 中修饰汽车图像
Scott Kelby

修补区域

通过使用修补工具,可以用其它区域或图案中的像素来修复选中的区域。像修复画笔工具一样,修补工具会将样本像素的纹理、光照和阴影与源像素进行匹配。您还可以使用修补工具来仿制图像的隔离区域。修补工具可处理 8 位/通道或 16 位/通道的图像。

注意:

修复图像中的像素时,请选择较小区域以获得最佳效果。

有关如何使用内容识别修补工具各个选项的信息,请参阅内容识别修补和移动

Photoshop 修补工具
使用修补工具替换像素

Photoshop 修补后的图像
修补后的图像

使用样本像素修复区域

  1. 选择修补工具
  2. 执行下列操作之一:
    • 在图像中拖动以选择想要修复的区域,并在选项栏中选择“源”。
    • 在图像中拖动,选择要从中取样的区域,并在选项栏中选择“目标”。

    注意:

    您也可以在选择修补工具之前建立选区。

  3. 要调整选区,请执行下列一种操作:
    • 按住 Shift 键并在图像中拖动,可添加到现有选区。
    • 按住 Alt 键(Windows)或 Option 键(Mac OS)并在图像中拖动,可从现有选区中减去一部分。
    • 按住 Alt+Shift 组合键(Windows)或 Option+Shift 组合键(Mac OS)并在图像中拖动,可选择与现有选区交迭的区域。
  4. 要从取样区域中抽出具有透明背景的纹理,请选择“透明”。如果要将目标区域全部替换为取样区域,请取消选择此选项。

    注意:

    “透明”选项非常适用于具有清晰分明纹理的纯色背景或渐变背景(如一只小鸟在蓝天中翱翔)。

  5. 若要控制粘贴的区域以怎样的速度适应周围的图像,请调整扩散滑块。图像中如果有颗粒或精细的细节则选择较低的值,图像如果比较平滑则选择较高的值。

  6. 将指针定位在选区内,并执行下列一种操作:
    • 如果在选项栏中选中了“源”,请将选区边框拖动到想要从中进行取样的区域。松开鼠标按钮时,使用样本像素修补原来选中的区域。
    • 如果在选项栏中选定了“目标”,请将选区边界拖动到要修补的区域。松开鼠标按钮时,使用样本像素修补新选中的区域。

使用图案修复区域

  1. 选择修补工具
  2. 在图像中拖动,选择要修复的区域。

    注意:

    您也可以在选择修补工具之前建立选区。

  3. 如果需要,请完成上述的第 3-4 步,以调整选区并应用具有透明背景的图案纹理。
  4. 从选项栏的“图案”面板中选择一个图案,并单击“使用图案”。

移去红眼

视频 | 移去红眼和美白牙齿

视频 | 移去红眼和美白牙齿
Photoshop 首席产品经理 Bryan O'Neil Hughes 会在这一集的 Photoshop Playbook 中展示如何使用 Photoshop 移去红眼和美白牙齿。
Bryan O'Neil Hughes

使用“红眼工具”可以去除人物或动物的闪光照片中的红眼。

  1. 在“RGB 颜色”模式下,选择红眼工具 。(红眼工具和污点修复画笔工具 在同一个组中。按住一个工具可以显示该组中的其他工具。)
  2. 在红眼中单击。如果对结果不满意,请还原修正,在选项栏中设置一个或多个以下选项,然后再次单击红眼:

    瞳孔大小

    增大或减小受红眼工具影响的区域。

    变暗量

    设置校正暗度。

注意:

相机闪光灯在主体视网膜上反光会引起红眼。在光线暗淡的房间里照相时,由于主体的虹膜张开得很宽,因此,红眼会比较常见。为了避免红眼,请使用相机的红眼消除功能。或者,最好使用可安装在相机上远离相机镜头位置的独立闪光装置。

视频 | 光线校正和移去不需要的对象

视频 | 光线校正和移去不需要的对象
Photoshop 首席产品经理 Bryan O'Neil Hughes 会介绍如何移去不需要的对象,以及使用基于画笔的颜色减淡功能将图像的明亮度和色温对等起来。
Adobe Photoshop

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略