Photoshop 提供了各种效果(如阴影、发光和斜面)来以非破坏性的方式更改图层内容的外观。图层效果与图层内容链接。移动或编辑图层的内容时,修改的内容中会应用相同的效果。例如,如果对文本图层应用投影并添加新的文本,则将自动为新文本添加阴影。

图层样式是应用于一个图层或图层组的一种或多种效果。可以应用 Photoshop 附带提供的某一种预设样式,或者使用“图层样式”对话框来创建自定样式。“图层效果”图标 将出现在“图层”面板中的图层名称的右侧。可以在“图层”面板中展开样式,以便查看或编辑合成样式的效果。

您可以在单个图层样式中应用多个效果。此外,部分效果的多个实例可以构成一个图层样式。

Photoshop 图层面板
显示应用了多种效果的图层的图层面板

A. 图层效果图标 B. 单击以展开和显示图层效果 C. 图层效果 

存储自定样式时,该样式成为预设样式。预设样式出现在“样式”面板中,只需单击一次便可将其应用于图层或组。

应用预设样式

可以从“样式”面板应用预设样式。Photoshop 随附的图层样式按功能分在不同的库中。例如,一个库包含用于创建 Web 按钮的样式;另一个库则包含向文本添加效果的样式。要访问这些样式,需要载入适当的库。有关载入和存储样式的信息,请参阅创建和管理预设样式

注意:

不能将图层样式应用于背景、锁定的图层或组。

显示样式面板

  1. 选取“窗口”>“样式”。

对图层应用预设样式

一般情况下,应用预设样式将会替换当前图层样式。不过,您可以将第二种样式的属性添加到当前样式的属性中。

  1. 执行下列操作之一:
    • 在“样式”面板中单击一种样式以将其应用于当前选定的图层。

    • 将样式从“样式”面板拖动到“图层”面板中的图层上。

    • 将样式从“样式”面板拖动到文档窗口,当鼠标指针位于希望应用该样式的图层内容上时,松开鼠标按钮。

      注意:在单击或拖动的同时按住 Shift 键可将样式添加到(而不是替换)目标图层上的任何现有效果。

    • 选取“图层”>“图层样式”>“混合选项”,然后单击“图层样式”对话框中的文字样式(对话框左侧列表中最上面的项目)。单击要应用的样式,然后单击“确定”。

    • 在形状图层模式下使用“形状”工具或“钢笔”工具时,请在绘制形状前从选项栏的弹出式面板中选择样式。

    注意:

    部分效果带有一个“+”图标,表示可以在一个图层样式中多次应用该效果。

应用另一个图层中的样式

  • 在“图层”面板中,按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并从图层的效果列表拖动样式,以将其拷贝到另一个图层。
  • 在“图层”面板中,单击此样式,并从图层的效果列表中拖动,以将其移动到另一个图层。

更改预设样式的显示方式

  1. 单击“样式”面板中的三角形、“图层样式”对话框或选项栏中的“图层样式”弹出式面板。
  2. 从面板菜单中选择显示选项:
    • “纯文本”:以列表形式查看图层样式。

    • “小缩览图”或“大缩览图”:以缩览图形式查看图层样式。

    • “小列表”或“大列表”:以列表形式查看图层样式,同时显示所选图层样式的缩览图。

图层样式对话框概述

可以编辑应用于图层的样式,或使用“图层样式”对话框创建新样式。

Photoshop“图层样式”对话框
“图层样式”对话框。单击复选框可应用当前设置,而不显示效果的选项。单击效果名称可显示效果选项。

可以使用以下一种或多种效果创建自定样式:

 

    投影

    在图层内容的后面添加阴影。

     

    内阴影

    紧靠在图层内容的边缘内添加阴影,使图层具有凹陷外观。

     

    外发光和内发光

    添加从图层内容的外边缘或内边缘发光的效果。

     

    斜面和浮雕

    对图层添加高光与阴影的各种组合。

     

    光泽

    应用创建光滑光泽的内部阴影。

     

    颜色、渐变和图案叠加

    用颜色、渐变或图案填充图层内容。

     

    描边

    使用颜色、渐变或图案在当前图层上描画对象的轮廓。它对于硬边形状(如文字)特别有用。

 

 

应用或编辑自定图层样式

注意:

不能将图层样式应用于背景图层、锁定的图层或组。要将图层样式应用于背景图层,请先将该图层转换为常规图层。

  1. 从“图层”面板中选择单个图层。
  2. 执行下列操作之一:
    • 双击该图层(在图层名称或缩览图的外部)。

    • 单击“图层”面板底部的“添加图层样式”图标 ,并从列表中选取效果。

    • 从“样式”>“图层样式”子菜单中选取效果。

    • 要编辑现有样式,请双击在“图层”面板中的图层名称下方显示的效果。(单击“添加图层样式”图标 旁边的三角形可显示样式中包含的效果。)

  3. 在“图层样式”对话框中设置效果选项。请参阅图层样式选项
  4. 如果需要,将其它效果添加到样式。在“图层样式”对话框中,单击效果名称左边的复选框,以便添加效果但不选择它。

    注意:

    您可以在不关闭“图层样式”对话框的情况下编辑多种效果。单击对话框左侧的效果名称以显示效果选项。

将样式默认值更改为自定值

  1. 在“图层样式”对话框中,根据需要自定设置。
  2. 单击“设置为默认值”。

    在您下次打开对话框时,系统会自动应用您自定的默认值。如果您调整设置并希望恢复您自定的默认值,请单击“复位为默认值”。

    注意:

    要恢复到 Photoshop 的原始默认设置,请参阅将首选项恢复为默认设置

图层样式选项

高度

对于斜面和浮雕效果,设置光源的高度。值为 0 表示底边;值为 90 表示图层的正上方。

角度

确定效果应用于图层时所采用的光照角度。可以在文档窗口中拖动以调整“投影”、“内阴影”或“光泽”效果的角度。

消除锯齿

混合等高线或光泽等高线的边缘像素。此选项在具有复杂等高线的小阴影上最有用。

混合模式

确定图层样式与下层图层(可以包括也可以不包括现用图层)的混合方式。例如,内阴影与现用图层混合,因为此效果绘制在该图层的上部,而投影只与现用图层下的图层混合。在大多数情况下,每种效果的默认模式都会产生最佳结果。请参阅混合模式

阻塞

模糊之前收缩“内阴影”或“内发光”的杂边边界。

颜色

指定阴影、发光或高光。可以单击颜色框并选取颜色。

等高线

使用纯色发光时,等高线允许您创建透明光环。使用渐变填充发光时,等高线允许您创建渐变颜色和不透明度的重复变化。在斜面和浮雕中,可以使用“等高线”勾画在浮雕处理中被遮住的起伏、凹陷和凸起。使用阴影时,可以使用“等高线”指定渐隐。有关更多信息,请参阅用等高线修改图层效果

距离

指定阴影或光泽效果的偏移距离。可以在文档窗口中拖动以调整偏移距离。

深度

指定斜面深度。它还指定图案的深度。

使用全局光

您可以使用此设置来设置一个“主”光照角度,此角度可用于使用阴影的所有图层效果:“投影”、“内阴影”以及“斜面和浮雕”。在任何这些效果中,如果选中“使用全局光”并设置一个光照角度,则该角度将成为全局光源角度。选定了“使用全局光”的任何其它效果将自动继承相同的角度设置。如果取消选择“使用全局光”,则设置的光照角度将成为“局部的”并且仅应用于该效果。也可以通过选取“图层样式”>“全局光”来设置全局光源角度。

光泽等高线

创建有光泽的金属外观。“光泽等高线”是在为斜面或浮雕加上阴影效果后应用的。

渐变

指定图层效果的渐变。单击“渐变”以显示“渐变编辑器”,或单击倒箭头并从弹出式面板中选取一种渐变。可以使用渐变编辑器编辑渐变或创建新的渐变。在“渐变叠加”面板中,可以像在渐变编辑器中那样编辑颜色或不透明度。对于某些效果,可以指定附加的渐变选项。“反向”翻转渐变方向,“与图层对齐”使用图层的外框来计算渐变填充,而“缩放”则缩放渐变的应用。还可以通过在图像窗口中单击和拖动来移动渐变中心。“样式”指定渐变的形状。

高光或阴影模式

指定斜面或浮雕高光,或阴影的混合模式。

抖动

改变渐变的颜色和不透明度的应用。

图层挖空投影

控制半透明图层中投影的可见性。

杂色

指定发光或阴影的不透明度中随机元素的数量。输入值或拖动滑块。

不透明度

设置图层效果的不透明度。输入值或拖动滑块。

图案

指定图层效果的图案。单击弹出式面板并选取一种图案。单击“新建预设”按钮 ,根据当前设置创建新的预设图案。单击“贴紧原点”,使图案的原点与文档的原点相同(在“与图层链接”处于选定状态时),或将原点放在图层的左上角(如果取消选择了“与图层链接”)。如果希望图案在图层移动时随图层一起移动,请选择“与图层链接”。拖动“缩放”滑块,或输入一个值以指定图案的大小。拖动图案可在图层中定位图案;通过使用“贴紧原点”按钮来重设位置。如果未载入任何图案,则“图案”选项不可用。

位置

指定描边效果的位置是“外部”、“内部”还是“居中”。

范围

控制发光中作为等高线目标的部分或范围。

大小

指定模糊的半径和大小或阴影大小。

软化

模糊阴影效果可减少多余的人工痕迹。

指定内发光的光源。选取“居中”以应用从图层内容的中心发出的发光,或选取“边缘”以应用从图层内容的内部边缘发出的发光。

扩展

在模糊之前扩大杂边边界。

样式

指定斜面样式:“内斜面”在图层内容的内边缘上创建斜面;“外斜面”在图层内容的外边缘上创建斜面;“浮雕效果”模拟使图层内容相对于下层图层呈浮雕状的效果;“枕状浮雕”模拟将图层内容的边缘压入下层图层中的效果;“描边浮雕”将浮雕限于应用于图层的描边效果的边界。(如果未将任何描边应用于图层,则“描边浮雕”效果不可见。)

方法

“平滑”、“雕刻清晰”和“雕刻柔和”可用于斜面和浮雕效果;“柔和”与“精确”应用于内发光和外发光效果。

平滑

稍微模糊杂边的边缘,可用于所有类型的杂边,不论其边缘是柔和的还是清晰的。此技术不保留大尺寸的细节特征。

雕刻清晰

使用距离测量技术,主要用于消除锯齿形状(如文字)的硬边杂边。它保留细节特征的能力优于“平滑”技术。

雕刻柔和

使用经过修改的距离测量技术,虽然不如“雕刻清晰”精确,但对较大范围的杂边更有用。它保留特征的能力优于“平滑”技术。

柔和

应用模糊,可用于所有类型的杂边,不论其边缘是柔和的还是清晰的。“柔和”不保留大尺寸的细节特征。

精确

使用距离测量技术创造发光效果,主要用于消除锯齿形状(如文字)的硬边杂边。它保留特写的能力优于“柔和”技术。

纹理

应用一种纹理。使用“缩放”来缩放纹理的大小。如果要使纹理在图层移动时随图层一起移动,请选择“与图层链接”。“反相”使纹理反相。“深度”改变纹理应用的程度和方向(上/下)。“贴紧原点”使图案的原点与文档的原点相同(如果取消选择了“与图层链接”),或将原点放在图层的左上角(如果“与图层链接”处于选定状态)。拖动纹理可在图层中定位纹理。

用等高线修改图层效果

在创建自定图层样式时,您可以使用等高线来控制“投影”、“内阴影”、“内发光”、“外发光”、“斜面和浮雕”以及“光泽”效果在指定范围上的形状。例如,“投影”上的“线性”等高线将导致不透明度在线性过渡效果中逐渐减少。使用“自定”等高线来创建独特的阴影过渡效果。

您可以在“等高线”弹出式面板和“预设管理器”中选择、复位、删除或更改等高线的预览。

Photoshop“投影”效果的“图层样式细节”对话框
“投影”效果的“图层样式细节”对话框

A. 单击以显示“等高线编辑器”对话框。 B. 单击以显示弹出式面板。 

创建自定等高线

  1. 在“图层样式”对话框中选择“投影”、“内阴影”、“内发光”、“外发光”、“斜面和浮雕”、“等高线”或“光泽”效果。
  2. 单击“图层样式”对话框中的等高线缩览图。
  3. 单击等高线以添加点,并拖动以调整等高线。或者,输入“输入”值和“输出”值。
  4. 要创建尖角而不是平滑曲线,请选择点并单击“边角”。
  5. 要将等高线存储到文件,请单击“存储”并命名等高线。
  6. 要将等高线存储为预设,请选取“新建”。
  7. 单击“确定”。新等高线即会被添加到弹出式面板的底部。

载入等高线

  1. 单击“图层样式”对话框中的等高线,然后在“等高线编辑器”对话框中选取“载入”。转到包含要载入的等高线库的文件夹,然后单击“打开”。

删除等高线

  1. 单击当前选定等高线旁边的反向箭头,以便查看弹出式面板。按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并单击要删除的等高线。

设置所有图层的全局光源角度

使用全局光可在图像上呈现普通的光源照明外观。

  1. 执行下列操作之一:
    • 选取“图层”>“图层样式”>“全局光”。在“全局光”对话框中输入值,或拖动角度半径以设置角度和高度,然后单击“确定”。

    • 在“投影”、“内阴影”或“斜面”的“图层样式”对话框中,选择“使用全局光”。对于“角度”,输入值或拖动半径,并单击“确定”。

    全局光源将应用于使用全局光源角度的每种图层效果。

显示或隐藏图层样式

如果图层具有样式,“图层”面板中的图层名称右侧将显示“fx”图标

隐藏或显示图像中的所有图层样式

  1. 选择“图层”>“图层样式”>“隐藏所有效果”或“显示所有效果”。

展开或折叠“图层”面板中的图层样式

  1. 执行下列操作之一:
    • 单击三角形 (位于“添加图层样式”图标 的旁边)以展开应用于该图层的图层效果的列表。

    • 单击三角形以折叠图层效果。

    • 要展开或折叠组中应用的所有图层样式,请按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并单击组中的三角形或倒三角形。应用于组中所有图层的样式也会相应地展开或折叠。

拷贝图层样式

拷贝和粘贴样式是对多个图层应用相同效果的便捷方法。

在图层之间拷贝图层样式

  1. 从“图层”面板中,选择包含要拷贝的样式的图层。
  2. 选取“图层”>“图层样式”>“拷贝图层样式”。
  3. 从面板中选择目标图层,然后选取“图层”>“图层样式”>“粘贴图层样式”。

    粘贴的图层样式将替换目标图层上的现有图层样式。

通过拖动在图层之间拷贝图层样式

  1. 执行下列操作之一:
    • 在“图层”面板中,按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并将单个图层效果从一个图层拖动到另一个图层以复制图层效果,或将“效果”栏从一个图层拖动到另一个图层也可以复制图层样式。

    • 将一个或多个图层效果从“图层”面板拖动到图像,以将结果图层样式应用于“图层”面板中包含放下点处的像素的最高图层。

缩放图层效果

图层样式可能已针对目标分辨率和指定大小的特写进行过微调。通过使用“缩放效果”,您将能够缩放图层样式中的效果,而不会缩放应用了图层样式的对象。

  1. 在“图层”面板中选择图层。
  2. 选取“图层”>“图层样式”>“缩放效果”。
  3. 输入一个百分比或拖动滑块。
  4. 选择“预览”可预览图像中的更改。
  5. 单击“确定”。

移去图层效果

可以从应用于图层的样式中移去单一效果,也可以从图层中移去整个样式。

从样式中移去效果

  1. 在“图层”面板中,展开图层样式,以便可以看到其效果。
  2. 将效果拖动到“删除”图标

从图层中移去样式

  1. 在“图层”面板中,选择包含要删除的样式的图层。
  2. 执行下列操作之一:
    • 在“图层”面板中,将“效果”栏拖动到“删除”图标

    • 选取“图层”>“图层样式”>“清除图层样式”。

    • 选择图层,然后单击“样式”面板底部的“清除样式”按钮

将图层样式转换为图像图层

要自定或调整图层样式的外观,可以将图层样式转换为常规图像图层。将图层样式转换为图像图层后,您可以通过绘画或应用命令和滤镜来增强效果。但是,您不再能够编辑原图层上的图层样式,并且在更改原图像图层时图层样式将不再更新。

注意:

此过程产生的图层可能不能生成与使用图层样式的版本完全匹配的图片。创建新图层时可能会看到警告。

  1. 在“图层”面板中,选择包含要转换的图层样式的图层。
  2. 选取“图层”>“图层样式”>“创建图层”。

    现在可以用处理常规图层的方法修改和重新堆栈新图层。一些效果(例如,内发光)将转换到剪贴蒙版内的图层。

创建和管理预设样式

可以创建自定样式并将其存储为预设,然后可以通过“样式”面板使用此预设。可以在库中存储预设样式,并在需要这些样式时通过“样式”面板载入或移去它们。

创建新预设样式

  1. 从“图层”面板中,选择包含要存储为预设的样式的图层。
  2. 执行下列操作之一:
    • 单击“样式”面板的空白区域。

    • 单击“样式”面板底部的“创建新样式”按钮。

    • 从“样式”面板菜单中选取“新建样式”。

    • 选取“图层”>“图层样式”>“混合选项”,并在“图层样式”对话框中单击“新建样式”。

  3. 输入预设样式的名称,设置样式选项,并单击“确定”。

重命名预设样式

  1. 执行下列操作之一:
    • 在“样式”面板中双击某个样式。如果“样式”面板设置为将样式显示为缩览图,则在对话框中输入新名称,并单击“确定”。否则,直接在“样式”面板中键入新名称,并按 Enter 键 (Windows) 或 Return 键 (Mac OS)。

    • 在“图层样式”对话框的“样式”区域中选择一种样式。然后从弹出式菜单中选取“重命名样式”,输入新名称,并单击“确定”。

    • 使用“形状”或“钢笔”工具时,从选项栏的“样式”弹出式面板中选择一种样式。然后从弹出式面板菜单中选取“重命名样式”。

删除预设样式

  1. 执行下列操作之一:
    • 将样式拖动到“样式”面板底部的“删除”按钮

    • 按住 Alt 键 (Windows) 或 Option 键 (Mac OS) 并单击“样式”面板中的图层样式。

    • 在“图层样式”对话框的“样式”区域中选择一种样式。(请参阅应用预设样式。) 然后从弹出式菜单中选取“删除样式”。

    • 使用“形状”或“钢笔”工具时,从选项栏的“图层样式”弹出式面板中选择一种样式。然后从弹出式面板菜单中选取“删除样式”。

将一组预设样式存储为库

  1. 执行下列操作之一:
    • 从样式面板菜单中选取“存储样式”。

    • 选择“图层样式”对话框左侧的“样式”。然后从弹出式菜单中选取“存储样式”。

    • 使用“形状”或“钢笔”工具时,单击选项栏中的图层样式缩览图。然后从弹出式面板菜单中选取“存储样式”。

  2. 为样式库选取一个位置,输入文件名,然后单击“存储”。

    可以将库存储在任何位置。但是,如果将库文件放在默认预设位置的 “预置/样式” 文件夹中,重新启动应用程序后,库名称将出现在“样式”面板菜单底部。

    注意:

    也可以使用“预设管理器”重命名、删除和存储预设样式库。

载入预设样式库

  1. 单击“样式”面板中的三角形、“图层样式”对话框或选项栏中的“图层样式”弹出式面板。
  2. 执行下列操作之一:
    • 选取“载入样式”将库添加到当前列表。然后选择想使用的库文件,并单击“载入”。

    • 选取“替换样式”,用一个不同的库替换当前列表。然后选择想使用的库文件,并单击“载入”。

    • 选取库文件(显示在面板菜单的底部)。然后单击“确定”以替换当前列表,或者单击“追加”以追加当前列表。

  3. 要返回到默认的预设样式库,请选取“复位样式”。可以替换当前列表或将默认库追加到当前列表。

    注意:

    也可以使用“预设管理器”载入和复位样式库。请参阅使用预设管理器

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略