视频 | 使用图像处理器批量处理多个文件

视频 | 使用图像处理器批量处理多个文件
了解如何使用“图像处理器”脚本,一次性准备数以百计的图像并将它们存储为不同的文件格式...
Julieanne Kost

使用图像处理器转换文件

图像处理器可以转换和处理多个文件。与“批处理”命令不同,您不必先创建动作,就可以使用图像处理器来处理文件。您可以在图像处理器中执行下列任何操作:

  • 将一组文件转换为 JPEG、PSD 或 TIFF 格式之一,或者将文件同时转换为所有三种格式。

  • 使用相同选项来处理一组相机原始数据文件。

  • 调整图像大小,使其适应指定的像素大小。

  • 嵌入颜色配置文件或将一组文件转换为 sRGB,然后将它们存储为用于 Web 的 JPEG 图像。

  • 在转换后的图像中包括版权元数据。

图像处理器可以处理 Photoshop (PSD)、JPEG 和相机原始数据文件。

  1. 请执行下列任一操作:
    • 选取“文件”>“脚本”>“图像处理器”(Photoshop)。

    • 选择“工具”>“Photoshop”>“图像处理器”(Bridge)。

  2. 选择要处理的图像。可以选择处理任何打开的文件,也可以选择处理一个文件夹中的文件。
  3. (可选)选择“打开第一个要应用设置的图像”可以对所有图像应用相同的设置。

    如果要处理一组在相同光照条件下拍摄的相机原始数据文件,可以将第一幅图像的设置调整到满意的程度,然后对其余图像应用同样的设置。

    如果文件的颜色配置文件与工作配置文件不符,请对 PSD 或 JPEG 源图像应用此选项。可以选取转换文件夹中的第一幅图像和全部图像所使用的颜色配置文件。

    注意:

    通过图像处理器应用的设置是临时性的,只能在图像处理器中使用。如果未在图像处理器中更改图像的当前“Camera Raw”设置,则使用这些设置来处理图像。

  4. 选择要存储处理后的文件的位置。

    如果多次处理相同文件并将其存储到同一目标,每个文件都将以其自己的文件名存储,而不进行覆盖。

  5. 选择要存储的文件类型和选项。

    存储为 JPEG

    将图像以 JPEG 格式存储在目标文件夹中名为 JPEG 的文件夹中。

    品质

    设置 JPEG 图像品质(0 到 12)。

    调整大小以适合

    调整图像大小,使之适合在“宽度”和“高度”中输入的尺寸。图像将保持其原始比例。

    将配置文件转换为 sRGB

    将颜色配置文件转换为 sRGB。如果要将配置文件与图像一起存储,请确保选中“包含 ICC 配置文件”。

    存储为 PSD

    将图像以 Photoshop 格式存储在目标文件夹中名为 PSD 的文件夹中。

    最大兼容

    在目标文件内存储分层图像的复合版本,以兼容无法读取分层图像的应用程序。

    存储为 TIFF

    将图像以 TIFF 格式存储在目标文件夹中名为 TIFF 的文件夹中。

    LZW 压缩

    使用 LZW 压缩方案存储 TIFF 文件。

  6. 设置其它处理选项。

    运行动作

    运行 Photoshop 动作。从第一个菜单中选取动作组,从第二个菜单中选取动作。必须在“动作”面板中载入动作组后,它们才会出现在这些菜单中。

    版权信息

    包括在文件的 IPTC 版权元数据中输入的任何文本。此处所含文本将覆盖原始文件中的版权元数据。

    包含 ICC 配置文件

    在存储的文件中嵌入颜色配置文件。

  7. 单击“运行”。

注意:

处理图像前,单击“存储”可以存储对话框中的当前设置。下次需要使用该组设置处理文件时,请单击“载入”,然后浏览到存储的图像处理器设置。

处理一批文件

“批处理”命令可以对一个文件夹中的文件运行动作。如果您有带文档输入器的数码相机或扫描仪,也可以用单个动作导入和处理多个图像。扫描仪或数码相机可能需要支持动作的取入增效工具模块。

注意:

如果第三方增效工具不能一次导入多个文档,则在批处理期间或用作动作的一部分时,该工具可能无效。有关详细信息,请与增效工具的厂商联系。

您还可以从 Acrobat Capture 或其它软件导入 PDF 图像。

当对文件进行批处理时,可以打开、关闭所有文件并存储对原文件的更改,或将修改后的文件版本存储到新的位置(原始版本保持不变)。如果您要将处理过的文件存储到新位置,则可能希望在开始批处理前先为处理过的文件创建一个新文件夹。

要使用多个动作进行批处理,请创建一个播放所有其它动作的新动作,然后使用新动作进行批处理。要批处理多个文件夹,请在一个文件夹中创建要处理的其它文件夹的别名,然后选择“包含所有子文件夹”选项。

注意:

为了提高批处理性能,应减少所存储的历史记录状态的数量,并在“历史记录”面板中取消选择“自动创建第一幅快照”选项。

批处理文件

  1. 执行下列操作之一:
    • 选取“文件”>“自动”>“批处理”(Photoshop)

    • 选取“工具”>“Photoshop”>“批处理”(Bridge)

  2. 在“组”和“动作”弹出式菜单中,指定要用来处理文件的动作。菜单会显示“动作”面板中可用的动作。如果未显示所需的动作,可能需要选取另一组或在面板中载入组。
  3. 从“源”弹出式菜单中选取要处理的文件:

    文件夹

    处理指定文件夹中的文件。单击“选取”可以查找并选择文件夹。

    导入

    处理来自数码相机、扫描仪或 PDF 文档的图像。

    打开的文件

    处理所有打开的文件。

    Bridge

    处理 Adobe Bridge 中选定的文件。如果未选择任何文件,则处理当前 Bridge 文件夹中的文件。

  4. 设置处理、存储和文件命名选项。有关“批处理”对话框设置的说明,请参阅批处理和快捷批处理选项

将嵌套文件夹中的文件批处理为不同格式

  1. 如平常那样处理文件夹,直到“目标”步骤为止。
  2. 为目标选取“存储并关闭”。可以为“覆盖动作中的‘存储为’命令”指定选项以执行下列操作:
    • 如果动作中的“存储为”步骤包含文件名,则会使用所存储文档的名称覆盖此名称;所有的“存储为”步骤均被视为在记录它们时没有使用文件名。

    • 在“存储为”动作步骤中指定的文件夹会被文档的原始文件夹覆盖。

    注意:

    动作中必须包含“存储为”步骤;“批处理”命令不会自动存储文件。

    例如,您可以使用此过程来锐化图像、调整图像大小,以及将图像以 JPEG 格式存储在其原始文件夹中。您可以创建一个具有锐化步骤、调整大小步骤以及“存储为 JPEG”步骤的动作。当对此动作执行批处理时,请选择“包含所有子文件夹”,为目标选择“存储并关闭”,然后选择“覆盖动作”中的“存储为”命令。

从动作创建快捷批处理

快捷批处理将动作应用于一个或多个图像,或应用于您将“快捷批处理”图标拖动到的图像文件夹。您可以将快捷批处理存储在桌面上或磁盘上的另一位置。

Photoshop“快捷批处理”图标
“快捷批处理”图标

动作是创建快捷批处理的基础。在创建快捷批处理前,必须在“动作”面板中创建所需的动作。(请参阅创建动作。)

  1. 选取“文件”>“自动”>“创建快捷批处理”。
  2. 指定快捷批处理的存储位置。单击对话框的“将快捷批处理存储于”部分中的“选取”,然后浏览到该位置。
  3. 选择“动作组”,然后指定打算在“组合”和“动作”菜单中使用的动作。(在打开对话框前选择“动作”面板中的动作可以预先选择这些菜单。)
  4. 设置处理、存储和文件命名选项。有关“批处理”对话框设置的说明,请参阅批处理和快捷批处理选项

有关跨平台快捷批处理的提示

当创建适用于 Windows 和 Mac OS 的快捷批处理时,请记住下列兼容性问题:

  • 在将 Windows 中创建的快捷批处理移动到 Mac OS 之后,必须将它拖动到桌面中的 Photoshop 图标上。Photoshop 将对 Mac OS 中使用的快捷批处理进行更新。

  • 在 Mac OS 中创建快捷批处理时,请使用 .exe 扩展名以使快捷批处理与 Windows 和 Mac OS 都兼容。

  • 操作系统之间不支持文件名引用。如果动作步骤(例如“打开”命令、“存储为”命令或从文件载入设置的调整命令)引用文件名或文件夹名,则执行将暂停,并提示用户输入文件名。

使用快捷批处理来处理文件

  1. 将文件或文件夹拖动到快捷批处理图标上。如果 Photoshop 尚未运行,则将启动 Photoshop。

批处理和快捷批处理选项

在“批处理”对话框和“快捷批处理”对话框中指定这些选项。

覆盖动作中的打开命令

确保在没有打开已在动作的“打开”命令中指定的文件的情况下,已处理在“批处理”命令中选定的文件。如果动作包含用于打开已存储文件的“打开”命令而您又未选择此选项,则“批处理”命令只会打开和处理用于记录此“打开”命令的文件。(这是因为在打开“批处理”源文件夹中的每个文件之后,“批处理”命令会打开动作指定的文件。由于最新打开的文件是动作中指定的文件,因此“批处理”命令将在该文件上执行动作,而不会处理“批处理”源文件夹中的任何文件。)

要使用此选项,动作必须包含“打开”命令。否则,“批处理”命令将不会打开您已选择用来进行批处理的文件。选择此选项不会忽略“打开”命令中的任何内容 -- 将只打开选择的文件。

如果记录的动作要在某个打开的文件上执行,或者动作中包含针对其所需的特定文件的“打开”命令,则取消选择此选项。

包含所有子文件夹

处理指定文件夹的子目录中的文件。

禁止颜色配置文件警告

关闭颜色方案信息的显示。

禁止显示文件打开选项对话框

隐藏“文件打开选项”对话框。当对相机原始图像文件的动作进行批处理时,这是很有用的。将使用默认设置或以前指定的设置。

目标菜单

设置用于存储已处理文件的位置

使文件保持打开而不存储更改(除非动作包括“存储”命令)。

存储并关闭

将文件存储在它们的当前位置,并覆盖原来的文件。

文件夹

将处理过的文件存储到另一位置。单击“选取”可指定目标文件夹。

覆盖动作中的存储为命令

确保将已处理的文件存储到在“批处理”命令中指定的目标文件夹中(或者如果选取“存储并关闭”,则存储到它们的原始文件夹中),并且这些文件具有其原始名称或在“批处理”对话框的“文件命名”部分指定的名称。

如果未选择此选项并且动作中包含“存储为”命令,则文件将存储到由动作中的“存储为”命令指定的文件夹,而不是存储到“批处理”命令中指定的文件夹。此外,如果未选择此选项并且动作中的“存储为”命令指定了文件名,则“批处理”命令每次处理图像时都会覆盖相同的文件(动作中指定的文件)。

注意:

如果您希望“批处理”命令使用您在该命令中指定的文件夹内的原始文件名来处理文件,可在动作中存储图像。然后,在创建批处理时,选择“覆盖动作”中的“存储为”命令,并指定目标文件夹。如果在“批处理”命令中重命名图像并且未选择“覆盖动作”中的“存储为”命令,则 Photoshop 会将已处理的图像存储两次:一次是使用新名称将其存储在指定的文件夹中;一次是使用原始名称将其存储在由动作中的“存储为”命令指定的文件夹中。

要使用此选项,动作中必须包含“存储为”命令。否则,“批处理”命令将不会存储已处理的文件。选择此选项不会跳过“存储为”命令中的任何内容 - 将只使用指定的文件名和文件夹进行存储。

注意:

某些存储选项在“批处理”命令或“创建快捷批处理”命令中不可用(例如,JPEG 压缩或 TIFF 选项)。要使用这些选项,请在包含所需选项的动作中记录一个“存储为”步骤,然后使用“覆盖动作的‘存储为’命令”选项以确保将文件存储在“批处理”命令或“创建快捷批处理”命令中指定的位置。Photoshop 会忽略在动作的“存储为”命令中指定的文件名和路径,并保留使用在“批处理”对话框中指定的新路径和文件名的存储选项。

文件命名

如果将文件写入新文件夹,请指定文件命名约定。从弹出式菜单中选择元素,或在字段中输入要组合为全部文件的默认名称的文本。可以通过这些字段,更改文件名各部分的顺序和格式。每个文件必须至少有一个唯一的字段(例如,文件名、序列号或连续字母)以防文件相互覆盖。起始序列号为所有序列号字段指定起始序列号。第一个文件的连续字母字段总是从字母“A”开始。

兼容性

使文件名与 Windows、Mac OS 和 UNIX 操作系统兼容。

注意:

使用“批处理”命令选项存储文件时,通常会用与原文件相同的格式存储文件。要创建以新格式存储文件的批处理,请在原始动作中记录“存储为”命令,后跟“关闭”命令。然后,在设置批处理时,在“目标”菜单中选择“覆盖动作”中的“存储为”命令。

错误菜单

指定处理错误的方法:

由于错误而停止

挂起进程,直到您确认了错误信息为止。

将错误记录到文件

将每个错误记录在文件中而不停止进程。如果有错误记录到文件中,则在处理完毕后将出现一条信息。要查看错误文件,请在运行“批处理”命令之后,使用文本编辑器打开它。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略