变换对象

  1. Photoshop 用户指南
  2. Photoshop 简介
    1. 有梦想,去实现
    2. Photoshop 的新增功能
    3. 编辑第一张照片
    4. 创建文档
    5. Photoshop | 常见问题
    6. Photoshop 系统要求
    7. 迁移预设、动作和设置
    8. 了解 Photoshop
  3. Photoshop 和 Adobe 服务
    1. Photoshop 和 Adobe Stock
    2. Creative Cloud Libraries
    3. Photoshop 中的 Creative Cloud Libraries
    4. 网格和参考线
    5. 创建动作
    6. 还原和历史记录
    7. 默认键盘快捷键
    8. 触摸功能和可自定义的工作区
    9. 将 Touch Bar 与 Photoshop 结合使用
    10. 在 Photoshop 中使用 Capture 应用程序内扩展
  4. Photoshop iPad 版
    1. Photoshop iPad 版 | 常见问题
    2. 了解工作区
    3. 系统要求 | Photoshop iPad 版
    4. 创建、打开和导出云文档
    5. 添加照片
    6. 处理图层
    7. 使用画笔进行绘图和绘画
    8. 建立选区并添加蒙版
    9. 修饰复合
    10. 使用调整图层
    11. 使用曲线调整复合图像的色调
    12. 应用变换操作
    13. 裁剪和旋转复合图像
    14. 旋转、平移、缩放和重置画布
    15. 使用文字图层
    16. 使用 Photoshop 和 Lightroom
    17. 在 Photoshop iPad 版中获取缺失字体
    18. Photoshop iPad 版中的日文文本
    19. 管理应用程序设置
    20. 触控快捷键和手势
    21. 键盘快捷键
    22. 系统要求 1.x | Photoshop iPad 版
    23. 系统要求 2.x | Photoshop iPad 版
    24. 编辑图像大小
    25. 在 Photoshop iPad 版上创作直播
    26. 使用修复画笔校正瑕疵
    27. 在 Capture 中创建画笔并将其用在 Photoshop 中
  5. 云文档
    1. Photoshop 云文档 |常见问题
    2. Photoshop 云文档 | 工作流程问题
    3. 在 Photoshop 中管理和使用云文档
    4. 升级 Photoshop 的云存储空间
    5. 无法创建或保存云文档
    6. 解决 Photoshop 云文档错误
    7. 收集云文档同步日志
    8. 共享访问权限并编辑您的云文档
  6. 工作区
    1. 工作区基础知识
    2. 创建文档
    3. 将 Touch Bar 与 Photoshop 结合使用
    4. Photoshop 中的 Microsoft Dial 支持
    5. 工具库
    6. 性能首选项
    7. 使用工具
    8. 触控手势
    9. 触摸功能和可自定义的工作区
    10. 技术预览
    11. 元数据和注释
    12. 快速共享您的创作
    13. 将 Photoshop 图像置入其他应用程序
    14. 首选项
    15. 默认键盘快捷键
    16. 标尺
    17. 显示或隐藏不打印的额外内容
    18. 指定图像的列
    19. 还原和历史记录
    20. 面板和菜单
    21. 置入文件
    22. 使用对齐功能定位元素
    23. 用标尺工具定位
    24. 预设
    25. 自定义键盘快捷键
    26. 网格和参考线
  7. Web、屏幕和应用程序设计
    1. Photoshop 设计功能
    2. 画板
    3. 在 Photoshop 中导出文件
    4. 设备预览
    5. 从图层拷贝 CSS
    6. 将 Web 页切片
    7. 切片的 HTML 选项
    8. 修改切片版面
    9. 使用 Web 图形
    10. 创建 Web 照片画廊
  8. 图像和颜色基础知识
    1. 如何调整图像大小
    2. 处理栅格图像和矢量图像
    3. 图像大小和分辨率
    4. 从相机和扫描仪获取图像
    5. 创建、打开和导入图像
    6. 查看图像
    7. 无效的 JPEG 标记错误 | 打开图像
    8. 查看多个图像
    9. 自定拾色器和色板
    10. 高动态范围图像
    11. 匹配图像中的颜色
    12. 在颜色模式之间转换
    13. 颜色模式
    14. 抹除图像的部分内容
    15. 混合模式
    16. 选择颜色
    17. 自定索引颜色表
    18. 图像信息
    19. 扭曲滤镜不可用
    20. 关于颜色
    21. 使用通道进行颜色和单色调整
    22. 在“颜色”和“色板”面板中选择颜色
    23. 取样
    24. 颜色模式或图像模式
    25. 色调
    26. 向动作添加条件模式更改
    27. 从 HTML、CSS 和 SVG 添加色板
    28. 位深度和首选项
  9. 图层
    1. 图层基础知识
    2. 非破坏性编辑
    3. 创建和管理图层和组
    4. 选择、编组和链接图层
    5. 将图像置入图框中
    6. 图层不透明度和混合
    7. 蒙版图层
    8. 应用智能滤镜
    9. 图层复合
    10. 移动、堆叠和锁定图层
    11. 使用矢量蒙版遮盖图层
    12. 管理图层和组
    13. 图层效果和样式
    14. 编辑图层蒙版
    15. 抽出资源
    16. 显示带有剪贴蒙版的图层
    17. 从图层生成图像资源
    18. 使用智能对象
    19. 混合模式
    20. 将多个图像组合到人像组中
    21. 使用自动混合图层组合图像
    22. 对齐和分布图层
    23. 从图层拷贝 CSS
    24. 载入图层或图层蒙版边界上的选区
    25. 显示其他图层中内容的挖空效果
    26. 图层
    27. 拼合
    28. 复合
    29. 背景
  10. 选择
    1. “选择并遮住”工作区
    2. 快速建立选区
    3. 选区快速入门
    4. 使用选框工具进行选择
    5. 使用套索工具进行选择
    6. 选择图像中的颜色范围
    7. 调整像素选区
    8. 在路径和选区边界之间转换
    9. 通道基础知识
    10. 移动、拷贝和删除选定的像素
    11. 创建临时快速蒙版
    12. 存储选区和 Alpha 通道蒙版
    13. 选择位于焦点中的图像区域
    14. 复制,拆分,和合并通道
    15. 通道计算
    16. 选区
    17. 定界框
  11. 图像调整
    1. 透视变形
    2. 减少相机抖动模糊
    3. 修复画笔示例
    4. 导出颜色查找表
    5. 调整图像锐化程度和模糊程度
    6. 了解颜色调整
    7. 应用亮度/对比度调整
    8. 调整阴影和高光细节
    9. 色阶调整
    10. 调整色相和饱和度
    11. 调整自然饱和度
    12. 调整图像区域中的颜色饱和度
    13. 快速调整色调
    14. 对图像应用特殊颜色效果
    15. 通过色彩平衡调整增强图像
    16. 高动态范围图像
    17. 查看直方图和像素值
    18. 匹配图像中的颜色
    19. 如何裁剪并拉直照片
    20. 将彩色图像转换为黑白图像
    21. 调整图层和填充图层
    22. 曲线调整
    23. 混合模式
    24. 设置用于印刷的图像目标值
    25. 使用色阶和曲线吸管工具调整颜色和色调
    26. 调整 HDR 曝光度和色调
    27. 滤镜
    28. 模糊
    29. 减淡或加深图像区域
    30. 调整可选颜色
    31. 替换对象颜色
  12. Adobe Camera Raw
    1. Camera Raw 的系统要求
    2. Camera Raw 新增功能
    3. Camera Raw 简介
    4. 创建全景图
    5. 支持的镜头
    6. Camera Raw 中的晕影、颗粒和去除薄雾效果
    7. 默认键盘快捷键
    8. Camera Raw 中的自动透视校正功能
    9. 如何在 Camera Raw 中进行非破坏性编辑
    10. Camera Raw 中的径向滤镜
    11. 管理 Camera Raw 设置
    12. 在 Camera Raw 中打开、处理和保存图像
    13. 在 Camera Raw 中使用增强型污点去除工具修复图像
    14. 旋转、裁切和调整图像
    15. 在 Camera Raw 中调整颜色显示
    16. 功能摘要 | Adobe Camera Raw | 2018 版
    17. 新增功能摘要
    18. Camera Raw 中的处理版本
    19. 在 Camera Raw 中进行局部调整
  13. 图像修复和图像恢复
    1. 通过“内容识别填充”从照片中移去对象
    2. 内容识别修补和移动
    3. 修饰和修复照片
    4. 校正图像扭曲和杂色
    5. 用于修复大多数问题的基本故障排除步骤
  14. 图像变换
    1. 变换对象
    2. 调整裁剪、旋转和画布大小
    3. 如何裁剪并拉直照片
    4. 创建并编辑全景图图像
    5. 变形图像、外形和路径
    6. 消失点
    7. 使用液化滤镜
    8. 内容识别缩放
    9. 变换图像、形状和路径
    10. 变形
    11. 变换
    12. 全景图
  15. 绘图和绘画
    1. 绘制对称图案
    2. 绘制矩形并修改描边选项
    3. 关于绘图
    4. 绘制和编辑形状
    5. 绘画工具
    6. 创建和修改画笔
    7. 混合模式
    8. 为路径添加颜色
    9. 编辑路径
    10. 使用混合器画笔绘画
    11. 画笔预设
    12. 渐变
    13. 填充和描边选区、图层和路径
    14. 用钢笔工具绘图
    15. 创建图案
    16. 使用图案生成器创建图案
    17. 管理路径
    18. 管理图案库和预设
    19. 使用绘图板绘图或绘画
    20. 创建纹理画笔
    21. 将动态元素添加到画笔中
    22. 渐变
    23. 使用“历史记录艺术画笔”绘制风格化描边
    24. 使用图案进行绘画
    25. 在多个设备上同步预设
  16. 文本
    1. 使用 OpenType SVG 字体
    2. 设置字符格式
    3. 设置段落格式
    4. 如何创建文字效果
    5. 编辑文本
    6. 行距和字距
    7. 阿拉伯语和希伯来语文字
    8. 字体
    9. 解决字体问题
    10. 亚洲文字
    11. 创建文字
    12. 使用 Photoshop 中的文字工具时发生文本引擎错误 | Windows 8
    13. 适合亚洲脚本的全球通用书写器
    14. 如何在 Photoshop 中添加和编辑文本
  17. 视频和动画
    1. Photoshop 中的视频编辑
    2. 编辑视频和动画图层
    3. 视频和动画概述
    4. 预览视频和动画
    5. 在视频图层中绘制帧
    6. 导入视频文件和图像序列
    7. 创建帧动画
    8. Creative Cloud 3D 动画(预览)
    9. 创建时间轴动画
    10. 创建视频图像
  18. 滤镜和效果
    1. 使用液化滤镜
    2. 使用模糊画廊
    3. 滤镜基础知识
    4. 滤镜效果参考
    5. 添加光照效果
    6. 使用自适应广角滤镜
    7. 使用油画滤镜
    8. 图层效果和样式
    9. 应用特定的滤镜
    10. 涂抹图像区域
  19. 存储和导出
    1. 以图形格式存储文件
    2. 在 Photoshop 中存储文件
    3. 文件格式
    4. 存储和导出视频和动画
    5. 存储 PDF 文件
    6. Digimarc 版权保护
  20. 打印
    1. 打印 3D 对象
    2. 从 Photoshop 打印
    3. 使用色彩管理进行打印
    4. 联系表和 PDF 演示文稿
    5. 以图片包版面的形式打印照片
    6. 打印专色
    7. 双色调
    8. 将图像打印到商业印刷机
    9. 改进 Photoshop 中的色彩打印
    10. 解决打印问题 | Photoshop
  21. 自动化
    1. 创建动作
    2. 创建数据驱动图形
    3. 脚本
    4. 处理一批文件
    5. 播放和管理动作
    6. 添加条件动作
    7. 关于动作和“动作”以显示“动作”面板
    8. 记录动作中的工具
    9. 向动作添加条件模式更改
    10. Photoshop 中有关增效工具和脚本的 UI 工具包
  22. 3D 和技术成像
    1. Creative Cloud 3D 动画(预览)
    2. 打印 3D 对象
    3. 3D 绘画
    4. 3D 面板增强功能 | Photoshop
    5. 基本的 3D 概念和工具
    6. 3D 渲染和存储
    7. 创建 3D 对象和动画
    8. 图像堆栈
    9. 3D 工作流程
    10. 测量
    11. DICOM 文件
    12. Photoshop 和 MATLAB
    13. 对图像中的对象计数
    14. 合并和转换 3D 对象
    15. 3D 纹理编辑
    16. 调整 HDR 曝光度和色调
    17. 3D 面板设置
  23. 色彩管理
    1. 了解色彩管理
    2. 保持颜色一致
    3. 颜色设置
    4. 使用颜色配置文件
    5. 对要联机查看的文档进行色彩管理
    6. 打印时对文档进行色彩管理
    7. 对导入的图像进行色彩管理
    8. 校样颜色

按比例缩放图层

在 Photoshop 21.0(2019 年 11 月版)中更新

现在,当变换任意图层类型时,拖动角手柄默认情况下会按比例缩放图层,这是由选项栏中处于“开”状态的保持长宽比按钮(链接图标)来指示的。要将默认的变换行为更改为不按比例缩放,只需关闭保持长宽比按钮(链接图标)即可。现在,按下 Shift 键可用作保持长宽比按钮的切换开关。如果“保持长宽比”按钮处于“开”状态,按下 Shift 键则会处于“关”状态,反之亦然。Photoshop 会记住您的最后变换行为设置(按比例或不按比例缩放),当您下一次启动 Photoshop 时,它将是您的默认变换行为。

使用选项栏中的“保持长宽比”按钮(链接图标)来选择默认的缩放行为
使用选项栏中的“保持长宽比”按钮(链接图标)来选择默认的缩放行为。

如何切换到旧版变换行为?

从菜单栏中,选取编辑 (Win)/Photoshop (Mac) > 首选项 > 常规,然后选择使用旧版自由变换

应用变换

对图像进行变换比例、旋转、斜切、伸展或变形处理。您可以向选区、整个图层、多个图层或图层蒙版应用变换。您还可以向路径、矢量形状、矢量蒙版、选区边界或 Alpha 通道应用变换。若在处理像素时进行变换,将影响图像品质。要对栅格图像应用非破坏性变换,请使用智能对象。(请参阅使用智能对象。)变换矢量形状或路径始终不会造成破坏,因为这只会更改用于生成对象的数学计算。

要进行变换,请首先选择要变换的项目,然后选取变换命令。必要时,可在处理变换之前调整参考点。在应用渐增变换之前,可以连续执行若干个操作。例如,您可以选取“缩放”并拖动手柄进行缩放,然后选取“扭曲”并拖动手柄进行扭曲。然后按 Enter 键或 Return 键以应用两种变换。

Photoshop 将使用在“首选项”对话框的“常规”区域中选定的插值方法,以便计算在变换期间添加或删除的像素的颜色值。插值设置将直接影响变换的速度和品质。默认的两次立方插值速度最慢,但产生的效果最好。

注意:

也可以使用“液化”滤镜使栅格图像变形和扭曲。

Photoshop 变换图像
变换图像

A. 原始图像 B. 翻转的图层 C. 旋转后的选区边框 D. 对象的局部被缩放 

变换子菜单命令

缩放

相对于项目的参考点(围绕其执行变换的固定点)增大或缩小项目。您可以水平、垂直或同时沿这两个方向缩放。

旋转

围绕参考点转动项目。默认情况下,此点位于对象的中心;但是,您可以将它移动到另一个位置。

斜切

垂直或水平倾斜项目。

扭曲

将项目向各个方向伸展。

透视

对项目应用单点透视。

变形

变换项目的形状。

旋转 180 度、顺时针旋转 90 度、逆时针旋转 90 度

通过指定度数,沿顺时针或逆时针方向旋转项目。

翻转

垂直或水平翻转项目。

视频教程:在 Photoshop 中处理矢量的相关提示

在这一集的“The Complete Picture”中,Julieanne 会展示有关在 Photoshop 中处理矢量的功能。

选择要变换的项目

  1. 执行下列操作之一:
    • 如果要变换整个图层,请激活该图层,并确保没有选中任何对象。
    注意:

    不能变换背景图层。要变换背景图层,请先将其转换为常规图层。

    • 要变换图层的一部分,请在“图层”面板中选择该图层,然后选择该图层上的部分图像。
    • 要变换多个图层,请在“图层”面板中执行下列两个操作之一:将多个图层链接在一起,或通过按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 并单击多个图层来选择多个图层。也可以在“图层”面板中,通过按住 Shift 键并单击,来选择多个连续的图层。(请参阅选择、编组和链接图层。)
    • 要变换图层蒙版或矢量蒙版,请取消蒙版链接并在“图层”面板中选择蒙版缩览图。
    • 要变换路径或矢量形状,请使用路径选择工具 以选择整个路径,或使用直接选择工具 以选择路径的一部分。如果选择了路径上的一个或多个点,则只变换与这些点相连的路径段。(请参阅选择路径。)
    • 要变换选区边界,请建立或载入一个选区。然后选取“选择”>“变换选区”。
    • 要变换 Alpha 通道,请在“通道”面板中选择相应的通道。

设置或移动变换的参考点

已在 Photoshop CC 2018 年 10 月版 (20.0) 中更新

所有变换都围绕一个称为参考点的固定点执行。默认情况下,这个点位于您正在变换的项目的中心。但是,您可以使用选项栏中的参考点定位符更改参考点,或者将中心点移到其它位置。

  1. 选取一个变换命令。图像上会出现外框。
  2. 默认情况下,参考点处于隐藏状态。要显示参考点 (),请选中选项栏中参考点定位符 () 旁边的复选框。

    变换对象时显示参考点。
    在选项栏中显示参考点复选框。

  3. 执行下列操作之一:
    • 在选项栏中单击参考点定位符 上的方块。每个方块表示外框上的一个点。例如,要将参考点移动到外框的左上角,请单击参考点定位符左上角的方块。
    • 在图像中出现的变换外框中,拖动参考点 。参考点可以位于您想变换的项目之外。

缩放、旋转、斜切、扭曲、应用透视或变形

您可以对所选图像应用各种变换操作,如“缩放”、“旋转”、“斜切”、“扭曲”、“透视”或“变形”。 

  1. 选择要变换的对象。
  2. 选取“编辑”>“变换”>“缩放”、“旋转”、“斜切”、“扭曲”、“透视”或“变形”。
    注意:

    如果您要变换某个形状或整个路径,“变换”菜单将变成“变换路径”菜单。如果您要变换多个路径段(而不是整个路径),则“变换”菜单将变成“变换点”菜单。

  3. (可选)在选项栏中单击参考点定位符 上的方块。
  4. 请执行下列一个或多个操作:
    使用选项栏中的“保持长宽比”按钮(链接图标)来选择默认的缩放行为
    使用选项栏中的“保持长宽比”按钮(链接图标)来选择默认的缩放行为

    • 如果您选取缩放,请拖动外框上的手柄。将鼠标放置在手柄上方时,指针会变为一个双向箭头。
      • 如果选项栏中的保持长宽比按钮(链接图标)处于“开”状态,则拖动角手柄会按比例缩放图层。
      • 如果选项栏中的保持长宽比按钮(链接图标)处于“关”状态,则拖动角手柄会不按比例缩放图层。
      • 按住 Shift 键,即可在按比例缩放与不按比例缩放之间切换。
    • 如果您选取了旋转,请将指针移到外框之外(指针变为弯曲的双向箭头),然后拖动。按 Shift 键可限制以 15 度为增量进行旋转。
    • 如果您选择了斜切,则拖动边手柄可倾斜外框。
    • 如果您选择了扭曲,则拖动角手柄可伸展外框。
    • 如果您选择了透视,则拖动角手柄可向外框应用透视。
    • 如果您选取了变形,请从选项栏中的“变形样式”弹出式菜单中选取一种变形,或者,要执行自定变形,请拖动网格内的控制点、线条或区域,以更改外框和网格的形状。
    • 对于所有类型的变换,都需要在选项栏中输入值。例如,要旋转项目,需在“旋转” 文本框中指定角度。
  5. (可选)如果需要,通过在“编辑”>“变换”子菜单中选择命令来切换到其它类型的变换。
    注意:

    当变换位图图像时(与形状或路径相对),每次提交变换时它都变得略为模糊;因此,在应用渐增变换之前执行多个命令要比分别应用每个变换更可取。

  6. (可选)如果要将图像变形,请单击选项栏中的“在自由变换和变形模式之间切换”按钮
  7. 完成上述步骤后,执行下列操作之一来提交变换:

    • 选择一个新工具。
    • 在“图层”面板中单击某个图层。(这项操作会自动提交变更,并且还会选择该图层。)
    • 在文档窗口中,单击画布区域以外的内容。
    • 在画布区域中,单击外框以外的内容。
    • 按 Enter 键 (Windows) 或 Return 键 (Mac OS);单击选项栏中的“提交”按钮 ;或者在变换选框内双击。

    要取消变换,请按 Esc 键或单击选项栏中的“取消”按钮

精确翻转或旋转

  1. 选择要变换的对象。

  2. 选取“编辑”>“变换”并从子菜单中选取下列命令之一:

    • “旋转”可在选项栏中指定角度

    • “旋转 180 度”可旋转半圈

    • “旋转 90 度(顺时针)”可顺时针旋转四分之一圈

    • “旋转 90 度(逆时针)”可逆时针旋转四分之一圈

    • “水平翻转”沿垂直轴水平翻转

    • “垂直翻转”沿水平轴垂直翻转

    注意:

    如果您要变换某个形状或整个路径,“变换”命令将变为“变换路径”命令。如果您要变换多个路径段(而不是整个路径),“变换”命令将变为“变换点”命令。

重复变换

要重复变换,请选择编辑 > 变换 > 再次

变换项目时复制该项目

要在变换项目时复制该项目,请在选择“变换”命令的同时按住 Alt 键 (Win) 或 Option 键 (Mac)。

重置智能对象变换

如果已变换智能对象,您可以通过执行下列操作之一来重置以前应用的所有变换:

  • 右键单击智能对象图层,然后选择“重置变换
  • 选择“图层”>“智能对象”>“重置变换
Adobe 徽标

登录到您的帐户