用户指南 取消(C)

使用智能对象

  1. Photoshop 用户指南
  2. Photoshop 简介
    1. 有梦想,去实现
    2. Photoshop 的新增功能
    3. 编辑第一张照片
    4. 创建文档
    5. Photoshop | 常见问题
    6. Photoshop 系统要求
    7. 了解 Photoshop
  3. Photoshop 和其他 Adobe 产品和服务
    1. 在 Photoshop 中使用 Illustrator 图稿
    2. 在 InDesign 中处理 Photoshop 文件
    3. 适用于 Photoshop 的 Substance 3D 素材
    4. 在 Photoshop 中使用 Capture 应用程序内扩展
  4. Photoshop iPad 版(在中国大陆不可用)
    1. Photoshop iPad 版 | 常见问题
    2. 了解工作区
    3. 系统要求 | Photoshop iPad 版
    4. 创建、打开和导出文档
    5. 添加照片
    6. 处理图层
    7. 使用画笔进行绘图和绘画
    8. 建立选区并添加蒙版
    9. 修饰复合
    10. 使用调整图层
    11. 使用曲线调整复合图像的色调
    12. 应用变换操作
    13. 裁剪和旋转复合图像
    14. 旋转、平移、缩放和重置画布
    15. 使用文字图层
    16. 使用 Photoshop 和 Lightroom
    17. 在 Photoshop iPad 版中获取缺失字体
    18. Photoshop iPad 版中的日文文本
    19. 管理应用程序设置
    20. 触控快捷键和手势
    21. 键盘快捷键
    22. 编辑图像大小
    23. 在 Photoshop iPad 版上创作直播
    24. 使用修复画笔校正瑕疵
    25. 在 Capture 中创建画笔并将其用在 Photoshop 中
    26. 使用 Camera Raw 文件
    27. 创建和使用智能对象
    28. 使用减淡和加深调整图像中的曝光度
  5. Photoshop Web 版(在中国大陆不可用)
    1. 常见问题
    2. 系统要求
    3. 键盘快捷键
    4. 支持的文件类型
    5. 工作区简介
    6. 打开并处理云文档
    7. 生成式 AI 功能
    8. 编辑的基本概念
    9. 快速操作
    10. 处理图层
    11. 修饰图像并去除瑕疵
    12. 快速建立选区
    13. 使用调整图层改进图像
    14. 移动、变换和裁切图像
    15. 绘制和绘图
    16. 使用文字图层
    17. 与 Web 上的任何人协作
    18. 管理应用程序设置
  6. Photoshop (Beta)(在中国大陆不可用)
    1. 开始使用 Creative Cloud Beta 版应用程序
    2. Photoshop (Beta) 桌面版
  7. 生成式 AI(在中国大陆不可用)
    1. Photoshop 中生成式 AI 的常见问题
    2. Photoshop 桌面版中的生成式填充
    3. Photoshop 桌面版中的生成式扩展
    4. Photoshop iPad 版中的生成式填充
    5. Photoshop iPad 版中的生成式扩展
    6. Photoshop iPad 版中的生成式变体
    7. Photoshop Web 版中的生成式 AI 功能
  8. 内容真实性(在中国大陆不可用)
    1. Photoshop 中的内容凭据
    2. NFT 的身份和来源
    3. 连接帐户进行创意归因
  9. 云文档(在中国大陆不可用)
    1. Photoshop 云文档 |常见问题
    2. Photoshop 云文档 | 工作流程问题
    3. 在 Photoshop 中管理和使用云文档
    4. 升级 Photoshop 的云存储空间
    5. 无法创建或保存云文档
    6. 解决 Photoshop 云文档错误
    7. 收集云文档同步日志
    8. 邀请其他人参与编辑云文档
    9. 完成文件和应用程序内注释的共享
  10. 工作区
    1. 工作区基础知识
    2. 首选项
    3. 使用 Photoshop“发现”面板加快学习速度
    4. 创建文档
    5. 置入文件
    6. 默认键盘快捷键
    7. 自定义键盘快捷键
    8. 工具库
    9. 性能首选项
    10. 使用工具
    11. 预设
    12. 网格和参考线
    13. 触控手势
    14. 将 Touch Bar 与 Photoshop 结合使用
    15. 触摸功能和可自定义的工作区
    16. 技术预览
    17. 元数据和注释
    18. 触摸功能和可自定义的工作区
    19. 将 Photoshop 图像置入其他应用程序
    20. 标尺
    21. 显示或隐藏不打印的额外内容
    22. 指定图像的列
    23. 还原和历史记录
    24. 面板和菜单
    25. 使用对齐功能定位元素
    26. 用标尺工具定位
  11. Web、屏幕和应用程序设计
    1. Photoshop 设计功能
    2. 画板
    3. 设备预览
    4. 从图层拷贝 CSS
    5. 将 Web 页切片
    6. 切片的 HTML 选项
    7. 修改切片版面
    8. 使用 Web 图形
    9. 创建 Web 照片画廊
  12. 图像和颜色基础知识
    1. 如何调整图像大小
    2. 处理栅格图像和矢量图像
    3. 图像大小和分辨率
    4. 从相机和扫描仪获取图像
    5. 创建、打开和导入图像
    6. 查看图像
    7. 无效的 JPEG 标记错误 | 打开图像
    8. 查看多个图像
    9. 自定拾色器和色板
    10. 高动态范围图像
    11. 匹配图像中的颜色
    12. 在颜色模式之间转换
    13. 颜色模式
    14. 抹除图像的部分内容
    15. 混合模式
    16. 选择颜色
    17. 自定索引颜色表
    18. 图像信息
    19. 扭曲滤镜不可用
    20. 关于颜色
    21. 使用通道进行颜色和单色调整
    22. 在“颜色”和“色板”面板中选择颜色
    23. 取样
    24. 颜色模式或图像模式
    25. 色调
    26. 向动作添加条件模式更改
    27. 从 HTML、CSS 和 SVG 添加色板
    28. 位深度和首选项
  13. 图层
    1. 图层基础知识
    2. 非破坏性编辑
    3. 创建和管理图层和组
    4. 选择、编组和链接图层
    5. 将图像置入图框中
    6. 图层不透明度和混合
    7. 蒙版图层
    8. 应用智能滤镜
    9. 图层复合
    10. 移动、堆叠和锁定图层
    11. 使用矢量蒙版遮盖图层
    12. 管理图层和组
    13. 图层效果和样式
    14. 编辑图层蒙版
    15. 抽出资源
    16. 显示带有剪贴蒙版的图层
    17. 从图层生成图像资源
    18. 使用智能对象
    19. 混合模式
    20. 将多个图像组合到人像组中
    21. 使用自动混合图层组合图像
    22. 对齐和分布图层
    23. 从图层拷贝 CSS
    24. 载入图层或图层蒙版边界上的选区
    25. 显示其他图层中内容的挖空效果
  14. 选择
    1. 选区快速入门
    2. 在复合图像中建立选区
    3. “选择并遮住”工作区
    4. 使用选框工具进行选择
    5. 使用套索工具进行选择
    6. 调整像素选区
    7. 移动、拷贝和删除选定的像素
    8. 创建临时快速蒙版
    9. 选择图像中的颜色范围
    10. 在路径和选区边界之间转换
    11. 通道基础知识
    12. 存储选区和 Alpha 通道蒙版
    13. 选择位于焦点中的图像区域
    14. 复制,拆分,和合并通道
    15. 通道计算
  15. 图像调整
    1. 替换对象颜色
    2. 透视变形
    3. 减少相机抖动模糊
    4. 修复画笔示例
    5. 导出颜色查找表
    6. 调整图像锐化程度和模糊程度
    7. 了解颜色调整
    8. 应用亮度/对比度调整
    9. 调整阴影和高光细节
    10. 色阶调整
    11. 调整色相和饱和度
    12. 调整自然饱和度
    13. 调整图像区域中的颜色饱和度
    14. 快速调整色调
    15. 对图像应用特殊颜色效果
    16. 通过色彩平衡调整增强图像
    17. 高动态范围图像
    18. 查看直方图和像素值
    19. 匹配图像中的颜色
    20. 裁剪并拉直照片
    21. 将彩色图像转换为黑白图像
    22. 调整图层和填充图层
    23. 曲线调整
    24. 混合模式
    25. 设置用于印刷的图像目标值
    26. 使用色阶和曲线吸管工具调整颜色和色调
    27. 调整 HDR 曝光度和色调
    28. 减淡或加深图像区域
    29. 调整可选颜色
  16. Adobe Camera Raw
    1. Camera Raw 的系统要求
    2. Camera Raw 新增功能
    3. Camera Raw 简介
    4. 创建全景图
    5. 支持的镜头
    6. Camera Raw 中的晕影、颗粒和去除薄雾效果
    7. 默认键盘快捷键
    8. Camera Raw 中的自动透视校正功能
    9. Camera Raw 中的径向滤镜
    10. 管理 Camera Raw 设置
    11. 在 Camera Raw 中打开、处理和保存图像
    12. 在 Camera Raw 中使用增强型污点去除工具修复图像
    13. 旋转、裁切和调整图像
    14. 在 Camera Raw 中调整颜色显示
    15. Camera Raw 中的处理版本
    16. 在 Camera Raw 中进行局部调整
  17. 图像修复和图像恢复
    1. 通过“内容识别填充”从照片中移去对象
    2. 内容识别修补和移动
    3. 修饰和修复照片
    4. 校正图像扭曲和杂色
    5. 用于修复大多数问题的基本故障排除步骤
  18. 图像增强和变换
    1. 替换图像中的天空
    2. 变换对象
    3. 调整裁剪、旋转和画布大小
    4. 如何裁剪并拉直照片
    5. 创建并编辑全景图图像
    6. 变形图像、外形和路径
    7. 消失点
    8. 内容识别缩放
    9. 变换图像、形状和路径
  19. 绘图和绘画
    1. 绘制对称图案
    2. 绘制矩形并修改描边选项
    3. 关于绘图
    4. 绘制和编辑形状
    5. 绘画工具
    6. 创建和修改画笔
    7. 混合模式
    8. 为路径添加颜色
    9. 编辑路径
    10. 使用混合器画笔绘画
    11. 画笔预设
    12. 渐变
    13. 渐变插值
    14. 填充和描边选区、图层和路径
    15. 用钢笔工具绘图
    16. 创建图案
    17. 使用图案生成器创建图案
    18. 管理路径
    19. 管理图案库和预设
    20. 使用绘图板绘图或绘画
    21. 创建纹理画笔
    22. 将动态元素添加到画笔中
    23. 渐变
    24. 使用“历史记录艺术画笔”绘制风格化描边
    25. 使用图案进行绘画
    26. 在多个设备上同步预设
    27. 迁移预设、动作和设置
  20. 文本
    1. 添加和编辑文本
    2. 统一文本引擎
    3. 使用 OpenType SVG 字体
    4. 设置字符格式
    5. 设置段落格式
    6. 如何创建文字效果
    7. 编辑文本
    8. 行距和字距
    9. 阿拉伯语和希伯来语文字
    10. 字体
    11. 解决字体问题
    12. 亚洲文字
    13. 创建文字
  21. 滤镜和效果
    1. 使用液化滤镜
    2. 使用模糊画廊
    3. 滤镜基础知识
    4. 滤镜效果参考
    5. 添加光照效果
    6. 使用自适应广角滤镜
    7. 使用油画滤镜
    8. 使用液化滤镜
    9. 图层效果和样式
    10. 应用特定的滤镜
    11. 涂抹图像区域
  22. 存储和导出
    1. 在 Photoshop 中存储文件
    2. 在 Photoshop 中导出文件
    3. 支持的文件格式
    4. 以图形格式存储文件
    5. 在 Photoshop 和 Illustrator 之间移动设计
    6. 存储和导出视频和动画
    7. 存储 PDF 文件
    8. Digimarc 版权保护
  23. 色彩管理
    1. 了解色彩管理
    2. 保持颜色一致
    3. 颜色设置
    4. 双色调
    5. 使用颜色配置文件
    6. 对要联机查看的文档进行色彩管理
    7. 打印时对文档进行色彩管理
    8. 对导入的图像进行色彩管理
    9. 校样颜色
  24. Web、屏幕和应用程序设计
    1. Photoshop 设计功能
    2. 画板
    3. 设备预览
    4. 从图层拷贝 CSS
    5. 将 Web 页切片
    6. 切片的 HTML 选项
    7. 修改切片版面
    8. 使用 Web 图形
    9. 创建 Web 照片画廊
  25. 视频和动画
    1. Photoshop 中的视频编辑
    2. 编辑视频和动画图层
    3. 视频和动画概述
    4. 预览视频和动画
    5. 在视频图层中绘制帧
    6. 导入视频文件和图像序列
    7. 创建帧动画
    8. Creative Cloud 3D 动画(预览)
    9. 创建时间轴动画
    10. 创建视频图像
  26. 打印
    1. 打印 3D 对象
    2. 从 Photoshop 打印
    3. 使用色彩管理进行打印
    4. 联系表和 PDF 演示文稿
    5. 以图片包版面的形式打印照片
    6. 打印专色
    7. 将图像打印到商业印刷机
    8. 改进 Photoshop 中的色彩打印
    9. 解决打印问题 | Photoshop
  27. 自动化
    1. 创建动作
    2. 创建数据驱动图形
    3. 脚本
    4. 处理一批文件
    5. 播放和管理动作
    6. 添加条件动作
    7. 关于动作和“动作”以显示“动作”面板
    8. 记录动作中的工具
    9. 向动作添加条件模式更改
    10. Photoshop 中有关增效工具和脚本的 UI 工具包
  28. 疑难解答
    1. 修复的问题
    2. 已知问题
    3. 优化 Photoshop 性能
    4. 基本故障诊断
    5. 对崩溃或冻结问题进行故障诊断
    6. 对程序错误进行故障诊断
    7. 对“暂存盘已满”错误进行故障诊断
    8. 对 GPU 和显卡驱动程序问题进行故障诊断
    9. 查找缺失的工具
    10. Photoshop | 围绕即将中断的 3D 功能的常见问题

了解智能对象并使用它们在 Photoshop 中执行非破坏性编辑。

Adobe Photoshop 深层链接

自己动手试一下
按照步骤操作,只需简单一步即可以智能对象的形式打开任意图像。

本文主题:

什么是智能对象

智能对象是包含栅格或矢量图像(如 Photoshop 或 Illustrator 文件)中的图像数据的图层。智能对象将保留图像的源内容及其所有原始特性,从而让您能够对图层执行非破坏性编辑。

在 Photoshop 中,您可以将图像的内容嵌入到 Photoshop 文档中。在 Photoshop 中,您还可以创建内容引自外部图像文件的链接智能对象。当源图像文件发生更改时,链接的智能对象的内容也会随之更新。

链接的智能对象与 Photoshop 文档中智能对象的重复实例截然不同。借助链接的智能对象,您可以跨多个 Photoshop 文档使用共享的源文件,这是一个广受 Web 设计人员欢迎的已经非常熟悉的概念。

智能对象的好处

可以利用智能对象执行以下操作:

  • 执行非破坏性变换。可以对图层进行缩放、旋转、斜切、扭曲、透视变换或使图层变形,而不会丢失原始图像数据或降低品质,因为变换不会影响原始数据。

  • 处理矢量数据(如 Illustrator 中的矢量图片),若不使用智能对象,这些数据在 Photoshop 中将进行栅格化。

  • 非破坏性应用滤镜。可以随时编辑应用于智能对象的滤镜。

  • 编辑一个智能对象并自动更新其所有的链接实例。

  • 应用与智能对象图层链接或未链接的图层蒙版。

  • 使用分辨率较低的占位符图像(您以后会将其替换为最终版本)尝试各种设计。

无法对智能对象图层直接执行会改变像素数据的操作(如绘画、减淡、加深或仿制),除非先将该图层转换成常规图层(将进行栅格化)。要执行会改变像素数据的操作,可以编辑智能对象的内容,在智能对象图层的上方仿制一个新图层,编辑智能对象的副本或创建新图层。

注意:

当变换已应用智能滤镜的智能对象时,Photoshop 会在执行变换时关闭滤镜效果。变换完成后,将重新应用滤镜效果。请参阅应用智能滤镜

Photoshop 智能对象的好处
“图层”面板中的常规图层和智能对象。缩览图右下角的图标表示智能对象。

Photoshop“图层”面板中的智能对象
(Photoshop)“图层”面板中的链接智能对象

创建嵌入的智能对象

可以使用以下几种方法创建嵌入的智能对象:使用“打开为智能对象”命令;置入文件 (Photoshop CS6) 或将文件作为嵌入对象置入(Photoshop 和 Photoshop CS6);从 Illustrator 粘贴数据;将一个或多个 Photoshop 图层转换为智能对象。

  1. 执行以下任意操作:
    • (Photoshop) 选择“文件”>“置入嵌入的对象”以将文件作为智能对象导入到打开的 Photoshop 文档中。
    • 选择“文件”>“打开为智能对象”,选择文件,然后单击“打开”。
    • (Photoshop CS6) 选择“文件”>“置入”以将文件作为智能对象导入到打开的 Photoshop 文档中。
    注意:

    尽管可以置入 JPEG 文件,但最好是置入 PSD、TIFF 或 PSB 文件,因为您可以添加图层、修改像素并重新存储文件,而不会造成任何损失。(要存储修改的 JPEG 文件,您需要拼合新图层并重新压缩图像,从而导致图像品质降低。)

    • 选择“图层”>“智能对象”>“转换为智能对象”以将选定图层转换为智能对象。
    • 在 Bridge 中,选择“文件”>“置入”>“在 Photoshop 中”以将文件作为智能对象导入到打开的 Photoshop 文档中。
    • 选择一个或多个图层,然后选择“图层”>“智能对象”>“转换为智能对象”。这些图层将被绑定到一个智能对象中。

    • 将 PDF 或 Adobe Illustrator 图层或对象拖动到 Photoshop 文档中。

    • 将 Illustrator 中的图片粘贴到 Photoshop 文档中,然后在“粘贴”对话框中选择“智能对象”。要获取最大的灵活性,请在 Adobe Illustrator 的“首选项”对话框的“文件处理和剪贴板”部分中启用“PDF”和“AICB(不支持透明度)”。

创建链接的智能对象

在 Photoshop 中,可以创建链接的智能对象。当源图像文件发生更改时,链接的智能对象的内容也会随之更新。对于团队或对于资产必须在设计间重复使用的情况,链接的智能对象特别有用。

请按以下步骤来创建链接的智能对象:

  1. 选择“文件”>“置入链接对象”
  2. 选择相应文件并单击“置入”。

链接的智能对象会在“图层”面板中创建并显示,并且带有链接图标 ()。

注意:

您还可以在打开的文档中,通过按住以下按键并拖放相应文件来创建链接的智能对象:

(Windows) Alt 键
(Mac OS) Option 键

要更改此默认行为,请关闭“首选项”>“常规”>“在置入时始终创建智能对象”

使用链接的智能对象缩减文件大小

因为链接的智能对象只是与外部文件存在依赖关系,而不是在所属文档中嵌入源文件,因此它们通常可以显著地缩减文件大小。尽管链接的智能对象不在所属文档中存储原始文件,但是它们仍存储着原始文件中图像数据的平铺版本和缩放版本。有时,此数据的大小可能显著大于原始文件的大小,使得文件大小缩减效果几乎可以忽略。

更新链接的智能对象

如果外部源文件在引用它的 Photoshop 文档打开时发生更改,则相关的链接的智能对象会自动更新。但是,当您打开包含不同步的链接的智能对象的 Photoshop 文档时,可以更新智能对象:

  • 右键单击链接的智能对象图层,并选择“更新修改的内容”。
  • 选择“图层”>“智能对象”>“更新修改的内容”

源图像已发生更改的链接的智能对象会在“图层”面板中突出显示:

Photoshop 不同步的链接的智能对象会在“图层”面板中突出显示
不同步的链接的智能对象会在“图层”面板中突出显示。

注意:

您可以通过选择“图层”>“智能对象”>“更新所有修改的内容”
,来更新当前 Photoshop 文档中的所有链接的智能对象。

Photoshop 缺少外部源文件的链接的智能对象会在“图层”面板中突出显示
缺少外部源文件的链接的智能对象会在“图层”面板中突出显示。

注意:

在检测链接的智能对象的更改或更新链接的智能对象时,Photoshop 只查看直接链接的文件。智能对象内部嵌套的链接不发生更新。

要解析缺少外部源的链接的智能对象,请执行以下步骤:

  1. 右键单击链接的智能对象图层图标并选择“解析断开的链接”。
  2. 导航到缺失对象的新位置。
  3. 单击“置入”。

查看链接的智能对象的属性

在“图层”面板中选择链接的智能对象图层后,选择“窗口”>“属性”

将显示以下属性:

  • 链接的智能对象的外部源文件的路径
  • 链接的智能对象的大小和位置坐标 (X, Y)

您可以直接在“属性”面板中执行以下操作:

  • 编辑外部图像文件的内容。如果需要,Photoshop 会打开能够处理源图像文件的外部应用程序。例如,如果外部源图像为 .ai 文件,则 Photoshop 会打开 Adobe Illustrator。
  • 在当前文档中嵌入链接的智能对象。

嵌入链接的智能对象

执行下列操作之一:

  • 右键单击“图层”面板中链接的智能对象图层,然后选择“嵌入链接的智能对象”。
  • 选择“图层”>“智能对象”>“嵌入链接的智能对象”
  • 在“属性”面板中,单击“嵌入”。
注意:

选择“图层”>“智能对象”>“嵌入所有链接的智能对象”,可以在 Photoshop 文档中嵌入所有链接的智能对象。

打包链接的智能对象

您可以将链接的智能对象打包到 Photoshop 文档中,以便将它们的源文件保存在计算机上的文件夹中。Photoshop 文档的副本会随源文件一起保存在文件夹中。

  1. 选择“文件”>“打包”。
  2. 选择要将源文件和 Photoshop 文档副本放置到的位置。

文档中的所有音频或视频链接的智能对象也都会被打包。

注意:

必须先保存文件,然后才能打包文件中包含的链接的智能对象。

Photoshop 如何查找链接的文件

Photoshop 始终在上次已知的相对位置查找链接的文件。如果在该位置找不到链接的文件,Photoshop 会按如下方式查找:

  • 在上次已知的绝对位置
  • 使用已保存的别名(仅限 Mac OS)
  • 在所属文档所在的文件夹中

此行为使您可以移动、复制和共享项目文件夹和文件,遇到断开链接的风险极低。

注意:

“解析缺失资源”对话框始终显示缺失源文件上次已知的绝对路径。

将嵌入的智能对象转换为链接的智能对象

您可以将嵌入的智能对象转换为链接的智能对象。转换时,应用于嵌入的智能对象的变换、滤镜和其他效果将得以保留。

执行以下操作:

  1. 选择 Photoshop 文档中嵌入的智能对象图层。
  2. 选择“图层”>“智能对象”>“转换为链接对象”
  3. 选择计算机上您希望将源文件保存到的位置。输入文件名,包括受支持的扩展名。例如,link_file.jpg。

按智能对象过滤“图层”面板

  1. 在“图层”面板中,从过滤弹出式菜单中选择“智能对象”。
Photoshop 按智能对象过滤图层
按智能对象过滤图层

  1. 单击以下图标之一:
  •     最新的链接的智能对象的过滤器
  •     不同步的链接的智能对象的过滤器
  •     缺失的链接的智能对象的过滤器
  •     嵌入的智能对象的过滤器
注意:

可以使用切换开关 () 关闭图层过滤。

复制嵌入的智能对象

  1. 在“图层”面板中,选择智能对象图层,然后执行下列操作之一:
    • 要创建链接到原始智能对象的重复智能对象,请选择“图层”>“新建”>“通过拷贝的图层”,或将智能对象图层拖动到“图层”面板底部的“创建新图层”图标。对原始智能对象所做的编辑会影响副本,而对副本所做的编辑同样也会影响原始智能对象。

    • 要创建未链接到原始智能对象的重复智能对象,请选择“图层”>“智能对象”>“通过拷贝新建智能对象”。对原始智能对象所做的编辑不会影响副本。

    一个名称与原始智能对象相同并带有“副本”后缀的新智能对象将出现在“图层”面板上。

编辑智能对象的内容

当您编辑智能对象时,来源内容会在 Photoshop(如果内容是栅格数据或相机原始数据文件)或默认处理置入格式的应用程序(例如,Adobe Illustrator 或 Adobe Acrobat)中打开。当您存储对源内容所做的更改时,Photoshop 文档中所有链接的智能对象实例中都会显示所做的编辑。

  1. 从“图层”面板中选择智能对象,然后执行下列操作之一:
    • 选择“图层”>“智能对象”>“编辑内容”。
    • 双击“图层”面板中的智能对象缩览图。
    • 在“属性”面板中,单击“编辑内容”。
  2. 单击“确定”按钮关闭该对话框。
  3. 对源内容文件进行编辑,然后选择“文件”>“存储”。

    Photoshop 会更新智能对象以反映您所做的更改。(如果看不到所做的更改,请激活包含该智能对象的 Photoshop 文档。)

替换智能对象的内容

您可以替换一个智能对象或多个链接实例中的图像数据。此功能使您能够快速更新可视设计,或将分辨率较低的占位符图像替换为最终版本。

注意:

当替换智能对象时,将保留对第一个智能对象应用的任何缩放、变形或效果。

  1. 选择智能对象,然后选择“图层”>“智能对象”>“替换内容”。
  2. 导航到要使用的文件,然后单击“置入”。
  3. 单击“确定”。

    新内容即会置入到智能对象中。

将嵌入的或链接的智能对象转换为图层

在 Photoshop 21.0(2019 年 11 月版)中引入

您可以将嵌入的或链接的智能对象直接转换回 Photoshop 文档中的组件图层。如果智能对象中有多个图层,则这些图层会被解包到“图层”面板的一个新图层组中。解包之后,包含不止一个图层的“智能对象”中的变换和智能滤镜将不会保留。 

将智能对象转换回其组件图层
将智能对象转换回其组件图层

  1. 图层面板选择“智能对象”图层。

  2. 执行以下任意操作:

    • 右键单击 (Win)/按住 Control 键单击 (Mac) 智能对象图层,然后从上下文菜单中选择转换为图层
    • 从菜单栏中,依次选取图层 > 智能对象 > 转换为图层
    • 属性面板中,单击转换为图层
    • 图层面板的选项菜单中,选取转换为图层
  3. 相关图层将会解包到图层面板的一个图层组中。

栅格化嵌入的或链接的智能对象

如果您不再需要编辑智能对象数据,则可以将智能对象的内容栅格化为常规图层。在对某个智能对象进行栅格化之后,应用于该智能对象的变换、变形和滤镜将不再可编辑。

选择智能对象,并选择“图层”>“智能对象”>“栅格化”

注意:

如果要重新创建智能对象,请重新选择其原始图层并从头开始。新智能对象将不会保留您应用于原始智能对象的变换。

导出嵌入的智能对象的内容

  1. 从“图层”面板中选择智能对象,然后选择“图层”>“智能对象”>“导出内容”。

  2. 选择存储智能对象内容的位置,然后单击“存储”。

    Photoshop 将以智能对象的原始置入格式(JPEG、AI、TIF、PDF 或其它格式)导出智能对象。如果智能对象是利用图层创建的,则以 PSB 格式将其导出。

重置智能对象变换

如果已变换智能对象,您可以通过执行下列操作之一来重置以前应用的所有变换:

  • 右键单击智能对象图层,然后选择“重置变换”
  • 选择“图层”>“智能对象”>“重置变换”

 Adobe

更快、更轻松地获得帮助

新用户?