注意:

希望了解如何调整选区?请参阅调整像素选区

移动选区

  1. 选择“移动”工具
  2. 在选区边界内移动指针,并将选区拖动到新位置。如果选择了多个区域,则在拖动时将移动所有区域。

    Photoshop 移动选区
    原来的选区(左图),和使用移动工具移动选区之后(右图)

拷贝和粘贴选区

在图像内或图像间拖动选区时,您可以使用移动工具拷贝选区,或者使用“拷贝”、“合并拷贝”、“剪切”和“粘贴”命令来拷贝和移动选区。使用移动工具进行拖动时无需使用剪贴板,因此可以节省内存。

在不同分辨率的图像之间粘贴选区或图层时,粘贴的数据将保持其像素大小。这可能会使粘贴的部分与新图像不成比例。在拷贝和粘贴图像之前,使用“图像大小”命令可以使源图像和目标图像的分辨率相同;也可以使用“自由变换”命令调整粘贴内容的大小。

注意:

根据您的色彩管理设置和与文件(或导入的数据)关联的颜色配置文件,可能会提示您指定如何处理文件(或导入的数据)中的颜色信息。

了解拷贝和粘贴命令

拷贝

拷贝现用图层上的选中区域。

合并拷贝

建立选中区域中所有可见图层的合并副本。

粘贴

将拷贝的选区粘贴到图像的另一部分中,或将其作为新图层粘贴到其他图像中。如果您有一个选区,则“粘贴”命令将拷贝的选区放到当前的选区上。如果没有现用选区,则“粘贴”命令会将拷贝的选区放到视图区域的中央。

原位粘贴

如果剪贴板包含从其他 Photoshop 文档拷贝的像素,请将选区粘贴到目标文档中与其在源文档中所处位置相同的相对位置中。

贴入或外部粘贴

将拷贝的选区粘贴到任意图像中的其他选区之中或之外。源选区粘贴到新图层,而目标选区边框将转换为图层蒙版。

拷贝选区

  1. 选择要拷贝的区域。
  2. 选取“编辑”>“拷贝”或“编辑”>“合并拷贝”。

拖动时拷贝选区

  1. 选择移动工具 ,或按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 以启动移动工具。
  2. 按住 Alt 键 (Windows) 或 Option 键 (Mac OS),并拖动要拷贝和移动的选区。

    当在图像之间拷贝时,将选区从现用图像窗口拖动到目标图像窗口。如果未选择任何内容,则将拷贝整个现有图层。在将选区拖动过另一个图像窗口时,如果可以将选区放入该窗口,则有一个边框高光显示该窗口。

    Photoshop 将选区拖动到另一个图像中
    将选区拖动到另一个图像中

在图像中创建选区的多个副本

  1. 选择移动工具 ,或按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 以启动移动工具。
  2. 拷贝选区:
    • 按住 Alt 键 (Windows) 或 Option 键 (Mac OS),并拖动选区。

    • 若要拷贝选区并以 1 像素位移副本,请按住 Alt 键或 Option 键,然后按箭头键。

    • 若要拷贝选区并以 10 像素位移副本,请按 Alt+Shift 组合键 (Windows) 或 Option+Shift 组合键 (Mac OS),然后按箭头键。

      只要按住 Alt 键或 Option 键,每按一次箭头键都会创建选区的一个副本,并将该副本从上一个副本起移动指定的距离。在这种情况下,将在相同的图层上建立副本。

将一个选区粘贴到另一个选区的里面或外面

  1. 剪切或拷贝想要粘贴的图像。
  2. 在同一图像或其他图像中,选择要进行贴入或外部粘贴的区域。

    注意:

    如果要进行外部粘贴,请选择一个小于拷贝的选区的区域。

  3. 执行以下任一操作:
    • 选择“编辑”>“选择性粘贴”>“贴入”。源选区的内容在目标选区内显示。

    • 选择“编辑”>“选择性粘贴”>“外部粘贴”。源选区的内容在目标选区周围显示。

    “贴入”或“外部粘贴”命令会向图像添加一个图层和图层蒙版。在“图层”面板中,新图层包含一个对应于粘贴选区的图层缩览图,该缩览图位于图层蒙版缩览图的旁边。图层蒙版基于贴入的选区:选区不使用蒙版(白色);图层的其余部分使用蒙版(黑色)。图层和图层蒙版之间没有链接 -- 也就是说,可以单独移动其中的每一个。

    Photoshop 使用“贴入”命令
    使用“贴入”命令

    A. 选中的窗玻璃 B. 拷贝的图像 C. 贴入命令 D. “图层”面板中的图层缩览图和图层蒙版 E. 重新调整粘贴的图像位置 
  4. 选择移动工具 ,或按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS) 以启动移动工具。然后拖动源内容,直到想要的部分被蒙版覆盖。
  5. 要指定底层图像的显示通透程度,请在“图层”面板中单击图层蒙版缩览图,选择一种绘画工具,然后编辑蒙版:
    • 若要隐藏图层下面的多一些图像,请用黑色绘制蒙版。

    • 若要显示更多的底层图像,请用白色绘制蒙版。

    • 若要部分显示底层图像,请用灰色绘制蒙版。

  6. 如果对结果满意,可以选取“图层”>“向下合并”将新图层和有下层图层的图层蒙版合并,使之成为永久性的更改。

在应用程序之间拷贝和粘贴

可以使用“剪切”、“拷贝”或“粘贴”命令从 Photoshop 中拷贝选区并将其贴入其它应用程序,或将其它应用程序中的图片贴入 Photoshop。剪切或拷贝的选区将一直保留在剪贴板上,直至您剪切或拷贝另一个选区为止。也可以通过拖放操作在 Photoshop 和 Illustrator 之间拷贝图片。

在某些情况下,剪贴板的内容会被转换为栅格图像。Photoshop 会在栅格化矢量图片时提示您。

注意:

图像以粘贴到的文件的分辨率栅格化。矢量智能对象不会栅格化。

从其它应用程序中,将 PostScript 图片粘贴到 Photoshop

  1. 在支持的应用程序中,选择图片,然后选取“编辑”>“拷贝”。
  2. 在 Photoshop 中,选择要将选区贴入到其中的图像。

  3. 选取“编辑”>“粘贴”。
  4. 在“粘贴”对话框中,从以下“粘贴为”选项中进行选择:

    智能对象

    将图片作为智能对象置入新图层。

    像素

    在粘贴图片时将其栅格化。“栅格化”将数学上定义的矢量图片转换为像素。

    路径

    将副本粘贴为“路径”面板中的一个路径。当从 Illustrator 拷贝类型时,必须先将其转换为轮廓。

    形状图层

    创建一个新的形状图层使用该路径作为矢量蒙版。

    注意:

    在从 Adobe Illustrator 拷贝图片时,Illustrator 中的默认剪贴板首选项可能会使“粘贴”对话框无法在 Photoshop 中显示。如果您希望在 Photoshop 中粘贴图片时显示“粘贴”选项,请在 Illustrator 的“首选项”对话框的“文件处理和剪贴板”区域中选择“AICB”。

  5. 如果在前一步中选取“粘贴为像素”,则可以在选项栏中选取“消除锯齿”,以便对选区边缘和周围像素之间的过渡效果进行平滑处理。

    注意:

    如果已经合并了数据并试图重新抽出栅格化数据,可以使用“修边”命令。

退出 Photoshop 时存储剪贴板内容

将 Photoshop 设置成退出后存储剪贴板上的内容,以便退出后仍然可以将内容粘贴到其它地方。

  1. 执行下列操作之一:
    • (Windows) 选取“编辑”>“首选项”>“常规”。

    • (Mac OS) 选取“Photoshop”>“首选项”>“常规”。

  2. 选择“导出剪贴板”,以便在退出 Photoshop 时将任何 Photoshop 内容存储在剪贴板上。

通过拖放操作从 Illustrator 拷贝图片

  1. 执行下列操作之一:
    • 将一个或多个 Illustrator 矢量对象拖动到在 Photoshop 中打开的图像中。这将在图像中创建矢量智能对象图层。选择“图层”>“智能对象”>“编辑内容”以在 Illustrator 中重新打开要编辑的内容。

    • 若要将矢量对象拷贝为 Photoshop 中的路径,请在从 Adobe Illustrator 拖动时按住 Ctrl 键 (Windows) 或 Command 键 (Mac OS)。

    • 要将 Photoshop 中当前选定图层的内容拷贝到 Illustrator 中,请使用移动工具以将 Photoshop 窗口中的内容拖动到打开的 Illustrator 文档中。

删除或剪切选定的像素

  1. 选取“编辑”>“清除”,或按 Backspace 键 (Windows) 或 Delete 键 (Mac OS)。要将选区剪切到剪贴板上,请选取“编辑”>“剪切”。

    删除背景图层上的选区时会将原始颜色替换为背景颜色。删除标准图层上的选区时会将原始颜色替换为图层透明度。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略